18:00:01 <smooge> #startmeeting Infrastructure (2018-04-05)
18:00:01 <zodbot> Meeting started Thu Apr  5 18:00:01 2018 UTC.  The chair is smooge. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:01 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:00:01 <zodbot> The meeting name has been set to 'infrastructure_(2018-04-05)'
18:00:01 <smooge> #meetingname infrastructure
18:00:01 <zodbot> The meeting name has been set to 'infrastructure'
18:00:01 <smooge> #topic aloha
18:00:01 <smooge> #chair smooge relrod nirik pingou puiterwijk tflink
18:00:01 <zodbot> Current chairs: nirik pingou puiterwijk relrod smooge tflink
18:00:05 <puiterwijk> hi
18:00:07 <nirik> morning
18:00:10 <aikidouke> salut
18:00:28 <smooge> hello fellow sysadmins
18:00:30 <puiterwijk> aikidouke! welcome back :)
18:00:41 <aikidouke> hey thanks! puiterwijk
18:00:46 <aikidouke> good to be back
18:00:49 <relrod> hello
18:01:02 <akrylo> Hello!
18:01:05 * cverna waves
18:01:27 <smooge> #topic New folks introductions
18:01:28 <smooge> #info This is a place where people who are interested in Fedora Infrastructure can introduce themselves
18:02:45 <smooge> hello any new people at the meeting? I saw an introduction a short while ago but not sure if they could join
18:02:53 <wesleyotugo> .hello2
18:02:54 <zodbot> wesleyotugo: wesleyotugo 'Dennis W. Otugo' <wesleyotugo@gmail.com>
18:03:01 <aikidouke> I'm not new, maybe renew?
18:03:16 <aikidouke> but I didnt send an intro email
18:03:27 <akrylo> I'm brand new, just sent my introduction a little bit ago.
18:04:03 <smooge> hi akrylo
18:04:07 <smooge> hello aikidouke
18:04:24 <aikidouke> o/ smooge
18:04:34 <akrylo> Greetings, smooge!
18:05:03 <smooge> akrylo, if it was sent in the last 2 hours, I have not finished reading it yet.. do you have anything you would like to say?
18:05:44 <nirik> welcome back aikidouke
18:05:48 <nirik> and welcome akrylo
18:05:50 <akrylo> Not a whole lot, just that I hope I can be a valuable asset to the team in the near future.
18:06:01 <smooge> thanks
18:06:27 <aikidouke> thanks nirik!
18:06:31 <smooge> ok  next up
18:06:34 <smooge> #topic announcements and information
18:06:34 <smooge> #info Infrastructure hackfest in april: https://fedoraproject.org/wiki/Infrastructure_Hackathon_2018
18:06:34 <smooge> #info Freeze is over. Release happened on Tuesday
18:06:34 <smooge> #info Mass update reboot happened last night.
18:06:35 <smooge> #info Pagure beta release on stg.pagure.io and src.stg.fp.o. Please test
18:06:58 <smooge> #info Freeze starts again in 2 weeks
18:07:49 <smooge> any other announcements?
18:08:35 <smooge> I would like to get some time next week to prioritize tickets so that we can have regular cleanups starting two weeks from now
18:09:00 <smooge> #topic Apprentice Open office minutes
18:09:00 <smooge> #info A time where apprentices may ask for help or look at problems.
18:09:10 <smooge> Any apprentice questions on tickets?
18:10:02 <aikidouke> is anyone actively working on any of the tickets related to libravatar?
18:10:52 <smooge> I am not sure. I am also not sure what the solution for them is
18:11:19 <puiterwijk> I've been playing with adding avatar support to IPA/CAIAPI
18:11:44 <puiterwijk> And I discussed with someone that in the mean time we could set up our own libravatar, but that's all I know
18:11:54 * aikidouke nods
18:11:58 <nirik> I am mixed on the idea.
18:12:06 <puiterwijk> nirik: so am I
18:12:10 <nirik> It likely means we would be stuck with it forever
18:12:13 <aikidouke> so is it going on the agenda for the infra hackathon?
18:12:15 <puiterwijk> This was just random discussion I've had with someone
18:12:33 <aikidouke> or has the discussion not gotten that far yet?
18:12:36 <nirik> aikidouke: possibly discussing it yeah...
18:12:46 <nirik> on the one hand we use it and it is nice to have.
18:12:58 <nirik> on the other we would have to maintain it forever, and we don't even know it.
18:13:35 <nirik> We did consider the idea of running a node a long while back...
18:13:40 <nirik> but no one had time to set it up
18:14:36 <smooge> aikidouke, do you have time to research how the current software would work, is written in, what its debt would be?
18:14:49 <puiterwijk> smooge: it's python
18:14:55 <puiterwijk> One of the big frameworks
18:15:03 <aikidouke> I can put some time into it smooge, yes
18:15:04 <smooge> python2 python3 python1.5?
18:15:35 <smooge> using a backend of nosql servers sitting on yaml2js databases?
18:15:44 <puiterwijk> django
18:15:50 <smooge> as I said
18:15:52 <puiterwijk> SQL
18:16:06 <puiterwijk> (not saying that setting it up is a good idea though.)
18:16:14 <puiterwijk> It's too big for what we'd need from it
18:16:20 <orc_fedo> nirik, as to stuck w it forever, it seems like a fine 'new' project for Gnome to adopt ;)
18:16:45 <orc_fedo> identity images almost make sense there
18:16:51 <nirik> well, someone could ask them... but I bet they don't want to either. ;)
18:17:02 <orc_fedo> where did dogtag go?
18:17:41 <nirik> no idea
18:17:48 * orc_fedo suspects the answer is: left chained behind the house, to starve out
18:18:15 <smooge> I believe it smolted
18:18:25 <puiterwijk> Hah
18:19:09 <aikidouke> If it's just a basic image hosting service, could we grow the function onto pagure or even badges?
18:19:34 <orc_fedo> aikidouke: there is a problem of inappropriate images slipping in
18:20:02 <relrod> Are we actively against just using gravatar? Libravatar falls back to gravatar anyway (when the fallback works). And we use github for some stuff, so the "but it's not FOSS argument" feels somewhat loose to me.
18:20:05 <nirik> There are also places we use them that people don't have or want a fedora account.
18:20:20 * aikidouke nods
18:20:32 <orc_fedo> gravatar has some EULA and privacy concerns
18:21:03 <smooge> aikidouke, we could do a lot of things.. but it will be a question of what can we adequetely support. I think the first thing I would like to know is what the current tool delivers, what it would require to run, and then why is it needed
18:21:05 <nirik> relrod: well, with github it's more 'up to the people doing the work where they would like to do that work with what tools' where gravatar is all in mixed with our apps and end users have to use whatever we force on them
18:21:27 <smooge> after that policies and headaches and problems would be a sort of summary chapter
18:21:30 <nirik> but yeah, we could at least short term fall back to gravatar
18:22:00 <aikidouke> smooge: if you want to give that bit to me as an AI, I will send an email to the list before the next meeting at least
18:22:10 <nirik> huh, it's a lot smaller than I thought
18:22:17 <smooge> AI?
18:22:24 <aikidouke> action item, sorry
18:22:25 <nirik> #info https://wiki.libravatar.org/shutdown-coordination/
18:23:17 <smooge> #action aikidouke will research libravatar the software resources needed and present to the group next meeting
18:23:22 <tibbs> Wow, that's very, very little real traffic.
18:23:29 <nirik> we could run that on a cloud instance without too much trouble... or better! give a cloud instance to people who want to manage it. ;)
18:23:46 <nirik> yeah, and almost no avatars.
18:23:51 <nirik> I guess it wasn't that popular.
18:24:12 <smooge> I have the feeling that we are seeing a tail end thing
18:25:09 <smooge> Any other apprentice questions?
18:25:51 <smooge> #topic Next Meeting and Agenda
18:26:23 <smooge> So next week most of the core Infrastructure will be hideyholed at a school working on FAD items
18:26:40 <nirik> yeah, we should skip next week
18:26:49 <smooge> I was thinking of skipping next weeks meeting and then put the week after to be a report meeting
18:26:58 <nirik> sounds good. +1
18:27:07 <smooge> any against?
18:28:10 <puiterwijk> I'm against not skipping, does that count?
18:28:46 <smooge> #info No meeting next week. Week after will be report back meeting
18:29:05 <smooge> #info Next meeting will be 2018-04-19 1800 UTC
18:29:15 <smooge> #topic Open Floor
18:29:32 <smooge> Anything for the open floor at the moment?
18:30:30 <smooge> to answer the question... orc_fedo http://www.dogtagpki.org/wiki/PKI_Main_Page
18:30:54 <smooge> Ok with that.. I am going to say goodnight gracie
18:31:04 <smooge> Thank you all for coming
18:31:05 <puiterwijk> Thanks for chairing, smooge
18:31:06 <smooge> #endmeeting