16:30:33 <nirik> #startmeeting IRC Support SIG (2010-02-11)
16:30:33 <nirik> #meetingname irc-support-sig
16:30:33 <zodbot> Meeting started Thu Feb 11 16:30:33 2010 UTC.  The chair is nirik. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:30:33 <nirik> #topic init process
16:30:35 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:30:38 <zodbot> The meeting name has been set to 'irc-support-sig'
16:30:50 <DiscordianUK> Good afternoon
16:31:40 * Southern_Gentlem 
16:32:58 <EvilBob> Good Morning Tokyo!
16:33:02 * nirik will wait another min or two for folks to wander in.
16:34:15 <nirik> ok, guess we are it. ;)
16:34:32 <nirik> #topic channel modes / #fedora-unregistered setup
16:34:41 <nirik> So, we deffered this from last week.
16:34:56 <nirik> Does anyone think we should change the setup? Or leave it as it is now?
16:35:16 <Southern_Gentlem> leave it at least till march 1st
16:35:18 <nirik> #info currently unregistered users are sent to #fedora-unregistered and not to the main #fedora channel
16:35:30 <nirik> why march 1st?
16:35:56 <Southern_Gentlem> that gives freenode a month to deal with the spambots
16:36:20 <Southern_Gentlem> (side note i perfer if we left it that way but i know it aint going to happen)
16:36:24 <nirik> well, I don't think spammers will ever go away completely.
16:36:36 <nirik> why not?
16:37:05 <Southern_Gentlem> the advisory board has asked in the past to be open
16:37:07 <mharris> nirik: Better suggestion.  Have all users redirected to #fedora-unregistered and given a URL to study.  After reading the webpages a web based quiz is given.  If they pass the quiz with 95% or higher they are given a token which they can pass to an IRC bot to be allowed entry into the channel, which is tied to their freenode account. ;)
16:37:09 <EvilBob> I say leave it as it is NOW
16:37:40 <nirik> Southern_Gentlem: if we feel this is the best setup, I was going to talk to the Board about leaving it this way.
16:37:46 <EvilBob> Southern_Gentlem: they have been over ruled by the IRC Support SIG
16:37:47 * hiemanshu is late
16:37:49 <mharris> nirik: +1
16:37:57 <nirik> mharris: har.
16:38:07 <Southern_Gentlem> +1 for that nirik
16:38:13 <DiscordianUK> Does anyone ever talk in -unreg?
16:38:25 <EvilBob> DiscordianUK: very few
16:38:30 * nirik notes registering on freenode is not more difficult than signing up for a mailing list or making a forum account.
16:38:34 <EvilBob> DiscordianUK: maybe two a day
16:38:36 <DiscordianUK> Indeed
16:38:47 <Southern_Gentlem> DiscordianUK,  if they do i point them at topic
16:38:53 <mharris> Put a bot in #fedora-unregistered that auto repeats the same message every 5 minutes.
16:38:54 <DiscordianUK> Then I'd agree with leaving it the way it is
16:39:03 <EvilBob> DiscordianUK: and those are the ones that have not seen the message from the bot yet
16:39:12 <EvilBob> mharris: done
16:39:16 <nirik> mharris: already done. ;)
16:39:20 <EvilBob> mharris: it is there already
16:39:21 <mharris> That will:  1) Inform people what they need to do to get into #fedora.   2) Annoy people who stick around indefinitely enough that they will either do #1 or take a hike.
16:39:33 <EvilBob> mharris: Go to your corner
16:39:35 <nirik> it's currently every 10min.
16:39:35 <EvilBob> LOL
16:39:37 <mharris> every 5 minutes?
16:39:39 <mharris> ah
16:39:48 <Southern_Gentlem> every 10 min but close enough
16:39:49 <mharris> so you went soft on them...
16:39:56 <nirik> we could move to 5min...
16:40:01 <DiscordianUK> It annoys me whenever Iook in there
16:40:01 <mharris> +1
16:40:03 <mharris> :)
16:40:05 * nirik shrugs
16:40:27 <EvilBob> I reminds me to check the channel for lost puppies
16:40:28 <nirik> anyhow, anyone object to the current setup or think we can do things any better a different way?
16:40:37 <mock> EvilBob: lol
16:40:42 <mharris> wow, 137 people in there.
16:40:47 <EvilBob> s/I/It
16:40:54 <Southern_Gentlem> mharris, if they can figure it out in 10 minutes do you want them in the channel
16:40:55 <DiscordianUK> It does seem to have raised the S/N level in the main channel
16:41:33 <EvilBob> Lowered?
16:41:34 <Khaytsus> I haven't been in the unred channel for about a week, I suppose we should watch it, although I generally just tell people they won't get suport and to read the topic
16:41:41 <mharris> autoboot people who are in #fedora-unregistered longer than 2 days non-stop
16:41:50 <Khaytsus> EvilBob: Raised :P  Less noise.
16:41:59 <EvilBob> Yes
16:42:18 <nirik> there are a number of folks in there that are registered too... ie, they got there, registered and then didn't close the channel.
16:42:38 <mock> does the bot send a direct message to those when they land in there?
16:42:45 <mharris> nirik: I've had that happen on ircd reconnect sometimes while I'm sleeping or something
16:42:50 <EvilBob> nirik: right or misconfigured clients
16:42:56 <mock> or just a general one?
16:43:00 <Khaytsus> It isn't perfect, such as clients who sometimes are late or don't register randomly, I myself sometimes have it happen..  I don't reconnect often either.
16:43:07 <nirik> mock: not currently. I think I can make it do so if we think it would be better that way.
16:43:35 <mharris> put some spambots in there
16:43:40 <DiscordianUK> I think the auto-kick after a period is a good idea
16:43:42 <mock> it might, in case the don't bother to read general messages
16:43:48 <Khaytsus> Often such channels are moderated anyway so nobody can talk, but I don't necessarily suggest we do that
16:43:58 <mock> might get their attention
16:44:07 <Khaytsus> Do we have a join message on that channel?  That might help if we don't.
16:44:09 <nirik> mharris: we did have a floodbot last week... 150+ joins and spam spew.
16:44:13 <nirik> Khaytsus: we do.
16:44:18 <Khaytsus> :)
16:44:19 <mharris> An IRC <-> Dr. Sbaitso gateway would be nice to have in there.
16:45:17 <EvilBob> Topic, Join, BotBlab, if they don't get it they never will
16:45:23 <nirik> anyhow, I think this protects the folks in #fedora from trolls/drive bys/spambots that would otherwise bother them, and think it's a small inconvinence to register...
16:45:38 <EvilBob> nirik: I agree
16:45:39 <Sonar_Guy> nirik: +1 keep it as is
16:45:45 <nirik> I can switch it to blabing in PM on join I think if we would like to do that.
16:45:46 <mharris> " Sorry for the trouble."  I'd remove that from the bot message.  There's no reason to be sorry.
16:45:51 <EvilBob> +1 keep it as is
16:45:53 <nirik> (or in addition to the main channel blab)
16:46:03 <Khaytsus> nirik: Nah, it babbling in the channel is fine, it's *not* a channel for chatting :)
16:46:13 <EvilBob> nirik: No, I don't think it is needed
16:46:35 <mharris> +1 as well
16:46:40 <nirik> ok, sounds like no big disagreements...
16:46:49 <mock> nirik: well, i wasn't thinking pm, but just directly addressing them in the channel
16:46:52 <nirik> let me take it to the board list and see if they are all happy with it.
16:47:05 <nirik> mock: I think it can do that too... would have to look tho.
16:47:10 <nirik> mock: you mean by nick?
16:47:17 <Southern_Gentlem> if not they can come run the channel
16:47:28 <mock> nirik: yes
16:47:30 <nirik> unregistereduser: you just join #fedora-unregistered, please register.
16:47:52 <EvilBob> Spamming per join is going to get annyone and flood the bot potentially on a split
16:48:17 <Khaytsus> To me the only real alternative is to autovoice in #fedora those who are registered and moderate it....  but that's noisy(flags) and join spam can still go on.
16:48:21 <EvilBob> s/annyone/annoying
16:48:24 <nirik> EvilBob: the Hearld plugin has support to detect net splits and throttle. ;)
16:48:53 <EvilBob> nirik: still don't think it is needed
16:49:06 <nirik> yeah, me either, but it's there if we want it.
16:49:10 <mharris> <fedbot> You have been redirected to this channel (#fedora-unregistered) because you ... ... please see http://freenode.net/faq.shtml#identify.  Sucks to be you.
16:49:20 <Khaytsus> Although perhaps every few weeks we should remove the r flag and see if the spam is still ongoing.  If we see it again, +r for another two weeks
16:49:45 <EvilBob> I stand with my vote
16:49:47 <nirik> well, I think it's gone down a lot at least.
16:49:48 <mharris> Khaytsus: why inconvenience ops and people who know how to join properly though?
16:49:58 <EvilBob> no change is good change in this case
16:50:14 <mharris> IMHO, changing back in forth is simply indecision
16:50:23 <nirik> #action Nirik will communicate to the Board the current setup for feedback.
16:50:24 <Khaytsus> mharris: A bot could autovoice users upon joining who are registered
16:50:25 <mharris> Which is more confusing to people than anything.
16:50:33 <nirik> mharris: yeah.
16:50:35 * mock looks at the dead horse in the channel
16:50:44 <nirik> #topic Weekly Stats / review
16:50:45 <Khaytsus> mock: Bear Grills would eat it
16:50:55 <nirik> http://fedora.theglaserfamily.org/ircstats/fedora-weekly.html
16:51:02 <nirik> a somewhat more busy week.
16:51:07 <mharris> Khaytsus: sure, you can do all sorts of complex things, but does it actually buy anything valuable?
16:51:18 <mharris> Or does it just change confusion to a new level?
16:51:20 <nirik> anyone have anything they would like to note from the previous week? problems increasing? links?
16:51:32 <Khaytsus> mharris: Yeah, it's swapping one annoyance for another.
16:51:48 <mharris> Khaytsus: you're not a Facebook employee are you? ;)
16:52:02 <Sonar_Guy> lol
16:52:13 <Khaytsus> mharris: No, but I hear they have good consultants when it comes to random changing.
16:52:25 <mharris> yeah :)
16:52:26 <nirik> There have been a number of requests for the 'remove packages added as deps'... I"m not sure why.
16:52:46 <Khaytsus> nirik: ie:  Undo what yum install package did?
16:53:00 <Khaytsus> Remove with leaves does that, or am I wrong?
16:53:07 <Khaytsus> It also does other nasty bits too if you're not careful.
16:53:28 <nirik> right. The best way IMHO is yum history
16:53:31 <Khaytsus> Does yum history allow such things?  I haven't played with it much.
16:54:26 <nirik> yep.
16:54:30 <nirik> yum history undo N
16:54:44 <Khaytsus> k, maybe we should write a guide on that in case it's not clear?
16:55:05 <nirik> Anyhow, I don't see much else outstanding this last week. We didn't even see much fallout from the dnssec-conf woes... of course those people may have been unable to reach irc. ;)
16:55:24 <nirik> if you like. It would be fine for the fedora wiki I would think...
16:55:33 <Khaytsus> Well darn, that's easy
16:55:46 <mharris> nirik: does fedbot keep stats for # of users in #fedora versus #fedora-unregistered over time to measure success rates?
16:55:49 <Khaytsus> yum history, identify transaction id, yum info id to make sure, yum undo id
16:55:59 <Khaytsus> Just tried it here, easy peasy
16:56:22 <nirik> mharris: it has a channel stats, but it doesn't keep stuff over time I don't think.
16:56:26 <nirik> @channelstats #fedora
16:56:26 <fedbot> nirik: On #fedora there have been 139417 messages, containing 5696725 characters, 997093 words, 3678 smileys, and 5172 frowns; 1819 of those messages were ACTIONs.  There have been 33410 joins, 2820 parts, 30924 quits, 84 kicks, 257 mode changes, and 1 topic change.  There are currently 403 users and the channel has peaked at 609 users.
16:56:29 <mharris> Might be beneficial to change the message to the actual instructions to register and identify
16:56:31 <nirik> @channelstats #fedora-unregistered
16:56:31 <fedbot> nirik: On #fedora-unregistered there have been 32414 messages, containing 1493805 characters, 211477 words, 96 smileys, and 6726 frowns; 69 of those messages were ACTIONs.  There have been 16851 joins, 6609 parts, 9991 quits, 91 kicks, 355 mode changes, and 4 topic changes.  There are currently 135 users and the channel has peaked at 261 users.
16:56:57 <Khaytsus> Now, can yum history get your dog back, your wife back, your truck back..
16:56:57 <nirik> mharris: yeah, not sure if they will fit, be we could try.
16:57:11 <mharris> multiple lines :)
16:57:53 <EvilBob> can we just ban people that make it to -unreg so they never get in to #fedora?
16:58:23 <mharris> LOL
16:58:36 <nirik> #topic Open Floor
16:59:03 <nirik> I think it might be fun to clear out unregistered once a cycle like we do with the ban lists... just kick everyone from channel.
16:59:16 <nirik> anyhow, anything else anyone has for open floor?
16:59:22 <nirik> things we can do to improve?
16:59:37 <mharris> nirik: every 6 months or so?  Sounds reasonable
16:59:48 <hiemanshu> nirik: Free Bacon :)
17:00:09 <mharris> or by "cycle" did you mean WRT line voltage oscillation? :)
17:00:17 <nirik> mharris: yeah, I think we did it after beta release each fedora cycle or something.
17:00:26 <mharris> 60Hz /kickall might flood the ircd :)
17:00:36 <EvilBob> I might have something but I don't think I can talk about it in a Politically Correct way, it will have to wait.
17:01:12 <nirik> mharris: the chanserv 'clear' command is nifty. ;)
17:01:13 <mharris> EvilBob: you tease!
17:01:32 <Sonar_Guy> EvilBob: just say it I already know I am an asshole!! ;^)
17:01:56 <nirik> http://t0x.in/ircfreenode.html#cs16
17:02:04 <nirik> EvilBob: ok. ;)
17:02:14 <nirik> alright, I will close out the meeting in a few here if nothing else comes up.
17:03:15 <nirik> Thanks for coming everyone!
17:03:21 <nirik> #endmeeting