16:00:35 <nirik> #startmeeting IRC Support SIG (2010-03-25)
16:00:35 <zodbot> Meeting started Thu Mar 25 16:00:35 2010 UTC.  The chair is nirik. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:35 <nirik> #meetingname irc-support-sig
16:00:35 <nirik> #topic init process
16:00:35 <nirik> Who all is around for the meeting?
16:00:36 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:40 <zodbot> The meeting name has been set to 'irc-support-sig'
16:01:04 * Southern_Gentlem 
16:01:53 * EvilBob 
16:02:25 * zcat 
16:02:33 <Khaytsus> I should put these on the calendar..
16:02:51 <fenrus02> for some reason, this one fell off mine
16:03:02 <EvilBob> fenrus02: time change?
16:03:04 <fenrus02> dst change i think
16:03:12 <fenrus02> EvilBob, *nod*
16:03:31 <nirik> yeah, we moved to this new time and DST at the same time.
16:03:31 <fenrus02> EvilBob, except that it moved by 30mins instead of an hour?
16:03:36 <Khaytsus> I tend to schedule meetings recurring until 12/31, I sometimes "lose" meetings that way :)
16:03:40 <nirik> so extra confusion. ;)
16:03:41 <EvilBob> fenrus02: yup
16:04:09 <nirik> So, I am going to try something a bit different this time... in this init process topic, I will gather any agenda items people have...
16:04:13 <EvilBob> fenrus02: we decided to meet in the middle at the top of the hour rather than on a half hour
16:04:18 <nirik> anyone have items for the agenda?
16:05:01 <EvilBob> we need a clear SOP for dealing with errors in judgment
16:05:03 <Southern_Gentlem> nothing other than what has been going on in the ops channel for that last couple of days
16:05:15 <nirik> yeah, ok... will add an item for that.
16:05:19 <Khaytsus> Opening up #fedora for F13 questions 4/6?  Beta still scheduled for that time..
16:05:20 <nirik> anything else?
16:05:30 * Sonar_Guy is here
16:05:36 <EvilBob> Closing #fedora to PPC questions
16:05:41 <nirik> Khaytsus: ok, will add that.
16:05:41 <Khaytsus> +1
16:05:43 <nirik> EvilBob: ha.
16:05:45 <zcat> +1
16:05:52 <Khaytsus> EvilBob: Doesn't mean Doug will go away
16:05:52 <EvilBob> Oops did I say that out loud?
16:06:03 <EvilBob> Khaytsus: Oh we had another last night
16:06:19 <Southern_Gentlem> 4/15 clearing banlist and remove registered restriction on #fedora
16:06:29 <nirik> Southern_Gentlem: ok. added.
16:06:40 <nirik> anything else for agenda? or shall we get started?
16:07:18 <EvilBob> Let it roll I think
16:07:25 <nirik> ok, cool.
16:07:30 <nirik> #topic Week in Review
16:07:35 <nirik> usual week in review.
16:07:40 <nirik> @channelstats #fedora
16:07:40 <fedbot> nirik: On #fedora there have been 274896 messages, containing 11500544 characters, 2017418 words, 7110 smileys, and 9746 frowns; 3687 of those messages were ACTIONs.  There have been 60706 joins, 4899 parts, 56104 quits, 151 kicks, 444 mode changes, and 9 topic changes.  There are currently 384 users and the channel has peaked at 609 users.
16:07:48 <nirik> http://fedora.theglaserfamily.org/ircstats/fedora-weekly.html
16:07:59 <nirik> anything anyone would like to shout out from the last week?
16:08:04 <Khaytsus> You can tell I've been overworked
16:08:54 <DiscordianUK> Sorry I'm late
16:09:21 <nirik> no worries.
16:09:26 <Southern_Gentlem> yeah i need to post the re-spin url more lol
16:09:30 <nirik> ok, pretty typical week from my view.
16:09:58 <fenrus02> DiscordianUK, you missed the topic-call.  Do you have any items you would like to add to the adjenda today?
16:10:14 <DiscordianUK> I have nothing additional
16:10:17 <DiscordianUK> thanks
16:10:18 <fenrus02> Southern_Gentlem, tell fedbot to spam it on schedule?
16:10:29 <Southern_Gentlem> rather not
16:10:44 <nirik> ok, shall we move on?
16:10:44 <fenrus02> agenda even.  sheesh.  i cannto typo
16:10:50 <Southern_Gentlem> yep
16:10:57 <nirik> #topic Ban Policies
16:11:25 <nirik> we never I think approved any formal policies for bans...
16:11:37 <nirik> basically they have been at the descetion of any op
16:11:45 * nirik can't spell
16:11:51 <nirik> We do have: https://fedoraproject.org/wiki/IRC_operators_code_of_conduct
16:12:17 <nirik> which we never really agreed on and used.
16:12:28 <EvilBob> I think that userA should never be banned for something that happened out of channel such as in a privmsg to userB or in another channel.
16:12:29 <zcat> I pretty much only ban for flood/trolling; others ban more for behavior/language
16:12:55 <fenrus02> nirik, add a link to freenode's page as well.
16:13:18 <nirik> there are notable things there we don't do... like mail an excerpt whenever a ban is done.
16:13:23 <fenrus02> nirik, any violation of freenode policy should not be allowed in any public channel (should go without saying, but likely should be reiterated)
16:13:26 <nirik> or keep track of what # offence something is.
16:13:48 <EvilBob> A preventative strike might be justified if "groupA" in #other channel plans a coordinated disruption.
16:14:52 <fenrus02> EvilBob, like game-spam you mean?  (also a violation of freenode policy)
16:14:53 <nirik> so, do we want to try and clean up these and enforce/agree to them?
16:15:14 <Southern_Gentlem> nirik,  i really do not approve of "bans by logs"
16:15:14 <nirik> do we want to require a email on each ban to a list?
16:15:26 <Southern_Gentlem> not really
16:15:43 <EvilBob> fenrus02: we have seen before a couple buddies come in to just team troll
16:15:57 <fenrus02> EvilBob, ah
16:16:17 <nirik> ok, so what do we want to do here? adjust this and agree/aprove it?
16:16:24 <nirik> and who will do the adjusting? ;)
16:16:41 <Southern_Gentlem> nirik,  what i would like to see is **tag** in the channels so we can find the bans in the logs easy
16:16:43 <Khaytsus> In calculus we were taught to think the extremees then figure out the middle..  If someone spams zero horrendous disgusting videos in PM to everyone in a given channel, no problem.  If they do it to every person in the channel is it a problem?  Where does it become not a problem?
16:17:01 <DiscordianUK> indeed
16:17:13 <EvilBob> I think we could all adjust using a paste to fpaste, then merge the ideas
16:17:19 <fenrus02> it becomes a problem that an op should handle when it becomes public.
16:17:31 <nirik> EvilBob: now in meeting? I suspect that will take a while...
16:17:39 <DiscordianUK> A ban is required when someone crosses *the* line but that line needs to be demarcated
16:18:16 <EvilBob> nirik: no in our free time we adjust on our own or a small group outside of the meeting, then perhaps a "hash it out" meeting
16:18:17 <nirik> I think we need to keep in mind scope here... PM's are out of our scope I think... unless they are direct to the op.
16:18:39 <nirik> if someone spams pm's to a channel, talk to #freenode ?
16:19:05 <EvilBob> freenode will kline as needed
16:20:03 <fenrus02> privmsg abuse should be handled in #freenode.  not by channel ops.
16:20:39 <Sonar_Guy> fenrus02: agreed
16:20:39 <nirik> ok, so how about: everyone adjust the wiki page over the next week... add/remove/edit whatever... if there are conflicts we can hash those out next week?
16:21:17 <EvilBob> editing eachothers works is a pain
16:21:27 <nirik> it can be...
16:21:47 <nirik> or if you want to make big changes, make your own doc/proposal.
16:21:53 <EvilBob> I still think copying the content, edit on your own in editor of your choice
16:22:14 <EvilBob> then work with others to get a sane proposal
16:22:53 <nirik> ok, fine with me.
16:23:44 <nirik> #agreed will work on https://fedoraproject.org/wiki/IRC_operators_code_of_conduct and get a policy we can agree to and enforce.
16:24:01 <nirik> #topic F13 questions in channel
16:24:15 <nirik> currently we are shunting f13 questions off to #fedora-qa
16:24:23 <nirik> Do we want to start taking them at Beta?
16:24:26 <EvilBob> We have had a policy about this in the past
16:24:51 <DiscordianUK> I think with F12 we started accepting them at Beta
16:25:10 <nirik> yeah, I think it was at Beta.
16:25:13 <fenrus02> after the beta is actually announced/available - and the user in question installed with it.
16:25:19 <EvilBob> If you can answer the question, cool, if someone else can, also cool. no hunting trips for hours on end trying to find a solution that is available in -qa
16:25:23 <fenrus02> otherwise, no point assisting with tc1 or whatnot
16:25:52 <DiscordianUK> Yes when the beta is generally released would be my thought
16:26:11 <EvilBob> snipe hunts are a pain for everyone
16:26:28 <nirik> yeah.
16:26:34 <EvilBob> "oh did you hear that bug, it's over there." "no it's over here"
16:26:36 <nirik> ok, no objections to that then?
16:27:10 <zcat> nope
16:27:12 <Khaytsus> Okay, that's how i remembered how we handled it in the past, sounds good to me :)
16:27:33 <Khaytsus> I wish I had more time to play with the betas, been swamped, but we'll see
16:27:39 <nirik> #agreed Will start taking F13 questions in #fedora after Beta is announced.
16:27:59 <nirik> #topic 2010-04-15 clean up day
16:28:00 <zcat> Khaytsus, apparently the TC1 refused to install on SSDs for some people...
16:28:08 <Khaytsus> zcat: I'm not that fancy ;)
16:28:19 <EvilBob> I disagree with changing the channel mode part of the suggestion
16:28:43 <Sonar_Guy> EvilBob: +1
16:28:51 <nirik> So, a proposal: on 4/15 we clean out ban lists (as we have done other cycles) and remove the redirect/ban on nonregistered and clear #fedora-unregistered
16:28:53 <EvilBob> flushing the ban list I am OK with
16:29:22 <DiscordianUK> I'd concur with flushing the ban list
16:29:22 <zcat> yep. i bet the fecalpheliac will be back soon after though.
16:29:36 <zcat> flushing...
16:29:49 <Khaytsus> nirik: If we do remove +r and # number of days down the road the spam comes back, what should we say is the policy?  +r for 3 months after each?
16:29:51 <nirik> yeah, I am on the fence about the non registered. I think it is still usefull.
16:29:53 <EvilBob> we deal with crap all the time
16:30:09 <fenrus02> hm.  i have actually enjoyed having unreg around ... keeps #fedora much more sane
16:30:14 <Khaytsus> zcat: Look for his ban(s) and keep 'em handy perahps
16:30:19 <Sonar_Guy> Keep the +r but flush the ban list
16:30:42 <EvilBob> fenrus02: +1
16:30:55 <EvilBob> less drive by noise
16:31:15 <Khaytsus> I think I am inclinded to agree though, +r does enforce some sort of level of sense...
16:31:19 <nirik> we could also: remove the redirect, clear #fedora-unregistered so all those people with autojoin get into channel, then put the redirect back... ie, just move some people around. Perhaps they would decide that registering is worth their while?
16:31:21 <fenrus02> empty the ban list, sure.  we've done that every release
16:31:25 <Southern_Gentlem> the +r does seem to be a good "i can follow directions test"
16:31:38 <Khaytsus> Southern_Gentlem: +1
16:31:47 <Khaytsus> I tried to say that and failed.
16:31:48 <Khaytsus> heh
16:31:57 <DiscordianUK> I'm for keeping the +r
16:32:28 <fenrus02> flush -unreg .. sure ... but dont let them babble in #fedora if they cannot be arsed to register.
16:32:54 <EvilBob> Flush the list, the channels also as an option, keep the mode.
16:33:31 <EvilBob> If we flush one channel, we should flush both IMO
16:33:35 <nirik> ok, so sounds like flush the ban list is good for everyone
16:33:42 <EvilBob> banlists in both also
16:33:56 <nirik> but folks think we should just leave the redirect and unregistered alone?
16:33:58 <fenrus02> EvilBob, += -social
16:33:59 <Sonar_Guy> EvilBob: +1 both need to be flushed
16:34:11 <Sonar_Guy> nirik: +1
16:34:20 <EvilBob> nirik: +1
16:34:42 <DiscordianUK> +1
16:34:43 <EvilBob> fenrus02: not really many there, most are set by the bot
16:35:12 <EvilBob> fenrus02: as a result they get removed on their own, I check it from time to time for those that get missed
16:35:15 <fenrus02> EvilBob, sure, but as long as we're flushing bans - clean them all out to prevent the "incident" that occurred in the past
16:35:40 <fenrus02> EvilBob, oh, if you're already monitoring the list then the end result set is the same.  n/m.
16:36:00 * nirik just got a call and two pages. back in a minute.
16:36:21 <EvilBob> I have about 15 minutes before I turn in to a bus
16:37:30 <nirik> ok, so anything more on this topic?
16:37:59 <fenrus02> is it consensus that the chan-modes remain "as is" and the bans get flushed?
16:38:00 <nirik> #topic Open Floor
16:38:05 <nirik> #undor
16:38:07 <nirik> #undo
16:38:07 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x2b03b0e650d0>
16:38:14 <nirik> fenrus02: I thought so...
16:38:21 <fenrus02> nirik, good.
16:38:48 <nirik> I can still see some reasons for flushing unregistered, but not many, so I guess it's best to just leave it
16:39:12 <zcat> EvilBob, so were you serious about deflecting PPCers? 0.3% of the installbase
16:39:21 <zcat> http://smolt.fedoraproject.org/static/stats/stats.html
16:39:45 <DiscordianUK> I understood there was to be no PPc F13
16:39:48 <EvilBob> zcat: not really, just annoying how religious they are
16:40:03 <EvilBob> zcat: we will be done with them soon enough
16:40:10 <zcat> righto
16:40:51 <nirik> #agreed Will clean out ban lists 4/15 and leave the channel setup as is otherwise.
16:40:54 <nirik> #topic Open Floor
16:40:56 <EvilBob> part of the problem is they will not go to -ppc because it is a support ghosttown
16:41:08 <nirik> anyone have anything for open floor?
16:41:29 <EvilBob> well, has been in the past, I don't even bother with being idle in there anymore
16:41:41 <DiscordianUK> All we can do is point them to #fedora-ppc for F12 stuff
16:41:56 <nirik> I am happy to help people with ppc issues for supported releases in #fedora.
16:41:59 <EvilBob> DiscordianUK: and if they refuse that answer?
16:42:09 <DiscordianUK> Warning etc
16:42:27 <fenrus02> DiscordianUK, ppc is not a primary arch.  that's different than saying "there is no support at all"
16:42:33 <EvilBob> DiscordianUK: and begin their religious rants about... make me puke
16:42:45 <nirik> fenrus02: it is in f11/f12. ;)
16:42:46 <DiscordianUK> Is there going to be a F13 for ppc?
16:42:56 <EvilBob> DiscordianUK: Hope so
16:42:57 <nirik> DiscordianUK: unknown. It will not be primary
16:43:00 <fenrus02> DiscordianUK, just means that f13 wont directly support it, and they'll have to go to a sig
16:43:15 <DiscordianUK> Hmmm
16:43:17 <EvilBob> DiscordianUK: it will be secondary, unclear if we support those I think.
16:43:41 <EvilBob> I hope the secondary arch concept works
16:43:52 <DiscordianUK> I have enough trouble with intel F13 on macs
16:44:02 <DiscordianUK> Never having used an Intel mac
16:45:22 <EvilBob> I have nothing else on my mind
16:45:45 <nirik> ok, thanks for coming everyone.
16:45:56 <nirik> #endmeeting