16:00:01 <nirik> #startmeeting IRC Support SIG (2010-06-10)
16:00:01 <zodbot> Meeting started Thu Jun 10 16:00:01 2010 UTC.  The chair is nirik. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:01 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:01 <nirik> #meetingname irc-support-sig
16:00:01 <nirik> #topic init process
16:00:01 <zodbot> The meeting name has been set to 'irc-support-sig'
16:00:11 <nirik> who all is around for a irc support sig meeting?
16:00:21 * dcr226 waves
16:00:23 <DiscordianUK> I am here
16:00:25 <plarsen> hello
16:00:40 <Sonar_Gal> hello
16:02:28 * nirik will wait another min for folks to wander in.
16:02:41 <fenris02> 
16:04:07 <mock> o/
16:04:10 <nirik> ok, I guess we should go ahead and get started in.
16:04:17 <nirik> #topic fedora-social guidelines
16:04:32 <nirik> I didn't really hear any feedback from the proposed guidelines from last week.
16:04:41 <nirik> They are in the #fedora-social topic...
16:04:54 <DiscordianUK> I was happy with the change
16:05:10 * mock was happy with the bacon
16:05:12 <nirik> https://fedoraproject.org/wiki/Fedora_Social_Channel_FAQ
16:05:50 <nirik> I think there was a bit of feedback about the politics/religion thing... (ie, remove it as sometimes they are ok discussions).
16:06:03 <dcr226> well, the freenode guidelines are mentioned
16:06:13 <nirik> yeah.
16:06:30 <dcr226> don't think it needs labouring beyond that
16:06:35 <plarsen> you can't really discuss "vim vs. emacs" without talking religion
16:06:50 <nirik> ok, I can strike that section then...
16:07:30 <nirik> we can of course amend this moving forward...
16:07:57 <DiscordianUK> if need be
16:08:18 <DiscordianUK> I don't see much need for policing of -social
16:08:36 <plarsen> nirik, would adding a reference to #fedora saying that's where the official help/support is for Fedora?
16:08:41 <fenris02> DiscordianUK, only gaurd to match freenode policy imho
16:08:43 <mock> what about a note of discussions getting out of hand could be intervened by ops
16:08:51 <DiscordianUK> fenris02:+1
16:09:05 <nirik> plarsen: well, if it's a fedora related question... might not be.
16:09:19 <nirik> mock: well, then you get into 'what is out of hand' ?
16:09:24 <DiscordianUK> as a matter of curiousity who does have ops there?
16:09:30 * dcr226 thinks having it in the faq and having -social ops is enough
16:09:30 <DiscordianUK> I know I do
16:09:39 <fenris02> DiscordianUK, /cs access #channel list
16:10:03 <plarsen> nirik, I was more thinking something as an overview of the channels available - and how the differs so you know where to post your issue?
16:10:17 <nirik> well, there is a smaller list of ops there... but there are a number of fedora ops who have access via fedbot.
16:10:31 * DiscordianUK nods
16:10:45 <nirik> plarsen: ah, yeah, might be nice to have some kind of 'channel guide' thing with info on a bunch of them.
16:10:52 <mock> nirik: more of a feel, but i believe an op could discern that if they read a few lines.
16:11:00 <DiscordianUK> I use fedbot
16:11:05 <nirik> https://fedoraproject.org/wiki/Communicate#IRC
16:11:20 <ardchoille> Someone made a statement in -social about "we come here to take a break from #fedora" and I feel that goes a long to explain that support q's don't belong in -social
16:11:25 <plarsen> ahhh, there it is.
16:11:43 <mock> nirik: if there's a lot of yelling and throwing of objects and slappings
16:11:46 <nirik> mock: yeah, but that gets very subjective... I think it's better to use the freenode offtopic guidelines.
16:11:52 * dcr226 adds #fedora-women to his favourite channels list
16:12:06 <fenris02> stalking?
16:12:16 <dcr226> >:-)
16:12:39 <nirik> I suppose we could add something about disrupting the channel?
16:12:57 <mock> what qualifies for that?
16:13:05 <fenris02> displaying graphic and horrific images is certainly on the list of abusive things in -social
16:13:25 <dcr226> nirik, don't think its needed for -social at all, there is faq's, ops, and regular -social occupants to do that imo
16:13:36 <DiscordianUK> That breaches freenode guidelines anyway
16:13:47 <nirik> well, I guess that falls under the freenode offtopic anyhow.
16:14:00 <fenris02> DiscordianUK, yes, but someone ignored it a while ago i'm told.
16:14:03 <nirik> "various forms of antisocial behavior"
16:14:31 <nirik> anyhow, I think this is a good start...
16:14:35 <dcr226> nirik, +1
16:14:39 * Southern_Gentlem 
16:14:42 <nirik> lets make it active and adjust if need be?
16:14:47 <DiscordianUK> +1
16:14:58 <fenris02> 
16:15:23 <nirik> any objections? ;)
16:15:56 * mock doesn't want to be objectable
16:16:15 <nirik> #agreed will put the #fedora-social faq in place and adjust as needed moving forward.
16:16:27 <nirik> #topic Week in Review
16:16:39 <Southern_Gentlem> nirik,  did we make Sonar_Gal an op in social?
16:16:41 <nirik> http://fedora.theglaserfamily.org/ircstats/fedora-weekly.html
16:17:02 <nirik> Southern_Gentlem: was going to get to ops nominations in a bit. ;)
16:17:16 <nirik> we didn't yet I don't think...
16:17:38 <fenris02> didnt?  oh. thought we had
16:18:05 <dcr226> afaik, it was in the nominations last week, and you were waiting for any objections nirik
16:18:09 * DiscordianUK is unsurprising down in the weekly stats
16:18:29 <nirik> it was a pretty busy week... but nothing vastly out of the ordinary that I can think of.
16:18:41 <nirik> aside from mharris being so active again. ;)
16:18:58 <DiscordianUK> It's good to see him back
16:19:02 <dcr226> don't think he slept for 3 days
16:19:11 <DiscordianUK> He's a wealth of experience
16:19:43 <Southern_Gentlem> and sarcasim
16:19:47 <nirik> ok, anyone have anything to note from the last week then? or shall we move along?
16:20:22 <mock> speaking of...
16:20:57 <nirik> indeed. ;)
16:21:25 <Sonar_Gal> :)
16:21:59 <nirik> ok, moving along then...
16:22:06 <nirik> #topic Op nominations
16:22:55 <ardchoille> Who is allowed to vote in these nominations?
16:23:00 <nirik> As far as Sonar_Gal for fedora-social, I wasn't sure she was willing to serve.... Since she is, I'm +1 to that... She's active in there and will help out nicely.
16:23:00 <dcr226> ops
16:23:10 <nirik> ardchoille: ops in the indicated channel.
16:23:11 <dcr226> Sonar_Gal, +1
16:23:20 <DiscordianUK> +1
16:23:25 <plarsen> If I have a vote, I'm for +1 too
16:23:35 <nirik> we collect feedback via email over the week, and then vote in the next meeting.
16:23:53 <thomasj> Are wwe voting Sonar_Gal right now?
16:23:55 <thomasj> *we
16:23:57 <mock> was there any mod to the bot for a @frying_pan function?
16:23:58 <nirik> thomasj: yeah.
16:24:03 <thomasj> +1 to Sonar_Gal
16:24:04 <nirik> mock: ha.
16:24:17 * mock submits there needs to be
16:24:22 * dcr226 is happy to build one
16:24:39 * dcr226 so long as he gets currency on its output
16:24:58 <Sonar_Gal> :)
16:25:02 <mock> dcr226: you be part of the test group :)
16:25:11 * DiscordianUK chuckles
16:25:20 <dcr226> mock, so long as I'm allowed back in afterwards :D
16:25:31 <nirik> Southern_Gentlem: any vote here? I think you already said +1 last week.
16:27:10 <nirik> anyhow, no objection, so I think this passes...
16:27:25 <nirik> #agreed Sonar_Gal to help op #fedora-social.
16:27:32 <nirik> ok, next up... dcr226
16:27:36 * dcr226 ducks
16:27:45 <mharris> +1 for SG
16:28:04 <DiscordianUK> for #fedora or both that and -social?
16:28:14 <nirik> DiscordianUK: for fedora.
16:28:17 <DiscordianUK> +1
16:28:21 <thomasj> dcr226 as fedbot op or full?
16:28:36 * thomasj missed a bit
16:28:43 * plarsen abstains .... wouldn't be right to vote here.
16:29:09 <nirik> thomasj: we could do either. I think it gets confusing tho to have people who are just ops via the bot... unless people think it's a good way to do a probationary period or something.
16:29:10 <Southern_Gentlem> +1 Sonar_Gal
16:29:25 <Southern_Gentlem> Sonar_Gal,  has been around along time
16:29:32 <DiscordianUK> It is confusing
16:29:36 <thomasj> nirik, is he already fedbot op?
16:29:39 <Southern_Gentlem> i think she should have full op in #social
16:29:48 <nirik> thomasj: nope.
16:29:51 <thomasj> ah ok
16:30:01 <mharris> Although people might start conspiracy theories if most ops nicks abbreviate to "SG".  :)
16:30:12 <DiscordianUK> I suggest dcr226 as a channel op in #fedora
16:30:18 <DiscordianUK> for now
16:31:00 <Southern_Gentlem> mharris,  never been a problem bifore when anvil me and sonar_guy where the only ones active
16:31:12 <thomasj> +1 for fedbot op for dcr226. Though if people think he might be ok for full, no real objections here. Except maybe the short time.
16:31:29 <nirik> I think dcr226 has been doing a great job... I'm +1 to making him an op, but ok with just adding to bot for a week as a trial period.
16:31:33 <mharris> Southern_Gentlem: just trying to be funny :)
16:31:39 <Southern_Gentlem> give both 30 days trail with the bot then we can move from there
16:31:49 <plarsen> About bot only - once you've used it once, I think it won't be a problem not having the real hat ...
16:31:49 <DiscordianUK> I'll support that
16:32:06 <nirik> well, what would say should be allowed via the bot then?
16:32:11 <Southern_Gentlem> +1
16:32:27 <thomasj> 30 day trial sounds fine. +1
16:32:34 <mharris> Using a bot to op would be the preferred method no? ;)
16:32:39 <nirik> yeah, it is.
16:32:41 <mharris> Cloaked bot actions.
16:32:56 <mharris> Unless it advertises who did it in messages
16:33:03 <DiscordianUK> It doesn't
16:33:13 <mharris> ah, sounds sweet :)
16:33:14 <nirik> but the confusion then is: can the person vote on other ops? can they change needed things that are not via the bot in channel? (not that we have to do that very often)
16:33:37 <plarsen> mharris, if the op has warned in channel about a given behavior and then the bots executes, is there really a need to advertise more than that?
16:33:47 * zcat peeks in
16:33:59 <nirik> so, restricted to what? ban/kick?
16:34:17 <mock> zcat: poke 756,1
16:34:27 <mharris> plarsen: no, I'm all in favour of all op actions in all channels being cloaked by default.  It helps to mitigate retaliation, DoS attacks, /msg whining, etc.
16:34:28 <DiscordianUK> That's 90% of all that's needed
16:34:42 <zcat> mock, hey, you sunk my &battleship
16:34:52 <mharris> Of course, then the bot is hip for DoS potentially :)
16:34:59 <plarsen> mharris, I think we agree then ;)  I thought you wanted the message to contain the nick of the op that caused the action.
16:35:37 <mharris> plarsen: naw, I like the idea of a channel bot that priv people can do cloaked op operations
16:35:41 * dcr226 can count on less than 2 fingers the number of times he would actually have used it anyway fwiw
16:36:01 <nirik> ok, I will look and see if we can config the bot this way. I think we can.
16:36:04 <nirik> ok, on to plarsen. ;)
16:36:19 <mharris> dcr226: yeah, same here.  There's only one person that I'd have +b'd in #f-s in recent times for sure.
16:36:32 <nirik> I think he also has been doing a good job and active. +1 here to the same setup as dcr226.
16:36:34 <mharris> And others ended up banning him several times anyway so... :)
16:36:39 <DiscordianUK> +1
16:36:43 <dcr226> mharris, think its the same person
16:36:54 <mharris> +00000001b
16:37:00 * plarsen tries to not look too conspicurate
16:37:18 <mharris> dcr226: fenris02?
16:37:24 <dcr226> lulz
16:37:26 <DiscordianUK> i had to op up in f-s once to ban someone who was bouncing
16:37:27 <mharris> just kidding :)  tweek*
16:37:30 <thomasj> +1 to plarsen with the same setup as dcr226
16:37:53 <mharris> ah yes, having ops to stomp on bouncings would be nice at times.
16:38:27 <mharris> perhaps an @antibounce command would be suitable for that, with exponential fallback
16:38:31 <Southern_Gentlem> DiscordianUK,  you jusyt not quick enough
16:38:52 <DiscordianUK> Southern_Gentlem, I was learning
16:39:05 <dcr226> well, I can probably sort a plugin to pickup on say 5 entries in 60 seconds? mharris
16:39:17 <nirik> anyhow, any objections on plarsen?
16:39:27 <DiscordianUK> No objections
16:39:43 <nirik> congrats to Sonar_Gal, dcr226, plarsen. Use your powers sparingly and wisely.
16:39:57 <Sonar_Gal> nirik, Thanks
16:39:59 <nirik> #agreed dcr226 and plarsen will be added to the bot setup for 30days.
16:39:59 <DiscordianUK> yes congrats all three of you
16:40:07 <dcr226> thanks all :)
16:40:10 <mharris> ie: if someone is @antibounce'd, they're given a /msg from the bot indicating their client is auto-rejoining too frequently and they need to fix it, followed by an n minute ban, if they rejoin after that, and rejoin again within 'm' seconds, then they're booted again for n*2 seconds, etc. until they sort out the problem
16:40:14 * Southern_Gentlem bounceing in and out $dayjob
16:40:19 <plarsen> Thank you all
16:40:39 <mharris> In fact, it'd be nice to have the bot just autodetect that happening to people and auto-autobounce them
16:40:56 <nirik> #topic Bot news
16:40:57 <DiscordianUK> Mmm not sure about auto
16:41:01 <dcr226> mharris, yeah, thats what I was on about
16:41:09 <nirik> so, dcr226 wrote up a simple plugin this last week...
16:41:17 <mharris> I like auto stuff
16:41:22 <zcat> mharris, the first 10 joins/parts per hour are free...
16:41:27 <nirik> it allows someone to notify ops about a problem.
16:41:35 <nirik> @ops help help!
16:41:52 <nirik> this will send a note to #fedora-ops channel
16:41:54 <nirik> that looks like:
16:41:58 <nirik> <fedbot> Hello, nirik says could someone take a look at issues in #fedora-meeting, (orig message : 'help help!')
16:42:07 <plarsen> I like that feature
16:42:10 <mock> nice
16:42:14 <DiscordianUK> That seems a good idea
16:42:23 <nirik> this should allow us to have people notify ops about a issue/problem, so someone can look at it.
16:42:36 <nirik> we need to add it to the wiki page and start otherwise advertising it's existance...
16:42:38 <mharris> @ops nirik is giving away all the bot secrets!
16:42:48 <nirik> unless folks have problems with the way it's setup now. ;)
16:42:56 <DiscordianUK> a possible DOS vector though
16:43:07 <dcr226> it has a limit DiscordianUK
16:43:09 <nirik> well, it's subject to the same limits as other commands.
16:43:11 <mharris> nirik: bummer, it doesn't mention all ops IRC nicks to kick in client side alerts
16:43:14 <DiscordianUK> okay
16:43:21 <dcr226> but still, yes - the same as the bot generally
16:43:22 <nirik> so it will ignore someone who does it too many time.
16:43:27 <DiscordianUK> okay
16:43:32 <nirik> also, we can set it to ignore people who abuse it.
16:43:32 <dcr226> nirik, if fedbot using twisted?
16:43:49 <nirik> dcr226: for it's connection method? I would have to look...
16:44:00 <mock> blacklist
16:44:16 <dcr226> nirik, if not, it probably wise - ddos can be non-trivial if it can run that many threads
16:44:18 <mock> with great power comes great responsibility --uncle ben
16:44:20 <nirik> no, it's using Socket.
16:44:40 <plarsen> gotta go afk for a few.
16:44:42 <dcr226> mock, that was Sun Tzu
16:44:55 <mharris> nirik: I'd propose snarfing the op list from ACCESS #foo LIST, and adding everyone's nicks to the msg sent to #fedora-ops, although some people might be using an alternate nick compared to what they're flagged in the access lists.
16:44:59 * mock saw spider-man instead of reading sun tzu
16:45:15 <dcr226> Heh
16:45:17 <nirik> mharris: well, there is a pingall command that would ping everyone in that channel.
16:45:18 <Southern_Gentlem> i think in the #ops channel is plenty
16:45:29 <dcr226> +1
16:45:31 <DiscordianUK> I think the channel is enough
16:45:44 <DiscordianUK> I sit in there if I'm around
16:46:10 <nirik> mharris: this is also a memoserv command that can send to all ops... but that also is messy... someone may have taken care of the issue and 5 others still get it and start looking into it.
16:47:21 <nirik> anyhow, lets try just to channel for now, and can adjust if need be.
16:48:06 * dcr226 notes that this particular plugin doesn't require any string. @ops is enough to trigger it
16:48:51 <nirik> right.
16:48:54 <nirik> #topic Open floor
16:48:58 <nirik> anything for open floor?
16:49:17 <mharris> You guys are too low tech.  I was thinking of an SIP plugin that dials everyone's FAS chat number with the text message from the @ops command translated to speech via festival.
16:49:26 <mharris> It's 2010!  Think big!
16:49:55 <nirik> ha. ;)
16:50:13 <dcr226> mharris, asterisk's manager api works well for that
16:51:13 * nirik will close out the meeting in a few if nothing else comes up.
16:51:37 * mock has nothing
16:51:43 <DiscordianUK> Nor me
16:51:55 <nirik> Thanks for coming everyone!
16:51:58 <nirik> #endmeeting