16:00:38 <nirik> #startmeeting IRC Support SIG (2010-08-19)
16:00:38 <zodbot> Meeting started Thu Aug 19 16:00:38 2010 UTC.  The chair is nirik. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:38 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:38 <nirik> #meetingname irc-support-sig
16:00:38 <zodbot> The meeting name has been set to 'irc-support-sig'
16:00:38 <nirik> #topic init process
16:00:45 <nirik> who all is around for meeting?
16:00:46 * dcr226 
16:00:49 <DiscordianUK> 
16:00:55 <Sonar_Gal> 
16:01:00 * zmore 
16:01:38 * EvilBob 
16:02:11 <nirik> ok, lets go ahead and get started in...
16:02:16 <nirik> #topic Week in review
16:02:26 <nirik> http://fedora.theglaserfamily.org/ircstats/fedora-weekly.html
16:02:58 <EvilBob> http://fedora.theglaserfamily.org/ircstats/fedora-social-weekly.html
16:03:15 * DiscordianUK is happy to note I fell to 7th place this week
16:03:18 <nirik> since our last meeting there have been: 3 people kicked/banned by operator action, and 11 people who were caught by the bot flood protection.
16:04:09 <EvilBob> one of those was an outburst following a kick/ban in social
16:04:12 <nirik> anything folks would like to note from this last week?
16:04:22 <DiscordianUK> Yep
16:04:40 <DiscordianUK> It's been quite a busy week
16:05:14 <nirik> yeah, busy but pretty typical...
16:05:19 <DiscordianUK> and we're seeing a fair number of people still wanting stuff from F14/rawhide
16:05:37 <nirik> yeah, that will only increase I suspect... ;)
16:05:44 <nirik> ok, moving along...
16:05:47 <nirik> #topic Feedback Processes
16:05:48 <DiscordianUK> It's bound to yes
16:05:57 <nirik> There has been some more discussion of this on the list...
16:06:13 * fcami knocks on the door
16:06:13 <nirik> https://admin.fedoraproject.org/mailman/listinfo/irc-support-sig for anyone who wishes to subscribe
16:06:31 <nirik> sounds like folks are interested in trying trac for feedback items...
16:06:38 <DiscordianUK> do feel free to contribute fcami
16:06:45 * fcami gets a seat
16:06:56 <EvilBob> do feel free to contribute $ANYONE
16:07:05 * dcr226 thinks trac might be a sledgehammer to crack a wallnut fwiw
16:07:11 <EvilBob> I like the idea of Trac
16:07:15 <DiscordianUK> trac seems to have the majority support
16:07:25 <nirik> well, it has advantages and disadvantages...
16:07:36 <DiscordianUK> I agree with dcr226 but
16:07:37 <fcami> I've already stated why I think trac is a good idea on the mailing list - mainly for organization / tracking (no pun intended) / history keeping purposes
16:08:07 <nirik> most often we get no feedback of any kind. ;) Interspaced with occassional flamewar/blowup feedback, then quiet again. ;)
16:08:32 <DiscordianUK> yeah and the new list is very quiet
16:08:46 <fcami> DiscordianUK: post something? :)
16:08:55 <dcr226> for the sake of posting?
16:09:03 <fcami> of breaking the quietness
16:09:12 <DiscordianUK> Not my style
16:09:47 <DiscordianUK> So I'll +1 trac
16:09:55 <EvilBob> nirik: can you briefly touch on the disadvantages to using trac
16:10:20 <EvilBob> and is there another solution that may be better suit that anyone knows about
16:10:26 <dcr226> fwiw, I had a particularly angry user pm me last week, the situation was diffused by letting him flame for 30 minutes or so without response, then I gave positive feedback on how to reduce the chances of him getting upset. there was no need for anything further than that
16:11:26 <dcr226> and I actually think that under the banner of "being an op" we should possibly focus more on being able to deal with $angry_user than find inventive ways to queue it for someone to deal with
16:11:29 <DiscordianUK> Sometimes there are issues you don't know about
16:11:30 <nirik> EvilBob: sure... I guess most of them revolve around how we want to set it up... do we want to try and keep tickets private or mail them to the list when they are added, etc.
16:11:57 <EvilBob> DiscordianUK: +1
16:12:05 <DiscordianUK> On #centos for example people get very confrontational with a guy who's blind
16:12:18 <DiscordianUK> Until he tells them that
16:12:23 <nirik> dcr226: somewhat agreed, but sometimes people want to 'speak to your supervisor' or can't be really talked to by the person who took the action...
16:12:24 * dcr226 is sitting it out, because someone's gonna have to set trac up and maintain it - for maybe 3 reports a month
16:12:43 <nirik> dcr226: well, thats not a big deal, I can do that end of it...
16:12:50 <dcr226> nirik, no, but we can ask in -ops who's prepared to be the "shoulder to cry on"
16:13:13 <DiscordianUK> Don't look at me
16:13:16 <dcr226> there's usually >1 op floating about at any one time
16:13:24 <EvilBob> I would think any trac ticket be required that the user include their IRC nick for reference
16:13:28 <DiscordianUK> Normally yes
16:13:37 <DiscordianUK> +1 EvilBob
16:13:42 <EvilBob> as such I think it would need to be kept private to prevent stigma
16:13:56 * dcr226 is more than happy to ignore pm flames for 30 minutes, to then point someone at the "maximizing irc support" wiki
16:13:59 <nirik> EvilBob: I would want them to include a fair bit of info... nick, logs, what they would like to see happen from their feedback, etc.
16:14:39 <EvilBob> I think PM on complaints should be avoided
16:14:48 <Sonar_Guy> EvilBob: +1
16:15:00 <DiscordianUK> I avoid pm's with people I don't know
16:15:15 <DiscordianUK> It's rude and bad netiquette
16:15:17 * dcr226 steps out of the topic and doesn't vote. I _want_ a process, but don't want to cause anyone un-needed work
16:15:18 <EvilBob> if one op should know about it all ops should know about it IMO
16:15:18 <fcami> I redirect people who sent me pms to #fedora
16:15:51 <fcami> aka "keep it in channel"
16:16:06 <nirik> I will have to ask about the privacy plugins for trac. I know there is one, but not sure what all it can do...
16:16:09 <dcr226> EvilBob, I'd be happy to share the log afterwards, I just think that people just need to get stuff off their chests sometimes. and talking to a non-responder gives them the ability to do so
16:16:23 * dcr226 really does can-it now
16:16:35 <EvilBob> well the #fedora channel is not the place for most complaints IMO, #fedora-ops is better for that to prevent disruption of the support channel
16:16:38 <DiscordianUK> That's reasonable 'keep it in channel and then you get the benefits of peer review of my answers'
16:16:39 <nirik> dcr226: couldn't we have them /msg fedbot then? ;)
16:16:50 <DiscordianUK> yikes
16:16:54 * nirik notes he won't answer. ;)
16:17:04 <dcr226> nirik, Heh
16:17:53 <DiscordianUK> Oh fedbot
16:18:00 <dcr226> nirik, in actual fact, I'm pretty sure, with some pre-defined responses, 90% of the complaints would go away ;-)
16:18:11 * DiscordianUK remembers that needs to be discussed
16:18:35 <dcr226> a tuple of "uh huh, yeah, I understand" would probably do it :)
16:18:52 <nirik> I'd be ok with trying trac, but I think I would lean toward making it public. If it's private I agree it might save stigma for some people, but then no one could search/learn from previous issues, only a small group would comment again which I think is bad.
16:19:09 <nirik> dcr226: eliza bot!
16:19:15 <dcr226> precisely
16:19:24 <DiscordianUK> i was just thinking that nirik
16:19:39 <nirik> "how does being mad at nirik for banning you make you feel?" ;)
16:20:03 <EvilBob> nirik: I understand your point, I guess my issue was publishing to the list
16:20:32 <DiscordianUK> We're about transparency
16:20:32 <nirik> EvilBob: yeah... I suppose we could not have it do that and only add a cc on the list once it's been looked at?
16:20:41 <nirik> ie, some of it might be junk/notabug
16:20:41 <Southern_Gentlem> thank you for your responce but your a whinney ass. pull up your big girl panties and get a life
16:20:47 <EvilBob> nirik: if the list only gets a notice of the ticket with no additional text that would be acceptable I hink
16:20:53 <dcr226> Southern_Gentlem, Heh
16:21:11 <nirik> not sure it can do that, but if there are only a few tickets ever it should be easy to just manually note to the list.
16:21:44 <EvilBob> nirik: Right on
16:21:50 <nirik> we could also track meeting items or other stuff we need to get done in there I suppose.
16:22:11 <dcr226> I think we need to vote on ml/trac and get something implemented, this has taken too long to get moving so far as it is
16:22:48 <nirik> dcr226: well, we already have a mailing list. ;)
16:23:02 <DiscordianUK> Indeed
16:23:07 <dcr226> nirik, with no feedback as yet ;-)
16:23:10 <EvilBob> and on that note I think we should have a moratorium for a few months to shake out the bugs before adding any additional ops
16:23:26 <nirik> so, proposal: ask for a trac instance. Feedback and meeting items can go there. List can be notified to comment on feedback tickets that are needing feedback.
16:23:33 <Southern_Gentlem> +1
16:23:45 <DiscordianUK> I don't agree with the moratorium on ops
16:23:50 <dcr226> +1 to get something moving, and at least we'll learn/adapt/junk where needed
16:24:01 <dcr226> (my +1 was for nirik)
16:24:03 <DiscordianUK> however +1 for trac
16:24:19 <nirik> any negative votes/objections to that?
16:24:28 <fcami> trac +1
16:24:34 <nirik> #agreed will ask for a trac instance. Feedback and meeting items can go there. List can be notified to comment on feedback tickets that are needing feedback.
16:24:36 <dcr226> sorted :)
16:24:43 <EvilBob> trac +1 with privacy notes
16:25:00 <Sonar_Guy> trac +1 with privacy notes
16:25:31 <nirik> EvilBob: I disagree on that. I think we can add ops and they could help us with setting up stuff/shaking bugs out. I think new perspectives are good to add in and could help us jaded people set up something better.
16:25:49 <nirik> (on the ops moratorium)
16:26:05 <DiscordianUK> I intend to propose a trail op in Open Meeting
16:26:10 <DiscordianUK> trial
16:26:32 <Southern_Gentlem> DiscordianUK,  do it
16:26:58 <mock> make it so
16:27:12 <DiscordianUK> I shall
16:27:14 <dcr226> mock, engage warp 3?
16:27:51 <nirik> ok, anything more on feedback? or shall we move on?
16:28:03 <dcr226> move on, its sorted from what I can see
16:28:03 <Southern_Gentlem> next
16:28:13 <nirik> #topic Fedora 14 Alpha coming up.
16:28:20 <nirik> So, alpha will be out next week
16:28:24 <mock> \o/
16:28:26 <EvilBob> Oh remember to send people to the trac instance that are happy
16:28:30 <nirik> I expect some increase in f14 questions.
16:28:35 <DiscordianUK> Yep
16:28:38 <nirik> EvilBob: totally agreed.
16:28:42 <dcr226> EvilBob, I will - I get loads ;-)
16:28:57 <DiscordianUK> Still #fedora-qa till beta is what I think
16:29:17 <dcr226> +1 DiscordianUK , and the -ops need some time with python2.7 and systemd
16:29:18 <nirik> oh, that reminds me of a trac disadvantage... they have to sign up for a fas account. (they would have to subscribe to the mailing list too, but that may be easier for some people)
16:29:29 <EvilBob> Yeah -qa until beta has been our history
16:30:10 <EvilBob> nirik: there is no guest accessability to file a ticket?
16:30:15 <DiscordianUK> Especially systemd
16:30:27 <nirik> EvilBob: nope. ;( You can view, but need an account to file.
16:30:37 <EvilBob> yuck
16:30:37 <dcr226> nirik, think that might be a killer for the trac idea ;-(
16:30:41 <EvilBob> OK moving on
16:31:17 <EvilBob> we could always do a standalone trac not tied to FAS I would think
16:31:27 <nirik> ok, anything more on f14a?
16:31:45 <dcr226> nirik, maybe a small wiki page with common issues that are likely to appear
16:32:06 <dcr226> rpmbuild --rebuild'ing f13 packages based on p2.6 are likely to fail for example
16:32:17 <dcr226> as will rpm --force
16:32:39 <raffairon> where can i made a suggestion for f14?
16:32:40 <nirik> many python packages should rebuild ok... depends on the package if they needed changes for 2.7
16:32:47 <dcr226> the wiki page would be for #fedora ops to read through (for clarity)
16:32:49 <nirik> rpm --force is always the wrong answer. ;)
16:32:57 <dcr226> true enough
16:33:16 <dcr226> raffairon, is it a request for an enhancement? if so, bugzilla
16:33:38 <EvilBob> raffairon: the devel mailing list, the #fedora-devel channel, bugzilla.redhat.com
16:33:54 <Southern_Gentlem> raffairon,  what is your suggestion
16:34:01 <EvilBob> Southern_Gentlem: Come on
16:34:09 <EvilBob> this is not the time or place
16:34:17 <EvilBob> we are in the middle of a meeting
16:34:31 <Southern_Gentlem> you may be right but let the person finish his statement
16:34:47 <EvilBob> He did not make a statement
16:34:54 <EvilBob> he asked a question
16:34:58 * dcr226 has no more comments ref F14a
16:35:07 <EvilBob> Next topic
16:35:12 <nirik> raffairon: we can direct you after the meeting. ;)
16:35:17 * DiscordianUK moves next business
16:35:17 <nirik> #topic Classroom Sessions
16:35:26 <nirik> So, we haven't had any irc classes in a while.
16:35:33 <nirik> I was going to look at signing up for some soon.
16:35:38 * dcr226 goes red and looks shifty
16:35:42 <nirik> If others would like to do so also, please do.
16:36:17 <DiscordianUK> I think some on new features in F14 would be good once those are clear
16:37:34 <nirik> yeah.
16:37:44 <nirik> anyhow, just wanted to note it.
16:37:48 <nirik> #topic Open Floor
16:37:50 <Southern_Gentlem> yep have to wait to see what floats or stinks
16:38:01 <DiscordianUK> I have two issues for this
16:38:48 <nirik> go ahead DiscordianUK
16:38:56 <DiscordianUK> The first is nb has noted that that including fpaste in all f14 spins is more likely if fedbot can be moved to our infrastrcuture
16:39:25 <nirik> DiscordianUK: yeah. Although I am not so sure this is a show stopper...
16:39:27 <DiscordianUK> The infrastructure team would be happy to let existing fedbot ops access it
16:39:33 <dcr226> how does fpaste affect fedbot ?
16:39:40 <nirik> dcr226: not at all.
16:39:47 <DiscordianUK> Not fedbot
16:39:50 <Southern_Gentlem> DiscordianUK,  i think you are confused
16:39:56 <DiscordianUK> I mean www.fpaste
16:40:16 <Southern_Gentlem> DiscordianUK,  fp.org is talking to Fedora unity about this
16:40:18 <EvilBob> DiscordianUK: this is not an ops issue
16:40:27 <DiscordianUK> okay right I apologise
16:40:32 <Sonar_Guy> EvilBob Southern_Gentlem +1
16:40:49 <EvilBob> It is a Fedora Unity issue and it is being handled
16:40:49 <nirik> except in the sense that we would all like to have fpaste available so we could better help people. ;)
16:41:10 <DiscordianUK> The other issue is I note fcami has been with us now in -ops for a while
16:41:23 <dcr226> its default in the dvd, and not in the livecd's. so I'm assuming thats because someone's trying to save space on the live media?
16:41:31 <DiscordianUK> and has talked sense about issues that evolved
16:41:45 <dcr226> DiscordianUK, we're still on F14a I think
16:41:49 <EvilBob> We need to have a policy in place for people getting "invited" to the channel
16:41:57 <nirik> EvilBob: I thought we did.
16:42:11 <EvilBob> perhaps a trac ticket being filed once that is in place
16:42:17 <nirik> You can come and stay in the ops channel if you are an op in #fedora or someone vouches for you.
16:42:34 <EvilBob> "someone" one being the issue I have
16:42:35 <DiscordianUK> I discussed it before I invited him with those that were there
16:42:53 <EvilBob> it should be discussed with everyone, there or not
16:42:55 <nirik> someone should == an op
16:43:10 <EvilBob> again "an" being one
16:43:23 <Southern_Gentlem> trac will help in the future of this issue move on
16:44:00 <nirik> right, thats been my understanding of our policy. We could change it of course...
16:44:01 <EvilBob> I already have disagreed with any new ops being added at this time
16:44:02 <EvilBob> -1
16:44:32 <EvilBob> it has nothing to do with fcami other than timing
16:44:43 <DiscordianUK> I do not believe we should refuse to add new ops
16:44:47 <nirik> fcami: are you around? do you wish to be an op? or would you be fine continuing to just be a helper?
16:45:12 <nirik> or I can ask him out of band...
16:45:23 * dcr226 notes he hasn't actually been nominated as yet (for people who aren't resident in -ops)
16:45:26 <fcami> nirik: around, yes.. an op, yes, because at least once I was a bit helpless and got lucky the situation stayed under control.
16:45:42 <fcami> on the other hand, I'd rather there be consensus on this.
16:45:49 <dcr226> fcami, there has to be
16:45:58 <fcami> dcr226: just stating the obvious I believe. :P
16:45:59 <Sonar_Gal> ops are voted in
16:46:05 <DiscordianUK> I nominate fcami as a trial (bot) op
16:46:12 <fcami> ty.
16:46:31 <dcr226> -1, no offense fcami reason to follow if anyone's interested
16:46:34 <nirik> so, lets have a week period for voting and discussion. ;)
16:46:38 <dcr226> ups
16:47:04 <nirik> you're welcome to comment now if you like...
16:47:08 <Sonar_Gal> nirik, +1
16:47:16 <nirik> but in the past we have taken a week to gather feedback and comments.
16:47:24 <nirik> before voting.
16:47:25 <DiscordianUK> Next meeting for a vote then
16:47:35 <dcr226> nirik, I'm happy to do what ever, now/ops/ml :)
16:47:35 <DiscordianUK> seems reasonable
16:47:38 <Southern_Gentlem> for a trail op or as full op
16:47:39 <EvilBob> Shall we take it to the list then?
16:47:46 <DiscordianUK> trial op
16:47:52 <DiscordianUK> for 28 days
16:48:00 <DiscordianUK> is my suggestion
16:48:05 <nirik> 28 days later? ;)
16:48:16 <DiscordianUK> Nah
16:48:24 <dcr226> nirik, feels like that sometimes ;-)
16:48:41 <DiscordianUK> as a trial op for 28 days and review in 4 weeks
16:48:42 <nirik> #info fcami proposed for trial operator
16:48:51 <nirik> #agreed will gather feedback and vote next week.
16:48:57 <DiscordianUK> cool
16:48:58 <nirik> Anything else for open floor?
16:49:05 <EvilBob> I would like to nominate opsec as a trial op
16:49:24 <nirik> EvilBob: ok.
16:49:24 <EvilBob> Not sure he is interested but what the hell
16:49:34 <nirik> EvilBob: yeah, can you inquire if he is willing?
16:49:44 <EvilBob> I will
16:50:04 <nirik> let me know and if he is we can start the feedback/gathering info thing...
16:50:31 <fcami> I am starting to think this is not worth the time you guys are spending on it.
16:50:44 <dcr226> fcami, which whut?
16:50:50 <fcami> nominating me.
16:50:58 <dcr226> fcami, it absolutely is
16:50:58 <nirik> fcami: naw... it's not that much time.
16:51:02 <nirik> :)
16:51:03 <Sonar_Gal> fcami, This is normal for voting on ops
16:51:06 <nirik> anything else for open floor?
16:51:20 <fcami> Sonar_Gal: I know the time is normal, I believe the benefits are not worth it. :)
16:51:23 <Sonar_Guy> +1 to fcami for trial op
16:51:50 <Sonar_Guy> +1 to opsec for trial op if he is interested
16:52:05 <dcr226> -1 to opsec, regardless of if he's interested
16:52:07 <fcami> after all, I've been doing support for a while and there has only been one, or at the most two times I wish I had +o. so.
16:52:08 * nirik will hold his votes till next week.
16:52:22 <dcr226> fcami, chill, there's time for this
16:52:28 <fcami> wilco.
16:52:37 <DiscordianUK> +1 for fcami
16:52:42 <DiscordianUK> -1 for opsec
16:53:03 <EvilBob> This is going to the list
16:53:25 <dcr226> separate list topics please, save my head spinning
16:53:30 <dcr226> :-)
16:53:41 <EvilBob> fcami: an op should never IMO +o for an issue they are involved in, another op should handle it
16:53:55 <fcami> EvilBob: I was not involved in the problem.
16:53:57 <DiscordianUK> He has no vote
16:54:12 * nirik will close the meeting in a minute if no new topics come up. ;)
16:54:51 <mock> did bacon get mentioned this meeting?
16:55:02 <DiscordianUK> It just did
16:55:04 <EvilBob> mock: it did now
16:55:10 <mock> \o/
16:55:16 <nirik> ha.
16:55:22 <nirik> Thanks for coming everyone.
16:55:24 <Sonar_Gal> bacon was #1
16:55:32 <nirik> #endmeeting