17:15:21 <dcr226> #startmeeting
17:15:21 <zodbot> Meeting started Thu Aug 18 17:15:21 2011 UTC.  The chair is dcr226. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:15:21 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:15:23 <dcr226> #meetingname irc-support-sig
17:15:23 <zodbot> The meeting name has been set to 'irc-support-sig'
17:15:35 * nirik waves
17:15:42 * DiscordianUK is
17:15:45 <dcr226> ok, might be a real quick, late notice meeting guys....but lets see what we can do :-)
17:15:49 * N3LRX 
17:15:55 <dcr226> #topic Week in Review
17:16:07 <dcr226> no stats I'm afraid, the sonarz are still getting themselves rigged up
17:16:12 <DiscordianUK> a very quiet week
17:16:23 <dcr226> but on the "feels like" scientific metric, obviously I'm the best
17:16:29 <dcr226> ;-)
17:17:15 <dcr226> yeah, quiet week.....did something happen to pulseaudio with Fedora 15? whereis pulseaudio returns nowt on my box (just noticed I may have been giving out wrong commands)
17:17:34 <DiscordianUK> I've not seen a change
17:17:37 <nirik> not that I know of
17:17:47 <nirik> still running along fine here.
17:17:54 <dcr226> ok, likely that I broke something then...that clears that up :-)
17:18:11 * dcr226 notes that "I broke something" is always a possibility over here ;-)
17:18:33 <dcr226> move on?
17:18:38 <nirik> sure
17:18:44 <dcr226> #topic Feedback Tickets
17:18:49 <dcr226> this is a bit sad I think
17:18:53 <dcr226> still no tickets
17:18:58 <dcr226> #link https://fedorahosted.org/irc-support-sig/report/1
17:19:04 <nirik> well, it's a quiet time... ;)
17:19:25 <nirik> we could drop the unregistered redirect to add in more spammers and trolls. ;)
17:19:27 <dcr226> yeah, I've been trying to coax feedback from folks, no avail ;-(
17:19:27 * nirik runs.
17:19:32 <dcr226> nirik, lol
17:19:43 <DiscordianUK> it's holiday season in the northern hemisphere
17:20:01 <dcr226> ok, I'll float it out there, because I said I would
17:20:07 <dcr226> #idea no auth for trac?
17:20:30 <nirik> -1 from me. I have seen in the past the amount of spam that results. ;)
17:20:30 <DiscordianUK> we can try that I guess?
17:20:41 <dcr226> ^^ the suggestion is for obvious reasons, I understand both sides of the argument, just looking for votes one way or the other
17:20:51 <DiscordianUK> I suspect it'll end in tears
17:21:15 <DiscordianUK> I'll -1 too
17:21:16 <EvilBob> If they can't be bothered to auth, I can't be bothered to give a crap about their "issue"
17:21:18 <nirik> I fear we would get a lot of people being anonymous and using it as a platform too.
17:21:22 <dcr226> yeah, was just a thought to see if we could get more...sadly on reflection I tend to agree it'll end badly
17:21:41 <dcr226> ok, so 3 -1's, that'll do me :-)
17:21:46 <N3LRX> I think we should give it a try. Not having to create an account for tickets may be an incentive to post more feedback.
17:21:51 * dcr226 waits
17:22:15 <DiscordianUK> It would be a bad reflection on the project if we did something that could be exploited
17:22:19 * dcr226 is ftr +1 as its his idea, and we can quickly revert
17:22:21 <N3LRX> If the spam gets bad close the doors again.
17:22:53 <dcr226> no-one else?
17:22:56 <EvilBob> Let me know so I can black list the trac email address
17:23:18 <dcr226> #action trac stays auth'd as before
17:23:21 <DiscordianUK> I think the nays have it
17:23:25 <dcr226> yep
17:23:57 <dcr226> ok then, next bit I wanted to add
17:24:16 <dcr226> #idea allow a bugzilla bot alias to query for outstanding bugs
17:24:30 <dcr226> ok, so we already discussed this...and again...it was just an idea
17:24:31 <DiscordianUK> on main?
17:24:52 <dcr226> but I thought it might be handy to @query a given error message and see if something is already in bz for it
17:25:16 <DiscordianUK> It might be useful
17:25:27 <EvilBob> Anything that accepts commands from the channel or spews crap to the channel beyond what we already have is a bad idea IMO
17:25:30 <DiscordianUK> I'm 0 on this
17:25:34 <dcr226> so if you are digging around at someones "pulseaudio failed to do foobar" you could @query pulseaudio foobar
17:25:42 <EvilBob> It can be abused and will be just by those wanting to have fun
17:25:55 <nirik> I think it's likely to be too noisy I fear.
17:26:04 <nirik> we could restrict it to ops/known folks
17:26:07 <nirik> but even so
17:26:07 <EvilBob> we have enough general crap in #fedora we don't need added dickhead noise added to it.
17:26:18 <dcr226> I tend to agree (again on reflection)...however, maybe there is middle ground
17:26:25 <DiscordianUK> +1 to restricted to ops
17:26:39 <dcr226> maybe if ops knew how to effectively use that plugin via /pm to the bot, it might prove handy?
17:26:44 <dcr226> not sure about implementation
17:27:07 <EvilBob> -1 period
17:27:27 <nirik> well, it's likely easier to use a browser. ;)
17:27:29 <EvilBob> this functionality exists with zodbot and the bugz alias
17:27:41 <nirik> EvilBob: not quite
17:27:44 <EvilBob> bugz.fp.o
17:28:02 <nirik> those give you a specific bug or a list of all bugs on a package.
17:28:11 <dcr226> yeah, ok...maybe not a really good idea (I can't have the awesome ideas every week) ;-)
17:28:12 <nirik> query gives you bugs that match some string, right?
17:28:17 <dcr226> correct
17:28:51 <dcr226> I can't dig out an example right this second, but @query some error message package would search it
17:29:24 <dcr226> but yeah, if you hit it with a package name only (pulseaudio/systemd/rhythmbox) it'll spam
17:29:38 <nirik> yeah, sadly, most packages have lots of bugs. ;)
17:29:45 * dcr226 nods
17:29:53 <dcr226> ok...so we're a no-go on that one :-)
17:30:07 <dcr226> #action no bugz from fedbot on #fedora
17:30:21 <Affix> dcr226: you could make the bugs return the most popular
17:30:23 <nirik> I have another related item. ;)
17:30:33 <nirik> Affix: popular based on what?
17:30:41 <Affix> based on number of reports
17:30:44 <dcr226> Affix, its awkward...have a play with it on -botgames and you'll see it can be tricky
17:30:45 <Affix> or number of comments
17:31:07 <EvilBob> @query abrt
17:31:10 <nirik> sadly, some bugs with lots of comments are not popular, they just have someone who wants an argument on them. ;)
17:31:12 <EvilBob> That would blow it up
17:31:17 <dcr226> fedbot and TheFBI both have bugzilla loaded, TheFBI won't ignore you...so you can play around
17:31:23 <dcr226> EvilBob, lol
17:31:26 <EvilBob> let that spew to the channel for a month
17:31:40 <dcr226> wait a second.... Process /usr/bin/ballbuster was killed by signal 6 (SIGABRT)
17:31:47 <dcr226> ??? what are we packaging here? ;-)
17:31:58 <Affix> ha
17:32:11 <dcr226> kidding....go for it nirik , you might want to change #topic though (I forgot)
17:32:49 <nirik> #topic another bug idea
17:32:57 <nirik> oh, not a chair. ;)
17:33:00 <nirik> anyhow, another idea:
17:33:01 <dcr226> #topic another bug idea
17:33:30 <nirik> allow fedbot to snaf 'bug xxxx' from the channel and show a link to the bug. Again this could be abused, but I think it would be quite handy...
17:33:50 <nirik> so when a user says "I have bug foo" we can see it and click on it easily.
17:33:51 <Affix> nirik: simply modifying the youtube script could possibly do that
17:34:02 <dcr226> Affix, the functionality is already there
17:34:06 <nirik> Affix: the bugzilla plugin does it. It's just a config change.
17:34:19 <Affix> nirik: ahh I didn't know that :)
17:34:25 <nirik> granted some people will abuse by saying lots of bug stuff. but we can tell them to not do that...
17:34:36 <dcr226> and fedbot will ignore them after 3
17:34:42 <DiscordianUK> indeed
17:34:43 <dcr226> zod wont
17:34:43 <nirik> dcr226: sadly no.
17:34:49 <dcr226> nirik, eh? should do
17:34:50 <nirik> it's a snarf...
17:34:53 <nirik> it's not a command
17:35:07 <nirik> it watches the channel for the string "bug XXXXX" and looks it up.
17:35:07 <dcr226> ok, well....I think there's a way around that if needed
17:35:23 <dcr226> yeah, I think we could use MessageParser to turn it into an aliased command
17:35:23 <nirik> yeah, we could hack in a ignore I suppose.
17:35:38 <EvilBob> So bug #969
17:35:40 <dcr226> get mp to look for bug NNNN and trigger alias
17:35:43 <dcr226> EvilBob, yeah, like that
17:35:47 <EvilBob> would barf up a URL
17:35:52 <nirik> yeah...
17:35:53 * dcr226 nods
17:36:12 <EvilBob> but that damn bug was biting me would not
17:36:23 <dcr226> no
17:36:42 <nirik> needs numeric I think.
17:36:46 <dcr226> its quite cute, and can be regex'ed moreso with MessageParser if need be
17:36:52 <nirik> but we could make the parser match on most anything right?
17:36:58 <dcr226> yep
17:37:10 <nirik> bug #nnn or bug nnn only
17:37:16 <dcr226> so long as you can explain it in a regex then yeah
17:37:41 <N3LRX> I think #nnnn is the best approach.
17:38:05 <nirik> most people don't use #, so I would say either should be acceptable.
17:38:11 <EvilBob> N3LRX: But users are... well they will screw it
17:38:17 * dcr226 is +1 to having it snarf, we can figure the regex....I think it will be handy, and we can shut it off if needed
17:38:49 <EvilBob> What about the bugzilla URL translation like youtube
17:38:56 <dcr226> it does that also
17:39:02 <Affix> EvilBob: Thats what I was thinking about
17:39:14 <EvilBob> I have <some long URL> WHat do you think?"
17:39:17 <nirik> yeah, bugzilla plugin does that.
17:39:33 <EvilBob> Well I think you should tell me what it is so I do't have to click on it
17:40:06 <dcr226> yeah, handy
17:40:10 <dcr226> its quite a nice plugin
17:40:34 <N3LRX> I have a modified script in xchat that already posts a link to me whenever someone posts #nnnn. It used to convert every #nnnn to debian bugz, but I changed it to reflect bugzilla.redhat.com instead.
17:40:37 <nirik> so, how about we enable it, revisit next week and see what a mess it's made? and disable anytime it's causing problems.
17:41:08 <dcr226> +1 i'm sold
17:41:12 <Affix> +1 me too
17:41:21 <EvilBob> as long as it is not the example I exploited, I'm fine with it
17:41:22 <dcr226> EvilBob, happy medium?
17:41:24 <dcr226> ah
17:41:27 <EvilBob> @query abrt
17:41:28 <DiscordianUK> +1
17:41:30 <dcr226> noooo
17:41:57 <EvilBob> That is so much fun
17:42:02 * dcr226 still thinks bug 677202 is funny
17:42:15 <EvilBob> @query asshole
17:42:18 <Affix> dcr226: I know what it is. Its a game
17:42:23 <EvilBob> damn
17:42:29 <dcr226> Affix, doesn't make it less funny ;-)
17:42:50 <dcr226> so, we're good on that then....no -1's ;-)
17:43:09 <dcr226> #action enable fedbot's bugzilla snarfer on #fedora...trial, can revisit
17:43:27 <dcr226> nirik, good with that?
17:43:48 * dcr226 guesses so
17:43:53 <dcr226> #topic open floor
17:44:22 <dcr226> anyone have anything for open floor?
17:44:24 <Affix> maybe have a fedora planet announce on -social
17:44:27 <nirik> sure.
17:44:37 <EvilBob> Huh?
17:44:44 <dcr226> Affix, thats EvilBob and co's domain
17:44:59 <Affix> like when fedora planet gets updated it's announced to the channel
17:45:03 <dcr226> like this
17:45:04 <dcr226> @rss http://planet.fedoraproject.org/rss20.xml 1
17:45:12 <Affix> dcr226: exactly
17:45:15 <nirik> don't think it's loaded.
17:45:16 <dcr226> maybe not enabled
17:45:18 <dcr226> ah
17:45:21 <nirik> zodbot has rss loaded.
17:45:29 <Affix> and it won't post stuff thats been announced before
17:45:42 <Affix> I also suggest you take a look at that bash script ;)
17:45:46 <N3LRX> that would be allot of noise in the channel. Planet is updated way too often it would be an endless stream. -1
17:45:49 <EvilBob> Affix: Even the planet reposts stuff
17:45:49 <dcr226> shameless plug
17:46:04 <EvilBob> Yeah -1
17:46:05 <Affix> ok Was just a suggestion
17:46:09 * Southern_Gentlem here
17:46:25 <DiscordianUK> I'm -1 for the planet updating noted on channel
17:46:32 * dcr226 is -1, I'm in charge of annoying the whole of -social
17:46:33 <EvilBob> install TabMix Plus in Firefox set it to auto-reload
17:46:39 <Southern_Gentlem> -1
17:46:51 <dcr226> ;-)
17:47:53 * nirik doesn't much care either way, but looks like the -1's have it
17:48:06 <dcr226> Affix, nice idea though, just would get messy I fear
17:48:15 <Affix> i suppose it would
17:48:21 <dcr226> we could have a middleground @planet alias (similar to @bacon) if folks really wanted
17:48:37 <Affix> that would be pretty nice
17:48:41 <EvilBob> Set up on JerkMeOffBot in -gamesbot or what ever
17:48:48 <dcr226> LOL#
17:48:51 <Affix> instead of messaging to channel it could send a notice
17:48:56 <DiscordianUK> I'd agree to @planet
17:49:01 <DiscordianUK> +1
17:49:03 <Affix> +1
17:49:06 <EvilBob> -1
17:49:18 <dcr226> EvilBob, -NickServ- jerkmeoffbot is not registered.
17:49:20 <dcr226> thanks ;-)
17:49:31 <EvilBob> Alt+Tab Ctrl+R
17:49:39 <DiscordianUK> Then it fails
17:49:40 <EvilBob> DONE
17:50:18 <dcr226> sooo....are we going to trial it until someone gets annoyed?
17:50:28 <EvilBob> I want an IRC bot to help me with my... well really I just want it to help me be lazy"
17:50:36 <EvilBob> -1 trial
17:50:54 <nirik> this would be the top entry?
17:50:57 <nirik> or ?
17:51:09 <dcr226> nirik, yeah
17:51:21 <dcr226> @rss http://planet.fedoraproject.org/rss20.xml 1
17:51:23 <dcr226> like that
17:51:28 <nirik> if it's only one link, I'm ok with it. If it's more then it's too noisy. ;)
17:51:31 <EvilBob> @rss http://planet.fedoraproject.org/rss20.xml 1
17:51:36 <EvilBob> I know it will change soon
17:51:40 <EvilBob> @rss http://planet.fedoraproject.org/rss20.xml 1
17:51:46 <EvilBob> Really it will
17:51:48 <EvilBob> @rss http://planet.fedoraproject.org/rss20.xml 1
17:51:56 <dcr226> HAHAHAHA
17:51:57 <Affix> EvilBob: its been mine for 6 hours
17:52:01 <EvilBob> Just wait I promise it will change
17:52:01 <EvilBob> @rss http://planet.fedoraproject.org/rss20.xml 1
17:52:04 <DiscordianUK> the planet isn't that busy
17:52:05 <dcr226> +1 trial, it won't hurt
17:52:19 * dcr226 doubts it'll get used after a bit anyway
17:52:22 * nirik makes a quick planet post saying "Hi irc bot"
17:53:01 <dcr226> ok...anything else?
17:53:19 <N3LRX> +1 trial if it gets abused it can be shut off.
17:54:04 <EvilBob> Oh I'll I abuse it so don't turn it on
17:54:16 <dcr226> I have permission to pull it back out quickly, as does nirik and I think nb
17:54:52 <Affix> have an if statement to stop EvilBob using it
17:54:59 <dcr226> that would end badly
17:54:59 <EvilBob> Seriously?
17:55:11 * dcr226 moves on quickly
17:55:14 <dcr226> anything else?
17:55:17 <EvilBob> You can't open a freaking browser window and look to see if it's been updated?
17:55:22 <EvilBob> WHat's next?
17:55:36 <dcr226> I think we're about done
17:55:43 <EvilBob> How lazy do you have to be?
17:56:03 * dcr226 will close up in a sec
17:56:36 <dcr226> thanks everyone!!
17:56:40 * dcr226 bacon for the logger
17:56:43 <dcr226> #endmeeting