17:00:57 <sochotnicky> #startmeeting Java SIG -- https://fedoraproject.org/wiki/SIGs/Java
17:00:57 <zodbot> Meeting started Tue Oct  5 17:00:57 2010 UTC.  The chair is sochotnicky. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:57 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:01:33 <mbooth> Hi... I'm working away and on a low bandwidth link, so apologies in advance if I disappear
17:01:52 <sochotnicky> #meetingname java-sig
17:01:52 <zodbot> The meeting name has been set to 'java-sig'
17:02:13 <sochotnicky> mbooth: ok, ruly noted :-)
17:02:20 <sochotnicky> #topic roll-call
17:02:32 <orionp> here
17:02:34 <sochotnicky> so who do we have here for java-sig meeting?
17:02:41 <cspike> heyho, i'm here
17:02:44 <akurtakov_> me too
17:03:18 <sochotnicky> #info orionp cspike akurtakov sochotnicky here
17:03:54 <sochotnicky> hmm, we'll have to develop some way of figuring out who is actually active and trying to do something besides writing their name on wiki..
17:04:12 <sochotnicky> I don't mind people not not doing anything, there are millions of reasons why that could happen..
17:04:24 <sochotnicky> but at least a courtesy email would be nice..
17:04:26 <sochotnicky> oh well
17:04:53 <sochotnicky> #topic maven-3 update and dependencies
17:05:05 <cspike> is there a problem with people being on the list and not doing something? i mean, we all know each other...
17:05:17 <cspike> never mind
17:05:17 <sochotnicky> I am currently stuck on google-guice library. It's a real piece of work
17:05:44 <sochotnicky> cspike: I meant people listed on https://fedoraproject.org/wiki/SIGs/Java#Members
17:05:54 <sochotnicky> anyway...we can talk about it later on
17:06:30 <sochotnicky> the guice uses custom ant task coming from unknown source
17:06:47 <akurtakov_> sochotnicky: how is it named?
17:06:54 <sochotnicky> akurtakov_: Munge
17:06:57 <akurtakov_> someone may have seen it
17:08:13 <sochotnicky> akurtakov_: true, source files are mixture of few licenses...I'll see what can be done
17:08:34 <sochotnicky> fortunately jarjar was updated recenly in rawhide..otherwise that would have been dependency too
17:08:50 <sochotnicky> #info google-guice is giving sochotnicky a hard time
17:09:00 <sochotnicky> there are still ways people can help out..
17:09:18 <sochotnicky> #info possiblity to help out by helping package maven-aether
17:09:47 <akurtakov_> maven-aether is depending on aether
17:10:06 <akurtakov_> so this are going to be >=2 packages?
17:10:23 <sochotnicky> akurtakov_: yes, I am guessing...I have just seen the artifactIds
17:10:57 <sochotnicky> #info animal-sniffer and mojo-signatures are packaged as is atinject
17:11:09 <akurtakov_> anyother known missing dependency?
17:11:56 <sochotnicky> akurtakov_: there are few sisu-X packages, but since we dropped sisu-guice for google-guice ...hard to tell
17:12:22 <cspike> sochotnicky: maybe it's a good idea to keep http://fedoraproject.org/wiki/MavenUpdate up2date
17:12:27 <akurtakov_> sochotnicky: sisu is renamed spice
17:12:35 <sochotnicky> akurtakov_: yes I know
17:12:49 <sochotnicky> cspike: true
17:12:55 <akurtakov_> so we will have to get at least the plexus integration part of sisu
17:12:56 <sochotnicky> #action update MavenUpdate wiki
17:13:25 <cspike> sochotnicky: may be trivial, but it's much simpler to find out what's going on
17:13:25 <sochotnicky> one way or the other...not fun
17:13:46 <sochotnicky> cspike: correct but since noone contacted me about it yet...
17:14:11 <sochotnicky> keeping it up-to-date just for my sake seems like I could be spending my time actually doing stuff
17:14:21 <sochotnicky> anyway...I'll update it
17:14:29 <cspike> thanks :)
17:14:56 <sochotnicky> #topic list of critical java packages
17:15:34 <sochotnicky> hmm, I don't think we had much done...but I believe cspike had a good idea..
17:15:55 <sochotnicky> make a wiki, and everyone can add packages that he/she wants to have monitored
17:16:00 <sochotnicky> gonna be much easier
17:16:07 <akurtakov_> I agree
17:16:10 <sochotnicky> at least to start with
17:16:21 <mbooth> Eclipse dep chain? ;-)
17:16:32 <cspike> we could start with the maven/ant stuff and maybe add some essential development libs like the apache-commons
17:16:51 <sochotnicky> #action sochotnicky create wiki page for adding java pkg commit monitoring
17:17:36 <akurtakov_> mbooth: essentially yes, if you can build all eclipse deps you've got ant+maven in a good shape
17:17:45 <cspike> at least, the provenpackages of javasig should have commit access to those packages to help out
17:17:46 <sochotnicky> #action cspike akurtakov_ mbooth sochotnicky add your important packages to monitoring
17:19:30 <sochotnicky> ok, going on..
17:19:37 <sochotnicky> #topic New packaging guidelines
17:19:43 <sochotnicky> akurtakov_: any news?
17:20:11 <akurtakov_> I finally got Eclipse SDK 3.6.1 in rawhide (today)
17:20:41 <mbooth> Nice one
17:20:42 <akurtakov_> and I've copied the current guidelines to my own page which I'm starting to edit
17:21:03 <akurtakov_> getting 3.6.1 was the sole blocker for any other work for me
17:21:32 <sochotnicky> ok, so you'll have more time on your hands now I see :-)
17:21:43 <akurtakov_> I will have rough updated version by the end of the week
17:21:49 <cspike> akurtakov_: could you add a link to the javasig wiki page?
17:21:51 <sochotnicky> anyway...have a link?
17:22:21 <akurtakov_> https://fedoraproject.org/wiki/User:Akurtakov/JavaPackagingDraftUpdate
17:22:27 <akurtakov_> yep, but no change yet
17:22:38 <akurtakov_> feel free to monitor the page
17:23:04 <sochotnicky> #link https://fedoraproject.org/wiki/User:Akurtakov/JavaPackagingDraftUpdate page where new draft is being prepared
17:23:31 <sochotnicky> ok
17:23:35 <sochotnicky> #topic Java/FAQ and Java wiki update, GCJ split
17:24:04 <sochotnicky> bozhidar is not here, so I don't know..but I don't think I've seen any changes recently. Probably start of school intervened
17:24:05 <akurtakov_> bozhidar is not here and noone else volunteered
17:24:26 <sochotnicky> ok, let's move on..
17:24:34 <sochotnicky> we can revisit if time permits
17:24:40 <sochotnicky> #info deferred
17:24:56 <sochotnicky> #topic Java FTBFS status (and JakartaCommonsRename)
17:25:14 <sochotnicky> cspike: you've done some impressive work over last week or so in this area :-)
17:25:36 <cspike> thanks :)
17:25:38 <mbooth> I someone restarted the rename, thanks for that :-)
17:25:49 <cspike> mbooth: hope you don't mind actually...
17:25:55 <akurtakov_> mbooth: orionp: cspike has done them all, they are just pending reviews
17:26:13 <mbooth> Not at all, cspike
17:26:29 <sochotnicky> akurtakov_ meant all that were left :-)
17:26:39 <sochotnicky> at least I think he did
17:26:49 <cspike> yup, should be all
17:26:49 <akurtakov_> yep
17:27:22 <sochotnicky> great, so if you have time...go ahead and take a review or two..
17:27:27 <akurtakov_> about FTBFS I've got the same as 2 weeks before
17:27:28 <orionp> Is there a list of reviews to be done?
17:27:38 <akurtakov_> haven't looked at them at all
17:27:44 <cspike> orionp: links are on the wiki page
17:27:52 <sochotnicky> orionp: https://fedoraproject.org/wiki/JakartaCommonsRename#Progress
17:28:01 <sochotnicky> I already took -pool
17:28:14 <cspike> the rest is tbd
17:28:45 <cspike> you may also have a look at the pseudo bug https://bugzilla.redhat.com/show_bug.cgi?id=588764
17:28:54 <sochotnicky> right
17:29:12 <sochotnicky> #link https://bugzilla.redhat.com/show_bug.cgi?id=588764 tracking bug for jakarta rename (all reviews are blocking this)
17:29:52 <sochotnicky> anyone have problem with FTBFSs?
17:30:04 <mbooth> There is also a bug for editing comps when they are done
17:30:20 <akurtakov_> I've got a problem with FTBFS
17:30:24 <akurtakov_> no time for them
17:30:53 <sochotnicky> akurtakov_: :-)
17:30:57 <sochotnicky> akurtakov_: which are they?
17:31:48 <sochotnicky> cspike: you were also trying to contact fnasser. Did you succeed?
17:32:01 <cspike> sochotnicky: i did?
17:32:19 <akurtakov_> sochotnicky: 631347, 631388, 631430, 631461
17:32:19 <sochotnicky> ah, sry...mbooth..
17:32:43 <sochotnicky> #info help with FTBFSs 631347, 631388, 631430, 631461 would be appreciated
17:33:03 <cspike> fnasser was on #fedora-java today btw...
17:33:17 <akurtakov_> he still is
17:35:25 <sochotnicky> mbooth: still here?
17:35:46 <sochotnicky> ok, let's assume he got in touch or will soon :-)
17:36:06 <sochotnicky> anything else to add to FTBFSs?
17:36:23 <sochotnicky> #topic Eclipse Helios SR1 update
17:36:34 <sochotnicky> akurtakov_: I believe this was your addition?
17:36:45 <akurtakov_> yes
17:37:00 <sochotnicky> don't be afraid to use #info :-)
17:37:04 <akurtakov_> so we have Eclipse SDK 3.6.1 in rawhide
17:37:35 <akurtakov_> all Eclipse plugins part of Helios will be updated shortly
17:38:04 <akurtakov_> mbooth: it would be nice if you push your eclipse plugins to SR1 too
17:38:33 <mbooth> Sure, will do that later in the week
17:38:36 <akurtakov_> updates for F-14 will be pushed too, unless someone objects
17:38:59 <akurtakov_> orionp: eclipse-ptp can get an update to SR1 too
17:39:07 <akurtakov_> it is part of helios, right?
17:39:17 <sochotnicky> #info Eclipse SDK 3.6.1 in rawhide, preparing for F-14 update push as well
17:40:25 <akurtakov_> we would really like to get some testing and karma
17:40:39 <cspike> ack
17:41:03 <sochotnicky> akurtakov_: send an email to java ML once updates are ready
17:41:13 <akurtakov_> sure
17:41:17 <sochotnicky> or even devel IMO
17:41:24 <sochotnicky> it's quite widely used package...
17:41:54 <akurtakov_> yeah, and the driving force behind java in fedora for years
17:41:57 <orionp> ptp is at SR1 in F14 now
17:42:15 <akurtakov_> orionp: cool, you were faster
17:42:48 <akurtakov_> time for open floor ?
17:42:52 <sochotnicky> seems another big update is behind us..
17:42:53 <sochotnicky> yeah
17:42:57 <sochotnicky> #topic open-floor
17:43:16 <akurtakov_> we have tomcat5 installed pretty much always
17:43:27 <cspike> sochotnicky: there are a few updates to apache-commons packages to do (see bugzilla). since i use quite a few of those libs quite regularly i really care for them. do you want me to do those updates for you?
17:43:29 <akurtakov_> but it FTBFS for at least 2 releases
17:44:02 <sochotnicky> cspike: if you don't mind...just ask for ACLs
17:44:11 <cspike> will do
17:44:16 <sochotnicky> akurtakov_: hmm, not good
17:44:34 <akurtakov_> I would ask all active maintainers to look at their packages and look for a way to move to tomcat6
17:44:43 <sochotnicky> another action: try to get rid of tomcat5
17:44:52 <akurtakov_> it's gonna be slow
17:45:10 <akurtakov_> first thing is maven
17:45:14 <sochotnicky> I would suggest making a list of packages depending directly on tomcat5
17:45:23 <sochotnicky> or servlet-api-2.4 or other aliases
17:45:39 <sochotnicky> and send that cross-referenced with maintainers
17:45:46 <sochotnicky> it makes people more cooperative IMO
17:45:55 <sochotnicky> I know it would help me :-)
17:46:04 <orionp> There doesn't seem to be much
17:46:58 <orionp> glite-security-trustmanager-tomcat5, logback, maven-project-info-reports-plugin,struts-webapps-tomcat5, tomcatjss
17:47:47 <sochotnicky> orionp: did you include old servlet-api too?
17:48:24 <orionp> Holdon
17:48:41 <orionp> servlet24 -> apache-commons-fileupload, httpunit
17:48:59 <orionp> servlet_2_4_api -> groovy
17:50:10 <orionp> servletapi5 -> apache-commons-configuration, apache-commons-jxpath, castor-demo,glite-security-trustmanager, glite-security-util-java, hsqldb, jakarta-taglibs-standar, kawa, struts, velocity, xmlrpc
17:50:41 <sochotnicky> hmm, velocity and xmlrpc are mine...
17:51:09 <sochotnicky> orionp: are you willing to make a list and send it to the mailing list?
17:51:16 <sochotnicky> seems like you have it almost done :-)
17:51:22 <orionp> sure
17:51:27 <sochotnicky> great
17:51:37 <akurtakov_> jsp api need to be checked too
17:51:43 <mbooth> Can you add this list to the wiki or open a bug, maybe?
17:52:07 <sochotnicky> seems like a good tracking bug..
17:52:25 <orionp> sure.  Were to put the link to the wiki page?
17:53:04 <sochotnicky> hmm, not sure
17:53:14 <akurtakov_> https://fedoraproject.org/wiki/SIGs/Java#Tasks ?
17:53:41 <sochotnicky> orionp: ^^ probably
17:53:46 <sochotnicky> will need cleaning up a bit
17:54:23 <cspike> actually, there should be more action items from the minutes go into https://fedoraproject.org/wiki/SIGs/Java#Tasks. if someone wants to help out, that's probably where he starts...
17:54:56 <cspike> just to inform people out there what we are doing
17:55:09 <sochotnicky> maybe a dedicated "How can I help out" section?
17:55:22 <sochotnicky> some low-hanging fruit
17:55:36 <cspike> i think everything lowering the threshold would be nice
17:56:13 <Froolap> why can't grub use the same drive assignments as everything else?
17:56:15 <akurtakov_> if we manage to get rid of tomcat5 for F15 it will be a real success
17:56:15 <sochotnicky> cspike: will you help me out with clearing it up a bit?
17:56:25 <sochotnicky> Froolap: wrong channel
17:56:34 <cspike> sochotnicky: sure
17:56:38 <akurtakov_> most problematic will be packages that are using jasper api
17:56:46 <Froolap> sochotnicky: I wasn't asking for help.
17:57:03 <sochotnicky> #action sochotnicky cspike add more information from meeting minutes to the wiki tasks section and low-hanging problems for newcomers
17:57:29 <sochotnicky> Froolap: still wrong channel :-)
17:57:37 <sochotnicky> ok, I guess we have 3 minutes left...
17:57:42 <sochotnicky> any last-minute wishes?
17:58:04 <sochotnicky> #endmeeting