15:09:41 <Kevin_Kofler> #startmeeting KDE SIG Meeting
15:09:41 <zodbot> Meeting started Tue Apr  1 15:09:41 2014 UTC.  The chair is Kevin_Kofler. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:09:41 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:09:45 <Kevin_Kofler> #meetingname kde-sig
15:09:45 <zodbot> The meeting name has been set to 'kde-sig'
15:09:47 <Kevin_Kofler> #topic Role call
15:09:48 * tosky is here
15:09:55 * Kevin_Kofler is present, who else?
15:10:00 * dvratil is here
15:10:03 <rdieter> ere
15:10:14 <pino|work> ← zombie
15:10:28 * rdieter feeds pino|work some brains
15:11:00 * rkratky is here
15:11:45 <Kevin_Kofler> ltinkl, than: ping
15:11:52 * ltinkl is here
15:12:00 <Kevin_Kofler> jreznik_q10: ping
15:12:14 <than> present
15:12:19 * jreznik_q10 is semi-here
15:12:41 <Kevin_Kofler> #chair tosky dvratil rdieter pino|work ltinkl than jreznik_q10
15:12:41 <zodbot> Current chairs: Kevin_Kofler dvratil jreznik_q10 ltinkl pino|work rdieter than tosky
15:12:49 * Martix is here
15:13:22 <Kevin_Kofler> #info Kevin_Kofler, tosky, dvratil, rdieter, pino|work, rkratky, ltinkl, than, jreznik_q10, Martix present.
15:13:25 <Kevin_Kofler> #topic Agenda
15:13:47 <Kevin_Kofler> So, I suppose an update on the eternal Plasma Product saga?
15:14:13 <tosky> I guess it can be summarized as "Product on hold for now"
15:14:55 <Kevin_Kofler> Anything else to discuss?
15:15:17 <Kevin_Kofler> The browser flamew… uh… discussion? ;-)
15:15:36 <Kevin_Kofler> Meh, let's start with the Product thing.
15:15:45 <Kevin_Kofler> #topic Plasma Product / Future of the KDE Spin
15:15:58 <Kevin_Kofler> So, where are we going now?
15:16:48 <Kevin_Kofler> FESCo OKed the product for no earlier than F22 (not F21), contingent on Board approval, the Board seems not happy with where we are going.
15:17:00 <Kevin_Kofler> It looks like they'd only be willing to approve a Product that is:
15:17:09 <ltinkl> is there any output from the board discussion? (the ticket is private)
15:17:25 <Kevin_Kofler> 1. completely use-case-oriented and technology-agnostic (which Workstation CLAIMS to be, but is clearly not, grrr…) and
15:17:39 <rdieter> I think it's premature to respond to feedback that doesn't exist yet
15:17:49 <sgallagh> There has been a request to publicize the content of that discussion on the Board ticket. Should happen tomorrow.
15:17:54 <Kevin_Kofler> 2. totally disjoint in its user base to Workstation, which doesn't seem a realistic or reasonable requirement to me at all.
15:18:02 <rdieter> (hint: borad discussions are ongoing, no consensus yet)
15:18:05 <Kevin_Kofler> Some FESCo members also share that view.
15:18:31 <ltinkl> we should really put this on hold until we have some concrete output from Board
15:18:37 <rdieter> ltinkl: +1
15:18:57 <dvratil> +1
15:18:58 <rdieter> but sgallagh is right, the feedback should come real soon
15:18:58 <ltinkl> otherwise we're chasing a moving target
15:19:04 <dvratil> yes
15:19:10 <Kevin_Kofler> ltinkl: +1, I thought that the discussion on the public advisory-board ML would be an indication of what's going on.
15:19:19 <Kevin_Kofler> But it looks like it's all being discussed in the private ticket.
15:19:30 <Kevin_Kofler> (according to what rdieter and ltinkl are saying)
15:19:40 <Kevin_Kofler> <SARCASM>Hooray for transparency!</SARCASM>
15:19:43 <sgallagh> Kevin_Kofler: Apparently, the Fedora Project Board doesn't use advisory-board for official discussions.
15:19:47 <sgallagh> (I am annoyed by this as well)
15:19:54 <rdieter> yay for having a silly private trac instance
15:19:54 <Kevin_Kofler> This is like the WTO, everything important is discussed in secret meetings.
15:20:09 <rdieter> sgallagh: I wish it was more like that too
15:20:25 <Kevin_Kofler> The Trac should be public to begin with.
15:20:29 <ltinkl> let's rather discuss the KDE spin for now
15:20:51 <rdieter> Kevin_Kofler: the idea is the private trac instance is supposed to be only for private stuff.  it's being a little abused for this topic (imho)
15:21:03 <Kevin_Kofler> And private stuff would be?
15:21:12 <rdieter> legal stuff
15:21:57 <Kevin_Kofler> Fedora is a public project, even things that are IMHO privacy-sensitive like the precise tickets for every reimbursement are discussed in public Trac instances, I don't see why the Board has to be an exception.
15:22:39 <rdieter> offtopic for this meeting
15:22:46 <Kevin_Kofler> Right.
15:23:02 <Kevin_Kofler> So, for F21, we'll definitely not be a Product? Or could the Board overrule FESCo on that?
15:23:20 <Kevin_Kofler> I.e. can we start discussing the Spin for F21 now?
15:23:23 <rdieter> again, speculation
15:23:37 <rdieter> what we *do* know, is there will be a kde spin, so yeah, let's discuss that
15:23:49 <sgallagh> rdieter: I generally think that's a fair assessment. FESCo will accept a Board decision to add a Product, but not mid-cycle I think.
15:24:24 <Kevin_Kofler> sgallagh: What a lame excuse. We wanted to be part of it from day 1, we were told to wait, that's why we are mid-cycle. :-/
15:24:48 <Kevin_Kofler> Also, your "mid"-cycle is actually longer than the regular Fedora release cycle.
15:25:08 <Kevin_Kofler> #topic F21 KDE Spin
15:25:28 <rdieter> Kevin_Kofler: different people saying different things, mixed messages.  its ok, trying to build consensus around fedora.next
15:25:35 <rdieter> it obviously means different things to different people
15:25:58 <Kevin_Kofler> So ltinkl and rdieter say we should discuss the Spin, is there even anything worth discussing?
15:26:09 <ltinkl> sgallagh: fair enough, we're in mid-cycle, but if you look at e.g. the Cloud product (already approved for F21), you will see that it's far behind us
15:26:12 <sgallagh> Kevin_Kofler: you may have noticed that I've been advocating in favor of KDE on FESCo. Please do not assume I'm trying to mislead you...
15:26:19 <Kevin_Kofler> The KDE Spin can just continue as we've always done it.
15:26:31 <ltinkl> sgallagh: for example I'm not seeing any PRD at all for Cloud
15:26:41 <Kevin_Kofler> sgallagh: I was shooting the messenger, sorry.
15:26:57 <rdieter> Kevin_Kofler: <nod>, though we could choose to implement some of the plasma product ideas sooner rather than later
15:27:11 * ltinkl has to leave in a few
15:27:13 <Kevin_Kofler> I realize you're just reporting the excuses some OTHER FESCo members are coming up with, sigh…
15:27:57 <rdieter> for example, I still think the "default browser" discussion is relevant
15:28:01 <Kevin_Kofler> rdieter: Hopefully not the Firefox thing (assuming it even wins that vote to begin with, right now it's tied with Rekonq).
15:28:17 <ltinkl> anyways, I think we should go thru the technical aspects of the Plasma Product and apply it now to the KDE spin
15:28:20 <Kevin_Kofler> (You were faster. ;-) )
15:28:28 <Martix> I agree with ltinkl, we can change remix to be more closer to our PRD specification
15:28:40 <ltinkl> things like the default web browser (cough), defaults apps in general, etc.
15:28:44 <Kevin_Kofler> Martix: Don't use the term "remix" to begin with!
15:28:46 <rdieter> ok, any low-hanging fruit to consider first?
15:28:48 <Kevin_Kofler> It's a non-starter.
15:29:08 <Kevin_Kofler> FESCo already approved us as an official Spin, and even release-blocking for F21, not just a Remix.
15:29:12 <ltinkl> mostly stuff in https://fedoraproject.org/wiki/Fedora_Plasma_Product/Integration
15:29:16 <rdieter> no need to be pedantic over terminoligy
15:29:32 <Martix> Kevin_Kofler: tomatoes & tomatos
15:29:41 <ltinkl> those could/should be done immediately
15:29:42 <Kevin_Kofler> Martix: A Remix is something unofficial.
15:30:00 <Kevin_Kofler> ltinkl: They don't want the Plasma Product for F21, they won't get the Plasma Product for F21.
15:30:23 <ltinkl> Kevin_Kofler: this is stuff that also applies to the KDE spin
15:30:27 <Kevin_Kofler> The integration stuff, where it's really KDE stuff, fine.
15:30:31 <Kevin_Kofler> (like kimpanel etc.)
15:30:35 <rdieter> ltinkl: most of those match the status quo.  differences I see offhand include: kde-connect, kimapplet, amarok
15:30:43 <Kevin_Kofler> Firefox, G* or other non-KDE libs, etc., no thanks.
15:30:46 <ltinkl> rdieter: oxygen font
15:30:55 <rdieter> is that even packaged yet?
15:30:56 <Martix> I think KDE WG should vote about default web browser :-)
15:31:14 <rdieter> Martix: we're still tallying votes
15:31:27 <Kevin_Kofler> Martix: There is a vote. It's for the Plasma Product (and the WG isn't relevant for the Spin to begin with, the Spin is a SIG matter, not a WG one :-p ).
15:31:28 <ltinkl> rdieter: no, not yet, Jonathan Riddel is prepping the release
15:31:40 <Martix> Kevin_Kofler: ok, so SIG
15:31:40 <Kevin_Kofler> It's also currently tied, with 4 people left to vote.
15:31:42 <rdieter> ltinkl: ok, so can't implement it yet. :)
15:31:59 <rdieter> Plasma WG members, please vote: https://fedoraproject.org/wiki/Talk:Fedora_Plasma_Product/Integration
15:32:01 <ltinkl> rdieter: right but the (semi)official tarball is there already in the review board
15:32:05 <Kevin_Kofler> For the Oxygen fonts, what's the benefit over DejaVu?
15:32:16 <Kevin_Kofler> AFAIK, Oxygen doesn't have nearly the glyph coverage DejaVu has.
15:32:28 <Kevin_Kofler> And DejaVu is not a GNOME font. ;-)
15:32:41 <rdieter> ltinkl: I think its premature to talk about using something by default, before it's even been packaged and is testable
15:32:45 <Kevin_Kofler> I'd understand the push for Oxygen if we were defaulting to Cantarell. ^^
15:32:46 <ltinkl> Kevin_Kofler: dejavu would be the fallback font, I guess xft can be configured that way
15:33:08 <ltinkl> rdieter: note it will be the default in Plasma 2 anyway
15:33:24 * ltinkl has to run now, for real :)
15:33:25 <Kevin_Kofler> rdieter: Also, the Oxygen Fonts are being renamed to Comme.
15:33:25 <rdieter> upstream default at least
15:33:30 <ltinkl> rdieter: yes
15:33:41 <rdieter> (Id still like to reserve judgement until we see it in action)
15:33:54 <Kevin_Kofler> (Is that pronounced "Commy" ;-) )
15:34:40 <rdieter> I take it back, amarok *is* already included by default in kde spin
15:35:05 <rdieter> so easy stuff, Any objection to adding kde-connect, kimpanel bits to comps *now*
15:35:18 <Kevin_Kofler> I think kimapplet is the only big thing that's missing.
15:35:36 <Kevin_Kofler> Otherwise, there's only the browser debate and the theming thing.
15:35:44 <Kevin_Kofler> (where IMHO what we have right now on our Spin is fine!)
15:36:07 <Kevin_Kofler> Ah right, kimpanel is the name, not kimapplet, I'm fixing the wiki.
15:36:17 <Kevin_Kofler> The problem with kimpanel is, does it actually work out of the box?
15:36:29 <rdieter> <nod>, unless someone puts forth some specific proposal about theming changes, sticking with what we have makes the most sense
15:36:34 <Kevin_Kofler> Last I checked, there were issues with I-Bus packaging that made it not just work.
15:36:56 <rdieter> re: kimpanel, possible, we'll have to test and see
15:37:12 <Kevin_Kofler> (IIRC, some scripts in I-Bus need(ed) to be patched to not hardcode the GTK+ stuff.)
15:37:12 <rdieter> that's an area I have no clue about
15:38:31 <Kevin_Kofler> So it all comes down to the browser as the main issue.
15:38:51 <Kevin_Kofler> IMHO, for a KDE Spin, it's even more inappropriate to ship Firefox than for a Plasma Product.
15:38:55 <Kevin_Kofler> It just doesn't belong.
15:39:06 <Kevin_Kofler> It's not a KDE browser, it doesn't even have KDE integration.
15:39:48 <Kevin_Kofler> It doesn't even support KWallet without an unofficial, reportedly buggy, extension that we do not ship in Fedora.
15:40:10 * rdieter senses Kevin_Kofler repetition coming again
15:40:25 <rdieter> we've been through the debate, no need to rehash it again
15:40:29 <Kevin_Kofler> All the reasons in https://lists.fedoraproject.org/pipermail/kde/2014-March/013298.html apply also to the KDE Spin, some a lot more.
15:40:45 <Kevin_Kofler> rdieter: It's not the same thing, a KDE Spin is about being pure KDE.
15:40:52 <Kevin_Kofler> That's the point of having the spin.
15:40:54 <rdieter> Kevin_Kofler: to *you* maybe
15:41:15 <rdieter> to me, the difference between what we considered a product and spin should be approx the same
15:41:21 <Kevin_Kofler> There are also the space concerns.
15:41:41 <Kevin_Kofler> The target size for the KDE spin was 1 GiB, or even 1 decimal GB depending on whom you ask.
15:41:51 <Kevin_Kofler> Firefox is not going to make us fit that target.
15:42:04 <rdieter> <nod>, we're already adding more stuff, I doubt we can still fit in 1gb
15:42:29 <Kevin_Kofler> For the Plasma Product, we could discuss new size parameters, but for the F21 KDE Spin, we should not blow our target.
15:42:45 <rdieter> we can rebase what out target size is
15:42:50 <rdieter> (if we choose)
15:42:57 <Kevin_Kofler> (Sigh, that's another reason why I fought so hard for keeping CD size, it was a hard target that doesn't get rediscussed at every release.)
15:43:23 <rdieter> (I wanted 2gb before, but we compromised on 1gb  iirc)
15:43:25 <Kevin_Kofler> And what other "more stuff" do you want to add?
15:43:26 <tosky> is it possible to have real numbers for the space issue? It would be easier to compare stuff
15:43:31 <rdieter> kde-connect, kimpanel
15:43:48 <rdieter> (and ibus doo-dads that kimpanel needs)
15:43:49 <Kevin_Kofler> kde-connect isn't large, is it?
15:44:05 <Kevin_Kofler> kimpanel, I'd leave that out of the spin, to be honest.
15:44:21 <Kevin_Kofler> Input methods are just too large.
15:44:37 <Kevin_Kofler> And as I said, so far nobody has managed to make kimpanel Just Work on Fedora.
15:45:04 <Kevin_Kofler> Those who were interested didn't have the required expertise, those that could have pulled it off did not have the motivation.
15:45:59 <Kevin_Kofler> tosky: It's very hard to quantify the space, unfortunately.
15:46:06 <rdieter> tosky: what kind(s) of numbers are you interested in?
15:46:08 <Kevin_Kofler> Things change (usually for the worse) at every release.
15:46:21 <Kevin_Kofler> And there are dependencies shared among several packages.
15:46:29 <rdieter> tosky: like size requirements of each proposed addition?
15:46:35 <tosky> rdieter: exactly
15:46:42 <tosky> if you already have them
15:46:57 <Kevin_Kofler> So if you already ship input methods, kimpanel is a couple KiB.
15:47:01 <rdieter> ok, not offhand, but I'll see about coming up with some numbers and post onlist over the coming days
15:47:09 <tosky> I guess some data could be gained from an installed image, trying yum install
15:47:23 <Kevin_Kofler> On our spin, where so far we purposefully omitted them for size reasons, adding in input methods is dozens of MiB.
15:47:23 <tosky> live image I guess uses some more space than the installed one
15:47:36 <Kevin_Kofler> Live images are compressed.
15:47:36 <rdieter> it's hard to prejudge how much .iso space these takes, since it's a compressed filesystem
15:47:41 <Kevin_Kofler> So they take less space than installed.
15:47:56 <Kevin_Kofler> Typically approximately the size of the RPMs (which are compressed with the same technology, xz).
15:48:17 <Kevin_Kofler> What matters for the size targets is the compressed size.
15:48:30 <Kevin_Kofler> The uncompressed image is a lot larger, but it doesn't matter much.
15:48:55 <Kevin_Kofler> The only place it leaks through is the kickstart, where you have to give the size of the uncompressed file system to use, you get an error if it doesn't fit.
15:49:29 <rdieter> yeah, but that's just an implementation detail most folks don't need to care about
15:49:50 <Kevin_Kofler> I said the uncompressed size doesn't matter much. :-)
15:49:58 <Kevin_Kofler> What people see is the compressed size.
15:50:37 <rdieter> (sure, was just highlighting it's a detail not worth mentioning here even)
15:51:21 <tosky> I see, thanks
15:52:48 <Kevin_Kofler> Without even considering any dependencies, Firefox is 51 MiB compressed!
15:52:59 <Kevin_Kofler> A huge cost for a web browser.
15:53:12 <Kevin_Kofler> (Rawhide x86_64 RPM size)
15:53:33 <Kevin_Kofler> Rekonq is only 5.3 MiB (compressed).
15:53:53 <Kevin_Kofler> (and AFAIK has no dependencies that are not on the KDE Spin yet)
15:54:30 <rdieter> yeah, if we choose to continue with 1gb target, then ff is out of the running
15:54:32 <Kevin_Kofler> konqueror + konqueror libs are even only 2 MiB.
15:55:06 <Kevin_Kofler> (-libs is only 47 KiB, so the main package is what matters)
15:55:14 <Kevin_Kofler> Firefox is just too big.
15:55:33 <Kevin_Kofler> (The reason is obvious: It carries its own HTML engine, its own toolkit abstraction etc.)
16:00:31 <Kevin_Kofler> #topic Open discussion
16:00:37 <Kevin_Kofler> So, anything else before we close the meeting?
16:01:06 <Kevin_Kofler> We're out of time (WOOT ;-) ).
16:02:44 <jgrulich> I have just a quick info about KF5 Beta in dvratil's COPR repo, everything is done except kde5-* packages
16:02:58 <Kevin_Kofler> OK.
16:03:11 <jgrulich> we should probably start doing reviews soon
16:03:28 <Kevin_Kofler> #info KF5 Beta in dvratil's COPR repo all done, except workspace-related / Plasma Next (kde5-*) packages for now.
16:03:30 * dvratil plans to start this week
16:03:43 <dvratil> (with reviews)
16:03:49 <Kevin_Kofler> #action dvratil to start submitting review requests this week.
16:03:53 <dvratil> I'll look on kde5-* tonight/tomorrow
16:04:09 <Kevin_Kofler> #action dvratil to look into kde4-* tonight/tomorrow.
16:04:11 <Kevin_Kofler> Thanks!
16:04:21 <Kevin_Kofler> Looks like all the fun is on #fedora-kde now anyway, so thanks all for coming and bye!
16:04:25 <Kevin_Kofler> #endmeeting