15:07:47 <rdieter> #startmeeting kde-sig
15:07:47 <zodbot> Meeting started Tue Apr  7 15:07:47 2015 UTC.  The chair is rdieter. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:07:47 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:07:54 <rdieter> #meetingname kde-sig
15:07:54 <zodbot> The meeting name has been set to 'kde-sig'
15:07:54 <adamw> sigh, sorry folks
15:09:49 <rdieter> adamw: oops, did I goof?
15:09:58 <adamw> no, i goofed (the meeting hangover)
15:10:20 <rdieter> we can wait, if needed
15:10:27 <Kevin_Kofler> The QA meeting was left in an unclosed state.
15:10:28 <adamw> no, not at all. it was left over from yesterday.
15:10:31 <Kevin_Kofler> It's fixed now.
15:10:33 <rdieter> ok
15:10:40 <rdieter> #topic roll call
15:10:48 * jgrulich is present
15:10:48 <Kevin_Kofler> Present.
15:10:53 <rdieter> alrighty, who's present for a friendly kde-sig meeting today?
15:12:58 * tosky here
15:13:15 <dvratil> hi
15:13:47 <rdieter> #info rdieter jgrulich Kevin_Kofler tosky dvratil present
15:13:53 <rdieter> #chair jgrulich Kevin_Kofler tosky dvratil
15:13:53 <zodbot> Current chairs: Kevin_Kofler dvratil jgrulich rdieter tosky
15:14:13 <rdieter> #topic agenda
15:14:16 <rdieter> what to discuss today?
15:14:32 <rdieter> any status updates?
15:14:46 * dvratil will be building KF5 5.9.0
15:15:24 <pino|work> hey, there's me too (got distracted by $work)
15:15:27 <rdieter> dvratil: so need koji targets re-enabed ?
15:15:32 <dvratil> rdieter:  yes please
15:15:33 <rdieter> #info pino|work present too
15:15:47 <dvratil> though probably tomorrow is enough, I have other work for today
15:16:00 <Kevin_Kofler> I can give a short status update on the PK-hif comps saga.
15:16:29 <rdieter> ok, that's a good start, let's go
15:16:44 * jreznik is here too (again)
15:16:51 <rdieter> #topic PK-hif comps
15:16:54 <rdieter> Kevin_Kofler: go ahead
15:16:57 <rdieter> #info jreznik present
15:17:00 <rdieter> #chair jreznik
15:17:00 <zodbot> Current chairs: Kevin_Kofler dvratil jgrulich jreznik rdieter tosky
15:17:36 <Kevin_Kofler> So the status is that I picked up the pull request a couple weeks ago, hughsie finally replied to my latest iteration, but now requested some non-trivial changes that I didn't have the time to do yet.
15:18:02 <pino|work> rdieter: chair me too please :p
15:18:02 <Kevin_Kofler> Well, I changed the generic gpointer user_data arguments to PkCompsData *comps_data where possible, but I haven't done the rest yet.
15:18:16 <rdieter> #chair pino|work
15:18:16 <zodbot> Current chairs: Kevin_Kofler dvratil jgrulich jreznik pino|work rdieter tosky
15:18:20 <Kevin_Kofler> #link https://github.com/hughsie/PackageKit/pull/49
15:18:38 <rdieter> Kevin_Kofler: any eta?
15:19:12 <Kevin_Kofler> I'm a bit annoyed by the fact that hughsie came up with the non-trivial comments only months after the initial submission, after having nitpicked on trivial formatting issues (and a few excess newlines at the end of debugging messages to the console) all this time.
15:19:14 <rdieter> (and thanks for your continued efforts here)
15:19:27 <rdieter> Kevin_Kofler: yeah, that's unfortunate. :(
15:20:07 <Kevin_Kofler> Hopefully this week. I have the setup to be able to compile PK-hif again (I had to redo it, backporting the current stuff to F20 now, my old F19 backport was already outdated because it took so long).
15:20:32 <Kevin_Kofler> Backporting the libhif stack is always fun, dependency hell…
15:20:48 <Kevin_Kofler> But I have that now.
15:20:57 * rdieter mumbles something about f22 alpha being pretty nice to use... :)
15:21:06 <rdieter> or even f21
15:21:11 <Kevin_Kofler> F21 would do, right.
15:21:17 <Kevin_Kofler> Whatever.
15:21:43 <Kevin_Kofler> In any case, I'm set up to build stuff now, and I'm working on it, hopefully I'll get it done this week.
15:22:40 <Kevin_Kofler> The object ownership is a bit messy in heliocastro's code, so I think it's leaking memory in some places, I may try to fix it, but then again I can also ignore the issue as long as hughsie doesn't complain. ^^
15:23:52 <rdieter> you'll do fine, thanks for the update
15:25:22 <ltinkl> right, I also had to recompile PK (including hif and hawkey) on F21 to be able to test the PK updates applet
15:25:37 <ltinkl> the PK version (1.0.4) on F21 just crashes
15:26:25 <rdieter> anything else or can we move on?
15:26:31 <Kevin_Kofler> Oh fun, so I may have to backport an even newer version to actually test things… (I backported the F21 SRPMs for now.) Sigh…
15:27:12 <Kevin_Kofler> #info hughsie has some valid complaints about the latest patch iteration.
15:27:25 <Kevin_Kofler> #action Kevin_Kofler is working on updating the pull request ASAP.
15:27:30 <Kevin_Kofler> rdieter: We can move on now.
15:27:40 <rdieter> #topic KF5-5.9 updates
15:28:04 <rdieter> dvratil: anything notable coming in kf5-5.9 ?
15:28:27 <dvratil> nothing much here, there's just kf5-modemmanager-qt moving from Plasma to KF5 in 5.9.0, but we have that covered already
15:28:49 <dvratil> thanks for fixing the 5.8.0 conflicts btw
15:30:11 <rdieter> heh, I *think* i've got all conflicts handled now.  *fingers crossed*
15:31:34 <rdieter> moving on...
15:31:35 <Kevin_Kofler> Also the kde-l10n ones?
15:31:58 * rdieter didn't touch kde-l10n
15:32:07 <Kevin_Kofler> There were several kde-l10n conflicts posted on the chan, I fixed some, dvratil fixed some more, but then even more came in.
15:32:13 <dvratil> I fixed some kde-l10n conflicts
15:32:44 <Kevin_Kofler> And also, dvratil, have you filed an update for F22 with your kde-l10n build yet (or edited mine)?
15:32:49 <dvratil> ok, I didn't know about the additional conflicts with kde-l10n
15:33:20 <dvratil> no, I didn't even bump release
15:33:21 <rdieter> https://admin.fedoraproject.org/updates/FEDORA-2015-5313/kde-l10n-14.12.3-2.fc22   I see
15:33:23 <dvratil> shame on me
15:33:32 <rdieter> I think there's a -3 build thought now too
15:33:36 <Kevin_Kofler> rdieter: That's what I filed, before dvratil's fixes.
15:33:53 <dvratil> so, does anyone have any details about the additional conflicts?
15:34:14 <rdieter> want to queue that one stable, or update with -3 now?
15:34:38 <Kevin_Kofler> We're in freeze right now, aren't we?
15:34:46 <Kevin_Kofler> So queuing stable won't do much good anyway.
15:34:52 <rdieter> public service announcement:  if you find problems (including conflicts), please file bugs.  kthxbye
15:35:06 <Kevin_Kofler> dvratil: I see this one, it's a translations conflict, but not in kde-l10n, but between 2 packages:
15:35:08 <Kevin_Kofler> .bug 1208947
15:35:12 <zodbot> Kevin_Kofler: Bug 1208947 file /usr/share/locale/bs/LC_MESSAGES/libkxmlrpcclient5.mo from install of plasma-workspace-5.2.2-2.fc21.x86_64 conflicts with file from package kf5-kxmlrpcclient-5.8.0-1.fc21.x86_64 - https://bugzilla.redhat.com/1208947
15:35:39 <dvratil> I think rdieter fix this and the kpeople conflict, right?
15:35:47 <Kevin_Kofler> rdieter: ↑ ?
15:36:01 <rdieter> plasma-workspace-5.2.2-5.fc22 should fix that
15:36:23 <rdieter> (it's on plasma-5 copr too)
15:36:27 <rdieter> and f22 -testing
15:36:46 <Kevin_Kofler> I hope there isn't more that we forgot about, it's easy to forget things when people just paste fpaste links to IRC.
15:36:59 <rdieter> I cheated by omitting the translations from plasma-workspace and Requires: kf5-kxmlrpcclient >= 5.8
15:37:14 <rdieter> it's problematic when folks to:  yum install kf5-*
15:37:32 <rdieter> that intalls more than what is strictly required, but it is a nice test regardless
15:39:12 <rdieter> moving on...
15:39:15 <rdieter> #topic open discussion
15:39:19 <rdieter> anything else to discuss?
15:39:32 <rdieter> oh, one more kf5 app coming :  okteta (will file update later today)
15:39:45 <rdieter> the okteta4 compat pkg review was completed yesterday
15:40:09 <Kevin_Kofler> How do we handle kioslaves for both kdelibs4 and KF5?
15:40:10 <rdieter> then I'll try to move on to some of the newer libk* ones for digikam
15:40:23 <rdieter> Kevin_Kofler: we try to build both
15:40:34 <rdieter> is that what you mean by "handle"?
15:40:39 <Kevin_Kofler> Yes, but how do we name the packages and how do we solve file conflicts?
15:40:47 <Kevin_Kofler> kio_mtp is one example, but I also want to package kio_gopher's KF5 port.
15:40:51 <rdieter> well, most kf5 ones are in kio-extras
15:40:58 <rdieter> so naming hasn't been an issue... yet
15:41:22 <rdieter> I suppose in this case, adding a -kf5 suffix makes sense
15:41:26 <Kevin_Kofler> I can submit it as kio5_gopher or kio_gopher5 or kio_gopher-kf5, and I can rename one version's kio_gopher.mo.
15:41:35 <rdieter> or kio5_ works for me too
15:41:55 <rdieter> didn't we already discuss this once on #fedora-kde?  I'm getting deja-vu
15:42:33 <rdieter> as far as translations, we should have a standard/best-practice there too
15:42:45 <Kevin_Kofler> We should, but do we?
15:42:56 <rdieter> not yet, I just hit that with kcm_mtp
15:43:11 <rdieter> In the short term, I ended up renaming *both* packages translations
15:43:20 <rdieter> kcm_mtp4 vs kcm_mtp5
15:43:45 <rdieter> long term, ... well, long term I'd prefer if upstream handled it :)
15:44:05 <rdieter> looks like we lost pino
15:44:13 <pino|work> hm?
15:44:15 * rdieter was going to ask his opinion
15:44:23 <rdieter> hrm, konvi autocomplete didn't find you :)
15:44:47 <pino|work> because there's another nick starting with "pin", i guess
15:44:49 <rdieter> ltinkl , pino|work, tosky : so, kde4 and kf5/plasma5 translations of common items often conflict
15:44:56 <rdieter> pino|work: ah, :)
15:45:26 <rdieter> for example, kio-extras (from plasma5) and kio_mtp both includes kio_mtp.mo , and they conflict by default
15:45:42 <rdieter> why suggestions on how best to handle that situation?
15:45:47 <rdieter> s/why/any/  rather
15:45:48 <pino|work> why?
15:45:53 <rdieter> any suggestions :)
15:45:58 <pino|work> k
15:46:16 <pino|work> ask opinions upstream, first? (if there's any sanity left there)
15:46:18 <rdieter> to me, one easy fix would be to rename things to not conflict
15:46:32 <Kevin_Kofler> kioslaves are the most common offenders, it seems.
15:46:34 <tosky> uhm, library stuff were not meant to conflict; kioslaves could be considered as libraries
15:46:35 <jreznik> btw. this is the current version of kde page - http://i.imgur.com/pbQDKX6.jpg
15:46:53 <jreznik> (for open discussion but to have it on meeting with everyone in)
15:47:12 <rdieter> and since development is happening in kf5/plasma5, that's probably where it makes most sense to do the renaming
15:47:41 <Kevin_Kofler> jreznik: The Telepathy description says "I supports" where it should be saying "It supports".
15:48:27 <rdieter> can someone more involved with localization/translations (than me) take this issue back to kde upstream for discussion?
15:49:06 <rdieter> I can, if needed, but my l10n-fu is lacking
15:49:17 <dvratil> tosky:  ^^ :)
15:49:32 <tosky> that's more for plasma, I guess
15:49:36 <tosky> do you have a complete list?
15:49:50 <tosky> (of the conflicting files)
15:50:06 <rdieter> tosky: in this context, in general, we're talking about runtime dependencies, but specifically, kioslave translations
15:50:32 <rdieter> tosky: in particular, kio_mtp.mo
15:50:46 <Kevin_Kofler> At least kio_mtp.mo (kio_mtp for KDE 4 vs. kio-extras) and kio_gopher.mo (separately released kioslave, has both versions).
15:51:03 <tosky> I think jgrulich was involved, so he can help with that
15:51:16 <tosky> about kio-gopher, the kf5 version was never released officially
15:51:21 <rdieter> it could be that this is a rare enough occurance, it may not be worth worrying too much about too
15:51:22 <tosky> I should reping Albert for that
15:51:59 <rdieter> since we've only hit it once so far (and maybe twice with kio_gopher soon)
15:52:16 * ltinkl rolls eyes at gopher :)
15:52:34 <Kevin_Kofler> Any kioslave that has translations outside of kde-l10n is likely to be affected.
15:52:35 <jgrulich> well, I have no idea what to do about it, we could rename it to kio_mtp5, but I wouldn't vote for it
15:52:54 <tosky> jgrulich: why no vote?
15:53:12 <ltinkl> uhm, please reming me why we need the old kio_mtp from KDE 4?
15:53:16 <ltinkl> remind even
15:53:27 <rdieter> ltinkl: for kde4 apps, like digikam/amarok that use it
15:53:34 <ltinkl> ah amarok, yup
15:53:37 <tosky> Kevin_Kofler: it's up to them to rename, I don't see why they couldn't do it
15:53:39 <jgrulich> ltinkl: and dolphin as well
15:53:53 <ltinkl> dolphin? do we still ship the KDE 4 version with P5?
15:54:17 <jgrulich> ltinkl: KF5 dolphin is not released yet
15:54:28 <Kevin_Kofler> In KDE 4, renaming the .mo files is as easy as 1. renaming the files and 2. passing the renamed name as a second argument to KComponentData.
15:54:49 <Kevin_Kofler> But in KF5, KComponentData is deprecated, so where is the catalog name now set? Can it even be set separately from the application name?
15:55:13 <Kevin_Kofler> That said, we may also just always rename the KDE 4 versions, it's nicer in the long term anyway.
15:55:15 <rdieter> ltinkl: yes, kde-applications still includes kde4 stuff, including dolphin, konqueror
15:55:26 <Kevin_Kofler> And there I know how to make the code find the renamed .mo files.
15:55:46 <rdieter> Kevin_Kofler: I know how too, now that I've done it once :)
15:55:50 <ltinkl> Kevin_Kofler: thru cmake and/or with KLocalizedString::setApplicationDomain("foo")
15:56:18 <ltinkl> but it still means patching applications, either KDE4 of 5
15:56:36 <tosky> I think we are overthinking (!) a bit
15:56:44 <tosky> it happened twice
15:57:00 <Kevin_Kofler> tosky: We need to fix both though.
15:57:01 <tosky> one case it's about kio-mtp, we can ask upstream to fix it (jgrulich, why wouldn't you vote)
15:57:06 <tosky> Kevin_Kofler: why?
15:57:15 <Kevin_Kofler> Because we can't ship them with file conflicts.
15:57:53 <Kevin_Kofler> File conflicts are a blocker-level bug.
15:58:06 <Kevin_Kofler> They make one or the other package uninstallable, and are also a blatant violation of the packaging guidelines.
15:58:09 <jgrulich> tosky: I just like kio_mtp more than kio_mtp5 and in case of renaming one kio slave, we would need to probably rename all of them for consistency
15:58:26 <tosky> jgrulich: what is the status of the other kioslaves?
15:59:03 <tosky> Kevin_Kofler: sorry, which are "both" here? kio-mtp and kio-gopher, or kio-mtp/4 and kio-mtp/5?
15:59:16 <jgrulich> tosky: no idea, all I did was to port kio_mtp to KF5 and add it to kio-extras to have it released, because I was using it
15:59:44 <jgrulich> tosky: I'm not involved in kio-extras development
16:00:02 <tosky> ok
16:00:12 <tosky> so ask upstream about renaming all kios in kio-extra
16:00:46 <Kevin_Kofler> kio_foo4 and kio_foo5 for any foo, unless the translations are only in kde-l10n.
16:00:58 <Kevin_Kofler> E.g. kio_mtp4 and kio_mtp5 conflict.
16:01:11 <rdieter> tosky: +1, that would be safest
16:01:25 * rdieter doesn't care to bikeshed on *how* they're renamed
16:02:34 <tosky> Kevin_Kofler: excluding the ones in kde-workspace which are not going to be coinstalled
16:02:53 <tosky> but I wouldn't rename kio_foo -> kio_foo4, just the version with 5
16:03:00 <Kevin_Kofler> ALL kioslaves MUST be coinstalled.
16:03:08 <Kevin_Kofler> If we have ones that are not coinstalled now, that is a bug.
16:03:16 <Kevin_Kofler> KDE 4 applications NEED the kdelibs4 kioslaves.
16:03:41 <rdieter> Kevin_Kofler: I don't think anyone disputes that :)
16:03:52 <tosky> ok, I can't check now, assume that all kioslaves are in kio-extras for now
16:04:09 <Kevin_Kofler> I guess things like kio_sysinfo can be exceptions, but isn't kio_sysinfo dead to begin with? :-)
16:05:45 <rdieter> <nod>
16:06:07 <rdieter> I guess we're getting close to out of time, any last thoughts before ending the meeting?
16:06:50 <Kevin_Kofler> A really nasty Krusader bug I ran into today: https://bugs.kde.org/show_bug.cgi?id=345952
16:07:00 <Kevin_Kofler> [Bug 345952] Krusader+kio_sftp: [data loss] Deleting symlink to directory recursively deletes linked directory
16:07:26 <Kevin_Kofler> NOT fun when you see a whole directory vanish under your eyes.
16:07:53 <rdieter> eep
16:08:12 <Kevin_Kofler> Should we try to fix this one downstream?
16:08:33 <Kevin_Kofler> I'm not sure where to start though.
16:08:40 <Kevin_Kofler> All I know is that Dolphin does the right thing.
16:09:00 <rdieter> sounds fix-worthy to me in general, but would need to know more about how/why it's happening first, of course
16:09:27 <Kevin_Kofler> I hope upstream replies soon, but seeing the state Krusader is in upstream at the moment, I'm not confident. :-(
16:12:50 <rdieter> ok, let's end the meeting, thanks everyone
16:12:53 <rdieter> #endmeeting