15:08:50 <rdieter> #startmeeting kde-sig
15:08:50 <zodbot> Meeting started Tue Dec  1 15:08:50 2015 UTC.  The chair is rdieter. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:08:50 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:08:50 <zodbot> The meeting name has been set to 'kde-sig'
15:08:53 <rdieter> #meetingname kde-sig
15:08:53 <zodbot> The meeting name has been set to 'kde-sig'
15:08:56 <rdieter> #topic roll call
15:09:08 * jgrulich is present
15:09:11 <rdieter> hi all, friendly kde-sig meeting about to start, who's present today?
15:09:20 <jgrulich> o/
15:09:23 * jreznik is here, sorry for some time of inactivity... let's hope it will be better :)
15:09:37 <rdieter> jreznik: thx
15:11:39 <rdieter> may have a short meeting
15:11:45 <rdieter> #info rdieter jgrulich jreznik present
15:11:50 <rdieter> #chair jgrulich jreznik
15:11:50 <zodbot> Current chairs: jgrulich jreznik rdieter
15:12:05 <than> present
15:12:40 <rdieter> #info than present
15:12:42 <rdieter> #chair than
15:12:42 <zodbot> Current chairs: jgrulich jreznik rdieter than
15:13:11 * dvratil has to pass today
15:13:28 <dvratil> but I don't have anything to report anyway, too busy with work work :(
15:13:46 * heliocastro here
15:13:50 <rdieter> dvratil: k
15:13:55 <rdieter> sudo dvratil work work work
15:14:02 <rdieter> #info heliocastro present
15:14:05 <rdieter> #chair heliocastro
15:14:05 <zodbot> Current chairs: heliocastro jgrulich jreznik rdieter than
15:14:33 <rdieter> #topic agenda
15:14:45 <rdieter> ok, what to discuss today?
15:15:20 * rdieter can give brief report on kde-apps status
15:15:36 <heliocastro> I' m just observer today, setting up things
15:16:31 * heliocastro can do a update on qt 5.6.x though
15:16:45 <rdieter> ok, good idea
15:18:31 <heliocastro> Nobody else ?
15:19:03 <rosalege> Hi guys, May I ask for the documentation to be included in KDE release notes for fedora 23
15:19:48 <rosalege> I would like to work updating the documentation page with this information
15:20:37 <jreznik> heliocastro: +1 to qt 5.6 update
15:21:23 <rdieter> rosalege: sure, sounds great, we can discuss that a bit too
15:21:30 <rdieter> moving on...
15:21:34 <rdieter> #topic kde-apps status
15:22:22 <rdieter> just a brief update, kde-apps is pretty big these days, and I've been falling behind keeping things updated there, but rawhide getting close to having all 15.08.3 included
15:22:59 <rdieter> I've been working to split it up into smaller manageable pieces:  ktp, edu, games, sdk
15:23:29 <rdieter> (just arbitrary groups, to keep batched updates simpler)
15:24:07 <rdieter> oh, and -pim stuff, which we're currently holding back, waiting on all the new kf5 pieces to be reviewed and landing in rawhide proper
15:24:55 <jgrulich> rdieter: I can help with reviews, I thought I already reviewed them all
15:24:57 <tosky> ups, sorry
15:25:23 <rdieter> tosky: hi
15:25:39 <rdieter> jgrulich: <nod>
15:26:06 <rdieter> dvratil has been busy lately, so he'll probably appreciate if someone can help lead that effort of bringing the kf5-based pim stack to rawhide
15:26:23 <rdieter> jgrulich: ^^ something you may be interested in? :)
15:26:40 * heliocastro have pykde on plate alreay
15:27:11 <rdieter> leading here means:  get overview of work done and what still needs to be done
15:27:12 <jgrulich> rdieter: sure, I can take case of that and import all the packages to rawhide
15:27:28 <rdieter> jgrulich: awesome, thanks
15:28:55 <rdieter> #action jgrulich to help dvratil with kf5 kdepim stack reviews/imports/whatever
15:29:37 <dvratil> yeah, I'd appreciate some help with that :) I can provide all the PIM insight, instructions and advices, probably won't get to do actualy packaging though :(
15:29:55 <rdieter> anyway, once 15.08.3 is in rawhide, I'll probably merge back to f23/f22 branches where it makes sense... then can start in on 15.12 beta (aka 15.11.80)
15:30:37 <rdieter> moving on...
15:30:49 <rdieter> #topic qt 5.6.x status
15:30:51 <rdieter> heliocastro: ^^
15:31:15 <heliocastro> Ok
15:31:21 <jgrulich> dvratil: I'll import all PIM frameworks into rawhide and then I'll let you know and we can discuss what to do next
15:31:37 <heliocastro> So, i did some changes on the qt 5.6.0 packages
15:32:05 <dvratil> jgrulich: isn't it better to make the whole stack work in Copr first? It's harder to test in rawhide...anyway, let's discuss that on Thursday :)
15:32:22 <heliocastro> Kicked out the bootstrap, and since we splitted the qdoc package, now we will (crossing fingers ) not need anymore the bootstrap stage
15:32:22 <jgrulich> dvratil: ok :) sounds like a plan
15:33:15 <rdieter> heliocastro: bootstrapping may still be needed for new arch's of course, so don't get rid of the macros/support completely (just means we won't have to use it nearly as often)
15:33:20 <heliocastro> The only acttual issue is copr on i386 builds
15:33:51 <heliocastro> rdieter: We need bootstrap 5.5 on new arches, later not anymore
15:34:13 <heliocastro> So, i' m using 5.6.0 roght now and everything looks fine
15:34:24 <heliocastro> So, remains the question on qtwebengine
15:34:41 <rdieter> heliocastro: jreznik reported some dependency issues earlier in #fedora-kde
15:34:46 <heliocastro> The new version has some different versions on internal 3rd party libs
15:35:16 <heliocastro> jreznik: Can you point me later ?
15:35:32 <heliocastro> There are harfbuzz need for epel/red hat 7
15:36:06 <heliocastro> So , webengine is not compiling with current libraries in fedora
15:36:41 <rdieter> heliocastro: possible to use bundled ones ?
15:37:01 <heliocastro> Yes, but then, will fall on the usual " not use bundled"
15:37:08 <rdieter> (the recent bundling guidelines allow for that, when system versions cannot be used)
15:37:14 <heliocastro> \o/
15:37:22 <heliocastro> This makes life easier than
15:37:51 <jreznik> heliocastro: I'm not able to get anything reasonable from dnf than just skipped due to broken dependencies
15:38:10 <jreznik> it's on f23/x86_64
15:38:16 <heliocastro> Same as me
15:38:48 <heliocastro> jreznik: Out of curiosity, try use yum for same operation
15:38:55 <rdieter> in particular "All packages whose upstreams allow them to be built against system libraries must be built against system libraries."
15:39:58 <rdieter> jreznik: dnf --best  should give some better clues, I think
15:40:41 <rdieter> since dnf effectively does the same as: yum --skip-broken now
15:40:51 <rdieter> (as I understand it)
15:41:01 * pino|work is super-late
15:41:22 <heliocastro> rdieter: Maybe jreznik pick the qdoc previous release, that forbids the update due to be = instead of =>
15:42:40 <rdieter> #info pino|work present
15:42:42 <rdieter> hello
15:42:51 <Caterpillar> hi
15:42:59 <rdieter> heliocastro: I'll try enabling the copr too after meeting, and see what happens too
15:43:00 <Kevin_Kofler> 15:38:55 <rdieter> in particular "All packages whose upstreams allow them to be built against system libraries must be built against system libraries."
15:43:08 <rdieter> #info Caterpillar present
15:43:11 <Kevin_Kofler> Well, this still means you must try the flag to build against the system lib.
15:43:21 <heliocastro> So i hope that the initiative of copr and blog more often brings more testers
15:43:21 <rdieter> Kevin_Kofler: yes, heliocastro tried, and it fails
15:43:27 <Kevin_Kofler> Only if it is so much too old that it won't build, THEN you're allowed to use the bundled version.
15:43:56 <heliocastro> My path is asking to the the packager to update it
15:43:58 <Kevin_Kofler> It'd be better to just fix the build (aggressively revert Chromium changes that require the new lib), but you don't have to listen to me thereā€¦ :-/
15:44:07 <heliocastro> if not possible, than i will go with bundled
15:44:23 <Kevin_Kofler> Upgrading the system lib would work too, of course, it'd be even better.
15:44:45 <heliocastro> we need to be realistic, we do not have manpower for any big patching and maintenance
15:45:08 <heliocastro> we need to go with the best available and less complicated solutions for us
15:45:33 <heliocastro> I can say that this month i got a  lot of upset of thew amount of complaining on kde on fedora
15:45:48 <heliocastro> Meaning, something is not right, even if the guys are overreacting
15:47:36 <Kevin_Kofler> I'm just going to STFU and let you do what you think is right. (I don't have the time to do it better either.)
15:51:30 <heliocastro> But that' s all for qt 5.6.x today. I really like to receive info of issues to have all in very good state
15:52:18 <rdieter> heliocastro: great thanks!
15:52:46 <rdieter> #topic f23 docs/release notes
15:52:51 <rdieter> rosalege: ^^ your topic
15:53:12 <rosalege> :)
15:53:47 <rosalege> Since all you work on the technical part.
15:54:07 <rosalege> What would be best to include in the release notes
15:54:21 <rosalege> That will provide to the end user
15:54:41 <rosalege> What they will find with the fedora kde spin
15:56:18 <rosalege> Or if you have some raw document that I look at
15:56:29 <rosalege> at I can work on a draft
15:56:36 * rdieter likes the sound of that
15:56:40 <rosalege> so you can check it later on
15:58:56 <rdieter> rosalege: great, thanks, looking forward to giving feedback on your draft
15:59:52 <rdieter> rosalege: anything else, or is that all for now?
16:00:28 <rosalege> For now, it will be all.
16:00:49 <rdieter> ok, moving on (thanks again)
16:00:55 <rdieter> #topic open discussion
16:01:15 <rdieter> we're almost at the hour-point, anything else worth mentioning before closing the meeting?
16:02:10 <rosalege> Please send the documentation you have to my email
16:02:22 <rosalege> Can I post it here?
16:03:30 <rdieter> rosalege: I'd recommend onlist (kde@lists.fpo)
16:03:35 <dvratil> have you guys heard any feedback on Plasma 5.5 beta in rawhide?
16:04:09 <rdieter> dvratil: I think I saw one bug filed that it wasn't working (but kinda sparse on details, iirc)
16:04:18 <rosalege> rdieter: perfect, thanks!
16:04:50 <rdieter> dvratil: speaking of 5.5beta, would you or anyone else be able/interested in updating the plasma5-unstable copr to match?
16:05:07 <rdieter> last I saw, copr was still on 5.4.90 (not 5.4.95 yet)
16:05:32 <dvratil> rdieter: makes sense, I'll see if I can run the magical scripts tonight
16:05:38 <rdieter> wee, magic
16:06:08 <dvratil> (otherwise I'll let you know)
16:06:27 <rdieter> now that it's in rawhide, should hopefully be easier to create src.rpm's for them all from master/ branch, and through it @ copr
16:06:38 <rdieter> er, throw
16:07:33 <rdieter> ok, let's wrap thing up, thanks everyone
16:07:39 <rdieter> #endmeeting