19:23:40 <nb> #startmeeting Lightning Talks
19:23:40 <zodbot> Meeting started Fri Jan 18 19:23:40 2013 UTC.  The chair is nb. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:23:40 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:23:51 <nb> #topic Poker: by Robyn Bergeron
19:23:55 <nb> #info poker is fun
19:24:01 <nb> #info trolling is awesome
19:24:09 <nb> #info many variations of poker
19:24:25 <Sparks_too> nb: Woot!
19:25:30 <nb> #info TV games are usually the "endgame" and not usually shown in their entirety
19:26:12 <Sparks_too> nb: I thought poker was easy until I realized that they don't show you the other players' cards like they do on TV
19:26:23 <nb> lol
19:28:36 <rrix> ianweller has a two up his sleeve
19:29:27 <Sparks_too> I'm bored, please stop
19:29:30 <mattdm> #info poker is hard to explain in 5 minutes
19:29:47 <nb> #info Robyn has exceeded her time limit, but is continuing because poker is awesome
19:29:48 <Sparks_too> mattdm: +1
19:30:31 <nb> #info Beefy Miracle as a Service approves of poker!
19:30:39 <nb> #info this presentation is from rbergero@fedoraproject.org
19:30:49 <nb> #topic Something by Ralph
19:30:59 <mizmo> g+ is confusing and hard :(
19:31:42 <mattdm> ooh this is pretty
19:31:42 <rrix> ianweller: you have the best notification noise
19:32:20 <ianweller> rrix: :D
19:32:35 <ianweller> pingou: are you alive
19:32:37 <ianweller> pingou: you're up next
19:32:59 <ianweller> nb: why are you using meetbot
19:33:03 <ianweller> nb: it kills the topic that has useful info
19:33:05 <ianweller> srsly
19:33:15 <sgallagh> wat?
19:33:46 <ianweller> wfm
19:33:47 <nb> ianweller, done
19:33:48 <rrix> ianweller: #endmeeting restores the useful info
19:33:52 <ianweller> rrix: :)
19:33:58 <ianweller> is anybody sitting next to pingou
19:34:04 <nb> ianweller, Southern_Gentlem suggested using meetbot to keep logs for people who are not here
19:34:08 <mizmo> http://etherpad-fudcon2013.rhcloud.com/   <= does not exist
19:34:09 <nb> so i am liberally using #info
19:34:17 <gholms> nb: Just make sure you don't do any new #topics.  ;)
19:34:25 <ianweller> nb: we can get logs from zodbot's host regardless of meetbot running if we need.
19:34:27 <sgallagh> mizmo: What do you mean it doesn't exist?
19:34:37 <rrix> mizmo: I've been complaining about that for like two hours; no one knows what pad URL people are using :(
19:34:37 <mattdm> or make new topics and then put it back quick
19:34:45 <mizmo> sgallagh, i click on it and it tells me i can create a new pad because that doesnt exist
19:35:01 <nb> ianweller, mattdm zodbot can't change the topic anymore so it should be ok i think
19:35:07 <sgallagh> Did you enter a name?
19:35:12 <mizmo> etherpad-fudcon2013.rhcloud.com is the server, not the pad. can you put up the pad name?
19:35:16 <mizmo> or is there no actual pad to follow?
19:35:17 <kk4ewt> #action nb build wikipage for central box
19:35:29 <gholms> #meetingname lightning-talks
19:35:29 <zodbot> The meeting name has been set to 'lightning-talks'
19:35:29 <sgallagh> There's no actual pad, it's there for individual sessions/hackfests to use I think
19:35:34 <mizmo> sgallagh, why would i create a new pad though? i want to follow whats going on
19:36:01 <sgallagh> I don't think anyone is maintaining an etherpad for the lightning talks
19:36:04 <ianweller> sgallagh: you're on deck
19:36:35 <mizmo> sgallagh, it doesn't matter what the etherpad is for, the URL in the topic is basically useless because theres no directory of what pads already exist (make more sense?)
19:36:35 * sgallagh warms up
19:36:43 <mizmo> it would be good to have a pad that had links out to the other pads
19:36:44 <sgallagh> mizmo: Yes, good point
19:36:44 <j_dulaney> ianweller:  lmr is having trouble accessing the intertubes
19:36:54 <nb> j_dulaney, what kind of trouble?
19:36:56 <j_dulaney> ianweller:  The wireless login page is timing out
19:36:59 <nb> hmm
19:37:06 <ianweller> j_dulaney: restart networkmanager
19:37:13 <rrix> j_dulaney: haave you tried turning it off and on again?
19:37:14 <rrix> yes
19:37:15 <rrix> that
19:37:53 <nb> #link http://fedocal.dev.fedoraproject.org
19:37:54 <nirik> https://fedocal.dev.fedoraproject.org/ <- current app pingou is talking about
19:37:59 <stickster> ianweller: nb: spot: Whoever has access to the EP instance -- can you grab URLs to all existing pads, put them on a "content" pad, and then use that in the /TOPIC above?
19:38:20 <stickster> And then we'll need to ask people creating pads to list them in the contents pad
19:38:24 <mizmo> there isn't a google hangout for lightning talks is there?
19:38:31 <nb> maxamillion, ping
19:38:42 <ianweller> maxamillion: ^^^^^^^
19:38:49 <skvidal> nb: yo - can you bring that web cam up from the main room?
19:38:53 <skvidal> or if anyone is in the mainroom?
19:38:57 <j_dulaney> pkgwat = pretty cool
19:39:04 <nb> herlo, ping
19:39:16 <skvidal> mizmo: I'm glad you liked the tile
19:39:32 <skvidal> nb: he's right here
19:39:38 <maxamillion> nb: pong
19:39:40 <mizmo> skvidal, we do need to redo our kitchen backsplash :)
19:39:41 <rrix> I don't even see herlo in here, is he in main room?
19:40:02 <stickster> I don't see his green shirt
19:40:04 <skvidal> reading this
19:40:05 <skvidal> go ahead
19:40:05 <skvidal> mizmo: please apologize to ray for me
19:40:06 <skvidal> rrix: he's in room A
19:40:06 <skvidal> rrix: w/me
19:40:06 <nb> maxamillion, hey, can you see what etherpads exist/
19:40:07 <skvidal> rrix: reading this
19:40:11 <rrix> ok
19:40:22 <maxamillion> nb: oh ... honestly not sure ... just a sec
19:40:22 <rrix> skvidal: tell him he's mean for not putting a webcam in main room for lightning talks
19:40:39 <skvidal> rrix: he says you can set one up right now
19:40:48 * mizmo <= disappointed pregnant lady cant see lightning talks >:(
19:40:48 <skvidal> with the webcam that's in there
19:40:48 <skvidal> TADA!
19:40:49 <rrix> I'm setting one up on my phone
19:40:52 <kk4ewt> rrix:  colby is recording
19:40:52 <rrix> oh there is one?
19:40:58 <rrix> kk4ewt: right, but no live stream
19:41:04 <j_dulaney> nb:  he still cannot access it
19:41:11 <skvidal> rrix: there's a cam in that room in a box
19:41:17 <skvidal> it says logitech on it
19:41:23 <skvidal> has a picture of a happy woman webchatting or something
19:41:32 <mizmo> skvidal, no worries i think he's still reeling from this siding treatment suggestion from lene jensen https://sphotos-b.xx.fbcdn.net/hphotos-prn1/c26.0.403.403/p403x403/602896_367492686679419_209483685_n.jpg
19:41:40 <skvidal> it's not obvious why the camera made her so happy
19:41:56 <stickster> WOW
19:42:01 <skvidal> but apparently she is a consumer who is made fully satisfied by that camera
19:42:08 <j_dulaney> This just went south
19:42:12 <nb> j_dulaney, try disconnecting and then reconnecting to the wifi
19:42:21 <ianweller> ctyler: you're up next
19:42:27 <ianweller> Sparks_too: are you dropping your talk?
19:42:31 <mizmo> j_dulaney, i think everything goes south when you have stripper poles on your bus...
19:42:41 <j_dulaney> nb:  He has
19:42:50 <j_dulaney> mizmo:  Indeed
19:43:01 <ianweller> his slides are so not showing.
19:43:02 <ianweller> oops
19:43:04 <nb> j_dulaney, idk, ask ianweller after lightning talks i guess
19:43:18 <ianweller> don't ask me anything
19:43:19 <rrix> I can't figure out how to make htis a youtube hangout
19:43:22 <skvidal> wow
19:43:23 <rrix> https://plus.google.com/hangouts/_/27ff7128d51ab99df4e4a151556fd31eb9ce5a3e
19:43:23 <skvidal> that is....
19:43:23 <skvidal> that's a statement
19:43:45 <rrix> also it's on my phone since no one knows where the webcam is
19:43:55 <skvidal> rrix: herlo is coming to irc
19:43:56 * mizmo tries to connect
19:44:27 <rrix> mizmo: lmk if the audio sucks
19:44:56 <herlo> rrix: quit being lazy
19:45:16 <rrix> herlo: no one knows where the webcam is and i'm not going to wander around in front of everyone while there is talking >_>
19:45:30 <Nushio> rrix: just do it silently
19:45:32 <mizmo> woo thanks rrix
19:45:32 <Nushio> :P
19:45:46 <herlo> rrix: mdomsch supposedly does
19:45:50 <rrix> mizmo: it's currently balanced on a shirt, and might fall over at any moment, just as a warning
19:45:59 <rrix> ok, well I will look for mdomsch
19:46:03 <herlo> thanks
19:46:20 <Nushio> oh, hey
19:46:23 <Nushio> i see people's faces
19:46:26 <herlo> and then you can do the hangout on your computer. There's a little click box for 'on air' which pushes it to youtube
19:46:29 <rrix> ok ill hold it
19:46:32 <Nushio> i hadn't used hangout in quite a very long while
19:46:40 <ianweller> ctyler: are you ready
19:46:47 <mizmo> lol
19:46:52 <mizmo> balanced on a beefy tornada
19:46:54 <mizmo> tornado
19:47:08 <nb> #link http://mojavelinux.github.com/decks/asciidoc-with-pleasure
19:47:23 <rrix> That has a crappier view but it's more stable
19:47:44 <rrix> anyone see where mdomsch is sitting?
19:47:50 <rrix> I don't have a good view of behind me
19:49:07 <russellb> rrix: right behind me
19:49:11 * rrix shrugs
19:49:13 <rrix> oh
19:49:15 <ianweller> shaiton: you're up next
19:49:15 <rrix> ok
19:49:17 <rrix> hmm
19:49:27 <russellb> which is upper left if looking at the spekaer
19:49:38 <rrix> Ah yes
19:49:39 <russellb> 2nd row from the very back
19:49:39 <rrix> I see him
19:49:45 <rrix> russellb: thanks, you rock
19:49:50 <russellb> np
19:49:52 <rrix> I will bother him when ctyler is done talking
19:50:15 <Nushio> rrix: is there a way you could reasonably adjust the camera angle so that the slides aren't at an angle? :P
19:50:20 <rrix> heh
19:50:27 <mhrivnak> Possible to kill the lights at the top of the white boards?
19:50:31 <rrix> Nushio: I can try, but I will probably end up holding it ;p
19:50:42 <Nushio> Oh, right, you're transmitting from the phone
19:50:59 <rrix> yeah :(
19:51:01 <Nushio> is that a galaxy nexus? It's got a good enough camera
19:51:14 <rrix> nexus4
19:51:17 <ianweller> mhrivnak: acknowledged, will do
19:51:24 <Nushio> Ah, that explains the camera
19:51:33 <Nushio> I thought it looked better than my crappy Galaxy Nexus
19:51:43 <rrix> you couldnt see that i bet
19:51:50 <Nushio> most likely no
19:52:10 <rrix> blinky leds
19:52:58 <jsmith> Yay for blinking lights!
19:53:11 <sgallagh> There. are. four. lights!
19:53:41 <ianweller> shaiton: you're up
19:54:05 <rrix> im gonna go find a webcam brb hangout
19:54:30 <mizmo> windows 7??
19:54:42 <sgallagh> mizmo: Podium computer
19:54:46 <gholms> I think that's the podium box.
19:54:47 <m0zes> no!
19:54:54 <mizmo> boohiss
19:55:08 <j_dulaney> Hmm
19:55:14 <ianweller> daMaestro: you're up next
19:55:17 <dyelar> That's the machine sitting under the podium when no computer is connected.
19:55:28 <stickster> yeah, it takes over if no lappy connected
19:55:30 <maxamillion> someone should turn it off
19:55:38 <stickster> I think we'd have to intrude into the locked cabinet
19:55:41 <ianweller> maxamillion: it's in a locked door
19:55:51 <ianweller> maxamillion: have you seen the messages about getting a list of pads from the website? is that possible?
19:56:06 <stickster> sorry, we're stuck with it, let's overlook it since we have the space for free :-)
19:56:08 <maxamillion> ianweller: no idea, the docs are shit ... I'm still trying to find tha tout
19:56:13 <ianweller> maxamillion: ten four. thanks
19:56:24 <stickster> maxamillion: Try <URL>/admin
19:56:27 * rrix shrugs
19:56:54 <stickster> I think you need the password to auth, but I have an instance elsewhere and I think that's the entry point
19:57:02 <pingou> thanks nirik :)
19:57:15 <ianweller> lmacken: you're up next
19:57:36 <rrix> I bet that stuff sitting on the floor right in front of me is that webcam
19:57:56 <ianweller> rrix: you mean what i'm pointing at?
19:58:07 <ianweller> they're not the webcams we bought but
19:58:08 <ianweller> i unno
19:58:11 <rrix> ianweller: my face would be in my  palm right now but I'm typing
19:58:28 <ianweller> rrix: yeah that's why we need three arms
19:58:38 <rrix> I will borrow a raspi
19:58:39 <maxamillion> stickster: this is the node.js rewrite ofetherpad ... there is no /admin :(
19:58:42 <rrix> for that ARM
19:58:45 <maxamillion> of eherpad*
19:58:48 <ianweller> boo
19:58:55 <maxamillion> bleh
19:58:58 <maxamillion> I just can't type
19:59:08 <stickster> maxamillion: Yeah, that's the one I was talking about, there is still an /admin though, I have it running on my instance... but depends on config
19:59:54 <mizmo> maxamillion, https://github.com/ether/etherpad-lite/wiki/How-to-list-all-pads
19:59:58 <maxamillion> stickster: ohhhh ok, I tried /admin and it didn't go anywhere ... assumed it was just something left out
20:00:13 <mizmo> do you have shell access to it? thats for node.js etherpad ^^
20:00:16 <maxamillion> mizmo: your google-fu is clearly stronger than mine, thanks
20:00:21 <maxamillion> mizmo: I do have shell access
20:00:32 <mizmo> maxamillion, i don't use google, i use ddg :)
20:00:40 <maxamillion> mizmo: +1
20:00:45 <mizmo> where are these mockups he's showing?
20:00:53 <mizmo> is that on the wiki?
20:00:58 <ianweller> unsure, i'll ask
20:01:17 <maxamillion> mizmo: my ehterpad is using mongodb .... :(
20:01:46 <maxamillion> going to poke around
20:01:47 <notting> mizmo: the revizor mockups? looks like it's a local file in pencil he has
20:01:58 <rrix> Correct
20:02:00 <ianweller> i'll have him upload to fppl
20:02:00 * gholms nods
20:02:03 <herlo> ahh, pencil is great!
20:02:29 <Nushio> alright, i'll be back later, gonna grab something to eat
20:02:30 <rrix> "I'll add them to my fedorapeople"
20:02:32 <mizmo> maxamillion, doesnt look super hard? http://api.mongodb.org/wiki/current/Tutorial.html#Tutorial-SpecifyingWhattheQueryReturns
20:02:36 <Nushio> good luck with the lightning talks! :D
20:02:46 <Nushio> I'm hoping someone blogs about this :)
20:02:56 <mizmo> http://api.mongodb.org/wiki/current/SQL%20to%20Mongo%20Mapping%20Chart.html
20:03:34 <nickanderson> I planned on being there today. Father in law in surgery, maybe ill make it tomorrow or sunday
20:03:37 <ianweller> >> #fedora-fedmsg
20:03:52 <mizmo> fedmsg-notify as a gnome-shell extension
20:03:57 <mizmo> click on the bus and you can see it?
20:04:00 <maxamillion> mizmo: right, jus tneed to find it
20:04:02 <maxamillion> just*
20:04:05 <maxamillion> bleh ... can't type today
20:04:06 <nb> fedmsg does announcements?
20:04:07 <ianweller> mizmo: yep
20:04:09 <mizmo> you can configure all the topics you will get messages on
20:04:39 <mizmo> if you had a bug from an abrt crash, it'll subscribe you to any updates around that bug and notify you when that bug changes (super slick)
20:04:49 <mizmo> you can have it notify you if specific users or packages are mentioned
20:04:54 <mizmo> it works, current version is in testing right now
20:05:29 <mizmo> it shows the avatars of folks who are doing things, or the service icon
20:05:41 <rrix> i want fedmsg in kde
20:05:43 <ianweller> dwalsh: you're up next
20:05:44 <mizmo> next he's talking about pyrasite
20:05:53 <notting> fedmsg brings in tkinter. wtf?
20:05:55 <nirik> rrix: fedmsg-notify works in systray.
20:06:01 <rrix> nirik: yay
20:06:07 <ianweller> dwalsh: i'll get your URL up when you come up.
20:06:18 <mizmo> pyrasite injects code into running python process using gdb
20:06:33 <pknirsch> btw, for anyone interested, the Fedora Secondary Arch team for Power is meeting the next 2 days in 3154 in case you wanna check up with anyone from the team. We even have the team from IBM here as well!
20:07:05 <mizmo> theres a gui to make using pyrasite easiesr
20:07:18 <mizmo> all the processes you have running in python on your machine show up
20:07:36 <mizmo> if you click on the process, it shows you information about it in real time, cpu/mem usage, open files, open network connections, etc
20:07:41 <mizmo> you can view a stack trace of what it's doing
20:07:51 <mizmo> you can click on the objects, and it will gdb introspect the objects
20:07:57 <mizmo> so you can see the largest objects in your process
20:07:57 <ianweller> i should definitely look at the pyrasite code to se how insane the gdb hack is :)
20:08:03 <gholms> Heh
20:08:04 <mizmo> it'll generate a graph of what methods are getting called
20:08:10 <mizmo> there's also a pyrasite shell
20:08:31 <maxamillion> bleh ... this is annoying
20:09:05 <mizmo> dan walsh next
20:09:33 <rrix> or danie as his badge would like us to believe
20:09:55 <ianweller> rrix: i still can't get over tha t:P
20:10:01 <rrix> ;)
20:10:04 <gholms> Heh
20:10:06 <jlk> danie boy
20:10:17 <mizmo> his voice doesnt broadcast very well lol maybe too low
20:10:23 <mizmo> i cant transcribe him hehe
20:10:31 * ianweller transcribes what he can
20:10:38 <j_dulaney> byobu is cool
20:10:38 <rrix> I can crank my volume perhaps
20:10:38 <mizmo> what wiki page is he looking at?
20:10:42 <ianweller> in most programs you use -EPERM, which just returns the string "permission denied"
20:10:53 <ianweller> http://fedoraproject.org/wiki/Features/FriendlyEPERM
20:10:55 <gholms> mizmo: Features/FriendlyEPERM
20:11:17 <ianweller> the problem is that hte kernel knows why you get -EPERM but it doesn't bother telling the application
20:11:18 <mizmo> too loud
20:11:19 <mizmo> omg
20:11:22 <mizmo> the world is ending
20:11:23 <mizmo> phew
20:11:26 <mizmo> nooooo
20:11:28 <mizmo> ahhh
20:11:35 <mizmo> it sounds like an alien attack hehe
20:11:57 <ianweller> so the goal of this feature is to get applications able to understand why permission was denied
20:12:10 <j_dulaney> Indeed
20:12:21 <rrix> sorry
20:12:27 <rrix> my laptop mic must be drunk
20:12:28 <mizmo> its all good
20:12:32 <rrix> mizmo: fixed?
20:12:34 <ianweller> and i am losing where is hould even be typing lol.
20:12:49 <mizmo> rrix, yeh hehe, im not dying anymore
20:12:53 <rrix> ok
20:12:57 <rrix> That was an interesting bug
20:13:23 <j_dulaney> slow git clone is slow
20:14:14 <j_dulaney> Ooh, new kernel?
20:14:36 <rrix> BARCAMP
20:14:41 <rrix> I'm gonna kill the main room hangout
20:14:48 * j_dulaney likes friendly eperm
20:14:59 <rrix> choke has a high quality recording for the intertubes
20:15:15 <mizmo> wheres that at
20:16:01 <rrix> On the nice camera in the main room
20:16:06 <rrix> I think he's just recording
20:16:11 <mizmo> ah
20:16:11 <rrix> not streaming
20:16:35 <rrix> bbl
20:27:45 * MarkDude is in the right place?
20:27:49 <rrix> No
20:27:49 <ianweller> MarkDude: hiya
20:27:54 <rrix> ianweller: sshh
20:28:19 <MarkDude> Donde esta El Beefy Miraclo?
20:28:23 <nb> MarkDude, no se
20:28:41 <nb> El Beefy Miraclo no esta aquie
20:28:43 <nb> aqui i mean
20:28:45 <MarkDude> Habla Tagalog?
20:28:50 <sgallagh> MarkDude: It was messibly devoured by Schrodinger's Cat
20:28:57 <nb> yo hablo ingles
20:29:00 <rrix> where am i
20:29:02 <nb> y un poco de espanol
20:29:08 <nb> rrix, idk where are you?
20:29:11 <nb> lol
20:29:13 <sgallagh> Marco!
20:29:15 <rrix> mexico apparently
20:29:17 <MarkDude> sgallagh, 50% of the Miracle was devoured at best
20:29:17 <rrix> or spain
20:29:34 <daMaestro> mizmo, http://jsteffan.fedorapeople.org/revisor_fudcon_lawrence/ ... don't laugh too much as my UI work ;-)
20:29:37 <mizmo> a vaca se comiĆ³ la carne de vacuno de miraculo
20:29:38 <nb> Polo!
20:29:46 * ianweller is back on call to help with shit
20:30:01 <ianweller> oh crap when did this channel's language switch
20:30:08 <sgallagh> mizmo: "A cow ate the beefy miracle"?
20:30:11 <MarkDude> Speaking of shit, how do I see any stuff going on at FUDcon?
20:30:16 <mizmo> daMaestro, the .ep file is a pencil file?
20:30:18 <nb> sgallagh, yes, spherical cow ate beefy miracle
20:30:21 <rrix> ianweller: that's what I don't get
20:30:30 <daMaestro> mizmo, yeah
20:30:33 <rrix> MarkDude: there are g+ hangouts floating around
20:30:33 <mizmo> i think its funny for a cow to eat the beef. less funny for a cat
20:31:00 * ianweller needs to check out pencil apparently
20:31:00 <mizmo> daMaestro, its not packaged for fedora is it?
20:31:05 <sgallagh> MarkDude: http://fedoraproject.org/wiki/FUDCon:Lawrence_2013#Friday.2C_January_18
20:31:05 <mizmo> how do you like it?
20:31:11 <mizmo> ive used it before, it was kinda laggy tho
20:31:13 <makfinsky> MarkDude: Look at the header of the schedule table, there are links to the live feeds.
20:31:16 <sgallagh> A couple of the rooms have clickable links to youtube
20:31:17 <MarkDude> ok, so I need to boot  Mint partition
20:31:25 <mizmo> whoah really? wheres the schedule table
20:31:32 <mizmo> drop the etherpad link and replace with the schedule table
20:31:44 <mizmo> oh sweet!! upstream ships as a fedora rpm
20:31:47 <sgallagh> MarkDude: Why would you have to boot Mint?
20:31:49 <rrix> I *really* need to set up ansible
20:31:55 <ianweller> rrix: same here
20:32:04 <nb> abompard, hey, i noticed you added your gpg key to your fudcon registration.  are you interested in our gpg key signing saturday?
20:32:10 <rrix> ianweller: come to the ansible talk *dodges things thrown*
20:32:19 <ianweller> i'm manning reg
20:32:20 <MarkDude> sgallagh, so it will work
20:32:20 <abompard> nb: sure !
20:32:21 * nb throws things although he is not sure why
20:32:23 <ianweller> since my minions left
20:32:36 <notting> rrix: we're going to watch spot talk about overhauling the fedora release process
20:32:37 <nb> abompard, add yourself to the wiki at http://bit.ly/fudcon2013-keysigning please
20:32:37 <MarkDude> See: F14 and before :D
20:32:50 <rrix> notting: Yeah, that talk is in 2112 for a reason ;P
20:32:54 <sgallagh> MarkDude: I do not understand.
20:32:59 <mizmo> what!  The live recording you're trying to play is still being processed and will be available soon.
20:33:06 <mizmo> what is the definition of 'live' then
20:33:07 <rrix> what
20:33:09 <notting> rrix: true, there's no rush
20:33:12 <rrix> "mostly live"
20:33:18 <rrix> notting: *rimshot*
20:33:57 <nickanderson> anyone interested in talking about CFEngine 3 tomorrow or Sunday? I couldn't make it to propose a talk today
20:34:00 <sgallagh> mizmo: I've just been informed that the live feed is not working for this one.
20:34:01 <sgallagh> Sorry
20:34:06 <mizmo> :(
20:34:11 <MarkDude> Depend on what your definition of is *IS*
20:34:20 <mattdm> I'll try to summarize as it goes
20:34:29 <mattdm> spot is saying that f18 longest delay ever
20:34:47 <mattdm> "pushing to 9 months not solution because it'll just make more slip"
20:34:55 <mizmo> i got it to work from clint's g+ page
20:35:01 <mizmo> the youtube link doesn't work tho
20:35:07 <mattdm> "crazy idea for what we should do instead...."
20:35:15 <mattdm> mizmo: so I can stop typing? :)
20:35:17 <mizmo> Room 2112 / Fedora Release Model / https://plus.google.com/100952077644304838223/posts/Q6ggUKmUkLZ
20:35:36 <mizmo> the amount of work that anaconda needed for newui - there was no real way it could have landed in 6 months
20:35:54 <mizmo> but, if you didn't know, and you looked from a distance from our feature pgaes, you would think we were trying to land it in 6 months
20:36:04 <mizmo> we need to better communicate to our users, what it means for these big features to land in fedora
20:36:06 <stickster> maxamillion: Hey, I have an SQL statement that should get us close enough to a list of pads for now if you didn't figure it out already. jsmith was a HUGE help here
20:36:08 <mizmo> and how we indicate to them where they land in the cycle
20:36:20 <mizmo> if you picked up red hat linux at 6.0, you had a pretty good idea of what that was gonna be like
20:36:22 <stickster> maxamillion: Are you running mysql on the back end?
20:36:26 <mizmo> it was gonna have the beginnings of big changes inside of it
20:36:35 <lmacken> mizmo++
20:36:36 <mizmo> it wouldn't be as necessarily as finished / polished as say a 6.2
20:36:41 <mizmo> people new that there was a 6.1 coming after it
20:36:50 <maxamillion> stickster: no, node.js
20:36:56 <maxamillion> stickster: errr ... mongodb
20:36:59 <mizmo> users who weren't quite willing to jump at the 6.0 point could wait a bit longer for more polish to jump on towards the end of that point release cycle
20:37:10 <mizmo> so what if we look at fedora with a concept of cycles like this, the way we used to do red hat linux
20:37:10 <stickster> maxamillion: Hm, if I give you the sql I used, maybe you can figure out the port
20:37:18 <maxamillion> stickster: I hav ethe sql I need
20:37:22 <stickster> Ah
20:37:25 <mizmo> the 6 month period we have between releases, is okay. not sacrosanct, not something we can't talk about in addition to this
20:37:25 <stickster> Sorry I'm late, maxamillion :_)
20:37:27 <maxamillion> stickster: looking at trying to extract similar data with mongo
20:37:32 * nb should have made a Horde packaging hackfest
20:37:34 <mizmo> but for most of our features, thta timetable / timeline / amount of updates works pretty well
20:37:38 <stickster> Yup, I just did it with the mysql store I use on mine
20:37:44 * stickster closes lid to get to talk
20:37:45 <mizmo> im taking the concept of a rolling release and setting aside for now
20:37:48 <maxamillion> stickster: no worries .... I'm just a little lost
20:37:53 <mizmo> i dont want to talk about it for the rest of this session - pitch your own session if you want to
20:38:04 <mizmo> let's talk about fedora 20, it's far enough in the future
20:38:04 <daMaestro> mizmo, yeah it is
20:38:22 <daMaestro> mizmo, pencil-2.0.3-1.fc17.noarch
20:38:22 <mizmo> let's say at fedora 20, we'd call it 20.0. and what we'd call fedora 21, we'd call 20.1. and let's go through until 20.4
20:38:29 <mizmo> er 20.3 since we started at 0
20:38:37 <mizmo> each cycle is four releases, so that's a 2 year window of releasing things
20:38:44 <mizmo> at the beginning of the cycle, we start thinking what fedora needs
20:38:54 <mizmo> we pitch big picture ideas, things like systemd, anaconda rewrite
20:39:02 <mizmo> we talk about as a comunity how these things fit into a 24-month cycle of releases
20:39:12 <mizmo> how feature complete are we at 20.0 vs 20.1 vs 20.2 vs 20.3
20:39:20 <mizmo> and that's not to say features like anaconda would take all 4 to get to feature complete status
20:39:38 <mizmo> but when users pick up 20.0, they can look at the feature tracking and understand which bits will be landing at what point for large scale features
20:39:55 <mizmo> if user picks it up blindly and never reads the docs, there should be an understanding the lower the point release, the more raw the release is
20:40:06 <mizmo> i want to improve the usability of fedora in general so we can pull more users into our pool
20:40:12 <mizmo> we can't grow more contributors without more usres
20:40:25 <mizmo> it's hard to do usability improvements when every 6 months, everything is different, moving, and changing
20:40:37 <gholms> Sounds a lot like ubuntu's 4-release cycle.  (Not a complaint; just an observation)
20:40:42 <mizmo> that is part of the coolness of fedora. but from a user / testing / almost everything POV, it makes people trying to do those things crazy and burn out faster
20:40:45 <mizmo> so let's temper that a little bit
20:40:48 <mizmo> look at the concept of a cycle
20:40:56 <mizmo> over the cycle of the fedora 20 release (.0, .1, .2, .3
20:40:56 <graphite6> new link for room 3152 videos, https://www.youtube.com/channel/UCRX3Fdf5i5MAxBTZ49chqvw?feature=watch (sorry if this msg is a duplicate)
20:41:06 <mizmo> let's plan what fedora 20 is going to look like at the end of 20.3
20:41:14 <mizmo> we go for that, work towards that as a community
20:41:20 <mizmo> set our sights high, try to fix the big problems
20:41:32 <mizmo> a lot of people are afraid to tackle the big problems because they know there's no way to fit it into one release
20:41:46 <mizmo> as a community we can work together, put ourselves in the same boat, these four releases shooting towards this big goal
20:41:53 <mizmo> and this isn't to say we won't have smaller 6-month timeline features
20:42:17 <mizmo> (1) i'd argue the amount of features we put into the 6-month only category... is because contributors don't think beyond what fedora is in the next 6 months, and not beyond
20:42:24 <mizmo> going to a cycle model, forces us to think bigger and broader
20:42:28 <mizmo> what is your #2 spot
20:42:38 <mizmo> (2) upgradeability is a huge thing for users
20:42:50 <mizmo> as part of this cycle model, we have to pair it with in-place upgrades across the cycle release
20:43:03 <mizmo> so you can in-place upgrade from 20.0 to 20.1 on and on
20:43:16 <mizmo> we can offer people to upgrade to the next point releaes, or continue to receive updates for 20.0
20:43:28 <mizmo> time for questions
20:43:39 <ianweller> rbergeron: did choke find his bags
20:43:43 <mizmo> - one thing i see with that, there will be some set of users who will only want to use .3 or .4
20:43:53 <mizmo> - so they will want .4 to be supported until the next .4 comes out
20:43:59 <mizmo> - so what do we do to continue supporting them
20:44:17 <mizmo> (spot) if we do do this, we'll have a good idea if that's true when we get there
20:44:42 <mizmo> (spot) when we look at where we are at 20.2 / 20.3... if there are users who like the approach and want to treat the last release as an LTS release, we can consider that
20:44:45 <adamw> q. was from dgilmore (for the record)
20:44:48 <mizmo> (spot) but we dont want to promise that as a hook
20:44:59 <mizmo> (spot) the problem with an LTS approach is that you have to investigate more significant resources into that
20:45:08 <mizmo> (spot) i don't want fedora to step into rhel's playground
20:45:20 <traviscline> Any golang hackers?
20:45:29 <mizmo> (spot) it is worth considering a slightly longer cycle for that last release, like 18 months maybe
20:45:40 <mizmo> - question
20:45:51 <mizmo> - it sounded like from what i was hearing, the ability to upgrade
20:45:57 <mizmo> (mumbly)
20:46:16 <mizmo> - you're able to go 20.0 -> 20.1 -> 20.2 -> 20.3... in the planning process how will we make that possible?
20:46:24 <mizmo> (spot) i'm not trying to get around the reboot problem
20:46:29 <mizmo> (spot) and i'm not suggesting throwing out fedup
20:46:38 <adamw> mizmo: the question was about whether he was proposing to upgrade between minor releases without rebooting
20:46:41 <adamw> the answer is in the negative
20:46:43 <mizmo> (spot) i think it's more, offering to the user, 'there's a major update, you can use fedup to do this'
20:47:06 <mizmo> (spot) there won't be anything that takes more than the remaining time in the cycle to be proposed as a feature when there isn't enough time for it
20:47:24 <mizmo> (spot) for example, proposing something like systemd in 20.3... there's not enough time, we'd ask them to wait until 21.0
20:47:37 <mizmo> (spot) minor features, no problem. new version of an upstream project - no problem
20:47:57 <mizmo> yes, thats it lol
20:48:00 <mizmo> he pointed right at it
20:48:09 <mattdm> heh
20:48:09 <mizmo> john dulaney > question
20:48:18 <mizmo> - if we do do the long term support thing, the problem i see in fedora...
20:48:28 <mizmo> - fedora 16 usage is probably nil right now, even though it's technically support
20:48:33 <mizmo> (spot) no it's not, it's absolutely not
20:48:38 <mizmo> - well what about fedora 15?
20:48:42 <mizmo> - well let me rephrase this
20:48:46 <mizmo> - we don't have as much testing for updates
20:48:58 <mizmo> (spot) that's a valid concern, i have ideas for how to addrses that, you can talk to me about it tomorrow, but a summary
20:49:01 <mattdm> (chorus of no no no so much old release in use from whole room)
20:49:14 <mizmo> (spot) if you read what people write about fedora - "is this the stable release, or should i wait a few more?"
20:49:31 <mizmo> (spot) "16's a good one, stay there" people are already doing that kind of guesswork as to which is the "good" release
20:49:36 <MarkDude> F14 is the good release, IMHO.
20:49:49 <mizmo> (spot) if we go to a cycle model, small pieces move, big pieces don't... you will have an idea of what it will look like at the end (look from a visual mockup pov)
20:49:58 <mizmo> dennis?
20:50:06 <sgallagh> yes, dgilmore
20:50:14 <mizmo> (spot) from a gnome pov, we have to figure out what that line is, and for each of the desktop sigs
20:50:21 <mizmo> (spot) we can't force kde to lock into one version
20:50:21 <MarkDude> Saying anything less hurts how we are looked at by others if we cant admit flaws, IMHO
20:50:33 <mizmo> (dgilmore) from kde 3 to kde 4 in a release though... shouldn't do that
20:50:38 <mizmo> (spot) i dont want to nail down to that level
20:50:49 <mizmo> (spot) we should look at what's coming down the pipeline for each upstream desktop
20:50:53 <sgallagh> MarkDude: You may say what you wish about Gnome, but Gnome is not Fedora. It is one piece of Fedora.
20:51:01 <mizmo> (spot) talk about the look/feel functionality features that upstream is going to do, or what we will invest in ourselves
20:51:21 <MarkDude> When quaid has spoke of Fedora in the OVERVIEW, he has pointed to both HIGH and LOWPOINTS
20:51:21 <mizmo> (spot) if we don't hit it, not a huge idea. sometimes a minor releaes of gnome changes very minor things, sometimes it changes everything
20:51:26 <MarkDude> Thats TOSW
20:51:35 <mizmo> (dgilmore) kde 3->4 or gnome 2->3, i'm talking at that level
20:51:35 <adamw> MarkDude: something like 60-70% of people here are running G3, btw. i've seen one MATE box and one cinnamon.
20:51:47 <adamw> i see two cinnamon!
20:51:50 <mizmo> (spot) some of this is being transparent about what we want to do
20:51:52 <MarkDude> Mate
20:51:54 * mattdm is totally running g3 even though i'm a skeptic
20:52:01 <mizmo> (spot) going to the upstreams and asking them what their planning model looks like 2 years out
20:52:02 <iunruh> any KDE love?
20:52:09 <adamw> ianweller: yeah, some.
20:52:10 <adamw> gr.
20:52:11 <mizmo> (spot) some communities will be able to answer that, some don't think that far out that way
20:52:14 <ianweller> lol
20:52:16 <ianweller> hi
20:52:19 * gholms is still using gnome 3 as part of his attempt to give it a chance
20:52:28 <mizmo> (Spot) if gnome says, at the middle of our cycle, that they just pushed out gnome 4, everything is new and you contrl it with your mind powers...
20:52:34 <j_dulaney> gnome using mind powers ...
20:52:40 <mizmo> (spot) that's a disruptive event, so we say to them - this can come out in the next cyclke
20:52:49 <mizmo> (spot) it makes things more complicated from a develpoment pov
20:53:01 <mizmo> (Spot) but we can work on things for the next cycle as we work on the current cycle
20:53:05 <mizmo> who is this
20:53:06 <MarkDude> Once G3 HAS nice extensions set up- it extensibility is moot to most. Anyway, Im gonna go eat lunch. Anaconda and pretending F14 was not our highpoint? bbl
20:53:07 * rrix running kde in a very similar configuration to the gnome-shell workflow
20:53:16 <mizmo> (spot) i dont want to nail down on the anaconda guys specifically...
20:53:26 <mizmo> (??) there are features that
20:53:32 <mizmo> (spot) anaconda did not land in f18 feature complete
20:53:41 <FunkyPenguin> mizmo: the one that asked is Joe Brokmier
20:53:43 <mizmo> (adamw) there are somet hings that just take longer than 6 months to get to a releaseable point
20:53:57 <mizmo> (peter) we tried to do it outside of the release cycle for a long time, it doesn't work, you can't do it
20:54:08 <mizmo> (peter) you're overwhelmed with additional changes you have to do to merge back, in the tree
20:54:16 <mizmo> (peter) 6 months... nothing like the amount of time it takes to do that
20:54:25 <mizmo> (peter) i fail to see how this addresses that at all
20:54:36 <mizmo> (spot) that's probably valid, but i kind of want to say anaconda as an example is an outlier
20:54:46 <mizmo> (peter) it is, and it isn't. we need more of a flexible schedule than we usually do
20:54:51 <MarkDude> Anaconda = outlier
20:54:54 <MarkDude> :D
20:54:59 <mizmo> (spot) if we look at systemd instead of ancaonda...
20:55:11 <mizmo> (spot) systemd implemented across multiple releases, and it implemented significant features in every release
20:55:18 <mizmo> (spot) we're still not to a feature complete place with systemd
20:55:36 <mizmo> (spot) if we look at which features can we not release the distribution without... anaconda is the only example i can think of that couldn't be released in 6 mo stages
20:55:44 <mizmo> (?) we skipped systemd in f14 because it wasn't ready at all
20:55:53 <j_dulaney> mizmo:  That was me
20:56:18 <mizmo> (joe) i like the way you're thinking but, doesn't that eschew the idea.. a major anaconda or systemd sized thing tomorrow, and you're at 20.1, and you're telling me i have to hold it for 18 months - doesn't that kill the whole benefit of the 6 month releae cycle?
20:56:29 <mizmo> (spot) the window narrows the further you go. if it's a 12-month feature, you could do it at 20.1
20:57:01 <mizmo> (spot) assuming you could take the feature into 6 mo chunks... as that window narrows... if you have a 12 month feature and there's 12 months left, there is time to do it, for the community to weigh the balance, to see if it's okay to add to the long term vision
20:57:20 <mizmo> (spot) eventually the point comes where the window because too narrow for anything longer than 6 months, but the wait of time you have is also less
20:57:32 <mizmo> (spot) especially if we open up 21.0 for development before we finished with 20.3
20:57:34 <gholms> ^ That addresses the "You're going to make us wait for 18 months to roll out $major_release" issue.
20:57:37 <mizmo> (spot) i dont know if that works in practically but...
20:57:46 <mizmo> (joe) are you exchanging one set of problems for another?
20:57:52 <mizmo> (spot) dont know if this is perfect
20:58:01 <mizmo> is that peter?
20:58:14 <mizmo> (peter) most of the time when a .3 happened, it wasn't planned beforehand
20:58:16 <adamw> yes, pjones
20:58:23 <MarkDude> Thx for doing the typing mo :)
20:58:23 <mizmo> (spot) we were closer to a 3 release model
20:58:34 <adamw> we're talking old rhl again here
20:58:39 <mizmo> (peter) if we move to a model like this, you wouldn't want to nail down "there are x many each time"
20:58:54 <mizmo> (peter) instead, let's talk about what we want to do in the end, and figure out how many releases it would take to get there
20:59:03 <sgallagh> mizmo: Can you see his sketch?
20:59:04 <mizmo> i cant see your drawing
20:59:06 <mizmo> nope hehe
20:59:09 <mizmo> its okay tho
20:59:24 <j_dulaney> mizmo:  Timeline
20:59:34 <mattdm> moar planning!
20:59:35 <mizmo> (spot) the idea is that the way this model will succeed, is that we'll do more planning, more analysis, pre, during, and post
20:59:54 <mizmo> person taking photo of sketch, upload it :)
20:59:59 <j_dulaney> |-----|------|------|------|
20:59:59 <mizmo> sounds like an slr :)
21:00:09 <mattdm> 20.0|------|20.1|------|20.2|------|20.3|------|
21:00:12 <sgallagh> Points are 20.0, 20.2, 21.2...
21:00:12 <mizmo> if we have an annual conference that is big and focused at each of these 6 month points
21:00:16 <mizmo> then we have one conference to plan
21:00:18 <ryanlerch> mizmo: that was me... uploading the pic now
21:00:19 <mizmo> one conference to check status
21:00:29 <mizmo> and one conference to post mortem the last cycle and plan the next cycle
21:00:36 <sgallagh> mizmo: every other 6-month point, otherwise it would be biannual :)
21:00:40 <mizmo> that's why i chose that length as opposed to other lengths
21:00:47 <mizmo> if we can shift those lengths, that's fine
21:00:55 <mizmo> we just don't want users to decide mid-stream it's all changing on them
21:01:15 <mizmo> (spot) let's do this for the first cycle, at the end of it we decide what 21 looks like (as peter is suggesting)
21:01:21 <mizmo> (? very quiet person i can't hear)
21:01:36 <mattdm> not sure who it is...
21:01:42 <Emichan> mizmo, asking about using even/odd split for stable/unstable releases
21:01:45 <mattdm> question is: what about doing even/odd stable unstable
21:01:50 <mizmo> (spot) we could do it that way, but it's a little more complicated
21:01:52 <Emichan> also not sure who it is
21:02:04 <mizmo> (spot) if we add odd and even release complexity... i don't know that the value outweighs the complication
21:02:08 * mizmo notes that's how gimp releases work
21:02:16 <mizmo> (jcm ?)
21:02:19 <Emichan> mizmo, also gnome right?
21:02:26 <mattdm> yes jcm
21:02:32 <mizmo> (jcm) any change of this nature, eg LTS, they do have a big annual kickoff conf and they do these kind of planning cycles
21:02:35 <mattdm> he says the u word
21:02:43 <mizmo> (jcm) so we can learn from what they do, look at what they do badly, what they do well
21:02:49 <mizmo> i dont type that word, this is a family channel
21:03:00 <mizmo> (jcm) consider we may not live in that world, this is our long term release cycle...
21:03:11 <mizmo> (jcm) at the same time... (mumble)
21:03:26 <mizmo> (spot) im hesitant to do that because anaconda is special
21:03:29 <ryanlerch> here is the whiteboard: http://ryanlerch.fedorapeople.org/fudcon_photos/DSC_0022.JPG
21:03:38 <mizmo> (spot) can you name something else that took more than 6 months to get to feature completeness
21:03:44 <mizmo> (?? lots of ppl talking at once)
21:03:52 <mizmo> (spot) gnome 3.0 wasn't good, but it worked when it came out
21:04:05 <mizmo> (jcm) there are plenty of examples, wouldn't be nice if that had much more time to mature
21:04:13 <mizmo> (jcm) just enough to be shippable vs. very nice and polished
21:04:17 <mizmo> (spot) i agree with you on that point
21:04:21 <mizmo> (spot) that's exactly what i'm trying to target
21:04:33 <mizmo> (spot) if they had 6 months beyond bare functionality to have time to polish...
21:04:44 <mizmo> (spot) 6 months -- it'll work. 12 months -- it'll work *niiice*
21:04:51 <mizmo> (spot) we're moving towards a goal at the end
21:05:01 <rrix> PROTIP: Ansible can set up more ansible hosts. Deploy thousands of hosts from one laptop sitting at Starbucks
21:05:03 <mizmo> (spot) if you don't need all that time, you don't need it
21:05:20 <mizmo> (jcm) so we start the 20 cycle... at the 20.3 release, let's support it for 18 mos
21:05:31 <mizmo> (spot) that's negotiable, if you look at other (shall not be named) models
21:05:43 <mizmo> (jcm) continue in a 21 cycle that kicks off immediately
21:05:51 <mizmo> (spot) or is already in a branched state...
21:05:59 <mizmo> (spot) you'd have a 20 branch and a rawhide-ish branch for 21
21:06:05 <mizmo> (spot) and something beyond that for the 21 cycle
21:06:17 <mizmo> (peter) you're talking about us working on something for the future now...
21:06:30 <mizmo> (spot) it's not a requirement, its for people who need to work on their feature *now* and don't want to wait
21:06:36 <sgallagh> "(spot) you'd have a 20 branch and a rawhide-ish branch for 21" should have finished with 20.1
21:06:44 <mizmo> (spot) could always try something new if it doesn't work
21:06:53 <mizmo> (? hard to hear fellow)
21:07:02 <sgallagh> pjones
21:07:07 <mizmo> did he move?? lol
21:07:08 <mattdm> notting now
21:07:11 <sgallagh> Sorry, that's Bill
21:07:12 <mizmo> oh that is notting
21:07:21 <mattdm> linux moves faster now than it did in rhl days
21:07:23 <mizmo> (notting) bigger, moves much faster overall... a new kernel coming out every 2 months roughly...
21:07:31 <mizmo> (notting) my concern, how do we know we can go to this release model
21:07:32 <mattdm> how do we know we can go back to the release model from those days
21:07:39 <mattdm> with the much faster world
21:07:43 <mizmo> (spot) i looked at all of the features submitted for the last several fedora releases
21:07:53 <mizmo> (spot) would they have been pitched as big features split across multiple ones? (systemd)
21:07:59 <mizmo> (spot) or we can get this done in 6 omnths? (gcc)
21:08:10 <mizmo> (spot) the majority of features we have, that no one notices, are the ones that can be done in the 6 month window
21:08:19 <mizmo> (spot) updating php, rebuilding all the ruby packages, updated glibc, etc.
21:08:22 <ryanlerch> photo of the room for those reading on here: http://ryanlerch.fedorapeople.org/fudcon_photos/spots_release_cycle_talk.jpg
21:08:27 <mizmo> (spot) none of these guys are asking for more time to do those features
21:08:34 <mizmo> (spot) so i think for most features, it'll be business as usual
21:08:42 <mizmo> (spot) where this will change things is the big ticket features that need more time
21:08:50 <mizmo> (spot) and the focus finally on a consistent user experience
21:09:08 <mizmo> (spot) im not trying to do a rhel style backport abi/api kind of thing
21:09:26 <mizmo> (spot) it's a harder problem, but i still think it's a solvable problem, by the nature that we alrady do it today in a weird sort of way
21:09:39 <mizmo> (spot) it's a lack of people tasked on this problem, a lack of people working to solve this problem, is why we haven't solved it
21:09:49 <mizmo> (david) (so very faint)
21:10:01 <mizmo> dcantrell david?
21:10:05 <ryanlerch> ya
21:10:07 <mizmo> (spot) a valid point
21:10:10 <sgallagh> mizmo: He's concerned that no users will install 20.0 or 20.1
21:10:15 <mizmo> (spot) historical red hat linux, and ububu
21:10:26 <mizmo> (spot) there's not a huge drop of users for the non-LTS releases
21:10:41 <mizmo> (spot) if we did see user abandonment like that... we can change. i dont think it'll kill fedora to try it
21:10:44 <mizmo> (??)
21:10:51 <mizmo> (spot) i haven't but i was going to tlak to them at fosdem
21:11:02 <mizmo> (mattdm) what's the plan for point releases and their life cycle
21:11:07 <mizmo> (spot) they still get 13 months of updates
21:11:11 <mizmo> (mattdm) what about...
21:11:15 <mizmo> (spot) i worry about doing that initially
21:11:24 <mizmo> (spot) if we say we didn't need those extra months, we could drop them the next time
21:11:37 <mizmo> (peter) instead of saying that .1->.2 can be upgraded... ??
21:11:44 <mizmo> (spot) an interesting question, not opposed to an automatic migration
21:11:53 <mizmo> (Spot) but we want the user sto know that is what they are opting into by default
21:11:56 <ianweller> 9 minute warning for sessions :)
21:11:57 <mizmo> (spot) it's a marketing thing
21:12:05 <sgallagh> mizmo: Instead of saying they can, should we just upgrade them right away?
21:12:06 <mizmo> (spot) there are gonna be users who dont want that
21:12:16 <mizmo> (spot) user notification could ask them to go to it now
21:12:23 <mizmo> (??)
21:12:36 <mizmo> (spot) i agree with that but we still have people running fedora 12
21:12:41 <mizmo> i still dont entirely understand our userbase
21:12:45 <mizmo> (peter) because of our actions...
21:12:58 <mizmo> (spot) i think it's less about who wants to stick with 20.0, and when they are ready to go to 20.1
21:13:03 <mizmo> (??)
21:13:12 <mattdm> (so much everyone talking at once)
21:13:15 <mizmo> (??) people who are still on fedora 12 would never install a .0 release
21:13:29 <mizmo> (??) do we have the resources to maintain so many releases of fedora concurrently?
21:13:39 <mizmo> (spot) the model i'm proposing doesn't change the number of concurrently supported releases
21:13:51 <mizmo> (spot) if these numbers were 20, 21, 22, 23, it'd be the same as todays
21:13:56 <mattdm> (whole room assuming lts for last release)
21:13:56 <mizmo> (peter) for 21 we would be
21:13:59 <mattdm> (except for spot)
21:14:03 <mizmo> (spot) i'm not considering the lts thing because of that reason
21:14:18 <mizmo> (spot) im saying lts is not necessarily part of this proposal
21:14:45 <mizmo> (dennis) you could slow the flow of things to the user over time
21:14:52 <mizmo> (spot) users frustrated they aren't getting what they want?
21:14:53 <mizmo> (peter) ?
21:15:00 <mizmo> (spot) i agree i dont know that that really works
21:15:08 <maxamillion> mizmo: are you here?
21:15:13 <mizmo> maxamillion, no im in westford
21:15:20 <mizmo> (spot) if we don't change the lifecycle
21:15:27 <mizmo> (spot) 20.0 end of lifed way before 21.0 shows up
21:15:27 <maxamillion> mizmo: how are you transcribing this conversation?
21:15:32 <mizmo> maxamillion, g+ hangout
21:15:36 <maxamillion> ahhhhh
21:15:37 <maxamillion> magic
21:15:46 <mizmo> (sgallag) as soon as point release declared stable, make previous point releases security fix only
21:15:49 <mizmo> (spot) it's an option, definitely
21:16:17 <mizmo> (??) why do people stay on old release, stay $5000 on copy of matlab, different pieces of software, and works on f14 but doesnt work on f16 bc of library changes...
21:16:25 <mizmo> (?? else) then why arent you running rhel
21:16:31 <mizmo> (??) thats great but not everybody does that
21:16:40 <mizmo> (??) take something like nvidia's tool. they provide a versoin that runs on fedora
21:16:46 <mizmo> (??) take steam, they're talking about steam on fedora
21:16:59 <mizmo> (??) it seemst o me that's a lot of the reason why people stick to an old version, for longer than what you'd expect
21:17:02 <mizmo> (spot) i agree, i think that's valid
21:17:04 <abompard> nb: done, I'm on the keysigning page now.
21:17:05 <mattdm> (nvidia tool = cuda, the gpu programming library)
21:17:08 <mizmo> (spot) i dont know how to solve that problem without being rhel
21:17:16 <mizmo> (??) ??
21:17:18 <nb> abompard, great thanks
21:17:23 <mizmo> (spot) it depends how we define major change
21:17:23 <sgallagh> mizmo: jreznik
21:17:33 <mizmo> (jreznik) model is...
21:17:37 <mizmo> )spot) i don't agree with that
21:17:57 <mizmo> (??) you're developing against libraries that change over time. coda will not install on f17 because it requires a specific library version
21:18:03 <mizmo> (sounds like shitty packaging to me -mo)
21:18:05 <mattdm> cuda :)
21:18:13 <mizmo> (spot) it depends where we draw the line on major changes
21:18:23 <mattdm> (it's a compiler with some crazy gcc integration -- very version specific)
21:18:25 <mizmo> (spot) i think where you want to draw the line isn't where i want to draw the line
21:18:26 <sgallagh> mizmo: Shitty nVidia: bad hard-coding
21:18:43 <mizmo> (spot) rhel solves that problem, it does an excellent job of doing that...
21:19:01 <mizmo> (spot) the audience for fedora is less interested in the $500 copy of matlab, more interested in gnome++ and more interested in the newest latest greatest
21:19:23 <mattdm> (also those people should ditch matlab and move to python + scipy)
21:19:31 <mizmo> (spot) we're not going to take gimp away and replace it with something new in the middle of the cycle
21:19:32 <mattdm> (no one said that I'm just editorializing)
21:19:42 <mizmo> (spot) if gimp's menus move slightly, that's more acceptable than replacing gimp with something else
21:20:00 * mizmo where we get killed is where hot new app comes out and we dont have it packages
21:20:08 * mizmo dismayed we still don't have mypaint 1.1 packaged :(
21:20:26 <mizmo> (jcm) is he talking about ppa?
21:20:36 <mizmo> (jcm) i will admit i have a windows vm
21:20:39 <mizmo> (crowd) get out
21:20:51 <mizmo> (jcm) if there were a longer tail and you could actually install these tools nad have them keep working
21:21:15 * mizmo wants to know how this cycle will impact 3rd parties developing against fedora, for example, the amazon mp3 downloader that stopped working years ago
21:21:31 <mizmo> (Adamw) it gives up the option of having an LTS. we dont have that option today)
21:21:38 <mizmo> pick my question ^^! !
21:22:00 <mizmo> (??) i dont think LTS... any real ... fedora... LTS... i think that fedora....
21:22:06 <notting> mizmo: they discontinued it for all linux, iirc
21:22:12 <mizmo> oh, jerks
21:22:20 * j_dulaney notes that this will change much of the nature of Fedora
21:22:20 <notting> (admittedly, it broken on fedora for a while first)
21:22:26 <mattdm> mizmo I think the question is same as the matlab issue isn't it?
21:22:26 <mizmo> (??) 14 was great, let's make that one have a longer life
21:22:27 <jreznik> ?? == vicodan
21:22:39 * mizmo yeh but you don't know if it's good until you know it's good is the problem with this suggestion
21:22:42 * mizmo editorializing
21:22:45 <adamw> mizmo: dan408 is saying he doesn't think lts will 'solve' anything, that what we have are more specific problems with changes not being properly handled
21:22:45 * j_dulaney directs attention at "First"
21:22:59 <mizmo> (Adamw) f15 was such a major change with gnome 3
21:23:19 <mizmo> (??) i'm not sure changing the release model is to bring people from other distros. the goal is to make fedora better for our existing users and devs. right now we are losing people
21:23:19 <adamw> that was still dan, not me. :)
21:23:26 <adamw> last ?? was jwb.
21:23:26 <mizmo> adamw, sorry
21:23:28 <jonmasters> mizmo: if Fedora had an 18 month cycle...oh man, so much goodness would follow
21:23:36 <mizmo> people in the background sound like they are underwater
21:23:41 <mattdm> +1 jonmasters
21:23:43 <adamw> send lifebelts
21:23:44 <mizmo> (spot) the only way to grow the userbase isn't to steal them from ububu
21:23:49 <mizmo> (joe) who is it that you are trying to satisfy
21:23:49 <mattdm> mizmo the whole room is flooding right now
21:23:53 <mizmo> (spot) that's a good question
21:24:03 <adamw> as an online comment - i like spot's plan as a way to deal with the change firehose, i don't see it as a problem in fact
21:24:06 <mizmo> (spot) im trying to get the people who run OS X and not linux to give us a shot
21:24:11 <mizmo> (?) doesn't this change the nature of fedora
21:24:17 <adamw> i'm surprised he hasn't mentioned btrfs, which seems like a poster child for the change
21:24:23 <mizmo> (?) 20.3 release, very likely that other distros at that point have newer version of our features than us
21:24:25 <notting> so, targeting jlk
21:24:31 <mizmo> (spot) happens all the time depending on other distro's timing
21:24:45 <adamw> btrfs in the kernel is more or less done, all the infrastructure is there
21:24:49 <mizmo> (spot) that's why this isn't a build a 5 year linux on fedora
21:24:54 <adamw> but anaconda handling needs a lot of work, userspace needs a lot of work
21:24:55 <mizmo> (Spot) happy to hear ideas / propsoals / rotten fruit
21:25:29 <mizmo> now what can i do
21:25:39 <adamw> it would be perfect to land btrfs-by-default in 20.0 with basic anaconda support, refine anaconda and userspace support over .1, .2, .3
21:25:45 <adamw> anyway, yeah.
21:25:51 <adamw> mizmo: thanks for that effort!
21:25:58 <mizmo> adamw, lol no prob
21:26:06 <mizmo> i think it's logged??
21:26:22 <adamw> i have it in my proxy logs if not.
21:26:27 <adamw> least, i should do.
21:26:33 <mizmo> me too
21:26:38 <adamw> ok, next talk!
21:26:51 <elad661> for those of us who aren't at fudcon and just joined: are we going to have minor releases? (ie 19.1 and such?)
21:26:58 <mizmo> elad661, it was just a proposal from spot
21:27:06 <elad661> oh, okay
21:29:30 <nb> .ping
21:29:30 <zodbot> pong
21:31:45 <mizmo> there isn't a stream for the coprs talk is there?
21:32:06 <rdieter> not yet
21:32:57 <nb> mizmo, seth said you need to move to western massachusetts because they have rivers and streams and all kinds of things there
21:33:11 * nb thinks paul or rex or someone is trying to set a stream up
21:33:20 <mizmo> nb, yay!
21:36:35 * ianweller goes to find coprs talk
21:37:33 <gholms> ianweller: Please note stuff here if you can.
21:37:45 <stickster> mizmo: Working on getting a COPR stream up for you
21:38:07 <mizmo> stickster, thanks... im listening to ryan's g+ hangout now
21:38:12 <stickster> OK
21:38:42 <mizmo> lagggg
21:38:52 <mizmo> Coprs talk
21:39:03 <mizmo> The name kind of sucks, it stands for collection of package repositories
21:39:05 * stickster sorry he's failing here... just slow
21:39:15 <MarkDude> 2112 is security?
21:39:18 <mizmo> one of the other guys working on this... came up with a sheet of interesting names, all the trademark people said no :(
21:39:21 <stickster> MarkDude: correct
21:39:23 <mizmo> all of them rejected, so we moved along
21:39:26 <MarkDude> Ty Sir :)
21:39:32 <mattdm> mizmo: mypaint 1.1.0 bugzilla https://bugzilla.redhat.com/show_bug.cgi?id=891044
21:39:33 <mizmo> whatever anyone wants to name it is fine with me
21:39:35 <gholms> Thanks, mizmo!
21:39:36 <mizmo> spot doesn't like it
21:39:38 <mizmo> mattdm++
21:39:46 <MarkDude> He is moving nearly as much as I do when I talk :d
21:39:48 <mizmo> (skvidal) it is basically a ppa
21:39:52 <mizmo> (skvidal) but don't call it that
21:40:03 <mizmo> (Skvidal) this is the problem, we don't trust anybody
21:40:04 * MarkDude is in camera 50% at best.
21:40:07 <mizmo> everyone here builds packages in mock, right?
21:40:10 <ianweller> oh yeah nobody's at registration desk
21:40:12 <ianweller> so i'm still gonna sit here
21:40:14 <ianweller> wheeee
21:40:14 <mizmo> the build requirements for those packages are installed as root, in a chroot
21:40:16 <j_dulaney> MarkDude:  You're here?
21:40:20 <mizmo> how many people know how to get out of that chroot, as root?
21:40:24 <mizmo> that's the problem, it's easy to do
21:40:47 <mizmo> we cant have people building arbitrary packages against arbitrary sources on our production systems
21:40:48 <MarkDude> j_dulaney, nope
21:41:02 <MarkDude> Watching on G+ since Fedora rocks!
21:41:02 <mizmo> they could push through some changes someone may or may not see and trojan all of our koji builders in a horrible way
21:41:07 <mizmo> it is entirely possible
21:41:12 <mizmo> but im not going ot be able to fix that problem in this way
21:41:14 <MarkDude> Take that Circle Jerk of Friends Distro
21:41:18 <mizmo> this helps people to be able to build arbitrary packages
21:41:24 <mizmo> the core of the problem is that we can't build these on systems we rely on
21:41:25 <rrix> MarkDude: Aren't we that distro?
21:41:31 <mizmo> because we can't trust the people building the packages
21:41:40 <mizmo> the solution is sort of in the cloud, and it's sort of in the ad hoc ness of it all
21:41:44 <mizmo> we have 2 private cloud instances set up
21:41:47 <mizmo> that we are running instances on
21:41:54 <mizmo> we have 30-some odd instances on our eucalyptus cloud
21:41:57 <mizmo> what we want to be able to do...
21:42:00 <mizmo> here's the overview
21:42:05 <MarkDude> We may be rrix - but unlike Dudebuntu, we dont generally use that in our marketing
21:42:16 <rrix> MarkDude: Right ;)
21:42:18 <mizmo> we have a front-end which has been written by borislav... he goes by slavek
21:42:20 <MarkDude> :D
21:42:23 <mizmo> he works in brno
21:42:29 <notting> Bohuslav Kabrda
21:42:31 <mizmo> it takes a set of packages you want to build, a set of repos you want to draw from
21:42:36 <mizmo> and the backend does the actual building process
21:42:40 <mizmo> the backup connects...
21:42:45 <rrix> ianweller: do you have somewhere else you need to be? I can duck out of rbergero's session
21:42:53 <MarkDude> Are there separate room channels for talking on irc?
21:42:57 <rrix> yeah
21:42:59 <mizmo> builds what you want, spins off a new cloud instance, provisions the new cloud instance as a builder, builds the packages over there, rsyncs the results back, and then destroys the cloud instances
21:43:01 <rrix> no on eis using themt hough
21:43:05 <rrix> i can type
21:43:07 <mizmo> if you trojan that system, that's nice, we don't care. it can't go anywhere
21:43:20 <mizmo> if you wanted to have a sleep in your package so you could take over our cloud instance? that'll be cute
21:43:23 <ianweller> rrix: not really
21:43:30 <MarkDude> Thx rrix altho, most likely I will just listen here ;)
21:43:32 <ianweller> if somebody wants to hit me with a link to the coprs hangout that'd be great though
21:43:39 <mizmo> there's a limit, 30-60 minutes... gets torn down then, nobody cares
21:43:40 <ianweller> (lol)
21:43:45 <rrix> MarkDude: Right, you're not missing much in the other channels ;)
21:43:59 <mizmo> that time limit is per package, not build
21:44:05 <mizmo> so you could have 15 hours if you had a build of 15 packages
21:44:11 <mizmo> you can't just put a sleep in there and take the node over
21:44:16 * stickster gets the hangout up -- where should I share this URL?
21:44:18 <mizmo> we can take the node down if needed
21:44:27 <mizmo> stickster, here, and the fudcon event page?
21:44:29 * MarkDude likes having the option of asking question tho. For the weekend a few sessions it MIGHT be more relevant and used,
21:44:36 <stickster> https://plus.google.com/hangouts/_/7f4a4357825ccbd5761f60a7ba13b161b9a0a40f?authuser=0&hl=en-US#
21:44:47 <rrix> ianweller: i think https://www.youtube.com/watch?v=EjL3E6XKgSA&feature=player_embedded
21:44:49 <ianweller> oh damnit it wants me to get g+
21:44:57 <ianweller> rrix: that's not live
21:44:58 <rrix> no that is ansible?
21:45:00 <rrix> yeah
21:45:06 <rrix> oh coprs isn't in that room anyways
21:45:09 <ianweller> yeh
21:45:09 <rrix> that is where seth was not is
21:45:11 <rrix> I'm durnk
21:45:15 <ianweller> lol
21:45:43 <MarkDude> All joking aside, just the effort Fedorans are putting into making remote participation an option is a strong contrast to how others do things. Being OPEN as well as giving VOICE.
21:45:57 <mizmo> as of right now i dont know of a way for rsync to be exploited
21:46:00 * MarkDude wants to write a bit about thatawesomeness
21:46:16 <MarkDude> +1 drunk
21:46:29 <mizmo> right now they can be el6 images, fedora ones, it doesn't matter, as long as mock can run successfully inside them
21:46:36 <mizmo> i suspect they'll be fedora 18ish in relatively short amount of time
21:46:50 <mizmo> keep in mind el7 isn't too far off in the horizon
21:47:12 <mizmo> you have to have all the images set up in advanace... that's an extra step
21:47:21 <mizmo> (slide link?)
21:47:29 <mizmo> (spot) we're not planning on ejecting these packages back into koji at any point
21:47:44 <mizmo> )skvidal) the whole point is we don't want stuff we don't trust being put into koji
21:47:59 <mizmo> (skvidal) when toshio and i started talking about this, it seemed like it'd be more pain than it's worth to put them in koji
21:48:13 <mizmo> (ooh i can read the slides!)
21:48:17 <sgallagh> Does anyone in 2148 (copr) happen to have a pack of tums?
21:48:24 <mizmo> (skvidal) i will have the slides available, but not yet
21:48:28 <mizmo> the components we're using
21:48:45 <mizmo> python flask, uses openid to do communications. only works with fedora project accounts, and only one of the peopl ein the list. i can add your name to the list if you like
21:48:56 <mizmo> i will be happy to accept your testing
21:49:02 <ryanlerch> http://ryanlerch.fedorapeople.org/fudcon_photos/sethvidal_on_copr.jpg
21:49:06 <mizmo> we've fixed a large number of bugs in the 2 weeks past thanks to testers
21:49:18 <mizmo> anyone familiar with mockchain? does a chainbuild on a bunch of pacakges all at once
21:49:30 <mizmo> mockremote runs around that, ssh into a remote system and pulls in all the results
21:49:37 <mizmo> using eucalyptus right now as our private cloud
21:49:39 <mizmo> to spawn instances
21:49:55 <mizmo> this is not euca specific at all, uses ec2 api (?) so should work with ec2, openstack, cloudstack
21:50:08 <mizmo> we're just using ec2
21:50:16 <mizmo> you know the eucatools that come with eucalyptus?
21:50:25 <mizmo> everything we use has an ec2 interface that has all the pieces we need
21:50:34 <mizmo> ansible has a playbook language, one of the things it can do is spawn a new instance
21:50:43 <mizmo> so we stepped around needing too many special case libraries
21:51:01 <mizmo> demo time
21:51:20 <mizmo> here's the existing interface that will change
21:51:28 <mizmo> tdawson is our own troy dawson here in the crowd, give him a hand!
21:51:33 <mizmo> i'll give you the example of a brand new copr
21:51:41 <mizmo> a copr can have a collection of builds, and a collection of package within those builds
21:51:43 <mizmo> let's give it a name
21:51:44 <sgallagh> copr-fe.cloud.fedoraproject.org (if you're on The List)
21:51:55 <mizmo> i want a build for fedora 17 and fedora 18 i386, because those are used a lot
21:52:03 <mizmo> i dont need any repos for it, im not using anything special
21:52:06 <mizmo> im going to build... ansible
21:52:11 <mizmo> just beacuse i have it on hand
21:52:25 <mizmo> i'll paste that package in. it's pulling it from koji for this example, but it can come from anywhere - it's just a url to the source rpm
21:52:31 <mizmo> so i go over here... wait for my network... there it is
21:52:42 <mizmo> down here you can see a build id has been allocated, it's not yet running so we'll refresh the page...
21:52:52 <mizmo> then skip over to this window... my network connection died :(
21:53:27 <mizmo> black on white would be readable for me, but no biggie
21:53:47 <mizmo> you see right here... job 80 from the server side
21:53:50 <mizmo> i'm gonna stretch this out...
21:53:55 <mizmo> and... it's adding it to the work queue
21:54:00 <mattdm> breaking news from the cloud track: openstack vs cloudstack is puppies vs kittens.
21:54:03 <mizmo> we have a worker spawned up already, it's started to create an f17 chroot
21:54:12 <mizmo> now it's doing a build for that chroots
21:54:15 <gholms> Heh
21:54:17 <mizmo> we'll see, if we go back over the web browser
21:54:24 <mizmo> we have a url returned to us for viewing the build results
21:54:29 <mizmo> just a simple webserver, nothing fancy to it at all
21:54:49 <mizmo> that file will get update whenever more data is available... i dont have any special web browser tricks to make it autorefresh, there's no reason we can't, we just don't at the moment
21:54:49 <gholms> mattdm: If necessary I could break out the walrus.  Or a koala.
21:54:55 <mizmo> that one is still building as you can see....
21:55:05 <mizmo> while that's happening, let me show what ryan, of our user interface and design team
21:55:12 <mizmo> as mockups so you can see what this could look like in the future
21:55:13 <mattdm> gholms: I vote for the walrus
21:55:21 <mattdm> it just wants its bukkits, man.
21:55:27 <mizmo> url for mockups?
21:55:29 <gholms> :)
21:55:41 <mizmo> (ryan) i took spot's chromium packages as an example here
21:55:48 <mizmo> (ryan) one coprs is essentially one build in this mockup
21:55:56 <mizmo> (ryan) one copr = spot's chromium repo, for example
21:56:05 <mizmo> (ryan) so you can add your builds to that repo, that's basically it
21:56:22 <mizmo> (skvidal) so if we go back to this screen
21:56:37 <mizmo> when we submit a build, all the packages you submit to the build will chainbuild, so any things that failed, will be build again
21:56:49 <mizmo> in addition, any more add on builds that you add to this copr, they will use the preivous packages as build reqiurements
21:56:54 <mizmo> so you can keep adding on as you go
21:56:59 <mizmo> you keep adding on and build up a repo of whatever you want
21:57:13 <mizmo> it's not terribly breathtaking exciting, it just allows us to do it in a safer way than doing it on our koji builder
21:57:21 <mizmo> it loops through until it has the same result twice
21:57:32 <mizmo> if you go through once, and the result is the same time as the last time, it'll just fail out
21:57:47 <mizmo> if you get a different reuslt it keeps trying, in case a needed dep wasn't finished yet caused the build to fail
21:58:05 <mizmo> you might run out of disk space... this isn't set up for a large scale build
21:58:07 <adamw> pjones: https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Trackers
21:58:23 <mizmo> these instances have 20gb total space, so if you can't do this in 12 gb... if you're rebuilding a distro, you might want to talk to us abut why you're doing that here
21:58:28 <mizmo> there's not a lot to set up
21:58:34 <mizmo> the whole back end is running on two cloud instances in our private cloud
21:58:40 <mizmo> we have ansible playbooks if you want to set up your own
21:58:46 <mizmo> i could probably get this running in 20-30 minutes on ec2
21:58:53 <mizmo> this is not, agian, this is not intended to replace koji
21:59:11 <mizmo> we're not trying to keep track of all the data koji keeps track of. we're trying to let peopl ebuild arbitrary packages and have them available, and not have to go through koji
21:59:19 <mizmo> eg if i want to try an arbitrary set of packages for fedora
21:59:39 <mizmo> (?) is it per fas account that this is done?
21:59:53 <mizmo> (?) right now kernel team is building rawhide kernels without debug turned out
21:59:59 <mizmo> (skvidal) a single copr can be owned by multiple people
22:00:06 <mizmo> (?) how does this compare to a koji scratch build
22:00:10 <mizmo> (skvidal) it's all mock
22:00:21 <mizmo> (?) srcatch build takes twice as long as a regular biuld because of the priorities... etc
22:00:29 <mizmo> (?) if we submit it thru this... do you have perf comparisons?
22:00:36 <mizmo> (skvidal) i don't, i'm glad to add you rname to the list so you can try it?
22:00:49 <mizmo> (spot) as this becomes more popular, i think we'll need to solve the performance problems .... a good problem to have
22:00:57 <mizmo> (spot) we're not worried about it now, it's addressable when we get there
22:01:06 <mizmo> (skvidal) it can only spawn off 5 workers at a time right now
22:01:09 <mizmo> (skvidal) that's tweakable
22:01:18 <mizmo> (skvidal) we can have them connect to multiple cloud instances as well
22:01:26 <mizmo> (skividal) if you want to spawn out to amazon or rackspace or whatever...
22:01:33 <mizmo> (skvdial) i think our build got finished, lets see
22:01:38 <mizmo> (skvidal) refreshing, waiting for network
22:02:03 <mizmo> (skvidal) it finished, and succeeded, so we click on this link again... those two chroots and two builds which finished succesfully took 6 minutes, including starting up the instances.
22:02:07 <herlo> https://www.youtube.com/user/herlo0?v=J255Sud4rDI&feature=plcp <-- learned 2111
22:02:08 <mizmo> (skvidal) that's not too bad
22:02:16 <mizmo> (skvidal) repos per chroot
22:02:22 <herlo> https://www.youtube.com/user/herlo0?v=cK9nrvkrWjM&feature=plcp <-- learned 2112
22:02:32 <mizmo> (??) im curious why you don't have workers ready to go, powered and ready for a job?
22:02:43 <mizmo> (skvidal) it takes 72 seconds to spin up a brand new instance - doesn't make sense to have them sitting there doing nothing
22:02:48 <mizmo> (??) preservation of resources
22:03:00 <mizmo> (??) i have devs pushing out builds, 5 minute build time will be hard to sell
22:03:05 <mizmo> (sgallag) not worse than koji
22:03:14 <mizmo> (??) we dont use koji either
22:03:18 <mizmo> (??) dont want to say what we use
22:03:26 <mizmo> (skvidal) if you want to make this faster, and help me make it faster, i'm all ears
22:03:27 <sgallagh> ?? = Jonathan Steffon
22:03:28 <nb> ?? == jonathan steffan
22:03:30 <mizmo> (skvidal) most of the time is spent in the build
22:03:51 <mizmo> (skvidal) i have it down to the millisecond for each of them... tell me where you want to spend less time.. .instance creation is 1/5 of the time, i'm convinced most of the time is being spent on the build
22:03:57 <mizmo> (sgallg) what about populating the chroot?
22:03:58 <herlo> graphite6: what is the youtube url for 3152 now?
22:04:05 <mizmo> (skvidal) we can prepopulate our instances with a cache
22:04:06 <herlo> #info https://www.youtube.com/user/herlo0?v=J255Sud4rDI&feature=plcp <-- learned 2111
22:04:11 <mizmo> (skvidal) let me show you what we have
22:04:11 <herlo> #info https://www.youtube.com/user/herlo0?v=cK9nrvkrWjM&feature=plcp <-- learned 2112
22:04:19 <mizmo> (skvidal) here's the build log
22:04:33 <mizmo> (skvidal) executed mockchain 30 seconds afterwars... build finished 146 seconds later
22:04:40 <mizmo> (skvidal) finished around 2.5 minutes
22:04:47 <mizmo> (skvidal) not to bad, could use some speedups
22:05:08 <mizmo> (skvidal) we pull back all the mock logs too, not just the packages... let's see what we have here
22:05:20 <mizmo> (skvidal) that's an interesting point, we're running mock multiple times within the same instnace...
22:05:43 <mizmo> (skvidal) we do not tear down the instance within a same build. put 15 packages in the build, they'll be built on the same instnace, we don't spin up a new instance for each one of those 15
22:05:51 <mizmo> (skvidal) if you want to trojan your packages, your problem
22:06:04 <mizmo> (Skvidal) please talk to me, if you want to help
22:06:23 <mizmo> (sgallag) looks like majority is populating mock
22:06:26 <ianweller> anybody know where makfinsky is
22:06:36 <herlo> nm, found it
22:06:38 <mizmo> (skvidal) let me look at one of your builds
22:06:41 <stickster> ianweller he's here in 2148, COPR talk
22:06:46 <herlo> #info https://www.youtube.com/watch?v=hMNIGgP5v1U <-- learned 3152
22:06:51 <stickster> ianweller: Do you need me to pass a msg or something?
22:06:55 <mizmo> (??) they all depending on other packages.... openshift-?? the biggest?
22:07:09 <mizmo> (skvidal) that one failed
22:07:21 <mizmo> (skvidal) sometimes it means the package failed, sometimes it means i failed :)
22:07:27 <ianweller> stickster: have him write down his credit card info for catering for me... if somebody can bring that down to registration desk i can phone it in to catering
22:07:28 <mattdm> can someone fell that out re openshift q?
22:07:30 <mizmo> (skvidal) this won't solve 'your package is not building' - that doesn't go away
22:07:35 <mizmo> (skvidal) it tried to build rhc twice...
22:07:36 <ianweller> or i can do it later, and call it in tuesday
22:07:39 <mizmo> (skvidal) and it failed
22:07:51 <mizmo> (notting?) curious...
22:07:52 <stickster> ianweller: He's on his way down to you
22:07:55 <herlo> updated links on the wiki now too
22:07:55 <mizmo> (skvidal) use mirrors inside ec2
22:07:57 <ianweller> stickster: coo
22:07:59 <stickster> er, to reg desk
22:08:01 <mizmo> (notting) assuming for our case we have mirrors there
22:08:10 <mizmo> (skvidal) if you are building there all the time, just use a url with an internal path to ec2
22:08:15 <mizmo> (notting) if we do in ec2...
22:08:16 <sgallagh> mizmo: notting is asking if building out an EC2 environment would be too expensive
22:08:26 <mizmo> (skvidal) i'm not suggesting we should do it in ec2, i'm just saying if we needed to it would be possible
22:08:42 <mizmo> (spot) we could always watermark it, we could extend by such amount but only that much
22:09:05 <mizmo> (skvidal) the thing that's very importnat, know it will be an inconvenience for some people - we did not want people uploading srpms to us
22:09:15 <mizmo> (skvidal) you've seen the gb's worth of rpms... you want to upload those in a web browser?
22:09:18 <graphite6> herlo: https://www.youtube.com/watch?v=hMNIGgP5v1U&feature=plcp is the link to room 3152 live stream
22:09:22 <mizmo> (skvidal) so having them specify a url seemed easy enough
22:09:38 <mizmo> (skvidal) i talked to josh bressers about it as well... the backend talks out, nothing talks in
22:09:44 <herlo> graphite6: tx
22:10:01 <mizmo> (skvidal) the place building all the rpms, is making all the requests. it requets out to the front end, it pushes out to the front end... nobody makes a connection in that could change a build in anyway
22:10:19 <mizmo> (skvidal) the files that it hosts have to be available on a public URL, but the advatnage is that you can isolate the part that does all the work
22:10:29 <mizmo> (notting) and we are requiing... copr is suitable fo rfedora?
22:10:44 <mizmo> )skvidal) when it does the push to the vm, it has to do a check to see if the license matches our set of licenses...
22:10:55 <mizmo> (skvidal) i have a good idea on how license check could work, not ready yet (??)
22:11:05 <mizmo> (spot) license check - doesn't cover patents, and doesn't cover lying
22:11:26 <mizmo> (spot) the way we negotiated this - we'll trust this and verify/audit coprs regularly to make sure nothing is blatantly obviously legal there
22:11:35 <mizmo> (spot) any fedora account found to violate repeatedly will face a loss of account
22:11:54 <mizmo> (spot) this is the rule, don't shove illegal stuff into this hole. you'll get a warning and then get your account booted
22:12:16 <rrix> skvidal: What's the URL for the infra ansible scripts? I'd love to take a look at them.
22:12:16 <mizmo> (spot) fedora legal has less than a 24 hour turnaround, if you have legal issues aorund fedora please talk to fedora legal
22:12:27 <rrix> actually let me google that
22:12:28 <mizmo> (skvidal) we don't have a way to password protect these
22:12:34 <nb> rrix, /git/ansible.git on lockbox01 i think
22:12:38 <rrix> Yeah
22:12:41 <mizmo> (skvidal) i now mod_auth pg exists, dont want to use
22:12:43 <rrix> #link http://infrastructure.fedoraproject.org/cgit/ansible.git/
22:12:50 <mizmo> (spot) they wanted a way for coprs to be private - not done yet, it's on the roadmap
22:12:53 <rrix> nb: <3
22:13:14 <mizmo> (spot) there's private, and there's locked down. those are different problems.
22:13:35 <mizmo> (sgallag) several ways to do this build into various frameworks
22:13:45 <mizmo> (skvidal) the front end offers this, the backend is a separate path
22:13:55 <mizmo> (skvidal) all this is is a webserver sitting there hosting files
22:14:00 <mizmo> nothing fancy
22:14:24 <mizmo> (kanarip) something about postgres?
22:14:36 <mizmo> (skvidal) mod)auth)pg exists, don't really want these ssystems talking directly to fas database
22:14:41 <mizmo> (skvidal) we don't store passwords locally on fas
22:14:49 <mizmo> (kanarip) can i connect with my ssh?
22:14:56 <mizmo> (skvidal) do you want those files owned by you locally?
22:15:03 <mizmo> (kanarip) trying to suggest a path to private repos
22:15:26 <mizmo> (skvidal) we can work on these things
22:15:58 <mizmo> (skvidal) if we want them to shrae with a group of people - not unreasonable, i do genuinely believe the first thing majority of people want to do is to build some packages and get them out to a bunch of folks
22:16:11 <mizmo> (skvidal) i hope that's the majority use case. if you're just using us for computational resources - t hat's kind of a dick move!
22:16:47 <mizmo> (skvidal) so, um... okay, i think that's the majority of what i had, more q's?
22:16:55 <mizmo> (kanarip) yeah, would you consider doing git urls as well, to dist-gist specifically?
22:17:17 <mizmo> (skvidal) we had this discussion early on... it was a very important subj that came up. we want to accept srpms and output repos.... if you can't make a srpm, don't talk to me
22:17:26 <rrix> OT: Does the Nexus4 support Qi wireless charging? I can't tell through googling
22:17:32 <mizmo> (spot) the folks in brno are working on something that is a tool to take lots of different things and generate a srpms as a result
22:17:40 <mizmo> (spot) making their own front end possible to use this backend
22:17:45 <rrix> Oh yeah, it totally does
22:17:50 <mizmo> (skvidal) there's a copr mailing list that is available
22:17:59 <mizmo> (skvidal) right now we're discussing a cli tool for all of this
22:18:11 <mizmo> (skvidal) troy suggested this on the list, two of us working on it now but no finished project yet
22:18:12 <rrix> I remember the Palm Touchstone knockoff thing now
22:18:21 <mizmo> (skvidal) i may or maynot have time to work on this at the hackfest tomorrow
22:18:29 <mizmo> (skvidal) if you want to add giturl support...
22:18:50 <mizmo> (spot) don't want this feature creep thing... want to avoid as much as possible... agile focused things that do one task very well, with multiple ways to get into that task
22:19:04 <mizmo> (Spot) e.g., - you do the build, and spit out the rpm. don't care where the srpm came from as long as its there
22:19:11 <mizmo> (sgallag) (mentioned something about jenkins)
22:19:31 <mizmo> (spot) specific cases, guy who tracks ?? wants to shove out rpms for people who want to bleed all over themselves
22:19:38 <stickster> ?? = TexLive
22:19:41 <mizmo> (Spot) dont' want a huge level of complexity
22:19:45 <sgallagh> mizmo: a CLI would be useful for tying into a continuous-integration system (i.e. do a build and run tests on each commit to git)
22:20:14 <mizmo> (skvidal) one of the things tat was importnat - we wanted all of the tools along the way to be functional pieces on their own. mockchain, a good tool in itself. the cloud system - we needed anyway, can be used for other things
22:20:22 <mizmo> (skvidal) cool from a usefulness point of view
22:20:33 <mizmo> (skvidal) we wanted to keep the focus narrow bc we didn't want too many pieces
22:20:36 <sgallagh> The Law of Unintended Consequences is working in our favor for once :)
22:20:37 <mizmo> (kanarip) fair enough
22:20:38 <abadger1999> pingou: how is/how did your talk go?
22:20:40 <mizmo> (skvidal) thank you everybody
22:20:51 <mizmo> i see you :)
22:20:52 <rrix> damn, qi stuff is expensive. Palm touchstone pucks are 10$ on amazon :(
22:20:54 <mizmo> my mike is off
22:20:59 <mizmo> nice soul patch dude
22:21:10 <mizmo> oh i want to see that one
22:21:20 <mizmo> yay :)
22:22:08 <mattdm> gholms: quick go put up the walrus picture
22:22:26 <gholms> AAAAAH!
22:22:30 * gholms goes to dig it up
22:22:53 * mizmo runs for bio break
22:22:58 <mizmo> should i transcribe the next one in a specific room other than this?
22:23:13 <gholms> Which one will you do next, mizmo?
22:24:14 <ianweller> i definitely swapped thinkpad chargers with somebody thursday night
22:24:15 <ianweller> oh well
22:24:25 <stickster> Live stream from Learned 2148 is up! (sorry for being late) http://youtu.be/if5BJX9WLEc
22:26:20 <mizmo> gholms, i wanna do the fedora formulas one!
22:26:54 <mizmo> ahh this is so nice, i can sit on my butt and move rooms
22:26:57 <maxamillion> stickster: I don't know what's going on with the etherpad, I found the mongo query to get the info and I just can't seem to get etherpad to spit it out
22:27:09 <maxamillion> stickster: my talk is about to come up so I'll mess with this later
22:27:16 <mizmo> thanks stickster you rock!!! clint and sarah too
22:27:53 <stickster> Okey dokey
22:27:57 <stickster> mizmo: No, YOU ROCK
22:28:23 <Nushio> mizmo: thanks for typing everything!
22:28:30 <elad661> so which link is the Fedora Formulas one?
22:28:37 <elad661> 2148?
22:28:54 <gomix> mizmo: yup, thanks
22:28:55 <mizmo> elad661, 2148 yeh!
22:29:02 * elad661 watches the stream
22:29:08 * gomix watches too
22:29:14 <mizmo> its my pleasure Nushio, gomix
22:29:17 <elad661> livestreaming the conference is an excellent idea
22:30:23 <mizmo> so once they stream, can the video be watched again later?
22:30:38 * mizmo thinking about blogging the ones she transcribed, would be cool to link to the vid too
22:31:25 <Nushio> mizmo: yeah, the video is stored, I'm not sure if its auto-published or if someone has to hit "publish"
22:31:29 <ianweller> IMPORTANT ANNOUNCEMENT: when you are done with the last talk in your room, please remove any trash and set the desks back to what you think is normal
22:32:24 <mizmo> Talk: Spins & Their Future / Fedora Formulas
22:32:32 <mizmo> (dgilmore) from release engineering POV, i would just like to kill spins
22:32:36 <stickster> ianweller: I'll take responsibility for 2148
22:32:42 <ianweller> stickster: rad
22:32:44 <mizmo> the main reason being, other than the main desktops, they don't seem to get any QA
22:32:48 <stickster> \m/
22:32:56 <mizmo> some of the spins won't compose for whatever reason
22:33:06 <mizmo> spin owners are supposed to be on top of them, making sure they fix and test them
22:33:16 <mizmo> fedora 18 for instance - we have no games spin, because it failed to compose for the past month
22:33:30 <mizmo> the spin owner didn't notice none of the spin candidates had his spin. so it obviously didn't have QA
22:33:42 <mizmo> in f17, i fixed a couple of the spins that were failing to compose so we had them
22:33:56 <Sparks_too> ianweller: Where for food tonight?
22:34:02 <mizmo> in f16, there were some pretty major bugs in f16
22:34:06 <mizmo> noone's stepping up to fix it
22:34:10 <ianweller> Sparks_too: there's pizza and cupcakes at 7 at the hotel :)
22:34:13 <mizmo> so, why dont we just not do spins anymore...
22:34:15 <ianweller> like i keep having to tell everybody apparently
22:34:25 <herlo> ianweller: we don't pay attention :)
22:34:26 <mizmo> (?) is that true for just a couple of them?
22:34:30 <mizmo> (spot) it's most of them
22:34:48 <herlo> ianweller: do you have any shot glasses?
22:34:50 <ianweller> mizmo: (spot isn't in that room, he's standing in front of me)
22:34:59 <mizmo> (dgilmore) some like sugar get testing throughout the whole process because we ship them and the QE guys try to test them as much as they can, but they don't get as much testing as KDE and desktop do
22:35:07 <mizmo> ianweller, s/spot/someone who sounded like spot LOL
22:35:22 <mizmo> (dgilmore) kde and gnome, we can't get away from. the functionality of spins is nice to have.
22:35:34 <mizmo> maybe there's a way to get the experience of the games spin, etc., through anaconda or some other way
22:35:46 <rrix> herlo: what is in this drink, now?
22:35:48 <ianweller> spot just left to go get booze, uh oh
22:35:49 <mizmo> maybe the answer is we only have a spin if 2-3 people sign up and agree to test it and tell us that it works
22:36:07 <mizmo> right now, when we ship them, there's no sign off to say, someone's tested the design suite, someone's tested games... etc
22:36:10 <MarkDude> No booze?
22:36:12 <herlo> rrix: http://www.drinksmixer.com/cat/434/
22:36:13 <MarkDude> FAIL.
22:36:14 <mizmo> (??) aren't there individual owners for those spins?
22:36:17 <Sparks_too> ianweller: Thanks for the reminder
22:36:19 <herlo> MarkDude: oh, it's boozey
22:36:20 <mizmo> (dgilmore) yes, but their communication is zilch
22:36:32 <herlo> ianweller: um, no
22:36:39 <mizmo> (??) people put a lot of work into their kickstarts, and i think there's a large perception, i made it, i'm done... and they don't know what else is involved... someone else picks it up
22:36:41 <MarkDude> herlo, I assumed so.
22:36:42 <herlo> ianweller: spot had booze before
22:36:44 <Sparks_too> ianweller: I've got SELinux on the brain
22:36:50 <herlo> I think he went to get more maybe
22:36:55 <mizmo> (dgilmore) in fedora 18, there were 4 proposed spins that never got in, because the spins process collapsed and failed to happen
22:37:01 <rrix> herlo: that is dangerous
22:37:02 * MarkDude apologized to folks for all the pics I posted from FUDcon for the booze
22:37:07 <herlo> rrix: it's yummy
22:37:10 <mizmo> (stickster) rather than just as points of failure or people not understanding the role they need to take -
22:37:11 <mdomsch> mizmo, I'm the ?? in there :-)
22:37:13 <rrix> herlo: that's what I said
22:37:15 <MarkDude> I mean,beers, everything
22:37:16 <herlo> lol
22:37:20 <herlo> rrix: sure you did
22:37:21 <MarkDude> hard booze
22:37:23 <mizmo> (stickster) spins were created so people could create different sides to what fedora provides
22:37:34 <mizmo> (stickster) we know there are significant numbers of people who do fedora electronics lab, etc.
22:37:34 <Sparks_too> mizmo: I think there are room-specific fudcon channels
22:37:41 <rrix> herlo: You're going to make me lose at poker twice as fast
22:37:45 <mizmo> (stickster) don't want to burden them with infrastructure / release cycle...
22:37:50 <herlo> rrix: duh :D
22:37:51 <mizmo> (??) there's an electronic lab talk going on right now
22:37:57 <rrix> herlo: damn youuuuu
22:37:59 * MarkDude wants to share on social media
22:38:01 <herlo> that, and enjoy your 21st year
22:38:05 <mizmo> (??) this may come as a surprise, our community is not as large as it once was
22:38:05 <herlo> rrix: ^^
22:38:17 <stickster> (svidal) surprise comment above ^^
22:38:25 <mizmo> (skvidal) i think the trouble is, when you have one person who is the spins community, people didn't have time or interest...
22:38:38 <rrix> herlo: good point
22:38:40 <mizmo> (skvidal) if we focus on the main system, make it easy to do something like this - i don't think we're losing anything in this case, we're just losing unreliable offerings
22:38:46 <mizmo> (dgilmore) and that's mostly what i'm getting at
22:38:53 <mizmo> (dgilmore) these new spins never got reviewed, tested, accepted
22:39:08 <herlo> rrix: the only rule I heard (from rbergeron) is that you have to be standing tomorrow. I am pretty sure I can make that happen with 'wake up juice'
22:39:17 <mizmo> (dgilmore) one did a very good job at being vocal at pushing things... still fell down, didn't get it done, because they realize what they needed until a week before release
22:39:30 <herlo> rrix: http://www.youtube.com/watch?v=eaUvLAvtNck
22:39:30 <rrix> dgilmore: when you're not talking to the room I'm in, could I borrow the charge cable for your fitbit for a few hours?
22:39:31 <mizmo> (dgilmore) redefining what that is, things that are more efficient to get the same result as intended as spins
22:39:36 * MarkDude is willing to bet our graph coincides with Gnome peaks, if not just F14
22:39:38 <mizmo> (dgilmore) let's just not say we suck and we won't do this
22:39:55 <rrix> herlo: Bros!
22:40:00 <rrix> bros on mute
22:40:02 <mizmo> (dan) was looking at pushing for spin - a large number of my jboss colleagues don't use linux, they use mac
22:40:10 <herlo> rrix: lol
22:40:11 <MarkDude> Thats the data I have seen. The actual numbers, altho- that does not cover everything
22:40:21 <mizmo> (dan) they say they want stuff out of the box, i want to be able to hand them sojething and tell them they don't need to install anything
22:40:47 <mizmo> (dan) if we gave them a spin and put it out there... biased to them
22:40:58 * ianweller starts picking up registration table
22:40:59 <mizmo> (dan) a python developer might have what they need out of the box with the desktop spin, but a java developer woudln't
22:41:15 <mizmo> (dgilmore) maybe an option would be --- customize your experience... hey i'm a java developer
22:41:24 <mizmo> (dgilmore) the community has said, these are the things a java developer would like
22:41:30 <mizmo> (dgilmore) i like to make robots, here's stuff for robots
22:41:35 <mizmo> (??) isn't that the java yum package group?
22:41:40 <mizmo> (??2) yes and no, there's comps as well
22:41:58 <mizmo> (dan) at least for some of the ones i've seen, they're really bad. the java group pulls in all sorts of stuff you don't need and misses stuff you do
22:42:03 <mizmo> (dan) but what about a better process..
22:42:27 <mizmo> (??) it's difficult to be precise with these sort of things. do you want to run java programs? develop java? even with a spin...
22:42:42 <mizmo> (??) if you say im making this specifically for jboss developers - that's very narrow compared to all java devs or users
22:42:50 <mizmo> (??2) the desktop spin has libvirt in it by default
22:42:55 <mizmo> (??) i think that's pulled in by boxes
22:43:05 <mizmo> (dgilmore) virtualization-gnome package group has boxes and libvirt
22:43:12 <mizmo> (dgilmore) it was in f17 as well
22:43:16 <mizmo> (??) i never installed it...
22:43:20 <mizmo> (??) is boxes optional?
22:43:23 <mizmo> (??2) i don't know
22:43:34 <elad661> Boxes is default
22:43:43 <mizmo> (??3) as minimal as virt-manager is, you need something more minimal?
22:43:47 <mizmo> (going off track here guys?)
22:44:14 <mizmo> (??) maybe at some point we might want to see what's being pulled
22:44:22 <mizmo> (??) maybe put in java development stuff
22:44:30 <mattdm> (sooo of track sorry)
22:44:31 <mizmo> yes please lets get back on topic :)
22:44:36 <mizmo> thanks
22:44:50 <mizmo> (??) i like the spins because it shows what each desktop does, what it looks like, stuff like that
22:45:02 <mizmo> (??) kde, gnome, lxde, etc
22:45:19 <mizmo> (??2) the spins for desktops arent going away...i would argue that's the only place where there's a valid reason to have a spin
22:45:26 <tburke> mizmo: in anaconda talk
22:45:27 <mizmo> (??2) in terms of everything else, formulas, i really like the idea
22:45:31 <elad661> That's not so accurate, the text on the spin sites is a marketing blurb
22:45:40 <tburke> I didn't understand that checkbox at bottom of kbd selection screen
22:45:46 <tburke> not obvious
22:46:06 <tburke> use default
22:46:15 <mizmo> tburke, the reason we added that checkbox in is because by default, we set US english as the default keyboard layout. the checkbox sets the default layout to your language's default
22:46:24 <mizmo> tburke, the problem with setting the language's default is two fold -
22:46:46 <mizmo> tburke, if you accidentally pick the wrong language, your keyboard will instantly change to a layout where you may not be able to use your keyboard to fix the problem and move it to the one you meant to pick
22:47:15 <mizmo> tburke, some languages have multiple keyboard layouts (french is a good example here, french from france and canadian french) and we don't know which one you want, they are different enough you couldn't interact with the system if we picked the wrong one for you
22:47:21 <abadger1999> Rm 2148:  https://fedoraproject.org/wiki/Fedora_formulas
22:47:32 <abadger1999> (kevin) giving a summary of that page now
22:47:36 <mdomsch> ??2 is herlo
22:47:38 <mizmo> (nirik) interactive system, optional thing, do you want a tour? we'll play a screencast for you and show you the features of this thing
22:47:38 <mdomsch> ??3 is me
22:47:52 <tburke> mizmo, why not have it checked by default?
22:48:07 <mizmo> (nirik) i think this could be a very powerful way to have a collection of stuff that somebody could go to and say, music development, i want to play with a music development
22:48:07 <elad661> [re: formulas] this idea needs some UX work, but I like it
22:48:28 <nb> rrix, logout url is https://1.1.1.1/logout.html
22:48:34 * nb suggests we use #fedora-fudcon-a,b,c,d,e,f
22:48:46 <mizmo> tburke, in anaconda we always pick the safest choice as the default, eg. anything that has a risk of destroying data, we don't pick as a default even if it would be more common. if we set changing your layout to something that has a chance of being unusable by you, it's less safe than sticking with us eng (or at least, that's the philosophy that drove the decision)
22:49:12 <mizmo> tburke, it's certainly something we can revisit. we're doing a usability test at devconf in brno next month, and a big part of that is to understand better the non-english/US experience through the UI
22:49:13 <ianweller> rrix: hehy i still have your USB cable at the reg desk come get it at some point
22:49:26 <mizmo> (?) what about something like revisor
22:49:29 <rrix> ianweller: I don't need it any time soon, just give it to me next time I see you
22:49:36 <ianweller> rrix: aight
22:49:50 <stickster> (2148-kevin) Think of avg forensics guy -- would he rather download the security ISO, burn and run, or go through a bunch of steps to get a GNOME image, add things, run it, discover things missing, go back, etc.
22:49:50 <mizmo> (nirik) think about something like your average forensics guy... would you rather download a spin, or build your own from a wizard?
22:49:57 <herlo> nb: you suggested that hours ago too :)
22:50:10 <mizmo> (smooge?) half the time when im dealing with the security iso - there's things on that iso that are greatly out of date that i have to update
22:50:27 <mizmo> (?) will it ever be the case that a spin would be perfect... i want this security stuff - oh but i really want emacs, i want emacs too
22:50:34 <stickster> mizmo: WHO DOESN'T?!?
22:50:36 <mizmo> (nirik) the only way you'd get something perfect for you like that is if you make it for yourself
22:50:38 <stickster> :-D
22:50:52 <herlo> stickster: many people don't want EMACS!
22:50:57 <herlo> :D
22:51:01 <m0zes> the answer is genroo
22:51:03 <mizmo> (??) but i want to be able to save my live cd
22:51:06 <mizmo> i want a repeatable live cd
22:51:08 <m0zes> s/genroo/gentoo
22:51:09 <mizmo> that's what i'm talking about
22:51:12 <mizmo> it's like a puppet manifest
22:51:14 <nb> herlo, lol we did use it briefly a little bit before lunch
22:51:19 <mizmo> (nirik) yeh, except that is constrainted
22:51:22 <herlo> nb: :)
22:51:32 * nb wonders if we have a meeting going in here so it will make logs
22:51:36 <nb> .listmeetings
22:51:36 <zodbot> nb: ('#fedora-fudcon', 'freenode')
22:51:37 <mizmo> (nirik) say your use case is, i have a lab of 20 machines, i want to boot those 20 machines off this CD on a graphic design thing so i can teach a class on the gimp
22:51:40 <nb> yes, we do
22:51:47 * mizmo <== been in this case multiple times
22:52:03 <ianweller> nb: like i said earlier........ zodbot keeps logs regardless of meetbot running or not. they're just not public but you can go get them.
22:52:10 <ianweller> and then we can post them
22:52:10 <mizmo> (nirik) gimp is 20 meg, 40 meg... the space issues - you would have to install or setup the CD in such a way that you apply the changes to it, make a new cd or usb, new image
22:52:10 <nb> ianweller, true
22:52:22 * mizmo <= when i was in that case, nirik, i had to create my own spin for the girl scouts
22:52:56 <mizmo> (kanarip) doesn't eliminate the problems you now have with livecd
22:53:03 <mattdm> mizmo how hard was it to create your own livecd?
22:53:09 <elad661> stop thinking about CDs, CDs are obsolete
22:53:18 <elad661> mattdm: it's pretty difficult, actually
22:53:21 <mizmo> mattdm, massively hard. like, crying and tearing my hear out and panicking for a solid 2-3 weeks hard :(
22:53:24 <elad661> there's no good UIs to do it
22:53:36 <mizmo> (skvidal) is it possible to separate this out a little bit - ignore for a moment the efficacy of spins. set it aside for a moment
22:53:44 <mizmo> (skvidal) let's look at what it is would be more compelling as a formula
22:53:53 <mizmo> (skvidal) kevin made a case the desktop case not a compelling case
22:54:06 <mizmo> (skvidal) what about a billion cloud instances? a set of servers? those are cases that are very compelling to me
22:54:22 <mizmo> (skvidal) the seven people who run linux on the desktop out there... the reality is that, fedora is running 6th place
22:54:34 <mizmo> (skvidal) we've got a lot of market share in the cloud, we might as well expand it, and expand it in the server realms
22:54:37 <nb> #endmeeting