12:00:13 <stickster> #startmeeting Magazine editorial board
12:00:14 <zodbot> Meeting started Wed Apr 18 12:00:13 2018 UTC.  The chair is stickster. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:00:14 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
12:00:14 <zodbot> The meeting name has been set to 'magazine_editorial_board'
12:00:18 <stickster> #meetingname magazine
12:00:18 <zodbot> The meeting name has been set to 'magazine'
12:00:23 <stickster> #topic Roll call
12:00:26 <stickster> .hello pfrields
12:00:27 <zodbot> stickster: pfrields 'Paul W. Frields' <stickster@gmail.com>
12:00:29 <ryanlerch> .hello ryanlerch
12:00:30 <zodbot> ryanlerch: ryanlerch 'Ryan Lerch' <rlerch@redhat.com>
12:02:34 * stickster waits to see who else shows
12:02:44 <rahulsundaram> .hello rahulsundaram
12:02:45 <zodbot> rahulsundaram: Sorry, but you don't exist
12:03:07 <stickster> that's darn rude, zodbot
12:03:16 <rahulsundaram> I totally do!
12:03:28 <ryanlerch> :/
12:03:44 <stickster> .fas sundaram
12:03:44 <zodbot> stickster: sundaram 'Rahul Sundaram' <metherid@gmail.com> - ruk 'Sundaramurthy' <rukmas@yahoo.com> - karthic 'Sundaram' <karthi131@gmail.com> - iamsiva11 'Siva Sundaramooorthy' <am11.4siv@gmail.com> - vms20591 'Meenakshi Sundaram' <ronaldoraine@hotmail.com> - venkatps 'Venkat Sundaram' <vnkt.ea@gmail.com> - mselvakumars 'Selvakumar Meenakshisundaram' <mselvakumarsundaram@gmail.com> - mohan1007 'mohana sundaram' (1 more message)
12:03:57 <stickster> rahulsundaram: it's ".hello <fasid>"
12:04:14 <rahulsundaram> fair enough
12:05:30 <stickster> OK, let's get rolling
12:06:37 <stickster> #topic Last week's stats
12:07:20 <stickster> #info Week of April 9: 46.2K views, a little down from the previous week and not super impressive :-(
12:07:43 <ryanlerch> :9
12:07:45 <stickster> Standout post was the GNOME extensions for developers article!
12:07:55 <ryanlerch> that was a solid post!
12:08:36 <stickster> I noticed March was about 255K page views, that's not bad, up from ~236K YoY
12:09:01 <stickster> Let's plunge into our coming week, we're behind a bit, no article went out yet today
12:09:47 <ryanlerch> sounds good!
12:10:05 <stickster> rahulsundaram: FYI, not sure if you read the wiki page on meetings... typically we look at stats, then look at pending articles starting with closest-to-publication status and moving backward. We sometimes will clean up the queue as well. We settle on a publishing schedule for the next 1.5-2.0 weeks
12:10:23 <stickster> #topic Pending review posts
12:10:33 <stickster> #link https://fedoramagazine.org/wp-admin/edit.php?post_status=pending&post_type=post
12:10:53 <stickster> #info --- getting started in Java ---
12:10:55 <stickster> #link https://fedoramagazine.org/?p=15129&preview=1&_ppp=aa14a3b1dc
12:10:56 <rahulsundaram> I am still catching up
12:11:42 <stickster> I haven't run through the steps in this Java article but the text looks pretty good, just minor tweaks needed
12:11:53 <x3mboy> .hello2
12:11:54 <ryanlerch> this one looks pretty solid. just a light edit and proof needed IMHO
12:11:54 <zodbot> x3mboy: x3mboy 'Eduard Lucena' <eduardlucena@gmail.com>
12:12:11 <stickster> o/ x3mboy
12:12:17 <x3mboy> stickster, o/
12:13:00 * cverna was waiting for the meeting in #fedora-magazine :D
12:13:11 <stickster> -ENOCAFFEINE?
12:13:35 <stickster> ryanlerch: Do you want to do a graphic for this? I can probably edit it for publishing tomorrow since we're behind
12:13:42 <stickster> but I won't get a chance until this afternoon
12:14:08 <ryanlerch> stickster: for sure! i can do the image first thing in the morning my time, and then post
12:14:18 <stickster> Cool
12:14:45 <stickster> #action ryanlerch do image for Java article; stickster to edit this afternoon; ryanlerch to publish Thu 2018-04-19
12:15:31 <stickster> #topic Draft posts to review
12:15:33 <stickster> #link https://fedoramagazine.org/wp-admin/edit.php?post_status=draft&post_type=post
12:16:30 <stickster> #info --- Buildah ---
12:16:44 <stickster> #link https://fedoramagazine.org/?p=20945&preview=1&_ppp=ad359acf09
12:16:58 <stickster> This was proposed on list and I thought it was an insta-+1
12:17:48 <cverna> yes it is a nice article +1
12:17:58 <stickster> The article needs some work though -- it's more of a list of commands, and it doesn't provide as much context as I'd like
12:18:08 <stickster> The second half is better
12:18:18 <stickster> since it gives a use case and walks through a specific process
12:20:15 <ryanlerch> stickster: yeah agree -- a good start -- does need some more context at the beginning for sure
12:20:44 <stickster> #action stickster email Ashutosh and ask him to work with the container folks for a little more info in the beginning
12:20:58 <stickster> but otherwise I think it's on its way and we definitely could publish it down the road
12:21:42 <stickster> #info --- GNOME 3.28 new features ---
12:21:49 <stickster> #link https://fedoramagazine.org/?p=20949&preview=1&_ppp=efb6d4663b
12:22:08 <stickster> This actually looks like a pitch to me, I don't recall seeing it earlier -- it's from sub_pop[m] and it's a solid idea, though
12:22:25 * stickster is +1
12:22:44 <ryanlerch> +1 from me too
12:22:51 <x3mboy> +1
12:23:36 <cverna> +1
12:24:38 <stickster> #agreed GNOME 3.28 feature article approved
12:24:48 <stickster> #action stickster email list/author with approval and ask for ETA
12:25:10 <stickster> #info --- reset lost password ---
12:25:19 <stickster> #link https://fedoramagazine.org/?p=20867&preview=1&_ppp=738c1ee6f8
12:25:57 <stickster> This is a great idea, and I think we already approved it -- just need the finishing touches I think?
12:27:04 <stickster> Needs a bit of markup polish, and I also see some screenshots are somewhat hard to read (blown up from very small size, not sure why)
12:27:28 <ryanlerch> yeah, +1 from me
12:27:37 <cverna> nice, +1 too
12:27:55 <stickster> I'm not sure about the SELinux "avoid relabeling" thing -- I think a full relabel is generally the right thing to do after any disabled session boot
12:27:57 <ryanlerch> might need to make it clear at the top that you need physical access to the machine to do this right?
12:28:02 <stickster> ryanlerch: for sure
12:28:21 <ryanlerch> that and it wont work with an encrypted system, right?
12:29:14 <stickster> ryanlerch: Hm, not sure. I think the mount would detect LUKS and ask for a password
12:29:20 <stickster> but that would need to be tested
12:30:07 * stickster leaves a note in the article
12:30:29 <ryanlerch> i can edit this one
12:30:32 <stickster> How do we want to handle this one then? It seems like a brilliant idea, just need to have the details checked
12:30:50 <rahulsundaram> I can validate details if I can get access to the draft
12:30:51 <stickster> I *think* it can be checked via a VM, though
12:31:03 <stickster> rahulsundaram: Are you logged into the magazine?
12:31:14 <ryanlerch> stickster: i also have a soare laptop here i can check it out on it
12:31:15 <stickster> The link above should work either way, fwiw
12:31:21 <rahulsundaram> I need to reset my password first :-)
12:31:31 <rahulsundaram> but I will take a look
12:31:33 <stickster> "thaw"
12:32:03 <stickster> #action ryanlerch and rahulsundaram to collaborate on checking technical details
12:32:32 <stickster> #action ryanlerch final edit on password reset article and image/publish
12:32:58 <stickster> #info --- Python development made easy ---
12:33:10 <stickster> #link https://fedoramagazine.org/?p=20594&preview=1&_ppp=08820e102c
12:33:20 <stickster> cverna: ^ I think this was your pitch, care to update?
12:33:45 <cverna> yes, I did not have much time to start on it
12:34:05 <cverna> but I will focus on it this week
12:34:36 <cverna> and get something for review for beginning of next week if that's ok
12:35:20 <stickster> cverna: Sure, that would be great
12:35:35 <x3mboy> !
12:35:40 <stickster> ryanlerch: I see a draft placeholder here for package security, but that was done already, right?
12:35:48 <stickster> Looks like we published that on April 4
12:36:16 <ryanlerch> stickster: yeah, that one is done!
12:36:23 <stickster> OK, I'll trash this extra placeholder then
12:37:22 <stickster> ryanlerch: there's also something on peek, you're still working on that one? (I know there was a Flathub question here.)
12:37:36 <stickster> x3mboy: haven't forgotten you, getting there shortly
12:37:49 <x3mboy> ;)
12:37:59 <ryanlerch> stickster: yeah, i can get that one together for when we need it
12:38:01 <stickster> x3mboy: if this is about podcast articles, I want to discuss that specifically in a moment
12:38:08 <x3mboy> Nope
12:38:15 <x3mboy> But ok
12:38:18 <ryanlerch> planning on getting it done sometime this week though
12:38:34 <stickster> ryanlerch: I feel like you inherited a lot today :-)
12:39:22 <stickster> ryanlerch: You also have the audacity noise removal article idea waiting for any time... no rush/pressur
12:39:25 <stickster> *pressure
12:39:42 <ryanlerch> stickster: all dependswhenwe schedule :)
12:39:49 <stickster> Yeah
12:40:01 <stickster> x3mboy: What's your topic, so I know what we should do next?
12:40:14 <x3mboy> There is a pitch about zsh that I want to tale
12:40:20 <x3mboy> s/tale/take
12:40:33 <stickster> x3mboy: Go for it! It's assigned to "nobody" so you can do just that
12:40:36 <x3mboy> My question is how deep this should be?
12:41:04 <x3mboy> Should I include how to make it the default shell?
12:41:33 <stickster> x3mboy: based on the original pitch it should cover installing zsh, switching your default to use it, setting up completion, and something about a "choice menu" (no idea what that means)
12:41:56 <stickster> I would say you should at least cover major differences that someone might encounter vs. the default bash shell
12:42:10 <x3mboy> That means that by "tabbing" (using the tab key) you can move in a menu
12:42:25 <x3mboy> I know exactly what all the topics means, so I will go for it
12:42:27 <stickster> you don't need to cover every single feature, nor configuring every option -- a couple noticeable ones, and include references to a couple good docs like a user guide
12:42:36 <stickster> x3mboy++
12:42:43 <x3mboy> And now I'm corious about what do you want to talk about the podcast
12:42:48 <x3mboy> ?
12:43:34 <stickster> x3mboy: awesome! I've assigned it to you as author and moved to "Drafts" folder
12:43:42 <x3mboy> Cool!
12:43:51 <stickster> #action x3mboy write draft on zsh and notify list when ready to review
12:44:00 <stickster> #topic Podcast articles
12:44:09 <cverna> x3mboy++
12:44:55 <stickster> So it looks to me like our podcast articles are not very high traffic. We should reconsider how we drive traffic to the podcast, vs. dedicating an article space to it
12:45:40 <stickster> For example, the latest episode #005 had only 901 page views *total* since publication. Usually our articles have 5,000-10,000 page views within a week, depending on topic area
12:46:58 <stickster> #idea What about a sidebar widget that links to the Podcast's various feed sites?
12:47:38 <ryanlerch> yeah, i think i am a +1 on this -- now the podcast is established, most people that are subscribed elsewhere are probably just ignoreing the magazine articles
12:48:43 <stickster> I'm not saying we shouldn't publish an article at all, but if we do, it shouldn't take up a M/W/F slot, but rather it would be an added article drop
12:48:43 <cverna> do we have the statistics about the subscriptions ?
12:48:55 <stickster> cverna: I don't but x3mboy should be able to provide those
12:49:13 <stickster> I can only tell how many people are viewing the magazine article
12:49:37 <ryanlerch> stickster: yeah a +1 for not taking up a MWF slot
12:49:38 <x3mboy> +1
12:50:01 <ryanlerch> 4 artmciles every second week cant hurt :)
12:50:10 <stickster> yup
12:50:21 <x3mboy> I have no problem, also, the most traffic that waqs driven by the Magazine was to SoundCloud, that is just going down little by little, but subscription based platforms are going up day by day
12:50:34 <x3mboy> So, I'm really ok to not take a complete slot for the magazine
12:50:40 <stickster> #agreed podcast articles should be "extra" published slots
12:51:13 <x3mboy> cverna, stickster I will publish the stats for the podcast on the commblog
12:51:19 <x3mboy> Probably this afternoon
12:51:21 <stickster> Any thoughts on the sidebar widget? I think it would be easy to have something that says "Check out the Fedora Podcast [iTunes / Google Play / Soundcloud / etc.]"
12:51:26 <cverna> x3mboy: nice :)
12:51:54 <stickster> ryanlerch: ^ would that be overloading the sidebar if we put it either above or below the Magazine email subscription widget?
12:52:12 <ryanlerch> stickster: maybe :)
12:52:52 <ryanlerch> was thinking might have an "ad" slot that randomly shows one of a few "ads"
12:53:00 <stickster> ryanlerch: oh, that's a neat idea
12:53:05 <ryanlerch> i.e. podcast, commblog
12:53:08 <ryanlerch> etc
12:53:26 <stickster> yeah, even getfedora could be on there
12:53:49 <ryanlerch> just have to figure out how to make it changeable in the UI
12:53:58 <ryanlerch> i could hardcode this in the theme
12:54:15 <ryanlerch> but it would be nice to be able to change it without updating the theme
12:54:20 <ryanlerch> leave it with me!
12:54:34 <stickster> ryanlerch: https://wordpress.org/plugins/randomtext/
12:55:05 <stickster> that extension hasn't been touched in a while but my bet is, it's so simple it just keeps working
12:55:25 * stickster has a rotating tagline extension on his blog whose code hasn't changed in years
12:55:38 <ryanlerch> stickster: sold!
12:56:05 <x3mboy> Thanks for bringing this up
12:56:06 <x3mboy> :D
12:56:09 <stickster> #agreed Look at randomtext plugin or other way to rotate ads in a sidebar widget
12:56:13 <x3mboy> I need to run now
12:56:16 <stickster> #topic Publishing schedule for next week
12:56:19 <x3mboy> But I will keep online
12:56:19 <stickster> thanks x3mboy  o/
12:59:56 <ryanlerch> thanks x3mboy!
13:00:04 <stickster> Will this schedule work? ----- Thu Apr 19: Java (stickster) -- Fri Apr 20: reset password (ryanlerch) -- Mon Apr 23: CD tagging #2 (stickster) -- Wed Apr 25: Python devel?? -- Fri Apr 27: peek??
13:00:33 <stickster> oof, magazine is being slow on me
13:00:57 <ryanlerch> stickster: LGTM
13:00:59 <ryanlerch> +!
13:01:40 <cverna> works for me
13:01:50 <stickster> #agreed PUBLISHING: Thu Apr 19: Java (stickster) -- Fri Apr 20: reset password (ryanlerch) -- Mon Apr 23: CD tagging #2 (stickster) -- Wed Apr 25: Python devel (cverna/stickster) -- Fri Apr 27: peek (ryanlerch)
13:02:09 <stickster> OK, that does it! Sorry for running over, and thanks for coming everyone
13:02:18 <stickster> #endmeeting