21:00:50 <stickster> #startmeeting Magazine editorial board
21:00:50 <zodbot> Meeting started Wed Jan 16 21:00:50 2019 UTC.
21:00:50 <zodbot> This meeting is logged and archived in a public location.
21:00:50 <zodbot> The chair is stickster. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:50 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
21:00:50 <zodbot> The meeting name has been set to 'magazine_editorial_board'
21:00:52 <stickster> #meetingname magazine
21:00:52 <zodbot> The meeting name has been set to 'magazine'
21:00:53 <stickster> #topic Roll call
21:00:56 <stickster> .hello pfrields
21:01:01 <cverna> hello o/
21:01:01 <zodbot> stickster: pfrields 'Paul W. Frields' <stickster@gmail.com>
21:01:02 <stickster> #chair asamalik cverna ryanlerch sub_pop[m]
21:01:02 <zodbot> Current chairs: asamalik cverna ryanlerch stickster sub_pop[m]
21:01:07 <asamalik> .hello2
21:01:08 <zodbot> asamalik: asamalik 'Adam Samalik' <asamalik@redhat.com>
21:01:10 * stickster hands gavel to asamalik :-D
21:01:35 <asamalik> stickster: thanks for starting the meeting :D
21:02:17 <asamalik> #topic Last week's stats
21:02:42 <asamalik> #info Week of Jan 7: 63.5K pageviews -- the second highest week this year! :-)
21:03:05 <cverna> :)
21:04:47 <asamalik> https://www.irccloud.com/pastebin/MTa5M3A8/
21:04:52 <stickster> ha, nice Adam
21:04:58 <asamalik> eh...
21:05:01 <asamalik> let me try again!
21:05:11 <stickster> oh, I wasn't talking about your error, that would be mean
21:05:16 <asamalik> #topic Pending review posts
21:05:16 <asamalik> #link https://fedoramagazine.org/wp-admin/edit.php?post_status=pending&post_type=post
21:05:18 <stickster> "second highest this year"
21:05:29 <asamalik> stickster: ah I wasn't thinking that! :-)
21:05:35 <asamalik> but good timing!
21:05:47 <stickster> yeah, looks like nothing in Pending Review
21:05:48 <asamalik> #info no pending review
21:06:03 <asamalik> #topic Drafts to review
21:06:03 <asamalik> #link https://fedoramagazine.org/wp-admin/edit.php?post_status=draft&post_type=post
21:06:27 <asamalik> #info --- Build a Django RESTful API on Fedora ---
21:06:38 <asamalik> #link https://fedoramagazine.org/?p=23093&preview=true
21:07:01 <cverna> I would say that I have 80% done, I ll finish it tomorrow
21:07:26 <cverna> so I can start working on part 2
21:07:28 <stickster> nice, cverna!
21:07:34 <stickster> cverna++
21:07:35 <asamalik> that looks really nice!
21:07:42 <asamalik> cverna++
21:07:55 <asamalik> so do we wanna publish that on Friday?
21:08:04 <stickster> asamalik: we're set for this Friday already
21:08:19 <cverna> part 2 will be deploy the application on openshift
21:08:29 <asamalik> stickster: ah cool
21:08:43 <stickster> We have the HDYF: 2019 scheduled then, so this could go Monday if someone edits, etc.
21:08:58 <cverna> then I think I will have a Part 3 and Part 4 build a REACT JS app on Fedora + deploy it on Openshift
21:09:43 <cverna> so at the end of the 4 parts reader will be able to build a python API backend and a JS front end and deploy everything on Openshift
21:09:47 <stickster> 😯
21:09:51 <asamalik> stickster: you're right
21:09:54 * asamalik got a bit confused
21:10:18 <asamalik> cverna: woot!
21:10:41 <cverna> that's what you call a full stack series :P
21:10:50 <asamalik> nice
21:10:50 <stickster> for sure
21:10:58 <asamalik> cverna: so this one Monday?
21:11:08 * asamalik can do the editing
21:11:09 <cverna> asamalik: works for me :)
21:11:12 <asamalik> cool!
21:11:29 <cverna> I ll ping you once it is ready for review
21:11:53 <asamalik> ryanlerch: do you wanna do a picture? silence means yes!
21:12:07 <asamalik> :D
21:12:09 <asamalik> #agreed publish 'Build a Django RESTful API on Fedora' on Monday
21:12:46 <asamalik> #info --- Open Power Summit 2018 ---
21:12:51 <asamalik> #link https://fedoramagazine.org/?p=24514&preview=true
21:13:21 <stickster> This looks like a trip report, was there a pitch on the list for it earlier?
21:13:46 <asamalik> I can't recall one, might be wrong
21:14:06 <asamalik> probably not
21:14:16 <cverna> no I don't think there was
21:14:31 <asamalik> it's for an event from October last year....
21:14:32 <cverna> that might be cool for the community blog
21:15:28 <stickster> cverna: agree
21:15:37 <asamalik> doesn't talk about Fedora much, either
21:15:44 <asamalik> yeah I'm -1 here
21:15:54 <stickster> I'll take the action of emailing the contributor to have them check in with communityblog folks about it on marketing list
21:16:02 <asamalik> stickster: thanks!
21:16:21 <stickster> #action stickster email OpenPowerSummit article author about moving content to communityblog
21:16:40 <stickster> That leaves us a little low on content but I don't think that's a good reason to start lowering the bar :-)
21:16:53 <asamalik> agree
21:16:56 <asamalik> #info --- Jam – Fedora Labs  ---
21:17:00 <asamalik> https://fedoramagazine.org/?p=23675&preview=true
21:17:24 <asamalik> is this supposed to be a pitch?
21:17:44 <asamalik> nope, we've approved it
21:18:14 <cverna> yes that sounds cool
21:19:11 <asamalik> do we want to email the author about the status? or just give them a bit more time?
21:19:18 <stickster> I think I did email the author about finishing it and don't recall a response -- let me double check
21:19:28 <asamalik> stickster: that's right, Dec 5
21:20:46 <ryanlerch> .hello ryanlerch
21:20:47 <zodbot> ryanlerch: ryanlerch 'Ryan Lerch' <rlerch@redhat.com>
21:20:55 <ryanlerch> sorry for beinglate!
21:21:42 <cverna> ryanlerch: o/
21:21:57 * asamalik waves at ryanlerch
21:22:03 <stickster> no worries, we're churning through drafts... howdy ryanlerch
21:22:17 <stickster> #info stickster emailed Jam Lab article author + list again
21:22:30 <ryanlerch> yes, can do the django rest api image for monday
21:22:37 <asamalik> ryanlerch++
21:22:54 <asamalik> stickster: thanks!
21:23:01 <asamalik> so that's been all drafts
21:23:26 <asamalik> #topic Pitches to approve
21:23:26 <asamalik> #link https://fedoramagazine.org/wp-admin/edit.php?post_status=pitch&post_type=post
21:24:20 <asamalik> #info --- How to Build a Netboot Server, Part 5 ---
21:24:26 <asamalik> have we talked about this one last time?
21:24:39 <asamalik> #link https://fedoramagazine.org/?p=24286&preview=true
21:25:32 <cverna> I can't remember but we might have
21:25:33 <stickster> Yeah, I'm not sure gregbartholomew had time to look at updating it for non-ZFS
21:25:39 <stickster> that was the sticking point
21:25:51 <ryanlerch> ah, yeah that was it
21:25:59 <asamalik> ah right!
21:26:14 <asamalik> still ZFS
21:27:49 * stickster puts an "editorial comment" in the post
21:28:54 <ryanlerch> stickster++
21:28:54 <zodbot> ryanlerch: Karma for pfrields changed to 7 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
21:29:11 <stickster> that way we don't have to dig up notes or memories :-D
21:29:18 <stickster> ^ mine is THE WORST these days
21:30:00 * asamalik also wants to have some memory!
21:30:14 <stickster> asamalik: is that all the "new" content?
21:30:43 <asamalik> stickster: yeah...
21:31:14 <asamalik> nothing on the list, either
21:31:34 <stickster> #idea figure out publishing in a new topic that includes thinking about Brno/DevConf.cz stuff next week
21:32:19 <asamalik> sounds good!
21:32:33 <asamalik> #topic Publishing schedule
21:32:55 <asamalik> so we have Friday and Monday covered
21:33:22 <ryanlerch> i could come up with something for wednesday
21:33:25 <ryanlerch> maybe
21:33:27 <ryanlerch> :D
21:33:40 <stickster> Since there are a bunch of people tied up in Brno next week, it will be tough to "whip up" content on the fly there... so we might want to try and fill the next four spots 2019-01-23 through 2019-01-30 with stuff
21:34:08 <stickster> like, have a lot of little articles ready as opposed to grand ideas (which are AWESOME but often take longer)
21:34:12 <asamalik> that would be ideal
21:34:52 <ryanlerch> yeah, some quicx app reviews etc
21:36:24 <cverna> I saw a nice article on podman ability to create pods (like in kubernetes) I was thinking that we could have an article on how to use podman pods to replace docker-compose
21:36:40 <cverna> I can put a pitch in
21:36:48 <asamalik> would it be worth to post one about DevConf promoting the live streaming?
21:36:53 <asamalik> well, if there is one
21:36:58 <asamalik> there was last year
21:37:06 <stickster> cverna: Oh, that's a cool one
21:37:12 <stickster> Anything that puts the OCI stuff out there is awesome
21:37:37 <asamalik> cverna: that would be great!
21:37:54 <cverna> yes it likely needs a bit of playing around before writing tho , that's takes usually sometime
21:38:00 <cverna> some time*
21:39:45 <stickster> I think an article or two about small apps or extensions would fit the bill
21:40:53 <stickster> we have some starter pitches in the Magazine as well. Is everyone currently wracking their brain for ideas, or just distracted? :-)
21:41:03 * asamalik is really trying to have ideas!
21:41:30 * cverna just added the podman pitch
21:41:49 <cverna> in the draft :s
21:41:57 <stickster> cverna: Hey, you were just talking about mindmapping the other day. I installed XMind and have been trying it out
21:42:14 <asamalik> ah I really like XMind!
21:42:20 <cverna> ha that could be a nice article
21:42:22 <cverna> :)
21:42:22 <asamalik> was also using FreeMind which was good
21:43:31 * cverna is thinking about using a MindMap instead of slide for his DevConf talk
21:44:06 <stickster> Maybe an article about a mindmap app would be cool... I'm doing a mindmap and could do that
21:44:38 <cverna> +1
21:45:03 <ryanlerch> i could do one on a few small utility GNOME shell extenstions
21:45:10 <ryanlerch> like this one https://extensions.gnome.org/extension/818/battery-percentage/
21:46:43 <cverna> yes +1 too
21:46:56 <stickster> ooh neat
21:47:16 <stickster> #action stickster do article on a mindmap app, either freemind or xmind
21:47:45 <ryanlerch> +1 on mindamap
21:48:19 <asamalik> +1 on both
21:50:11 <stickster> We mentioned freemind in a Feb 2017 article "3 mind mapping tools in Fedora"
21:50:18 <stickster> So that seems old enough this is fair game ;-
21:50:29 <stickster> freemind is dnf installable so I'm going to prefer that one for the moment
21:50:35 <asamalik> I'm a bit short on ideas right now, sorry :(
21:51:11 <stickster> asamalik: You know, you've done a lot of stuff on docs... is there something you could pull out of that experience? Like Antora or something else?
21:51:30 <stickster> ugh, freemind UI is so 2005
21:52:00 <asamalik> stickster: maybe I could just introduce Antora and say we use it for the docs?
21:52:14 <asamalik> they did a lot of great work and deserve some publicity
21:52:35 <stickster> asamalik: how complex is it to show a simple two or three page doc build?
21:52:48 <stickster> I really like the idea of giving them kudos and publicity
21:52:50 <ryanlerch> all the buttons all the time in freemind
21:52:50 <asamalik> stickster: very simple
21:52:57 <stickster> asamalik: I'm +1 on it for sure
21:53:01 <stickster> ryanlerch: yeah!
21:53:02 <asamalik> cool!
21:53:25 <cverna> do we have the CI/CD working on docs ? would be nice way to show people how to setup something similar
21:53:42 <stickster> xmind feels more modern. at the same time, it's "freeware" in that you can run it for free, but they provide a pay service
21:53:43 <asamalik> #action asamalik will write an Antora article, showing how to use it, and to give those amazing people a bit of publicity
21:54:40 <cverna> How do we save an article as pitch with the new wordpress ?
21:54:41 <asamalik> stickster: that's why I was using freemind... the way it looks brings memories, yeah, but it has nice keyboard shortcuts for manipulating the map!
21:54:45 * cverna is clueless
21:56:17 <stickster> cverna: whoa, good point... with the new editor I can't find that either!
21:57:47 <asamalik> yeah.. no idea how to do tha
21:58:08 <stickster> argh, this is not helpful since it means people can't put in pitches currently
21:58:25 <cverna> yes that's kind of breaking the workflow
21:58:31 <stickster> ryanlerch: are our custom statuses coming from the Editorial Workflow plugin, or something else?
21:58:49 <asamalik> it looks like you can save it as a draft, and then in the list find it again, click "quick edit" and set "state" to "pitch"
21:59:06 <asamalik> but...
21:59:07 <asamalik> :)
21:59:14 <ryanlerch> looking
21:59:36 <stickster> asamalik: but you're an editor I think... if I was just signing on as a contributor, I think the permissions don't allow me to do it
21:59:46 <asamalik> stickster: ah wow
21:59:51 <stickster> we could change that of course
22:00:26 <ryanlerch> stickster: i think they are...
22:00:32 <ryanlerch> cant 100% remmeber
22:00:49 <stickster> ryanlerch: looks like editflow has got a bunch of changes recently on GitHub
22:01:46 <asamalik> oops, running out of time
22:01:52 * stickster realizes we're over time... I'm not pressed today, but do we have a plan for the week?
22:01:57 <stickster> s/week/week(s)/
22:02:20 <ryanlerch> yeah, edit flow is how we got the custom statuses
22:02:22 * stickster can have his article ready in advance to go out next Wednesday or Friday if needed
22:02:28 <asamalik> we have Fri and Mon + 2 more articles
22:02:31 <stickster> I'll do it by this weekend
22:02:48 <asamalik> stickster: cool! so I could put yours on wednesday
22:02:50 <stickster> If you and Ryan come up with a couple, we'll be covered through after DevConf
22:02:54 <ryanlerch> i'll try to get a few in the bank today and tomorrow
22:02:56 <asamalik> mine on Friday
22:03:07 <stickster> you guys are good eggs :-)
22:03:12 <stickster> asamalik++ ryanlerch++
22:03:22 <ryanlerch> cookie party
22:03:24 <stickster> awwwwww! out of cookies? come on zodbot
22:03:30 <ryanlerch> oh, stickster is out of cookies
22:03:35 <stickster> I'm a nobody now
22:03:56 * stickster gives asamalik some time to type in schedule, it's a pain :-D
22:04:24 <stickster> ryanlerch: haha! editflow 0.9 needed for Block Editor compatibility
22:04:41 <asamalik> #proposed #agreed PUBLISHING SCHEDULE: Fri Jan 18, HDYF 2018 -- Mon Jan 21, Build a Django RESTful API on Fedora (asamalik:edit/ryanlerch:image) --  Wednesday Jan 23, mind maps (stickster) -- Friday Jan 25, Antora (asamalik) -- Monday Jan 28, gnome plugins (ryanlerch) -- Wednesday Jan 30, ?! (?!)
22:05:10 <asamalik> stickster: I remembered that pain so I was prepping the whole time!
22:05:26 <stickster> nice Adam :-)
22:05:39 <stickster> +1 on schedule
22:05:44 <cverna> +1
22:05:54 <asamalik> can we teach zodbot some AI stuff so he/she/it does that automatically?
22:05:56 <stickster> ryanlerch: did you see my cool image for Friday's article?
22:06:13 <stickster> asamalik: ha, hackfest
22:06:17 <asamalik> we could also write an article about that
22:06:19 <asamalik> or two
22:06:36 <asamalik> what about that Wednesday Jan 30?
22:07:28 <asamalik> should we just leave it now and decide on the go? it's in two weeks
22:09:05 <stickster> asamalik: I guess we could decide on the go -- we sometimes get new content along the way
22:09:20 <asamalik> stickster: all right!
22:09:22 <asamalik> #agreed PUBLISHING SCHEDULE: Fri Jan 18, HDYF 2018 -- Mon Jan 21, Build a Django RESTful API on Fedora (asamalik:edit/ryanlerch:image) --  Wednesday Jan 23, mind maps (stickster) -- Friday Jan 25, Antora (asamalik) -- Monday Jan 28, gnome plugins (ryanlerch) -- Wednesday Jan 30, ?! (?!)
22:09:24 <asamalik> there we go!
22:09:34 <asamalik> #topic All other business (open floor)
22:10:45 <cverna> nothing on my side :)
22:10:59 * stickster needs to combine the two pending classroom posts
22:11:09 <stickster> so it doesn't look like we're a Classroom-specific blog
22:11:25 <stickster> #action stickster combine pending Classroom posts for Feb 1 + 4 into one article
22:11:40 <asamalik> stickster++
22:11:42 <stickster> That takes care of the Friday after the Wednesday we're worried about :-)
22:11:55 <stickster> We could push it earlier buuuuuuuuut......
22:12:02 * asamalik sent stickster a picture of a cookie
22:12:09 <stickster> <eof/>
22:12:31 <asamalik> thinks "how sad and unfortunate"
22:12:42 <asamalik> anyway
22:13:06 <asamalik> stickster: ha!
22:13:13 <asamalik> we can use that as a backup I guess!
22:13:25 <asamalik> OK, I think we're ready to close this?
22:13:44 * cverna is ready to go to bed :P
22:13:55 * asamalik is also ready to go to bed :P
22:14:01 <asamalik> #endmeeting