12:00:13 <stickster> #startmeeting Magazine editorial board
12:00:13 <zodbot> Meeting started Wed May 22 12:00:13 2019 UTC.
12:00:13 <zodbot> This meeting is logged and archived in a public location.
12:00:13 <zodbot> The chair is stickster. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:00:13 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
12:00:13 <zodbot> The meeting name has been set to 'magazine_editorial_board'
12:00:18 <stickster> #meetingname magazine
12:00:18 <zodbot> The meeting name has been set to 'magazine'
12:00:23 <stickster> #topic Roll call
12:00:27 <cverna> hello
12:00:28 <stickster> .hello pfrields
12:00:29 <zodbot> stickster: pfrields 'Paul W. Frields' <stickster@gmail.com>
12:01:43 <asamalik> .hello2
12:01:46 <zodbot> asamalik: asamalik 'Adam Samalik' <asamalik@redhat.com>
12:01:51 <asamalik> happy Wednesday!
12:02:00 <stickster> #chair cverna asamalik
12:02:00 <zodbot> Current chairs: asamalik cverna stickster
12:02:46 <cverna> :)
12:03:00 <stickster> Happy Wednesday all... asamalik, let me know if you want to chair these going forward now that we switched time. I have no problem doing it today, I know you got
12:03:10 <bcotton> .hello2
12:03:12 <zodbot> bcotton: bcotton 'Ben Cotton' <bcotton@redhat.com>
12:03:12 <stickster> back from OSCAL just recently
12:03:52 <stickster> Neat Ben is here! 💯
12:03:59 <stickster> #chair bcotton
12:03:59 <zodbot> Current chairs: asamalik bcotton cverna stickster
12:04:34 <asamalik> stickster: I can definitely chair starting next week yes!
12:05:21 <asamalik> stickster: thanks for doing it today
12:05:25 <stickster> no worries!
12:06:12 <stickster> Sorry, took a few minutes to get set up here
12:06:12 * asamalik has overcommitted a bit for today *sips coffee*
12:06:23 * bcotton also sips coffee
12:06:25 <stickster> #topic Last week's stats
12:07:03 <stickster> #info Week of May 13: 68.2K pageviews, back down in the usual range after the release. I believe we had a weird publishing week as well
12:07:39 <stickster> However, we have a shot at May being our best month ever if we can get some mass-appeal articles out over the next week
12:08:34 <stickster> #topic Special Topic: Magazine infrastructure
12:08:44 <asamalik> \o/
12:08:58 <cverna> oh man that topic sounds serious :)
12:10:15 <stickster> Before we review articles... a topic came up about infrastructure on the list, which I presume is why Ben is here... bcotton, do you want to take the mic?
12:10:20 <bcotton> sure
12:12:08 <bcotton> So on CommBlog, the WordPress dashboard says "hey, you need to upgrade your PHP". I opened a ticket with infra and they said it's on CentOS 7 which doesn't have a newer PHP available. our options are 1. move to a hosted WordPress (i.e. wordpress.com) or 2. move to an F30 container in the community openshift cloud
12:12:10 <bcotton> #link https://pagure.io/fedora-infrastructure/issue/7806
12:12:55 <bcotton> the CommBlog team is still discussing it, but we figure Magazine may have the same issue and since we're such BFFs, it would be good to have us all in the conversation
12:12:57 <bcotton> EOF
12:13:18 <stickster> bcotton: Good summary, thanks
12:13:31 * cverna would prefer option 1
12:13:55 <cverna> but I guess that involves having a way to authenticate there
12:13:59 <stickster> Before we do any deciding... are people aware of the Remi repo that offers PHP 7.3 for EL7?
12:14:03 <asamalik> I would probably prefer the hosted option so the infra team can focus on our strategic stuff
12:14:24 <stickster> Oh look at that, 7.4 as of this morning
12:14:35 <asamalik> ha
12:15:00 <bcotton> cverna: i agree for the reason asamalik said
12:15:04 * stickster configured his own CentOS 7 Linode to use that so he could get the 7.3 boost for Wordpress sites he runs
12:15:14 <cyberpear> also software collections
12:15:31 <cverna> yes but If I understand it correctly the VMs that are currently running in the infracloud will disappear at one point
12:15:49 <cverna> to be moved to community OpenShift
12:15:50 <bcotton> stickster: i'd be okay with that as a short-term option. i think moving to WP.com is a better choice long term anyway. we can go ask your team or council for the money
12:16:05 <stickster> That being said... I personally think "running WordPress" isn't a core competency for the infra team and we are better off on a hosted platform. We'd need to use the *business* plan for $$ so we can run our own plugins and theme.
12:16:16 <stickster> Just making sure the record reflects all the facts :-)
12:17:23 <cverna> do we have a way to authenticate with FAS in WP.com ?
12:17:35 <cverna> I guess that is the main blocker
12:17:53 <stickster> cverna: with the business plan, we should be able to do that, since we get to customize our plugins/themes
12:18:09 <stickster> but someone would need to test it first
12:18:28 <bcotton> yeah, FAS and fedmsg/fedora-messaging
12:18:49 <cverna> stickster: ok afer a quick look there are few plugins that seems to be available (https://wordpress.org/plugins/miniorange-openid-connect-client/)
12:20:16 <bcotton> should we maybe plan to have a few hours at Flock for testing? we'll hopefully have a lot of people in teh room and easy access to folks who can help with openid setup if needed
12:20:31 <bcotton> obviously we'll need to do some prep work between now and then
12:20:41 <stickster> bcotton: That sounds wise.
12:20:57 <bcotton> that's the second time i've been called wise in the last 5 minutes. i'm worried
12:21:00 * stickster is in for that, esp. since he has plenty of access to the current box
12:21:11 <stickster> "He don't look wise" -- The Hudsucker Proxy
12:21:27 <cverna> ha how about transferring the current content ? Is that easy ?
12:21:36 * cverna does not know much about wordpress
12:21:40 <asamalik> bcotton: stickster said the *idea* *sounds* wise :P
12:21:41 * asamalik hides
12:21:46 <asamalik> but I'm +1
12:21:55 <stickster> cverna: I don't think we know how it works yet, but I would be surprised if it was difficult. Also, there are backup/restore plugins that make it easier.
12:21:58 <bcotton> cverna: it's all mysql tables, so it should be easy to dump and reimport
12:22:23 <bcotton> and if we're paying wp.com, they'll probably help us. heck, they might even give us a friendly discount
12:22:34 <bcotton> asamalik++
12:22:37 <stickster> ¯\_(ツ)_/¯
12:22:40 <cverna> ok yes just thinking out load about what needs to be done :)
12:22:47 <stickster> We're small potatoes to them, they actually *make* money
12:22:59 <bcotton> they power 25% of the internetz
12:23:14 <bcotton> but marketing folks always like to hand out discounts :-)
12:23:23 <bcotton> but that's neither here nor there
12:23:49 <cverna> +1 for me too to move to WP.com
12:23:50 <stickster> OK, next action here is probably to gather some info on moving to wp.com
12:24:12 <stickster> #idea Medium-term plan should be to move FM to wordpress.com
12:24:16 <stickster> +1 from me as well
12:24:19 <bcotton> stickster: i'll take that #action
12:24:49 <bcotton> +1 as commblog seems to feel the same way
12:24:51 <stickster> #agreed Start investigating moving FM to wordpress.com business plan (+1: 3, -1: 0)
12:25:08 <stickster> #action bcotton investigate wp.com options since comm-blog is also going that way
12:25:14 <stickster> Thanks Ben -- great topic to bring up
12:25:24 <cverna> bcotton++
12:25:24 <zodbot> cverna: Karma for bcotton changed to 6 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
12:25:36 <asamalik> bcotton++
12:25:36 <zodbot> asamalik: Karma for bcotton changed to 7 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
12:25:42 <bcotton> proposed #action bcotton to create a Taiga board for planning. people can add things i need to investigate
12:25:54 <stickster> #info For those in the peanut gallery, and doing self-hosted, check out the Remi PHP repos -- they work great.
12:25:55 <bcotton> poorly worded #action, but there we go :-)
12:26:19 <stickster> #info If you're a paid RHEL 7 customer, look to software collections :-)
12:26:28 <stickster> bcotton: +1
12:26:36 <cverna> +1 for the board too
12:26:46 <asamalik> +1
12:26:49 <bcotton> does anyone feel like using the Remi PHP repo is important as a bridge to the next phase, or if it ain't broke don't fix it
12:26:53 <bcotton> #action bcotton to create a Taiga board for planning. people can add things i need to investigate
12:27:38 <stickster> bcotton: AIUI the performance gets *significantly* better with PHP 7
12:27:40 <bcotton> (i'm mostly asking because if you say "leave it alone" i wont even bother bringing it up as an option to commblog)
12:28:24 <stickster> that's what I've seen on my own self-hosted instances... so it *is* an option if people want to do their own upkeep
12:28:58 <stickster> bcotton: I think it's best for people to make decisions with all the info
12:29:24 <stickster> *and* I think moving to wp.com is the right move for us provided we can make everything work the same way there (which I think we can)
12:29:38 * cverna don't really mind either way (php7 or not)
12:29:48 <stickster> They also support domain mapping so it should mean everything can work the way we want
12:30:05 <stickster> OK, we need to move on and we have next actions
12:30:15 <stickster> #action bcotton create a Taiga board for planning
12:31:24 <asamalik> speaking about boards... I was thinking whether we want to move our publishing planning to a board, too? but that's probably for the open floor or a ML :)
12:31:37 <stickster> yeah, let's start with list, that's a bigger topic
12:31:48 <stickster> #topic Pending review posts
12:31:50 <stickster> #link https://fedoramagazine.org/wp-admin/edit.php?post_status=draft&post_type=post
12:32:11 <stickster> #info nothing here :-( moving on
12:32:19 <stickster> #undo
12:32:19 <zodbot> Removing item from minutes: INFO by stickster at 12:32:11 : nothing here :-( moving on
12:32:23 <stickster> Ha, I was looking at the wrong list
12:32:43 <cverna> we have petr's article
12:32:44 <stickster> #info --- Packit ---
12:32:46 <stickster> #link https://fedoramagazine.org/?p=27782&preview=1&_ppp=63c109b2cb
12:33:24 <stickster> Hmm. I think this content is incredibly useful, but *only* for packagers.
12:33:53 <cverna> or for upstream looking to add their package to Fedora
12:34:05 <asamalik> yes, I feel like the community blog would be the best for this
12:34:15 <stickster> Ohhhh good point cverna
12:34:19 <asamalik> cverna: maybe?
12:34:24 <cverna> that's was the point that make me feel that the magazine is a good place
12:34:45 <stickster> The general developer case is a good one for us to be targeting. +1 cverna
12:35:00 <cverna> maybe a app maintainer will read the article and feel that it is not that much work to add his app to Fedora
12:35:33 <asamalik> how much do we want to say it that packaging in Fedora is hard? :)
12:35:42 <asamalik> *want it to say
12:36:01 <cverna> :)
12:36:44 <stickster> +1 from me
12:36:53 <stickster> asamalik: It ain't easy.
12:37:35 <cverna> +1 too
12:37:48 <asamalik> fair :)
12:37:52 <asamalik> definitely +1
12:37:58 <stickster> I would say, if phracek__ thinks the article is ready, we can run it as soon as Friday.
12:38:21 <asamalik> I can edit it and make an image
12:38:44 <asamalik> for Friday
12:39:54 <cverna> asamalik++
12:39:54 <zodbot> cverna: Karma for asamalik changed to 3 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
12:39:56 <stickster> asamalik: Whoa! Cool on you. You're on
12:39:59 <stickster> asamalik++
12:39:59 <zodbot> stickster: Karma for asamalik changed to 4 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
12:40:15 <stickster> #action asamalik edit phracek article and image it for Friday publication
12:40:36 <stickster> That's it for this status category unfortunately, so, moving on...
12:40:44 <stickster> #topic Drafts to review
12:40:55 <stickster> #link https://fedoramagazine.org/wp-admin/edit.php?post_status=draft&post_type=post
12:41:15 <stickster> *this* is the status with nothing new :-(
12:42:05 <cverna> :-(
12:42:10 <asamalik> if we don't have enough, I can write the one about Pantheon desktop which is new in f30... we've mentioned it some time ago... I could have it ready for next Wednesday
12:42:38 <stickster> asamalik: OK, you're on there as well. Beggars are not going to be choosers!
12:42:39 * asamalik hopes the desktop is ready, haven't actually checked
12:42:48 <asamalik> hahaha
12:42:52 <cverna> lol
12:42:59 <bcotton> YOLO
12:43:10 <stickster> #action asamalik check that Pantheon is ready to use in F30 and if so will write an article for it for next Wednesday
12:43:42 <stickster> #action stickster write to pyzhang and see if they still want to do the article on Hygon Dhyana
12:44:38 <cverna> I did write them an email last week but I had no answer ^^
12:45:14 <cverna> Do you think an article on how to use Gnome shell keyboard shortcuts would be interesting ? Gnome is actually design to be mostly used with the keyboard
12:45:48 <stickster> cverna: That's a pretty good idea too. We tend to get lots of hits on GNOME articles as well.
12:45:51 <bcotton> cverna: sounds good to me
12:46:03 <stickster> #topic Random pitches to fill content :-)
12:46:19 <stickster> #idea from cverna: GNOME Shell keyboard shortcuts
12:46:29 <stickster> Lots of folks don't know about Ctrl+Alt+Tab for instance
12:46:29 <bcotton> do we have a list of article ideas somewhere? i've found in other contexts that saying "here's stuff we want someone to write about" lowers the barrier
12:46:56 <stickster> bcotton: yes, in the "Starter pitches" category already stocked up with stuff
12:47:44 <cverna> 5 Gnome shell keyboard shortcuts to increase your productivity --> I can probably do that for monday
12:47:48 <bcotton> stickster: let's pretend i'm not very smart for a moment. where would i find that?
12:47:52 <stickster> cverna: That would be outstanding
12:48:06 <stickster> bcotton: Log in, go to posts, and choose the "Starter pitches" status at top
12:48:28 <bcotton> ah! didn't know that would be visible to me
12:48:35 <stickster> That's how I do it, and I'm proven to be not very smart, esp. if you ask my wife or kids
12:48:40 <cverna> ok then count me in
12:48:49 <stickster> cverna++
12:48:51 <zodbot> stickster: Karma for cverna changed to 5 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
12:48:56 <asamalik> cverna++
12:48:59 <zodbot> asamalik: Karma for cverna changed to 6 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
12:49:07 <stickster> #action cverna Write "5 GNOME Shell keyboard shortcuts" article for Monday
12:49:10 <bcotton> unsolicited suggestion: it might be good to advertise that list (on what channel(s)? idk) from time to time so people know to look for it
12:49:12 <stickster> cverna: I can edit/image for you
12:49:23 <cverna> stickster: thanks :)
12:49:33 <stickster> bcotton: We should probably do an article on it ;-)
12:49:52 <stickster> #action stickster edit/image cverna's keyboard shortcuts article
12:50:18 <stickster> cverna: Do you think you'd deliver it on Friday, or by Sunday? I can probably handle either way, just looking for when to reserve time
12:50:43 <cverna> stickster: I think I can do that for Friday
12:52:25 <stickster> cverna: neat! You're on
12:52:51 <stickster> I'm going to try to come up with something for next Friday myself ;-) maybe that "come write for us" article
12:53:05 <stickster> #action stickster write a "come write for us" article pointing to Starter Pitches
12:53:22 <stickster> OK, we need to get out of here for next meeting, so:
12:53:25 <stickster> #topic Publishing schedule
12:54:00 <asamalik> meetings++
12:54:30 <stickster> #proposed #agreed Fri 2019-05-24: Packit (asamalik) -- Mon 2019-05-27: GNOME Shell keycombos (cverna/stickster) -- Wed 2019-05-29: Pantheon (asamalik) -- Fri 2019-05-31: Writing for FM (stickster)
12:54:51 <asamalik> +1
12:54:59 <cverna> lgtm :)
12:56:25 <stickster> [3~ #agreed Fri 2019-05-24: Packit (asamalik) -- Mon 2019-05-27: GNOME Shell keycombos (cverna/stickster) -- Wed 2019-05-29: Pantheon (asamalik) -- Fri 2019-05-31: Writing for FM (stickster)
12:56:29 <stickster> ARGH!
12:56:33 <stickster> #agreed Fri 2019-05-24: Packit (asamalik) -- Mon 2019-05-27: GNOME Shell keycombos (cverna/stickster) -- Wed 2019-05-29: Pantheon (asamalik) -- Fri 2019-05-31: Writing for FM (stickster)
12:56:48 <cverna> \o/
12:56:58 <stickster> #topic All other business (open floor)
12:57:08 <stickster> nothing from me
12:57:13 * asamalik has nothing
12:57:16 <cverna> same here
12:57:30 <bcotton> nothing for this time,b ut i'm looking at possibly using taiga for planning commblog posts. i'll report here how that goes
12:57:42 <bcotton> (fwiw trello is still the best for that use case that i've found)
12:58:05 <asamalik> bcotton: I had the same idea for the Magazine!
12:58:14 <stickster> *nod, cards seem to mimic real-life methods for a lot of publications
12:58:20 <stickster> let us know bcotton
12:58:26 <cverna> yes trello is dead simple, taiga is very opinionated IMO
12:58:35 <asamalik> and they allow post comments etc easily
12:59:02 <stickster> asamalik++. OK then... Time to wrap, see you next week, same bat-time, same bat-channel!
12:59:03 <bcotton> asamalik: yes, that's why i brought it up. you inspired me
12:59:07 <stickster> #endmeeting