12:00:01 <stickster> #startmeeting Magazine editorial board
12:00:01 <zodbot> Meeting started Wed Jul  3 12:00:01 2019 UTC.
12:00:01 <zodbot> This meeting is logged and archived in a public location.
12:00:01 <zodbot> The chair is stickster. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:00:01 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
12:00:01 <zodbot> The meeting name has been set to 'magazine_editorial_board'
12:00:02 <ryanlerch> .hello ryanlerch
12:00:03 <zodbot> ryanlerch: ryanlerch 'Ryan Lerch' <rlerch@redhat.com>
12:00:03 <stickster> #meetingname magazine
12:00:03 <zodbot> The meeting name has been set to 'magazine'
12:00:05 <stickster> #topic Roll call
12:00:09 <stickster> .hello pfrields
12:00:10 <zodbot> stickster: pfrields 'Paul W. Frields' <stickster@gmail.com>
12:00:20 <ryanlerch> morning stickster!
12:00:24 <stickster> #chair ryanlerch cverna asamalik
12:00:24 <zodbot> Current chairs: asamalik cverna ryanlerch stickster
12:00:27 <stickster> evening ryanlerch
12:00:35 <ryanlerch> :D
12:01:15 <asamalik> .hello2
12:01:18 <zodbot> asamalik: asamalik 'Adam Samalik' <asamalik@redhat.com>
12:01:27 <bcotton> .hello2
12:01:31 <zodbot> bcotton: bcotton 'Ben Cotton' <bcotton@redhat.com>
12:01:46 <stickster> #chair bcotton
12:01:46 <zodbot> Current chairs: asamalik bcotton cverna ryanlerch stickster
12:01:52 <stickster> Yay Ben's here!
12:02:19 <bcotton> oh sh.....
12:03:44 <stickster> I'm not expecting Clément -- he and his wife just had a baby last week :-)
12:03:52 <stickster> #topic Last week's stats
12:04:30 <stickster> #info Week of June 24: 68.8K pageviews, up over 11% from previous week
12:04:36 <asamalik> \o/
12:04:41 <stickster> Not surprising since we published more that week, I thik :-)
12:05:07 <ryanlerch> woo!
12:05:20 <stickster> #info June 2019: 264K pageviews, very slightly down YoY, last June was 267K
12:05:55 <stickster> It seems like we would have been up if not for a couple post bobbles
12:07:14 <stickster> We have a few posts to review, and keeping in mind that some people have holidays coming up, we might as well plunge in :-)
12:07:35 <stickster> #topic Drafts to review
12:07:39 <stickster> #link https://fedoramagazine.org/wp-admin/edit.php?post_status=draft&post_type=post
12:08:08 <stickster> #info --- zsh environment basics ---
12:08:13 <stickster> #link https://fedoramagazine.org/?p=21453&preview=1&_ppp=9ab54217c6
12:09:00 <stickster> So... to me this looks like environment basics that apply 99% to bash (only exception I can see is talking about .zshrc instead of .bashrc)
12:09:57 <stickster> I think it's a great thing to teach people, but maybe we can slightly reorient title that way and make it less zsh focused? Still lets x3mboy trampoline off the concepts for his next article
12:10:13 <asamalik> yeah... so was it meant to show how similar it is in those things?
12:10:43 <stickster> asamalik: No, just meant to show the concepts themselves -- aliases, resource files, variables
12:10:50 <asamalik> ok
12:11:45 * stickster searching for an action-y title, or something that sounds cool
12:11:56 <asamalik> I like how it shows the source and export commands... not everyone knows those... but probably not zsh...
12:12:10 <asamalik> basically the Resource Files section talks about making aliases permanent
12:12:19 <asamalik> we could tweak it to include bash, too
12:12:29 <stickster> I think zsh, bash both have .*shrc so it would be easy to tweak
12:12:54 <stickster> "Get to know the shell environment"
12:12:57 <asamalik> and name it something general like "Manage your shell environment"
12:13:02 <asamalik> yeah
12:13:05 <stickster> ^ that's good
12:13:23 <stickster> ryanlerch: bcotton: Any ideas on this one?
12:13:24 <ryanlerch> yeha, that is perfect
12:13:53 <bcotton> +1 to the tweaks and to both title ideas
12:13:56 <stickster> I have some time to edit late this afternoon, right before holidays which is nice
12:14:03 <asamalik> I'm a bit overcommitted before my holiday that starts this Friday... but this is easy enough and I think I could squeze it in to get it ready for Friday
12:14:18 <asamalik> to do at least something :)
12:14:57 <asamalik> or sure stickster even better :P
12:15:09 <stickster> asamalik: That sounds good, why don't you take this one. I'll plan to work on something for next week in advance while you're gone
12:15:15 <asamalik> ha ok!
12:15:30 <stickster> #action asamalik edit shell environment article -- genericize it slightly
12:15:57 <stickster> #undo
12:15:57 <zodbot> Removing item from minutes: ACTION by stickster at 12:15:30 : asamalik edit shell environment article -- genericize it slightly
12:16:06 <stickster> #action asamalik edit shell environment article for Friday publication -- genericize it slightly
12:16:21 <stickster> ryanlerch: got time to do an image for that one ^ ?
12:16:31 <ryanlerch> stickster: for sure!
12:16:36 <stickster> #action ryanlerch do image for shell environment article
12:17:03 <stickster> #info --- Silverblue 101 ---
12:17:18 <stickster> ryanlerch: can you turn on public preview and #link here?
12:17:46 <ryanlerch> #link https://fedoramagazine.org/?p=28637&preview=1&_ppp=16ecedcaa6
12:18:04 <stickster> thanks!
12:18:07 <ryanlerch> saorry stickster!
12:18:13 <stickster> nope nope, it's all good
12:18:40 <stickster> So this was actually an article some readers requested. It's a little like a FAQ but I think overall pretty darn good
12:19:48 <stickster> It directly answers all the questions our readers (and reddit) were asking
12:21:47 <asamalik> I really like it!
12:22:00 <ryanlerch> yeah, its very throuough
12:22:09 <Southern_Gentlem> next is a need for a CoreOS article
12:22:23 <stickster> I don't mind editing and pushing this one out... I'd actually like to have an article for tomorrow (Thursday) so we have three this week
12:22:33 <ryanlerch> never done a FAQ before, so let's see how that format goes i reckon
12:23:01 <ryanlerch> stickster: i can do the image for it too
12:23:07 <stickster> cool, thanks ryanlerch
12:23:26 <stickster> #edit ryanlerch do image for Silverblue article for a Thu publication
12:23:30 <stickster> argh
12:23:34 <stickster> #action ryanlerch do image for Silverblue article for a Thu publication
12:23:44 <stickster> #action stickster edit Silverblue article for a Thu publication
12:24:23 <stickster> Is the "Silverblue 101" title good enough? Or do we want something else?
12:25:13 <ryanlerch> i think saying it is a FAQ might help
12:25:21 <ryanlerch> if it keeps that format
12:25:27 <bcotton> plus "silverblue faq" has a nice lyrical quality
12:25:28 <stickster> I don't see why not
12:25:58 <Southern_Gentlem> stickster, that title is fine, it will be catchy  for people wanting to learn what Silverblue is
12:26:11 <bcotton> question titles tend to do well, generally speaking: "what is Fedora Silverblue?" might be a good one
12:26:38 <Southern_Gentlem> +1 bcotton as well
12:26:46 <stickster> bcotton: That's a good point... and it kind of leads into the first section anyway.
12:26:52 <stickster> bcotton++
12:26:58 <ryanlerch> bcotton++
12:26:58 <zodbot> ryanlerch: Karma for bcotton changed to 16 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
12:27:10 * stickster retitles it
12:27:22 <stickster> OK, we'll get this out for tomorrow
12:27:38 <stickster> #info --- Managing passwords with Bitwarden and Podman ---
12:27:51 <stickster> #link https://fedoramagazine.org/?p=28543&preview=1&_ppp=765450d206
12:28:22 <stickster> This is actually a pitch that just came in recently on the list -- I jumped in and +1'd it on the list, anyone opposed?
12:30:14 <stickster> Sounds like not :-)
12:30:25 <stickster> #agreed pitch is approved, author will hopefully have draft soon
12:30:33 <stickster> #topic Pitches to approve
12:30:43 <stickster> #link https://fedoramagazine.org/wp-admin/edit.php?post_status=pitch&post_type=post
12:30:50 <stickster> #info --- Firefox 68 release ---
12:31:08 <stickster> #link https://fedoramagazine.org/?p=28538&preview=1&_ppp=6797e86de9
12:31:20 <asamalik> is there something significant in this release?
12:31:35 <stickster> ryanlerch: I think this one is yours. Fits totally with our meeting notes last week about reporting on new releases of popular software that will be found in Fedora
12:31:59 <ryanlerch> asamalik: nothing significant, just more a notification that there was a new release
12:32:10 <ryanlerch> was going to try to do them regularly
12:32:24 <ryanlerch> happy to hear +'s or -'s on that idea
12:32:53 <stickster> There are a couple neat things in the new release, like the ability to manage website workarounds, and better info about addons
12:32:59 <stickster> +1 from me
12:33:34 <asamalik> ryanlerch: ha ok! yeah why not, posting about relevant updates could actually be quite nice
12:33:35 <asamalik> +1
12:34:05 <stickster> LibreOffice 6.2.5 is coming out today supposedly, but I don't know what it has
12:34:10 <ryanlerch> i emailed the package owner to see if they had any input too
12:34:26 <ryanlerch> ^ for firefox
12:34:33 <stickster> ryanlerch++
12:34:43 <stickster> I bet a .z release is not much to squawk about
12:34:45 <bcotton> +1 if for no other reason than it's a good way to make our upstreams like us more
12:35:12 <asamalik> bcotton +1 !
12:35:25 <stickster> Indeed!
12:35:39 <stickster> Looks like LibreOffice 6.3 will be out next month (early August)
12:36:22 <asamalik> I really like this idea
12:37:09 <stickster> The rest of the pitches are not new, and no activity so far
12:37:31 <stickster> ryanlerch: Do you want to line up the Firefox 68 article for next Wed, by which time it should be out?
12:37:43 <ryanlerch> stickster: for sure!
12:37:56 <stickster> obviously we don't want to publish without that being true :-) but they're pretty solid on schedule usually
12:39:20 * bcotton is working on the bonding article. the technical research is done (and it works), and i'm working on making words
12:39:30 <stickster> bcotton++ !!!
12:39:57 <stickster> #idea stickster to pick up a starter pitch and run with it for Monday... like sharing a folder, which has interesting facets. I'd plan to cover both the shared-system (i.e. chmod) but also remote sharing using Workstation/Silverblue
12:40:12 <bcotton> stickster: +1
12:40:48 <stickster> ryanlerch: Did you see that cool Jupyter article image? I know it's simple but I loved the photo I found (cc by-sa!)
12:41:02 <ryanlerch> stickster: i did! loved it!
12:41:15 <stickster> OH CRAP
12:41:28 <stickster> ryanlerch: I screwed up!!!! I just saw that I put "Jupiter" in the image and not "Jupyter"
12:41:33 * stickster will fix right after this
12:41:46 <stickster> HAHAHA. Serves me right for "the sin of pride"
12:43:06 <stickster> So I guess here we are:
12:43:10 <stickster> #topic Publishing schedule
12:44:32 <stickster> PROPOSED: #agreed Thu Jul 4, Silverblue (stickster/ryanlerch) -- Fri Jul 5, shell env (asamalik/ryanlerch) -- Mon Jul 8, folder sharing (stickster) -- Wed Jul 10, Firefox 68 (ryanlerch) -- Fri Jul 12, TBD (maybe bcotton?)
12:44:59 <stickster> ^ based on above ryanlerch gets the MVP award :-D
12:45:23 <bcotton> +1 (i hope to have my article done by this time next week)
12:45:29 <asamalik> +1
12:46:57 <stickster> bcotton: that will work out just about perfectly, if so
12:46:57 <ryanlerch> +1
12:47:09 <stickster> #agreed Thu Jul 4, Silverblue (stickster/ryanlerch) -- Fri Jul 5, shell env (asamalik/ryanlerch) -- Mon Jul 8, folder sharing (stickster) -- Wed Jul 10, Firefox 68 (ryanlerch) -- Fri Jul 12, TBD (maybe bcotton?)
12:47:20 <stickster> #topic Open floor, all other business
12:47:26 <bcotton> o/
12:47:51 <asamalik> I have an update about my Taiga/kanban/tracking things
12:48:26 <stickster> go for it asamalik !
12:49:01 <asamalik> basically, Taiga gives a nice view of the state, but it's quite hard to maintain it manually + we can't assign authors that have not been manually added to it
12:49:11 <asamalik> so the view is nice, but the maintenance not that much
12:49:47 <asamalik> I've tried a few boards that work within wordpress, but none of those visualized the states of the articles.. they sort of worked independently
12:49:54 <stickster> Yeah, that mismatch seems difficult
12:49:59 <asamalik> so basically no benefit over taiga, except they usually didn't look that great
12:50:23 <asamalik> so I looked at other options and played with the plugin we use for managing states — Edit Flow
12:50:23 <stickster> oof
12:50:41 <stickster> "didn't look that great" --> oof. Not a comment on edit flow :-)
12:50:54 <asamalik> ha, no :)
12:50:59 <asamalik> and I think if we just keep using that, but maybe tweak the categories
12:51:10 <asamalik> in a way that we don't have to remember which pitch we've seen, etc
12:51:37 <asamalik> and we either trash articles that we know won't make it, or use a "stalled" category for them
12:52:06 <stickster> If our authors are able to move their article as we tell them, this should work on its own, though, right?
12:52:26 <stickster> contributor puts new article for consideration into --> Pitch
12:52:37 <stickster> We review it, put it into --> Draft (and make the contributor an Author)
12:52:48 <stickster> They finish, put it into --> Pending Review
12:53:01 <asamalik> I was thinking about a state between Pitch and Draft
12:53:08 <asamalik> for "approved, but not yet worked on"
12:53:09 <stickster> Maybe the second step is the issue :-) We don't always do that successfully
12:53:33 <asamalik> yeah
12:54:01 <stickster> If we add that other state, it adds a step to the contributor's work. They have to remember to move it out of "not yet worked on" and into standard "Draft"
12:54:10 <asamalik> and also there's just too much stuff we "know" we've seen and don't need to review, but it's sometimes confusing... and I wanted to also fix that by the board by only showing what's not dead
12:54:33 <stickster> Are there ways we could fix that by simply enforcing better hygiene with our states now?
12:55:01 <stickster> i.e. "We don't see your finished article until you move it to Pending Review"; and "We don't look at anything in Draft"
12:55:01 <asamalik> maybe?
12:55:11 <asamalik> and maybe the "Starter Pitches" is what I'm looking for?
12:55:26 <stickster> That's the "ideas someone could take" bin
12:55:47 <stickster> We could move pitches to it if they fail to get drafted
12:56:05 <stickster> in cases where we clearly have said, "yay +1" and then nothing happens
12:56:15 <asamalik> yeah, that's my thinking... there is basically no difference between "ideas someone could take" and "approved pitches"
12:56:21 <stickster> Good point
12:56:37 <asamalik> yes
12:56:45 <stickster> "New pitches" and "Approved pitches"
12:56:55 <asamalik> yeah
12:57:02 <asamalik> and draft would be like in progress
12:57:25 <asamalik> then we should have a "stalled" section (or move it back to pitches?) when the author does not have time anymore... which happens
12:57:30 <asamalik> and then the pending review
12:57:45 <stickster> I like "move back to approved pitches"
12:58:00 <stickster> We also have a "holding pen" bucket that could be eliminated in that case
12:58:01 <asamalik> yeah, that's probably better than just "stalled" and giving up on it basically
12:58:08 <asamalik> and anyone else can pick it up and finish it
12:58:12 <asamalik> and it's all transparent
12:58:16 <stickster> #proposed #idea asamalik to write up a better flow that doesn't get too confusing, and put on list
12:58:26 <bcotton> +1
12:58:26 <asamalik> ha, deal! but when I'm back
12:58:35 <stickster> yeah, not urgent by any means
12:58:43 <asamalik> and I'll trash the board
12:58:58 <stickster> we can deal with this as we have for a while, or if someone else wants to write it up in the meantime, they're welcome
12:58:59 <asamalik> and wait for bcotton's experiments with a board with the commblog :P
12:59:20 <stickster> I like the idea of not tracking in two places, or adding another system to a process that may not need it
12:59:25 <bcotton> asamalik: oh, i'm waiting for you :p
12:59:38 <stickster> OK, that's time... I'm going to close up, meeting starting elsewhere in < 1 min!
12:59:42 <stickster> Thanks for coming everyone!
12:59:43 <asamalik> cool!
12:59:45 <stickster> #endmeeting