12:01:12 <asamalik> #startmeeting Magazine editorial board
12:01:12 <zodbot> Meeting started Wed May 27 12:01:12 2020 UTC.
12:01:12 <zodbot> This meeting is logged and archived in a public location.
12:01:12 <zodbot> The chair is asamalik. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:01:12 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
12:01:12 <zodbot> The meeting name has been set to 'magazine_editorial_board'
12:01:12 <asamalik> #meetingname magazine
12:01:12 <zodbot> The meeting name has been set to 'magazine'
12:01:12 <asamalik> #topic Roll call
12:01:12 <asamalik> #chair stickster ryanlerch cverna asamalik sub_pop gregbartholomew jakfrost misc rwaltr
12:01:12 <zodbot> Current chairs: asamalik cverna gregbartholomew jakfrost misc rwaltr ryanlerch stickster sub_pop
12:01:54 <stickster> .hello pfrields
12:01:55 <zodbot> stickster: pfrields 'Paul W. Frields' <stickster@gmail.com>
12:02:39 <bcotton> .hello2
12:02:42 <zodbot> bcotton: bcotton 'Ben Cotton' <bcotton@redhat.com>
12:02:50 <sysoplab> .hello2 sysoplab
12:02:52 <zodbot> sysoplab: sysoplab 'Sean Zipperer' <sysop+fedora@sysoplab.com>
12:02:57 <asamalik> Happy Wednesday!
12:03:08 <asamalik> .hello2
12:03:09 <zodbot> asamalik: asamalik 'Adam Samalik' <asamalik@redhat.com>
12:03:45 <sysoplab> I will be afk by end of this meeting sorry folks have to drop SO off at work and do some tech support for some people this morning.
12:05:01 <asamalik> sysoplab: no worries!
12:05:09 <asamalik> #topic Agenda
12:05:09 <asamalik> #link https://docs.fedoraproject.org/en-US/fedora-magazine/workflow/
12:05:09 <asamalik> #info -- 1/ Last week's stats --
12:05:09 <asamalik> #info -- 2/ In progress followup --
12:05:09 <asamalik> #info -- 3/ Finished articles to review --
12:05:10 <asamalik> #info -- 4/ Articles to edit --
12:05:10 <asamalik> #info -- 5/ Publishing schedule --
12:05:11 <asamalik> #info -- 6/ Article proposals to clarify / approve --
12:05:11 <asamalik> #info -- 7/ Open floor --
12:05:21 <asamalik> #topic 1/ Last week's stats
12:05:29 <asamalik> #info Week of 18 May: 73k pageviews -- slightly down from the previous week, but still above average
12:06:12 <stickster> Not too shabby considering only a couple articles
12:06:23 <asamalik> yep!
12:06:26 <sysoplab> How long is the sample you're taking from for the average?  Every week since I've been here has been above average but down
12:06:49 <asamalik> sysoplab: there was a release announcement that has generated a lot of traffic
12:07:00 <asamalik> so even though it's been falling for a few weeks, it's still above average
12:07:06 <asamalik> if you log in to Wordpress, it's on the dashboard
12:07:12 <asamalik> just scroll down a bit and you'll see a chart
12:07:42 <sysoplab> Ok will do.
12:07:52 <asamalik> and I just look at the whole graph, it's showing the past 3 months
12:08:25 <asamalik> #topic 2/ In progress followup
12:08:25 <asamalik> #info Looking at the 'in progress' column, is there something that's been finished? Anything to follow up on with its author?
12:08:25 <asamalik> #link Board: https://teams.fedoraproject.org/project/asamalik-fedora-magazine/kanban
12:09:33 <asamalik> there is one about mindmapping, moved there yesterday
12:09:45 <asamalik> so we can definitely give the author time :)
12:10:01 <asamalik> #topic 3/ Finished articles to review
12:10:02 <asamalik> #info Looking at the 'review' column, let's decide which articles are good to go. Move each either to the 'to edit' (finished) or to the 'in progress' (needs more work) and provide feedback.
12:10:02 <asamalik> #link Board: https://teams.fedoraproject.org/project/asamalik-fedora-magazine/kanban
12:11:10 <stickster> asamalik: I think the firewall article should be in 'in progress' according to comments.
12:11:31 <asamalik> agree
12:12:07 <stickster> cverna moved his article to 'review' so I assume that means it's a finished draft though!
12:12:12 <sysoplab> The fast API one I was tagged for yesterday and I got first read through in.  Soon as I get back from above stuff I plan on noting what I can.  There was at least one tense that seemed wrong
12:12:14 <asamalik> and #156 loos good :)
12:12:55 <asamalik> ok, I'm moving it to to edit
12:13:16 <asamalik> and that's all here
12:13:18 <asamalik> #topic 4/ Articles to edit
12:13:18 <asamalik> #info Looking at the 'to edit' column, assign an editor and a cover image creator.
12:13:18 <asamalik> #link Board: https://teams.fedoraproject.org/project/asamalik-fedora-magazine/kanban
12:13:41 <asamalik> and here we have just one, the very same we just discussed :D
12:14:05 <asamalik> anyone would like to edit or image this one? :)
12:14:11 * asamalik is happy to do both
12:16:11 <stickster> I can do either
12:16:24 <stickster> I'll make you an image tonight for it, how's that
12:16:30 <asamalik> deal
12:16:43 <asamalik> #action asamalik edit #156
12:16:52 <asamalik> #action stickster image #156
12:17:20 <asamalik> #topic 5/ Publishing schedule
12:17:21 <asamalik> #info Looking at the 'queued' and 'to edit' columns, decide the publishing schedule for the next week period.
12:17:21 <asamalik> #info If there is not enough content, we might also need to look at the 'in progress' or even the 'article spec' columns come up with additional content.
12:17:21 <asamalik> #link Board: https://teams.fedoraproject.org/project/asamalik-fedora-magazine/kanban
12:17:30 <asamalik> looks like we have two candidates!
12:17:35 <asamalik> #165 is already done
12:17:41 <asamalik> #156 we've just discussed
12:17:58 <asamalik> so what about #165 Friday, and #156 Monday?
12:18:24 <sysoplab> The fast API one like I said I should be able to get any edits needed done this afternoon.  I'm not good at image creation though (never done it)
12:18:50 <sysoplab> Might want to have an experienced editor go through it after me to see if I messed up
12:18:58 <asamalik> sysoplab: oh do you want to edit it? sure!
12:19:00 <asamalik> happy to help with that
12:19:15 <stickster> sysoplab++
12:19:15 <zodbot> stickster: Karma for sysoplab changed to 3 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
12:19:34 <stickster> sysoplab: I can take care of the image for #156
12:19:50 <asamalik> sysoplab++
12:19:50 <zodbot> asamalik: Karma for sysoplab changed to 4 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
12:20:39 <bcotton> sysoplab++
12:21:03 <asamalik> #proposed #agreed PUBLISHING SCHEDULE: Fri 29 May 2020: #165 Generate an epub file on Fedora (image: DONE, edit: DONE) -- Mon 01 Jun 2020: #156 Use FastAPI to build python microservices (image: stickster, edit: sysoplab (and asamalik helps))
12:22:04 <sysoplab> Ok I'll tag asamalik to see what I missed.  Thanks for the opportunity.  Driving now so afk sorry (don't text /meet and drive.)
12:22:16 <asamalik> sysoplab: safe travels!
12:22:44 <cverna> I did a an image for the FastAPI reusing an old image from a previous Python article :P
12:23:01 <cverna> thanks sysoplab for the review + edits
12:23:10 <cverna> sysoplab++
12:23:10 <zodbot> cverna: Karma for sysoplab changed to 5 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
12:23:14 <asamalik> stickster: they're stealing our jobs!
12:23:47 <stickster> lol
12:24:45 <asamalik> cverna: so I'll mark the image as done — can you please add it to the article?
12:25:02 <asamalik> any +1's -1's to the publishing schedule?
12:25:05 <bcotton> +1
12:27:25 <cverna> asamalik: sure
12:27:31 <cverna> +1 here
12:27:53 <stickster> +1
12:28:00 <asamalik> #agreed PUBLISHING SCHEDULE: Fri 29 May 2020: #165 Generate an epub file on Fedora (image: DONE, edit: DONE) -- Mon 01 Jun 2020: #156 Use FastAPI to build python microservices (image: DONE, edit: sysoplab (and asamalik helps))
12:28:12 <asamalik> #topic 6/ Article proposals to clarify / approve
12:28:12 <asamalik> #info Review the the article proposals and decide about what's next — a new article spec? more discussion?
12:28:12 <asamalik> #link Article proposals: https://pagure.io/fedora-magazine-proposals/issues
12:31:16 <stickster> asamalik: What should we do with proposals that don't have any action or responses in a long time?
12:31:52 <stickster> I suppose they may be good for someone else to take up
12:31:54 <asamalik> good question, we don't have any standard procedure for that, but we probably should have
12:32:39 <stickster> Here's a suggestion, if no response from the proposer, we should relabel it as needs-author
12:32:47 <stickster> or needs-writer, whichever that label was
12:33:01 <asamalik> so that's decided in Taiga
12:33:13 <asamalik> do you mean proposals Pagure?
12:33:39 <stickster> proposals Pagure.
12:33:48 <stickster> for example https://pagure.io/fedora-magazine-proposals/issue/36
12:34:00 <stickster> I thought we were talking about proposals at this point
12:34:49 <asamalik> yep, sorry, got confused with the writer. Haven't realized this was about a proposal that still needs some work to be accepted, but whoever has proposed it is no longer responding
12:35:03 <asamalik> I'd say just trash it at that point
12:35:52 <asamalik> or if the idea is interesting, we can write article specs about it so someone can pick it up
12:35:57 <bcotton> +1 to the tag proposal
12:38:42 <asamalik> So I thought we're only collecting ideas in Pagure. And actual articles  that we track and have authors etc are in Taiga. So I'd expect authors to look in Taiga for ideas, not in Pagure. But I'm open to changes
12:38:52 * asamalik doesn't think that the existing system is working brilliantly
12:40:07 <stickster> Yeah, you've got a point here.
12:40:51 <stickster> So really the problem is that we should be closing the proposals/ideas faster and moving to Taiga if they're good
12:41:02 <stickster> So there shouldn't be such a big backlog in Pagure
12:41:04 <asamalik> in an ideal world, we'd only have one system that would do both
12:41:14 <asamalik> right
12:41:21 <stickster> If the idea is good, it would just move to Taiga
12:41:38 <asamalik> exactly
12:42:30 <stickster> So what if we make an action to try and clear off all backlog of ideas --
12:43:04 <stickster> (1) if it's an agreed on idea, make a card in Taiga and close Pagure issue
12:43:26 <stickster> (2) if it's not agreed and very old or no conversation, close Pagure issue as "wontfix"-ish
12:43:47 <stickster> (3) if it's not agreed and still somewhat active, try to push conversation toward a resolution
12:44:18 <stickster> (4) if it's not agreed but clearly an idea that would be fine, make a card in Taiga and close Pagure issue
12:45:08 <asamalik> sounds good
12:46:24 <bcotton> ship it
12:46:47 <bcotton> i wish we could remember why we're not using taiga issues. that would ease the "convert to card" process
12:47:02 <asamalik> bcotton: I remember that
12:47:25 <asamalik> there were so many fields and it was so confusing to look at that we decided we didn't want to use it, and went for pagure
12:48:13 <asamalik> it wasn't very clear that queue was for proposals, and there was no clear way to have "article proposals" or something written there for additional clarity
12:48:24 <bcotton> siiiigh
12:48:56 <asamalik> I'd love to have that button so much, though
12:49:34 <asamalik> I was also thinking about an alternative approach that would change more things, but could work
12:50:13 <asamalik> Using Discourse instead of the mailing list and this issue tracker... so we'd have one place to discuss things, but as opposed to the mailing list, a place we could easily link to and newcomers could join easily and see everything
12:50:54 <asamalik> article proposals would be just another posts there... and when +1'd, we'd give the person who proposed it permissions in taiga, and maybe ask them to create a card and link back to the thread
12:51:34 <asamalik> that way there would be much less work, and we would still be able to track what we approved
12:52:08 <stickster> Hmm
12:52:22 <asamalik> bcotton: you use discourse for the comm blog right? how does it work for you?
12:52:51 <bcotton> it scales well to an editorial team of 1 :-)
12:53:02 <asamalik> heh
12:53:12 <bcotton> but discourse is an interesting idea
12:53:54 <bcotton> the only downside is adding people who don't use it to a conversation. email is much easier that way. but i'm not sure that's a compelling reason to stay put
12:53:57 <sysoplab> discourse is that forum like stuff trueos went to for a while right?  That wasn't very usable
12:54:01 <asamalik> and I don't mean replacing Taiga... just the issues + mailing list... so the workflow would remain
12:54:20 <sysoplab> (sorry scrolling up and trying to read what I missed quick)
12:55:00 <stickster> LOL
12:55:22 <stickster> "editorial team of 1"
12:55:29 <asamalik> was it Forman? there's a community that switched from a mailing list to discourse and they were giving talks about how their community engagement grew more than double
12:55:32 <stickster> I guess it would be possible for that to work. It would mean one less thing
12:55:43 <stickster> Right now we have mailing list, proposals queue, and Taiga kanban.
12:55:53 <stickster> This would eliminate one of those things
12:56:12 <misc> asamalik: https://theforeman.org/2017/12/foreman-migrates-to-discourse.html
12:56:13 <asamalik> right... so we'd have "discussions of any kind, including ideas and proposals" and a tracker
12:56:20 <misc> asamalik: https://theforeman.org/2018/07/discourse-6-months-on-impact-assesment.html
12:56:55 <asamalik> misc++
12:56:59 <zodbot> asamalik: Karma for misc changed to 5 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
12:57:00 <asamalik> that's it I believe!
12:57:46 <stickster> That seems like it could be an improvement.
12:58:00 <misc> now, we have discourse for Fedora Silverblue and others, and I am not sure the effect can be replicated
12:58:33 <misc> but, people can just test
12:58:39 <stickster> I wonder if Foreman folks have continued to see this trend
12:58:47 <asamalik> oh, we're out of time almost!
12:59:06 <stickster> I think this might be worth a try, but it would mean doing some measurements to see if it worked
12:59:10 <asamalik> Let's continue this on the list? I can start a thread
12:59:12 <misc> greg moved to ansible so I do not know if foreman has a resident data geek anymore :)
12:59:16 <stickster> asamalik++
12:59:16 <zodbot> stickster: Karma for asamalik changed to 4 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
12:59:44 <stickster> cverna: Also, I went ahead and spruced up your graphic for the article so there'd be a new snake :-)
13:00:02 <asamalik> snakes++
13:00:10 <asamalik> all right, thanks everyone for coming!
13:00:12 <sysoplab> I'd like the mailing list to continue to exist.  I'm indifferent to the KanBan thing (don't like/hate it)
13:00:14 <asamalik> #endmeeting