15:00:19 <glb> #startmeeting Magazine editorial board
15:00:19 <zodbot> Meeting started Thu Jul  8 15:00:19 2021 UTC.
15:00:19 <zodbot> This meeting is logged and archived in a public location.
15:00:19 <zodbot> The chair is glb. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:19 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:19 <zodbot> The meeting name has been set to 'magazine_editorial_board'
15:00:19 <glb> #meetingname magazine
15:00:19 <zodbot> The meeting name has been set to 'magazine'
15:00:20 <glb> #topic Roll call
15:00:20 <glb> #chair ryanlerch cverna asamalik sub_pop gregbartholomew jakfrost misc rwaltr rlengland
15:00:20 <zodbot> Current chairs: asamalik cverna glb gregbartholomew jakfrost misc rlengland rwaltr ryanlerch sub_pop
15:00:38 <glb> .hello glb
15:00:39 <zodbot> glb: glb 'Gregory Lee Bartholomew' <gregory.lee.bartholomew@gmail.com>
15:01:56 <rlengland> .hello rlengland
15:01:57 <zodbot> rlengland: rlengland 'Richard England' <rlengland@gmail.com>
15:02:40 <glb> Good morning Richard.
15:02:48 <rlengland> good morning
15:03:17 <glb> #topic Agenda
15:03:17 <glb> #link https://docs.fedoraproject.org/en-US/fedora-magazine/workflow/
15:03:18 <glb> #info -- 1/ Last week's stats --
15:03:18 <glb> #info -- 2/ In progress followup --
15:03:19 <glb> #info -- 3/ Finished articles to review --
15:03:19 <glb> #info -- 4/ Articles to edit --
15:03:20 <glb> #info -- 5/ Publishing schedule --
15:03:20 <glb> #info -- 6/ Editor of the Week --
15:03:21 <glb> #info -- 7/ Open floor --
15:03:38 <glb> #topic 1/ Last week's stats
15:03:51 <glb> #info Week of June 28: 54.0K pageviews -- trending a bit low
15:04:12 <glb> #topic 2/ In progress followup
15:04:12 <glb> #info Looking at the 'in progress' column, is there something that's been finished? Anything to follow up on with its author?
15:04:13 <glb> #link Board: https://teams.fedoraproject.org/project/asamalik-fedora-magazine/kanban
15:05:15 <glb> There are a lot of cards in the "in progress" column.
15:05:35 <rlengland> getting difficult to keep track of them...
15:06:06 <glb> Do you think we should take the time to go through them all?
15:06:43 <rlengland> Since it's just you and me, I doubt it.
15:07:15 <glb> You seem to have been doing a good job at keeping track of their status and responding to questions in them.
15:07:20 <glb> rlengland++
15:07:29 <rlengland> I just have to remember to do a sweep of my email every day or I miss someone/something
15:08:34 <glb> I kind of wish there was a way to order or prioritize them in the column somehow. But I don't think there is any (automated) way to do that.
15:08:47 <glb> I'm just skimming them now.
15:08:53 <rlengland> Yes, I wish that as well.
15:10:19 <glb> The "all posts" view in WordPress seems to order articles by the date that they were last updated. That seems to work as a decent indicator of what is being worked on.
15:10:44 <rlengland> I'll take a look at that
15:11:58 <glb> I think #330 Yubikey is very close to being ready.
15:12:24 <rlengland> +1
15:12:28 <rlengland> :-)
15:12:28 <glb> I moved it back to "in progress" because there was a licensing problem with one of the images in the article.
15:13:11 <glb> I've already got my name on it to do the editing for it and I will get it to publication whenever the author makes the needed corrections.
15:13:58 <computerkid> .hello2
15:13:59 <zodbot> computerkid: computerkid 'Grayson Penland' <gpenland06@gmail.com>
15:14:08 <glb> #action glb to get #330 published after author makes requested correction; will use next available time slot determined from "due date" on cards.
15:14:21 <glb> Hi computerkid. :-)
15:14:50 <computerkid> Hey. I'm just around and wanted to see what's going on in the Magazine :D
15:15:34 <glb> Well, there are lots of articles "in progress", but not enough that are "ready for review". :-)
15:15:52 <glb> That's my view of the current state of things anyway. :-)
15:16:31 * rlengland agrees
15:16:57 * rlengland and thinks we could use another editor or 2
15:18:14 <glb> computerkid: if any topics come up during your podcast interviews that you think might make for good Fedora Magazine articles, please don't hesitate to suggest to people that the "write an article about that" for Fedora Magazine. ;D
15:18:43 <glb> *they
15:18:53 <computerkid> Haha, the last two episodes were about BTRFS, and IDK how many more articles we can write about that XD
15:19:33 <glb> LOTS! IMO. It is a very complex topic that could use more coverage. :-)
15:20:29 <glb> I remember that Chris Murphy said he wanted to write some articles a while back. I think he is just too busy for it.
15:20:39 <glb> Well, moving along.
15:20:59 <glb> #info Are there any upcoming test days?
15:20:59 <glb> #link https://apps.fedoraproject.org/calendar/QA/
15:21:38 <glb> There is!
15:21:52 <glb> That link needs to be fixed in the documentation though.
15:22:05 <glb> It should be https://calendar.fedoraproject.org/QA/
15:22:29 <glb> #action glb to update "test days" link in Fedora Magazine documentation.
15:23:35 <glb> So the card for the test day has already been made and it is in the "queued" column.
15:23:47 <glb> #link https://teams.fedoraproject.org/project/asamalik-fedora-magazine/us/346?kanban-status=193
15:23:48 <rlengland> I published the Kernel 5.13 test days article.  Hope I wasn't premature. Didn't hear from sumantro
15:23:59 <glb> Oh. OK.
15:24:20 <rlengland> Didn't want to wait too long
15:24:28 <glb> It looks like it has been pinned too. Good. :-)
15:24:45 <rlengland> Took me forever to find that 'pin' option
15:25:06 <glb> I actually don't know where it is myself. I've never done it. :-),
15:25:19 <rlengland> Part of the quick edit
15:25:29 <rlengland> little tiny check box
15:25:32 <glb> Ah good to know. Thanks rlengland.
15:25:35 <glb> rlengland++
15:25:57 <glb> I know that that is where the series stuff is too.
15:26:19 <glb> From the discussions on the forum, I think we will be needing to make use of that a lot in the near future.
15:26:32 <rlengland> Oh?
15:27:21 <glb> There might be other ways to set up a series, but that is how I've done it in the past.
15:27:41 <rlengland> Oh, about article series.  gottcha
15:27:57 <rlengland> We should discuss series at the end
15:27:59 <glb> You create a series on a different page, then you can assign articles to the series in the quick edit area.
15:28:05 <glb> OK.
15:28:24 <glb> #info Review release schedule
15:28:25 <glb> #link https://fedorapeople.org/groups/schedule/f-<N>/f-<N>-magazine-tasks.html
15:28:42 <glb> #info nothing until September.
15:29:03 <glb> #topic 3/ Finished articles to review
15:29:03 <glb> #info Looking at the 'review' column, let's decide which articles are good to go. Move each either to the 'to edit' (finished) or to the 'in progress' (needs more work) and provide feedback.
15:29:04 <glb> #link Board: https://teams.fedoraproject.org/project/asamalik-fedora-magazine/kanban
15:29:46 <rlengland> I've dipped my toe int #331 and find my podman foo is inadequate
15:29:55 <rlengland> *into
15:30:04 <glb> Looking at #331 -- Use Docker Compose with Podman to Orchestrate Containers on Fedora #link https://teams.fedoraproject.org/project/asamalik-fedora-magazine/us/331?kanban-status=196
15:31:59 <glb> It looks like it could use some work on the styling.
15:32:24 <glb> The author used several inline code blocks.
15:32:40 <glb> But those should be easy enough to change to preformatted sections.
15:33:08 <glb> I don't see any serious problems with it, so I think we can move it over to "to edit".
15:33:40 <rlengland> Styling I could handle. I wasn't certain I could walk through the steps adequately
15:34:40 <glb> I doubt my container foo is much better than yours.
15:35:00 <glb> Do you want to try editing this one? I'm fine with doing it if you don't want to.
15:35:54 <rlengland> I'll give it a shot.  If there a tech issues I'm sure someone will call it out.  I just hate to miss something obvious because I didn't catch it
15:36:07 <rlengland> *are
15:36:53 <glb> Well, I think docker is sort of being deprecated in favor of podman.
15:37:35 <rlengland> That's the kind of insight I lack.
15:37:49 <rlengland> Same for the chroot article which I'm glad you chipped in on.
15:38:35 <glb> I guess my point is that even if the docker stuff isn't exactly right, it may not matter too much since people will be rapidly adopting podman anyway.
15:38:52 <rlengland> understood
15:39:14 <glb> OK well, moving along...
15:40:24 <glb> #topic 4/ Articles to edit
15:40:25 <glb> #info Looking at the 'to edit' column, assign an editor and a cover image creator.
15:40:25 <glb> #link Board: https://teams.fedoraproject.org/project/asamalik-fedora-magazine/kanban
15:41:20 <glb> So it looks like you have both of the articles currently in "to edit".
15:41:34 <rlengland> #342 was amended so I think it can be scheduled
15:41:39 <glb> I will edit the Yubikey article when it is ready (expected soon).
15:41:55 <rlengland> I'll work through#331
15:42:27 <glb> So do you think you can have #342 ready for tomorrow?
15:42:34 <rlengland> Yes
15:43:02 <glb> OK.
15:43:41 <glb> Since the Yubikey article isn't yet ready, I guess I'll have to put #331 in the next time slot on Monday.
15:43:45 <glb> Does that sound OK?
15:44:11 <rlengland> certainly
15:44:38 <glb> Let me know if you think I'm giving you too much.
15:44:51 <rlengland> I'm okay so far
15:45:43 <glb> Note that #331 has a custom image made by the author referenced in the comments.
15:45:55 <glb> I had a look at it and it looks OK to me.
15:46:15 <rlengland> good to know. thanks
15:47:55 <glb> OK. I think I have the data updated on the cards. I just need to run a script to get the printout.
15:48:24 <glb> #proposed PUBLISHING SCHEDULE: Fri 09 Jul 2021: #342 OS chroot (beginner level) (image: DONE, edit: @rlengland) -- Sat 10 Jul 2021: #346 Fedora Test Day Annoucments (image: DONE, edit: DONE) -- Mon 12 Jul 2021: #331 Use Docker Compose with Podman to Orchestrate Containers on Fedora (image: Mehdi Haghgoo, edit: rlengland)
15:49:19 <glb> Just a sec. I'll put the Yubikey article down for Wednesday ...
15:50:03 <glb> #proposed PUBLISHING SCHEDULE: Fri 09 Jul 2021: #342 OS chroot (beginner level) (image: DONE, edit: @rlengland) -- Sat 10 Jul 2021: #346 Fedora Test Day Annoucments (image: DONE, edit: DONE) -- Mon 12 Jul 2021: #331 Use Docker Compose with Podman to Orchestrate Containers on Fedora (image: Mehdi Haghgoo, edit: rlengland) -- Wed 14 Jul 2021: #330
15:50:03 <glb> How to use YubiKey with Fedora 34 (image: glb, edit: glb)
15:50:15 <glb> Does it look good to you rlengland?
15:50:23 <rlengland> +1
15:50:45 <glb> Actually, the test day article already went out.
15:50:52 <glb> I should probably correct that ...
15:51:33 <glb> #agreed PUBLISHING SCHEDULE: Fri 09 Jul 2021: #342 OS chroot (beginner level) (image: DONE, edit: @rlengland) -- Mon 12 Jul 2021: #331 Use Docker Compose with Podman to Orchestrate Containers on Fedora (image: Mehdi Haghgoo, edit: rlengland) -- Wed 14 Jul 2021: #330 How to use YubiKey with Fedora 34 (image: glb, edit: glb)
15:52:06 <rlengland> that got it
15:52:07 <rlengland> +1
15:52:13 <glb> Ack. That was supposed to be in the next section.
15:52:16 <glb> #topic 5/ Publishing schedule
15:52:16 <glb> #info Looking at the 'queued' and 'to edit' columns, decide the publishing schedule for the next week period.
15:52:17 <glb> #info If there is not enough content, we might also need to look at the 'in progress' or even the 'article spec' columns come up with additional content.
15:52:17 <glb> #link Board: https://teams.fedoraproject.org/project/asamalik-fedora-magazine/kanban
15:52:27 <glb> #agreed PUBLISHING SCHEDULE: Fri 09 Jul 2021: #342 OS chroot (beginner level) (image: DONE, edit: @rlengland) -- Mon 12 Jul 2021: #331 Use Docker Compose with Podman to Orchestrate Containers on Fedora (image: Mehdi Haghgoo, edit: rlengland) -- Wed 14 Jul 2021: #330 How to use YubiKey with Fedora 34 (image: glb, edit: glb)
15:52:38 <rlengland> one more time, fire for effect
15:52:38 <rlengland> +1
15:52:41 <glb> #topic 6/ Editor of the Week
15:53:07 <glb> So you are +1 to being editor of the week?
15:53:33 <rlengland> I'll keep watching during the week if you'll run the meeting. That work?
15:53:56 <glb> Just thought I'd try to rope you in. :-),
15:54:06 <rlengland> I'm authority adverse
15:54:11 <glb> #info glb will be Editor of the Week next week
15:54:22 <glb> #topic 7/ Open floor
15:54:51 <glb> Looks like I didn't leave much time for the series discussion.
15:55:29 <rlengland> #349 and #350 came from proposals for series.  I've tried to put them up to providing new proposal for each article.  Is that the best way to work that?
15:55:31 <glb> I don't think any of them will need to be published in the coming week anyway.
15:55:43 <glb> Probably.
15:55:52 <glb> I've used tasks before.
15:56:08 <glb> But mainly that was because the articles needed to go out in sequence.
15:56:39 <rlengland> I'm confused about the tasks. Is that doced anywhere?
15:56:41 <glb> The first one was just a "how to install" and that wasn't really useful on its own.
15:56:51 <rlengland> True
15:57:18 <glb> No. It isn't documented. I just did it that way to confuse people. :-)
15:57:28 <rlengland> I'm wondering if we need to 'codify' the process for a series by documenting it in the writer info
15:57:39 <rlengland> Confusion accomplished :-)
15:57:45 <glb> I think that would be a good thing to do.
15:58:08 <glb> Would you like to give updating the documentation a try?
15:58:22 <glb> I think I can approve pull requests if you want to try to create some.
15:58:44 <rlengland> How do we go about that? I assume this is in git somewhere?
15:59:02 <glb> Also, just FYI, since we are down to just the two of us, now is probably a good time to revise anything if you want to.
15:59:29 <rlengland> :-) true approval is easier
15:59:29 <glb> Yes. It is a git repo much like the fedora magazine images.
15:59:52 <rlengland> Can you email me the location?
16:00:02 <glb> Since we are out of time. Do you want to continue this discussion on #fedora-magazine?
16:00:12 <rlengland> sure see you there
16:00:12 <glb> Sure, I can email it to you.
16:00:17 <glb> Thanks.
16:00:21 <glb> #endmeeting