14:02:34 <andreasn> #startmeeting meeting
14:02:34 <zodbot> Meeting started Mon Jan 11 14:02:34 2016 UTC.  The chair is andreasn. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:34 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:02:34 <zodbot> The meeting name has been set to 'meeting'
14:02:38 <mvollmer> .hi mvo
14:02:41 <andreasn> .hi andreasn
14:02:58 <dperpeet> .hello dperpeet
14:02:59 <zodbot> dperpeet: dperpeet 'None' <dperpeet@redhat.com>
14:03:11 <andreasn> .hello andreasn
14:03:12 <zodbot> andreasn: andreasn 'Andreas Nilsson' <anilsson@redhat.com>
14:03:18 <andreasn> that's what the command is
14:03:27 <dperpeet> .hello mvo stefw petervo
14:03:28 <zodbot> dperpeet: Sorry, but you don't exist
14:03:32 <stefw> .hello stefw
14:03:34 <zodbot> stefw: stefw 'Stef Walter' <stefw@redhat.com>
14:03:36 <andreasn> .hello mvo
14:03:40 <zodbot> andreasn: mvo 'Marius Vollmer' <marius.vollmer@gmail.com>
14:03:43 <stefw> in other news ... dperpeet doesn't exist
14:03:45 <andreasn> .hello petervo
14:03:46 <zodbot> andreasn: petervo 'Peter Volpe' <petervo@redhat.com>
14:04:05 <andreasn> #topic Agenda
14:04:07 <dperpeet> that was pretty harsh
14:04:11 <stefw> heh
14:04:15 <stefw> tell zodbot to naked ping itself
14:04:23 <mvollmer> ts ts ts
14:04:40 <stefw> * cockpit-devel mailing list hosting
14:04:54 <mvollmer> * rhel atomic
14:05:03 <mvollmer> * weekly image updates
14:06:05 <andreasn> anything else?
14:06:22 <andreasn> #topic #cockpit-devel mailing list hosting
14:06:38 <andreasn> #topic cockpit-devel mailing list hosting
14:06:54 <stefw> Fedora changed their mailing list setup significantly over the new year
14:07:11 <stefw> It requires Fedora accounts, or Mozilla Persona to log in
14:07:17 <stefw> and the archives are really hard to use
14:07:18 <andreasn> right now we're hosted here https://lists.fedorahosted.org/archives/list/cockpit-devel%40lists.fedorahosted.org/
14:07:41 <andreasn> any gmail account works, right?
14:07:44 <stefw> These changes may make sense for Fedora, but seem to have dropped the value as a generic hosting of mailing lists
14:07:56 <stefw> in theory one can make any email account "work"
14:08:30 <stefw> i also have no idea where admin access has gone
14:08:41 <andreasn> I have a private document with a design review I made. It ended up being quite a lot of issues
14:08:43 <stefw> i'm wondering if we should consider moving the mailing list to something else
14:08:43 <mvollmer> i am still owner
14:08:49 <stefw> mvollmer, ah ok good
14:09:01 <stefw> i have no idea where we would move to ... but figured i'd bring it up
14:09:01 <mvollmer> I can add everyone as owner, I think
14:09:07 <andreasn> wrong hirearchy, wrong gestalt usage and generally too much noise
14:09:11 <mvollmer> there is no separate moderator password anymore
14:09:16 <andreasn> lots of inconsistency etc
14:09:35 <dperpeet> do we have good options for where we could move?
14:10:00 <mvollmer> so what is broken?
14:10:10 <mvollmer> does it just look ugly?
14:10:20 <mvollmer> or are the archives now non-public?
14:10:32 <andreasn> no, not only ugly, it works wrong
14:10:44 <andreasn> the hirearchy is broken and stuff
14:10:44 <stefw> the archives are public
14:10:52 <mvollmer> are we frocing people now to make fedora or persona accounts?
14:10:57 <stefw> right, that one
14:11:01 <stefw> maybe this is all worth it
14:11:18 <stefw> but it's hard to even get started when it's so unusable
14:11:29 <dperpeet> I think if it's just a matter of creating an account, it's not worth moving
14:11:43 <stefw> maybe we can offer to subscribe people who don't want to make an account?
14:11:52 <stefw> like they tell us on irc, and we add them?
14:12:01 <stefw> mvollmer, do you have the option to do that in the admin interface?
14:12:25 <mvollmer> let's see
14:12:46 <jscotka> dperpeet, as you mentioned troubles with chrome, and size of windows, it seems that is also happen in my latest commit: https://fedorapeople.org/groups/cockpit/logs/pull-3435-e2bc9b96-fedora-23/log.html#63
14:13:20 <dperpeet> jscotka, let's talk about this after the meeting
14:13:55 <mvollmer> I'll make y'all owners first
14:14:37 <stefw> ok
14:14:49 <andreasn> ok, so it sounds like no move for now
14:14:49 <stefw> well i guess we can adopt a wait and see stance
14:14:53 <mvollmer> stefw, swalters@redhat.com?
14:14:56 <stefw> andreasn is going to help them with design?
14:14:59 <andreasn> I can start filing design bugs
14:15:02 <stefw> mvollmer, stefw@fedoraproject.org
14:15:14 <andreasn> and see if they get any traction
14:15:39 <stefw> alright, sounds good
14:15:46 <mvollmer> andreasn, what's your email for the list ownership?
14:15:51 <mvollmer> dperpeet, dperpeet@redhat.com?
14:15:54 <andreasn> lists@andreasn.se
14:16:22 <dperpeet> mvollmer, correct
14:16:34 <mvollmer> petervo@redhat.com?
14:16:48 <petervo> yep
14:17:33 <andreasn> #action andreasn to file design bugs against hyperkitty
14:18:03 <andreasn> next topic?
14:19:00 <andreasn> #topic RHEL Atomic
14:19:24 <mvollmer> okay, I have started with rhel-atomic
14:19:30 <mvollmer> https://github.com/cockpit-project/cockpit/pull/3445
14:19:50 <mvollmer> there is trouble with the versions of rpm-ostree, and I need some help there
14:19:55 <stefw> really good stuff, by the way
14:20:05 <stefw> adding that to our list of tested operating systems
14:20:10 <mvollmer> yeah
14:20:39 <mvollmer> petervo, do you have time to help?
14:20:59 <petervo> mvollmer, i can try, really we need a new build
14:21:02 <mvollmer> it's probably easy for you, and hard for me
14:21:16 <mvollmer> what does that mean?
14:21:19 <petervo> but we can probably provide our own while we wait
14:21:26 <mvollmer> is rpm-ostree too old in rhel aotmic?
14:21:34 <petervo> yes
14:21:39 <mvollmer> alright
14:21:48 <mvollmer> let's discuss in the PR, wdyt?
14:21:54 <petervo> ok
14:22:25 <mvollmer> so, this was mostly an announcement that I worked on that :)
14:22:33 <andreasn> next up?
14:22:40 <mvollmer> second
14:22:59 <mvollmer> the motivation is to get sosreport properly going on rhel atomic
14:23:13 <mvollmer> so I'll do that also
14:23:17 <andreasn> neat
14:23:43 <mvollmer> first I hoped that it is trivial since Fedora Atomic has sosreport, but RHEL Atomic doesn't
14:23:53 <mvollmer> to save 50 KiB or so, probably :-)
14:24:19 <mvollmer> done
14:24:47 <andreasn> #topic weekly image updates
14:25:03 <mvollmer> also just an announcement that I want to work on that next
14:25:09 <mvollmer> nothing done so far
14:25:19 <mvollmer> but I think it is important
14:25:31 <dperpeet> as an automatic build that opens a pull request?
14:25:43 <dperpeet> I believe that's how we envisioned it
14:25:50 <mvollmer> yes, exactly
14:25:55 <dperpeet> or even automatic merge if everything passes :)
14:26:06 <dperpeet> for now I think the pull request would be nice
14:26:19 <dperpeet> cockpituous can become a major contributor, finally
14:26:30 <stefw> mvollmer, github-scan would be the place to add such a task ... because this is based on whether such a pull  request exists in github
14:26:50 <mvollmer> okay, makes sense
14:27:10 <mvollmer> so the verify container would create (and test) these PRs
14:27:26 <stefw> that's how imagined it
14:27:33 <stefw> but you may find a problem with that
14:27:39 <stefw> or choose to do it differently ... obviously
14:27:54 <stefw> mvollmer, there's so me work here
14:27:54 <stefw> https://github.com/cockpit-project/cockpit/pull/3380
14:28:01 <stefw> which puts the publishing logic into github-task
14:28:10 <stefw> the first commit
14:28:14 <mvollmer> okay
14:28:14 <stefw> you may want to include that in your work
14:28:41 <mvollmer> I'll check it out
14:30:21 <andreasn> ok, open floor next then
14:30:25 <andreasn> #topic Open Floor
14:30:44 <stefw> i think that the recent check-networking fixes have broken the networking tests
14:30:52 <stefw> well they have races
14:30:56 <stefw> just FYI
14:31:03 <mvollmer> damn
14:31:05 <stefw> so if anyone runs into that
14:31:07 <stefw> on fedora-atomic
14:31:17 <stefw> it's probably good that we work together to fix it or at least file a bug and start tracking the issue
14:31:21 <stefw> i haven't had a chance to do this yet
14:34:23 <mvollmer> are we done?
14:34:33 <mvollmer> that was short
14:34:34 <andreasn> I think so
14:35:04 <andreasn> #endmeeting