15:04:43 <asamalik> #startmeeting modularity
15:04:43 <zodbot> Meeting started Tue Apr 16 15:04:43 2019 UTC.
15:04:43 <zodbot> This meeting is logged and archived in a public location.
15:04:43 <zodbot> The chair is asamalik. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:04:43 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:04:43 <zodbot> The meeting name has been set to 'modularity'
15:04:43 <asamalik> #meetingtopic Weekly Meeting of the Modularity Team
15:04:43 <asamalik> #topic Roll Call
15:04:43 <asamalik> #chair sgallagh langdon contyk ignatenkobrain
15:04:43 <zodbot> Current chairs: asamalik contyk ignatenkobrain langdon sgallagh
15:05:04 <asamalik> .hello2
15:05:05 <zodbot> asamalik: asamalik 'Adam Samalik' <asamalik@redhat.com>
15:05:15 <langdon> .hello2
15:05:16 <zodbot> langdon: langdon 'Langdon White' <langdon@redhat.com>
15:05:31 <asamalik> we have nothing on the agenda and I know that multiple people are out today
15:05:37 <asamalik> so it might be quite fast :)
15:06:06 <langdon> don't jinx it!
15:07:01 <sct> .hello sct
15:07:02 <zodbot> sct: sct 'Stephen Tweedie' <sct@redhat.com>
15:08:26 * asamalik waves at sct (and his cat)
15:08:34 <asamalik> #topic Agenda
15:08:34 <ignatenkobrain> .hello2
15:08:35 <zodbot> ignatenkobrain: ignatenkobrain 'Igor Gnatenko' <i.gnatenko.brain@gmail.com>
15:08:50 <asamalik> nothing on the agenda, anything people want to talk about?
15:09:23 <ignatenkobrain> basically as I said on #fedora-modularity -- who is taking care of MBS and what could be ETA to support buildafter thing?
15:10:37 <langdon> factory 2 team.. did u file an rfe on fm-orchestrator?
15:11:39 <asamalik> ignatenkobrain: https://tree.taiga.io/project/modularity-wg/epic/33
15:12:00 <asamalik> looks like contyk drives that, and sgallagh already did some work for it
15:12:37 <asamalik> but I have nothing more for you unfortunately :(
15:12:58 <langdon> and both are afk
15:13:09 <ignatenkobrain> langdon: it seems I did not... I have opened it right away https://pagure.io/fm-orchestrator/issue/1216
15:14:02 <langdon> well.. is it dependent on the modulemd ticket asamalik referenced?
15:14:14 <langdon> or do you want just that part?
15:15:06 <ignatenkobrain> langdon: modulemd is done like 2 months ago
15:15:27 <ignatenkobrain> https://github.com/fedora-modularity/libmodulemd/commit/f88d327fd712a064b42f9b35e3b610354555b928
15:15:32 <ignatenkobrain> well, 1 month and 2 days
15:15:59 <langdon> the other ticket seems to imply it needs more work
15:17:54 <ignatenkobrain> Only MBS part is missing
15:18:01 <ignatenkobrain> and MBS is still not even ported to libmodulemd v2
15:18:20 <ignatenkobrain> so it seems to me that nobody is even planning to work on it
15:18:47 <asamalik> ignatenkobrain: maybe you could help :P
15:19:06 <ignatenkobrain> asamalik: I'm pretty busy with my $dayjob...
15:19:18 <langdon> hmm.. I can ask around.. I thought libmodulemd v2 was in progress
15:19:20 <asamalik> but anyway, let's see what happens in the ticket?
15:19:20 <ignatenkobrain> and also running fedpkg module-build is very time consuming nowadays
15:19:25 <ignatenkobrain> I have to run it like 30+ times
15:19:39 <ignatenkobrain> langdon: would appreciate, thanks
15:19:41 <langdon> because?
15:21:18 <ignatenkobrain> langdon: s390x fails 10 times out of 12
15:21:24 <ignatenkobrain> https://pagure.io/fedora-infrastructure/issue/7712
15:21:55 <langdon> Ahh I see
15:23:10 <ignatenkobrain> langdon: so if that will be solved + buildafter, my modules will be built within 1-2 hours instead of 2-3 days as it is now :)
15:24:17 <langdon> right
15:27:02 <asamalik> ignatenkobrain: that feels like many small pieces that probably don't look that significant separately, but when you put it like that, it would make sense to track this as a whole and get it done
15:27:16 <asamalik> because 1-2 hours vs. 2-3 days seems crazy
15:27:49 <x3mboy> Hi!
15:27:57 <x3mboy> Just checking in and reading
15:27:59 <ignatenkobrain> asamalik: well, it is just 2 different pieces.... If I would not have to resubmit failed builds, it would be like 5-7 hours
15:28:05 <ignatenkobrain> and when buildafter gets implemented, that will be down to 1-2 hours
15:28:12 <x3mboy> I'm coming back from a long resting period
15:28:19 <ignatenkobrain> probably even faster (depending how fast koji will generate repo)
15:28:41 <asamalik> or maybe I should say that with those numbers it demonstrates it has this big impact
15:28:52 <asamalik> x3mboy: welcome back!
15:29:09 <x3mboy> asamalik: Hi!
15:29:11 <x3mboy> Thanks
15:29:42 <langdon> ignatenkobrain: maybe give your example, with link to the infra ticket in the comments on your new ticket? to show the impact and that it isn't just "would be nice"?
15:29:49 <langdon> x3mboy: hi!
15:30:19 <ignatenkobrain> langdon: ack, I'll add comment there
15:30:48 <x3mboy> langdon: o/
15:31:11 <asamalik> cool!
15:31:34 <asamalik> yeah it didn't feel like that important to me before seeing the numbers
15:31:42 <asamalik> it's always good to have data
15:31:51 <asamalik> ok, anything else to talk about today?
15:33:53 <langdon> nothing from me
15:34:32 <asamalik> ah, there is one
15:34:34 <asamalik> #topic Next meeting's chair
15:35:01 * asamalik looks at langdon, definitely for no reason
15:35:11 <langdon> asamalik: :P i can do the next one
15:35:39 * langdon adds reminder
15:36:09 <asamalik> langdon: haha thanks!
15:36:32 * langdon goes back to reviewing devconf abstracts
15:36:36 <asamalik> #action langdon will chair the next meeting
15:36:44 <asamalik> ok thanks everyone!
15:37:13 <asamalik> #endmeeting