15:01:16 <asamalik> #startmeeting modularity
15:01:16 <zodbot> Meeting started Tue Jun 18 15:01:16 2019 UTC.
15:01:16 <zodbot> This meeting is logged and archived in a public location.
15:01:16 <zodbot> The chair is asamalik. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:16 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:01:16 <zodbot> The meeting name has been set to 'modularity'
15:01:16 <asamalik> #meetingtopic Weekly Meeting of the Modularity Team
15:01:16 <asamalik> #topic Roll Call
15:01:16 <asamalik> #chair sgallagh langdon contyk ignatenkobrain
15:01:16 <asamalik> .hello2
15:01:16 <zodbot> Current chairs: asamalik contyk ignatenkobrain langdon sgallagh
15:01:17 <zodbot> asamalik: asamalik 'Adam Samalik' <asamalik@redhat.com>
15:01:26 <contyk> .hello psabata
15:01:27 <zodbot> contyk: psabata 'Petr Šabata' <psabata@redhat.com>
15:01:46 <asamalik> we haven't done this for a bit :)
15:01:59 <contyk> feels like yesterday
15:02:03 <asamalik> it does!
15:02:05 <asamalik> sort of
15:02:29 * contyk blames the old age
15:02:31 <contyk> and coffee
15:03:03 <contyk> so I've noticed we have a couple of tickets open that need some attention
15:03:19 <asamalik> let's have a look!
15:04:03 <langdon> .hello2
15:04:04 <zodbot> langdon: langdon 'Langdon White' <langdon@redhat.com>
15:04:07 <asamalik> there is nothing marked with the meeting tag, but we probably want to just go through all the new ones?
15:04:19 <contyk> we're not really prepared today but I think we should definitely review the queue and see what needs to be discussed in real time next week
15:04:24 <contyk> I'll try to do that today
15:04:38 <contyk> but the more people do it the better :)
15:04:59 <asamalik> fair
15:06:27 <langdon> so where do you want to start?
15:06:44 <contyk> I probably wouldn't go through the list today
15:06:47 <asamalik> contyk: do you think it's worth going through one by one here? or do we wanna read through them and review next time?
15:06:55 <asamalik> which will definitely happen, right? :)
15:07:00 <contyk> just if we can all promise to review it on our own, comment where we can add something
15:07:12 <contyk> and tag some with the meeting label if we think we need to discuss it here
15:07:40 <ignatenkobrain> .hello2
15:07:41 <zodbot> ignatenkobrain: ignatenkobrain 'Igor Gnatenko' <i.gnatenko.brain@gmail.com>
15:07:51 <asamalik> contyk: ok
15:07:55 <contyk> but langdon is re-defining the modularity objective
15:08:04 * langdon needs to finish that
15:08:06 <asamalik> ah! do we wanna talk about that?
15:08:07 <contyk> that should be mentioned here
15:08:12 <langdon> contyk: did you have any ideas for the "deliverables"
15:09:45 <contyk> hmm
15:09:50 <contyk> well, ursa prime is technical
15:10:02 <contyk> it also touches epel8 but that's probably not our goal per se
15:10:07 <contyk> unsure what flatpaks means
15:10:21 <contyk> dnf has issues, of course
15:10:22 <langdon> modules->flatpaks
15:10:40 <contyk> not much of a fan of "automatic modulemd creation", we seem to be focusing on that the whole time and nobody seems to need it
15:11:12 <contyk> but re:hackfests, I'll be submitting a packager experience/modularity bof for flock
15:11:22 <asamalik> we might need some higher-level architecture guidelines for modules
15:11:23 <contyk> I hope you lot will be there
15:11:36 <asamalik> like how to use dependencies, when to bundle stuff in a module, etc
15:11:39 <contyk> that's a good point
15:11:51 <contyk> documentation that explains not just what and how but most importantly why
15:12:00 <asamalik> definitely
15:12:29 <contyk> and I still view the lack of easy content discovery methods as a major problem for change owners and the security team
15:13:17 <asamalik> contyk: yeah the content discovery is probably two parts... repoquery which I've written the prototype for, and buildroot only content in repos so we can query those
15:13:18 <asamalik> then we're good
15:13:38 <langdon> you don't mean like a "website" for discovery?
15:14:12 <contyk> no, I mean more like "I'm rebasing python in base and need to find out what needs to be rebuilt"
15:14:37 <contyk> or "everything built against this nvr is affected by this cve, I need to find out what that is and rebuild it"
15:14:54 <contyk> people know how to do this with non-modular stuff, it's easy; with modules, not so much
15:15:03 <langdon> ahh.. completely different kind of "discovery" :)
15:15:08 <contyk> not everything is in the repo and even when it is, it requires special knowledge
15:16:22 * langdon working on sharing my draft
15:16:27 <asamalik> contyk: when we talked about ursa major back at devconf.. we mentioned accessible repos for the buildroot content.. that's still a plan, right?
15:16:46 <asamalik> sorry for my ignorance, more and more things are piling up lately :)
15:17:08 <contyk> I'm not sure that would be sufficient but it depends on what they would include
15:17:24 <contyk> but if it's something akin CRB, it could work, yeah
15:17:40 <langdon> ok.. here is the draft: https://docs.google.com/document/d/1dbGI4TWCatjJClt9CAF4-UiB3ytFMHxACMn5BGgxfHg/edit?usp=sharing
15:17:59 <asamalik> well basically if we can have the everything+modular repos and "the rest" repos that would also enable local builds against buildroot-only modules, we're good
15:18:27 <asamalik> having everything as repos gives us consistent interface... but anyway, I'm rabbitholing here a bit
15:18:37 <langdon> we also need timelines
15:18:46 <langdon> do we have any eta for ursa prime?
15:18:58 <langdon> anything we could show at flock?
15:19:02 <contyk> it's not just buildroot only modules, i.e. modules available to MBS only
15:19:15 * langdon just realizes he missed the cfp deadline
15:19:15 <contyk> but also about packages filtered from modules that we actually ship
15:19:18 * langdon thinks
15:19:34 <contyk> flock cfp? really? me too then
15:19:43 <langdon> i think it was the 15th
15:19:51 <contyk> eta for ursa prime is sometime before f31 mass rebuild
15:20:07 <contyk> the mbs work is underway now
15:20:09 <langdon> ohh.. there is one more round by july 1
15:20:26 <asamalik> there are two or three rounds
15:20:33 <langdon> 3
15:20:36 <asamalik> yes, the second should be july 1
15:20:47 <langdon> thats 3rd actually
15:21:21 <langdon> alright.. is "buildroot" one word or two? my fingers can never decide
15:21:53 <asamalik> one
15:22:10 <langdon> ursa prime is gonna do package filtering as well? or is thta a different system?
15:23:10 <contyk> yes, the packages are always filtered
15:23:25 <contyk> they're only available to your own module while you're building it
15:25:32 <langdon> contyk: yeah.. i get that.. what i was asking was "are you saying above that the package filtering will be done by ursa prime?"
15:25:56 <contyk> no, it won't
15:27:00 <langdon> ok.. so that still needs to be done, right?
15:27:18 <contyk> I'm a little confused by this question because those are fairly unrelated topics, imho :)
15:27:30 <contyk> ursa prime is a concept of putting modules in the non-modular buildroot
15:27:40 <langdon> ha.. i thought you were tying them together.. thats why i was confused too!!
15:27:41 <contyk> it doesn't do anything to anything because it's not an actual thing
15:28:35 <langdon> ok.. well.. i wrote two deliverables for f31.. one is ursa prime and one is filtering.. is thta the right timeline?
15:28:43 <langdon> we should probably check with infra
15:28:58 <contyk> what do you mean by filtering?
15:29:39 <langdon> what i have in the doc.. and what I thought you were saying here "[11:19] <contyk> but also about packages filtered from modules that we actually ship"
15:29:47 <langdon> "Filtering out packages that are not identified in the module’s modulemd"
15:30:15 <contyk> so asamalik was talking about having an additional compose with content that is not shipped anywhere so that people can query those RPMs
15:30:41 <contyk> he was talking about "buildroot only modules"; I was just adding that we also care about packages that are normally filtered out
15:30:49 <contyk> even though they are part of modules that we ship
15:31:10 <langdon> ohhhhh.... i was very confused.. i thought we were still talking about ursa prime
15:31:26 <langdon> which surprised me.. but meh
15:31:56 <langdon> ok.. so ... full different topic.. we need a "discovery deliverable that shows filtered out packages, buildroot modules, etc"?
15:31:56 <contyk> :)
15:31:57 <asamalik> ah, no, I was relating to content discovery
15:32:12 <contyk> yes, that's better
15:32:14 <asamalik> a compose of "things that are not in the release repos, but are used"
15:33:01 <asamalik> and I remembered that during the ursa major-related discussions, this was mentioned there in relation to local builds
15:33:17 <asamalik> and with that, we could kill two birds with one stone
15:33:58 <contyk> offline local builds could benefit from that, yes
15:34:15 <asamalik> yes
15:35:00 <asamalik> anyway, do we have something else to discuss today? do we want to continue with this?
15:35:32 <langdon> sorry.. my connection dropped.. back now
15:35:34 <langdon> asamalik: it is due tomorrow :)
15:35:47 <contyk> wasn't it the end of the week?
15:36:07 <langdon> i thought it was the council meeting... but either way "before next modularity meeting"
15:36:30 <asamalik> I thought it was before the next council meeting
15:36:34 <asamalik> so yeah, tomorrow :)
15:37:59 <contyk> well, are you editing the public doc?
15:38:06 <langdon> contyk: yes
15:38:15 <langdon> i locked the old one
15:38:36 <langdon> i may leave it in there until some other people have looked at it then move it to the wiki
15:39:00 * sgallagh shows up late
15:39:34 <sgallagh> asamalik: I have an item to discuss, actually
15:39:44 <langdon> we have an anonymous panda and a python!
15:39:48 <asamalik> sgallagh: please tell me more!
15:40:16 <asamalik> langdon: so contyk and I? :)
15:40:18 <sgallagh> At yesterday's Fedora QA meeting, it was suggested that the Modularity WG should take over responsibility for approving changes to the Module Defaults
15:40:24 <langdon> no.. contyk is contyk
15:40:26 <contyk> I'm logged in
15:41:01 <langdon> ohh.. now im not sure.. no "viewing icon" for contyk.. but his comments are labeled
15:41:15 <asamalik> sgallagh: I think that sounds fair
15:41:16 <langdon> now we have a lemur and a rabbit!
15:41:18 <contyk> sgallagh: that doesn't make much sense to me
15:41:22 <sgallagh> contyk: Why?
15:41:28 <langdon> sgallagh: shouldn't that be fesco?
15:41:47 <sgallagh> The idea is that the Modularity WG would have more subject matter expertise on what is and isn't sensible to be in a default stream/profile
15:41:48 * langdon actually thought it was fesco
15:41:53 <sgallagh> Well, stream at least.
15:42:02 <contyk> because I see this group as a short-lived* team of people driving the tech, not a comittee responsible for Fedora content forever
15:42:07 * langdon notes we are *team* now! ;)
15:42:31 <contyk> it also means that modules are special and need a special group to make decisions
15:42:37 <langdon> contyk: the debate on that has always been.. does modularity team morph in to an fpc
15:42:44 <langdon> ??
15:43:05 <contyk> I think defaults are a fesco matter
15:43:17 <contyk> module packaging could be an fpc matter
15:43:41 <sgallagh> OK, but I think at minimum we need to work on drafting a questionnaire/guidelines on when a stream should be a default and when not.
15:43:44 <contyk> with this group making suggestions while it exists
15:43:55 <contyk> oh yes, that I agree with
15:44:02 <sgallagh> Because FESCo as it stands does not have that expertise.
15:44:12 * langdon rubs hands together and declares "Deliverable!"
15:45:40 <asamalik> ok, yes... us providing guidelines/examples/boundaries and then fesco owning that decision within that bounaries makes sense
15:45:55 <sgallagh> Probably defining a proper process (similar to the one for enabling default services in Fedora)
15:46:25 * sgallagh takes a cautious step away from langdon
15:46:36 <langdon> hahahahahah
15:46:40 <langdon> how do you like "Document / questionnaire regarding how and when streams should be declared default and when they shouldn’t. Should also include how and when they can be changed. Definition of the formal process for default declaration including RACI."
15:46:59 <asamalik> I kind of like switching defaults to be treated similarly to introducing new major versions of software into a new fedora release
15:47:08 <contyk> I absolutely hate it
15:47:11 <asamalik> just with the simplification that it's just a switch technically
15:47:13 <contyk> (kidding)
15:47:34 <asamalik> and that newer/older/different streams can exist at the same time
15:47:36 * langdon cries
15:47:38 <sgallagh> langdon: worksforme
15:47:55 <sgallagh> asamalik: It's not just a switch, but that's another complicated topic.
15:48:50 <asamalik> sgallagh: agree that not overall... I meant that replacing sources in dist-git for a new version and building them is now a switch... dependencies, rebuilds, and all the other fun remains
15:50:20 <langdon> i think a bunch of us will be at flock.. if everyone hasn't booked travel yet, should we propose a hackfest to at least outline this documentation (all the ones mentioned, not just sgallagh's) and flesh out any of the deliverables for the objective?
15:50:42 <sgallagh> +1
15:50:42 <langdon> i.e. a few days before flock...
15:50:44 <contyk> at flock? sure
15:50:47 <sgallagh> Is the CFP still open?
15:50:57 <langdon> 3rd round lcoses on the 1st
15:51:00 <contyk> I'd say it's two months away but we wouldn't get to it sooner anyway
15:51:00 <langdon> *closes
15:51:25 <langdon> well.. i can submit the objective with wishy-washy deliverables and tell them the first hackfest will iron them out..
15:51:27 <sgallagh> Modularity Documentation Hackfest sounds like it might be popular.
15:51:31 <langdon> maybe present them at flock
15:52:04 <langdon> do we want to do "time before flock" or just "at flock"?
15:52:17 <langdon> i definitely can't spare after flock cause of devconf.us
15:56:23 <asamalik> ok, anything else for today?
15:56:39 <contyk> do some #infos?
15:56:44 <contyk> and I'll chair the next one
15:56:45 <asamalik> it was a bit more organic than usually, but I think that's sometimes necessary
15:56:56 <asamalik> #action contyk to chair the next meeting
15:56:57 <langdon> tap tap.. is this thing on?
15:56:59 <asamalik> contyk++
15:57:00 <langdon> do we have a decision on the hackfest idea?
15:57:02 <langdon> i should probably propose it tomororow
15:57:10 <asamalik> langdon: wanna info anything about the objective update?
15:57:19 <langdon> sure
15:57:32 <contyk> or I can do some infos, if you like
15:57:44 <langdon> are you guys seeing this?
15:57:47 <contyk> yes
15:58:01 <langdon> ok.. still don't feel like i know the answer on the hackfest
15:58:16 <contyk> langdon: just at flock
15:58:27 <asamalik> ah, right, yeah at flock
15:58:38 <langdon> so... skip talks or whatever?
15:58:59 <langdon> #info draft of the next modularity objective can be found here: https://docs.google.com/document/d/1dbGI4TWCatjJClt9CAF4-UiB3ytFMHxACMn5BGgxfHg/edit?usp=sharing
15:59:10 <langdon> #info will move the draft to the wiki soon
15:59:17 <asamalik> I thought that working together is the point of the conference :P
15:59:32 <langdon> ha.. i suppose
15:59:45 <contyk> #action Everyone will review the ticket queue before the next meeting
15:59:46 <contyk> :P
15:59:56 <asamalik> contyk++
16:00:03 <asamalik> everyone++
16:00:03 <langdon> i think we all get pulled in different directions at flock.. focusing on modularity may be difficult
16:00:09 <langdon> asamalik++
16:00:14 <langdon> sgallagh++
16:00:14 <zodbot> langdon: Karma for sgallagh changed to 10 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
16:00:20 <langdon> contyk++
16:00:29 <asamalik> asamalik++
16:00:29 <zodbot> asamalik: You may not modify your own karma.
16:00:33 <asamalik> :/
16:00:40 <langdon> ha
16:00:44 <sgallagh> asamalik++
16:00:50 <asamalik> sgallagh++
16:00:50 <zodbot> asamalik: Karma for sgallagh changed to 11 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
16:00:53 <asamalik> langdon++
16:01:04 <asamalik> ok, cookies distributed
16:01:06 <asamalik> infos done
16:01:06 <langdon> contyk+++++ (for chairing ;) )
16:01:20 <asamalik> any last words before we close this?
16:01:42 <asamalik> 3
16:01:44 <contyk> well
16:01:49 <asamalik> 2
16:02:01 <contyk> *something about blockchain and cookie distribution*
16:02:03 <asamalik> 2.5 for contyk
16:02:11 <asamalik> .fire contyk
16:02:12 <zodbot> adamw fires contyk
16:02:17 <asamalik> 1
16:02:17 <langdon> blocks!
16:02:21 <langdon> i love blocks!
16:02:28 <asamalik> #endmeeting