15:02:28 <langdon> #startmeeting Modularity Team Meeting
15:02:28 <zodbot> Meeting started Tue Dec 10 15:02:28 2019 UTC.
15:02:28 <zodbot> This meeting is logged and archived in a public location.
15:02:28 <zodbot> The chair is langdon. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:28 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:02:28 <zodbot> The meeting name has been set to 'modularity_team_meeting'
15:02:35 <langdon> #meetingname modularity
15:02:35 <zodbot> The meeting name has been set to 'modularity'
15:02:43 <langdon> #topic Roll Call
15:02:49 <langdon> #chair contyk sgallagh
15:02:49 <zodbot> Current chairs: contyk langdon sgallagh
15:03:06 <sgallagh> .hello2
15:03:07 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
15:03:42 <langdon> .hello2
15:03:43 <zodbot> langdon: langdon 'Langdon White' <langdon@redhat.com>
15:05:29 <langdon> anyone else around? merlinm, contyk?
15:05:35 <langdon> sgallagh: is contyk afk today?
15:05:59 <sgallagh> Not as far as I know
15:06:17 <merlinm> .hello2
15:06:20 <zodbot> merlinm: merlinm 'Merlin Mathesius' <mmathesi@redhat.com>
15:06:41 <contyk> .hello psabata
15:06:42 <zodbot> contyk: psabata 'Petr Ĺ abata' <psabata@redhat.com>
15:06:57 <langdon> ok.. let's move to agenda
15:07:02 <langdon> #topic agenda setting
15:07:24 <langdon> i assume we should go through tickets.. but does anyone have anything else? or a particular burning ticket?
15:08:18 <sgallagh> langdon: Could you summarize the meeting about the alternate proposal from last week?
15:08:25 <sgallagh> For those of us who were unable to attend
15:08:52 <langdon> sgallagh: ohh shoot.. i forgot to send out the notes didn't i?
15:09:01 * sgallagh wants to know if we're scrapping this project or not :-/
15:09:06 <langdon> let's table it as a i have "actual" meeting notes
15:09:10 * contyk can find the link
15:09:13 <langdon> i think it ended better than that
15:09:19 <langdon> i have it
15:09:31 <langdon> https://meetbot.fedoraproject.org/fedora-meeting-3/2019-12-05/modularity.2019-12-05-15.01.html
15:09:45 <langdon> ill info it in a sec
15:09:46 <contyk> sgallagh: I think we agreed to continue with what we have
15:09:57 <contyk> improving gradually
15:10:12 <langdon> i would propose we do #168 and the #169 and then see if we can get ot anything else
15:10:16 <langdon> so...
15:10:17 <sgallagh> ok
15:11:11 <langdon> #topic Review of RFC Modularity Simplified meeting
15:11:24 <langdon> #action langdon to send out the minutes
15:11:27 <sgallagh> #link https://meetbot.fedoraproject.org/fedora-meeting-3/2019-12-05/modularity.2019-12-05-15.01.html provides a summary
15:11:36 <langdon> #link https://meetbot.fedoraproject.org/fedora-meeting-3/2019-12-05/modularity.2019-12-05-15.01.html link to the minutes
15:11:40 <langdon> ohh ha
15:11:57 <langdon> let's revisit at "open floor" if we want to discuss.
15:12:04 <langdon> then if anyone wants to skim now they can
15:12:25 <langdon> #topic #168 some thoughts on modularity docs (https://pagure.io/modularity/issue/168)
15:12:38 <langdon> whats the zodbot title trick?
15:12:58 <sgallagh> It's just #topic
15:13:27 <langdon> yeah.. i meant to get zodbot to detail the title from a pagure issue numebr.. but i suppose that doesn't help in the #topic
15:15:06 <langdon> ok.. from my read, this is a punch list of docs comments/updates.. we should probably assign it and /or break it up in to different people's work
15:15:07 <sgallagh> .modularity 168
15:15:08 <zodbot> sgallagh: Issue #168: some thoughts on modularity docs - modularity - Pagure.io - https://pagure.io/modularity/issue/168
15:15:12 <langdon> ah ha
15:15:49 <langdon> does anyone see anything invalid (like "wrong" not like "oh, that's doc'd over here")
15:16:52 <sgallagh> I can take these on if it can wait until the new year.
15:16:54 <langdon> or any other comments?
15:17:35 <langdon> i may try and attack them before the new year.. so maybe ill break out a new ticket for each one i do? or something?
15:17:43 <sgallagh> langdon++
15:17:43 <langdon> ill describe it in a comment when i start
15:17:56 <langdon> ok.. should we move on?
15:18:45 * langdon continues to have fun with the bad ff that doesn't work with extensions
15:18:56 <langdon> ok.. im switching topics
15:19:05 <langdon> .modularity 169
15:19:07 <zodbot> langdon: Issue #169: Security vulnerabilities (CVEs) are not properly tracked in modular packages - modularity - Pagure.io - https://pagure.io/modularity/issue/169
15:19:14 <langdon> #topic Issue #169: Security vulnerabilities (CVEs) are not properly tracked in modular packages - modularity - Pagure.io - https://pagure.io/modularity/issue/169
15:19:27 <langdon> #undo
15:19:27 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x7fbf1559eed0>
15:19:53 <langdon> #action langdon to review ticket and start working on doc updates; sgallagh to contribute post jan 1
15:19:56 <langdon> #topic Issue #169: Security vulnerabilities (CVEs) are not properly tracked in modular packages - modularity - Pagure.io - https://pagure.io/modularity/issue/169
15:20:57 <langdon> this seems like something we should have a plan for or is this a bug?
15:21:27 <sgallagh> I believe this is being tracked in a RHEL ticket
15:21:30 <sgallagh> Let me see if I can find it
15:22:24 <langdon> ok
15:23:18 <sgallagh> Sorry, taking longer than expected.
15:23:22 <sgallagh> Still looking
15:23:58 <langdon> would jeopardy music help?
15:25:03 <sgallagh> Sorry, I can't find anything except an internal email thread
15:25:09 <langdon> weird
15:25:14 <sgallagh> I thought there was an associated ticket, but it's not mentioned.
15:25:27 <sgallagh> So probably we should create one, since it's definitely important for RHEL
15:25:41 <langdon> you don't think so for fedora?
15:25:43 <contyk> for both distros :)
15:25:48 <langdon> ohh ok
15:25:57 * langdon was confused for a min
15:25:58 <contyk> security procedures need to be updated
15:26:27 <langdon> so.. is this sufficient for fedora? or do we need a "do this please" ticket? rather thna one pointing at the problem?
15:26:53 <contyk> no, we need Fedora security to report and track these just like they track non-modular content
15:27:36 <sgallagh> Right, I didn't mean "not important for Fedora", just that it's "very important for RHEL" (and therefore has a better chance of getting resourced)
15:27:51 <langdon> contyk: yeah.. so do we need to "design" that and file a ticket for them to start doing it? or is it just "start doing it now, please" ticket?
15:29:29 <langdon> maybe we need to open a discussion with f-security to start
15:29:36 <langdon> any volunteers?
15:30:03 * sgallagh is actively avoiding putting anything new on his plate this week
15:30:23 <langdon> ha.. ok
15:30:42 <langdon> ill "file a ticket" and ask for a meeting post jan 1?
15:30:55 <langdon> like start the discussion
15:31:00 <sgallagh> If someone else wants to get to it, that's fine with me
15:31:20 * langdon feels like this is a conversation we already had.. but.. must be crazy
15:31:25 <sgallagh> I've just only got three and a half working days left in 2019 and several things I need to sew up
15:32:02 <langdon> sgallagh: pfft.. you have merlin taking one already! ;)
15:32:28 <langdon> ok.. ill assign me the "do something with this" .. and we can revisit in a couple weeks
15:32:32 <sgallagh> ack
15:32:46 <langdon> contyk: do you have any comments/thoughts on this before i #action ^^
15:33:03 <contyk> I think it's a good plan
15:33:08 <langdon> ok.. cool
15:33:10 <contyk> file a ticket and let's talk with them in January
15:33:28 <langdon> #action langdon to follow up with fedora security and ensure a discussion can start in early jan
15:33:40 <contyk> we definitely talked about content visibility to teams such as security and how they can identify what packages are provided and by what
15:33:46 <contyk> but that might be it
15:33:52 <contyk> there's another ticket like that in our queue :)
15:34:06 <langdon> contyk: sgallagh who will follow up with rhel? do you want me to "file that ticket" too?
15:34:12 <langdon> contyk: lol'
15:34:28 <sgallagh> langdon: Yes, please
15:34:34 <langdon> sgallagh: ack
15:34:34 <contyk> yes
15:34:42 * langdon adds to other to do list
15:35:25 <langdon> ok..
15:35:28 <langdon> gonna move now
15:35:42 <langdon> .modularity #167
15:35:42 <zodbot> langdon: Error: '#167' is not a valid integer.
15:35:45 <langdon> .modularity 167
15:35:46 <zodbot> langdon: Issue #167: Publish drafts/module-tagging-service/format.md - modularity - Pagure.io - https://pagure.io/modularity/issue/167
15:36:00 <langdon> #topic Issue #167: Publish drafts/module-tagging-service/format.md - modularity - Pagure.io - https://pagure.io/modularity/issue/167
15:36:25 <langdon> thoughts?
15:38:25 <langdon> i think we have to follow up with the "team formally known as factory-2" right?
15:39:16 <langdon> or not.. i am not sure..
15:40:44 <contyk> oh, that's my doc
15:40:46 <contyk> I think
15:42:08 <langdon> contyk: what would you like to do? do you want me just to assign it to you?
15:44:51 <contyk> langdon: I think so, assign it to me
15:45:07 <langdon> ok
15:45:29 * langdon lost his winder
15:45:32 <langdon> *windo
15:45:34 <langdon> *window
15:46:34 <langdon> #action assigned to contyk
15:46:47 <langdon> .modularity 166
15:46:48 <zodbot> langdon: Issue #166: Everything reference repository definition - modularity - Pagure.io - https://pagure.io/modularity/issue/166
15:46:58 <langdon> #topic Issue #166: Everything reference repository definition - modularity - Pagure.io - https://pagure.io/modularity/issue/166
15:47:26 <langdon> this is the issue i made the other day.. i would just like contyk, sgallagh, merlinm to give it a read and see if you have anything to add
15:48:40 <sgallagh> I don't have anything to add until a first draft is made
15:49:24 <langdon> ok
15:49:39 <merlinm> Yup. That ticket is sufficiently vague.
15:50:00 <langdon> i meant like any other "content that may not be easily available" that we would want in the "special repo" that we hadn't thought of yet :)
15:50:07 <langdon> merlinm: you are welcome ;)
15:50:45 <contyk> I can add some stuff as comments
15:50:50 <contyk> like what it should include
15:51:24 <langdon> yeah.. thats what i had in mind
15:51:29 <langdon> i think i listed 2 things
15:51:44 <langdon> ok..
15:52:14 <langdon> #action contyk to add some comments about any other content that should be included ("content that is not easily available")
15:53:02 <langdon> ok.. skipping 165
15:53:13 <langdon> .modularity 164
15:53:15 <zodbot> langdon: Issue #164: The orphan reporting needs to be adapted to cover modular cases - modularity - Pagure.io - https://pagure.io/modularity/issue/164
15:53:23 <langdon> #topic  Issue #164: The orphan reporting needs to be adapted to cover modular cases - modularity - Pagure.io - https://pagure.io/modularity/issue/164
15:54:33 <langdon> this just looks likea chunk of work.. seems pretty straightforward.. do we have anything similar for rhel? should we?
15:55:10 <langdon> "orphaned" isn't quite the right word for rhel.. but "wont be in the next release" might use a similar script
15:56:18 <langdon> almost out of time.. sgallagh, contyk any thoughts?
15:56:42 <sgallagh> langdon: Geez, if I start having thoughts that might be dangerous
15:57:07 <langdon> sgallagh: lol.. especially this close to shutdown!
15:58:20 <contyk> I had thoughts once
15:58:28 <langdon> and look what happened?
15:59:01 <contyk> exactly
15:59:23 <langdon> ok.. well.. im gonna shut this thing down.. but I am curious if you think we need a rhel version of this ticket
16:00:28 <langdon> #info no resolution at this point.. but seems like a legit ticket/issue
16:00:34 <langdon> #endmeeting