15:00:04 <nils> #startmeeting modularity_wg
15:00:04 <zodbot> Meeting started Tue Aug 16 15:00:04 2016 UTC.  The chair is nils. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:04 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:04 <zodbot> The meeting name has been set to 'modularity_wg'
15:00:04 <nils> #meetingtopic Weekly meeting of Modularity WG
15:00:13 <cpacheco> .hello cpacheco
15:00:14 <zodbot> cpacheco: cpacheco 'Courtney Pacheco' <cpacheco@redhat.com>
15:00:25 <jkurik> .hello jkurik
15:00:26 <moto-timo> .hello ttorling
15:00:27 <zodbot> jkurik: jkurik 'Jan Kurik' <jkurik@redhat.com>
15:00:30 <zodbot> moto-timo: ttorling 'None' <TicoTimo@gmail.com>
15:00:30 <nils> #chair dgilmore haraldh jkurik langdon tflink
15:00:30 <zodbot> Current chairs: dgilmore haraldh jkurik langdon nils tflink
15:00:37 <nils> could you wait :P?
15:00:46 <nils> #topic Roll Call
15:00:50 <nils> sheesh :)
15:00:55 <cpacheco> ha :)
15:00:57 <nils> .helo nphilipp
15:01:00 <cpacheco> .hello cpacheco
15:01:01 <nils> .hello nphilipp
15:01:01 <zodbot> cpacheco: cpacheco 'Courtney Pacheco' <cpacheco@redhat.com>
15:01:04 <zodbot> nils: nphilipp 'Nils Philippsen' <nphilipp@redhat.com>
15:01:08 <moto-timo> .hello ttorling
15:01:09 <zodbot> moto-timo: ttorling 'None' <TicoTimo@gmail.com>
15:01:12 <jkurik> .hello jkurik
15:01:13 <nils> #chair sct
15:01:13 <zodbot> Current chairs: dgilmore haraldh jkurik langdon nils sct tflink
15:01:13 <zodbot> jkurik: jkurik 'Jan Kurik' <jkurik@redhat.com>
15:01:25 <nils> did I forget a chair?
15:02:52 <nils> okay, mikedep333 and cydrobolt seem to be missing
15:03:34 <nils> #topic Agenda
15:03:34 <nils> #info Ensure we support all arches
15:03:47 <haraldh> .hello harald
15:03:48 <nils> that must be flush-left I suppose
15:03:48 <zodbot> haraldh: harald 'Harald Hoyer' <harald@redhat.com>
15:03:51 <sct> .hello sct
15:03:51 <asamalik> .hello asamalik
15:03:52 <zodbot> sct: sct 'Stephen Tweedie' <sct@redhat.com>
15:03:55 <zodbot> asamalik: asamalik 'Adam Samalik' <asamalik@redhat.com>
15:03:59 <nils> #info Ensure we support all arches
15:04:20 <nils> any other bigger topic that's not yet mentioned: http://piratepad.nl/modularity-wg-agendas
15:04:58 <asamalik> nils, do we want to mention the BPO vs PDC?
15:05:01 <langdon> .hello langdon
15:05:02 <zodbot> langdon: langdon 'Langdon White' <langdon@fishjump.com>
15:05:07 <nils> asamalik: sure
15:05:16 * langdon kinda here.. More so in 5/10
15:05:22 <nils> #info BPO ./. PDC roles
15:05:34 <langdon> Arches may be tough cause lubos is afk
15:05:43 <langdon> Forgot when I put it on the agenda
15:05:51 <nils> ahh ok
15:05:58 <nils> so shall we shelve it, langdon?
15:06:09 <nils> I can put it on agenda next week
15:06:28 <langdon> nils probably, unless dgilmore wants to discuss some aspect now
15:06:45 <langdon> threebean is also afk I believe
15:06:51 <nils> yeah
15:06:56 <nils> dgilmore: ?
15:07:22 <nils> tick-tock
15:07:37 <nils> good, let's shelve it
15:07:41 <nils> #undo
15:07:41 <zodbot> Removing item from minutes: INFO by nils at 15:05:22 : BPO ./. PDC roles
15:07:44 <nils> #undo
15:07:44 <zodbot> Removing item from minutes: INFO by nils at 15:03:59 : Ensure we support all arches
15:07:51 <nils> #info BPO ./. PDC roles
15:07:56 <langdon> sct do you want to have any more container discussion here or wait?
15:08:26 <dgilmore> langdon: sorry I am in another meeting
15:08:47 <dgilmore> I have no idea what ya'll are talking about
15:08:50 * langdon notes we need to figure out conflict with server wg
15:09:11 <nils> dgilmore: the ensuring our stuff is run not only on x86_64 topic
15:09:20 <langdon> jkurik is here today though, can we add that to our agenda?
15:09:22 <nils> dgilmore: langdon meant to shelve it until lubos is back
15:09:25 <sct> langdon: Want to catch up with you about it first, we can bring things here next week
15:09:36 <nils> langdon: which topic is this about?
15:09:44 <langdon> sct ack
15:09:46 <sct> langdon: still trying to sync up on all the post-flock discussions after my PTO. :)
15:09:57 <langdon> Rescheduling this meeting nils
15:10:04 <nils> aah
15:10:09 <nils> langdon: -> agenda?
15:10:26 <nils> langdon: likewise with container convo?
15:10:33 <jkurik> langdon: server wg is also thinking of rescheduling their meeting
15:10:38 <langdon> Containers next week
15:10:48 <nils> jkurik: let's both reschedule to the same slot :o)
15:10:59 <langdon> +1 :)
15:11:00 <jkurik> nils: no problem :)
15:11:06 <moto-timo> +1
15:11:21 * moto-timo chuckles
15:11:27 <nils> langdon: I'll add containers (w/o more detail) to the agenda next week then
15:11:39 <langdon> Ok.. So can we ask jkurik to sort it and call it closed?
15:11:48 <langdon> Meeting time I mean
15:11:51 <nils> good
15:11:52 <nils> #undo
15:11:52 <zodbot> Removing item from minutes: INFO by nils at 15:07:51 : BPO ./. PDC roles
15:12:15 <nils> #info reschedule meeting time
15:12:20 <nils> #info BPO ./. PDC roles
15:12:20 <langdon> Sorry were we not still on agenda
15:12:25 <nils> aren't we
15:12:40 <nils> langdon: have you taken over without telling me? tsk, tsk
15:12:40 <langdon> I saw the undo.. Was confused
15:12:46 <langdon> Ha.. No
15:12:58 * langdon just talks a lot
15:13:00 <nils> as far as I know we're still on agenda
15:13:06 <nils> which isn't good, but hey
15:13:35 <nils> okay, let's move on
15:13:38 <langdon> So we have the agenda.. I think
15:13:46 <nils> #topic reschedule meeting time
15:13:53 <jkurik> #action jkurik to reschedule the meeting to a time not overlapping with Server WG meeting
15:13:58 <nils> #action jkurik sort out meeting time conflict with server WG
15:14:01 <nils> #undo
15:14:01 <zodbot> Removing item from minutes: ACTION by nils at 15:13:58 : jkurik sort out meeting time conflict with server WG
15:14:09 <nils> yours is better :)
15:14:19 <jkurik> :)
15:14:22 <nils> #topic BPO ./. PDC roles
15:14:29 <nils> asamalik: the floor is yours
15:14:38 <moto-timo> I see BPO = Build Pipeline Overview... what is PDC?
15:14:47 <nils> Product Definition Center
15:14:53 <jkurik> product definition center
15:14:57 <moto-timo> ok. that's what I thought thank you.
15:15:01 <langdon> Links?
15:15:08 <nils> moto-timo: https://pdc.fedoraproject.org/
15:15:10 <asamalik> there has been a little confusion about BPO and PDC as they are both things with a database full of module data and web UI
15:15:17 <nils> #info PDC: https://pdc.fedoraproject.org/
15:15:31 <asamalik> so I talked to nils and langdon and we agreed on this:
15:15:33 <nils> #info BPO (dev): http://dev.fed-mod.org
15:15:47 <asamalik> http://blog.samalik.com/roles-of-pdc-and-bpo-in-modularity/
15:15:55 <asamalik> (published as a blog post by me)
15:15:59 <nils> #info http://blog.samalik.com/roles-of-pdc-and-bpo-in-modularity/
15:16:27 <asamalik> btw PDC is called "Product Definition Center" but think of it more as a metadata database
15:16:48 <nils> the most confusing part of its name is "definition"
15:16:50 <moto-timo> sure. ty
15:17:06 <asamalik> and it (PDC) will stay as a DB only
15:17:06 <nils> it's not where things are defined, but it documents what we have in terms of products, releases and so on
15:17:16 <nils> asamalik: from our perspective
15:17:31 <asamalik> nils, good point, from Modularity perspective :)
15:17:47 <asamalik> and BPO will be a web UI to browse some of the metadata and build state of modules
15:18:01 <asamalik> and I guess that's all from my side
15:18:07 <nils> asamalik: have you put the document you wrote in the wiki already?
15:18:11 <asamalik> questions? feedback?
15:18:19 <asamalik> nils, no I haven't, good point
15:18:24 <asamalik> there is a Infra wiki
15:18:30 <moto-timo> reading blog now. good stuff.
15:18:39 <nils> PDC is more about documenting _what is_, but not going very much into detail about build states and so forth
15:18:46 <asamalik> https://fedoraproject.org/wiki/Modularity/Infra
15:19:02 <asamalik> I will need to update it to make this problem clear
15:19:15 <langdon> asamalik, "solution" :)
15:19:15 <asamalik> but there will be no changes in concept - just making it clear more explicitly
15:19:51 <moto-timo> so is there a transformation between databases or not needed?
15:19:59 <langdon> we do need to validate it with threebean when he is back.. just to be sure we aren't missing anything
15:20:04 <nils> moto-timo: whatcha mean, transformation?
15:20:25 <moto-timo> schema A -> schema B
15:20:51 <nils> moto-timo: we're in discussion with PDC upstream about the changes we need there re: schemata, migration
15:20:59 <moto-timo> great
15:21:02 <nils> it won't be much :)
15:21:41 <nils> I mean, we have some non-negligible additions, but the changes to existing structures will be minimal (fingers crossed)
15:21:59 <moto-timo> yeah. It's all about context.
15:22:09 <langdon> moto-timo, but... there is an elasticsearch backend for bpo.. which, in a sense, is a transformaiton.. but it is really just loading data from fed-msg (mostly)
15:22:10 <nils> asamalik: shall we #info the wiki page yet?
15:22:16 <nils> it's a cache
15:22:28 <moto-timo> excellent
15:22:29 <nils> (the elastic search thing=
15:22:30 <nils> )
15:23:08 <asamalik> nils, do it and maybe make note that we will do changes to the wiki after threebean sees it?
15:23:25 <nils> asamalik: even better, I'll #action it to you :P
15:23:39 <asamalik> nils, ha, thanks!
15:24:12 <nils> #action asamalik check back with threebean on the soundness, then document this at https://fedoraproject.org/wiki/Modularity/Infra
15:24:21 <nils> langdon: sounds good?
15:24:23 <nils> asamalik: ^^
15:24:32 <langdon> +1
15:24:39 <asamalik> nils, sounds excellent
15:24:42 <nils> good
15:24:57 <nils> next point, no point
15:25:00 <nils> #topic Open Floor
15:25:19 * langdon was hoping for nils to get an action to action asamalik ;) .. langdon was in consulting
15:25:47 <langdon> any one see out talk(s) at flock? any comments on the demo nils did?
15:25:48 <nils> langdon: /me too :)
15:26:09 <nils> langdon: my demo lacked explosions, but I blame that on asamalik  :D
15:26:13 <moto-timo> #action ttorling to watch Flock talks
15:26:13 * asamalik langdon shoud have done an action to tell this idea about action for an action before nils created that action
15:26:19 <langdon> #link https://www.youtube.com/watch?v=KK4Id8TKydQ&list=PLcwHJG45BmAO35tZBfZyxWKgANCvJCG0J
15:26:38 <nils> asamalik: Yo dawg!
15:26:46 * asamalik just wrote it it with /me without thinking :)
15:27:10 <langdon> #info https://www.youtube.com/watch?v=KK4Id8TKydQ&list=PLcwHJG45BmAO35tZBfZyxWKgANCvJCG0J < youtube version of just the demo from the flock talk
15:28:30 <nils> whoa mod-bot is flooding #fedora-modularity when we're in here
15:28:45 <langdon> nils, this is why i muted him.. he is too chatty
15:29:19 <nils> haha
15:29:27 <langdon> ok.. our open floor is too open
15:29:43 <nils> langdon: usually it's okay -- good to know when changes are done to PRs etc
15:29:51 <langdon> jberkus was trying out the stuff in the pagure repo and the docs are wrong... :( /cc jkaluza
15:29:52 * nils stares down into the abyss
15:30:18 <langdon> also.. no jan :( .. but.. i think the unionized profiles was a mistake
15:30:23 <nils> langdon: that's awefully unspecific if I might say so ;)
15:30:27 <langdon> 1 install profile per "install"
15:30:52 <langdon> nils, sorry.. was thinking there was more context.. he wanted to try "dnf module enable ..."
15:31:00 <langdon> so the dnf plugin client
15:31:00 <nils> langdon: you mean "dnf module enable somemodule profile1 profile2 profile3"?
15:31:06 <nils> ah yeah
15:31:21 <langdon> nils, yeah.. just profile1 period makes a lot more sense
15:31:44 <nils> yeah, if profile1 + profile2 is sensible, make that profile3
15:31:53 <langdon> cause otherwise they have to know how to union .. which is just weird.. better to just have 30 of them or what not
15:32:00 <langdon> nils, exactly
15:32:25 <nils> at some point we probably need more MD for profiles, so people can query what to expect from them
15:32:28 <langdon> no karsten either today?
15:32:48 <langdon> nils, uggh .. good point
15:32:57 * moto-timo thinks everybody should just take August off
15:33:01 <nils> haha
15:33:12 <nils> I've pinged him
15:33:12 <langdon> karsten is also working on the EOL concept in modulemd .. should be hitting the list soon
15:33:12 <moto-timo> global holiday
15:33:33 <langdon> moto-timo, im fairly sure they are.. i am just here.. and I am not particularly useful ;)
15:33:49 * moto-timo agrees
15:33:59 <langdon> moto-timo, harsh ;)
15:34:00 <moto-timo> about self
15:34:02 <moto-timo> lol
15:34:19 * moto-timo not particularly useful either. Moar Koffeeee.
15:34:20 <langdon> ok.. any other updates from people?
15:34:27 <jkurik> I will be on vacations the next week, so the action to reschedule the meeting might be delayed once I am back
15:34:37 <langdon> jkurik, s'ok
15:35:16 <langdon> sgallagh is starting to do some work on base-runtime but is also helping by being our liaison in to the server-wg... so he is probably there today not here
15:36:00 <langdon> hmm.. nils should we just wrap it up?
15:36:05 <moto-timo> for next week "containers" is generic for Docker, lxc, whatever I assume
15:36:18 <jkurik> btw: https://lists.fedoraproject.org/archives/list/server@lists.fedoraproject.org/thread/3I7N5DIRZDLN6LP354GNU2XIW45BKG7D/
15:36:25 <nils> langdon: I think so
15:36:32 <nils> objections, anyone?
15:36:34 <langdon> moto-timo, really its can we/should we use "containers" for parallel install
15:36:42 <moto-timo> ah
15:36:43 <jkurik> the server WG is rescheduling their meeting, so my action will be solved without any work :)
15:36:45 <langdon> where "containerS" just == isolation..
15:36:52 <langdon> jkurik++
15:36:52 <zodbot> langdon: Karma for jkurik changed to 6 (for the f24 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:37:16 <langdon> jkurik, shows true open source spirit by convincing someone else to do the thing
15:37:18 <langdon> ;)
15:37:43 <langdon> ok.. nils, i say call it
15:37:51 <moto-timo> just make the tests fail, then somebody will work on it :)
15:38:02 <langdon> or disable the tests ;)
15:38:07 <moto-timo> +1
15:38:19 <nils> good
15:38:22 <nils> #endmeeting