15:00:04 <nils> #startmeeting modularity_wg
15:00:04 <zodbot> Meeting started Tue Sep  6 15:00:04 2016 UTC.  The chair is nils. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:04 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:04 <zodbot> The meeting name has been set to 'modularity_wg'
15:00:04 <nils> #meetingtopic Weekly meeting of Modularity WG
15:00:04 <nils> #chair haraldh jkurik langdon tflink
15:00:04 <zodbot> Current chairs: haraldh jkurik langdon nils tflink
15:00:13 <nils> #topic Roll Call
15:00:18 <nils> .hello nphilipp
15:00:19 <zodbot> nils: nphilipp 'Nils Philippsen' <nphilipp@redhat.com>
15:00:31 <jkurik> .hello jkurik
15:00:32 <zodbot> jkurik: jkurik 'Jan Kurik' <jkurik@redhat.com>
15:00:59 <cpacheco> .hello cpacheco
15:01:00 <zodbot> cpacheco: cpacheco 'Courtney Pacheco' <cpacheco@redhat.com>
15:01:19 <clime> hey
15:01:41 <langdon> .hello langdon
15:01:42 <zodbot> langdon: langdon 'Langdon White' <langdon@fishjump.com>
15:02:06 <sgallagh> .hello sgallagh
15:02:08 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
15:03:02 <nils> #topic Agenda
15:03:02 <nils> #info Badge
15:03:18 <nils> that's a short agenda for today, does anybody have anything to add?
15:03:53 <sgilson> .hello sgilson
15:03:54 <zodbot> sgilson: sgilson 'None' <sgilson@redhat.com>
15:04:04 <lkocman> .hello lkocman
15:04:05 <zodbot> lkocman: lkocman 'Lubos Kocman' <lkocman@redhat.com>
15:04:38 <nils> btw: http://piratepad.nl/modularity-wg-agendas <-- here is it again
15:04:39 <sgallagh> nils: General question: should the Base Runtime share this meeting and agenda?
15:05:25 <nils> sgallagh: good question, langdon?
15:05:27 <sct> .hello sct
15:05:28 <zodbot> sct: sct 'Stephen Tweedie' <sct@redhat.com>
15:05:36 <langdon> sgallagh, i like that idea.. why have another meeting
15:05:38 <nils> #chair sct
15:05:38 <zodbot> Current chairs: haraldh jkurik langdon nils sct tflink
15:05:38 <sct> sgallagh: My preference would be to share if the time works
15:05:42 <sgallagh> nils: Maybe that question is worth an agenda item
15:05:55 <sct> sgallagh: and split if and when it turns out we've got too much content for one meeting.
15:06:15 <sgallagh> I pretty much agree, just figured we could make it official
15:06:19 <sct> +1
15:06:25 <langdon> +1
15:06:42 <nils> now to make meetbot happy...
15:06:46 <nils> #undo
15:06:46 <zodbot> Removing item from minutes: INFO by nils at 15:03:02 : Badge
15:06:54 <nils> #info should base runtime share this meeting and agenda
15:06:58 <nils> #info Badge
15:07:08 <nils> #topic should base runtime share this meeting and agenda
15:07:15 <nils> #chair dgilmore
15:07:15 <zodbot> Current chairs: dgilmore haraldh jkurik langdon nils sct tflink
15:07:16 <moto-timo> .hello ttorling
15:07:17 <zodbot> moto-timo: ttorling 'None' <TicoTimo@gmail.com>
15:07:54 <nils> any objections to base runtime sharing the meeting?
15:08:00 <asamalik> .hello asamalik
15:08:01 <zodbot> asamalik: asamalik 'Adam Samalik' <asamalik@redhat.com>
15:08:22 <nils> none, good
15:08:31 * asamalik is sorry for being late
15:08:55 <nils> #agreed base runtime to share this meeting and agenda for the time being
15:09:06 <nils> sct, langdon, sgallagh: ^^ good?
15:09:10 <sgallagh> ack
15:09:11 <langdon> nils, yep
15:09:15 <sct> Yep
15:09:18 <nils> cool, next
15:09:21 <langdon> sgallagh, do you have a particular thing you wanted to add?
15:09:21 <nils> #topic Badge
15:09:25 <nils> #undo
15:09:25 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x7f78c4250250>
15:09:44 <sgallagh> langdon: I'll mention a couple minor notes in Open Floor.
15:09:49 <sgallagh> I don't have a discussion topic today.
15:09:51 <langdon> cool
15:10:06 <nils> #topic Badge
15:10:28 <langdon> i think we have no updates :(
15:10:55 <nils> langdon: postpone it till next week?
15:11:09 <langdon> nils, yeah.. unless you know something i dont
15:11:44 <nils> langdon: I don't think so ;).
15:12:01 <nils> #info postponed until next meeting
15:12:27 <nils> #topic Open Floor
15:12:39 <nils> sgallagh: you had something :)
15:12:42 <sgilson> question here
15:12:50 <asamalik> Copr can build modules! At least in the dev environment
15:12:52 <lkocman> What about coper progress? Theyr're rocking!
15:12:53 <lkocman> yeah
15:12:59 <nils> not all at once :)
15:13:02 <nils> sgilson: ?
15:13:15 <asamalik> https://www.youtube.com/watch?v=uNW8QEzsdDg
15:13:16 <sgilson> ok, it's about attribution for wiki articles I create but didn't write
15:13:34 <nils> sgilson: who wrote them?
15:13:44 <sgilson> two I'm thinking of: stc
15:13:50 <sgallagh> one moment. Multi-tasking
15:13:52 <sgilson> sct
15:13:53 <sgilson> sorry
15:14:08 <langdon> asamalik, nils: I think we stopped announcing demos in this meeting.. We should bring that back
15:14:46 <nils> sgilson: I think it's okay if you mention that in the commit message, "originally by XYZ" or something like that
15:14:51 <nils> langdon, sct? ^^
15:15:21 <sgilson> ok, can do, and I'll add a kind of by line to the top of each
15:15:22 * lkocman goes for a beer stock market
15:15:23 <langdon> Are there commit messages in the wiki?
15:15:37 <sgallagh> langdon: Yes, every edit identifies the account that made it
15:15:40 <nils> langdon: yes, mediawiki has them
15:15:41 <langdon> I think we should add a revision history or something to the doc
15:15:55 <nils> langdon: there is one already :)
15:15:58 <sgallagh> langdon: Well, that's kind of what the revision history of the wiki is for
15:16:00 <nils> at least in MW
15:16:04 <sct> sgilson: Sure.  We can cover that when we talk tomorrow if you want too.
15:16:14 <sgallagh> The concern is mainly that it's ascribed to the editor, not necessarily the writer.
15:16:15 <sgilson> sct OK thanks
15:16:18 <langdon> sgallagh I think that is the problem.. The wiki revision history is wrong if Gilson posts for sct
15:16:20 <sgallagh> I usually resolve that with a byline
15:16:34 <sgilson> sgallagh: right
15:16:40 <sgallagh> "This document was contributed by A, B and C"
15:16:46 <sgilson> 72 points, right?
15:16:51 <sgilson> type size
15:16:54 <nils> heh
15:16:57 <nils> of course, minimum
15:17:30 <langdon> I like the "contributions from"
15:17:39 <sgilson> so sct let me know if you want to attribute those articles to someone else ;^)
15:18:12 <langdon> sgilson I think that depends on how negative the feedback is :)
15:18:23 <nils> heh
15:18:24 <sgilson> langdon: good point, wait and see
15:18:41 <sgilson> k thx
15:19:23 <nils> #info attribution of contributed/edited content in the wiki using bylines
15:19:31 <nils> sgilson, langdon, ^^ ?
15:19:33 <langdon> ok.. should we mention the copr stuff now? more formally?
15:19:42 <langdon> nils, no..
15:19:48 <nils> ok
15:19:50 <nils> #undo
15:19:50 <zodbot> Removing item from minutes: INFO by nils at 15:19:23 : attribution of contributed/edited content in the wiki using bylines
15:20:33 <asamalik> ok Copr is for me I guess :)
15:20:33 <langdon> #info attribution of contributed/edited content should be provided in a contribution section on the wiki pages (particularly if not reflected in MW revision history)
15:20:45 <langdon> ^^ better?
15:20:48 <sgilson> langdon: looks good
15:20:56 <nils> langdon: much clearer, thanks
15:21:12 <nils> ok, COPR, asamalik!
15:21:18 <asamalik> Copr team worked on building modules and it's working now as a proof of concept. Not yet in production, still needs some polishing.
15:21:34 <asamalik> If you want to see the workflow, have a look at this 2 min long video: https://www.youtube.com/watch?v=uNW8QEzsdDg
15:21:35 <langdon> asamalik, where is it?
15:21:54 <langdon> #chairs
15:21:59 <langdon> #chair
15:21:59 <zodbot> Current chairs: dgilmore haraldh jkurik langdon nils sct tflink
15:22:06 <langdon> #chair asamalik
15:22:06 <zodbot> Current chairs: asamalik dgilmore haraldh jkurik langdon nils sct tflink
15:22:16 <langdon> asamalik, info it!! :)
15:22:29 <asamalik> langdon: it's deployed on the dev instance
15:22:31 <nils> #info and #link
15:22:34 <langdon> and, do we have an eta for prod?
15:22:41 <asamalik> # info Copr team worked on building modules and it's working now as a proof of concept. Not yet in production, still needs some polishing.
15:22:48 <langdon> asamalik, no space :)
15:23:02 <asamalik> #info Copr team worked on building modules and it's working now as a proof of concept. Not yet in production, still needs some polishing.
15:23:24 <asamalik> #link https://www.youtube.com/watch?v=uNW8QEzsdDg
15:23:30 <asamalik> langdon: ha! thanks :)
15:23:43 <langdon> asamalik, undo last
15:24:12 <langdon> #undo
15:24:12 <zodbot> Removing item from minutes: <MeetBot.items.Link object at 0x38844dd0>
15:24:18 <langdon> i didn't know i could do that
15:24:19 <langdon> #link https://www.youtube.com/watch?v=uNW8QEzsdDg is a 2 min long demo of the current state
15:24:30 <langdon> asamalik, just providing descrip on the link
15:24:40 <asamalik> langdon: cool!
15:24:40 <dgilmore> langdon: any chair can
15:25:14 <asamalik> I also wrote a blog post about Copr's role in modularity
15:25:17 <asamalik> let me find it
15:25:17 <langdon> dgilmore, yeah.. didn't think i could undo someone else's :)
15:25:40 <asamalik> http://blog.samalik.com/copr-in-the-modularity-world/
15:26:07 <asamalik> It will be also posted on the community blog
15:26:08 <langdon> asamalik, #link with descrip :)
15:26:20 <asamalik> #link http://blog.samalik.com/copr-in-the-modularity-world/ Copr in the modularity world - blog post
15:26:30 * asamalik is learning
15:26:33 <langdon> woot!
15:26:53 <nils> 👍
15:26:59 * asamalik hopes it's a positive woot!
15:27:00 <langdon> more demos we should highlight?
15:27:13 <asamalik> langdon: not yet, I should get more tomorrow
15:27:22 <asamalik> it's delayed this week because of the holiday in the US this monday
15:28:02 <langdon> asamalik, ahh right..
15:28:03 <langdon> ok
15:28:19 <langdon> asamalik, can you add "demos" to the agenda for next time? please?
15:28:30 <asamalik> langdon: will do
15:28:32 <moto-timo> +1
15:28:55 <langdon> ok.. sgallagh did you have more to bring up?
15:29:27 <sgallagh> Just a minor status update, mentioning what I'm working on.
15:30:12 <langdon> sgallagh, ok.. are you typing?
15:30:22 <sgallagh> I got handed a straw-man example of what a base runtime might look at from a previous brainstorming session.
15:30:37 <sgallagh> Along with its rather massive collection of dependencies.
15:30:52 <langdon> it was perfect, right? /me thinks he was involved :)
15:30:57 <sgallagh> So right now, I'm working on building a few helper tools for analyzing those dependencies and figuring out what is needed where.
15:31:15 <langdon> sgallagh, you should definitely talk to haraldh about his helper tools..
15:31:20 <langdon> there may be overlap
15:32:08 <sgallagh> langdon: I've seen some of them.
15:32:17 <langdon> ok.. cool
15:32:36 <langdon> more stuff from anyone?
15:32:53 <sgallagh> FWIW, I'll be working from https://github.com/sgallagher/python3-rpm-deps
15:33:41 <sgallagh> (It doesn't do much that's useful yet; it's a rewrite of some code I wrote for Server a while back to help trim the DVD size, but I'm adding more in today)
15:33:44 <sgallagh> EOF
15:35:12 <langdon> sgallagh, geppetto may also have some useful bits too
15:36:18 <sgallagh> langdon: I've been speaking with him
15:36:26 <langdon> cool
15:36:32 <langdon> ok.. anyone else?
15:36:32 <sgallagh> Some of the stuff I wanted to do was on the TODO list for DNF
15:36:38 <sgallagh> But not there yet
15:37:35 <langdon> sgallagh, can we ask the dnf team to up the priority?
15:38:09 <sgallagh> langdon: Unlikely. It's nice-to-have stuff. (It's all to do with querying)
15:38:15 <sgallagh> They've got their hands full with *actual* bugs,.
15:38:33 <sgallagh> I'll look into merging my stuff back in eventually
15:38:38 <langdon> sgallagh, well. it might be worth asking anyway.. follow up with me offline?
15:38:42 <sgallagh> For now, I'm just keeping it separate and using their API
15:39:56 <langdon> ok
15:40:26 <nils> anything/anybody else?
15:41:29 <langdon> nils, i think we should call it
15:41:37 <nils> yup
15:41:43 <nils> #endmeeting