15:01:34 <nils> #startmeeting modularity_wg
15:01:34 <zodbot> Meeting started Tue Oct 11 15:01:34 2016 UTC.  The chair is nils. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:34 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:01:34 <zodbot> The meeting name has been set to 'modularity_wg'
15:01:34 <nils> #meetingtopic Weekly Meeting of the Modularity Working Group
15:01:34 <contyk> :)
15:01:59 <nils> #chair dgilmore haraldh langdon mikedep333 tflink
15:01:59 <zodbot> Current chairs: dgilmore haraldh langdon mikedep333 nils tflink
15:02:08 <nils> #topic Roll Call
15:02:10 <contyk> .hello psabata
15:02:11 <zodbot> contyk: psabata 'Petr Ĺ abata' <psabata@redhat.com>
15:02:12 <langdon> .hello langdon
15:02:12 <nils> .hello nphilipp
15:02:14 <zodbot> langdon: langdon 'Langdon White' <langdon@fishjump.com>
15:02:17 <zodbot> nils: nphilipp 'Nils Philippsen' <nphilipp@redhat.com>
15:02:19 <asamalik> .hello asamalik
15:02:20 <zodbot> asamalik: asamalik 'Adam Samalik' <asamalik@redhat.com>
15:02:35 * asamalik waves
15:03:01 <nils> #topic Agenda
15:03:12 <nils> #info CommOps: Fedora Modularity onboarding
15:03:24 <nils> anything else for the agenda?
15:03:46 <contyk> I'll provide some status for BRT
15:03:59 <nils> #info Base Runtime Status
15:04:19 <nils> good
15:04:33 <nils> #topic CommOps: Fedora Modularity onboarding
15:05:31 <cpacheco> .hello cpacheco
15:05:33 <zodbot> cpacheco: cpacheco 'Courtney Pacheco' <cpacheco@redhat.com>
15:05:38 <nils> #link https://pagure.io/fedora-commops/issue/69 CommOps team finished the initial work for Modularity
15:06:03 <langdon> woohoo!
15:06:09 <langdon> thanks commops team!
15:06:16 <langdon> #info commops++
15:06:17 <langdon> :)
15:06:20 <contyk> +1
15:06:23 <nils> +1
15:06:46 <nils> #agreed kudos to CommOps for their work!
15:07:07 <nils> #topic Base Runtime Status
15:07:10 <nils> #chair contyk
15:07:10 <zodbot> Current chairs: contyk dgilmore haraldh langdon mikedep333 nils tflink
15:07:10 <contyk> give me a minute; need to get to my desk
15:08:09 <contyk> okay :)
15:08:13 * contyk hates typing on the phone
15:08:41 <contyk> so I just wanted to say we've fixed some bugs in our first prototype and decided to standardize it on f25b1
15:08:59 <contyk> we're also *trying* to build it with the modularity infra
15:09:09 <contyk> however, it's kinda slow and we keep running into issues
15:09:17 <nils> .oO(...try harder...) :-P
15:09:26 <contyk> nils: it's your fault :P
15:09:39 <contyk> anyway, I've submitted another BRT build today so we'll so how it goes
15:09:40 <nils> heh
15:09:56 <contyk> hopefully we'll have some artifacts (i.e. yum repos) to show by the next meeting
15:10:06 <lkocman> contyk, some issues with regen-repo timeouts
15:10:13 <lkocman> I just openned some issues but we can work trough
15:10:16 <lkocman> *through
15:10:32 <contyk> lkocman: also the pdc-updater was down
15:10:40 <contyk> anyway, that's all from me
15:10:43 <lkocman> contyk, right but that's easy to fix
15:10:58 <contyk> lkocman: easy to fix but it halted the work for days :)
15:11:03 <lkocman> right
15:11:31 <lkocman> well that only tells you how well is the whole build pipeline tested
15:11:32 <lkocman> ;-)
15:11:45 <lkocman> not talking of unit tests
15:11:55 <nils> contyk: what is f25b1? a commit hash in which repo?
15:12:03 <contyk> nils: Fedora 25 Beta 1
15:12:08 <langdon> can we setup e2e tests in the ci ? make sure things stay upright?
15:12:09 <nils> aaaa
15:12:14 <contyk> not like there's going to be another beta release...
15:12:14 <langdon> i actually thought we had put some in already
15:12:41 <nils> #info fixed some bugs in the first prototype, decided to standardize it on F-25 Beta
15:12:48 <nils> contyk: like this ^^?
15:12:53 * contyk nods
15:13:32 <contyk> moto-timo: you're late
15:13:34 <moto-timo> .hello ttorling
15:13:37 <zodbot> moto-timo: ttorling 'None' <TicoTimo@gmail.com>
15:13:42 <moto-timo> yeah. connectivity issues
15:14:07 <nils> contyk: anything else about BRT status?
15:14:13 <contyk> not at this point
15:14:15 <nils> good
15:14:19 <nils> #topic Open Floor
15:14:32 <nils> anything for open floor?
15:14:47 <langdon> any answers to my qs above?
15:15:05 <lkocman> cpacheco, ^ did you test your resubmit change? I might need it tonight :-)
15:16:13 <contyk> hmm, my module build submission is still running
15:16:20 <contyk> for nearly four hours now
15:16:31 <contyk> we really need to make that parallel...
15:16:43 <lkocman> contyk, well I think that the problem is that builder.py failed on getTag which returned none since pdc-updater was down
15:16:47 <lkocman> and that stopped everything
15:17:00 <contyk> lkocman: that's for 0.25-2
15:17:03 <lkocman> I might need to fail task / resubmit
15:17:07 <lkocman> uh right
15:17:11 <contyk> lkocman: this is 0.25-3, after jkaluza restarted it
15:17:32 <lkocman> okay I'll play with it with beer at home
15:17:34 <contyk> maybe I'm running into another, mysterious issue
15:17:40 <contyk> :)
15:17:44 <lkocman> just don't submit a new one :-)
15:18:01 <lkocman> I'll backup db and will do some research :-)
15:18:12 <contyk> now what happens if I hit ^C...
15:18:15 <lkocman> also will burn down every single person who broke rida with new merges :-)))
15:18:24 <contyk> anyway, let's take this to #fedora-modularity
15:18:28 <nils> aye
15:18:35 <nils> anything else?
15:18:38 <contyk> yes
15:18:40 <lkocman> nils, not from me
15:18:41 <contyk> answer langdon's questions
15:18:43 <contyk> :)
15:19:01 <langdon> ?!?!
15:19:23 <langdon> maybe no one knows?
15:19:27 <langdon> cause james is afk?
15:20:09 <nils> probably
15:20:43 <langdon> ha
15:20:50 <langdon> ok.. ill follow up later in the week
15:21:04 <nils> ok
15:21:07 <nils> so...
15:21:09 <langdon> i guess I am just surprised that we aren't being pinged by outages.. cause I thought we were testing
15:21:32 <langdon> ok.. im good if we want to wrap
15:21:54 <nils> Thanks for coming everybody!
15:21:58 <nils> #endmeeting