14:00:00 <nils> #startmeeting modularity_wg
14:00:00 <zodbot> Meeting started Tue Oct 16 14:00:00 2018 UTC.
14:00:00 <zodbot> This meeting is logged and archived in a public location.
14:00:00 <zodbot> The chair is nils. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:00 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:00:00 <zodbot> The meeting name has been set to 'modularity_wg'
14:00:00 <nils> #meetingtopic Weekly Meeting of the Modularity Working Group
14:00:01 <nils> #topic Roll Call
14:00:06 <nils> .hello nphilipp
14:00:07 <zodbot> nils: nphilipp 'Nils Philippsen' <nphilipp@redhat.com>
14:01:54 * nils whistles in the dark
14:02:29 * sgallagh waves
14:03:13 <contyk> o/
14:03:16 <contyk> .hello psabata
14:03:17 <zodbot> contyk: psabata 'Petr Šabata' <psabata@redhat.com>
14:03:38 <contyk> the usual "I still have three minutes" and then you forget to join
14:03:45 <ignatenkobrain> .hello2
14:03:50 <zodbot> ignatenkobrain: ignatenkobrain 'Igor Gnatenko' <i.gnatenko.brain@gmail.com>
14:04:04 <sgallagh> .hello2
14:04:08 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
14:04:42 <mattdm> THREE? We have a meeting THREE?
14:04:55 <contyk> yes
14:04:57 <sgallagh> mattdm: You'd think the FPL would know these things ;-)
14:05:56 <nils> #topic Agenda
14:05:56 <nils> #info [ignatenkobrain] How do we keep rawhide sane? (re: forcing people to latest modules)
14:06:10 <nils> anything else?
14:06:36 <nils> ok, let's get it on
14:06:39 <sgallagh> I think mattdm wanted to raise some questions about readines
14:06:42 <sgallagh> *readiness
14:06:46 <nils> ah ok
14:07:06 <nils> like this: #info [mattdm] F29 readiness
14:07:22 <nils> ?
14:07:26 <asamalik> .hello2
14:07:27 <zodbot> asamalik: asamalik 'Adam Samalik' <asamalik@redhat.com>
14:07:39 <contyk> anything about the pkgkit blocker?
14:07:49 <contyk> maybe there's nothing to talk about
14:08:08 <nils> contyk, don't know, could fit under the F29 readiness umbrella
14:08:14 <mattdm> #info [mattdm] F29 readiness
14:08:15 <contyk> you're probably right
14:08:16 <mattdm> #info [mattdm] F29 readiness
14:08:30 <nils> not sure if this worked, you're not chair yet
14:08:39 <nils> #info [mattdm] F29 readiness
14:08:59 <nils> let's start
14:09:16 <nils> #topic How do we keep rawhide sane? (re: forcing people to latest modules)
14:09:20 <nils> #chair ignatenkobrain
14:09:20 <zodbot> Current chairs: ignatenkobrain nils
14:09:36 <nils> ignatenkobrain, that's yours
14:09:47 <nils> #link https://pagure.io/modularity/issue/108 Pagure Issue
14:10:19 <ignatenkobrain> Give me 5 mins
14:10:20 <ignatenkobrain> I'm in lift in hotel
14:10:27 <ignatenkobrain> Need to get into the room
14:10:31 <contyk> ok
14:10:32 <nils> ok, let's switch the topics around
14:10:34 <nils> #undo
14:10:34 <zodbot> Removing item from minutes: <MeetBot.items.Link object at 0x7ff78c3db6d0>
14:10:43 <nils> #topic F29 readiness
14:10:46 <nils> #chair mattdm
14:10:46 <zodbot> Current chairs: ignatenkobrain mattdm nils
14:10:52 <nils> tag, you're it :)
14:11:01 <mattdm> okay, so, I'm very worried about dnf
14:11:13 <mattdm> not just the existing bugs, but potential for unforseen trouble
14:11:14 <contyk> there should be a badge for that
14:11:19 <mattdm> contyk--
14:11:30 <nils> for being worried about dnf? :D
14:11:47 <mattdm> I'm wondering if we should push modularity for everyone to f30
14:11:59 <mattdm> which I know sucks but I'm wondering if it sucks least
14:12:07 <contyk> so
14:12:15 <contyk> for me there are two major features I'd like to see in f29
14:12:23 <mattdm> It seems like that would at least protect desktop users
14:12:27 <contyk> one was the metadata store in dnf, which was originally a blocker but isn't anymore
14:12:34 <contyk> it saddens me but I could live with that
14:12:47 <contyk> but that packagekit not working with the defaults properly, that surprised me
14:12:52 <mattdm> it's not a blocker just becuase it was impossible to get fixed, not because it's somehow become less of a big deal
14:12:56 <contyk> if that doesn't get fixed, I agree we should push the change to f30
14:13:00 <contyk> because there's nothing left
14:13:15 <sgallagh> contyk: There's two issues there, though. One technical, one policy.
14:13:32 * ignatenkobrain is back
14:13:34 <sgallagh> The technical ones is that the PackageKit implementation is wrong and should be fixed.
14:13:51 <nils> not precisely nothing, PK being able to update with modular content present is at least something
14:14:02 <sgallagh> The policy one is that we didn't adequately announce that default streams would be appearing in F29, so QA was caught unaware.
14:14:09 <mattdm> sgallagh, contyk so we need hughsie to fix that?
14:14:25 <mattdm> sgallagh: so... that policy thing in favor of delay?
14:14:32 <contyk> sgallagh: you mean default streams in general or those specific default streams?
14:14:40 <sgallagh> contyk: In general
14:14:42 <contyk> mattdm: that would be wonderful, yeah
14:15:05 <sgallagh> mattdm: I can't parse "that policy thing in favor of delay?"
14:15:11 <mattdm> contyk: I'm not shooting for wonderful at this point. It's more _do we have anyone else who can even do that_?
14:15:15 <contyk> sgallagh: alright; I guess I could get behind that, after the nitpicking yesterday
14:15:24 <contyk> mattdm: no ;)
14:15:31 <nils> contyk, well...
14:15:36 <contyk> mattdm: the decision was that we either fix this in pkgkit or we drop defaults from f29
14:15:36 <sgallagh> contyk: Possibly
14:15:46 <sgallagh> Neal suggested he might be able to look into that.
14:15:47 <mattdm> sgallagh: Sorry. It sounds like because the announcement was inadequate, we should not put it in F29
14:15:56 <nils> mattdm, I've volunteered looking into if I can fix it, but I haven't touched PK code in a while.
14:16:05 <mattdm> nils++
14:16:05 <zodbot> mattdm: Karma for nphilipp changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:16:10 <langdon> .hello2
14:16:11 <zodbot> langdon: langdon 'Langdon White' <langdon@redhat.com>
14:16:11 <contyk> well, okay, technically it could be some other person :)
14:16:17 <nils> #chair langdon
14:16:17 <zodbot> Current chairs: ignatenkobrain langdon mattdm nils
14:16:21 * langdon foolishly tried to install f29
14:16:22 <sgallagh> mattdm: I'm coming down slightly on that side, but it DOES have a negative impact.
14:16:28 <contyk> langdon: I'm sorry
14:16:30 <nils> Still, unless it's been changed completely I should be able to find my way around.
14:16:35 <sgallagh> We'd essentially lose DWM and Stratis from F29, which is Not Good (TM)
14:16:47 <sgallagh> (Or rather, we'd lose them without manual enablement)
14:17:17 <mattdm> sgallagh: Eh, I asked agrover some questions about setting up my system with stratis, and he was like "oh, wow, you're ahead of me -- it's not really ready for that kind of dogfooding yet"
14:17:19 <contyk> not having it fixed also means no more default streams, even for entirely new content
14:17:49 <mattdm> so I'm not worried about stratis on the desktop needing extra config to add m modular repo in f29 timeframe
14:17:51 <sgallagh> contyk: I think we're being asked not to add any default streams for F29... not just for F29 release.
14:18:35 <mattdm> Also, I need to get back to another meeting I am currently playing hooky from....
14:18:49 <mattdm> So mostly I just want to set this grenade down on the table...
14:18:52 <mattdm> pull the pin....
14:18:56 <mattdm> see what happens :)
14:19:02 <nils> why, thank you!
14:19:07 <sgallagh> Thanks for that...
14:19:15 <contyk> sgallagh: what do you mean by that?
14:19:48 <sgallagh> contyk: I mean that the proposal on the table is that F29 has no default streams for its lifetime. We introduce default streams as an F30+ feature.
14:19:58 <mattdm> you're welcome! bye-eeee
14:20:05 <nils> hah!
14:20:46 <langdon> we couldn't add default streams during f29? why not?
14:20:59 <nils> langdon, lack of proper implementation in PackageKit
14:21:09 <sgallagh> langdon: "we didn't adequately announce that default streams would be appearing in F29, so QA was caught unaware."
14:21:10 <nils> installs a package from the stream but doesn't enable it
14:21:26 <nils> yeah, that's the non-technical reason :)
14:21:32 <sgallagh> nils: That's the technical problem. But the fact that no one expected to test it is also a serious problem.
14:21:43 <nils> It is.
14:21:49 <contyk> sgallagh: yes, that's what worries me
14:21:58 <langdon> ahhh i see.. i was wondeing about the tech side.. which seems like something that could just be an update
14:22:47 <contyk> I think not having defaults in f29 will significantly hinder adoption
14:22:48 <nils> sgallagh, you mentioned that Neal could maybe help out (technical side I guess). Which Neal is it, Gompa?
14:22:51 <contyk> from both users and developers
14:22:54 <nils> ^^^
14:22:59 <sgallagh> nils: Yes
14:23:33 <sgallagh> contyk: I don't think it's going to be as much of a hindrance as you do.
14:24:04 <sgallagh> It's probably best if we have one general release where people tend towards opting in while we work out the hiccups.
14:24:29 <sgallagh> I do think we want to fix the PK situation in an update to F29 so we can *test* default streams (such as with an add-on repo)
14:24:46 <contyk> sgallagh: I thought that was f28
14:24:50 <langdon> yeah.. but.. no defaults means a lot of our assumptions about "how things work" are a bit borked.. hopefully there aren't any gaps
14:25:56 <asamalik> in theory, no defaults could be seen as a regression in Server which had a default for reviewboard
14:26:07 <nils> this, too
14:26:19 <sgallagh> asamalik: We actually reverted that before release because it broke Django
14:26:24 <sgallagh> IIRC
14:27:54 <asamalik> sgallagh: ah have we?
14:28:01 <sgallagh> I *think* so?
14:28:03 <nils> sgallagh, it's listed with default stream and profiles in the fedora-module-defaults repo.
14:28:04 * asamalik is on a phone and can't easily validate
14:28:07 <sgallagh> argh
14:28:11 <contyk> so with the only two modules that have defaults in f29, is there something we could do for QA to make them feel okay with this?
14:28:15 <contyk> assuming pkgkit gets fixed
14:28:18 <sgallagh> Oh right. We figured that out too late.
14:28:18 <nils> It's listed as "disabled" here, but that may be local config.
14:28:39 <sgallagh> Well, that was a bug, so I'd not call dropping it to be a regression :)
14:28:42 <contyk> because it's really just two modules/packages (+the concept)
14:29:00 <sgallagh> I think it's that last part (the concept) that has them nervous.
14:29:22 <contyk> what I'm trying to say that we can prove the concept works relatively easily
14:29:25 <nils> contyk, the tests re: defaults we did at the test day should be adaptable to PK, no?
14:30:46 <contyk> nils: can you remind me what tests those were?
14:31:15 <contyk> sgallagh: and thanks to that libgit2 "glitch" we even know you can be automatically updated from ursine to defaults
14:31:16 <sgallagh> contyk: Except that QA isn't likely to be happy without a full test plan describing expected behavior in all of the myriad of cases.
14:31:17 <nils> contyk, install a package that is only available from a module, check that it is installed and the stream gets enabled
14:31:47 <nils> sgallagh, yeah, but the test plan should be a matter of copy/paste from DNF, shouldn't it?
14:32:10 <sgallagh> nils: A test plan that would need to be fully approved and executed during Final Freeze?
14:32:29 <nils> Mhm, that would be cutting it close.
14:32:49 <sgallagh> nils: Go/No-Go is scheduled for the day after tomorrow.
14:33:12 <contyk> *No-Go ;)
14:33:16 <sgallagh> To do this is asking at minimum for a week's slip
14:34:26 <asamalik> so can this be a minimum week's slip vs. no defaults decision?
14:34:26 <langdon> we can get the dnf fixes in too then!
14:34:39 <nils> \o/
14:34:58 <asamalik> langdon: you're gonna code them? :P
14:34:59 <nils> One week is well into January, isn't it? :D
14:35:14 <langdon> nils: right?
14:35:21 <langdon> asamalik: no.. nils said he would
14:35:33 <sgallagh> asamalik: I can't represent QA on that question.
14:35:36 <contyk> nils volunteered to fix pkgkit only
14:35:44 <nils> Introducing Time-Of-The-Year-Zones as a feature for Fedora!
14:35:44 <contyk> langdon can still take dnf
14:35:48 <asamalik> sgallagh: fair
14:35:50 <sgallagh> I'm wearing this hat that doesn't fit too well because we don't have a rep here
14:37:07 <langdon> contyk: i have to rewrite libdnf in go first
14:37:11 <contyk> we could also say it's a minimum one week slip for f29 vs. six months slip for modularity
14:37:21 <contyk> but maybe that would sound too dramatic to some
14:37:40 <langdon> i think people will be more worried about the "max slip" than the min slip
14:37:49 <ignatenkobrain> so what about going back to my topic since we don't have much time left?
14:37:49 <contyk> there's no max
14:37:52 <nils> So the "ship this feature in PK as an update" is off the table?
14:38:40 <contyk> we can leave this for Thursday, yes
14:38:43 <contyk> see what happens before then
14:38:52 <sgallagh> nils: FWIW, our agreed-upon policy on Defaults is that they can only happen via Change Proposal in Fedora and only in advance of a release.
14:39:05 <sgallagh> So we can add the feature as an update, but we cannot add new default streams post-release.
14:39:12 <sgallagh> Unless we change that policy, of course.
14:39:14 <contyk> well, the policy is very fuzzy; that's why we have an epic to clarify it
14:39:36 * asamalik is checking into a hotel, might be lagging
14:39:39 <nils> sgallagh, understood (then again, we have some defaults already *shrugs*)
14:40:13 <contyk> I like to think the intent was to require changes for defaults changes, not for new content or moving content to modules without rebases
14:40:21 <langdon> and.. what does "having defaults" have to do with fixing pkgkit? e.g. if we had the fix shipped we don't nec. need to ship defaults...
14:40:23 <contyk> but that's what needs to be clarified
14:40:44 <langdon> but i would argue having an exception to the policy for the f29 cycle would make the most sense
14:40:53 <nils> langdon, we only need the fix in PK if there are defaults present. Which there are :).
14:40:54 <langdon> contyk: +1
14:40:55 <contyk> langdon: the bug in pkgkit has the same impact as the lack of modulemd store in dnf
14:41:40 <contyk> although the mechanism of the bug is very different
14:42:10 <contyk> if you install modular content before the fix lands, the module still won't be enabled
14:42:27 <contyk> and you might be upgraded to packages not coming from that stream
14:42:33 <contyk> potentially
14:42:39 <asamalik> yeah that default streams + change policy needs a revisit — the intention was only not to introduce breaking changes in a similar manner like traditional rpms could
14:43:00 * sgallagh nods
14:43:05 <contyk> so, let's continue this on Thursday?
14:43:07 <langdon> ohh.. the pk bug isn't limited to install a pkg from a default stream? it is any install?
14:43:11 <contyk> and discuss ignatenkobrain's topic?
14:43:15 <nils> yep
14:43:17 <langdon> whats thurs?
14:43:28 <sgallagh> Wait, no
14:43:32 <contyk> langdon: "no-go" + readiness meetings
14:43:35 <sgallagh> It must be limited to the default streaam
14:43:39 <langdon> ohh gotcha
14:43:42 <sgallagh> PK can't see the other streams at present, can it?
14:43:47 <contyk> nope
14:44:16 <contyk> but if I install stratis from the default and then enable an ursine stratis with higher NVR appears, I will be upgraded to it, despite "consuming" the stream
14:44:35 <nils> so, #info postponed to Go/No-Go meeting on Thursday?
14:45:35 <contyk> +1
14:45:48 <nils> NB: wasn't there at least the idea to not allow defaults for modules whose packages are available as ursine ones? I remember something from the reviewboard/django thing.
14:45:49 <contyk> well, the readiness meeting
14:45:57 <nils> ok "readiness" it is
14:46:22 <nils> #info postponed until the Fedora 29 readiness meeting on Thursday
14:46:23 <sgallagh> nils: Not allow defaults that would conflict with other defaults.
14:46:36 <nils> aah
14:47:00 <nils> #topic How do we keep rawhide sane? (re: forcing people to latest modules)
14:47:04 <nils> #chair ignatenkobrain
14:47:04 <zodbot> Current chairs: ignatenkobrain langdon mattdm nils
14:47:17 <ignatenkobrain> so tl;dr
14:47:28 <ignatenkobrain> imagine that f30 has libgit2 0.27 stream
14:47:34 <nils> #link https://pagure.io/modularity/issue/108
14:47:35 <ignatenkobrain> and f32 will have 0.28
14:47:43 <ignatenkobrain> how do we make sure that people are actually upgrading to that?
14:47:53 <contyk> why would we want them to upgrade?
14:48:00 <contyk> if 0.27 is still supported
14:48:04 <nils> That's counter the purpose of having streams.
14:48:25 <asamalik> so this might be a bit bigger thing to do right...
14:48:25 <sgallagh> Right, it's one of the *many* reasons I don't think you want something like libgit2 to have a default stream.
14:48:30 <ignatenkobrain> because that's a new default and ursine RPMs are built against that stream?
14:48:33 <sgallagh> Unless the default stream is something like "rolling"
14:48:45 <nils> ^^^^ or "latest"
14:48:50 <ignatenkobrain> sgallagh (IRC): if it won't have default stream, then you can't build ursine content
14:48:59 <contyk> agreed with sgallagh
14:49:02 <sgallagh> In other words, I think that 0.27 in F30 should be ursine and have modular alternatives
14:49:10 <ignatenkobrain> not that you can do it now, but I heard that there is a plan
14:49:14 <nils> ignatenkobrain, that would be solved by having a latest/rolling stream
14:49:17 <ignatenkobrain> sgallagh (IRC): this is called maintenance burden
14:49:29 <ignatenkobrain> why do I have to maintain ursine RPM and modular RPM?
14:49:36 <ignatenkobrain> I want to maintain just a module
14:49:42 <asamalik> we're transforming the monolithic OS into more independent parts
14:49:43 <langdon> perhaps a rawhide stream... that is rolling
14:49:43 <ignatenkobrain> nils (IRC): the question is what latest is for different platforms
14:49:53 <asamalik> and we need to discuss new approaches to "upgrades"
14:50:05 <langdon> well.. i think rawhide is a special case
14:50:07 <contyk> well, I understand ignatenkobrain's point and it's all part of the design
14:50:14 <contyk> but it's poor UX in practice
14:50:26 <langdon> it is development.. so the default streams should all be the "rawhide stream".. which is rolling..
14:50:32 <asamalik> it won't be just a "distro upgrade" with all the pieces upgrading at the same time
14:50:34 <ignatenkobrain> like when 0.28 gets released, people should not be forced to upgrade to it on F30, but rawhide users should (unless they specify that they don't)
14:50:45 <langdon> if someone wants to do something in rawhide with something sticky..they choose a diff stream
14:50:55 <ignatenkobrain> langdon (IRC): what do you do with released fedoras?
14:51:14 <contyk> ignatenkobrain: so we have a dnf command for resetting the stream to the default
14:51:18 <ignatenkobrain> do you make everyone on latest stream upgrade too?
14:51:18 <ignatenkobrain> that sounds really bad
14:51:31 <sgallagh> ignatenkobrain: So, Modularity has operated from the very beginning under something I call the Modularity Prime Directive, which is that no module stream is ever changed on the user without their initiating it.
14:51:43 <sgallagh> (Which also means "not a click-through acceptance")
14:51:52 <contyk> we could say that if you have upgrade issues related to consuming a stream like this, you either need to resolve that by doing something about the broken deps
14:51:55 <contyk> or reset the stream
14:51:56 <langdon> ignatenkobrain: no.. released fedora would work as it does.. default streams thta do their thing
14:52:02 <nils> sgallagh, you made a comment on Pagure re: upgrading default streams (i.e. which the user didn't set specifically) to new defaults in upgrade which sounds sensible to me
14:52:02 <contyk> but it's yet another hoop to jump through
14:52:07 <asamalik> yeah, the reason to have distro releases is compatibility over a period of time
14:52:12 <asamalik> it's the same for streams
14:52:20 <sgallagh> nils: Could you link it?
14:52:21 <asamalik> 28 and 29 are like streams of fedora
14:52:22 <ignatenkobrain> langdon (IRC): but if you say that default stream should be "latest", this latest will break ABI
14:52:32 <nils> https://pagure.io/modularity/issue/108#comment-535380
14:52:33 <langdon> the upgrade issue is still a *per release* issue.. like for each release the module stream maintainer will have to decide if people should be upgraded
14:53:23 <langdon> ignatenkobrain: no... i said a *special* stream in rawhide called "rawhide" that is rolling.. it isn't what is used in released.. at alpha or beta or something a cut is taken that is what is released as blah-stream for fXX
14:53:43 <sgallagh> nils: OK, thanks. Needed to remember what I was thinking, there.
14:53:57 <ignatenkobrain> langdon (IRC): so: I'm libgit maintainer and I want people to switch to 0.28 whenever that appears in F32. unless they explicitly told to keep it.
14:54:03 <ignatenkobrain> langdon (IRC): this is stupid
14:54:12 <ignatenkobrain> we want to move away from rawhide/f29/f28
14:54:13 <contyk> langdon: a scenario where I'm on rawhide, a rolling release, yet want to pin some software to specific versions feels entirely valid to me, too
14:54:15 <ignatenkobrain> branches
14:54:20 <sgallagh> I think what I meant was that `dnf system-upgrade` might need to add some options or become interactive to resolve cases where some defaults change or streams become unavailable.
14:54:35 <ignatenkobrain> we want to have just 10, 11, 12 streams (proabbly some latest ones too)
14:54:35 <contyk> sgallagh: +1
14:54:41 <asamalik> sgallagh: that could be one of the options yes
14:54:47 <ignatenkobrain> sgallagh (IRC): it is not only system-upgrade
14:54:52 <ignatenkobrain> look at rawhide users
14:55:00 <ignatenkobrain> at some point, defaults might change in rawhide
14:55:12 <ignatenkobrain> so the dnf update or dnf distro-sync should be fixed
14:55:18 <asamalik> if you have a default stream of something which changes, it would ask "do you want to keep the stream? or keep the default?"
14:55:29 <asamalik> it could even remember that for next time
14:55:34 <contyk> ignatenkobrain: yes but we still don't want to automatically switch streams, that really defeats the purpose
14:55:59 <ignatenkobrain> I remember contyk saying that implicitly enabled stream and explicitly is a different thing in dnf. This is actually not true.
14:56:01 <langdon> i think this is a failure of using irc for a very dense conversation w/ lots of different points..
14:56:12 <contyk> ignatenkobrain: it is
14:56:19 <nils> I'm thinking a "switch default streams if not expressly override" flag for dnf could be worthwhile having for Rawhide.
14:56:22 <sgallagh> A general flag on DNF like `--reset-module-defaults` (and a more fine-grained one) might be acceptable
14:56:22 <ignatenkobrain> asamalik (IRC): the problem is that when you switch stream, you don't know if it will break anything ;)
14:56:33 <contyk> sgallagh: we have that per module
14:56:40 <contyk> dnf module reset, I believe
14:56:40 <asamalik> we have 4 mins... proposal: instead of finding solution, let's find a way how to find a solution...
14:56:41 <nils> Which could be "on" in Rawhide and "off" in releases.
14:56:44 <ignatenkobrain> because switching streams in dnf == just change available rpms
14:56:50 <ignatenkobrain> then you do dnf distro-sync and it fails
14:56:52 <asamalik> specific proposals? user survey with them?
14:56:52 <ignatenkobrain> so you try to switch something else
14:57:00 <sgallagh> contyk: I meant as part of an update/distro-sync/etc. action
14:57:02 <ignatenkobrain> and until you find working combination
14:57:07 <sgallagh> In case you don't know ahead of time what may change
14:57:16 <contyk> a jit.si breakout? :)
14:57:29 <nils> why not
14:57:41 <langdon> so.. rawhide would, by default, be based on streams that are rolling, probably called rawhide as well.. you could, in rawhide, always change streams from default.. when we are close to a release, we snap the rawhide stream to be the next stream required for the release; next: each stream that wants to provide an upgrade/migration during a new release of fedora needs to decide it is nec. and how to approach/release it
14:58:21 <ignatenkobrain> langdon (IRC): how is it different than having f28/f29/rawhide streams?
14:58:29 <ignatenkobrain> because this is what you are proposing here
14:58:30 <nils> langdon, that makes the "install Rawhide but switch over to branched" use case a little cumbersome, then you'd have to change all streams to their respective defaults
14:58:50 <langdon> asamalik, sgallagh you still need unattended upgrades.. so .. unless you passed "-i" or something to the upgrade process it shoudl a) follow new defaults b) not upgrade if you had an explicit non-default
14:58:51 <contyk> proposal: let's conitnue the discussion in the ticket and have a jit.si breakout sometime next week
14:59:01 <nils> +1
14:59:08 <asamalik> +1
14:59:19 <sgallagh> langdon: I'm not trying to design it here. Just toss out some high-level ideas
14:59:21 <langdon> contyk: +1
14:59:28 <sgallagh> +1
14:59:41 <contyk> ignatenkobrain: ?
14:59:49 <ignatenkobrain> +1
14:59:55 <langdon> ignatenkobrain: i am gonna hold my reply to the jitsi if i can.. im not sure myfingers can type enough :)
14:59:56 <asamalik> contyk: do you wanna do a brainstorming? or maybe people coming with specific proposals and giving like 3 min pitches and then discussion?
15:00:18 <contyk> probably more like brainstorming but we might get somewhere in the ticket before then
15:00:22 <ignatenkobrain> just don't do it today/tomorrow, I'm pretty busy these days ;)
15:00:23 <nils> brainstorming IMO
15:00:29 <contyk> ignatenkobrain: next week :)
15:00:48 <nils> next week sounds good
15:00:50 <contyk> nils: would you make a whenisgood form for this?
15:01:01 <nils> I don't even know what whenisgood is :)
15:01:08 <nils> like doodle?
15:01:19 <contyk> yeah, http://whenisgood.net/
15:01:37 <contyk> or something else is fine too
15:01:47 <nils> okay, who is interested in this, everybody who chimed up in the last quarter hour?
15:01:55 <langdon> probably
15:02:10 <asamalik> nils: i am
15:02:15 <contyk> yeah
15:02:36 <contyk> at least we'll try this scheduling / jit.si process as well :)
15:02:39 * sgallagh nods
15:02:52 <nils> so: ignatenkobrainm langdon asamalik sgallagh contyk
15:02:58 <nils> have I forgotten anybody?
15:03:10 <contyk> nils: yourself
15:03:19 <nils> hah, I wouldn't have :)
15:03:56 <contyk> info?
15:03:59 <contyk> and let's close this?
15:04:16 <nils> sure, how long do we want to take this, 1 hour?
15:04:25 <contyk> sounds good
15:05:01 <nils> #info postponed for face to face over jit.si next week, scheduling via whenisgood.net
15:05:04 <nils> ^^?
15:06:41 <nils> Ok, no objections :)
15:06:45 <contyk> +1
15:07:02 <nils> #action nils send out a whenisgood form link to the usual suspects
15:07:19 <nils> I guess we'll skip open floor this time :)
15:07:38 <contyk> looking forward to Thursday
15:07:55 <nils> heh
15:08:04 <nils> ok, thanks everybody!
15:08:07 <nils> #endmeeting