15:43:11 <sgallagh> #startmeeting Modularity Bug Triage
15:43:11 <sgallagh> #meetingname modularitybugs
15:43:11 <sgallagh> #topic Init
15:43:11 <zodbot> Meeting started Fri Nov 17 15:43:11 2017 UTC.  The chair is sgallagh. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:43:11 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:43:11 <zodbot> The meeting name has been set to 'modularity_bug_triage'
15:43:11 <zodbot> The meeting name has been set to 'modularitybugs'
15:43:26 <mizdebsk> mprahl: i have a quite big module (~210 components) for which it's not possible to determine build order reliably - everything forms a big dependency cycle
15:43:47 <mizdebsk> i used to keep resubmitting module until it was built, but it's not possible any longer :/
15:44:05 <sgallagh> #info We will go through the bug list at https://bugzilla.redhat.com/showdependencytree.cgi?id=1492243&hide_resolved=1 and ensure that each BZ is either assigned or removed from committment to F27 Modular GA
15:45:05 <langdon> geppetto: you around?
15:45:27 <sgallagh> #chair langdon geppetto
15:45:27 <zodbot> Current chairs: geppetto langdon sgallagh
15:45:38 <langdon> .hello2
15:45:39 <zodbot> langdon: langdon 'Langdon White' <langdon@redhat.com>
15:45:43 <sgallagh> .hello2
15:45:43 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
15:45:49 <mprahl> mizdebsk: Sorry, I'm not understanding the value of it being tagged in your situation. Could you elaborate a bit more please?
15:46:27 <sgallagh> OK, we will go through only the ones marked as NEW
15:46:49 <mizdebsk> mprahl: is private message fine by you? i don't want to disturb the meeting
15:46:53 <sgallagh> #topic BZ 1510488
15:46:55 <sgallagh> .bug 1510488
15:46:55 <zodbot> sgallagh: Bug 1510488 – review all modules to check if default profile belongs to stream - https://bugzilla.redhat.com/1510488
15:46:58 <mprahl> mizdebsk: Sure thing
15:47:18 <sgallagh> langdon: I think this one is clearly in your team's wheelhouse
15:47:24 <langdon> sgallagh: yep
15:47:27 <sgallagh> And is definitely something that needs to be done
15:47:57 <sgallagh> According to your last comment, you want geppetto to look into this.
15:48:13 <sgallagh> So we can mark this as ASSIGNED (which will double as "triaged")?
15:48:20 <sgallagh> err "Triaged+Committed"
15:48:38 <langdon> sgallagh: yeah.. i think i meant to and spaced
15:48:48 <sgallagh> No problem; we also didn't have a policy in place.
15:48:59 <sgallagh> So, last question: due date?
15:49:17 <sgallagh> I don't think this *must* be done before the Freeze.
15:49:27 <langdon> let's say tuesday anyway
15:49:36 <sgallagh> In fact, I think this might be something we want to keep open until just before Go/No-Go
15:49:47 <langdon> sgallagh: ??
15:49:52 <sgallagh> Since we want to make sure whatever we're shipping at the end is correct
15:49:57 <langdon> like make all the edits we find at once?
15:50:15 <langdon> maybe a separate bug to review them before go/no-go?
15:50:16 <sgallagh> Well, more treat this as an ongoing bug that is only finished when we release
15:50:28 <sgallagh> Or make this a tracker for specific examples
15:51:10 <langdon> i kinda feel like we should have a tracker for this.. and a "process".. it is kinda like comps.. we need this and variants-modular.xml to be reviewed at the last minute..
15:51:13 <sgallagh> langdon: How do you want to handle this?
15:51:19 * sgallagh nods
15:51:47 <langdon> what would be similar in traditional fedora? that we could model the process on?
15:51:53 <sgallagh> As far as a process, once we hit Freeze I'll try to be more rigorous with the code review policy
15:52:08 <sgallagh> langdon: We really don't have an analog in traditional Fedora
15:52:28 <langdon> so ... maybe it is on the release checklist for qa?
15:52:37 <sgallagh> That's not a bad idea
15:52:45 <langdon> adamw: you around?
15:53:07 <sgallagh> It's maybe a little early for him. (PST)
15:53:34 <langdon> proposed #action: langdon to follow up with fedora qa about adding review of variants-modular.xml & system profile to qa release checklist
15:53:37 <langdon> ?
15:53:53 <sgallagh> Well, they shouldn't have to review variants-modular.xml
15:54:01 <langdon> someone should
15:54:10 <langdon> and it needs to map to system profile
15:54:16 <sgallagh> From QA's perspective, they should probably confirm that `dnf module list` shows the right values
15:54:27 <sgallagh> variants-modular.xml is input, not output.
15:54:52 <sgallagh> QA should REALLY only be responsible for the output being correct. If it is *not*, then it's up to eng to fix the incorrect input
15:55:19 <langdon> ohh i meant.. make sure everything in variants has a default in system profile
15:55:20 <sgallagh> langdon: When these don't match up, `dnf module list` output is wrong (in an easy-to-spot way)
15:55:32 <sgallagh> langdon: Except that some shoudn't :)
15:55:37 <langdon> true
15:55:43 <sgallagh> langdon: Pure-library modules should have no default profile, at least
15:55:54 <langdon> meh.. maybe we need to think about this some more?
15:55:59 <sgallagh> Default stream should match though
15:56:11 <sgallagh> And that's easily identified through the `dnf module list` output
15:56:51 <sgallagh> So I think your idea of adding this to the release criteria is a really good one
15:57:04 <langdon> yeah... we just need the "mechanics"
15:57:06 <sgallagh> QA will spot when it's *wrong* and we can figure out which bit is wrong
15:57:32 <langdon> how do they know if the module list is correct though?   we have been having this problem in f27..
15:57:54 <sgallagh> langdon: They don't have to know if it's *correct*, just if it's *consistent*
15:57:57 <sgallagh> (In this specific case)
15:57:57 <langdon> or do you just mean "if it is there, it should a) have a default, b) have a matching profile"
15:58:00 <langdon> gotcha
15:59:17 <sgallagh> #action langdon and geppetto will amend the proposed release criteria for Modularity to describe the expected output of `dnf module list` wrt default streams and profiles.
15:59:22 <sgallagh> (Reasonable?)
15:59:44 <langdon> yeah.. i think so
15:59:48 <sgallagh> ok
16:00:15 <sgallagh> OK, let's move on to the next one.
16:00:38 <sgallagh> #topic BZ 1511693
16:00:39 <sgallagh> .bug 1511693
16:00:39 <zodbot> sgallagh: Bug 1511693 – Server Software Selection screen shows Everything - https://bugzilla.redhat.com/1511693
16:01:27 <sgallagh> So, this is a compose problem. In traditional Fedora, something (as yet unknown to me) in the Pungi process takes comps.xml and trims it down to only the content that is actually available
16:01:53 <sgallagh> In Modular composes right now, the comps.xml is being dropped in as-is, which results in displaying all of the content available to non-modular Fedora
16:01:59 <langdon> yeah.. i wonder if dgilmore or dcantrell can help here
16:02:12 <sgallagh> Which is misleading and problematic. (It also silently just ignores content it can't actually install)
16:02:45 <langdon> well.. worse than that.. it shows it to you, lets you choose it, then ignores it, right?
16:03:04 <sgallagh> Right
16:03:14 <sgallagh> So we have two possible choices here.
16:03:23 <langdon> i saw in the ticket
16:04:23 <langdon> i think we should try and run down option #1... aka, figure out how traditional makes this automatically work and clone it
16:04:45 <sgallagh> Well, first choice to make: does this block GA?
16:05:06 <sgallagh> My gut says yes, but it may be really tricky to solve "correctly"
16:05:17 <sgallagh> (option #1 being "correctly")
16:05:25 <langdon> well.. fixing it definitely blocks ga .. but i dont think #1 does
16:06:05 <langdon> we have months to do it properly and a few hours of ugly xml if necessary
16:06:06 * sgallagh nods
16:06:14 <sgallagh> We don't have months
16:06:21 <langdon> i meant for f28
16:06:35 <langdon> we don't need to modify it between GA and f28 beta, right?
16:06:50 <sgallagh> Sorry, I misunderstood what you were saying
16:07:02 <sgallagh> Right, if we hand-edit, we have all of F28 to figure out the right answer
16:07:20 <sgallagh> That hand-editing may be less fun than it seems, though.
16:07:35 <sgallagh> But we'll manage if we must
16:07:42 <sgallagh> OK, I guess I'll self-assign this one.
16:07:45 <sgallagh> And we'll commit to it.
16:07:52 <langdon> ohh.. i am pretty confident in the no fun..
16:07:59 <langdon> this also is something i can do..
16:08:18 <sgallagh> #info We commit to having at least the manually-edited XML for GA, with a preference for automatically-managed.
16:08:21 <langdon> how do you want assign the "run down #1" part?
16:08:24 <sgallagh> #action sgallagh will work this one.
16:08:28 <sgallagh> I'll take it
16:08:37 <langdon> ohh gotcha.. didn't take that away
16:08:59 <langdon> ill definitely be on for the hand edit part if nec... your skills are btter spent elsewhere
16:09:18 <sgallagh> langdon: comps.xml is fairly complex. Do you have experience with it?
16:09:33 <sgallagh> (in the same way that the sun is "a bit warm")
16:09:34 * walters thinks anaconda should stop trying to have too much of a UI, if you want to install modules, have a terminal you can fire up that runs in the target root and you can just `dnf install` interactively
16:09:40 <langdon> sgallagh: no... but it is just a file.. you can explain it to me in 10m .. and we can see what happens
16:09:44 <walters> the same way you do post-install
16:09:53 <langdon> :)
16:09:59 <sgallagh> ... perhaps
16:10:29 <sgallagh> ok, let's move on for now
16:10:42 <sgallagh> #info langdon volunteers to hand-edit the XML if it comes to that.
16:10:47 <sgallagh> Saving that for posterity :)
16:10:54 <langdon> walters: or... even if you want to keep graphical.. use a "software installer" (dnf, gnome software, cockpit, what have you) rather than it being the same app
16:11:01 <langdon> sgallagh: lol
16:11:09 <sgallagh> #topic BZ#1512540
16:11:11 <sgallagh> .bug 1512540
16:11:11 <zodbot> sgallagh: Bug 1512540 – python3 has a wrong stream and fails installation - https://bugzilla.redhat.com/1512540
16:11:26 <sgallagh> whoops, this one is already on POST
16:11:29 <langdon> actually, i don't know if you can install software with cockpit.. seems like something you should be able to do :)
16:11:31 <sgallagh> #info Already fixed
16:11:33 <walters> right, which actually all quickly snowballs into anaconda being an app in a desktop system with a browser and terminal even for servers
16:11:40 <langdon> my favorite kind of bug
16:11:48 <sgallagh> langdon: You can update, so installing comes next
16:12:06 * langdon doesn't use cockpit all that often
16:12:12 <sgallagh> #topic BZ#1513864
16:12:13 <sgallagh> .bug 1513864
16:12:14 <zodbot> sgallagh: Bug 1513864 – failed to start dnf makecache - https://bugzilla.redhat.com/1513864
16:12:38 <sgallagh> I'm not sure this is critical for GA, but it's an ugly log message
16:12:55 <langdon> this is weird
16:13:16 <langdon> are we missing some dnf dep?
16:13:20 <sgallagh> I'm inclined to assign this to ignatenkobrain, but take it off our committed list.
16:13:27 <sgallagh> langdon: Not enough info in the bug right now to say
16:13:47 <ignatenkobrain> having logs would be handful
16:13:57 <ignatenkobrain> because right now it is missing any information
16:13:59 <sgallagh> ignatenkobrain: Sounds trivial to repro, though
16:14:03 <langdon> web ui == cockpit in this bug?
16:14:07 <sgallagh> yes
16:14:20 <langdon> gotcha
16:14:36 <langdon> so ignatenkobrain can we assign it to you?
16:14:50 <ignatenkobrain> you can :)
16:15:07 <langdon> will it get fixed?!? ;)
16:15:09 <sgallagh> langdon: It doesn't appear to negatively impact operation, so I'd say we don't *commit* to it
16:15:28 <langdon> well.. a major use case for cockpit doesn't work..
16:15:42 <ignatenkobrain> langdon: without knowing logs it is impossible to say
16:16:02 <sgallagh> langdon: What do you mean?
16:16:02 <ignatenkobrain> it might be trivial fix, but might be huge problem. I have no idea without logs
16:16:20 <sgallagh> langdon: Cockpit isn't broken.
16:16:31 <sgallagh> Cockpit's log viewer showed a service failing to start.
16:16:33 <langdon> well.. maybe i am not understanding the bug correctly.. but it seems you can't view the system logs tab of cockpit
16:16:35 <sgallagh> It's behaving properly :)
16:16:43 <langdon> ohhh.. not how i read it
16:16:52 <langdon> i thought the logs weren't loading because of this bug
16:17:05 <langdon> which seemed weird.. but hey.. its a bug
16:17:05 <sgallagh> No, I'm pretty sure it's what I said
16:17:14 <langdon> ok.. then yes.. not committed
16:17:15 <sgallagh> Because the results list shows it the way Cockpit would display it
16:19:03 <sgallagh> Done
16:19:22 <sgallagh> #topic BZ#1513943
16:19:24 <sgallagh> .bug 1513943
16:19:24 <zodbot> sgallagh: Bug 1513943 – mysql fails installation missing libnuma - https://bugzilla.redhat.com/1513943
16:20:02 <sgallagh> This seems like a clear blocker to me... the MySQL module can't install mysql-server
16:20:24 <langdon> that seems suboptimal
16:20:40 <sgallagh> I don't think you can even *see* suboptimal through that much water.
16:20:51 <langdon> ha
16:21:00 <langdon> let's assign it to karsten
16:21:19 * karsten hides
16:21:23 <langdon> ha
16:21:38 <langdon> karsten: you can see if you can reassign it to hhorak if you like
16:21:53 <langdon> would like the owners to own things
16:21:56 <sgallagh> OK, so blocker?
16:22:00 <karsten> looks like an easy one
16:22:02 <langdon> yeah
16:22:05 <karsten> ah
16:22:09 <sgallagh> karsten: Famous last words :)
16:22:13 <langdon> point
16:22:47 <sgallagh> OK, assigned to karsten for now. Thanks
16:22:52 * langdon is kinda surprised mysql is even in fedora.. isn't the core closed source?
16:23:18 <sgallagh> langdon: No, community-mysql is completely F/OSS
16:23:47 <langdon> ohh. right.. i think you can use one of the non-default drivers which are open
16:23:49 <sgallagh> #topic BZ#1514367
16:23:50 <sgallagh> .bug 1514367
16:23:50 <zodbot> sgallagh: Bug 1514367 – dnf autocompletion fails - https://bugzilla.redhat.com/1514367
16:24:18 <sgallagh> I think we skipped the inclusion of bash-completion in the Modular distro entirely.
16:24:31 * langdon points out both mysql rpms are listed as orphaned :/
16:24:41 <langdon> ha.. oops
16:24:47 <sgallagh> For the sake of ease-of-use, this is probably something we may want to include
16:24:58 <langdon> yes.. i can't use linux without it :)
16:25:12 <sgallagh> langdon: https://koji.fedoraproject.org/koji/buildinfo?buildID=991063 was built last month...
16:25:20 <ignatenkobrain> can you ? ;)
16:25:40 <sgallagh> .whoowns community-mysql
16:25:40 <zodbot> sgallagh: mschorm
16:25:42 <langdon> sgallagh: just going by src.fp.o
16:25:45 <ignatenkobrain> I'm -1 for autocompletion being blocker
16:25:51 <ignatenkobrain> strongly
16:26:06 <langdon> sgallagh: i think i was looking at "mysql" .. wrong rpm
16:26:14 <sgallagh> langdon: Yeah, I was just going to tell you that
16:26:47 <sgallagh> ignatenkobrain: Well, we're not really talking blockers, more "things we're committed to releasing"
16:26:57 <sgallagh> Fedora QA gets to decide what actually *blocks*
16:27:15 <sgallagh> If we don't get it done in time for release and QA doesn't care... *shrug*
16:27:19 <karsten> having no autocompletion is a very welcome feature, one of the first things I uninstall
16:27:27 <langdon> ha
16:27:56 <sgallagh> karsten: I don't think anyone said it had to be mandatory.
16:27:58 <ignatenkobrain> since yesterday first thing I do is install zsh :)
16:28:01 <sgallagh> Just that not offering it would probably be BAD
16:28:25 <ignatenkobrain> note that IIRC RHEL server comes without bash-completion
16:28:26 <sgallagh> And I *do* think that it improves usability and should likely be part of the default install.
16:28:32 <langdon> yeah... i think we should try and get it in.. it is just adding a few packages to platform, right?
16:28:47 <sgallagh> langdon: Might even be a leaf package.
16:28:49 <sgallagh> I need to check.
16:28:52 <sgallagh> I guess I'll take this one
16:29:12 <langdon> i think it is bash-completion and then all the completions are in the respective content rpms
16:29:26 <sgallagh> Usually, yes
16:30:43 <sgallagh> #topic BZ#1514445
16:30:44 <sgallagh> .bug 1514445
16:30:45 <zodbot> sgallagh: Bug 1514445 – "locate" is not able to find file - https://bugzilla.redhat.com/1514445
16:31:00 <langdon> btw.. i can not repro 1513864 (dnf makecache thing)
16:31:18 <sgallagh> langdon: This is one of those tools that might belong in a system-tools module
16:31:28 <langdon> yeah.. +1
16:31:29 <threebean> mizdebsk, ignatenkobrain: want to have a look at https://pagure.io/fm-orchestrator/pull-request/800 ?
16:31:41 <langdon> wanted screen in there too
16:32:07 <mizdebsk> threebean: already saw it, looks good to me
16:32:31 <langdon> sgallagh: im gonna assign this to asamalik[m]
16:32:56 <sgallagh> langdon: What's the plan?
16:33:02 <sgallagh> Create a new module for tools?
16:33:05 <karsten> sgallagh:  numactl seems to be a good candidate for platform. Lots of packages require it and its own requirements are minimal
16:33:23 <sgallagh> karsten: File a BZ and we'll discuss it in one of these triages :)
16:33:30 <langdon> sgallagh: well.. revive system-tools.. and put this and screen (at least) in it
16:33:35 <sgallagh> (file against fedora-modular-release)
16:33:41 <karsten> sgallagh:  https://bugzilla.redhat.com/1513943
16:33:44 <karsten> ;-)
16:34:06 <langdon> sgallagh: does that make sense to you? (re: system-tools)
16:34:07 <sgallagh> oh, hmm
16:34:31 <sgallagh> langdon: Seems like a reasonable plan to me
16:35:10 <langdon> sgallagh: updated ticket
16:35:34 <sgallagh> karsten: Let's discuss numactl after the meeting
16:36:07 <sgallagh> langdon: Okay, and we are committing to system-tools, then?
16:36:07 <karsten> ping me pls, I'll try to stay online for a while
16:36:17 <langdon> sgallagh: ohh.. i didn't mention anything about system-tools blocking the release..
16:36:30 <langdon> i would say "yes" but non-blocker..
16:36:55 <langdon> i had already been discussing reviving system-tools with adam this week
16:37:03 * sgallagh nods
16:37:56 <sgallagh> OK, that was the last one currently on the list.
16:38:16 <langdon> sgallagh: should completion be in plat or system-tools?
16:38:28 <langdon> actually think it should be in plat
16:38:33 <langdon> too much of a dep
16:38:38 <sgallagh> langdon: platform. It should rev with bash
16:38:42 <langdon> +1
16:39:35 <langdon> so.. endmeeting?
16:43:16 <langdon> sgallagh: ping?
16:43:16 <zodbot> langdon: Ping with data, please: https://fedoraproject.org/wiki/No_naked_pings
16:43:36 <sgallagh> #endmeeting