14:00:15 <FranciscoD> #startmeeting NeuroFedora 2019-01-11
14:00:15 <zodbot> Meeting started Fri Jan 11 14:00:15 2019 UTC.
14:00:15 <zodbot> This meeting is logged and archived in a public location.
14:00:15 <zodbot> The chair is FranciscoD. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:15 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:00:15 <zodbot> The meeting name has been set to 'neurofedora_2019-01-11'
14:00:26 <FranciscoD> #meetingname neurofedora
14:00:26 <zodbot> The meeting name has been set to 'neurofedora'
14:00:36 <FranciscoD> #chair gicmo pac23 mhough blackfile
14:00:36 <zodbot> Current chairs: FranciscoD blackfile gicmo mhough pac23
14:00:43 <FranciscoD> #topic Roll call
14:00:48 <FranciscoD> .hello ankursinha
14:00:49 <zodbot> FranciscoD: ankursinha 'Ankur Sinha' <sanjay.ankur@gmail.com>
14:01:10 <blackfile> .fas blackfile
14:01:11 <zodbot> blackfile: blackfile 'Luis Manuel Segundo' <luis@blackfile.net>
14:01:18 * blackfile Panama
14:01:27 <FranciscoD> .localtime FranciscoD
14:01:28 <zodbot> FranciscoD: User "FranciscoD" doesn't exist
14:01:31 <FranciscoD> uh
14:01:34 <FranciscoD> .localtime ankursinha
14:01:35 <zodbot> FranciscoD: The current local time of "ankursinha" is: "14:01" (timezone: Europe/London)
14:01:56 <FranciscoD> #info IRC meeting commands: https://fedoraproject.org/wiki/Meeting:Guide
14:02:19 <FranciscoD> Let's wait a few minutes for the other to join if they can make it :)
14:02:27 <blackfile> ok
14:02:44 <pac23> ok
14:03:06 <gicmo> ko
14:03:26 <FranciscoD> lol XD
14:03:31 * FranciscoD wonders if that was intentional :P
14:03:42 <pac23> lol
14:03:57 <zbyszek> Hi
14:04:02 <gicmo> FranciscoD: it was (-;
14:04:06 <FranciscoD> #chair zbyszek
14:04:06 <zodbot> Current chairs: FranciscoD blackfile gicmo mhough pac23 zbyszek
14:04:08 <gicmo> o/ zbyszek
14:04:10 <FranciscoD> hello zbyszek :)
14:04:25 <pac23> hi zbyszek
14:04:27 <FranciscoD> I think the ones that had filled in the whenisgood and could make it are here
14:04:34 <FranciscoD> Before we get on:
14:04:37 <FranciscoD> #topic Joining the team
14:05:30 <FranciscoD> #info We need package maintainers, testers, doc writers, users---> there are so many ways of getting involved
14:05:49 <FranciscoD> #info To help with packaging, please join the neuro-sig FAS group, and then log out and back in to src.fp.o once your membership is approved
14:06:10 <FranciscoD> #info To join the group on pagure (where we maintain issues), please drop any of us a ping and we'll add you
14:06:20 <blackfile> must execute the command .fas <username> for the meeting
14:07:07 <FranciscoD> #info Our channels: #fedora-neuro on IRC, https://t.me/NeuroFedora on Telegram, neuro-sig@lists.fp.o is our ML
14:07:14 <FranciscoD> The telegram and IRC channels are bridged
14:07:25 <FranciscoD> I think that's the main tldr of how we're currently functioning
14:07:57 <FranciscoD> #info https://pagure.io/neuro-sig/NeuroFedora -> housekeeping repo
14:08:05 <FranciscoD> #info https://pagure.io/neuro-sig/documentation -> documentation repo
14:08:24 <zbyszek> I see 7 people in https://admin.fedoraproject.org/accounts/group/view/neuro-sig
14:08:26 <FranciscoD> blackfile: it isn't compulsory: as you say things, zodbot will note it all down
14:08:56 <blackfile> ok
14:09:01 <FranciscoD> zbyszek: igor isn't actively working on neurofedora now
14:09:20 <FranciscoD> neither is ilgrad. I think they were working on it when it had first started.
14:09:24 <FranciscoD> With mhough
14:09:35 <gicmo> let me join the neuro-sig group, I don't think I have done that
14:10:04 <FranciscoD> gicmo: added you ;)
14:10:14 <gicmo> hah, so quick!
14:10:25 <FranciscoD> I was just looking at the page :)
14:10:50 <gicmo> thanks!
14:10:50 <FranciscoD> also added you to the pagure group now
14:11:00 <zbyszek> Lots of stuff to package
14:11:01 <FranciscoD> zbyszek: do you think we need to remove the inactive members?
14:11:18 <gicmo> ❤️
14:11:25 <zbyszek> No, I think it doesn't matter, and people can become active again
14:11:35 <FranciscoD> Yeh, that's what I thought. We'll leave them be.
14:11:51 <FranciscoD> I tried to come up with some sort of agenda for the meeting. Here are some tickets I put up:
14:11:56 <FranciscoD> #info Tickets: https://pagure.io/neuro-sig/NeuroFedora/issues?tags=S%3A+Next+meeting
14:12:36 <FranciscoD> #info Additional agenda item: prioritise packages so we have some order in which to go about them
14:13:01 <FranciscoD> Currently, we've been pretty much picking them up at random (and I've been working through the common simulator chains)
14:13:27 <FranciscoD> Should we go through the tickets quickly?
14:13:34 <gicmo> sounds good
14:13:34 <pac23> sure
14:13:49 <FranciscoD> #info Poster at CNS: https://pagure.io/neuro-sig/NeuroFedora/issue/189
14:14:18 <FranciscoD> #info Annual organisation for computational neuroscience conference is at Barcelona in July this year: https://www.cnsorg.org/cns-2019
14:14:34 <FranciscoD> I intend to submit a poster---that'll get us more visibility within the community.
14:14:47 <gicmo> cool!
14:14:53 <FranciscoD> #info Everyone that contributes in any way will be a mentioned in the author list
14:15:06 <FranciscoD> I'll work on an abstract shortly. The registration has just opened
14:15:14 <pac23> FranciscoD can i talk to someone i know regarding designing the poster,will see if she volunteers
14:15:58 <FranciscoD> pac23: it'll be a conference poster--they usually have standard formats. I'll dig up one of mine from last year after the meeting :)
14:16:11 <pac23> okay
14:16:20 <FranciscoD> #info https://pagure.io/neuro-sig/NeuroFedora/issue/188 -> Own neurofedora.org?
14:16:31 <FranciscoD> would this be worth doing?
14:16:50 <FranciscoD> or maybe we can use neuro.fp.org instead? That'll probably be quite easy for infra to set up
14:17:17 <pac23> neuro.fp.org
14:17:18 <fm-neuro> pagure.issue.assigned.added -- ankursinha assigned ticket neuro-sig/NeuroFedora#189 to ankursinha https://pagure.io/neuro-sig/NeuroFedora/issue/189
14:17:18 <gicmo> neuro debian just has "http://neuro.debian.net/"
14:17:24 <fm-neuro> pagure.issue.comment.added -- ankursinha commented on ticket neuro-sig/NeuroFedora#189: "Poster at CNS" https://pagure.io/neuro-sig/NeuroFedora/issue/189#comment-549247
14:17:36 <FranciscoD> gicmo: yes, I plagiarised their idea
14:17:40 <FranciscoD> quite shamelessly XD
14:17:49 <gicmo> Sharing is caring! (-:
14:17:50 <zbyszek> I think neuro.fp.o is OK
14:18:05 <blackfile> I think that  neuro.fp.org is better
14:18:14 <FranciscoD> awesome, that
14:18:28 <FranciscoD> #agreed Use neuro.fp.o (+5, -0)
14:18:55 <pac23> do we have a gh pages site ? should do that too
14:19:08 <FranciscoD> #info https://pagure.io/neuro-sig/NeuroFedora/issue/152 -> Organisational blog on neurofedora.github.io?
14:19:10 <FranciscoD> pac23: ^
14:19:26 <FranciscoD> #info We do have a github organisation: https://github.com/neurofedora
14:19:37 <FranciscoD> Please e-mail me your github usernames, and I'll add you all to it
14:19:50 <pac23> ok
14:19:55 <FranciscoD> May need a bit of a cleanup. Looks like it was used for the packaging bit when neurofedora initially started
14:20:14 <fm-neuro> pagure.issue.comment.added -- zbyszek commented on ticket neuro-sig/NeuroFedora#152: "Oganizational blog on neurofedora.github.io" https://pagure.io/neuro-sig/NeuroFedora/issue/152#comment-549248
14:21:01 <FranciscoD> Do we need a blog? I currently write updates on my private blog every week or so: https://ankursinha.in/tag/neurofedora/
14:21:30 <pac23> dedicated blog/site would be nice,
14:21:31 <gicmo> How about a planet? like planet.gnome.org? where we can collect all blog posts with a certain tag/label
14:21:33 <FranciscoD> I simply collate whatever activity the SIG has done, and enumerate it in a blog post
14:21:47 <zbyszek> FranciscoD: I think that's good enough
14:22:01 <FranciscoD> gicmo: I have these to neuroscience related planets set up already: https://ankursinha.in/planet-neuroscientists/ and https://ankursinha.in/planet-neuroscience/
14:22:16 <FranciscoD> (both hosted on GH)
14:22:51 <gicmo> ah nice
14:23:14 <FranciscoD> Would anyone else like to blog about our work? Then we can set up the organisation blog. Otherwise, for the time being, I can continue to write these updates.
14:24:24 <gicmo> seems like that is a no ;) .. I wish I was better at blogging...
14:24:25 * LoKoMurdoK here
14:24:28 <blackfile> welcome LoKoMurdoK
14:24:30 <LoKoMurdoK> meeting time?
14:24:32 <FranciscoD> #chair LoKoMurdoK
14:24:32 <zodbot> Current chairs: FranciscoD LoKoMurdoK blackfile gicmo mhough pac23 zbyszek
14:24:33 <LoKoMurdoK> late..
14:24:43 <LoKoMurdoK> .fas lbazan
14:24:44 <zodbot> LoKoMurdoK: lbazan 'Luis Enrique Bazán De León' <bazanluis20@gmail.com>
14:24:54 <FranciscoD> gicmo: it does take time. I only manage the short snippets each week too :(
14:24:58 <pac23> i will write something cant guarantee though
14:25:16 <FranciscoD> OK. Let's leave it for the time being? When we have more cycles, we can revisit it?
14:25:27 <pac23> yes
14:25:30 <zbyszek> yes
14:25:44 <FranciscoD> That's all +1s again from the looks of it
14:25:46 <gicmo> sure
14:26:10 <blackfile> +1
14:26:25 <FranciscoD> #agreed FranciscoD publish updates on his blog for the time being. Organisational blog to be revisited in the future (+5, -0)
14:26:35 <LoKoMurdoK> +1
14:26:39 <FranciscoD> oops!
14:26:41 <FranciscoD> #undo
14:26:41 <zodbot> Removing item from minutes: AGREED by FranciscoD at 14:26:25 : FranciscoD publish updates on his blog for the time being. Organisational blog to be revisited in the future (+5, -0)
14:26:45 <FranciscoD> #agreed FranciscoD publish updates on his blog for the time being. Organisational blog to be revisited in the future (+6, -0)
14:26:47 <FranciscoD> :)
14:27:01 <FranciscoD> #info https://pagure.io/neuro-sig/NeuroFedora/issue/8 -> A web location for user-end troubleshooting?
14:27:22 <FranciscoD> Note that we're going to move AskFedora from askbot to discourse in the near future
14:27:32 <FranciscoD> I was thinking we could just have a "sub category" thing there
14:27:37 <gicmo> you mean like stackoverflow or something?
14:27:43 <FranciscoD> and the ML and IRC/Telegram are here too
14:27:46 <FranciscoD> gicmo: yes
14:28:28 <gicmo> I remember there was https://neurostars.org/
14:28:35 <zbyszek> FranciscoD: I think it's all a question of manpower. Users can always use bugzilla to file bugs.
14:28:42 <gicmo> but I think that was generic neuroscience
14:28:54 <FranciscoD> gicmo: yes, neurostars still there: also on discourse now
14:28:55 <zbyszek> I don't think there's enough people to commit to yet another medium.
14:28:58 <LoKoMurdoK> to give support?
14:29:02 <FranciscoD> zbyszek: +1
14:29:05 <LoKoMurdoK> zbyszek: +1
14:29:07 <gicmo> man, I need to get on discourse ;)
14:29:14 <FranciscoD> but I really do not expect researchers to file bugs
14:29:17 <gicmo> yeah, I think zbyszek is right
14:29:32 <FranciscoD> From my experience, even getting them to write an e-mail some mailing list is an uphill task XD
14:29:40 <gicmo> haha, very true
14:29:51 <FranciscoD> #info https://neurostars.org/ -> NeuroStars generic troubleshooting form
14:29:53 <FranciscoD> er.. forum
14:30:14 <FranciscoD> #info A list of neuroscience resources is here: https://docs.fedoraproject.org/en-US/neurofedora/related-links/
14:30:35 <FranciscoD> OK, should we leave it to what we have now then: the mailing list, IRC/telegram?
14:31:00 <pac23> we can also have a GH repo with users filling issues there
14:31:08 <FranciscoD> pac23: we'd prefer pagure tbh
14:31:13 <pac23> would be convenient for many devs
14:31:15 <FranciscoD> but yes, github is probably more commonly used
14:31:22 <pac23> okay
14:31:40 <pac23> even comms-sig is moving to GitHub
14:31:52 <FranciscoD> commops you mean?
14:31:56 <pac23> yes
14:32:06 <pac23> atleast they were planning to back in dec
14:32:20 <FranciscoD> well, the goal of neurofedora is to further free/open science, so even if it's a bit more trouble, we should stick to free/open source tools as much as possible
14:32:40 <pac23> yes,
14:32:51 <FranciscoD> Should we see if we receive bugs etc, and then see if it needs to be improved?
14:32:56 <FranciscoD> It's early days yet
14:33:06 <gicmo> sounds good to me
14:33:13 <zbyszek> Also, having two lists of bugs is always a problem. I think it's fine to tell users to use pagure.
14:33:22 <FranciscoD> +1
14:33:29 <FranciscoD> need an FAS for that, though, right?
14:33:48 <zbyszek> Yes.
14:33:55 <FranciscoD> #info A new FAS (better interface etc) is being planned, but there's no ETA of when it'll be ready for deployment
14:34:20 <FranciscoD> Similar issue with Askfedora on discourse: we'd like to limit logins to FAS for metrics etc., but that means everyone must get an FAS account first.
14:34:41 <pac23> i guess it will be done this Gsoc
14:34:49 <pac23> fas interface*
14:34:51 <FranciscoD> Possibly
14:35:23 <FranciscoD> I'll update the documentation to point to our pagure. Folks that can, will file issues there. Others can mail us on the ML etc
14:35:34 <FranciscoD> #action FranciscoD update docs to request users to file bugs on pagure
14:35:46 <FranciscoD> #info https://pagure.io/neuro-sig/NeuroFedora/issue/121 -> Add comps groups
14:36:08 <FranciscoD> This currently only applies to the computational neuroscience software---since we have a few of the main tools packaged already
14:36:14 <zbyszek> Is there a list of software that should be in this group?
14:36:33 <FranciscoD> This is the queue (to be packaged): https://pagure.io/neuro-sig/NeuroFedora/issues?tags=F%3A+Computational+neuroscience
14:36:49 <FranciscoD> and this is a subset of what we already have: https://docs.fedoraproject.org/en-US/neurofedora/compneuro-tools/
14:37:30 <FranciscoD> #info Neuron (without MPI/Python) is currently in review: https://bugzilla.redhat.com/show_bug.cgi?id=1662526
14:38:26 <FranciscoD> Folks have suggested a few new tools using our suggestion form, by the way. So someone did read our documentation, and my post to the computational neuroscience mailing list
14:39:06 <FranciscoD> #info Link to our suggestion form is here: https://docs.fedoraproject.org/en-US/neurofedora/overview/#_suggest_software_for_inclusion
14:39:26 <FranciscoD> I check it periodically, open tickets, and let the requesters know (please check the ML: I cc it to my mails)
14:39:38 <zbyszek> That's interesting. What was requested?
14:39:40 <LoKoMurdoK> ok
14:39:52 <gicmo> I wonder if some of the packages would make sense as flatpaks, with silverblue on the horizon
14:40:15 <FranciscoD> zbyszek: https://pagure.io/neuro-sig/NeuroFedora/issue/192 (BluePyOpt) and https://pagure.io/neuro-sig/NeuroFedora/issue/193 (neurom) recently
14:40:22 <FranciscoD> fsleyes was requested before
14:40:39 <FranciscoD> gicmo: I think the GUI tools for neuro-imaging may work as flatpaks
14:40:42 <fm-neuro> pagure.project.group.added -- zbyszek added group "neuro-sig" to project rpms/python-pysb with admin access https://src.fedoraproject.org/rpms/python-pysb
14:40:51 <FranciscoD> but I don't see simulators like nest/neuron being of use
14:40:55 <FranciscoD> I'm thinking of docker images for those
14:41:06 <FranciscoD> but I've got to figure out the docker process in fedora first
14:41:14 <gicmo> yeah, makes sense
14:41:26 <FranciscoD> #info https://pagure.io/neuro-sig/NeuroFedora/issue/180 -> Docker images for NEST
14:41:52 <FranciscoD> a docker image with PyNN, NEST, Brian, NEURON would be useful: lots of folks use this software group
14:41:58 <LoKoMurdoK> in the blog some screenshots of the packages working in fedora...
14:42:18 <fm-neuro> pagure.issue.edit -- zbyszek edited the close_status and status fields of ticket neuro-sig/NeuroFedora#157 https://pagure.io/neuro-sig/NeuroFedora/issue/157
14:42:19 <fm-neuro> pagure.issue.comment.added -- zbyszek commented on ticket neuro-sig/NeuroFedora#157: "Request rights to python-pysb" https://pagure.io/neuro-sig/NeuroFedora/issue/157#comment-549253
14:42:20 <FranciscoD> LoKoMurdoK: most of what we have currently are command line tools or librariies
14:42:26 <gicmo> FranciscoD:  Package NixView  ... there is a flatpak for that (which I did) ... could do a "normal" rpm too, once libnixio is packaged
14:42:44 <FranciscoD> gicmo: ah, that'd be awesome
14:43:05 <gicmo> FranciscoD: should I just take the issues?
14:43:05 <FranciscoD> gicmo: here's another question: do we have to build the flatpaks on fedora infra, or can we do it using flathub etc?
14:43:22 <LoKoMurdoK> FranciscoD: the command lines tools mm some tests? or demos?
14:43:27 <FranciscoD> maybe using the GH organisation so we can share maintainership
14:43:29 <FranciscoD> ?
14:43:49 <gicmo> FranciscoD: heh, controversial question ... .. from the desktop team's POV I think flathub
14:43:52 <FranciscoD> gicmo: yes, please take whatever issues you'd like to work on :)
14:44:03 <zbyszek> There is (going to be) a /flatkpack namespace on pagure, and I think this should be used to build flatpaks
14:44:17 <FranciscoD> yeh, I remember reading the e-mail
14:44:34 <FranciscoD> thee's a container namespace on src.fp.o too, which is what I reckon we'll use for docker images
14:44:51 <FranciscoD> I think bodhi already does updates for containers---not yet for flatpaks yet
14:44:58 <FranciscoD> so that ensures that these go through the QA process
14:45:08 <fm-neuro> pagure.project.group.added -- zbyszek added group "neuro-sig" to project rpms/libsbml with admin access https://src.fedoraproject.org/rpms/libsbml
14:45:09 <gicmo> zbyszek: different subgroups have different ideas how flatpaks should be build, ... e.g. from rpms or via the freedesktop SDK
14:45:32 <zbyszek> FWIW, I'm on the "from rpms" side ;)
14:45:47 <FranciscoD> gicmo: if we do provide flatpaks via flathub, can we please at least keep the repos under the NeuroFedora github organisation?
14:45:50 <fm-neuro> pagure.issue.edit -- zbyszek edited the close_status and status fields of ticket neuro-sig/NeuroFedora#156 https://pagure.io/neuro-sig/NeuroFedora/issue/156
14:45:51 <fm-neuro> pagure.issue.comment.added -- zbyszek commented on ticket neuro-sig/NeuroFedora#156: "Request rights on libsbml" https://pagure.io/neuro-sig/NeuroFedora/issue/156#comment-549258
14:46:16 <gicmo> one of the initial goals of flatpak was to ease cross-distro installation but also to make it easier for app developers to get it packaged ONCE and not differently for all distros ... which the rpm thing kinda defeats
14:46:30 <FranciscoD> hrm, yeh
14:46:54 <gicmo> there was a bit of a heated discussion internally ;)
14:47:01 <FranciscoD> hahaha
14:47:13 <zbyszek> gicmo: I'm not sure if that's true.
14:47:29 <gicmo> FranciscoD: if you want things on flathub, they have to be on "https://github.com/flathub/"
14:47:37 <zbyszek> One shouldn't care how the flatpak is built, just like it doesn't matter if it uses make or ninja
14:48:03 <gicmo> zbyszek: well, NixView is on flathub, but not in fedora, because libnixio is not in Fedora
14:48:07 <FranciscoD> gicmo: ah, OK---but then it's hard to put them under the NeuroFedora umbrella, right?
14:48:21 <gicmo> FranciscoD: yeah :/
14:48:45 <FranciscoD> how about we have a page on "third party software resources" and enumerate these there?
14:48:53 <FranciscoD> in docs?
14:49:01 <gicmo> sounds good to me
14:49:18 <FranciscoD> #action FranciscoD create new page for third party software resources in docs
14:49:35 <FranciscoD> LoKoMurdoK: we could do demos, but that'll imply knowing how each tool works well enough
14:49:49 <FranciscoD> I tend to link to upstream documentation instead---that's my shortcut XD
14:50:05 <gicmo> zbyszek: the biggest counter arguments against flathub is that 1) it is branded as fedora and 2) you need to trust the flathub guys and their build envs ..
14:50:23 <fm-neuro> pagure.issue.assigned.added -- gicmo assigned ticket neuro-sig/NeuroFedora#41 to gicmo https://pagure.io/neuro-sig/NeuroFedora/issue/41
14:50:25 <fm-neuro> pagure.issue.assigned.added -- gicmo assigned ticket neuro-sig/NeuroFedora#52 to gicmo https://pagure.io/neuro-sig/NeuroFedora/issue/52
14:50:28 <fm-neuro> pagure.issue.assigned.added -- gicmo assigned ticket neuro-sig/NeuroFedora#53 to gicmo https://pagure.io/neuro-sig/NeuroFedora/issue/53
14:50:38 <FranciscoD> #action FranciscoD add https://flathub.org/apps/details/org.gnode.NixView to "third party sources list" on docs
14:50:55 <FranciscoD> gicmo: does that also mean there's no guarantee of correctness for packages on flathub?
14:51:08 <gicmo> FranciscoD: no, they are reviewed
14:51:14 <zbyszek> What is the rpoblem with libnixio?
14:51:16 <FranciscoD> That'll be an issue: we try to run whatever tests possible when building for Fedora (it's required by the guidelines anyway)
14:51:23 <gicmo> FranciscoD: it is a bit like app store
14:51:37 <FranciscoD> OK, that's better then
14:51:46 * FranciscoD is a bit cautious about correctness
14:52:09 <FranciscoD> it won't be much good if people use NeuroFedora and have to retract their results because we didn't test for correctness while providing software XD
14:52:09 <gicmo> zbyszek: no problem at all, just that nobody had time to package it yet ... (-;
14:52:24 <zbyszek> Is it part of nix or nixview, or a separate thing?
14:52:48 <gicmo> it is a separate thing
14:53:20 <gicmo> https://github.com/G-Node/nix/
14:53:23 <FranciscoD> I'd get to it eventually. I've been focussing on the simulators at the moment.
14:53:30 <FranciscoD> I can review the package for you, though
14:53:37 <FranciscoD> We usually double team on packages XD
14:53:56 <gicmo> FranciscoD: we have a spec file and there is even a copr ..
14:54:08 <FranciscoD> ah, that shouldn't be too hard then?
14:54:12 <gicmo> FranciscoD: the include path changed and the library needs proper so versioning
14:54:26 <gicmo> so we were thinking of holding back until 1.5.0 is out ...
14:54:33 <FranciscoD> yeh, sure
14:54:36 <gicmo> I talk to the people and see what the status is
14:54:55 <gicmo> I wonder if the matlab bindings work in Octave these days :/
14:55:14 <FranciscoD> that brings us to the next (and probably last ticket) ;)
14:55:27 <FranciscoD> #info https://pagure.io/neuro-sig/NeuroFedora/issue/155 -> Including packages that need Matlab at runtime
14:55:49 <FranciscoD> The context is here: https://pagure.io/neuro-sig/NeuroFedora/issue/101 -> SPM
14:56:02 <FranciscoD> it's commonly used in neuroimaging, but upstream officially only supports matlab
14:56:07 <zbyszek> I think there's no general answer here, and each case should be considered on its own merits
14:56:18 <FranciscoD> mhough has spoken to upstream, and they say that it does work with octave too
14:56:41 <zbyszek> If the maintainers feel like it should work with octave, it's OK to package.
14:56:55 <FranciscoD> zbyszek: hrm, as long as maintainers can check for correctness
14:56:56 <zbyszek> But I'd give lower priority to octave/matlab packages than to the python ones...
14:57:01 <FranciscoD> +1 to that
14:57:09 <gicmo> +1
14:57:19 <FranciscoD> for SPM, mhough said that the correctness tests that run for matlab also run for octave
14:57:24 <FranciscoD> so that gives me some confidence
14:57:56 <FranciscoD> #info Prioritise python over Matlab/Octave
14:58:20 <FranciscoD> That's all the tickets really. 5 minute open floor for any general comments?
14:58:50 <FranciscoD> #topic Open floor
14:59:20 <FranciscoD> Is there anything else we can do to improve the user-experience, and maybe get more people to contribute?
14:59:29 <FranciscoD> Are the docs OK, for example?
14:59:38 <zbyszek> FranciscoD: thank you for working on this, it's great to see neuroscience pick up steam again in fedora ;)
14:59:48 <gicmo> +100
14:59:50 <gicmo> ;)
14:59:58 <LoKoMurdoK> =)
15:00:10 <FranciscoD> Thanks for helping out really :)
15:00:15 <pac23> +1000
15:00:46 <FranciscoD> Everyone in the pagure group has commit access to docs etc., so please feel free to add to them etc
15:00:52 <FranciscoD> it's just asciidoc
15:01:01 <pac23> i was thinking maybe for contirbutors we could mark issues on GH as easy pick many websites used by students to start open soruce contribs track them
15:01:04 <FranciscoD> docs are looking at including a search box Ive heard
15:01:07 <pac23> that way we can get some
15:01:27 <FranciscoD> +1
15:01:47 <FranciscoD> but the primary concern is that we probably want people with some knowledge of neuroscience since this is all specialised software
15:01:56 <FranciscoD> so they sort of need to know a little bit of context
15:02:28 <FranciscoD> and it'll be advantageous if the contributors are in it for the long term: either from the Fedora or the Neuroscience aspect (or both, like me)
15:02:41 <FranciscoD> otherwise, such projects tend to die out rather quickly
15:02:49 <gicmo> yeah
15:03:06 <gicmo> I will try and push to get the german neuroinformatics node people on board
15:03:12 <pac23> also can you point me to some basic neuroscience docs
15:03:17 <FranciscoD> I've seen it happen with Fedora medical: I packaged software for them as part of GSoC, but then the leader went on to do a phd and dropped his interest in fedora-medical completely
15:03:22 <gicmo> (they are on Arch and ubuntu for now :/)
15:03:24 <pac23> i dont know much about it
15:03:45 <FranciscoD> pac23: ah, that's an idea: neuroscience resources for beginners
15:03:56 <FranciscoD> #action FranciscoD add a page "neuroscience resources for beginners"
15:04:17 <pac23> i know its related to the brain for starters,lol :p
15:04:21 <FranciscoD> gicmo: that'd be nice. If we can have a ready to install image, that'll bring people over to Fedora quicker
15:04:28 <FranciscoD> that's on the todo list too
15:04:47 <FranciscoD> although, we may have to have multiple "labs": one for each component: comp neuro, imaging, analysis etc
15:04:52 <FranciscoD> will need a bit of thought
15:05:12 <FranciscoD> https://labs.fedoraproject.org/ -> I mean these
15:05:37 <gicmo> ahh cool yes
15:06:28 <FranciscoD> #action FranciscoD send out logs
15:06:38 <FranciscoD> #action FranciscoD summarise meeting discussion in next blog post
15:07:00 <FranciscoD> If there's nothing else, we can close the meeting. We've gone 6 minutes past our 1 hour
15:07:50 <FranciscoD> I think we have 2 sponsors on the neuro-sig packaging team, by the way. So please feel free to get prospective packagers in touch with us.
15:07:59 <FranciscoD> LoKoMurdoK is a sponsor, right?
15:08:03 <LoKoMurdoK> yes
15:08:08 <FranciscoD> and zbyszek, are you a package sponsor too?
15:08:11 <zbyszek> Yes
15:08:13 <FranciscoD> (or a provenpackager even)
15:08:33 <FranciscoD> #info LoKoMurdoK and zbyszek are package maintainer sponsors
15:08:45 <pac23> +1
15:09:00 <gicmo> good stuff
15:09:17 <FranciscoD> With that I'll close this meeting. We can plan another one when we've made some progress. Please feel free to open tickets and things on the ML etc as and when needed.
15:09:32 <pac23> yes
15:09:35 <FranciscoD> #info Thanks gicmo pac23 zbyszek LoKoMurdoK blackfile mhough for coming, and helping out
15:09:41 <FranciscoD> pac23++
15:09:41 <zodbot> FranciscoD: Karma for pac23 changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:09:44 <FranciscoD> gicmo++
15:09:44 <zodbot> FranciscoD: Karma for gicmo changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:09:46 <LoKoMurdoK> FranciscoD++
15:09:47 <zbyszek> FranciscoD++
15:09:48 <zodbot> zbyszek: Karma for ankursinha changed to 7 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:09:50 <LoKoMurdoK> zbyszek++
15:09:51 <zodbot> LoKoMurdoK: Karma for zbyszek changed to 5 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:09:51 <FranciscoD> zbyszek++
15:09:56 <LoKoMurdoK> blackfile++
15:09:58 <FranciscoD> already given the one I reckon XD
15:10:01 <FranciscoD> blackfile++
15:10:02 <LoKoMurdoK> :-)
15:10:03 <zbyszek> LoKoMurdoK++
15:10:03 <zodbot> zbyszek: Karma for lbazan changed to 4 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:10:06 <FranciscoD> LoKoMurdoK++
15:10:08 <LoKoMurdoK> pac23++
15:10:08 <zodbot> LoKoMurdoK: Karma for pac23 changed to 2 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:10:09 <zbyszek> pac23++
15:10:09 <LoKoMurdoK> xD
15:10:11 <gicmo> FranciscoD++
15:10:12 <zodbot> zbyszek: Karma for pac23 changed to 3 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:10:13 <LoKoMurdoK> coockies time
15:10:15 <gicmo> zbyszek++
15:10:15 <zodbot> gicmo: Karma for ankursinha changed to 8 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:10:18 <gicmo> yay!
15:10:18 <zodbot> gicmo: Karma for zbyszek changed to 6 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:10:18 <FranciscoD> haha: impromptu cookie party
15:10:23 <zbyszek> gicmo++
15:10:24 <LoKoMurdoK> hahahahaha
15:10:24 <zodbot> zbyszek: Karma for gicmo changed to 2 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:10:27 <FranciscoD> mhough++
15:10:31 <FranciscoD> already given
15:10:34 <FranciscoD> we need more cookies
15:10:35 <zbyszek> mhough++
15:10:35 <zodbot> zbyszek: Karma for mhough changed to 2 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:10:38 <LoKoMurdoK> xD
15:10:41 <FranciscoD> Right. Closing now
15:10:43 <FranciscoD> #endmeeting