15:00:45 <FranciscoD> #startmeeting NeuroFedora 2019-09-19
15:00:45 <zodbot> Meeting started Thu Sep 19 15:00:45 2019 UTC.
15:00:45 <zodbot> This meeting is logged and archived in a public location.
15:00:45 <zodbot> The chair is FranciscoD. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:45 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:45 <zodbot> The meeting name has been set to 'neurofedora_2019-09-19'
15:00:54 <FranciscoD> #meetingname neurofedora
15:00:54 <zodbot> The meeting name has been set to 'neurofedora'
15:01:02 <FranciscoD> #chair zbyszek MeWjOr LoKoMurdoK alciregi
15:01:02 <zodbot> Current chairs: FranciscoD LoKoMurdoK MeWjOr alciregi zbyszek
15:01:14 <FranciscoD> Sorry telegram folks, can't chair you :(
15:02:23 <FranciscoD> #topic Agenda summary
15:02:26 <FranciscoD> #info https://lists.fedoraproject.org/archives/list/neuro-sig@lists.fedoraproject.org/thread/CF7RE5AC6O2TH5PPOX7KVCQUKDPBTHWI/
15:02:34 <FranciscoD> #info Introductions and roll-call
15:02:40 <FranciscoD> #info Tasks from last meeting
15:02:44 <FranciscoD> #info Pagure tickets
15:02:47 <FranciscoD> #info Bugs
15:02:56 <FranciscoD> #info Neuroscience query of the week
15:03:02 <FranciscoD> #info Next meeting chair
15:03:08 <FranciscoD> #info Open floor
15:03:16 <FranciscoD> #topic Introductions and roll call
15:03:28 <FranciscoD> .fas ankursinha
15:03:28 <zodbot> FranciscoD: ankursinha 'Ankur Sinha' <sanjay.ankur@gmail.com>
15:03:51 <MeWjOr> .fas major
15:03:51 <zodbot> MeWjOr: bryant3 'SQ III' <usafmajorsq3@att.net> - mhayden 'Major Hayden' <mhayden@redhat.com> - amayorov 'Aleksandr Mayorov' <sanek_majorov@mail.ru> - majordomo 'majordomo' <majordomo@doyouwantants.com> - munawarp 'Munawar Punnasseri' <munawar@majortechie.com> - fourmajor 'Stuart Matthews' <stu@fourmajor.com> - ramuso 'ramajor' <ramajor@prl.res.in> - majora '' <setve@protonmail.com> - ppk 'Prashant Kulkarni' (2 more messages)
15:04:01 <blackfile> .fas blackfile
15:04:02 <zodbot> blackfile: blackfile 'Luis Manuel Segundo' <luis@blackfile.net>
15:04:27 <FranciscoD> #chair blackfile
15:04:27 <zodbot> Current chairs: FranciscoD LoKoMurdoK MeWjOr alciregi blackfile zbyszek
15:04:43 <MeWjOr> fas: major: Aniket Pradhan <aniket17133@iiitd.ac.in>
15:06:56 <zbyszek> .hello2
15:06:57 <zodbot> zbyszek: zbyszek 'Zbigniew Jędrzejewski-Szmek' <zbyszek@in.waw.pl>
15:07:12 <zbyszek> I'm here, but my network is really bad, so I mgiht drop off anytime
15:07:15 <tg-fedneuro> <b​t0dotninja> Hi
15:07:35 <FranciscoD> No worries zbyszek
15:07:43 <FranciscoD> Hi blackfile @bt0dotninja! :)
15:07:56 <FranciscoD> Moving to next topic
15:08:06 <FranciscoD> #topic Tasks from last meeting on 12th Sep 2019
15:08:27 <FranciscoD> #info Minutes: https://meetbot.fedoraproject.org/teams/neurofedora/neurofedora.2019-09-12-15.01.html
15:08:43 <FranciscoD> #info FranciscoD dan1mal open comps PR: DONE
15:09:10 <FranciscoD> #info dan1mal to update their user page on wiki: https://fedoraproject.org/wiki/User:Dan1mal: DONE
15:09:35 <FranciscoD> #info FranciscoD submit change proposal: DONE
15:09:47 <FranciscoD> #info Change propsal was sent out to devel-announce and devel lists: https://fedoraproject.org/wiki/Changes/Comp_Neuro_Lab
15:10:06 <FranciscoD> #info FranciscoD write OSB workshop event report: PENDING, Reassigning
15:10:11 <FranciscoD> #action FranciscoD write OSB workshop event report
15:10:21 <FranciscoD> #info mhough send out logs: DONE
15:10:34 <FranciscoD> That was quite good XD
15:10:53 <FranciscoD> #topic Pagure tickets
15:11:11 <FranciscoD> #info Pagure tickets marked for this meeting: https://pagure.io/neuro-sig/NeuroFedora/issues?status=Open&tags=S%3A+Next+meeting
15:11:40 <FranciscoD> #info Issue #250: Figure out badges rule to award badge automatically to pagure group members: https://pagure.io/neuro-sig/NeuroFedora/issue/250
15:11:56 <FranciscoD> This needs to be followed up, but it depends on a ticket on the badges pagure project
15:12:07 <FranciscoD> #info Issue #678: You're a member of the Neuro Fedora SIG - fedora-badges : https://pagure.io/fedora-badges/issue/678
15:12:19 <FranciscoD> #info riecatnor improved the badge, please give your comments
15:12:36 <FranciscoD> #info Improved version of badge: https://pagure.io/fedora-badges/issue/678#comment-597731
15:13:06 * FranciscoD already commented
15:13:16 <FranciscoD> everyone else, please take a look and drop a comment
15:13:33 <blackfile> ok
15:13:39 <FranciscoD> When that is done, we can give everyone the badge, and look at automating it
15:14:06 <FranciscoD> #info Issue #250: Figure out badges rule to award badge automatically to pagure group members - NeuroFedora - waiting on Badges #678
15:14:39 <FranciscoD> #info Issue #274: Flock: conference reports - NeuroFedora - https://pagure.io/neuro-sig/NeuroFedora/issue/274
15:14:52 <FranciscoD> Another poke for everyone that went to Flock XD
15:15:07 <FranciscoD> I'll close this in a few days, though---it's been a while since Flock
15:15:14 <FranciscoD> #action FranciscoD close #274 on Monday
15:15:31 <FranciscoD> #info Issue #292: A default bibliography manager for inclusion in NeuroFedora groups/image - NeuroFedora - https://pagure.io/neuro-sig/NeuroFedora/issue/292
15:15:41 <FranciscoD> I filed this today while working with Jabref etc
15:15:46 <FranciscoD> Thoughts?
15:16:08 <MeWjOr> I only know about bibtex... whats up with it?
15:16:23 <FranciscoD> If you think you need more time to play with the tools, we can leave this for the time being and discuss it in a week or two
15:16:31 <FranciscoD> MeWjOr: bibtex is a format---most of these tools support it
15:16:44 <FranciscoD> and then, when using LaTeX, bibtex is a tool to work with bibtex files
15:16:50 <FranciscoD> but it isn't a reference manager really
15:17:32 <MeWjOr> Ohh.. okay
15:19:18 <FranciscoD> #info BibTeX format and explanations: https://en.wikipedia.org/wiki/BibTeX
15:19:38 <MeWjOr> https://github.com/zotero I remember this as well... Zotero is a manager, right?
15:19:50 <FranciscoD> Yes, web based with a client also
15:19:55 <FranciscoD> pretty good features
15:20:14 <FranciscoD> the one main competitor to Mendeley (which is now owned by publishing giant Elsevier)
15:20:33 <MeWjOr> And it is not packaged for Fedora, yet
15:20:53 <FranciscoD> No, only Jabref is in fedora, and is currently outdated
15:20:59 <FranciscoD> zotero isn't
15:21:09 <FranciscoD> mendeley shouldn't be (not FOSS)
15:21:18 <FranciscoD> bibus is now inactive upstream
15:21:18 <tg-fedneuro> <b​t0dotninja> I don't know, ship a firefox plugin doesn't sound good
15:21:37 <FranciscoD> bt0dotninja: which one? zotero?
15:21:48 <tg-fedneuro> <b​t0dotninja> yes, zotero
15:21:50 <FranciscoD> it is a standalone tool too---with plugins for FF/Chrome etc
15:21:58 <FranciscoD> and it's a full web app too that syncs with the client
15:22:15 <FranciscoD> https://www.zotero.org/download/ -> version 5.0 for Linux
15:23:57 <MeWjOr> Maybe I can try my hands on packaging Zotero?
15:24:58 <FranciscoD> Yeh, I haven't seen how hard/easy it is though
15:25:20 <FranciscoD> So maybe give it a go, and if it's too complex, leave it for the time being
15:25:36 <FranciscoD> We can always just link to the download page in our docs at the moment
15:25:36 <MeWjOr> From what I can see is it just requires copying the directory to /opt and then creating symlinks
15:26:00 <FranciscoD> MeWjOr: oh, no---that's "installing". For the rpm, it'll have to be built from source
15:26:06 <tg-fedneuro> <b​t0dotninja> what one is ship with the science lab?
15:26:16 <FranciscoD> https://www.zotero.org/support/dev/client_coding/building_the_standalone_client
15:26:17 <tg-fedneuro> <b​t0dotninja> or they don't ship any
15:26:31 <FranciscoD> I don't think they ship any
15:27:02 <MeWjOr> I guess I will have to look at their compiling instructions then.. :P
15:27:20 <FranciscoD> I feel like this is low-priority, since both Jabref and Zotero provide pre-compiled binaries to download
15:27:51 <FranciscoD> I'd be happy with adding them to the docs for the time being, and focussing on packaging more research software
15:27:59 <MeWjOr> +1
15:28:08 <tg-fedneuro> <b​t0dotninja> +1 too
15:28:55 <FranciscoD> OK, let's do that for the moment
15:29:02 <FranciscoD> #action FranciscoD add zotero and jabref to docs
15:29:19 <FranciscoD> #agreed Add zotero + jabref to docs and not work on packaging them up at the moment
15:29:41 <FranciscoD> That's all the tickets then
15:30:17 <FranciscoD> Before we move on to the next topic
15:30:35 <FranciscoD> Does anyone know what we have to do next for the lab image? The change proposal is fine, but what now? XD
15:31:25 <tg-fedneuro> <k​eszybz> It should get handled automatically by Ben Cotton.
15:31:46 <FranciscoD> He's sent the e-mail out to the lists
15:32:17 <FranciscoD> I think we get a tracker bug for this next
15:32:36 <zbyszek> Yep, he should take care of the necessary steps.
15:32:45 <tg-fedneuro> <L​oKoMurdoK> In another meeting 😔
15:33:08 <FranciscoD> zbyszek: OK, so we wait then :)
15:33:18 <FranciscoD> #info https://fedoraproject.org/wiki/Changes/Policy#How_is_a_change_accepted.3F -> next steps here
15:33:27 <FranciscoD> @LoKoMurdoK: no worries :)
15:33:46 <FranciscoD> @bt0dotninja: do you think we can make a F31 based ISO for ourselves to test?
15:33:57 <FranciscoD> that shouldn't be too hard, right?
15:34:01 <tg-fedneuro> <b​t0dotninja> yes
15:34:18 <FranciscoD> Do we have some place to keep it in?
15:34:24 <tg-fedneuro> <b​t0dotninja> no, let me try and update the ticket
15:34:28 <FranciscoD> Should I ask infra to give us some fedora-people space?
15:34:43 <tg-fedneuro> <b​t0dotninja> sounds lake a plan
15:34:47 <tg-fedneuro> <b​t0dotninja> like
15:35:04 <FranciscoD> OK, I'll do that
15:35:18 <FranciscoD> #action FranciscoD file ticket with infra requesting fedorapeople space to host our test lab image
15:35:33 <FranciscoD> How much space should I ask for? 10/15 gigs?
15:36:36 <tg-fedneuro> <b​t0dotninja> it's enough to two or three images
15:36:44 <FranciscoD> #info Next steps for lab image: generate test images
15:36:52 <FranciscoD> OK, I'll ask for 15gigs and see what they say :)
15:37:32 <FranciscoD> #info PR#410: Add neuro-fedora related groups and categories - fedora-comps - https://pagure.io/fedora-comps/pull-request/410 -> filed already, waiting for merge
15:37:43 <FranciscoD> I expect we'll wait till F31 release---everyone is quite busy at the moment ;)
15:38:12 <tg-fedneuro> <b​t0dotninja> that is true
15:38:13 <FranciscoD> #action FranciscoD poke/ping comps PR in 2 weeks
15:38:41 <FranciscoD> #topic Open bugs
15:38:59 <FranciscoD> #info Open bugs: https://tinyurl.com/neurofedora-bugs
15:39:20 <FranciscoD> Have a few simple python updates---any takers?
15:39:40 <MeWjOr> Hi
15:39:52 <FranciscoD> are you done with your exams MeWjOr ?
15:40:01 <tg-fedneuro> <b​t0dotninja> true
15:40:11 <MeWjOr> They'll get over on Sunday
15:40:18 <MeWjOr> :D
15:40:31 <FranciscoD> OK, get them over with, then you can take a few of these up if you're not busy celebrating :P
15:40:50 <FranciscoD> #info NOTE: All python-fsl* packages must be submitted as a single update
15:41:10 <FranciscoD> I'm working on ITK and VXL etc. Will have those fixed in a week too, hopefully
15:41:22 <MeWjOr> What does the last info mean..
15:41:31 <FranciscoD> MeWjOr: so, you update the spec, push, build
15:41:39 <FranciscoD> then you have to submit updates to bodhi, right?
15:41:55 <MeWjOr> No, I meant what does submitting them as a single update mean
15:42:09 <FranciscoD> a bodhi update can include multiple packages
15:42:32 <FranciscoD> since these are linked, they generally move together---so we have to ensure that they hit the mirrors together
15:42:44 <MeWjOr> Ohh.. got it
15:42:54 <FranciscoD> so we submit all of them in the same bodhi update---that way they hit "stable" together and go to users together
15:43:11 <FranciscoD> when there are runtime deps between packages, this needs to be kept in mind
15:43:33 <zbyszek> Actually runtime deps should be handled by installation-time deps.
15:44:01 <zbyszek> But installation-time deps can cause packages to be uninstallable, if some part of the package set is not pushed to the mirrors along with the rest.
15:44:17 <zbyszek> That's where the #info item comes in.
15:44:21 <FranciscoD> +1
15:44:51 <MeWjOr> Ohh... okay
15:45:23 <FranciscoD> MeWjOr: you can do the fsl packages this time to see how it is done :)
15:45:40 <MeWjOr> Great!
15:45:48 <FranciscoD> no hurry, though---we only just pushed an fsl update with the sip/wxpython fixes
15:46:13 <FranciscoD> Any other major bugs that we need to look into urgently?
15:46:31 <FranciscoD> there are one or two that are waiting for upstream to fix :(
15:47:37 <FranciscoD> OK, next topic then
15:47:42 <FranciscoD> #topic Neuroscience query of the week
15:48:22 <FranciscoD> I was wondering: any one interested in reading this paper: https://www.cell.com/neuron/fulltext/S0896-6273(19)30290-9
15:48:30 <FranciscoD> "The Scientific Case for Brain Simulations"
15:48:44 <FranciscoD> It's quite high level---discusses what modelling/simulation is and why its important
15:49:08 <mhough> Can we distribute a PDF?
15:49:16 <FranciscoD> Also discusses quite a few tools, and should have something about what the Human Brain Project is up to
15:49:39 <FranciscoD> mhough: this is the pre-print: https://arxiv.org/abs/1906.06189
15:49:53 <FranciscoD> and I can download the PDF once the meeting is over---will have to hop on to the uni VPN :)
15:50:10 <zbyszek> We probably could, but I think it's enough to provide a link from our wiki pages...
15:50:21 <mhough> Yeah I would love to read that
15:50:44 <FranciscoD> zbyszek: for the pdf? I think the silly thing is paywalled, so one needs access
15:50:55 <FranciscoD> orrr, one should probably not use sci-hub :)
15:51:16 <zbyszek> Oh, I misread.
15:51:17 <mhough> arxiv works
15:52:27 <FranciscoD> So should we discuss that in the next meeting, or maybe in 2 weeks to give everyone time to read it properly?
15:53:38 <mhough> Happy to talk about once everyone has time to read it
15:54:18 <FranciscoD> OK, let's aim for two weeks
15:54:34 <FranciscoD> I'll file us a ticket to track this too---that way everyone will be aware
15:54:49 <FranciscoD> Next topic
15:55:03 <FranciscoD> #topic Next meeting time and chair
15:55:18 <FranciscoD> Next meeting in a week? +1/-1/0 please?
15:55:20 <FranciscoD> +1
15:55:23 <MeWjOr> +1
15:55:29 <tg-fedneuro> <b​t0dotninja> +1
15:55:46 <mhough> +1
15:56:00 <FranciscoD> that's enough +1s
15:56:05 <MeWjOr> :P
15:56:12 <MeWjOr> Can I host the next meeting?
15:56:20 <FranciscoD> #info Next meeting will be in a week on 26 September, same time
15:56:26 <FranciscoD> #info MeWjOr will chair the next meeting
15:56:30 <FranciscoD> Yep ;)
15:56:32 <MeWjOr> Yay!
15:56:35 <tg-fedneuro> <b​t0dotninja> :)
15:56:37 <FranciscoD> #action FranciscoD send out meeting logs
15:56:51 <FranciscoD> #action MeWjOr send out reminder on Tuesday
15:57:07 <FranciscoD> #action MeWjOr set up agenda---go over pagure tickets and mark ones that need discussing
15:57:23 <FranciscoD> #action MeWjOr ping folks over telegram an hour or so before the meeting
15:57:39 <FranciscoD> I think that's all you need to do before the meeting
15:57:49 <FranciscoD> #topic Open Floor
15:58:01 <FranciscoD> 3 minutes for this---anything interesting going on? :)
15:58:38 <FranciscoD> This happened, of course: https://www.engadget.com/2019/09/17/rms-fsf-mit-epstein/
15:58:48 <FranciscoD> I'll let you read it and find out what/why etc.
15:58:55 <MeWjOr> Is that the one about Stallman?
15:58:58 <FranciscoD> Yeh
16:00:14 <FranciscoD> There are quite a few good neuroscience related reads here: https://ankursinha.in/planet-neuroscientists/
16:00:33 <FranciscoD> How To Cope Under Pressure, According To Psychology – Research Digest: https://digest.bps.org.uk/2019/09/17/how-to-cope-under-pressure-according-to-psychology/
16:00:35 <FranciscoD> for example
16:01:58 <FranciscoD> The BPS does some really good topics
16:02:07 <FranciscoD> OK, if nothing else, I'll close the meeting
16:02:13 <FranciscoD> Closing in 5
16:02:35 <MeWjOr> I might do something related to psycho-acoustics, in the next half of my semester
16:02:39 <MeWjOr> any thought?
16:02:46 <mhough> Very cool
16:02:56 <FranciscoD> Ooo, I don't know much about it. I can ask around and look
16:03:04 <mhough> What kind of thing?
16:03:35 <MeWjOr> It's basically creating neural responses through some specific tones
16:03:37 <FranciscoD> Let me close the meeting and then we can discuss that
16:03:42 <MeWjOr> Sure
16:03:42 <FranciscoD> #endmeeting