16:03:35 <FranciscoD> #startmeeting NeuroFedora - 2019-11-05
16:03:35 <zodbot> Meeting started Tue Nov  5 16:03:35 2019 UTC.
16:03:35 <zodbot> This meeting is logged and archived in a public location.
16:03:35 <zodbot> The chair is FranciscoD. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:03:35 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:03:35 <zodbot> The meeting name has been set to 'neurofedora_-_2019-11-05'
16:03:43 <MeWjOr> So...FranciscoD you chairing today?
16:03:47 <MeWjOr> Ohh
16:03:50 <FranciscoD> #chair gicmo alciregi bt0 zbyszek MeWjOr LoKoMurdoK
16:03:50 <zodbot> Current chairs: FranciscoD LoKoMurdoK MeWjOr alciregi bt0 gicmo zbyszek
16:04:06 <FranciscoD> MeWjOr: for the time being I guess
16:04:16 <FranciscoD> #meetingname neurofedora
16:04:16 <zodbot> The meeting name has been set to 'neurofedora'
16:04:32 <FranciscoD> #topic Agenda
16:05:01 <FranciscoD> #info Introductions and roll call
16:05:12 <FranciscoD> #info Pagure tickets: https://pagure.io/neuro-sig/NeuroFedora/issues?status=Open&tags=S%3A+Next+meeting
16:05:20 <FranciscoD> #info Bugs: https://tinyurl.com/neurofedora-bugs
16:05:30 <FranciscoD> #info Action items from last meeting
16:05:43 <FranciscoD> #info Some neuroscience
16:05:48 <FranciscoD> #info Next meeting time/chair
16:05:52 <FranciscoD> #info Open floor
16:06:00 <FranciscoD> #topic Introductions/roll calls
16:06:08 <FranciscoD> .fasinfo ankursinha
16:06:09 <zodbot> FranciscoD: User: ankursinha, Name: Ankur Sinha, email: sanjay.ankur@gmail.com, Creation: 2008-05-28, IRC Nick: FranciscoD, Timezone: Europe/London, Locale: en_GB, GPG key ID: E629112D, Status: active
16:06:12 <zodbot> FranciscoD: Approved Groups: @wikiedit provenpackager +packager robotics-sig @ask-fedora scitech @neuro-sig @fedora-join cla_fedora cla_done fedorabugs @freemedia @gitfedora-tour cla_fpca @gitfpaste +qa
16:06:27 <FranciscoD> let's wait ~5 minutes for folks to join, then we'll proceed
16:06:31 <MeWjOr> .fasinfo major
16:06:32 <zodbot> MeWjOr: User: major, Name: Aniket Pradhan, email: aniketpradhan1999@gmail.com, Creation: 2019-02-09, IRC Nick: MeWjOr, major_, Timezone: Asia/Kolkata, Locale: en, GPG key ID: None, Status: active
16:06:36 <zodbot> MeWjOr: Approved Groups: qa neuro-sig fedorabugs packager wikiedit cla_done cla_fpca
16:07:38 <bt0> .fasinfo bt0dotninja
16:07:39 <zodbot> bt0: User: bt0dotninja, Name: Alberto Rodriguez Sanchez, email: hotgalan@gmail.com, Creation: 2016-07-25, IRC Nick: bt0, Timezone: America/Mexico_City, Locale: en, GPG key ID: E74B5808, Status: active
16:07:42 <zodbot> bt0: Approved Groups: neuro-sig fedorabugs packager +advocates @commops +summer-coding +ask-fedora mindshare +fedora-join @fedora-mx ambassadors dotnet-team marketing cla_done cla_fpca
16:08:57 <FranciscoD> OK, let's proceed, folks can catch up
16:09:02 <FranciscoD> #topic Pagure tickets: https://pagure.io/neuro-sig/NeuroFedora/issues?status=Open&tags=S%3A+Next+meeting
16:09:26 <FranciscoD> #info Issue #307: NeuroFedora at FOSDEM 2020. - NeuroFedora - Pagure.io: https://pagure.io/neuro-sig/NeuroFedora/issue/307
16:09:42 <FranciscoD> MeWjOr: any general progress on FOSDEM?
16:09:51 <MeWjOr> So, I went through the slides... as discussed earlier..
16:09:59 <FranciscoD> nice, what did you think?
16:10:21 <MeWjOr> There's a bit much of neuroscience, I guess?
16:10:35 <FranciscoD> yeh, which slides were these?
16:10:41 <FranciscoD> the flock ones or OSB?
16:10:52 <MeWjOr> The Flock ones
16:10:58 <FranciscoD> ok
16:11:15 <FranciscoD> #info Flock slides are neuroscience heavy---need tailoring to target audience
16:11:17 <MeWjOr> And we would need to add information about the neuro-comps image
16:11:27 <FranciscoD> yeh, like today's blog post
16:11:30 <MeWjOr> yep
16:11:36 <FranciscoD> MeWjOr: can you note these down in the ticket?
16:11:43 <MeWjOr> Okay
16:11:44 <FranciscoD> Also, maybe a 20 minute talk would be sufficient?
16:11:52 <FranciscoD> instead of a 40 minute one?
16:11:57 <MeWjOr> Most probably... yes
16:12:03 <FranciscoD> OK, please note that down too
16:12:20 <FranciscoD> #action MeWjOr note tweaks we require to slides for FOSDEM
16:12:39 <FranciscoD> #info 20 minute talk should be sufficient for FOSDEM
16:13:12 <FranciscoD> I need to find time to work on the abstract too
16:13:13 <bt0> the flock slides + an update will be great to cover that 20 minutes
16:13:29 <FranciscoD> MeWjOr: do you want to go over the abstract we submitted to CNS and try tweaking it for FOSDEM?
16:13:58 <MeWjOr> Yeah, sure. I can try
16:14:07 <MeWjOr> Where is the abstract though?
16:14:25 <FranciscoD> on overleaf, and also on Github I would think
16:14:28 <FranciscoD> Hold on, looking
16:14:58 <bt0> overleaf and sharing the link can works
16:15:00 <MeWjOr> also, is it fine if I import the presentations on Overleaf?
16:15:20 <FranciscoD> yeh, of course
16:15:31 <FranciscoD> This is the read-only link for the abstract: https://www.overleaf.com/read/cppxsdmxvndj
16:15:44 <FranciscoD> how do we share the write links? Should I e-mail it privately to everyone?
16:15:50 <MeWjOr> Like, first on GitHub and then on Overleaf... Because that would enable the functionality of collaboration as well
16:16:28 <MeWjOr> Mailing the write-access links would be better
16:16:46 <FranciscoD> the abstract is already on GH + Overleaf
16:17:07 <FranciscoD> I think we can make them public---if we get spam, we'll think about what to do XD
16:18:27 <FranciscoD> hold on, moving repo to NeuroFedora
16:18:33 <bt0> +1
16:18:35 <FranciscoD> we could even do it on Pagure, but it's already on GH
16:19:20 <MeWjOr> You cannot link pagure and overleaf... like you can do with gh and overleaf, though
16:19:25 <FranciscoD> yeh, I know
16:19:36 <FranciscoD> Right, here we are:
16:19:43 <FranciscoD> #info Flock slides: https://github.com/neurofedora/2019-flock-neurofedora
16:19:51 <FranciscoD> #info OSB workshop slides: https://github.com/neurofedora/201909-OSB-neurofedora
16:20:02 <FranciscoD> #info CNS abstract: https://github.com/neurofedora/2019CNS-neurofedora-abstract
16:20:12 <FranciscoD> we'll mirror them on Pagure, that'll be OK
16:20:24 <FranciscoD> #action FranciscoD send edit link to team
16:20:33 <MeWjOr> question: if I import a project from gh on overleaf, then if we make any changes, are they commited onto gh at some point, or would we have to manually download all the files and then commit them?
16:20:51 <FranciscoD> MeWjOr: overleaf lets you push and pull from GH, but it must be done manually
16:20:54 <FranciscoD> no auto-sync
16:21:36 <MeWjOr> ohhkay
16:22:14 <FranciscoD> If you use LaTeX locally, you don't need to worry too much about Overleaf
16:22:28 <FranciscoD> that's more for folks who aren't used to writing LaTeX and using Git etc
16:22:53 <FranciscoD> OK, I think that's enough for this ticket today?
16:22:59 <MeWjOr> Yep
16:23:09 <FranciscoD> #info Skipping brochure ticket: WIP
16:23:21 <FranciscoD> #info Skipping badges ticket: still blocked at badges
16:23:33 <FranciscoD> #info Issue #311: Move neuroscience planets to NeuroFedora - NeuroFedora - Pagure.io: https://pagure.io/neuro-sig/NeuroFedora/issue/311
16:24:09 <FranciscoD> So, currently, I have these two setup on my GH account: https://ankursinha.in/planet-neuroscience/ and https://ankursinha.in/planet-neuroscientists/
16:24:37 <FranciscoD> they're actually at sanjayankur31.github.io/planet..., but since sanjayankur31.github.io is linked to my ankursinha.in CNAME, it applies to them too
16:24:48 <FranciscoD> I was wondering if we should move them to Neurofedora instead?
16:24:59 <FranciscoD> then they'll become neuroblog.fedoraproject.org/planet...
16:25:07 <FranciscoD> sounds a lot nicer than if linked to my name
16:25:29 <MeWjOr> Yup...
16:25:31 <FranciscoD> also means the whole team can administer these
16:25:36 <FranciscoD> instead of it being just me
16:26:05 <FranciscoD> One issue with moving them would be that URLs for people currently using them would break, but we'll announce the change and give folks time to move etc
16:26:17 <FranciscoD> Or, for a bit, we could just run them in both places---I don't know
16:26:37 <FranciscoD> (I don't think I can set up a redirect from GH pages)
16:27:06 <MeWjOr> running them in both places would become very awkward and confusing at some point..
16:28:01 <MeWjOr> You can redirect from the gh-page...
16:28:03 <FranciscoD> yeh, maybe just migrate them---they're RSS feeds, shouldn't be much trouble
16:28:43 <FranciscoD> MeWjOr: how does one do that? It needs to be a URL level redirect: ankursinha.in/planet.../* needs to redirect to neuroblog.fedoraproject.org/planet.../
16:28:51 <FranciscoD> I thought that sort of thing needs htaccess files etc
16:29:26 <MeWjOr> I was thinking of simply using a javascript function at ankursinha.in/... which redirects to neuroblog.fp..
16:29:31 <MeWjOr> :|
16:30:12 <FranciscoD> hrm, but we don't want everything to redirect etc
16:30:15 <FranciscoD> will have to look
16:30:34 <MeWjOr> Using that, you can also notify the users that the website is being shifted and all...
16:31:17 <FranciscoD> well, it'll require changes to my blog's theme etc
16:31:22 <FranciscoD> right?
16:31:24 <MeWjOr> Kind of like how the Fedora docs were shifted to docs.fp.o
16:31:57 <MeWjOr> Not necessarily
16:32:08 <FranciscoD> where would the JS go?
16:32:24 <FranciscoD> I could try this maybe: https://github.com/Nitron/pelican-alias
16:32:25 <MeWjOr> You can utilize the same theme, show a message on the top saying that "we are shifting here..."
16:32:44 <MeWjOr> the JS would go in index.html (or the homepage)
16:32:57 <FranciscoD> all the html is generated by pelican using the theme
16:33:00 <FranciscoD> for my blog, that is
16:33:05 <FranciscoD> for the planets, it's generated by "Venus"
16:33:15 <FranciscoD> (none of it is hand-written HTML)
16:33:33 <FranciscoD> ankursinha.in is the blog, which will stay where it is
16:33:44 <FranciscoD> only the .../planet-neuro.. bits need to be redirected
16:33:54 <FranciscoD> let me try the pelican plugin, maybe that'll do the trick
16:34:15 <FranciscoD> #action FranciscoD try pelican alias plugin and see what can be done
16:34:22 <MeWjOr> So, I guess you can stop updating the one hosted at ankursinha.in/... ? and then just update the new one... The old one would remain just like a static redirect to the new one
16:34:37 <FranciscoD> #info worse case scenario, we break the URL for some people
16:34:52 <MeWjOr> :
16:34:54 <MeWjOr> :P
16:35:06 <FranciscoD> MeWjOr: yeh, hopefully that plugin will let me create a "planet-neuroscience" page that will redirect to the new URL
16:35:09 <FranciscoD> will have to tinker
16:35:23 <FranciscoD> #action FranciscoD update ticket with info
16:35:35 <FranciscoD> That's all the tickets then
16:35:37 <FranciscoD> next topic
16:35:56 <FranciscoD> #topic NeuroFedora bugs: https://tinyurl.com/neurofedora-bugs
16:36:33 <FranciscoD> In pretty good shape there, nothing too urgent
16:36:39 <FranciscoD> #info Bugs are in good shape, nothing urgent
16:36:59 <FranciscoD> Any review tickets etc that aren't on the list that we should look at?
16:37:17 <MeWjOr> I'll make one by tomorrow
16:37:37 <FranciscoD> great
16:37:50 <FranciscoD> #info Everyone, please keep packaging up tools from our list
16:37:57 <FranciscoD> #topic Action items from last meeting
16:38:16 <FranciscoD> #info FranciscoD tweak abstract draft for FOSDEM -> MeWjOr is taking a look
16:38:25 <FranciscoD> #info MeWjOr go through current slide sets -> DONE
16:38:32 <FranciscoD> #info MeWjOr ping FOSDEM booth thread asking for someone to take the lead so they can help -> DONE
16:39:29 <FranciscoD> #info MeWjOr work on #308 -> DONE: New image has been publicised:  https://neuroblog.fedoraproject.org/2019/11/05/neurofedora-computational-neuroscience-iso-image-is-now-available.html
16:39:44 <FranciscoD> #topic Some neuroscience?
16:39:52 <FranciscoD> Anyone read anything interesting lately?
16:39:58 * FranciscoD hasn't had time to find another podcast :(
16:40:19 <FranciscoD> maybe we should also make it the chair's responsibility to find something for us to read/hear?
16:40:21 <FranciscoD> XD
16:40:28 * MeWjOr is struggling to write/complete assignments
16:40:32 <MeWjOr> Ahh!
16:40:57 <FranciscoD> MeWjOr: assignments should get priority over volunteering work :)
16:41:13 <FranciscoD> #info No neuroscience to discuss today :( :( :(
16:41:17 <FranciscoD> Right, next topic
16:41:22 <FranciscoD> #topic Next meeting chair
16:41:46 <FranciscoD> bt0: do you want to take a turn maybe? :P
16:41:56 <bt0> sure
16:42:04 <bt0> action me please
16:42:07 <FranciscoD> awesome, thanks :)
16:42:09 <MeWjOr> bt0++
16:42:28 <FranciscoD> #action bt0 to chair next meeting: send reminder on Friday, send out logs after meeting etc
16:42:33 <FranciscoD> #action FranciscoD send out meeting logs
16:42:35 <bt0> MeWj0r++
16:42:38 <FranciscoD> #topic Open Floor
16:42:40 <FranciscoD> major++
16:42:42 <MeWjOr> why is it that I am always unable to give a cookie to anyone... >.<
16:42:46 <FranciscoD> bt0dotninja++
16:42:46 <zodbot> FranciscoD: Karma for bt0dotninja changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
16:42:49 <MeWjOr> ahh... Thanks <3
16:42:51 <FranciscoD> try their FAS
16:43:07 <MeWjOr> well...you took it for this release cycle...
16:43:13 <bt0> major++
16:43:15 <zodbot> bt0: Karma for major changed to 2 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
16:43:18 <bt0> :)
16:43:21 <FranciscoD> yoos, new release cycle, new cookies :)
16:43:28 <FranciscoD> Anything in Open Floor folks?
16:43:30 <MeWjOr> bt0dotninja++
16:43:39 <bt0> :P
16:43:44 <MeWjOr> If anyone wants to talk about Optical Communications?
16:43:47 <bt0> not from me
16:43:48 <MeWjOr> XD
16:44:03 <FranciscoD> woah, dunno enough to talk about them XD
16:44:31 <MeWjOr> it's just using a LED to communicate using a glass-y wire
16:44:36 <MeWjOr> :P
16:44:43 <FranciscoD> I remember reading about it all at some point
16:45:03 <FranciscoD> probably in refraction etc, where they talk about optical fibres
16:45:12 * FranciscoD can't remember
16:45:16 <MeWjOr> reflection*
16:45:18 <FranciscoD> Anyway, let's close the meeting then
16:45:22 <FranciscoD> #endmeeting