13:06:03 <FranciscoD> #startmeeting NeuroFedora 2021-01-18
13:06:03 <zodbot> Meeting started Mon Jan 18 13:06:03 2021 UTC.
13:06:03 <zodbot> This meeting is logged and archived in a public location.
13:06:03 <zodbot> The chair is FranciscoD. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:06:03 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
13:06:03 <zodbot> The meeting name has been set to 'neurofedora_2021-01-18'
13:06:09 <FranciscoD> #meetingname neurofedora
13:06:09 <zodbot> The meeting name has been set to 'neurofedora'
13:06:20 <FranciscoD> #chair lbazan MeWjOr gicmo achilleas bt0 zbyszek
13:06:20 <zodbot> Current chairs: FranciscoD MeWjOr achilleas bt0 gicmo lbazan zbyszek
13:06:31 <lbazan> morning!
13:06:35 <FranciscoD> Anyone else here? (Please note that we can't chair folks over telegram at the moment)
13:06:38 <lbazan> .fas lbazan
13:06:38 <zodbot> lbazan: lbazan 'Luis Enrique Bazán De León' <bazanluis20@gmail.com>
13:06:59 <FranciscoD> lbazan: hold on :P
13:07:04 <FranciscoD> #topic Agenda for today
13:07:12 <FranciscoD> #info New introductions and roll call
13:07:16 <FranciscoD> #info Tasks from last meeting
13:07:20 <FranciscoD> #info Open Pagure tickets
13:07:24 <FranciscoD> #info Open bugs check
13:07:30 <FranciscoD> #info Open package reviews check
13:07:37 <FranciscoD> #info Kochei package build status check
13:07:46 <FranciscoD> #info CompNeuro lab compose check
13:07:52 <FranciscoD> #info Neuroscience query of the week
13:07:58 <FranciscoD> #info Next meeting day, chair
13:08:01 <FranciscoD> #info Open floor
13:08:05 <FranciscoD> Starting with the first one
13:08:11 <FranciscoD> #topic New introductions and roll call
13:08:14 <FranciscoD> lbazan: go :P
13:08:20 <lbazan> xD
13:08:40 <FranciscoD> #info Ankur Sinha (ankursinha), FranciscoD, UTC, NeuroFedora, Join SIG, etc. :D
13:09:37 <lbazan> I've been away for a while, due to work issues but I'll be back soon as and I have to buy a new laptop.
13:09:38 <MeWjOr> Hey all! It's been so loong :D
13:09:42 <lbazan> :-)
13:09:42 <bt0> #info Alberto Rodriguez, bt0dotninja, UTC -6, CommOps, Neuro, Join, Cats
13:09:51 <FranciscoD> Is this the first meeting of the year?
13:09:55 <FranciscoD> If so, Happy new year! :P
13:09:57 <lbazan> yeap!
13:10:00 <bt0> yes, it is
13:10:03 <FranciscoD> 🎇
13:10:04 <lbazan> 2021 wueee
13:10:16 <FranciscoD> Hope everyone is keeping safe :)
13:10:35 <MeWjOr> #info Aniket Pradhan, major / MeWjOr, UTC +5:30, Neuro, packaging and stuff :P
13:10:48 <MeWjOr> Happy New Year folks! \o/
13:11:01 <bt0> Happy new year
13:11:06 <lbazan> Has anyone already injected the vaccine?
13:11:14 <bt0> Hi Compadre MeWj0r :)
13:11:20 <bt0> not here
13:11:22 <lbazan> MeWjOr++
13:11:22 <zodbot> lbazan: Karma for major changed to 5 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
13:11:33 <MeWjOr> lbazan, if you're planning on buying a lenovo laptop with Fedora, you can get some hefty discount on your FAS ID
13:11:33 <lbazan> FranciscoD++
13:11:33 <zodbot> lbazan: Karma for ankursinha changed to 12 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
13:11:36 <FranciscoD> lbazan: my parents in India got the first round already. They're doctors there
13:11:40 <MeWjOr> Hola bt0
13:12:03 <FranciscoD> here in the UK, I think they've started vaccinating the over 70s this week
13:12:09 <lbazan> MeWjOr already buy lenovo x1 but I use the newyear discount!:-)
13:12:17 <FranciscoD> nic
13:12:19 <FranciscoD> *nice
13:12:29 <lbazan> FranciscoD ok
13:12:30 <gicmo> o/
13:12:31 <FranciscoD> lenovo did have some good discounts. I got lots of e-mails from them :D
13:12:32 <MeWjOr> aah.... vaccine's too far away for regular joe's... The essential workers would be getting a shot first
13:12:42 <FranciscoD> MeWjOr: yeh, makes sense too
13:12:47 <FranciscoD> OK, next topic then
13:12:53 <FranciscoD> #info Tasks from last week
13:12:55 <FranciscoD> gicmo: \o
13:13:25 <FranciscoD> MeWjOr Work over the update for python-mne
13:13:27 <FranciscoD> MeWjOr: done?
13:13:57 <FranciscoD> Looks like it. There's a Python 3.10 FTBFS, but that's a different issue
13:14:12 <FranciscoD> #info MeWjOr Work over the update for python-mne: DONE
13:14:21 <FranciscoD> Next: MeWjOr Fix the deps for python-odml
13:15:08 <FranciscoD> MeWjOr: this required owlrl to be packaged, right? I think that is complete?
13:15:52 <MeWjOr> Yes, python-mne is fixe
13:16:00 <MeWjOr> fixed*
13:16:16 <MeWjOr> although there is a new bug with py3.10 but I guess that is still alpha for now
13:16:42 <FranciscoD> sounds good, and odml?
13:16:49 <MeWjOr> owlrl if I remember correctly is still in progress since it's one dep is still FTBFS
13:16:58 <MeWjOr> and odml depends upon owlrl
13:17:25 <FranciscoD> Uh, OK
13:17:29 <FranciscoD> let us know if we can help
13:17:33 <FranciscoD> I'll reassign to you for the moment
13:17:42 <MeWjOr> sure, I'll start working on getting the deps ready
13:17:50 <FranciscoD> #info MeWjOr Fix the deps for python-odml: WIP (requires owlrl etc.)
13:17:52 <FranciscoD> #action MeWjOr Fix the deps for python-odml
13:18:05 <FranciscoD> Next: alciregi check on python-pydicom package
13:18:11 <FranciscoD> @Alessio: you here? :D
13:18:45 <FranciscoD> https://bugzilla.redhat.com/show_bug.cgi?id=1838435 -> WIP
13:18:48 <FranciscoD> reassigning
13:18:56 <FranciscoD> #info alciregi check on python-pydicom package: WIP
13:19:00 <FranciscoD> #action alciregi check on python-pydicom package
13:19:25 <FranciscoD> Next: NeuroFedora team: go over ticket: https://pagure.io/neuro-sig/NeuroFedora/issue/374
13:19:32 <FranciscoD> This is about the change proposal for the CompNeuro image.
13:19:44 <FranciscoD> I've filed the proposal, and the review. We just need the review ticket reviewed
13:20:06 <FranciscoD> #info CompNeuro container image review: https://bugzilla.redhat.com/show_bug.cgi?id=1913491
13:20:12 <FranciscoD> Any takers for the review? :P
13:20:39 <FranciscoD> Beta freeze is  on Feb 23, so this needs to be reviewed at least 2 weeks before so that it can hit stable
13:20:48 <MeWjOr> Would it be the same as a package review?
13:20:59 <bt0> good question
13:21:01 <FranciscoD> MeWjOr: same process, but you'll check against the container guidelines
13:21:09 <FranciscoD> https://docs.fedoraproject.org/en-US/containers/guidelines/review/
13:21:25 <FranciscoD> it's much simpler tbh: the packages are already in rpms, so only the Dockerfile needs to be checked
13:21:44 <bt0> :P
13:21:48 <FranciscoD> bt0: the Dockerfile is based on the one you had written anyway XD
13:21:58 <bt0> yeah, i read it
13:22:06 <FranciscoD> I just removed ipython---we'll make a different one for the teaching use case with ipython in it
13:22:21 <FranciscoD> bt0: you can review this then :P
13:22:25 <bt0> sounds good
13:22:32 <bt0> yes
13:22:35 <FranciscoD> awesome, thanks :)
13:22:51 <FranciscoD> #action bt0 review https://bugzilla.redhat.com/show_bug.cgi?id=1913491 (CompNeuro container image)
13:23:15 <FranciscoD> Next: FranciscoD update docs to close #409
13:23:48 <FranciscoD> Done, this was about adding the matrix URL to our docs: https://docs.fedoraproject.org/en-US/neurofedora/communicating/
13:24:13 <FranciscoD> Is the link there OK? (looks weird)
13:25:09 <MeWjOr> Nah... there's some issue with the link
13:25:17 <FranciscoD> Hrm
13:25:34 <FranciscoD> I'll look at that later
13:25:47 <FranciscoD> #action FranciscoD look at escaping URL correctly for Matrix link
13:26:33 <FranciscoD> will need some ascii doc fu perhaps
13:26:49 <FranciscoD> Next: FranciscoD look into python-missngo issue
13:26:58 <FranciscoD> hrm, can't find any bugs, so I must've fixed it XD
13:27:21 <bt0> :)
13:27:53 <FranciscoD> Ah, it's marked in Koschei. Let's look at that again when we get to that topic
13:28:06 <FranciscoD> Next: bt0 research how to add images to the fedora registry
13:28:09 <FranciscoD> this is done
13:28:12 <FranciscoD> #info bt0 research how to add images to the fedora registry DONE
13:28:19 <FranciscoD> Next: FranciscoD rename placeholder docs page from "docker" to "containers"
13:28:44 <FranciscoD> Also done, I've also added info to the containers page: https://docs.fedoraproject.org/en-US/neurofedora/containers/
13:29:22 <FranciscoD> #info FranciscoD rename placeholder docs page from "docker" to "containers" DONE
13:29:23 <bt0> awesome
13:29:23 <lbazan> let me put neurosig as admin in all package
13:29:34 <FranciscoD> lbazan++
13:29:34 <zodbot> FranciscoD: Karma for lbazan changed to 3 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
13:29:45 <FranciscoD> bt0: if you find errors in the container page, please feel free to fix them
13:29:54 <FranciscoD> I did test out all commands, but maybe I missed something
13:29:58 <lbazan> python-missingno not have bz
13:30:06 <bt0> sure
13:30:10 <FranciscoD> lbazan: yeh, weird---we'll open one via Koschei
13:30:17 <fm-neuro> pagure.project.group.access.updated -- lbazan updated access of group "neuro-sig" to admin on project rpms/python-missingno https://src.fedoraproject.org/rpms/python-missingno
13:30:17 <FranciscoD> #info FranciscoD send out logs DONE
13:30:27 <FranciscoD> Next topic
13:30:30 <FranciscoD> #topic Open Pagure tickets
13:30:40 <FranciscoD> Nothing here this week
13:31:03 <fm-neuro> pagure.project.group.access.updated -- lbazan updated access of group "neuro-sig" to admin on project rpms/python-mne-bids https://src.fedoraproject.org/rpms/python-mne-bids
13:31:19 <FranciscoD> We have a few tasks that need to be done before the beta freeze, though. So please do take a peek at these tickets
13:31:21 <FranciscoD> https://pagure.io/neuro-sig/NeuroFedora/issues?status=Open&milestone=F34+Beta+freeze+2021-02-23
13:31:37 <FranciscoD> they're primarily additions to the comp-neuro image and the web-page
13:31:49 <FranciscoD> I'll take care of those this weekend hopefully
13:31:56 <FranciscoD> Next topic
13:32:01 <FranciscoD> #topic Open bugs check
13:32:14 <FranciscoD> #info Link: https://tinyurl.com/neurofedora-bugs
13:32:41 <FranciscoD> hrm, a few new ones
13:32:48 <FranciscoD> lbazan: a few for you
13:33:01 <fm-neuro> pagure.project.group.access.updated -- lbazan updated access of group "neuro-sig" to admin on project rpms/python-lfpy https://src.fedoraproject.org/rpms/python-lfpy
13:33:07 <FranciscoD> mostly updates, though, so not too urgetn
13:33:15 <FranciscoD> please do go over them and fix them whenever possible
13:33:44 * FranciscoD sees a couple of ITK bugs
13:33:47 <FranciscoD> *sigh*
13:34:13 <FranciscoD> anything there that seems high priority?
13:35:01 * FranciscoD waits for everyone to have a look
13:35:06 <fm-neuro> pagure.project.group.access.updated -- lbazan updated access of group "neuro-sig" to admin on project rpms/python-hdmf https://src.fedoraproject.org/rpms/python-hdmf
13:35:27 <MeWjOr> umm... not high priority bugs imo
13:35:49 <fm-neuro> pagure.project.group.access.updated -- lbazan updated access of group "neuro-sig" to admin on project rpms/python-neurosynth https://src.fedoraproject.org/rpms/python-neurosynth
13:36:11 <FranciscoD> MeWjOr: yeh, I don't think any of them are urgent either
13:36:29 <FranciscoD> next topic then
13:36:34 <FranciscoD> #topic Koschei check
13:36:46 <FranciscoD> #info Link to neuro-sig packages on Koschei: https://koschei.fedoraproject.org/groups/neuro-sig
13:37:12 <FranciscoD> a few here
13:38:22 <FranciscoD> I'll just file bugs for the ones where Koschei hasn't already done so
13:38:55 <fm-neuro> pagure.project.group.access.updated -- lbazan updated access of group "neuro-sig" to admin on project rpms/python-chaospy https://src.fedoraproject.org/rpms/python-chaospy
13:39:58 <FranciscoD> OK, bugs for all of them. Please go through the list and work on any that may interest you
13:40:10 <FranciscoD> #info Everyone please go through FTBFS bugs and fix whichever ones they can
13:40:36 <FranciscoD> next topic
13:40:59 <FranciscoD> #topic CompNeuro lab compose status check for F34
13:41:09 <FranciscoD> #info Looks good: https://koji.fedoraproject.org/koji/packageinfo?packageID=30691
13:41:17 <MeWjOr> Nice
13:41:30 <FranciscoD> Yeh, phew! XD
13:41:47 <FranciscoD> #topic Neuroscience query of the week
13:42:00 <FranciscoD> Anything here? I remember adding one or two new items to the reading list
13:42:19 <FranciscoD> There is this one:
13:42:29 <FranciscoD> https://osf.io/muk7v/  (OSF | Guidelines Toward Inclusive Practices in Academics by eLife Community Ambassadors)
13:42:42 <FranciscoD> I think the doc there on Mentoring was relevant
13:43:00 <FranciscoD> And this one: https://www.simonsfoundation.org/2021/01/05/the-democratization-of-neuroscience/  (The Democratization of Neuroscience)
13:43:20 <FranciscoD> speaks about open-neuroscience.com, and we're already one it: https://open-neuroscience.com/post/neurofedora/
13:44:01 <MeWjOr> aah... this is interesting
13:44:47 <bt0> cool
13:44:54 <FranciscoD> there's a lot of interest in doing things the community way
13:45:01 <FranciscoD> it's just hard to do it along with $dayjobs
13:45:08 <FranciscoD> so same problems as FOSS CD
13:45:12 <FranciscoD> *XD
13:45:16 <FranciscoD> it'll get better though
13:45:48 <FranciscoD> I don't know if I've mentioned this, but we've also started a Software working group with INCF and OCNS
13:45:50 <FranciscoD> https://neurostars.org/t/ocns-infrastructure-software-tools-sig-meet-and-greet-initial-discussions/15560
13:46:02 <FranciscoD> again, the idea is to do more community based development
13:46:20 <FranciscoD> INCF is this: https://www.incf.org/
13:46:28 <FranciscoD> OCNS is this: https://www.cnsorg.org/
13:47:11 <FranciscoD> we'll do a talk on NeuroFedora at one of the sessions for the WG too.
13:47:27 <FranciscoD> I don't think I have any other updates
13:47:31 * FranciscoD thinks
13:48:16 <FranciscoD> #chair major_
13:48:16 <zodbot> Current chairs: FranciscoD MeWjOr achilleas bt0 gicmo lbazan major_ zbyszek
13:48:17 <gicmo> That is very cool
13:48:50 <FranciscoD> gicmo: hopefully we'll keep it going
13:48:55 * gicmo feels nostalig for his days where he was working at the INCF G-Node
13:48:59 <FranciscoD> most academic/research SIGs/WGs tend to die out XD
13:49:05 <FranciscoD> gicmo: haha, yeh, INCF is awesome
13:49:05 <gicmo> achilleas recently moved from there to Red Hat
13:49:14 <MeWjOr> welp, my router suddenly decided to commit sudoku :P
13:49:23 <FranciscoD> gicmo: tuttut, taking all our researchers!! XD
13:49:27 <gicmo> apropos, totally should have poked achilleas
13:49:49 <FranciscoD> .fas achilleas
13:49:50 <zodbot> FranciscoD: akoutsou 'Achilleas Koutsou' <akoutsou@redhat.com> - achilleas 'Achilleas Karanasios' <achilleas.karanasios@gmail.com>
13:49:55 <FranciscoD> .fasinfo achilleas
13:49:56 <zodbot> FranciscoD: User: achilleas, Name: Achilleas Karanasios, email: achilleas.karanasios@gmail.com, Creation: 2019-07-28, IRC Nick: None, Timezone: UTC, Locale: en, GPG key ID: None, Status: active
13:49:59 <zodbot> FranciscoD: Approved Groups: cla_fpca cla_done
13:50:23 <FranciscoD> achilleas: if you'd like to work on packaging etc., please do ping me. I can sponsor you to the packager group as a neuro-sig member
13:50:23 <gicmo> FranciscoD: I think it is akoutsou
13:50:33 <FranciscoD> .fasinfo akoutsou
13:50:34 <zodbot> FranciscoD: User: akoutsou, Name: Achilleas Koutsou, email: akoutsou@redhat.com, Creation: 2020-12-14, IRC Nick: achilleas, Timezone: UTC, Locale: en, GPG key ID: None, Status: active
13:50:37 <zodbot> FranciscoD: Approved Groups: cla_done cla_fpca
13:50:41 <gicmo> achilleas: I will leave him NO CHOICE
13:50:43 <gicmo> ;P
13:50:46 <FranciscoD> ah, good, still applies XD
13:50:52 <FranciscoD> gicmo: hahaha
13:51:23 <FranciscoD> OK, next topic
13:51:28 <FranciscoD> #topic Next meeting time, day, chair
13:51:34 <FranciscoD> Same time in 2 weeks work for everyone?
13:51:41 <lbazan> +1
13:51:46 <MeWjOr> +
13:51:47 <lbazan> gicmo++
13:51:47 <zodbot> lbazan: Karma for gicmo changed to 4 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
13:51:51 <lbazan> zbyszek++
13:51:51 <zodbot> lbazan: Karma for zbyszek changed to 10 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
13:51:54 <bt0> +1
13:51:55 <FranciscoD> Henry e-mailed the list
13:52:04 <gicmo> <3
13:52:07 <FranciscoD> they're in Australia, so this time doesn't work for them.
13:52:15 <FranciscoD> let me reply to them there and see what can be done
13:52:38 <lbazan> +1
13:52:53 <FranciscoD> Henry had also messaged our account on Twitter, so I'd replied to them there asking them to ping us on the ML where the whole team could chat to them
13:53:17 <FranciscoD> please do reply to them on the ML and welcome them to the team too, everyone :)
13:53:25 <MeWjOr> ahh... that's great
13:53:35 <FranciscoD> every new contributor is one more person to help us keep going :D
13:53:40 <MeWjOr> have they joined the Telegram/IRC yet?
13:54:06 <FranciscoD> I think Henri joined over Telegram too
13:54:17 <FranciscoD> s/Henri/Henry/
13:54:44 <FranciscoD> who wants to chair the next meeting? :D
13:54:53 <FranciscoD> #action FranciscoD send out meeting logs
13:55:49 <FranciscoD> MeWjOr: bt0 gicmo achilleas lbazan : will you chair the next meeting? :D
13:55:55 <lbazan> go ahead!
13:55:57 <lbazan> :-)
13:56:23 <bt0> I can do it
13:56:27 <MeWjOr> umm... I probably won't be able to chair... but can attend
13:56:34 <achilleas> FranciscoD: yeah, mine is akoutsou
13:56:39 <FranciscoD> yay, we have a chair, that's all it takes :)
13:57:09 <achilleas> FranciscoD: I could package, I guess.  Bit of a noob in fedora/rpm packaging, but I'll figure it out
13:57:35 <FranciscoD> achilleas: sure, sounds good. There's lots of non-packaging bits too---whatever interests you really
13:57:50 <FranciscoD> if there's something you'd like to do that we don't do yet, we could even start a new task/sub-project
13:58:23 <achilleas> When is the next meeting?  Maybe I should attend one first before diving into chairing and figuring out what's to be done etc.
13:58:40 <FranciscoD> achilleas: next meeting will be in 2 weeks, at the same time (1300 UTC)
13:58:52 <achilleas> righto
13:58:55 <FranciscoD> (I send out reminders to the mailing list and poke everyone here too)
13:59:02 <bt0> Feb 1
13:59:04 <FranciscoD> #info bt0 chair next meeting
13:59:08 <bt0> :)
13:59:14 <FranciscoD> #info Next meeting on Feb 1 at 1300 UTC
13:59:26 <FranciscoD> right, we're at 59 past, so right on time
13:59:31 <FranciscoD> a minute for open floor before we close
13:59:38 <FranciscoD> akoutsou++
13:59:40 <zodbot> FranciscoD: Karma for akoutsou changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
13:59:52 <FranciscoD> #topic Open flooor
13:59:56 <bt0> akoutsou++
13:59:56 <zodbot> bt0: Karma for akoutsou changed to 2 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
13:59:56 <FranciscoD> enough time for a cookie party XD
14:00:28 <FranciscoD> gicmo++ bt0++ major++ lbazan++ zbyszek++
14:00:28 <gicmo> FranciscoD++
14:00:28 <lbazan> yeah!
14:00:34 <gicmo> lbazan++
14:00:34 <zodbot> gicmo: Karma for lbazan changed to 4 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:00:37 <FranciscoD> we've already used up our cookies this release? :o
14:00:44 <gicmo> I think I might have
14:00:49 <bt0> gicmo++ major++ zbyszek++
14:00:55 <gicmo> major++
14:00:56 <MeWjOr> FranciscoD++
14:00:59 <bt0> lbazan++
14:01:00 <MeWjOr> gicmo__
14:01:00 <gicmo> achilleas++
14:01:01 <zodbot> gicmo: Karma for akoutsou changed to 3 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:01:03 <MeWjOr> gicmo++
14:01:07 <bt0> FrenciscoD++
14:01:07 <FranciscoD> :(
14:01:09 <MeWjOr> achilleas++
14:01:09 <zodbot> MeWjOr: Karma for akoutsou changed to 4 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:01:13 <bt0> FranciscoD++
14:01:16 <MeWjOr> bt0++
14:01:22 <bt0> :)
14:01:24 <MeWjOr> lbazan++
14:01:24 <zodbot> MeWjOr: Karma for lbazan changed to 5 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:01:41 <MeWjOr> I'm out of cookies I guess :P
14:01:59 <FranciscoD> yeh
14:02:03 <FranciscoD> me too
14:02:15 <achilleas> FranciscoD++
14:02:15 <zodbot> achilleas: Karma for ankursinha changed to 13 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:02:15 <FranciscoD> Anyway, thanks everyone for coming. I'll see you again in 2 weeks
14:02:31 <FranciscoD> Please work on the bugs etc. in the meantime, and ping us if there's anything we can help with :)
14:02:34 <FranciscoD> #endmeeting