13:02:41 <FranciscoD_> #startmeeting NeuroFedora - 2022-01-17
13:02:41 <zodbot> Meeting started Mon Jan 17 13:02:41 2022 UTC.
13:02:41 <zodbot> This meeting is logged and archived in a public location.
13:02:41 <zodbot> The chair is FranciscoD_. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
13:02:41 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
13:02:41 <zodbot> The meeting name has been set to 'neurofedora_-_2022-01-17'
13:02:51 <FranciscoD_> #meetingname neurofedora
13:02:51 <zodbot> The meeting name has been set to 'neurofedora'
13:03:34 <FranciscoD_> #chair bittin vanessa_kris oluyosola Oluyosola Afolabi Haf shaane[m]
13:03:34 <zodbot> Current chairs: Afolabi FranciscoD_ Haf Oluyosola bittin oluyosola shaane[m] vanessa_kris
13:03:54 <FranciscoD_> if anyone else is here too, please let me know so I can chair you
13:04:01 <MeWjOr> o\
13:04:05 <MeWjOr> \o*
13:04:27 <FranciscoD_> #chair MeWjOr
13:04:27 <zodbot> Current chairs: Afolabi FranciscoD_ Haf MeWjOr Oluyosola bittin oluyosola shaane[m] vanessa_kris
13:04:41 <FranciscoD_> MeWjOr: i hope that works if you're on the IRC side of things, we'll check :)
13:04:52 <FranciscoD_> #chair omnidapps omnidapps[m]
13:04:52 <zodbot> Current chairs: Afolabi FranciscoD_ Haf MeWjOr Oluyosola bittin oluyosola omnidapps omnidapps[m] shaane[m] vanessa_kris
13:05:15 <FranciscoD_> #topic Agenda for today
13:05:23 <FranciscoD_> #info New introductions and roll call.
13:05:31 <FranciscoD_> #info Tasks from last meeting.
13:05:32 <MeWjOr> well, my BNC account got suspended, so am pretty blank about things happening on IRC :P
13:05:41 <FranciscoD_> #info Open Pagure tickets.
13:05:50 <FranciscoD_> #info Package health check.
13:05:58 <FranciscoD_> #info Open package reviews check.
13:06:09 <FranciscoD_> #info CompNeuro lab compose status check for Fedora 36.
13:06:16 <FranciscoD_> #info Neuroscience query of the week
13:06:25 <FranciscoD_> #info Next meeting day, and chair.
13:06:32 <FranciscoD_> #info Open floor
13:06:46 <FranciscoD_> Anything else not covered by all of this that someone will like to discuss? :)
13:07:16 <FranciscoD_> MeWjOr: I'm trying to say on Matrix more, because that way if someone asks things when we're not around, I can come back and reply later etc.
13:07:29 <FranciscoD_> OK, if everyone is happy with the agenda, let's get started with it
13:07:37 <FranciscoD_> #topic New introductions and roll call
13:07:57 <FranciscoD_> Please introduce yourselves, using the info command, for the logs. For example, I go:
13:08:07 * bittin is here looking a bit as the Fedora DI meeting today got cancelled
13:08:09 <bittin> .hello2 bittin
13:08:10 <zodbot> bittin: bittin 'Luna Jernberg' <droidbittin@gmail.com>
13:08:21 <FranciscoD_> #info ankursinha (FrancisciD), UTC+0 (London), Packaging, NeuroFedora, Ask Fedora, Fedora Join etc.
13:08:58 <bittin> #info LunaJernberg (bittin) UTC+2 (Sweden), Fedora QA/Swedish Translator (looking around)
13:09:55 <MeWjOr> #info major (MeWjOr) UTC+5:30 (India), Packaging, NeuroFedora, pretty much a zombie nowdays :D
13:09:56 <vanessa_kris[m]> #info Vanessa Christopher (vanessa_kris) UTC +1 (Cameroon) NeuroFedora
13:10:39 <FranciscoD_> vanessa_kris: is doing her Outreachy internship with us, and is doing a brilliant job at packaging! you can follow their progress here and on their blog: https://vanessa-kris.github.io/
13:10:43 <FranciscoD_> vanessakris++
13:10:47 <FranciscoD_> major++
13:10:47 <zodbot> FranciscoD_: Karma for major changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
13:10:49 <FranciscoD_> bittin++
13:10:49 <zodbot> FranciscoD_: Karma for bittin changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
13:10:58 <FranciscoD_> vanessa_kris++
13:10:58 <zodbot> FranciscoD_: Karma for vanessa_kris changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
13:11:20 <FranciscoD_> vanessa_kris: hrm, is that going to your new account or  your old one? (We should figure that out after the meeting too!)
13:11:43 <FranciscoD_> I'll wait another minute for other to join before proceeding with the agenda
13:11:55 <vanessa_kris[m]> FranciscoD_: Right
13:12:08 <MeWjOr> I have to agree... My mail box is usually flooded from notifications from the work vanessa_kris[m] is doing. Awesome indeed!
13:12:48 <MeWjOr> FranciscoD++
13:12:50 <vanessa_kris[m]> MeWjOr: Thank you 😊
13:12:58 <MeWjOr> vanessa_kris++
13:13:08 <MeWjOr> bittin++
13:13:13 <FranciscoD_> #topic Tasks from last meeting
13:13:27 <FranciscoD_> #info Minutes from previous meeting are here: https://meetbot.fedoraproject.org/teams/neurofedora/neurofedora.2021-12-06-13.01.html
13:13:45 <FranciscoD_> Haf hardeborlaa vanessa_kris practice reviewing on #2018705 (python-mapbox-earcut) for music
13:14:05 <FranciscoD_> Haf: vanessa_kris ^ did we assign this to either of you yet?
13:14:16 <FranciscoD_> (I think hardeborlaa is no longer in the channel :( )
13:14:47 <vanessa_kris[m]> FranciscoD_: I don’t think so
13:15:03 <bittin> does not seem like they are
13:15:30 <FranciscoD_> OK, vanessa_kris we can assign this to you for your Outreachy task this week? Give you some more review practice?
13:16:03 <FranciscoD_> #action FranciscoD_ assign rhbz #2018705 to vanessa_kris as Outreachy task for this week
13:16:16 <FranciscoD_> Haf hardeborlaa vanessa_kris practice reviewing on #2016779 also (python-cyipopt)
13:16:49 <FranciscoD_> ah, and another one: Haf hardeborlaa vanessa_kris practice reviewing #2026389 also
13:17:04 <FranciscoD_> OK, I'll give you maybe one or two at most to review vanessa_kris , that'll be enough practice for a week
13:17:31 <vanessa_kris[m]> FranciscoD_: Alright 😅
13:18:22 <FranciscoD_> we'll take a look in the topic on open review tickets
13:18:37 <FranciscoD_> these are all the action items from the last meeting, moving to next topic
13:18:51 <FranciscoD_> #topic Open Pagure tickets
13:19:10 <FranciscoD_> #info Please open tickets on pagure and use the "next meeting" tag to mark them for discussion
13:19:24 <FranciscoD_> #info Nothing here this time: https://pagure.io/neuro-sig/NeuroFedora/issues?status=Open&tags=S%3A+Next+meeting (reading list is discussed in a differnt topic)
13:19:35 <FranciscoD_> #topic Packages health check
13:19:42 <FranciscoD_> #info Our packager dashboard is here: https://packager-dashboard.fedoraproject.org/neuro-sig
13:20:08 <bittin> some stuff fails to build, and some stuff that can be built?
13:21:05 <FranciscoD_> bittin: yeh, a few FTBFS builds, but it's best to wait till the F36 mass rebuild to work on those, because some may get fixed there (and others may break)
13:21:34 <bittin> ah can one be curious and ask when that is, if its decided yet?
13:22:16 <FranciscoD_> note that we have automation that files bugs for FTBFS/FTI packages according to the FESCo guidelines: https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
13:22:16 <FranciscoD_> So do keep an eye on all the bugs that are opened, we don't want something to get orphaned for this sort of thing :)
13:22:39 <FranciscoD_> bittin: https://fedorapeople.org/groups/schedule/f-36/f-36-key-tasks.html -> says Feb 08
13:22:46 <bittin> FranciscoD_, ah thanks :)
13:22:55 <oluyosola[m]> #info Oluyosola Afolabi(Oluyosola) UTC +1 (Nigeria) NeuroFedora
13:23:11 <FranciscoD_> hello oluyosola ! great to have you here
13:23:23 <FranciscoD_> oluyosola++
13:23:23 <zodbot> FranciscoD_: Karma for oluyosola changed to 2 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
13:23:41 <oluyosola[m]> FranciscoD_: I am glad to be here too
13:23:54 <oluyosola[m]> Sorry for coming late for the meeting house
13:24:07 <bittin> so anything special to discuss, or hoping everything survives the mass rebuilds 8th Feb ?
13:24:12 <FranciscoD_> MeWjOr: were you sort of keeping mne etc. up to date? vanessa_kris and I updated it recently, so do take a look to see if we messed up anything if you have a minute please?
13:24:24 <FranciscoD_> bittin: best to leave FTBFS till the mass rebuild
13:24:48 <FranciscoD_> Got some new versions, though, so please do work on them and open pull requests if you have the time
13:24:59 <bittin> okay :) (not that versed in the packing process but curious)
13:25:03 <FranciscoD_> most should be simple spec version bumps
13:25:24 <FranciscoD_> oluyosola[m]: no worries at all :)
13:25:42 <FranciscoD_> ah, hrm, I still need to update ITK
13:25:45 <FranciscoD_> that's a beast..
13:25:54 <FranciscoD_> #action FranciscoD_ make time to update ITK
13:25:58 <MeWjOr> haha, not "keeping" it, but since I was using it (until recently), I loved pushing out the updates... but sure, will have a look definitely :D
13:26:24 <FranciscoD_> MeWjOr: is snakemake also a simplish package?
13:26:30 <MeWjOr> ITK XD
13:26:43 <FranciscoD_> if yes, we can put it on vanessa_kris 's task list for this week, for more update/PR practice
13:26:45 <MeWjOr> yep, it's quite simple, yes
13:26:52 <FranciscoD_> OK, cool
13:27:01 <MeWjOr> =b
13:27:13 <FranciscoD_> #action FranciscoD_ add snakemake update to vanessa_kris 's Outreachy task list for this or next week
13:27:31 <FranciscoD_> vanessa_kris: anything you see there that you'd like to take on for some specific practice?
13:27:48 <FranciscoD_> if so, do let us know---we need to make sure that these tasks have a strong learning component for you
13:27:55 <FranciscoD_> oluyosola: same for you too ^
13:28:08 <FranciscoD_> we've always got lots of bits to help you practice specific tasks
13:28:17 <FranciscoD_> Haf: same for you too :) ^
13:28:54 <FranciscoD_> #topic Open package reviews check
13:29:13 <FranciscoD_> #info Please head to the fedora-neuro tracker bug here, and click on "advanced fields" to see all the bugs this tracker bug "depends on": https://bugzilla.redhat.com/show_bug.cgi?id=fedora-neuro
13:30:55 <FranciscoD_> https://bugzilla.redhat.com/show_bug.cgi?id=2016779 -> hardeborlaa has submitted this one, I'll ping it
13:30:59 <bittin> a whole lot of python
13:31:38 <FranciscoD_> #action FranciscoD_ complete review for autograd
13:32:06 <FranciscoD_> oluyosola: https://bugzilla.redhat.com/show_bug.cgi?id=2016786 -> anything we can do to help with this one? Any specific issues you're running into?
13:32:19 <FranciscoD_> bittin: yeh, :D
13:33:00 <oluyosola[m]> No I will update it. I have worked on the review but yet to push
13:33:05 <FranciscoD_> vanessa_kris: did we import this one? https://bugzilla.redhat.com/show_bug.cgi?id=2017610
13:33:22 <FranciscoD_> oluyosola[m]: excellent, do ping us here if there's anything at all we can do to help
13:33:47 <FranciscoD_> #action oluyosola provide update to python-pesto review tickett
13:34:43 <vanessa_kris[m]> FranciscoD_: Yes
13:34:52 <FranciscoD_> FranciscoD_: ah, yeh, updates have also reached stable. I'll go close it.
13:34:58 <bittin> https://src.fedoraproject.org/rpms/python-git-changelog
13:35:01 <bittin> looks like it
13:35:26 <FranciscoD_> vanessa_kris: i think we forgot to mention the bug in the bodhi update---otherwise bodhi would've closed the bug when the update hit stable :)
13:35:58 <vanessa_kris[m]> FranciscoD_: Oh what could be done?
13:35:58 <FranciscoD_> oluyosola: how about this one? https://bugzilla.redhat.com/show_bug.cgi?id=2017716
13:36:23 <FranciscoD_> vanessa_kris[m]: nothing now, it's  a minor tweak. i just closed the bug manually now instead of bodhi automatically doing it for us. All sorted 👍️
13:38:30 <FranciscoD_> #action hardeborlaa needs to import this one (approved): https://bugzilla.redhat.com/show_bug.cgi?id=2018238
13:38:40 <FranciscoD_> #info FranciscoD_ set the need-info flag
13:39:05 <FranciscoD_> https://bugzilla.redhat.com/show_bug.cgi?id=2018705 -> we'll take this up for review this/next week
13:39:33 <FranciscoD_> Haf: anything we can do to help with this one? https://bugzilla.redhat.com/show_bug.cgi?id=2019686
13:40:32 <FranciscoD_> #info FranciscoD_ set needs-info for @Haf on #2019686
13:40:50 <FranciscoD_> https://bugzilla.redhat.com/show_bug.cgi?id=2020886 -> we'll review this this/next week
13:41:21 <FranciscoD_> https://bugzilla.redhat.com/show_bug.cgi?id=2026389 -> I need to make a tweak from the looks of it
13:41:41 <FranciscoD_> #action FranciscoD_ update #2026389
13:42:03 <FranciscoD_> https://bugzilla.redhat.com/show_bug.cgi?id=2034723 -> needs review too, any takers? :)
13:43:01 <vanessa_kris[m]> FranciscoD_: I’ll do it
13:43:31 <FranciscoD_> vanessa_kris[m]: OK, we'll put this on the list when we assign you tasks too then :) (We gotta make sure we limit to 30 hours for you, with all the other blog etc. tasks too)
13:43:58 <FranciscoD_> #action FranciscoD_ vanessa_kris : see if #2034723 can be put on Outreachy task list this or next week too
13:44:12 <FranciscoD_> last one is astor, which is almost there. needs a few minor tweaks vanessa_kris
13:44:12 <FranciscoD_> https://bugzilla.redhat.com/show_bug.cgi?id=2041270
13:44:41 <FranciscoD_> that's quite few reviews, which is a very good sign :)
13:44:51 <vanessa_kris[m]> > <@ankursinha:fedora.im> last one is astor, which is almost there. needs a few minor tweaks vanessa_kris
13:44:51 <vanessa_kris[m]> >
13:44:51 <vanessa_kris[m]> > https://bugzilla.redhat.com/show_bug.cgi?id=2041270
13:44:51 <vanessa_kris[m]> Almost done with that it’ll be up before the end of today
13:45:01 <FranciscoD_> #topic F36 compose check
13:45:17 <FranciscoD_> #info Please check this koji task for the F36 comp neuro image's build status: https://koji.fedoraproject.org/koji/packageinfo?packageID=30691
13:45:28 <FranciscoD_> #info All green ticks---building nicely!
13:45:40 <FranciscoD_> #topic Neuroscience query of the week
13:46:17 <FranciscoD_> #info Collect anything neuroscience related that may be of general interest here: https://pagure.io/neuro-sig/NeuroFedora/issue/318
13:46:33 <FranciscoD_> I had a few since our last meeting:
13:46:34 <FranciscoD_> https://medium.com/the-spike/2021-the-review-of-the-year-in-neuroscience-693abea44cd8
13:46:50 <FranciscoD_> ^review of what happened in Neuroscience in 2021, by Professor Mark Humphries
13:47:01 <FranciscoD_> https://www.nature.com/articles/s41593-021-00980-9
13:47:12 <bittin> #info Nonsense correlations in neuroscience
13:47:14 <bittin> #info https://www.biorxiv.org/content/10.1101/2020.11.29.402719v3
13:47:29 <bittin> #info Large-scale neural recordings call for new insights to link brain and behavior
13:47:34 <omnidapps[m]> Hey guys - sorry I couldn’t make it today. Just got back from a weekend trip around Thailand. For next couple of weeks I’m not going to be taking any action items, but I’ll pick up some tasks if I find time. FranciscoD[m]
13:47:49 <FranciscoD_> omnidapps[m]: sure thing, sounds good! Hope you enjoyed your break :)
13:48:31 <FranciscoD_> bittin: this is a review, which talks about how we're now able to record more and more neurons from the brain, but we may now need new theoretical methods/frameworks to make sense of it all :)
13:48:52 <FranciscoD_> I'm not sure it's Open Access, so drop me a ping if you can't access it and i'll send you the PDF
13:49:19 <FranciscoD_> #info omnidapps[m] just got back from a trip and will take on action items in a few weeks
13:49:22 <MeWjOr> it is open access... :D
13:49:46 <FranciscoD_> phew, good!
13:50:07 <FranciscoD_> So, please feel free to add any new ones that you may come across on the planets
13:50:12 <bittin> says it costs 32$ here but oh well
13:50:22 <FranciscoD_> #info Plant neuroscience -> journal papers:  https://neuroblog.fedoraproject.org/planet-neuroscience/
13:50:41 <FranciscoD_> #info Planet neuroscientists -> people of neuroscience: https://neuroblog.fedoraproject.org/planet-neuroscientists/
13:51:18 <FranciscoD_> MeWjOr: I just noticed that neither planet gives a description of what is collects, maybe I should add a line on top to explain? WDYT?
13:52:05 <FranciscoD_> #topic Next meeting day, and chair
13:52:11 <FranciscoD_> In 2 weeks, same time (1300 UTC)?
13:52:14 <MeWjOr> ohh, definitely a good idea... a description would definitely help people who are new to it
13:52:18 <FranciscoD_> if that works for you, please say "+1"
13:52:23 <FranciscoD_> MeWjOr: great, I'll add one
13:52:33 <bittin> +-0 (not sure yet)
13:52:34 <FranciscoD_> #action FranciscoD_ add short description to planets describing what they do
13:52:35 <MeWjOr> awesome! let me know if I can help ;D
13:53:01 <vanessa_kris[m]> +1
13:53:03 <MeWjOr> bittin, ahh, you were talking about the second article you sent... my bad*
13:53:07 <FranciscoD_> I'm +1 for 1300 UTC in 2 weeks
13:53:11 <bittin> MeWjOr, yeah
13:53:21 <FranciscoD_> bittin: is that the nature neuroscience one?
13:53:25 <MeWjOr> +1
13:53:33 <bittin> FranciscoD_, Large-scale neural recordings call for new insights to link brain and behavior one
13:53:46 <FranciscoD_> bittin: Ah, I thought so. one sec
13:54:13 * FranciscoD_ posted a file: (3729KiB) < https://libera.ems.host/_matrix/media/r0/download/fedora.im/c6eade4d5894de3824eff426a2b32b303661d86b/s41593-021-00980-9.pdf >
13:54:18 <FranciscoD_> ^
13:54:41 <bittin> #info https://libera.ems.host/_matrix/media/r0/download/fedora.im/c6eade4d5894de3824eff426a2b32b303661d86b/s41593-021-00980-9.pdf
13:55:00 <MeWjOr> you can also search the articles on google scholar and it often provides many resources which are providing the PDF for free
13:55:11 <FranciscoD_> OK, so next meeting will be at the same time in 2 weeks on Jan 31
13:55:18 <bittin> yep
13:55:26 <FranciscoD_> #agreed next meeting on Jan 31 at 1300 UTC
13:55:33 <bittin> MeWjOr, ah ok
13:55:34 <FranciscoD_> #action FranciscoD_ write up announcement blog post etc.
13:55:39 <FranciscoD_> who'd like to chair the next one?
13:55:49 <FranciscoD_> vanessa_kris: MeWjOr oluyosola ?
13:56:03 <FranciscoD_> (bittin:  not asking you because you may not make it)
13:56:11 <bittin> true
13:56:30 <bittin> (might be back at work then)
13:56:37 <MeWjOr> I wouldn't be too sure about myself, either... I have to manage two computers now and its a mess :'(
13:57:02 <FranciscoD_> MeWjOr: ugh, yeh, I had to install Anydesk on my work computer to use it from home. :(
13:57:17 <FranciscoD_> behind uni network etc. so no possibility of ssh/vnc 😢
13:57:25 <FranciscoD_> OK, I'll chair again in two weeks, no problem
13:57:32 <FranciscoD_> #action FranciscoD_ chair next meeting
13:57:38 <MeWjOr> wish they provided this much flexibility in corporate :clown:
13:57:41 <bittin> so Open Floor time ?
13:57:45 <FranciscoD_> yep
13:57:50 <FranciscoD_> #topic Open floor
13:57:53 * bittin does not have anything
13:57:59 <FranciscoD_> Anything that wasn't on the agenda is welcome here
13:58:11 <FranciscoD_> Otherwise, I'll close in 2 minutes on the hour mark
13:58:26 <FranciscoD_> Thanks all for coming, great to have so many folks at the meeting
13:58:38 <MeWjOr> :D
13:58:40 <FranciscoD_> if there's anything we can help with, do drop a ping here in the channel and someone will get back to you ASAP
13:58:58 <MeWjOr> is there a way we can setup matrix on mobile?
13:59:10 <FranciscoD_> MeWjOr: yeh, just download the element app. Works great.
13:59:16 <bittin> Element has an iOS/Android client
13:59:23 <bittin> / app
13:59:33 <FranciscoD_> you can use it to login to the fedora homeserver, and general matrix both
13:59:38 <FranciscoD_> i.e., it supports "spaces"
13:59:40 <MeWjOr> ooohh,, I didn't know about this... thanks!
13:59:45 <bittin> np
14:00:41 <bittin> #endmeeting