13:00:50 <FranciscoD_> #startmeeting NeuroFedora - 2022-09-26
13:00:50 <zodbot> Meeting started Mon Sep 26 13:00:50 2022 UTC.
13:00:50 <zodbot> This meeting is logged and archived in a public location.
13:00:50 <zodbot> The chair is FranciscoD_. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
13:00:50 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
13:00:50 <zodbot> The meeting name has been set to 'neurofedora_-_2022-09-26'
13:00:56 <FranciscoD_> #meetingname neurofedora
13:00:56 <zodbot> The meeting name has been set to 'neurofedora'
13:01:12 <FranciscoD_> #topic Agenda
13:01:23 <FranciscoD_> #info The agenda is here: https://neuroblog.fedoraproject.org/2022/09/24/next-open-neurofedora-meeting-26-September-1300-utc.html
13:01:33 <FranciscoD_> #topic Introductions and roll call
13:01:43 <FranciscoD_> Please let us know if you're here (and so I can chair you too)
13:01:48 <FranciscoD_> .hello ankursinha
13:01:49 <zodbot> FranciscoD_: ankursinha 'Ankur Sinha' <sanjay.ankur@gmail.com>
13:02:06 <Penguinpee> FranciscoD_: When I looked up my own account earlier, zodbot told me something blew up. 💣
13:02:16 <Penguinpee> .hello gui1ty
13:02:17 <zodbot> Penguinpee: gui1ty 'None' <gui1ty@penguinpee.nl>
13:02:40 <FranciscoD_> Penguinpee: yeh, zodbot sometimes errs with calls :/
13:03:06 <FranciscoD_> #chair Penguinpee Penguinpee
13:03:06 <zodbot> Current chairs: FranciscoD_ Penguinpee
13:03:22 <FranciscoD_> let's wait ~5 minutes for folks to join in
13:05:11 <FranciscoD_> #chair vanessa_kris HafsatAjia-Egbey music
13:05:11 <zodbot> Current chairs: FranciscoD_ HafsatAjia-Egbey Penguinpee music vanessa_kris
13:06:49 <FranciscoD_> #chair davdunc Alessio zbyszek[m] mairacanal mairacanal[m] achilleas aekoroglu major MeWjOr mhough
13:06:49 <zodbot> Current chairs: Alessio FranciscoD_ HafsatAjia-Egbey MeWjOr Penguinpee achilleas aekoroglu davdunc mairacanal mairacanal[m] major mhough music vanessa_kris zbyszek[m]
13:06:56 <FranciscoD_> I can chair others as they come in
13:07:05 <FranciscoD_> #topic Tasks from last meeting
13:07:18 <FranciscoD_> #info Minutes from last meeting (12 Sep) are here: https://meetbot.fedoraproject.org/fedora-neuro/2022-09-12/neurofedora.2022-09-12-13.00.html
13:08:07 <FranciscoD_> #info FranciscoD_ file ticket with releng about python-pyABF repo: request cleaning, and ask if shallow clones can be used -> DONE
13:08:33 <FranciscoD_> vanessa_kris: your build should succeed now, releng cleaned up the repo for us so
13:08:52 <FranciscoD_> Could you try pushing new builds and let us know if that works?
13:09:20 <FranciscoD_> Here's the releng ticket: https://pagure.io/releng/issue/11025
13:09:31 <FranciscoD_> humaton++
13:09:31 <zodbot> FranciscoD_: Karma for humaton changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
13:09:37 <FranciscoD_> .thank humaton
13:09:37 <zodbot> FranciscoD_ thinks humaton is awesome and is happy they are helping! (Please also type humaton++ since that is what gives them a cookie)
13:09:59 <vanessa_kris[m]> This chat room is acting weird, I can’t see previous message but about pyABF the build still failed
13:10:16 <FranciscoD_> oh, hrm, not sure what's up with matrix
13:10:27 <FranciscoD_> I'll take a look at pyABF after the meeting then, and see what's up there
13:10:55 <Penguinpee> I think there are/were some issues with the matrix bridge. I saw a multitude of "giving voice" in various channels earlier.
13:11:04 <FranciscoD_> #action FranciscoD_ look at python-pyABF build issues
13:11:31 <FranciscoD_> Penguinpee: ah, probably with the irc <-> matrix thing---that does also do weird things from time to time
13:11:56 <FranciscoD_> -> FranciscoD update python-mne: https://bugzilla.redhat.com/show_bug.cgi?id=2115503 : I think this is complete, let me quickly check
13:12:35 <FranciscoD_> ah, nope, I've missed this one, reassigning
13:12:49 <FranciscoD_> #action FranciscoD_ update python-mne: https://bugzilla.redhat.com/show_bug.cgi?id=2115503
13:13:12 <FranciscoD_> #info FranciscoD update python-mne: https://bugzilla.redhat.com/show_bug.cgi?id=2115503  -> PENDING, reassigned
13:14:17 <FranciscoD_> -> FranciscoD package up deps for python-pybids update: this is WIP, quite a few deps there
13:14:32 <FranciscoD_> #info FranciscoD package up deps for python-pybids update: https://bugzilla.redhat.com/show_bug.cgi?id=1996270  -> WIP
13:15:47 <FranciscoD_> those are all tasks from the last meeting
13:15:50 <FranciscoD_> next topic
13:16:00 <FranciscoD_> #topic Open Pagure tickets
13:16:21 <FranciscoD_> #info Any tickets that need to be discussed at a meeting should be tagged "next meeting": https://pagure.io/neuro-sig/NeuroFedora/issues?status=Open&tags=S%3A+Next+meeting
13:16:37 <FranciscoD_> #info No tickets to discuss (reading list is discussed in a separate topic)
13:16:56 <FranciscoD_> #topic Package health check
13:17:50 <FranciscoD_> #info Please open up the neuro-sig packager dashboard: https://packager-dashboard.fedoraproject.org/dashboard?groups=neuro-sig
13:18:12 <FranciscoD_> We prioritise in the following order:
13:18:45 <FranciscoD_> - FTBFS/FTI bugs (because if packages remain FTBFS/FTI for too long, they get orphaned/retired as per FESCo policy:  https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs)
13:19:01 <FranciscoD_> - other general bugs in existing packages
13:19:19 <Penguinpee> .bug 2113639
13:19:21 <zodbot> Penguinpee: 2113639 – python-odml: FTBFS in Fedora rawhide/f37 - https://bugzilla.redhat.com/2113639
13:19:29 <FranciscoD_> - package update related bugs (opened either manually or by release-monitoring.org)
13:19:33 <FranciscoD_> and finally:
13:19:44 <FranciscoD_> - anything else, general
13:20:13 <FranciscoD_> #info Suggested bug priority order: Security bugs (CVEs), FTBFS/FTI, other general bugs and updates
13:20:47 <Penguinpee> Sorry. I was a bit to quick. Anyway, above bug should be set to assigned or else the package may get retired.
13:20:49 <lbazan> All my packages are already assigned to neuro-admin.
13:20:59 * lbazan morning!
13:21:01 <FranciscoD_> Penguinpee: hrm, yeh, looks like MeWjOr is a little busy nowadays and hasn't had a look
13:22:10 <FranciscoD_> I've pinged MeWjOr on the bug now. I suggest we wait a week for a response and otherwise take it on ourselves
13:22:29 <Penguinpee> Sounds good.
13:22:33 <FranciscoD_> #info https://bugzilla.redhat.com/show_bug.cgi?id=2113639 -> pinged MeWjOr , wait till 2022-10-03 for response, take over if none
13:23:01 <FranciscoD_> Penguinpee: would you like to keep an eye on this one and look at it if MeWjOr doesn't respond?
13:23:21 <FranciscoD_> it should hopefully be a minor bug---most of these are
13:24:07 <Penguinpee> Sure. I make a note.
13:24:16 <FranciscoD_> great, I'll action you too:
13:24:42 <FranciscoD_> #action Penguinpee keep an eye on https://bugzilla.redhat.com/show_bug.cgi?id=2113639 and take over bug if we don't hear from MeWjOr  in a week
13:25:08 <FranciscoD_> COPASi seems to be FTBFS, but no bugs have been filed about it yet
13:25:27 <FranciscoD_> ah, hold on, it's s390x, maybe COPASI excludes that arch
13:26:00 <FranciscoD_> the spec doesn't say so from what I can see.
13:27:49 <FranciscoD_> I think the info on the dashboard isn't quite up to date, COPASI looks file on Koschei: https://koschei.fedoraproject.org/package/COPASI?collection=f38
13:29:23 <FranciscoD_> #info python-neatdend is FTBFS, filed https://bugzilla.redhat.com/show_bug.cgi?id=2129862
13:30:07 <FranciscoD_> note: you can click on the package in the dashboard and it should take you to the koschei page for FTBFS packages, and if a bug is not filed, you can use koschei to file one
13:31:05 <FranciscoD_> #info python-numpoly is FTBFS for rawhide, filed: https://bugzilla.redhat.com/show_bug.cgi?id=2129863
13:31:30 <FranciscoD_> #info python-nilearn is FTBFS, already filed: https://bugzilla.redhat.com/show_bug.cgi?id=2126115
13:31:33 <FranciscoD_> #action FranciscoD_ fix https://bugzilla.redhat.com/show_bug.cgi?id=2126115
13:31:40 <Penguinpee> You can also filter out Koschei (FTBFS). Icon next to the spanner.
13:31:50 <FranciscoD_> +1
13:33:02 <FranciscoD_> #info python-pynn needs to also excludearch s390x because python-neo now does it
13:33:53 <FranciscoD_> #action FranciscoD_ make pynn excludearch s390x
13:33:59 <Penguinpee> Koschei is totally new to me. Do the FTBFS alerts for Koschei also need attention?
13:34:41 <FranciscoD_> yeh, we should look at them because they tell us that a package isn't currently building properly
13:35:09 <FranciscoD_> folks also manually run the scripts that will file FTBFS/FTI bugs for us as per FESCo policy, so one can even just wait for that
13:35:22 <FranciscoD_> but if we have the time, better to look at koschei and fix issues as they appear
13:35:59 * Penguinpee takes note to read up on Koschei
13:36:23 <FranciscoD_> #action FranciscoD_ also add excludearch for elephant and efel and epyviewer
13:36:35 <FranciscoD_> Penguinpee:  https://fedoraproject.org/wiki/Koschei
13:37:13 <Penguinpee> Thanks. I add it to my ToDo.
13:37:29 <FranciscoD_> #info Packages are healthy: a few minor FTBFS bugs, and then lots of update bugs
13:37:55 <FranciscoD_> #action neuro-sig please update packages by working on the update bugs that release-monitoring.org files for us
13:38:59 <FranciscoD_> #topic Open package reviews check
13:39:22 <FranciscoD_> #info Please open the neuro-sig review tracker bug, and then click on "show advanced fields" to see what review bugs are blocking it: https://bugzilla.redhat.com/show_bug.cgi?id=fedora-neuro
13:39:48 <FranciscoD_> #info Only python-pyABF review is open (because of build issues). No other tickets to review
13:40:21 <FranciscoD_> Penguinpee: so this is the bug you'll block when you open new reviews for any neuro-sig packages. That way, we can easily find then by going to this tracker bug
13:40:36 <FranciscoD_> #topic CompNeuro lab compose status check for Fedora 36/37
13:41:00 <FranciscoD_> #info please head to the koji task for our CompNeuro OS build to see if it's chugging along nicely: https://koji.fedoraproject.org/koji/packageinfo?packageID=30691
13:41:11 <FranciscoD_> #info All good: green ticks for both rawhide and F37
13:41:19 <Penguinpee> Yeah, I understand how this works.
13:41:48 <FranciscoD_> #topic Neuroscience query of the week
13:42:17 <FranciscoD_> #info Anything science/neuroscience related that we want to share with the team goes here. One can also post on the pagure ticket: https://pagure.io/neuro-sig/NeuroFedora/issue/318
13:42:40 <FranciscoD_> I haven't found anything new since the last meeting yet
13:42:50 <FranciscoD_> Haven't had a chance to look at the planets too much, though
13:43:15 <FranciscoD_> #info we host planet neuroscientists: collection of blogs etc. related to neuroscience:  https://neuroblog.fedoraproject.org/planet-neuroscientists/
13:43:33 <FranciscoD_> #info we also host planet-neuroscience: collection of feeds from peer-reviewed journals: https://neuroblog.fedoraproject.org/planet-neuroscience
13:45:27 <FranciscoD_> #topic Next meeting day, and chair
13:45:58 <FranciscoD_> The next meeting will be in 2 weeks: 1300 UTC on October 10
13:46:12 <FranciscoD_> would anyone like to chair (I'm always here as default/backup chair)
13:46:58 <FranciscoD_> #info Next meeting in 2 weeks: 1300 UTC on October 10
13:47:05 <Penguinpee> I would, but not right next week. Taking it slowly. ;)
13:47:18 <FranciscoD_> #info FranciscoD_ will chair
13:47:20 <FranciscoD_> sounds good :)
13:47:34 <FranciscoD_> #topic Open floor
13:47:44 <FranciscoD_> Anything else that needs discussing goes here, we have 13 minutes :)
13:48:43 <Penguinpee> Just a question regarding plotnine. You asked me to open reviews. Does that include the packages that still fail to build?
13:48:50 * FranciscoD_ tries the python-pyabf build in the meantime
13:49:30 <FranciscoD_> Penguinpee: depends on why they fail to build i guess, but usually one doesn't open reviews until at least the package builds (after disabling tests etc. if required)
13:49:46 <FranciscoD_> then in the review we discuss if the tests should remain disabled or if there's a better way to handle them and so on
13:50:14 <FranciscoD_> but is the one that's still failing to build the first one in the dep tree?
13:50:23 <FranciscoD_> otherwise we can review the others until we get to it
13:51:56 <Penguinpee> FranciscoD_: I think we are on the same page. I'll open reviews for the lower dependencies first. Three of the are ready. Do I need to add DEPENDS flags in BZ since mizani depends on plottable?
13:52:12 <Penguinpee> *the packages
13:52:52 <Penguinpee> The review of mizani would be difficult without plottables in rawhide, I guess.
13:52:58 <FranciscoD_> sure, you can use depends there to make the dep tree clear
13:53:18 <FranciscoD_> yeh, if it's a build time requirement, we need to review + build, then go to the next one
13:53:28 <Penguinpee> Okay. I know what to do then. Thanks.
13:53:36 <Penguinpee> If at all possible I would like to give plotnine a tag line: Plot 9 From Outer Space 🪐
13:53:47 <FranciscoD_> haha XD
13:54:08 <Penguinpee> Do you know what it refers to?
13:54:48 <FranciscoD_> just ducked it---1957 horror film?
13:55:27 <Penguinpee> Yeah, dubbed "worst film ever".
13:55:57 <FranciscoD_> LOL
13:56:05 <FranciscoD_> I might give it a go, in that case XD
13:57:35 <FranciscoD_> for the scikit-misc issue, maybe we can try: `sed -i 's:longintrepr.h:cpython/longinrepr.h:' skmisc/loess/src/_loess.c` ?
13:57:48 <FranciscoD_> i.e., patch the file to correct the location of the include
13:58:24 <FranciscoD_> `sed -i 's:\(longintrepr.h\):cpython/\1:' skmisc/loess/src/_loess.c` is better, less error prone
13:58:35 <Penguinpee> I think it's generated. I greped for it. But I'll check again.
13:58:41 <FranciscoD_> but it'll only be required for rawhide, which is where we have py3.11
13:58:53 <FranciscoD_> uh, if it's generated we're out of luck
13:59:44 <Penguinpee> Yeah. It's weird since Cython appears to have fixed that relocation already. I'll poke upstream again.
14:00:28 <FranciscoD_> sounds good, I'll tinker with it if I can find some time too
14:00:35 <Penguinpee> I could also ask on python-devel.
14:00:47 <FranciscoD_> we've hit the hour mark, so let's close the meeting (and we can continue chatting here)
14:00:48 <FranciscoD_> #endmeeting