#fedora-neuro: NeuroFedora - 2023-02-13

Meeting started by FranciscoD_ at 13:00:14 UTC (full logs).

Meeting summary

    1. Agenda: https://neuroblog.fedoraproject.org/2023/02/13/next-open-neurofedora-meeting-13-february-1300-utc.html (FranciscoD_, 13:00:43)

  1. Introductions and roll call (FranciscoD_, 13:01:38)
  2. Tasks from last meeting (FranciscoD_, 13:10:08)
    1. Last meeting logs are here: https://meetbot.fedoraproject.org/fedora-neuro/2023-01-30/neurofedora.2023-01-30-13.00.html (FranciscoD_, 13:10:08)
    2. FranciscoD_ check if typing stub packages are required by packages for anything other than linting -> PENDING (FranciscoD_, 13:10:56)
    3. ACTION: FranciscoD_ check if typing stub packages are required by packages for anything other than linting (FranciscoD_, 13:11:04)
    4. No response from glymur upstream about s390x test failures yet (FranciscoD_, 13:12:36)
    5. ACTION: FranciscoD_ music nudge glymur upstream about s390x failures some time again in a week or so (FranciscoD_, 13:13:58)
    6. Penguinpee nudge odml upstream about rdflib dep progress some time -> DONE (FranciscoD_, 13:15:45)

  3. Open tickets (on Pagure) (FranciscoD_, 13:16:12)
    1. Any tickets to be discussed in the meeting are marked using the "next meeting" tag here: https://pagure.io/neuro-sig/NeuroFedora/issues?status=Open&tags=S%3A+Next+meeting (FranciscoD_, 13:16:40)
    2. https://pagure.io/neuro-sig/NeuroFedora/issue/538 -> Mastodon account for NeuroFedora? (FranciscoD_, 13:17:11)
    3. ACTION: FranciscoD_ mail list about mastodon account ticket (FranciscoD_, 13:24:56)
    4. https://pagure.io/neuro-sig/NeuroFedora/issue/539: Simulation tools comps group: change to "default"? (FranciscoD_, 13:25:21)
    5. AGREED: Mark all packages in neuron modelling sim comps group to default (+3, -0, 0) (FranciscoD_, 13:29:39)
    6. ACTION: Penguinpee update comps to mark all packages in neuron-sim group to "default" (FranciscoD_, 13:30:46)

  4. Packages health check (FranciscoD_, 13:32:18)
    1. Please head to the neuro-sig packager dashboard to get a summary of all our packages: https://packager-dashboard.fedoraproject.org/dashboard?groups=neuro-sig (FranciscoD_, 13:32:36)
    2. We prioritise FTBFS (fails to build from source) and FTI (fails to install) bugs and any CVEs (security bugs), then we look at other issues, and finally for package updates (FranciscoD_, 13:33:46)
    3. FESCo (Fedora Engineering Steering Committee) guidance of FTBFS/FTI is here: https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/ (FranciscoD_, 13:34:25)
    4. In short, if a package does not build from source or does not install for a while, and no action is take, it will be retired (FranciscoD_, 13:34:59)
    5. https://bugzilla.redhat.com/show_bug.cgi?id=2168138 (FranciscoD_, 13:36:20)
    6. ACTION: FranciscoD_ update python-lfpy and fix FTI (FranciscoD_, 13:36:45)
    7. ACTION: @all: please investigate any FTBFS issues and fix them when possible (FranciscoD_, 13:41:12)
    8. A few FTBFS issues pointed by Koschei, a few FTI bugs, and other general "new version is available" bugs: packages look fine in general (FranciscoD_, 13:42:04)

  5. Open package reviews (FranciscoD_, 13:42:48)
    1. Any new neuro-sig software that needs to go through the review process to be added to the Fedora repos should block our "tracker bug": https://bugzilla.redhat.com/show_bug.cgi?id=fedora-neuro (FranciscoD_, 13:43:33)
    2. https://bugzilla.redhat.com/show_bug.cgi?id=2161337 -> python-types-python-dateutil -> required to run tests for datalad -> needs me to check if this is required by the package at all, or is it only a dep for linting. If it's a dep for linting, we patch it out in datalad and don't add it to Fedora (FranciscoD_, 13:46:00)
    3. https://bugzilla.redhat.com/show_bug.cgi?id=2165669 -> python-fspath -> required by python-linuxdoc, which is required to update rtfilter (FranciscoD_, 13:46:58)

  6. Comp Neuro ISO status check for rawhide/F38 (FranciscoD_, 13:49:46)
    1. A quick check to see if the comp-neuro lab ISO is being generated correctly: https://koji.fedoraproject.org/koji/packageinfo?packageID=30691 (FranciscoD_, 13:50:04)
    2. Comp-neuro ISO is currently failing because all composes are failing: https://pagure.io/releng/failed-composes/issues (FranciscoD_, 13:52:08)
    3. also s390x builders is a bit hit and miss atm guess composes will build normal again when they are up again (FranciscoD_, 13:54:58)
    4. ACTION: FranciscoD_ fix python-lfpy FTI because it's also causing our Comp-neuro ISO compose to fail (FranciscoD_, 13:55:37)
    5. s390x builders are down for maintenance (FranciscoD_, 13:56:05)
    6. Thread on -devel to follow: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/4FE3Y6VAH6Q4TFQFVI62XAYYX35WPCPV/#B2AZBYTQU6JA4NWBEVKPHENQ45G4MM7R (FranciscoD_, 13:57:15)

  7. Neuroscience query/info of the week (FranciscoD_, 13:57:51)
    1. Google's demo of its ChatGPT rival doesn't go so well: https://arstechnica.com/information-technology/2023/02/in-paris-demo-google-scrambles-to-counter-chatgpt-but-ends-up-embarrassing-itself/ (FranciscoD_, 13:59:29)

  8. Open floor (FranciscoD_, 14:00:34)
    1. Lots of packages on our backlog: quite a few "good first issue" ones too: https://pagure.io/neuro-sig/NeuroFedora/issues?tags=T%3A+Software&status=Open (FranciscoD_, 14:06:16)
    2. Next meeting in 2 weeks at same time (1300 UTC) (FranciscoD_, 14:12:21)


Meeting ended at 14:12:37 UTC (full logs).

Action items

  1. FranciscoD_ check if typing stub packages are required by packages for anything other than linting
  2. FranciscoD_ music nudge glymur upstream about s390x failures some time again in a week or so
  3. FranciscoD_ mail list about mastodon account ticket
  4. Penguinpee update comps to mark all packages in neuron-sim group to "default"
  5. FranciscoD_ update python-lfpy and fix FTI
  6. @all: please investigate any FTBFS issues and fix them when possible
  7. FranciscoD_ fix python-lfpy FTI because it's also causing our Comp-neuro ISO compose to fail


Action items, by person

  1. FranciscoD_
    1. FranciscoD_ check if typing stub packages are required by packages for anything other than linting
    2. FranciscoD_ music nudge glymur upstream about s390x failures some time again in a week or so
    3. FranciscoD_ mail list about mastodon account ticket
    4. FranciscoD_ update python-lfpy and fix FTI
    5. FranciscoD_ fix python-lfpy FTI because it's also causing our Comp-neuro ISO compose to fail
  2. music
    1. FranciscoD_ music nudge glymur upstream about s390x failures some time again in a week or so
  3. Penguinpee
    1. Penguinpee update comps to mark all packages in neuron-sim group to "default"


People present (lines said)

  1. FranciscoD_ (154)
  2. Penguinpee (34)
  3. zodbot (18)
  4. FrancescoTabaro[ (11)
  5. LunaJernberg[m] (10)
  6. oluyosola[m] (2)
  7. music (0)
  8. vanessa_kris (0)
  9. omnidapps[m] (0)
  10. oluyosola (0)
  11. Francesco (0)
  12. Tabaro (0)


Generated by MeetBot 0.4.