13:00:34 <FranciscoD_> #startmeeting NeuroFedora - 2023-06-19
13:00:34 <zodbot> Meeting started Mon Jun 19 13:00:34 2023 UTC.
13:00:34 <zodbot> This meeting is logged and archived in a public location.
13:00:34 <zodbot> The chair is FranciscoD_. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
13:00:34 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
13:00:34 <zodbot> The meeting name has been set to 'neurofedora_-_2023-06-19'
13:00:39 <FranciscoD_> #meetingname neurofedora
13:00:39 <zodbot> The meeting name has been set to 'neurofedora'
13:00:49 <FranciscoD_> #info Agenda is on the blog: https://neuroblog.fedoraproject.org/2023/06/19/next-open-neurofedora-meeting-19-June-1300-utc.html
13:00:56 <FranciscoD_> #info bot commands: https://fedoraproject.org/wiki/Meeting:Guide#MeetBot_Commands
13:01:01 <FranciscoD_> #topic Introductions and roll call
13:01:06 <FranciscoD_> .hellowmynameis ankursinha
13:01:44 <FranciscoD_> .hellomynameis ankursinha
13:01:45 <zodbot> FranciscoD_: ankursinha 'Ankur Sinha' <sanjay.ankur@gmail.com>
13:01:53 <FranciscoD_> there we go
13:02:11 <FranciscoD_> I'll wait here till 5 past
13:06:11 <FranciscoD_> .members neuro-sig
13:06:13 <zodbot> FranciscoD_: Members of neuro-sig: sagitter, ignatenkobrain, bt0dotninja, zbyszek, sergiopr, blackfile, ankursinha, lbazan, ilgrad, gicmo, alciregi, nerdsville, mhough, music, major, fangq, anilbey, iztokf, aekoroglu, gui1ty, shaneallcroft, hardeborlaa, mairacanal, vanessakris
13:06:44 <FranciscoD_> #topic Tasks from last meeting
13:06:52 <FranciscoD_> #info last meeting logs are here: https://meetbot.fedoraproject.org/latest/neurofedora
13:07:23 <FranciscoD_> #info FranciscoD_ open issue/PR in package maintainer docs about re-triggering CI on PRs: PENDING
13:07:29 <FranciscoD_> forgot about these, re-assigning
13:07:33 <FranciscoD_> #action FranciscoD_ open issue/PR in package maintainer docs about re-triggering CI on PRs
13:07:47 <FranciscoD_> #info FranciscoD_ start non-responsive maintainer checks for Ilya: PENDING
13:07:51 <FranciscoD_> #action FranciscoD_ start non-responsive maintainer checks for Ilya
13:08:18 <FranciscoD_> #info Penguinpee ask around if Koschei can be made to send notifications to the ML or automatically file bugs: PENDING (since Penguinpee has been on vacation since last meeting from what I know)
13:08:19 <FranciscoD_> #action Penguinpee ask around if Koschei can be made to send notifications to the ML or automatically file bugs
13:08:31 <FranciscoD_> #topic Open pagure tickets
13:08:35 <FranciscoD_> #info https://pagure.io/neuro-sig/NeuroFedora/issues?status=Open&tags=S%3A+Next+meeting
13:09:08 <FranciscoD_> #info https://pagure.io/neuro-sig/NeuroFedora/issue/549 -> NeuroFedora at Flock: we've submitted a CFP
13:10:47 <FranciscoD_> #info https://pagure.io/neuro-sig/NeuroFedora/issue/551 -> Discussion on EPEL support: to be discussed in the ticket, please do take a look and comment
13:10:54 <Penguinpee> .hello gui1ty
13:10:55 <zodbot> Penguinpee: gui1ty 'Sandro .' <gui1ty@penguinpee.nl>
13:11:06 <Penguinpee> Sorry for being late. Got sidetracked.
13:11:43 <Penguinpee> Yeah, I'll pick up the Koschei notifications issue again.
13:13:06 <FranciscoD_> ah, no worries, I thought you were still on vacation?
13:13:06 <FranciscoD_> although I did see your replies on the -devel list today, which made me question my thought XD
13:13:20 <FranciscoD_> #info https://pagure.io/neuro-sig/NeuroFedora/issue/552 -> using packit to help with neuro-sig package maintenance: only opened this a few hours ago, so we'll discuss it next meeting when folks have had a chance to look into things
13:14:02 <Penguinpee> Packit looks promising. I may try it on some of my own packages in the course of the coming weeks.
13:15:10 <Penguinpee> I got back from vacation Thursday night. Back to work tomorrow. It took me the better part of the weekend to catch up.
13:15:46 <FranciscoD_> Cool, I took over the vxl ticket in the meantime, have made some headway
13:16:15 <FranciscoD_> yeh, packit looks very useful, if it can help us with some of the simpler package update type tasks, that'll help us
13:16:28 <Penguinpee> Nice! I'll leave vxl to you then.
13:16:37 <FranciscoD_> Sure thing. I haven't been doing any builds in the past week because I'm waiting for the python3.12 builds to complete
13:17:26 <Penguinpee> Yeah. I saw that. I still have other, non-Python, packages I need to attend to.
13:17:42 <FranciscoD_> #info https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/message/ZTID6MR7TU2X6ZKDGGH7RR426ODUEENX/ -> python 3.12 rebuild is in progress, please hold off building python and related packages until this is complete
13:18:19 <FranciscoD_> #
13:18:33 <FranciscoD_> #info Python 3.12 side tag on Koji: https://koji.fedoraproject.org/koji/builds?latest=0&tagID=f39-python&order=-build_id&inherited=0
13:18:49 <FranciscoD_> #topic Packages health check
13:19:19 <FranciscoD_> #info Neuro-sig packager dashboard: https://packager-dashboard.fedoraproject.org/dashboard?groups=neuro-sig
13:19:41 <FranciscoD_> #info Please ignore s390x FTBFS reports if the package exludes s390x as a build arch.
13:20:17 <FranciscoD_> #info A few python packages have new versions available: we'll wait until the py3.12 rebuild is over to tackle these
13:20:51 <FranciscoD_> #info Same applies to ftbfs bugs
13:21:31 <Penguinpee> Well, we can test the FTBFS packages on the stable branches, can we not?
13:22:08 <FranciscoD_> yeh, stable branches are good
13:22:26 <FranciscoD_> #info Continue FTBFS investigations on stable branches (since they're unaffected by the re-build)
13:23:04 <FranciscoD_> packages going FTBFS on stable branches usually indicate a dep update, which means the maintainers of packages did not do a complete impact assessment---this was being discussed in the -devel thread
13:25:01 <Penguinpee> I hope to be able to spare some cycles for working on FTBFS packages. New releases could be queued by way of PR, which we only merge after the Python 3.12 side tag has been merged.
13:27:59 <Penguinpee> I just looked at the FTBFS (F38) for python-neurotune: No dependency changes. Might be a false positive. There has been some discussion on the devel list about noarch packages failing on some archs (e.g. i686).
13:28:41 <FranciscoD_> #info FTBFS reports for these packages in stable branches: arbor (f37), genesis-simulator (f38), getdp (f38), highfive (f38), libneurosim (f38), libsbml (f38), libsonata (f37), morphio (f38), python-astor (f37), python-bluepyopt (f37, f38), python-cyiopt (f37), python-dipy (f38), python-mne (f37, f38), python-neatdend (f37), python-neurotune (f38), python-nibabel (f37), python-nilearn (f38), python-nipy (f38, f37), python-pandas (f37),
13:28:41 <FranciscoD_> python-pyswarms (f38, f37), python-pyunicorn (f38, f37), python-steps (f38)
13:29:39 <FranciscoD_> Yeh -> https://koschei.fedoraproject.org/package/python-neurotune?collection=f38
13:29:56 <Penguinpee> OSError: [Errno 28] No space left on device: '/tmp/mock-resolv.dbitjql0'
13:30:21 <FranciscoD_> yeh, these will fix themselves when koschei checks them next
13:30:29 <Penguinpee> Would a simple scratch build make this go away on the Koschei dashboard?
13:30:39 <FranciscoD_> #info Some FTBFS koschei reports could be false positives -> builders ran out of space
13:31:07 <FranciscoD_> Penguinpee: I don't think so, but I don't know. I think koschei has to do the build. No harm trying?
13:31:33 <Penguinpee> Sure. I'll try.
13:32:54 <FranciscoD_> the wiki page doesn't say anything about manual re-triggers: https://fedoraproject.org/wiki/Koschei#Your_packages
13:35:54 <FranciscoD_> Other than the FTBFS issues, packages are fine
13:36:06 <FranciscoD_> #topic Open package reviews check: https://bugzilla.redhat.com/show_bug.cgi?id=fedora-neuro
13:36:11 <FranciscoD_> #undo
13:36:11 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x7f1e0245fa58>
13:36:19 <FranciscoD_> #topic Open package reviews check
13:36:28 <FranciscoD_> #info Neuro-sig reviews tracker bug: https://bugzilla.redhat.com/show_bug.cgi?id=fedora-neuro
13:36:48 <FranciscoD_> #info Please remember to block this when submitting a new review so that all sig members are notified
13:37:11 <Penguinpee> Oh. I didn't know about the wiki. Thanks for the link. I may have spotted the answer regarding FTBFS bugs. But I'll ask around nonetheless.
13:38:16 <FranciscoD_> #info one review ticket open: https://bugzilla.redhat.com/show_bug.cgi?id=2213973 -> should be easy, if someone has the cycles, please take it up (blocks the python-bokeh update)
13:38:45 <Penguinpee> How are new packages affected by the mass rebuild for Python 3.12?
13:39:20 <FranciscoD_> hrm, I think the review can go ahead, but one should perhaps not commit/build until the rebuild is completed
13:39:58 <FranciscoD_> #action FranciscoD_ mail -devel about review swap if package not picked up in a few days
13:40:12 <Penguinpee> Or notify the Pythonistas doing the mass rebuild?
13:41:31 <FranciscoD_> Yeh, could do---but they'll have to update their package list and then run the build etc.
13:41:47 <FranciscoD_> probably simpler to wait for the mass rebuild to finish and then add new packages
13:44:15 <FranciscoD_> #topic Comp neuro image compose check
13:44:20 <FranciscoD_> #info koji task here: https://koji.fedoraproject.org/koji/packageinfo?packageID=30691
13:44:34 <FranciscoD_> #info Green tick, all going along fine here
13:44:53 <FranciscoD_> #topic Neuro(science) query of the week
13:45:46 <FranciscoD_> #info Not neuro related, but one related to all the LLMs: https://venturebeat.com/ai/the-ai-feedback-loop-researchers-warn-of-model-collapse-as-ai-trains-on-ai-generated-content/
13:46:13 <FranciscoD_> I don't remember coming across anything else too interesting
13:48:14 <FranciscoD_> #info https://www.sciencenews.org/article/supermassive-black-hole-orbit-blazar
13:48:18 <FranciscoD_> #info https://www.sciencenews.org/article/one-photon-photosynthesis-light
13:48:54 <FranciscoD_> #info https://blog.arxiv.org/2023/06/12/arxiv-is-hiring-software/ (job opportunity at arxiv)
13:49:44 <FranciscoD_> that's all I can find on the planet
13:49:56 <FranciscoD_> #topic next meeting day, chair
13:50:44 <FranciscoD_> #info same time (1300 UTC), in 2 weeks (03 July)
13:50:50 <FranciscoD_> #info ankursinha will chair
13:50:54 <FranciscoD_> #topic Open floor
13:51:29 <FranciscoD_> we've got ~10 minutes here, for anything that wasn't discussed already
13:52:00 <Penguinpee> I haven't read the full LLM article yet. But the headline makes it sound like other diseases caused by feeding an organism with stuff it wouldn't eat by itself, e.g CJD (aka mad cow disease).
13:54:43 <FranciscoD_> yeh, I guess the thing is---what is the LLM supposed to eat? If it's meant to "eat the whole internet" as it does now, it will end up eating lots of things it and other LLMs produce
13:55:08 <FranciscoD_> the article does point out some fixes, I'm sure the big LLM corps are working on these already
13:55:30 <Penguinpee> I tried to access your proposal for Flock. But I was nagged into filling out a form and didn't bother. Is it available somewhere else FranciscoD_?
13:55:58 <Penguinpee> "I'm sure the big LLM corps are working on these" <-- For sure. They need to protect their assets.
13:56:49 <FranciscoD_> Penguinpee: I can update the comment with the text, I think one has to sign into the flock cfp portal to see it  there
13:58:16 <Penguinpee> Yeah. And upon signing in I have to provide details. Some of which I believe should be pre-filled with FAS data if that is the login method one chooses.
13:59:06 <Penguinpee> No biggie. I'll try again and may nag some people as to why all that is required.
13:59:16 <FranciscoD_> +1
13:59:20 <FranciscoD_> I added the abstract etc. to our ticket
13:59:43 <Penguinpee> ankursinha++
13:59:52 <Penguinpee> FranciscoD_++
14:00:11 <Penguinpee> .fasinfo ankursinha
14:00:12 <zodbot> Penguinpee: User: ankursinha, Name: Ankur Sinha, Email: sanjay.ankur@gmail.com, Creation: 2008-05-28T06:16:53, IRC Nicks: FranciscoD and FranciscoD_, Timezone: Europe/London, Locale: en-GB, GPG Key IDs: E629112D, Status: None
14:00:15 <zodbot> Penguinpee: Groups: fedora-contributor, ask-fedora, fedora-join, fedorabugs, freemedia, gitfedora-tour, gitfpaste, neuro-sig, packager, provenpackager, qa, robotics-sig, scitech, scitech_sig, wikiedit
14:00:30 <Penguinpee> No cookies for you, I guess. ;)
14:00:36 <FranciscoD_> no cookies till the next release cycle :(
14:00:37 <FranciscoD_> yeh
14:01:03 <FranciscoD_> Cool, thanks for coming as usual Penguinpee . We've hit the hour mark, I'll close the meeting now and send out the logs
14:01:05 <Penguinpee> What does zodbot think? One cannot live on one cokkie per release alone.
14:01:05 <FranciscoD_> #endmeeting