13:02:44 <FranciscoD_> #startmeeting NeuroFedora - 2023-07-03
13:02:44 <zodbot> Meeting started Mon Jul  3 13:02:44 2023 UTC.
13:02:44 <zodbot> This meeting is logged and archived in a public location.
13:02:44 <zodbot> The chair is FranciscoD_. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
13:02:44 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
13:02:44 <zodbot> The meeting name has been set to 'neurofedora_-_2023-07-03'
13:02:49 <FranciscoD_> #meetingname neurofedora
13:02:49 <zodbot> The meeting name has been set to 'neurofedora'
13:02:56 <FranciscoD_> @room: https://fedoraproject.org/wiki/Meeting:Guide#MeetBot_Commands
13:03:08 <FranciscoD_> @room:  https://neuroblog.fedoraproject.org/2023/07/03/next-open-neurofedora-meeting-03-July-1300-utc.html
13:03:15 <FranciscoD_> #topic Introductions and roll call
13:03:23 <FranciscoD_> .members neuro-sig
13:03:24 <zodbot> FranciscoD_: Members of neuro-sig: sagitter, ignatenkobrain, bt0dotninja, zbyszek, sergiopr, blackfile, ankursinha, lbazan, ilgrad, gicmo, alciregi, nerdsville, mhough, music, major, fangq, anilbey, iztokf, aekoroglu, gui1ty, shaneallcroft, hardeborlaa, mairacanal, vanessakris
13:04:24 <FranciscoD_> we'll wait here for ~5 mins for folks to join
13:04:37 <Penguinpee> .hello gui1ty
13:04:38 <zodbot> Penguinpee: gui1ty 'Sandro .' <gui1ty@penguinpee.nl>
13:04:45 <FranciscoD_> .hello ankursinha
13:04:46 <zodbot> FranciscoD_: ankursinha 'Ankur Sinha' <sanjay.ankur@gmail.com>
13:05:09 <AniketPradhan[m]> Hello folks... Aniket/major/mewjor here... I used to actively contribute sometime ago, but here I'm again 😀
13:05:28 <AniketPradhan[m]> * Hello folks... Aniket/major/mewjor here... I used to actively contribute sometime ago, but here I am again 😀
13:05:29 <Penguinpee> Welcome back!
13:05:34 <AniketPradhan[m]> .hello major
13:05:35 <zodbot> AniketPradhan[m]: major 'Aniket Pradhan' <aniketpradhan1999@gmail.com>
13:05:52 <AniketPradhan[m]> Missed zodbot :'P
13:06:35 <FranciscoD_> Aniket Pradhan: o/
13:06:40 <FranciscoD_> major++
13:06:40 <zodbot> FranciscoD_: Karma for major changed to 1 (for the release cycle f38):  https://badges.fedoraproject.org/tags/cookie/any
13:06:47 <FranciscoD_> welcome back cookies :)
13:07:13 <AniketPradhan[m]> 😻
13:07:36 <AniketPradhan[m]> Love the emoji support on Matrix... Freenode was meh
13:08:26 <FranciscoD_> haha
13:08:27 <Penguinpee> 🍪 🥠 🍪
13:08:32 <FranciscoD_> cool, let's proceed with the agenda
13:08:44 <FranciscoD_> #topic Tasks from last meeting
13:08:57 <FranciscoD_> #info Last meeting minutes are here: https://meetbot.fedoraproject.org/fedora-neuro/2023-06-19/neurofedora.2023-06-19-13.00.html
13:09:35 <music[m]> .hello music
13:09:36 <zodbot> music[m]: music 'Benjamin Beasley' <code@musicinmybrain.net>
13:09:38 <FranciscoD_> #info FranciscoD_ open issue/PR in package maintainer docs about re-triggering CI on PRs -> DONE -> https://pagure.io/fedora-docs/package-maintainer-docs/pull-request/129 (merged)
13:10:04 <FranciscoD_> I also opened this which needs more of a review to see what bits are now outdated: https://pagure.io/fedora-docs/package-maintainer-docs/pull-request/130
13:10:46 <FranciscoD_> #info FranciscoD_ start non-responsive maintainer checks for Ilya -> DONE -> https://bugzilla.redhat.com/show_bug.cgi?id=2219364 +  https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/DRWWW2Q3IZEIUFT2BEXPJSIDS76D6UPK/
13:11:16 <FranciscoD_> #info FranciscoD_ mail -devel about review swap if package not picked up in a few days -> Not needed, IIRC Penguinpee reviewed the package and we've imported it now
13:11:35 <FranciscoD_> Penguinpee ask around if Koschei can be made to send notifications to the ML or automatically file bugs
13:11:42 <FranciscoD_> Penguinpee: ^ any luck with this?
13:11:55 <Penguinpee> I have been told: FTBFS bugs are only filed after mass rebuilds, not from koschei data.
13:12:30 <FranciscoD_> Yeh, I thought so. One can manually use the koschei web interface to file new FTBFS bugs, but that's a bit of work
13:12:30 <Penguinpee> Notifications to list I didn't get an answer. Will poke again. But it probably needs an admin to set this up, if at all.
13:12:38 <FranciscoD_> Yeh
13:12:50 <Penguinpee> Koschei is not in in the new FMN yet, though.
13:13:04 <FranciscoD_> ah, I was just checking https://notifications.fedoraproject.org/
13:13:27 <Penguinpee> There's an issue for that. IIRC, it needs a patch for Koschei as well.
13:13:43 <FranciscoD_> Doesn't matter, we'll just do our package health checks and keep on top of things every two weeks until this is possible
13:14:03 <music[m]> Penguinpee: thanks!
13:14:20 <Penguinpee> Yep, without FTBFS filed by Koschei the notifications become obsolete, anyway.
13:14:35 <FranciscoD_> #info Penguinpee ask around if Koschei can be made to send notifications to the ML or automatically file bugs -> DONE -> currently not possible to receive e-mail notifications from koschei
13:15:20 <Penguinpee> Once FMN supports Koschei, I will setup notifications for my own packages to start with.
13:15:55 <FranciscoD_> those are all that tasks, unless there are any comments on these, we can move on to the next topic?>
13:16:19 <FranciscoD_> Yeh, that'll be good. We could even setup notifications for our packages and send it to the private ML, the one where bugzilla notifications go
13:16:48 <FranciscoD_> #topic Open pagure tickets
13:16:59 <FranciscoD_> #info https://pagure.io/neuro-sig/NeuroFedora/issues?status=Open&tags=S%3A+Next+meeting
13:17:02 <Penguinpee> You cannot select a target other than the e-mail addresses known to FAS in FMN.
13:17:47 <FranciscoD_> Penguinpee: yeh, but sometimes infra can setup things that the various frontends cannot, so it may be possible
13:17:51 <Penguinpee> Not on the list, but we may need to discuss vxl.
13:18:05 <FranciscoD_> Please refresh the pagure issues page folks, I just added the vxl issue to the list
13:18:10 <FranciscoD_> Penguinpee: you beat me to it ^
13:18:18 <Penguinpee> https://pagure.io/neuro-sig/NeuroFedora/issue/548
13:18:36 <FranciscoD_> let's start with this one
13:18:57 <FranciscoD_> #info Issue #548: Review vxl package with regards to license and stripping lenna image
13:20:02 <FranciscoD_> I think the primary issue here is that upstream usually responds with "we don't have the resources, please do the work and open a PR"
13:20:21 <Penguinpee> My suggestion is to get rid of vxl and use have InsightToolkit expose its bundled vxl.
13:20:59 <FranciscoD_> we could look into that, but it does mean that the version of vxl we ship will be the one ITK bundles
13:21:11 <FranciscoD_> does ITK solve the issues we're looking at?
13:21:21 <FranciscoD_> if it does, we could look at replicating what they do with the main vxl package instead?
13:21:43 <Penguinpee> Yes. They have removed the triangle stuff. music[m] commented about it.
13:21:44 <FranciscoD_> removing lenna is easy, the triangle part is trickier
13:21:57 <FranciscoD_> there is a license included, even if it's in a header file..
13:22:30 <Penguinpee> License and Lenna are easy to solve. It's triangle that's troublesome.
13:22:41 <FranciscoD_> Yeh, here it is: https://github.com/InsightSoftwareConsortium/ITK/pull/1920/files
13:22:56 <FranciscoD_> could do that
13:23:28 <Penguinpee> I think ITK has bundled vxl exactly for that reason - triangle not being FOSS licensed.
13:24:03 <music[m]> Not clear if ITK’s patch is easy to apply to vxl upstream, or if they only patched the parts they use rather than all the parts impacted by Triangle removal.
13:24:36 <FranciscoD_> let me see what debian do :P
13:25:25 <FranciscoD_> https://sources.debian.org/patches/vxl/ -> I *think* this is the latest
13:25:27 <Penguinpee> I think OpenSuSE may also be worth checking. They opened the issue on vxl upstream.
13:25:33 <FranciscoD_> they seem to be carrying my soname etc. patches
13:25:51 <FranciscoD_> Penguinpee: I saw that, looked like they decided to not include vxl (or that's the impression I got from the ticket).
13:25:53 <FranciscoD_> let me fetch it
13:26:27 <FranciscoD_> https://build.opensuse.org/request/show/817960 -> they were including ITK with the bundled vxl
13:26:31 <FranciscoD_> I think?
13:26:36 <Penguinpee> That's a lot of patches!
13:27:53 <FranciscoD_> I see no mention of triangle in the vxl debian page, but I did find this: https://packages.debian.org/sid/libdevel/libtriangle-dev
13:28:33 <FranciscoD_> https://tracker.debian.org/pkg/vxl -> hrm?
13:28:47 <FranciscoD_> "package is gone"
13:29:04 <music[m]> https://www.debian.org/doc/debian-policy/ch-archive.html#the-non-free-archive-area
13:30:05 <Penguinpee> But they do ship triangle, even though it's "non-free"?
13:30:23 <FranciscoD_> I guess it's their way of shipping it  in RPM Fusion?
13:30:31 * FranciscoD_ doesn't know debian's system very well
13:30:41 <music[m]> above link applies to triangle
13:30:47 <Penguinpee> How about moving vxl to RPMFusion?
13:31:03 <FranciscoD_> yeh, could do that, will still have to patch it out of vxl, though
13:31:16 <FranciscoD_> debian seems to have just dropped it and use the ITK bundle: https://lists.debian.org/debian-med/2016/09/msg00042.html
13:32:07 <FranciscoD_> from: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=837355
13:32:07 <Penguinpee> That boils down to my suggestion: drop vxl in favor of bundled vxl from ITK.
13:32:33 <Penguinpee> bundled and patched, making it compatible license wise.
13:32:49 <FranciscoD_> what version is ITK bundling?
13:32:58 <Penguinpee> no idea
13:33:04 <FranciscoD_> basically: do they seem like they update their bundle when new releases of vxl are released?
13:33:27 <FranciscoD_> bundling has downsides.. we also don't know how much work it'll be to make the itk package provide vxl-devel for the other deps
13:33:55 <FranciscoD_> debian does not include alizams from the looks of it
13:34:32 <FranciscoD_> nor petpvc: https://tracker.debian.org/search?package_name=petpvc
13:34:40 <FranciscoD_> which are two deps on vxl, apart from ITK
13:34:53 <FranciscoD_> https://tracker.debian.org/search?package_name=alizams
13:36:44 <Penguinpee> For these packages wee need to have ITK provide vxl-devel.
13:37:34 <Penguinpee> ITK does merge upstream vxl.
13:38:06 <music[m]> Note that it looks like both packages really depend just on ITK, but need a vxl header as part of the APIs.
13:38:06 <FranciscoD_> Yeh, I found this: https://github.com/InsightSoftwareConsortium/ITK/commit/1d9710fbc8915e0262d215bc2343171c16b31b0c
13:38:06 <music[m]> (However, I’m not taking time to read a lot of sources for this one.)
13:38:12 <FranciscoD_> trying to see what they did with triangle
13:38:34 <Penguinpee> They removed triangle, didn't they music[m]?
13:39:14 <FranciscoD_> https://github.com/InsightSoftwareConsortium/ITK/tree/1d9710fbc8915e0262d215bc2343171c16b31b0c/Modules/ThirdParty/VNL -> "contains a portion of vxl"
13:39:31 <Penguinpee> I can have a look at what's possible with having ITK expose its bundled vxl.
13:40:11 <FranciscoD_> OK, how about I look into patching out triangle from vxl first, since that's the "right thing to do"
13:40:22 <FranciscoD_> if that doesn't work, you can look at tweaking itk to expose vxl?
13:40:43 <Penguinpee> That's also fine. But if ITK has already done that, why re-invent the wheel.
13:41:15 <FranciscoD_> because bundling is a PITA in general, and usually causes more issues that it solves..
13:41:27 <FranciscoD_> we'll also have to check to see if ITK's vxl does provide everything that native vxl does
13:41:47 <Penguinpee> Alright. You give it a try first FranciscoD_ and if it's too much of a hassle, I can look into the bundled vxl.
13:42:24 <FranciscoD_> I can't find it at the mo, but I do remember the guidelines also stating that each src rpm should only provide one software package
13:42:31 <Penguinpee> I'm not keen on it, but I dislike upstream's responses and unwillingness to take care of their own dog food.
13:42:46 <FranciscoD_> so, it's OK for ITK to bundle vxl, but may not be OK to use it to generate vxl-devel etc
13:43:16 <music[m]> Relatedly, I suspect ITK and vxl both have a ton of bundled libraries that should ideally be looked at in the medium term. But incorrect bundling is a much lower priority than license issues.
13:43:18 <FranciscoD_> yeh, I've had to submit quite a few patches to vxl before, which is why it's usually quite low on my task list---it's usually quite a bit of work for each update :(
13:43:19 <Penguinpee> We could always ask for an exemption given the vxl situatiion and pointing at other distros.
13:43:42 <FranciscoD_> yeh, ITK is quite a PITA with bundling too
13:43:47 <FranciscoD_> they bundle everything IIRC
13:43:54 <FranciscoD_> which is why it's also a pain to update
13:44:02 <Penguinpee> Terrible!
13:45:55 <FranciscoD_> here's another example: https://github.com/vxl/vxl/issues/627
13:46:35 <FranciscoD_> (scroll to the last few comments for context on vxl maintenance)
13:46:56 <FranciscoD_> the pitfalls of academic software---folks don't get paid to maintain it
13:47:19 <FranciscoD_> it's changing now, but mostly maintaining software in research/academia is still a "labour of love" :/
13:47:37 <FranciscoD_> anyway, I'll update the ticket to note what we discussed here, and try to patch out triangle etc. Let's see how that goes
13:47:55 <Penguinpee> That's why I'd rather get rid of it and focus on one difficult package instead of two.
13:48:05 <FranciscoD_> #action FranciscoD_ work on patching out triangle from vxl etc. to update it
13:48:47 <FranciscoD_> #info Issue #552: Using packit for some package updates (simpler python packages?) -> https://pagure.io/neuro-sig/NeuroFedora/issue/552
13:48:54 <FranciscoD_> not urgent, I just thought it may help us
13:49:10 <FranciscoD_> with simpler packages where it'll open PRs for us to review automatically
13:49:35 <Penguinpee> I haven't looked into it yet.
13:50:11 <FranciscoD_> yeh, me neither. Maybe I'll experiment with a very simple package and see how hard it is to get it setup
13:50:50 <FranciscoD_> does sound great..
13:51:19 <FranciscoD_> #info https://packit.dev/posts/pull-from-upstream/ -> has steps described
13:51:27 <AniketPradhan[m]> Ohh, i remember packit from packit-ogr
13:52:06 <Penguinpee> Do we have a volunteer?
13:52:13 <AniketPradhan[m]> Maybe I can look into it if no one is currently working on it... Could be a good coming back package to work on
13:52:49 <FranciscoD_> sounds good Aniket Pradhan ---maybe test on a package that has frequent releases?
13:53:02 <FranciscoD_> let me check, one sec
13:53:27 <Penguinpee> AniketPradhan[m]: You can take the ticket and add your findings. That would be great.
13:54:19 <FranciscoD_> I think python-trimesh has a frequent release cycle -> almost two releases a month: https://pypi.org/project/trimesh/#history
13:54:33 <FranciscoD_> https://src.fedoraproject.org/rpms/python-trimesh
13:55:07 <FranciscoD_> music: what do you think of testing packit out on python-trimesh, since you usually do the updates?
13:55:08 <AniketPradhan[m]> Haha, i remember seeing plenty emails for trimesh in my mailbox
13:55:47 <Penguinpee> tempus fugit
13:56:10 <FranciscoD_> woah, yeh, we're at the hour almost
13:56:33 <FranciscoD_> let's skip the other tix for the moment, they're not that important
13:56:42 <FranciscoD_> Oh, yeh, our talk at flock was accepted btw
13:57:00 <FranciscoD_> #action FranciscoD_ update ticket wtih flock talk updates
13:57:10 <FranciscoD_> #action Aniket Pradhan look into using packit for updates, on python-trimesh
13:57:18 <Penguinpee> Nice! Less nice: Cork is expensive! More expensive than I thought/hoped.
13:57:38 <FranciscoD_> uh, I haven't looked at it at all, need to get a visa appointment asap too
13:57:55 <music[m]> FranciscoD_: I haven’t learned much about packit yet, but trimesh seems like an OK target for trying it.
13:58:45 <FranciscoD_> cool, thanks
13:59:06 <FranciscoD_> I think we'll need to skip the other topics today folks, we're out of time pretty much
13:59:15 <music[m]> Penguinpee: For a moment I thought you were renovating your floors.
13:59:44 <FranciscoD_> and I won't make it to the next meeting on 17th, I'll be at a conference:  https://www.cnsorg.org/cns-2023-quick
13:59:45 <Penguinpee> music[m]: ??? What typo did I make now?
14:00:06 <Penguinpee> I can chair the next meeting, if you'd like me to.
14:00:09 <FranciscoD_> #info FranciscoD_ will be at CNS*2023, will miss next meeting: https://www.cnsorg.org/cns-2023-quick
14:00:15 <FranciscoD_> Penguinpee: that'll be awesome :)
14:00:21 <FranciscoD_> #info Penguinpee to chair next meeting
14:00:32 <FranciscoD_> #info Next meeting in two weeks on July 17 at 1300 UTC
14:00:48 <FranciscoD_> I'll write up the blog etc. and send out the reminder and all that
14:01:10 <Penguinpee> FranciscoD_++
14:01:15 <music[m]> Penguinpee: None! Cork (the tree bark) is an old-school alternative to wood floors.
14:01:37 <music[m]> Also a city in Ireland, of course.
14:02:00 <Penguinpee> Oh yeah! No, no plans for renovating. Although I could use a new floor...
14:02:14 <FranciscoD_> #info Skip other topics today because we're out of time
14:02:27 <FranciscoD_> I'll close the meeting now, and we can do the other bits asynchronously (as we do anyway)
14:02:30 <FranciscoD_> #endmeeting