2023-10-09 12:57:17
         <@ankursinha:fedora.im>  
        !startmeeting 
        
2023-10-09 12:57:18 <@meetbot:fedora.im> Meeting started at 2023-10-09 12:57:17 UTC
2023-10-09 12:57:18 <@meetbot:fedora.im> The Meeting name is 'NeuroFedora'
2023-10-09 12:57:23 <@ankursinha:fedora.im> there we go
2023-10-09 12:57:43 <@gui1ty:fedora.im> Excellent! It's alive (and kicking).
2023-10-09 12:58:01 <@ankursinha:fedora.im> !meetingname neurofedora
2023-10-09 12:58:42 <@ankursinha:fedora.im> I think I should've used the pretty name with the first command but oh well..
2023-10-09 12:58:53 <@gui1ty:fedora.im> Long time ago. Feeling a bit rusty.
2023-10-09 12:59:05 <@ankursinha:fedora.im> !info Agenda: https://neuroblog.fedoraproject.org/2023/10/09/next-open-neurofedora-meeting-09-October-1300-utc.html
2023-10-09 12:59:37 <@ankursinha:fedora.im> !topic Introductions and roll call
2023-10-09 12:59:40 <@ankursinha:fedora.im> .members neuro-sig
2023-10-09 12:59:51 <@ankursinha:fedora.im> @room ^ please join the meeting if you are around
2023-10-09 12:59:55 <@gui1ty:fedora.im> That would be `!members`.
2023-10-09 13:00:11 <@ankursinha:fedora.im> ah, I thought zodbot would still perform normally?
2023-10-09 13:00:13 <@ankursinha:fedora.im> !members
2023-10-09 13:00:22 <@ankursinha:fedora.im> !members neuro-sig
2023-10-09 13:00:25 <@gui1ty:fedora.im> !members neuro-sig
2023-10-09 13:00:32 <@ankursinha:fedora.im> zodbot: members neuro-sig
2023-10-09 13:00:37 <@ankursinha:fedora.im> @ping
2023-10-09 13:00:42 <@ankursinha:fedora.im> zodbot seems down
2023-10-09 13:00:48 <@ankursinha:fedora.im> or something has changed..
2023-10-09 13:00:51 <@gui1ty:fedora.im> It's maubot!
2023-10-09 13:01:13 <@ankursinha:fedora.im> ah, so the whole bot has changed? I thought only the meeting specific bits had changed..
2023-10-09 13:01:20 <@ankursinha:fedora.im> so maybe the other commands haven't been ported over yet?
2023-10-09 13:01:21 <@gui1ty:fedora.im> Meet Bot: members neuro-sig
2023-10-09 13:01:42 <@gui1ty:fedora.im> Yeah, I think this is for meetings only.
2023-10-09 13:01:55 <@gui1ty:fedora.im> !hello gui1ty
2023-10-09 13:02:02 <@gui1ty:fedora.im> !hello
2023-10-09 13:02:08 <@gui1ty:fedora.im> !hi
2023-10-09 13:02:23 <@gui1ty:fedora.im> No luck. :-\
2023-10-09 13:02:33 <@ankursinha:fedora.im> FranciscoD: Members of neuro-sig: sagitter, ignatenkobrain, bt0dotninja, zbyszek, sergiopr, blackfile, ankursinha, lbazan, ilgrad, gicmo, alciregi, nerdsville, mhough, music, major, fangq, anilbey, iztokf, aekoroglu, gui1ty, shaneallcroft, hardeborlaa, mairacanal, vanessakris
2023-10-09 13:02:42 <@ankursinha:fedora.im> I think zodbot needs a restart or whatever
2023-10-09 13:02:53 <@ankursinha:fedora.im> *if* it's still meant to work with these fedora specific commands
2023-10-09 13:03:01 <@gui1ty:fedora.im> Hallelujah! 👼
2023-10-09 13:03:14 <@ankursinha:fedora.im> let's wait here for a bit, we started a tad early
2023-10-09 13:04:22 <@gui1ty:fedora.im> Ankur Sinha (FranciscoD@fedora): You are cheating! 😉
2023-10-09 13:04:41 <@ankursinha:fedora.im> yep, using zodbot on IRC :P
2023-10-09 13:05:15 <@ankursinha:fedora.im> !topic Tasks from last meeting
2023-10-09 13:05:31 <@ankursinha:fedora.im> !info Last meeting minutes are here: https://neuroblog.fedoraproject.org/2023/10/09/next-open-neurofedora-meeting-09-October-1300-utc.html
2023-10-09 13:05:44 <@ankursinha:fedora.im> oops, nope not there
2023-10-09 13:05:45 <@ankursinha:fedora.im> !undo
2023-10-09 13:05:56 <@ankursinha:fedora.im> hrm, maybe undo is not a thing yet
2023-10-09 13:06:06 <@ankursinha:fedora.im> !info Last meeting minutes are here: https://meetbot.fedoraproject.org/fedora-neuro/2023-09-11/neurofedora.2023-09-11-13.00.html
2023-10-09 13:06:27 <@ankursinha:fedora.im> !info No action items from last meeting
2023-10-09 13:06:38 <@ankursinha:fedora.im> !topic Open Pagure tickets
2023-10-09 13:06:44 <@gui1ty:fedora.im> I'm sure you will have lots of feedback after the meeting...
2023-10-09 13:07:14 <@ankursinha:fedora.im> !info Pagure tickets are here: https://pagure.io/neuro-sig/NeuroFedora/issues?status=Open&tags=S%3A+Next+meeting
2023-10-09 13:07:27 <@ankursinha:fedora.im> The only ticket to look at is the vxl one, which I'm still plodding along with
2023-10-09 13:07:38 <@ankursinha:fedora.im> let's action that to me again so it stays high on my task list XD
2023-10-09 13:08:02 <@gui1ty:fedora.im> Shall I open a formal license review ticket on GitLab. I still have to do that for a package of mine under review.
2023-10-09 13:08:21 <@ankursinha:fedora.im> for vxl? I think there's already a ticket about it on GitHub etc.
2023-10-09 13:08:42 <@gui1ty:fedora.im> Okay. I'll leave you to it then.
2023-10-09 13:08:52 <@ankursinha:fedora.im> https://github.com/vxl/vxl/issues/752#issuecomment-1594999896
2023-10-09 13:09:14 <@gui1ty:fedora.im> I meant a Fedora / Red Hat internal license review.
2023-10-09 13:09:59 <@gui1ty:fedora.im> But that's maybe out of scope. I may be thinking about a different package. I heard music mention a full review somewhere.
2023-10-09 13:09:59 <@ankursinha:fedora.im> Hrm, could do, but maybe let me get the package updated etc. after stripping out what I can and then we can see if we need legal to bless it?
2023-10-09 13:10:43 <@gui1ty:fedora.im> Let's keep it actioned to you and decide on next steps later.
2023-10-09 13:10:48 <@ankursinha:fedora.im> +1
2023-10-09 13:11:16 <@gui1ty:fedora.im> !info All packages are added to CI / Zuul now.
2023-10-09 13:11:28 <@ankursinha:fedora.im> !action FranciscoD continue working on vxl update
2023-10-09 13:11:41 <@ankursinha:fedora.im> yeh, thanks so much for the zuul bits
2023-10-09 13:11:52 <@ankursinha:fedora.im> do we need to note somewhere that we should add all new packages to zuul to?
2023-10-09 13:12:41 <@gui1ty:fedora.im> I would say let's do it periodically or make it a task of main admins to add their own packages.
2023-10-09 13:12:49 <@ankursinha:fedora.im> cool
2023-10-09 13:13:04 <@gui1ty:fedora.im> It's not a lot of work. I just had all of mine added and music did the same.
2023-10-09 13:13:06 <@ankursinha:fedora.im> we don't really have a neurofedora specific SOP about this, we tend to follow the general package maintainer's docs
2023-10-09 13:13:38 <@gui1ty:fedora.im> It could be part of _flag the tracking bug_...
2023-10-09 13:13:50 <@ankursinha:fedora.im> +1, let's add it there
2023-10-09 13:13:59 <@ankursinha:fedora.im> and maybe it could be point 16 here: https://docs.fedoraproject.org/en-US/package-maintainers/New_Package_Process_for_Existing_Contributors/
2023-10-09 13:14:21 <@gui1ty:fedora.im> !info NeuroFedora tracking bug is now also aliased to, eh, `NeuroFedora`. 🧠
2023-10-09 13:14:30 <@ankursinha:fedora.im> I'm assuming zuul folks are happy to have everyone add their packages, right?
2023-10-09 13:14:37 <@ankursinha:fedora.im> it's not still a "limited release" kind of thing?
2023-10-09 13:14:59 <@gui1ty:fedora.im> I don't know, to be honest. I heard no-one complaining....
2023-10-09 13:15:13 <@ankursinha:fedora.im> then that's fine, as long as no one said "no, this is too much"
2023-10-09 13:15:28 <@gui1ty:fedora.im> Seeing it was announced on Python SIG mailinglist, I think we are good.
2023-10-09 13:16:22 <@ankursinha:fedora.im> !info Adding packages to zuul: https://fedoraproject.org/wiki/Zuul-based-ci
2023-10-09 13:16:43 <@ankursinha:fedora.im> !topic Packages health check
2023-10-09 13:16:56 <@ankursinha:fedora.im> !info Neuro-sig packages dashboard: https://packager-dashboard.fedoraproject.org/dashboard?groups=neuro-sig
2023-10-09 13:17:27 <@ankursinha:fedora.im> !info We prioritise Fails to build from source (FTBFS) and fails to install (FTI) bugs along with CVEs, followed by general bugs and new package releases etc.
2023-10-09 13:17:48 <@gui1ty:fedora.im> I guess we can skip the F37 FTBFS issues?
2023-10-09 13:18:22 <@ankursinha:fedora.im> yeh, let's not spend resources in F37 any more
2023-10-09 13:18:49 <@ankursinha:fedora.im> I see a few FTBFS, but none of them look new
2023-10-09 13:19:02 <@ankursinha:fedora.im> most of them we are aware of and working on
2023-10-09 13:19:05 <@gui1ty:fedora.im> What's the difference between `fedora-health-check` and Koschei on the dashboard? Different sources of truth?
2023-10-09 13:20:14 <@gui1ty:fedora.im> !info The dashboard also has a nice overview of open PRs!
2023-10-09 13:20:45 <@ankursinha:fedora.im> oo, not sure what fedora-health-check is..
2023-10-09 13:22:00 <@ankursinha:fedora.im> they both seem to indicate FTBFS bugs..
2023-10-09 13:22:07 <@ankursinha:fedora.im> let me pop over to -devel and ask
2023-10-09 13:25:03 <@ankursinha:fedora.im> I guess we could check the sources etc., but let's see if we can get an idea more easily ;)
2023-10-09 13:25:35 <@ankursinha:fedora.im> https://packager-dashboard.fedoraproject.org/helpmepls -> FTBFS is koschei only but health-check is both FTI + FTBFS
2023-10-09 13:26:00 <@ankursinha:fedora.im> maybe the health-check is when Miro runs his script, so it's not part of the koschei CI, and will show some results that koschei has already pointed out..
2023-10-09 13:27:30 <@ankursinha:fedora.im> Anyway, packages look fine
2023-10-09 13:27:43 <@ankursinha:fedora.im> !info Packages are in good health: a few FTBFS bugs, and new releases.
2023-10-09 13:27:54 <@gui1ty:fedora.im> All right. I'll look into the issues for packages I recently worked on like `highfive` FTBFS in F38.
2023-10-09 13:28:26 <@ankursinha:fedora.im> !info Please do add a packit config file when updating a package if you can, it automates some of the menial work, example: https://src.fedoraproject.org/rpms/snakemake/blob/rawhide/f/.packit.yaml
2023-10-09 13:28:33 <@ankursinha:fedora.im> sounds good
2023-10-09 13:28:51 <@ankursinha:fedora.im> !topic Open package reviews check
2023-10-09 13:29:02 <@gui1ty:fedora.im> `cc1plus: all warnings being treated as errors` doesn't sound like what we want...
2023-10-09 13:29:18 <@ankursinha:fedora.im> !info All neuro-sig package reviews should "block" the fedora-neuro/neurofedora tracker bug: https://bugzilla.redhat.com/show_bug.cgi?id=fedora-neuro (that way all sig members are notified)
2023-10-09 13:29:33 <@ankursinha:fedora.im> that's a compilation flag: `-Wall` probably
2023-10-09 13:30:01 <@ankursinha:fedora.im> which I think is in the default build flags..
2023-10-09 13:30:19 <@ankursinha:fedora.im> ```$ echo $CXXFLAGS -O2 -flto=auto -ffat-lto-objects -fexceptions -g -grecord-gcc-switches -pipe -Wall -Wno-complain-wrong-lang -Werror=format-security -Wp,-U_FORTIFY_SOURCE,-D_FORTIFY_SOURCE=3 -Wp,-D_GLIBCXX_ASSERTIONS -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -fstack-protector-strong -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -m64 -mtune=generic -fasynchronous-unwind-tables -fstack-clash-protection -fcf-protection -fno-omit-frame-pointer -mno-omit-leaf-frame-pointer ```
2023-10-09 13:30:38 <@ankursinha:fedora.im> ``` $ echo $CXXFLAGS -O2 -flto=auto -ffat-lto-objects -fexceptions -g -grecord-gcc-switches -pipe -Wall -Wno-complain-wrong-lang -Werror=format-security -Wp,-U_FORTIFY_SOURCE,-D_FORTIFY_SOURCE=3 -Wp,-D_GLIBCXX_ASSERTIONS -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -fstack-protector-strong -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -m64 -mtune=generic -fasynchronous-unwind-tables -fstack-clash-protection -fcf-protection -fno-omit-frame-pointer -mno-omit-leaf-frame-pointer ```
2023-10-09 13:31:02 <@ankursinha:fedora.im> wait no, I got that wrong
2023-10-09 13:31:15 <@ankursinha:fedora.im> `-Werror` does that, not `-Wall`
2023-10-09 13:31:32 <@gui1ty:fedora.im> I'm pretty sure "treat all warnings as errors" is not the default. Rather something upstream might have set.
2023-10-09 13:31:51 <@ankursinha:fedora.im> yeh, that's from upstream, we don't use `-Werror`, only `-Werror=format-security`
2023-10-09 13:32:32 <@ankursinha:fedora.im> !info Only one review in progress: https://bugzilla.redhat.com/show_bug.cgi?id=2242026
2023-10-09 13:32:36 <@gui1ty:fedora.im> Back to the topic: `python-pyuca` needs a license review for the Unicode license 😥
2023-10-09 13:32:54 <@ankursinha:fedora.im> yeh, this one needs legal review
2023-10-09 13:32:58 <@ankursinha:fedora.im> let's hope it goes through
2023-10-09 13:32:58 <@gui1ty:fedora.im> Spyde 6.x requires `pyuca`.
2023-10-09 13:33:14 <@gui1ty:fedora.im> I think it will. But it takes time.
2023-10-09 13:34:04 <@gui1ty:fedora.im> Spyder 6.x requires `pyuca`.
2023-10-09 13:34:15 <@ankursinha:fedora.im> cool,
2023-10-09 13:34:23 <@ankursinha:fedora.im> is it an optional dep, or will spyder not work at all without it?
2023-10-09 13:35:12 <@gui1ty:fedora.im> Since 6.x is still a pre-release I haven't looked into it, but went ahead and submitted the review. I will check.
2023-10-09 13:35:36 <@ankursinha:fedora.im> cool, maybe worth waiting till legal gives a result
2023-10-09 13:35:44 <@ankursinha:fedora.im> if all's OK, you won't need to look into spyder etc
2023-10-09 13:36:10 <@gui1ty:fedora.im> Yeah, as long as 6.x is not released I can hold back on it. It's all preparation for when it lands.
2023-10-09 13:36:20 <@ankursinha:fedora.im> cool
2023-10-09 13:36:37 <@ankursinha:fedora.im> !topic CompNeuro lab compose check for F39/rawhide
2023-10-09 13:36:46 <@ankursinha:fedora.im> !info All good: https://koji.fedoraproject.org/koji/packageinfo?packageID=30691
2023-10-09 13:37:03 <@ankursinha:fedora.im> !topic Neuro(science) query of the week
2023-10-09 13:37:09 <@ankursinha:fedora.im> Not a lot new that I've seen
2023-10-09 13:37:35 <@ankursinha:fedora.im> there's this that's worth knowing, given how commonly SWC is used as a format
2023-10-09 13:37:50 <@ankursinha:fedora.im> !info https://www.incf.org/commentaries/swc -> INCF review request for the SWC format for storing neuronal morphologies
2023-10-09 13:38:27 <@ankursinha:fedora.im> One can see lots of (pretty!) neurons at NeuroMorpho.org
2023-10-09 13:38:38 <@ankursinha:fedora.im> !info See neuronal morphologies at https://neuromorpho.org/
2023-10-09 13:39:14 <@gui1ty:fedora.im> Can we get that as a screensaver (if that's still a thing these days)?
2023-10-09 13:39:31 <@ankursinha:fedora.im> Can probably get wallpapers, not sure if a screensaver is still a thing XD
2023-10-09 13:41:08 <@gui1ty:fedora.im> It makes me think of fractals like Mandelbrot. Mesmerizing!
2023-10-09 13:41:30 <@ankursinha:fedora.im> here are a couple I generated last week, the top is a Layer 2/3 Pyramidal cell in humans
2023-10-09 13:42:04 <@ankursinha:fedora.im> the lower one is a model of an olfactory bulb: https://v1.opensourcebrain.org/projects/miglioreetal14_olfactorybulb3d
2023-10-09 13:42:34 <@gui1ty:fedora.im> `Your connection is not private` Ouch!
2023-10-09 13:42:51 <@ankursinha:fedora.im> oo, is that the v1 link?
2023-10-09 13:43:02 <@gui1ty:fedora.im> Yes: `Expires On Sunday, October 8, 2023 at 12:42:54 PM`
2023-10-09 13:43:08 <@ankursinha:fedora.im> ah, of course
2023-10-09 13:45:02 <@gui1ty:fedora.im> Ankur Sinha (FranciscoD@fedora): Time to merge the NeuroM PR? 🙂
2023-10-09 13:45:16 <@ankursinha:fedora.im> yeh, let me take a look, ones sec
2023-10-09 13:45:21 <@ankursinha:fedora.im> s/ones/one/
2023-10-09 13:46:05 <@ankursinha:fedora.im> https://src.fedoraproject.org/rpms/python-neurom/pull-request/5# -> this one?
2023-10-09 13:46:11 <@ankursinha:fedora.im> OK to rebase it I guess?
2023-10-09 13:46:21 <@gui1ty:fedora.im> You may have to merge the Packit PR first and then mine. Not sure.
2023-10-09 13:46:45 <@gui1ty:fedora.im> Not sure why it wouldn't cleanly merge. It's based on top of the Packit PR.
2023-10-09 13:47:12 <@ankursinha:fedora.im> I'll check locally, always find that easier than using pagure for anything a little advanced XD
2023-10-09 13:47:14 <@gui1ty:fedora.im> Yeah, rebasing is also fine.
2023-10-09 13:49:14 <@ankursinha:fedora.im> find to rebase, I'll go do that now
2023-10-09 13:50:30 <@gui1ty:fedora.im> Yeah. It looks like I rebased the packit branch. The commit hashes are different.
2023-10-09 13:50:40 <@ankursinha:fedora.im> no worries, all sorted
2023-10-09 13:50:48 <@ankursinha:fedora.im> I closed the packit PR too, since yours had it already
2023-10-09 13:50:57 <@gui1ty:fedora.im> As long as it applies cleanly (fast-forward) it's fine. If not, I need to take a look.
2023-10-09 13:51:19 <@ankursinha:fedora.im> applied fine, all nice and linear now :)
2023-10-09 13:51:34 <@ankursinha:fedora.im> !topic Next meeting day + chair
2023-10-09 13:51:34 <@gui1ty:fedora.im> Excellent! 🎉
2023-10-09 13:52:01 <@ankursinha:fedora.im> Same time in 2 weeks? Now that we have meetbot working, we can get back to our normal schedules :)
2023-10-09 13:52:23 <@gui1ty:fedora.im> Sure! Works for me.
2023-10-09 13:52:44 <@ankursinha:fedora.im> !agreed next meeting in 2 weeks at same time: 23 October 2023, 1300 UTC
2023-10-09 13:52:57 <@ankursinha:fedora.im> !info FranciscoD will chair
2023-10-09 13:53:01 <@ankursinha:fedora.im> !topic Open floor
2023-10-09 13:53:04 <@ankursinha:fedora.im> Anything else? :)
2023-10-09 13:53:17 <@gui1ty:fedora.im> Ankur Sinha (FranciscoD@fedora): Will you update NeuroM or shall I?
2023-10-09 13:53:42 <@ankursinha:fedora.im> I can do it, will get packit to do the rawhide build and then run my `fedpkg-sync-...` script for the other branches
2023-10-09 13:54:12 <@gui1ty:fedora.im> sounds good
2023-10-09 13:54:39 <@gui1ty:fedora.im> I have nothing for open floor.
2023-10-09 13:54:54 <@ankursinha:fedora.im> awesome, nothing here of note I can think of either
2023-10-09 13:55:14 <@ankursinha:fedora.im> !info Meet Bot worked wonderfully!
2023-10-09 13:55:31 <@ankursinha:fedora.im> only thing missing was the "undo" command, I can file an issue for that (or check to see if one is already filed)
2023-10-09 13:55:35 <@gui1ty:fedora.im> Big questions: where will the logs go?
2023-10-09 13:55:43 <@ankursinha:fedora.im> the github page says they should go to mote
2023-10-09 13:56:00 <@ankursinha:fedora.im> https://github.com/GregSutcliffe/maubot-meetings
2023-10-09 13:56:20 <@ankursinha:fedora.im> we'll need to update this page for the new bot: https://fedoraproject.org/wiki/Meeting:Guide#MeetBot_Commands
2023-10-09 13:56:29 <@ankursinha:fedora.im> maybe just add a new column for this new bot
2023-10-09 13:56:35 <@ankursinha:fedora.im> and gotta see why zodbot isn't talking to us
2023-10-09 13:57:35 <@gui1ty:fedora.im> Not sure. Doesn't it require the bridge? I thought they are rewriting zodbot for Matrix as well.
2023-10-09 13:58:58 <@ankursinha:fedora.im> maybe the zodbot here is just a "ghost" hanging about
2023-10-09 13:59:04 <@ankursinha:fedora.im> they'd probably need to re-write it for matrix, yeh
2023-10-09 13:59:08 <@ankursinha:fedora.im> !endmeeting