2023-10-23 13:01:48
         <@ankursinha:fedora.im>  
        !startmeeting NeuroFedora - 2023-10-23
        
2023-10-23 13:01:48 <@meetbot:fedora.im> Meeting started at 2023-10-23 13:01:48 UTC
2023-10-23 13:01:49 <@meetbot:fedora.im> The Meeting name is 'NeuroFedora - 2023-10-23'
2023-10-23 13:01:54 <@ankursinha:fedora.im> !meetingname neurofedora
2023-10-23 13:02:12 <@ankursinha:fedora.im> !info Agenda for today's meeting is here: https://neuroblog.fedoraproject.org/2023/10/23/next-open-neurofedora-meeting-23-October-1300-utc.html
2023-10-23 13:02:33 <@ankursinha:fedora.im> !topic Introductions and roll call
2023-10-23 13:02:42 <@ankursinha:fedora.im> @room please join the meeting if you're around and available
2023-10-23 13:02:47 <@ankursinha:fedora.im> !members neuro-sig
2023-10-23 13:02:54 <@ankursinha:fedora.im> !help members
2023-10-23 13:02:55 <@zodbot:fedora.im> `members` is not a valid command
2023-10-23 13:03:05 <@ankursinha:fedora.im> !group neuro-sig
2023-10-23 13:03:06 <@zodbot:fedora.im> **Usage:** !group <subcommand> [...] ● members <groupname> - Return a list of members of the specified group ● sponsors <groupname> - Return a list of owners of the specified group ● info <groupname> - Return a list of owners of the specified group
2023-10-23 13:03:12 <@ankursinha:fedora.im> !group members neuro-sig
2023-10-23 13:03:13 <@zodbot:fedora.im> Members of neuro-sig: aekoroglu, alciregi, anilbey, Ankur Sinha, blackfile, bt0dotninja, fangq, gicmo, Sandro ., hardeborlaa, ignatenkobrain, ilgrad, iztokf, lbazan, Maíra Canal, Aniket Pradhan, mhough, Benjamin Beasley, Josh Santos, sagitter, sergiopr, shaneallcroft, vanessakris, Zbigniew Jędrzejewski-Szmek
2023-10-23 13:03:21 <@gui1ty:fedora.im> !hello
2023-10-23 13:03:22 <@zodbot:fedora.im> Sandro . (gui1ty)
2023-10-23 13:03:27 <@ankursinha:fedora.im> !hello
2023-10-23 13:03:28 <@zodbot:fedora.im> Ankur Sinha (ankursinha) - he / him / his
2023-10-23 13:03:41 <@ankursinha:fedora.im> let's wait here for a few minutse
2023-10-23 13:03:46 <@ankursinha:fedora.im> s/minutse/minutes/
2023-10-23 13:06:45 <@ankursinha:fedora.im> !topic Tasks from last meeting
2023-10-23 13:06:55 <@ankursinha:fedora.im> !info Last meeting logs are here: https://meetbot.fedoraproject.org/neuro_matrix_fedoraproject-org/2023-10-09/neurofedora.2023-10-09-12.57.html
2023-10-23 13:07:29 <@ankursinha:fedora.im> !info Only task there is for me(FranciscoD) to continue working on vxl, I'll give a progress update about that later
2023-10-23 13:07:38 <@ankursinha:fedora.im> !topic Open Pagure tickets
2023-10-23 13:07:56 <@ankursinha:fedora.im> !info Open pagure tickets are here: https://pagure.io/neuro-sig/NeuroFedora/issues?status=Open&tags=S%3A+Next+meeting
2023-10-23 13:09:13 <@ankursinha:fedora.im> !info #548: vxl package update and license audit: https://pagure.io/neuro-sig/NeuroFedora/issue/548
2023-10-23 13:09:31 <@ankursinha:fedora.im> !info Almost got it to build after backporting changes from previous release
2023-10-23 13:09:46 <@ankursinha:fedora.im> !info Also removed triangle, and recursively, everything that depends on it
2023-10-23 13:10:14 <@gui1ty:fedora.im> Nice job! On to the legal part....
2023-10-23 13:10:33 <@ankursinha:fedora.im> !info An initial license audit with licensecheck shows quite a jumble of licenses: https://pagure.io/neuro-sig/NeuroFedora/issue/548#comment-880107
2023-10-23 13:10:41 <@ankursinha:fedora.im> yeh, that'll be fun
2023-10-23 13:10:55 <@ankursinha:fedora.im> but at least all of it looks FOSS now (from a quick glance)
2023-10-23 13:11:28 <@ankursinha:fedora.im> I'll open a PR when I can get it to build, and then start on the license audit
2023-10-23 13:11:46 <@ankursinha:fedora.im> !action FranciscoD open a PR when build is ready, and then do license audit
2023-10-23 13:12:26 <@gui1ty:fedora.im> `stripping lenna image` - do you really need to make it worse? 🤣
2023-10-23 13:13:09 <@ankursinha:fedora.im> I'll see if there's an alternative image that we can give upstream
2023-10-23 13:14:18 <@ankursinha:fedora.im> !topic Package health check
2023-10-23 13:14:28 <@ankursinha:fedora.im> !info Neuro sig package dashboard is here: https://packager-dashboard.fedoraproject.org/dashboard?groups=neuro-sig
2023-10-23 13:17:29 <@gui1ty:fedora.im> Plenty of FTBFS. All good on FTI. Is that the correct conclusion?
2023-10-23 13:19:17 <@ankursinha:fedora.im> yeh, even fewer FTBFS issues if we only look at F39/rawhide
2023-10-23 13:19:55 <@gui1ty:fedora.im> And if we leave out exotic arches even less.
2023-10-23 13:20:04 <@ankursinha:fedora.im> +1
2023-10-23 13:20:52 <@ankursinha:fedora.im> lots of FTBFS bugs in F37, and I'd expect a majority of them are because some package we depend on got updated
2023-10-23 13:21:43 <@ankursinha:fedora.im> but the versions of these packages that have been pushed to users should continue to function fine
2023-10-23 13:22:55 <@ankursinha:fedora.im> hrm, koschei is throwing me a 502
2023-10-23 13:23:58 <@gui1ty:fedora.im> Works for me. Old build that has been cleaned up maybe?
2023-10-23 13:24:29 <@ankursinha:fedora.im> back up now, must've fallen over
2023-10-23 13:25:29 <@ankursinha:fedora.im> Cool, I guess we keep chipping away on the packages as usual
2023-10-23 13:25:47 <@ankursinha:fedora.im> !info Packages look fine, please fix FTBFS/FTI bugs and updates etc. as you get time
2023-10-23 13:26:07 <@ankursinha:fedora.im> !topic Open package reviews
2023-10-23 13:26:12 <@ankursinha:fedora.im> !info NeuroFedora review tracker: https://koschei.fedoraproject.org/package/python-pybids?collection=f38
2023-10-23 13:26:17 <@ankursinha:fedora.im> *sigh*,
2023-10-23 13:26:18 <@ankursinha:fedora.im> that's not it
2023-10-23 13:26:31 <@ankursinha:fedora.im> !info NeuroFedora review tracker: https://bugzilla.redhat.com/show_bug.cgi?id=fedora-neuro
2023-10-23 13:27:23 <@ankursinha:fedora.im> !info python-pyuca required by latest spyder: is under license review: https://bugzilla.redhat.com/show_bug.cgi?id=2242026
2023-10-23 13:28:03 <@ankursinha:fedora.im> !info python-vhackdx approved, waiting on import etc: https://bugzilla.redhat.com/show_bug.cgi?id=2243830
2023-10-23 13:28:13 <@gui1ty:fedora.im> It's not moving very fast, though. But I put in an official license review request.
2023-10-23 13:28:43 <@ankursinha:fedora.im> yeh, the official requests take a bit of time, but it should get done soonish hopefully 🤞
2023-10-23 13:29:04 <@ankursinha:fedora.im> !info python-lqrt: reviewed, waiting on submitter (me!): https://bugzilla.redhat.com/show_bug.cgi?id=2244809
2023-10-23 13:30:00 <@ankursinha:fedora.im> !action FranciscoD go over python-lqrt review and update package as per comments
2023-10-23 13:30:26 <@ankursinha:fedora.im> !topic CompNeuroFedora image build check
2023-10-23 13:30:43 <@ankursinha:fedora.im> !info https://koji.fedoraproject.org/koji/packageinfo?packageID=30691 -> All good ✅
2023-10-23 13:31:02 <@ankursinha:fedora.im> I believe F39 is now scheduled for release on October 31
2023-10-23 13:31:22 <@gui1ty:fedora.im> 🎃
2023-10-23 13:31:35 <@ankursinha:fedora.im> https://fedorapeople.org/groups/schedule/f-39/f-39-releng-tasks.html -> point 35
2023-10-23 13:31:47 <@ankursinha:fedora.im> !topic Neuroscience query of the week
2023-10-23 13:32:27 <@ankursinha:fedora.im> I don't think anything new/general has happened recently in neuroscience
2023-10-23 13:32:36 <@ankursinha:fedora.im> lots of papers as usual, but nothing of general interest (that I can recall)
2023-10-23 13:34:50 <@ankursinha:fedora.im> https://www.sciencenews.org/article/aging-enzyme-restore-muscle-strength -> seems interesting
2023-10-23 13:35:22 <@ankursinha:fedora.im> https://www.sciencenews.org/article/citizen-scientists-2024-solar-eclipse
2023-10-23 13:36:10 <@gui1ty:fedora.im> That's visible only on North America, isn't it?
2023-10-23 13:36:28 <@ankursinha:fedora.im> Some good pics: https://www.sciencenews.org/article/2023-nikon-small-world-photography
2023-10-23 13:36:37 <@ankursinha:fedora.im> yeh, I think that's the case
2023-10-23 13:37:36 <@ankursinha:fedora.im> https://www.wired.com/story/how-hop-nerds-are-saving-your-favorite-beer-from-climate-change/
2023-10-23 13:38:26 <@gui1ty:fedora.im> Catchy headline. Did I mention `brewtarget` is available in Fedora?
2023-10-23 13:39:13 <@gui1ty:fedora.im> !whoowns brewtarget
2023-10-23 13:39:13 <@zodbot:fedora.im> **owner:** gui1ty
2023-10-23 13:39:29 <@ankursinha:fedora.im> nice!
2023-10-23 13:39:45 <@ankursinha:fedora.im> https://packages.fedoraproject.org/pkgs/brewtarget/brewtarget/
2023-10-23 13:40:18 <@ankursinha:fedora.im> !topic Next meeting, and chair
2023-10-23 13:40:28 <@gui1ty:fedora.im> I have yet to make use of it myself... 🍻
2023-10-23 13:40:34 <@ankursinha:fedora.im> same time in 2 weeks?
2023-10-23 13:41:01 <@gui1ty:fedora.im> That should work for me.
2023-10-23 13:41:18 <@gui1ty:fedora.im> !info DST ends in Europe next weekend.
2023-10-23 13:42:47 <@ankursinha:fedora.im> +1, yeh, I've got to make sure I get my times right
2023-10-23 13:42:57 <@ankursinha:fedora.im> !topic Open floor
2023-10-23 13:43:40 <@gui1ty:fedora.im> Not much. BluePyOpt still has failing tests with `pebble >= 4.6`. :-\
2023-10-23 13:44:08 <@ankursinha:fedora.im> :(
2023-10-23 13:44:11 <@ankursinha:fedora.im> that's unfortunate
2023-10-23 13:44:37 <@ankursinha:fedora.im> is it the pebble related test?
2023-10-23 13:44:57 <@ankursinha:fedora.im> vxl also has some random test failing here, unrelated to my tinkering
2023-10-23 13:45:27 <@gui1ty:fedora.im> Yes, two of them still fail. I'm about to send a WIP PR. But you can easily test it with current rawhide, except for the typo.
2023-10-23 13:45:59 <@ankursinha:fedora.im> sounds good
2023-10-23 13:47:25 <@gui1ty:fedora.im> Nothing else on my part, really.
2023-10-23 13:47:36 <@ankursinha:fedora.im> yeh, I can't think of anything else either
2023-10-23 13:47:38 <@ankursinha:fedora.im> let's close
2023-10-23 13:47:39 <@ankursinha:fedora.im> !endmeeting