14:00:24 <sgallagh> #startmeeting OpenLMI (2013-12-02)
14:00:25 <zodbot> Meeting started Mon Dec  2 14:00:24 2013 UTC.  The chair is sgallagh. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:25 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:01:22 <sgallagh> #meetingname OpenLMI Public IRC Meeting
14:01:22 <zodbot> The meeting name has been set to 'openlmi_public_irc_meeting'
14:01:22 <sgallagh> Come on, zodbot...
14:01:23 <zodbot> sgallagh: Error: Can't start another meeting, one is in progress.
14:01:26 <zodbot> sgallagh: Error: Can't start another meeting, one is in progress.
14:01:43 <sgallagh> #chair sgallagh tsmetana jsafrane rdoty
14:01:43 <zodbot> Current chairs: jsafrane rdoty sgallagh tsmetana
14:01:51 <sgallagh> #info Meetings are recorded and will be posted on www.openlmi.org. Opinions expressed do not necessarily reflect the reviews of the participant's employer.
14:01:56 <sgallagh> #topic Roll Call
14:02:01 <sgallagh> .hellomynameis sgallagh
14:02:03 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
14:03:04 <sgallagh> Anyone else here?
14:03:33 <jsafrane> .hellomynameis jsafrane
14:03:34 <zodbot> jsafrane: jsafrane 'Jan Šafránek' <jsafrane@redhat.com>
14:03:40 <tbzatek> .hellomynameis tbzatek
14:03:43 <zodbot> tbzatek: tbzatek 'Tomas Bzatek' <tbzatek@redhat.com>
14:04:03 <rnovacek> .hellomynameis rnovacek
14:04:04 <zodbot> rnovacek: rnovacek 'Radek Novacek' <rnovacek@redhat.com>
14:04:25 <sgallagh> kkaempf: Are you around today?
14:04:41 <sgallagh> rdoty: ?
14:04:54 <kkaempf> Oh, sorry, sure I am.
14:05:19 <kkaempf> .hellomynameis kkaempf
14:05:20 <zodbot> kkaempf: Sorry, but you don't exist
14:06:19 <sgallagh> Ok, I have three agenda items for today. The first was a follow-up on OpenLMI 1.0.1 plans.
14:06:39 <sgallagh> kkaempf: I had an action item from last week to contact you about scheduling (which I didn't get a chance to do, with the US holiday)
14:07:14 <sgallagh> What does your timeline look like for needing the 1.0.1 release with the patches you provided?
14:07:28 <kkaempf> sgallagh: Having a new release within the next ~4 weeks would be great.
14:07:48 <rdoty> sgallagh: I'm around
14:08:01 <sgallagh> Ok, so I don't think we'll have any trouble getting something before the new year. Is that safe to say, jsafrane?
14:09:18 <jsafrane> yes, we have bunch of patches that can be released. Still, I'm not sure we can fix all the bugs since then
14:09:21 <kkaempf> sgallagh: btw, the .spec file fixes for SUSE are rather intrusive (did someone say ugly ? ;-)), would these be acceptable upstream ?
14:09:34 <jsafrane> *unitl then
14:10:07 * kkaempf sees plenty of %if 0%{?suse_version}
14:10:09 <sgallagh> jsafrane: Well, we'll *never* fix all the bugs.
14:10:22 <sgallagh> jsafrane: I'm thinking more in terms of killing off any known crash bugs in that timeframe.
14:10:34 <jsafrane> sgallagh: sure, I mean fix those we know about :)
14:10:42 <sgallagh> kkaempf: I haven't seen your spec patches. Is there a patch?
14:11:29 <kkaempf> sgallagh: I can start putting them up for review.
14:12:38 <sgallagh> I think in general, a conditionalized spec file that we share will be easier to maintain in the long run than carrying separate spec files in a contrib dir, personally
14:12:50 <openlmi-buildbot> build #165 of networking-rawhide is complete: Success [build successful]  Build details are at http://openlmi-rnovacek.rhcloud.com/builders/networking-rawhide/builds/165
14:12:58 <sgallagh> kkaempf: Submit them; maybe we can crowdsource a way to make them cleaner.
14:12:59 <rnovacek> openlmi-buildbot: mute
14:13:00 <openlmi-buildbot> Shutting up for now.
14:13:11 <kkaempf> sgallagh: Great, thanks !
14:14:28 <sgallagh> #action kkaempf to submit spec file patches for SUSE to upstream
14:14:28 <sgallagh> #info kkaempf would like an OpenLMI 1.0.1 upstream release before the end of the month.
14:14:47 <sgallagh> Just to get a formal proposal on the table:
14:15:05 <jsafrane> ok, so let's say we will do a bugfix release of all openlmi-* providers
14:15:31 <sgallagh> Proposal: GOAL: OpenLMI 1.0.1 will release during by Dec. 20th with all known crash bugs fixed.
14:16:20 <sgallagh> err, rephrasing:
14:16:30 <sgallagh> Proposal: GOAL: OpenLMI 1.0.1 will release by Dec. 20th with all known crash bugs fixed.
14:16:49 <sgallagh> (I was originally going to say "during the week of dec 16, and changed midway through)
14:17:23 <sgallagh> Can I get +1 or -1's for this? (+1 if you believe this is achievable, -1 if not)
14:17:33 <rnovacek> +1
14:17:44 <jsafrane> sgallagh: +1
14:18:09 <jsafrane> tbzatek: what about indication races ^?
14:18:36 <sgallagh> jsafrane: I'm not sure I want to make that a condition on the 1.0.1 release.
14:19:03 <tbzatek> well I've already thought we fixed all the issues but then they appeared again, however this is a priority so +1
14:19:08 <sgallagh> i.e. Include them if they're ready in time, but don't block on it
14:19:46 <sgallagh> Ok, so shall I amend the Proposal to include that as a condition of release, then?
14:20:05 <jsafrane> ok
14:20:12 <tbzatek> ack
14:20:53 <sgallagh> Proposal: GOAL: OpenLMI 1.0.1 will release by Dec. 20th with all known crash bugs and indication races fixed.
14:21:25 <sgallagh> #agreed GOAL: OpenLMI 1.0.1 will release by Dec. 20th with all known crash bugs and indication races fixed.
14:21:54 <sgallagh> #topic Planning OpenLMI 1.1.0 (Features)
14:22:13 * sgallagh forgot to change the topic for the previous discussion. I'll fix it up in the logs later.
14:23:11 <sgallagh> Last week, we started discussing the next phase of feature development (probably on a roughly six-month schedule)
14:23:52 <sgallagh> kkaempf: http://www.openlmi.org/node/45 has the summary of that discussion. I was hoping to get your input on upcoming feature needs as well.
14:24:39 <kkaempf> sgallagh: I'll send you feedback via mail.
14:24:57 <sgallagh> #action kkaempf to send feature suggestions by email
14:25:36 <sgallagh> Does anyone want to bring anything up for particular discussion here?
14:25:53 <jsafrane> sgallagh: udisks?
14:26:44 <jsafrane> sgallagh: how does it look there with lvm & cockpit etc? we're reaching limits of blivet
14:26:58 <sgallagh> I think we made a pretty good start on this last week, so we can incorporate kkaempf's input when it arrives and then we should have a plan we can finalize.
14:28:04 <sgallagh> jsafrane: Just a sec, let me see if I can bring someone in to discuss that.
14:28:24 <sgallagh> Ah, rats. He signed off half an hour ago...
14:28:57 <sgallagh> jsafrane: I know that we're moving ahead with having a udisk2 extension daemon that will handle LVM.
14:29:56 <sgallagh> I don't know how far along it is yet, so I'm not certain if I'd be comfortable making it a dependency on OpenLMI 1.1.0 today. I have a meeting with the Cockpit folks in 90 minutes; I'll ask about it then.
14:30:32 <jsafrane> sgallagh: ok, so we're going to stick with blivet for 1.1.0
14:30:43 <tbzatek> sgallagh: is it discussed publicly somewhere? some mailinglist? looking for technical details...
14:31:59 <sgallagh> #action sgallagh to get an update on the udisks-lvm work from Cockpit.
14:31:59 <sgallagh> jsafrane: I also had a break-room conversation this week with one of the Blivet developers.
14:31:59 <sgallagh> She's interested in the efforts to merge the two projects, but her time is limited by imminent deadlines right now.
14:31:59 <sgallagh> That effort will probably remain on hold until the new year
14:32:34 <jsafrane> ok
14:33:09 <sgallagh> jsafrane: I'd be wary of signing up for the switch-over without more information.
14:34:14 <sgallagh> tbzatek: Not yet; this has been mostly an in-person series of discussions.
14:34:32 <tbzatek> sgallagh: ah okay
14:34:38 <sgallagh> They haven't gone public because the continuing result of those meetings has been "We want to do this, but we have too much on our plate right now"
14:35:53 <sgallagh> Ok, anything further on this topic? The last thing I had on my agenda was LMIShell. (Including how to spell it)
14:36:57 <phatina> sgallagh: let's stick to LMIShell - I already got a message from content services about this topic, they will also go with LMIShell
14:37:38 <sgallagh> Moving on, then
14:37:38 <sgallagh> #topic LMIShell
14:38:11 <sgallagh> phatina: I'm generally agreed there too
14:39:00 <sgallagh> Ok. #agreed LMIShell is the correct spelling
14:39:19 <sgallagh> So, I've been playing around with LMIShell for the last week, trying to get an example indication script working.
14:39:33 <sgallagh> (Well, the three days I worked last week)
14:40:07 <sgallagh> There are a number of documentation issues that made this difficult. Some, I have submitted a patch for. Others I am still working on.
14:40:38 <sgallagh> However, I'm presently stuck trying to figure out how to debug the providers.
14:40:57 <sgallagh> That's a bit of documentation that really needs to be improved on www.openlmi.org
14:41:13 <sgallagh> At the very least, a guide on how to get Pegasus to output debug logs is essential.
14:41:29 <sgallagh> Anyone here willing to write that up?
14:41:32 <rdoty> kkaempf: have you used Indications for anything?
14:41:58 <kkaempf> rdoty: Not yet. I just started to learn about filters/subscriptions etc.
14:42:06 <rdoty> OK, thanks
14:43:47 * miminar volunteers
14:43:49 <sgallagh> rdoty: I know you've been playing with LMIShell as well. Care to share any of your findings with the rest of the class?
14:43:54 <sgallagh> miminar: Thank you very much
14:44:12 <miminar> I need to recapitulate it myself :)
14:44:21 <rdoty> I'm working on a series of Blog postings on LMIshell that will appear starting this week.
14:44:42 <rdoty> I've encountered a number of rough edges, and asked for help.
14:45:11 <rdoty> In general, LMIShell is in good shape. The API level documentation is excellent.
14:45:30 <rdoty> More info is needed on installation and getting started, which I'm working on.
14:46:02 <sgallagh> #action miminar to write debug log tutorials for Pegasus
14:46:02 <sgallagh> miminar: I'll be happy to edit for you (as a native speaker)
14:46:02 <sgallagh> Ok, I don't personally have anything else here until I can get past this current block.
14:46:02 <sgallagh> rdoty: Anything from you, or shall I go to Open Floor?
14:46:02 <rdoty> Also, we need examples and to more forcefully point people to the available documentation.
14:46:20 <rdoty> Overall, I'm very impressed as I dig into LMIShell
14:46:51 <miminar> sgallagh: your help will be very much appreciated, I'll send you a draft when it's ready
14:48:25 <sgallagh> rdoty: So you're putting together some "getting started" guides as well?
14:48:40 <rdoty> Trying to - I need help!
14:48:56 <rdoty> I'm basically documenting my experiences as I work through it.
14:49:19 <rdoty> Circulated an early draft to the engineering team for feedback.
14:49:19 <sgallagh> rdoty: That's a good approach. Are you publishing those experiences somewhere? An email to the devel list would be helpful
14:50:13 <sgallagh> Not just the stuff you've worked out, but where you were forced to figure something out instead of being helped along.
14:50:21 <rdoty> Hmm, as an alternative I might post the rough draft on the blog and ask for feedback and comments there. techponder.wordpress.dom
14:50:38 <sgallagh> #link techponder.wordpress.com
14:50:52 <rdoty> Since I'm playing the role of naive user, I'm hitting the simple stuff.
14:51:19 <rdoty> It looks like the hard work has been done, and now we need to polish the easy stuff and tell people how to get started.
14:51:29 <rdoty> Fairly typical for an Open Source project...
14:52:01 <rdoty> As noted, I'm _very_ impressed with the API level documentation available
14:52:37 * sgallagh nods
14:52:48 <sgallagh> Thank you for pathfinding for us.
14:52:59 <rdoty> My pleasure
14:53:20 <sgallagh> Ok, let's move on to Open Floor
14:53:23 <sgallagh> #topic Open Floor
14:53:42 <sgallagh> Anyone have anything they'd like to discuss or get clarification on this week?
14:53:54 <rdoty> Has anyone put together a step by step guide to configuring a VM with OpenLMI and connecting to it from the host?
14:54:35 <sgallagh> rdoty: by "configuring a VM with OpenLMI", I assume you mean "configuring a VM providing OpenLMI services"?
14:55:00 <rdoty> Or "configuring a VM which is managed through OpenLMI"
14:55:00 <sgallagh> Or do you mean "modifying the VM itself using OpenLMI" (which is not something I believe we can do...)
14:55:26 <rdoty> Well, we can certainly modify storage, network, SW, users, etc., in a VM
14:55:29 <kkaempf> sgallagh: libvirt-cim should cover the 'manage VMs' use case
14:55:51 <sgallagh> rdoty: Fundamentally, that's identical to managing a physical machine
14:55:58 <rdoty> Correct
14:56:18 <sgallagh> kkaempf: Right... we need to look into that. libvirt-cim can probably do it, but we haven't documented that case or tested it for supportability.
14:56:27 <sgallagh> Probably a good candidate for 1.1.0, actually
14:59:08 <sgallagh> rdoty: Are you really talking about a "How do I try out OpenLMI myself without hosing my system?" document?
14:59:08 <sgallagh> rdoty: That would probably be a good tutorial for a techponder entry (that we might then steal as "official content" on openlmi.org)
14:59:19 <sgallagh> kkaempf: Back to the scheduling discussion before: would you be willing to share your plans for release of OpenLMI for SUSE (OpenSUSE?)
14:59:31 <rdoty> sgallagh: That is a part of it.
14:59:34 <sgallagh> How are you planning to deliver and announce it?
15:00:21 <kkaempf> sgallagh: Sure, once the schedule is available. Neither openSUSE nor SLES have a published release plan currently.
15:00:55 <sgallagh> Fair enough.
15:01:38 <sgallagh> As far as marketing; is this something you expect to see announced as a feature of a release or something that will be carried along quietly?
15:02:52 * sgallagh wants to be prepared for an influx of bug reports, for example :)
15:03:28 <kkaempf> I sure hope to announce inclusion of openLMI as a feature ;-)
15:04:02 <sgallagh> Good to hear!
15:04:25 <sgallagh> Ok, we're over time. Does anyone have anything urgent left to discuss? If not, I'll close out the meeting.
15:04:54 <sgallagh> Oh, actually. One tiny thing: I *think* we're all agreed on "OpenLMI" as the official capitalization, is that right?
15:05:34 <rdoty> Correct
15:05:40 <jsafrane> +1
15:05:46 * kkaempf turns red :-)
15:06:56 <sgallagh> #agreed OpenLMI is the official capitalization of the project name.
15:07:16 <sgallagh> kkaempf: Sorry, not trying to embarrass anyone. Just figured we should make that official.
15:07:23 <sgallagh> Since we did so for LMIShell earlier in the same meeting
15:07:35 <kkaempf> sgallagh: no worries ;-)
15:08:28 <sgallagh> Ok, thank you everyone for participating!
15:08:39 <sgallagh> #endmeeting