#openlmi: OpenLMI Public IRC Meeting (2013-12-09)

Meeting started by sgallagh at 14:02:03 UTC (full logs).

Meeting summary

    1. Meetings are recorded and will be posted on www.openlmi.org. Opinions expressed do not necessarily reflect the reviews of the participant's employer. (sgallagh, 14:02:14)

  1. Roll Call (sgallagh, 14:02:19)
  2. Follow-up on udisks-LVM (sgallagh, 14:05:23)
    1. Progress on the LVM extensions to udisks is proceeding. Cockpit upstream is driving this effort and his highly receptive to OpenLMI input and collaboration. (sgallagh, 14:10:36)
    2. OpenLMI will need to monitor progress on udisks-lvm closely to determine when is the right time to switch over. Depending on delivery schedules, this may mean OpenLMI 1.2.0. (sgallagh, 14:11:17)
    3. The current implementation will be a second add-on daemon to udisks providing extended functionality. The goal is to eventually merge the projects together, pending upstream udisks approval. (sgallagh, 14:12:03)

  3. Progress on OpenLMI 1.0.1 (sgallagh, 14:13:41)
    1. ACTION: tsmetana to clone RHBZ crashes and races into the upstream trac for organizational purposes (sgallagh, 14:24:24)
    2. There is concern that one of the race-condition bugs may need more time to debug and fix. (sgallagh, 14:26:55)
    3. suggestion may be to do a 1.0.1rc1 release next week and finalize it in early January. (sgallagh, 14:27:29)

  4. realmd issue (sgallagh, 14:29:07)
    1. the dbus message might timeout sooner than the result of the realmd operation (join/leave) is known to the realmd daemon itself (sgallagh, 14:30:47)
    2. ACTION: sgallagh to assist tsmetana on the realmd issue (sgallagh, 14:35:34)

  5. Indication subscriber deadlock (sgallagh, 14:36:30)
    1. In certain circumstances, it's possible to get the indication manager to freeze up until Pegasus is rebooted (sgallagh, 14:37:47)
    2. ACTION: tbzatek to cherry-pick a series of fixes from master that will significantly reduce the hit rate of this issue (sgallagh, 14:38:37)
    3. tbzatek is continuing to research the cause of the deadlock (sgallagh, 14:38:53)

  6. Indication delivery (sgallagh, 14:39:56)
    1. Indications are not delivered when the subscription is made after the software provider is initialized (sgallagh, 14:41:27)
    2. ACTION: miminar is working on a fix (sgallagh, 14:42:38)
    3. Fix requires job handling rework (sgallagh, 14:43:10)

  7. Open Floor (sgallagh, 14:43:22)


Meeting ended at 14:45:56 UTC (full logs).

Action items

  1. tsmetana to clone RHBZ crashes and races into the upstream trac for organizational purposes
  2. sgallagh to assist tsmetana on the realmd issue
  3. tbzatek to cherry-pick a series of fixes from master that will significantly reduce the hit rate of this issue
  4. miminar is working on a fix


Action items, by person

  1. miminar
    1. miminar is working on a fix
  2. sgallagh
    1. sgallagh to assist tsmetana on the realmd issue
  3. tbzatek
    1. tbzatek to cherry-pick a series of fixes from master that will significantly reduce the hit rate of this issue
  4. tsmetana
    1. tsmetana to clone RHBZ crashes and races into the upstream trac for organizational purposes
    2. sgallagh to assist tsmetana on the realmd issue


People present (lines said)

  1. sgallagh (76)
  2. tsmetana (22)
  3. miminar (13)
  4. tbzatek (10)
  5. zodbot (9)
  6. rnovacek (1)
  7. jsafrane (0)
  8. rdoty (0)


Generated by MeetBot 0.1.4.