14:14:34 <sgallagh> #startmeeting OpenLMI Public IRC Meeting (2014-01-27)
14:14:34 <zodbot> Meeting started Mon Jan 27 14:14:34 2014 UTC.  The chair is sgallagh. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:14:34 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:14:55 <sgallagh> #meetingname OpenLMI Public IRC Meeting
14:14:55 <zodbot> The meeting name has been set to 'openlmi_public_irc_meeting'
14:14:58 <sgallagh> #chair sgallagh tsmetana jsafrane rdoty
14:14:58 <zodbot> Current chairs: jsafrane rdoty sgallagh tsmetana
14:15:04 <sgallagh> #info Meetings are recorded and will be posted on www.openlmi.org. Opinions expressed do not necessarily reflect the reviews of the participant's employer.
14:15:05 <tsmetana> .hellomynameis tsmetana
14:15:07 <zodbot> tsmetana: tsmetana 'Tomas Smetana' <tsmetana@redhat.com>
14:15:08 <sgallagh> #topic Roll Call
14:15:13 <rnovacek> .fas rnovacek
14:15:13 <zodbot> rnovacek: rnovacek 'Radek Novacek' <rnovacek@redhat.com>
14:15:15 <tsmetana> .hellomynameis tsmetana
14:15:17 <zodbot> tsmetana: tsmetana 'Tomas Smetana' <tsmetana@redhat.com>
14:15:20 <phatina> .fas phatina
14:15:21 <zodbot> phatina: phatina 'Peter Hatina' <phatina@redhat.com>
14:16:21 <aledvink> .fas aledvink
14:16:22 <zodbot> aledvink: aledvink '' <aledvink@redhat.com>
14:16:29 <sgallagh> #topic Licensing of lmiwbem
14:16:58 <tbzatek_> .fas tbzatek
14:16:59 <jsafrane> .fas jsafrane
14:16:59 <zodbot> tbzatek_: tbzatek 'Tomas Bzatek' <tbzatek@redhat.com>
14:17:02 <zodbot> jsafrane: jsafrane 'Jan Šafránek' <jsafrane@redhat.com>
14:17:21 <sgallagh> phatina: Ok, so you have questions about how to license lmiwbem?
14:17:25 <phatina> talking to Tomas, we ran across a potential problem with licenses - I wanted to discuss this topis with you
14:17:33 <sgallagh> Go ahead
14:17:47 <phatina> sgallagh: maybe I was too quick, but there is one source file, which comes from PyWBEM
14:17:54 <phatina> sgallagh: and the rest is mine/ours
14:18:08 <phatina> sgallagh: where the only one source file is licensed under LGPLv2
14:18:21 <openlmi-buildbot> build #435 of providers-rawhide is complete: Exception [exception tests]  Build details are at http://openlmi-rnovacek.rhcloud.com/builders/providers-rawhide/builds/435  blamelist: Peter Schiffer <pschiffe@redhat.com>
14:18:25 <phatina> sgallagh: the other sources are licensed under LGPLv2.1+
14:18:27 <rnovacek> openlmi-buildbot: mute
14:18:27 <openlmi-buildbot> Shutting up for now.
14:18:37 <sgallagh> pywbem is LGPLv2?
14:18:43 <phatina> sgallagh: do you find this as a problem and should I fix this?
14:19:14 <phatina> sgallagh: cim_types.py from PyWBEM is LGPLv2
14:19:41 <sgallagh> 2, not 2.1? (Just trying to be clear)
14:19:51 <phatina> sgallagh: right, 2, not 2.1
14:20:38 * sgallagh takes a quick look at the code
14:21:29 <sgallagh> phatina: I assume this is lmiwbem_types.py?
14:21:38 <phatina> sgallagh: yes
14:22:48 <sgallagh> I'm not a lawyer, so I need to think for a minute about how this interacts.
14:23:40 <sgallagh> Certainly, the easiest thing to do would be to contact the other two authors of the file and ask for them to agree to an LGPLv2.1+ relicensing
14:24:25 <jsafrane> ... or rewrite it
14:24:42 <phatina> sgallagh: so we rather stick to LGPLv2.1+
14:25:07 <sgallagh> phatina: Among other things, LGPLv2 was retired in favor of 2.1 because (IIRC) its language was slightly ambiguous
14:25:25 <sgallagh> I'd be fine if they agreed to strict LGPLv2.1 as well (no +)
14:26:40 * sgallagh is doing some quick legal precedent searching
14:28:00 <sgallagh> So, my brief and non-expert opinion search suggests that right now these licenses are not compatible. So something has to change somewhere.
14:28:12 <sgallagh> I'd really prefer that we not adopt LGPLv2 ourselves
14:28:39 <phatina> ok, so I will contact those 2 authors about re-licensing
14:29:03 <sgallagh> I think that's the easiest approach.
14:29:29 <phatina> if there is a problem, I will talk to you later
14:30:00 <sgallagh> It might be possible to also do a clean-room implementation (most of that file is single-reasonable-implementation, so only the DateTime would probably need to be reimplemented)
14:30:07 <sgallagh> That would need a legal opinion.
14:31:23 <phatina> sgallagh: right
14:33:58 <sgallagh> So, let's take two action items then
14:34:27 <sgallagh> #action phatina to contact Tim Potter and Bart Whiteley to ask about relicensing.
14:34:54 <sgallagh> #action sgallagh to ask Red Hat Legal for opinion on reimplementation.
14:36:45 <phatina> sgallagh: ok, shoudl fedora's package-review wait until this is resolved?
14:37:25 <sgallagh> phatina: Well, you could file it, but it will have to block FE_LEGAL
14:37:52 <phatina> sgallagh: fine
14:38:57 <sgallagh> Ok, anything further on this topic?
14:39:26 <phatina> nothing else from me
14:41:50 <sgallagh> #topic Open Floor
14:42:02 <sgallagh> That was the only item on the agenda. Any topics for Open Floor this week?
14:44:30 <sgallagh> Ok, sounds like no one has anything at the moment.
14:44:36 <sgallagh> Thank you for participating, folks!
14:44:53 <tsmetana> thanks for your help.
14:45:44 <sgallagh> #endmeeting