14:59:45 <mchua> #startmeeting
14:59:45 <zodbot> Meeting started Fri May  7 14:59:45 2010 UTC.  The chair is mchua. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:59:45 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:59:46 <mchua> #meetingname POSSE CA
14:59:46 <zodbot> The meeting name has been set to 'posse_ca'
14:59:49 <alolita> ok good
14:59:57 <mchua> #meetingname POSSE and workshop CA
14:59:57 <zodbot> The meeting name has been set to 'posse_and_workshop_ca'
15:00:00 <mchua> (probably more accurate :)
15:00:09 <alolita> :-)
15:00:23 <alolita> mel: i have 3 things on the agenda
15:00:29 * mchua nods
15:00:53 <alolita> 1. update on getting more profs involved
15:01:14 <alolita> 2. we need to prepare materials to spread the word on campuses
15:01:28 <alolita> 3. need to update the wiki
15:01:37 * mchua nods
15:01:55 <alolita> should i start? or should we wait for quaid?
15:01:56 <mchua> Is that all for POSSE, or each of those for both the workshop and for POSSE?
15:02:09 <alolita> yes that is for POSSE coming up on July 5-9
15:02:10 <mchua> I'd also like to figure out the workshop - in fact, I was hoping we could spend most of today on the workshop.
15:02:14 <mchua> Ok.
15:02:35 <alolita> by the workshop do you mean the OSCON workshop?
15:02:43 <alolita> with OSL?
15:03:05 <mchua> alolita: yep.
15:03:44 <alolita> so i have about an hour today only so let's do a quick update on POSSE CA and then spend 30 minutes on the workshop
15:03:56 <mchua> Sounds good.
15:04:00 <mchua> #topic POSSE CA update
15:04:41 <alolita> I spent quite a bit of time with SFSU's Sameer Verma - whom you know too
15:04:52 <mchua> #info Mel's report: Heard back from Sameer (SFSU) and need to respond; Max is looking into Stanford but no replies yet; currennt count is 1 applicant from NY.
15:04:55 <mchua> (that's it from me)
15:04:57 <mchua> alolita: Oh, awesome!
15:04:59 <alolita> he had good feedback -
15:05:12 * mchua hadn't heard anything from Sameer since that email we all got
15:05:35 <alolita> there are two profs from SFSU - one is Sameer himself and another prof in CS
15:06:15 <alolita> i have asked Sameer to take some of the material from his managing open source course that he teaches and present it
15:06:40 <alolita> it would be part of the overview from 20000 ft session
15:07:25 <mchua> Ok - that sounds good.
15:07:27 <alolita> that gets him involved as well as pull the folks/profs/lab assistants etc. he works with
15:07:32 <mchua> +1
15:08:00 <mchua> Once we get 5 attendees and know who they are / background / etc, the three of us need to sit down and go through the curriculum and figure out who's doing what and how.
15:08:26 <alolita> so one of things I'm hearing again is that we keep all the teaching on the 4 full days
15:08:31 <mchua> Worcester and RIT are in the middle of doing that, the logs have been floating across the TOS list - but it's good to know who's coming first, because that's what it needs to be adjusted to.
15:08:46 <mchua> What's the last half-day for?
15:09:32 <alolita> well right now - we have july 5 as welcome and intros; july 6-9 as full days?
15:09:56 <alolita> at least in the template so we need to adjust that
15:10:04 <mchua> July 5-8 as full days, July 9 as a half-day.
15:10:25 <mchua> We end at lunch on Friday - Friday is more of a reflection/wrap-up/what are your future plans? day than anything else
15:10:26 <alolita> ok
15:10:39 <mchua> Monday is focused on communication tools; the intro itself is very short.
15:10:52 <mchua> but we can fine tune the curriculum when we know the profs who are coming.
15:11:16 <alolita> july 4 is sunday and most folks will not be back on july 5
15:11:20 <mchua> If they're all at Sameer's level, that's fantastic - we can accelerate a bunch of things, spend more time getting deeper into community work, etc.
15:11:24 <mchua> Right.
15:11:27 <mchua> I'll likely be taking a red-eye flight over myself.
15:11:33 <alolita> right
15:12:13 <alolita> so let's start july 6 tuesday and end on july 9 friday (3 full days and 1 half day?)
15:12:33 <alolita> we could consolidate some of the labs to cover all the material yet in the 3.5 days timeframe
15:12:45 <mchua> We really do need all 5 consecutive days.
15:12:57 <alolita> i am concerned that the profs/lab assts will only attend half of the sessions and then disappear
15:13:05 <mchua> There's some material - some skills training, essentially - that can be covered faster with a cohort that has background.
15:13:15 <mchua> But the cycles and the rhythms of community engagement can't be compressed.
15:13:49 <alolita> i don't think we will be compressing any community engagement - just knitting the course more tightly :-)
15:14:17 <mchua> Talking with community members takes time, and can't always be hurried up on demand - review processes take time, and such, and we start them talking with folks on Monday because it really does take a couple days to make it in.
15:14:43 <mchua> We could bump everything forward a day, have the social intro mixer Monday night, start full classes on Tuesday morning, and then end with a Saturday half-day.
15:15:01 <alolita> also some one like sameer or his cs colleague don't want to do the labs since they know the stuff already
15:15:21 <alolita> yes that can work - im concerned that monday is not the best day to start after july 4th
15:15:41 <alolita> i want everyone to be at the camp all days :-)
15:17:04 <alolita> so let's start the sessions on july 6 thru july 10
15:17:34 <alolita> and do a huddle for at least the three of us on july 5 afternoon/evening
15:17:58 <alolita> then you can reach the west coast by 4pm and we can meet after that?
15:17:59 <mchua> Ok. need to doubecheck with quaid that he's ok with the shift, but hopefully he'll be able to make Saturday morning.
15:18:16 <alolita> well - i think you and i can cover saturday if needed :-)
15:18:21 <mchua> alolita: I'll reach the west coast by whenever you need me by. :) they have fireworks on both sides of the continent.
15:18:26 <mchua> alolita: true!
15:18:42 <mchua> #idea move session to July 6-10
15:18:55 <mchua> #action mchua check if date-shift is ok for our current applicant
15:19:28 <alolita> well - july 5th is always a dicey date for any class
15:19:36 <alolita> after a long weekend
15:20:20 <alolita> topic 2: 2. we need to prepare materials to spread the word on campuses
15:20:45 <alolita> most universities have exams here week of may 15
15:20:49 * mchua nods
15:20:56 <alolita> and graduation on week of may 22
15:21:00 <alolita> that's coming up
15:21:05 <mchua> yeah, that's about the timing here as well.
15:21:16 <alolita> so any announcements, flyers on campuses have to be done before that
15:21:19 <mchua> we've got an email template - what other things would be good to have? flyer?
15:21:22 <mchua> ah, flyer.
15:21:57 <alolita> we need a flyer (a PDF) to post on bulletin boards on campus
15:22:21 <alolita> sfsu / sameer requested that and so will others as we send them an announcement package
15:22:58 <mchua> Ok. I'll make that today; you'll have it before I leave work for the weekend.
15:23:07 <mchua> I'll do a one-page flyer and then a slightly longer mini-info packet.
15:23:20 <alolita> i can personally go to stanford and sjsu and post these with the cs department's approval
15:23:32 <alolita> yes - so let's talk about our announcement packet
15:23:42 <mchua> #action mchua make flyer/packet
15:23:52 <alolita> we want to have an announcement and a flyer
15:23:52 <mchua> #action alolita post materials at stanford, sjsu
15:24:02 <mchua> alolita: Ok - what needs to be on the announcement?
15:25:50 <alolita> the announcement will contain a brief intro para about POSSE (what it stands for and its background), a para about when and where, and a third para about what we will cover in the week (at a high level) and a section in bullets about location, times, dates, contact info
15:26:07 <mchua> Sounds good.
15:26:28 <alolita> what is our contact info? do we have a form we ask profs to fill out online?
15:26:45 <alolita> we can put up a form online if needed and just provide the url
15:26:54 <mchua> We have posse@teachingopensource.org, which is also the email address they send their applications to.
15:27:22 <mchua> (The application is 10 questions, all short.)
15:27:22 <alolita> well - let's make it simpler - where there is an online form they could fill out and just hit submit
15:27:44 <mchua> I can throw up a basic web form.
15:27:57 <mchua> with a mailto that does essentially the same thing.
15:28:17 <alolita> cool - because then you don't have to parse email - its all there sorted and ready to be searched on
15:28:56 <mchua> #action mchua throw up registration webform
15:29:06 <alolita> its just that a url is easier to provide where people can go and register than asking them to do a appl via email :-)
15:30:11 <mchua> Right-o.
15:30:15 <alolita> so mel - our announcement package will be the announcement letter, the PDF flyer (8.5 by 11)
15:30:24 * mchua nods
15:30:38 <alolita> can i help you in reviewing this info before we send it out
15:31:15 <alolita> then we have more eyeballs and ensure its in sync with what we're presenting at POSSE
15:31:27 <alolita> i will also then post it from opensource.org
15:32:07 <alolita> and get SFSU, SJSU and other schools to link to the page
15:32:39 <mchua> alolita: That would be fantastic.
15:32:52 <alolita> mel: also i would like to have the program schedule tuned in terms of dates by tuesday so that folks are not confused when they go to the site
15:32:59 * mchua nods.
15:33:33 <mchua> Agreed. I'd like to make sure Karsten knows (even if he can't make the last day, though I hope he can) and that our first applicant is informed, but I think we can decide right now to make the date shift.
15:33:56 <alolita> ok cool
15:34:21 <alolita> i think the date shift will be fine - its better to be in sync with getting more folks to attend than folks skipping days
15:34:32 <alolita> so moving to the next topic
15:34:35 <alolita> 3. need to update the wiki
15:34:52 <mchua> #agreed Date shift one day later
15:35:08 <alolita> i can take a pass at the wiki info this weekend and get the info we have in sync
15:35:12 <mchua> That sounds great.
15:35:33 <mchua> it's mostly the date and registration link, and then whatever explanatory text from the announcement package we want to merge in, I'd think.
15:35:43 <mchua> #action alolita take a wiki revision pass over the weekend
15:35:46 <alolita> so by monday cob we can do a quick review and then be ready with the announcement packet as well as wiki info by tuesday
15:36:16 <alolita> we can mention on the wiki that the topics on the schedule are still being refined so subject to change
15:36:30 <mchua> I'll be offline this weekend (which is unusual for me - I'm usually doing a least a bit of work), just so you know - going on a birthday camping trip with a friend.
15:36:33 <mchua> alolita: Yep. that sounds great.
15:36:56 <alolita> that is unusual :-) but its good to have a camping trip - where are you going?
15:37:04 <alolita> hiking?
15:38:37 <alolita> so that concludes my 3 items of discussion for POSSE Ca
15:39:07 <alolita> let's go over the OSL OSCON workshop briefly
15:39:09 <mchua> alolita: Some nature preserve in Florida - I'm not entirely sure; it's my first camping trip.
15:39:18 <mchua> alolita: Yep, POSSE CA is a wrap for now. Woo!
15:39:22 <mchua> #topic OSL OSCON workshop
15:39:32 * mchua pulls up notes from last time
15:39:37 <alolita> fantastic - sunny florida too :-)
15:39:45 <mchua> alolita: I'm still trying to get a picture of what you'd like to do for that workshop, tbh.
15:39:57 <mchua> alolita: we hope it will be sunny :) it may rain Saturday.
15:40:11 <alolita> :-)
15:40:41 <alolita> so let's go over the OSL OSCON workshop
15:41:22 <alolita> as well heard from Jeff S of OSL and will from others also - a shorter version of POSSE may work better
15:41:52 * mchua nods
15:42:00 <mchua> I'd certainly be more than willing to try it.
15:42:40 <alolita> a 2.5 day format has become very popular since it usually involves a fri, sat and sun
15:42:57 <alolita> so warm-up and general topics for half day on friday
15:43:08 <alolita> and in-depth sessions on sat and sun
15:43:36 <alolita> we should emphasize on community development and best practices
15:43:53 <mchua> That sounds great.
15:44:41 <mchua> #link http://meetbot.fedoraproject.org/teachingopensource/2010-04-30/mini_professor_workshop.2010-04-30-15.03.html
15:44:44 <alolita> the skills component - i.e. getting / building src code, rpm packaging, bug triage, using bugzilla etc. is a half -day (4 hours)
15:44:55 <mchua> alolita: did you pick cloud/virt/security yet, and do we have space?
15:45:40 <alolita> so what we're doing is introducing profs to collaborative community development best practices, and doing the how-to section in a condensed form
15:45:49 <alolita> yes
15:45:51 <mchua> Awesome.
15:46:04 <alolita> so the way i would do it :-)
15:46:08 <alolita> is
15:46:37 <alolita> 1 day for collaborative development, community best practices
15:47:08 <alolita> 1/2 day for a special topic - e.g. virtualization or security etc.
15:47:28 <mchua> (which topic?)
15:47:39 <alolita> 1/2 day for how-to - i.e. getting / building src code, rpm packaging, bug triage, using bugzilla etc.
15:47:45 <mchua> (so we can schedule a dev expert to come by)
15:47:49 * mchua nods, this sounds great so far
15:47:54 <alolita> i would suggest virtualization for the osl workshop
15:48:27 <alolita> since there is a good amount of interest in that area and we can pull in a dev expert for a half day
15:49:04 <alolita> so the labs are started on the second day and completed on the third day
15:49:17 <alolita> i.e. the hands-on work
15:50:53 <alolita> so in the 1/2 day on virtualization - we are looking at it in depth with an engineer going through what's the current architecture first, what's coming up in the next couple of releases and then questions
15:52:05 <alolita> then we take our how-to session to walk through a virt related bug fix if possible and go through the tools and processes
15:52:08 <mchua> #agreed OSL workshop topic: virtualization
15:52:16 <mchua> #action mchua find virt engineer to come for OSL workshop
15:53:03 <alolita> mel: i know lance at osl - and we know jeff - so we should draft a formal proposal based on our conversations with jeff and send it to them?
15:53:54 <alolita> i have to run in 7 minutes
15:54:13 <alolita> so does that provide you some detail mel?
15:55:42 <mchua> alolita: It does! thanks!
15:55:56 <mchua> alolita: What can I do to help, or should I wait for you to draft something up / talk with lance & jeff?
15:56:36 <alolita> i can draft up a letter proposal based on what we discussed today; let's review it next week and then send it to lance and jeff?
15:56:52 <alolita> we can review it next friday at the meeting?
15:57:06 <mchua> alolita: that sounds great.
15:57:10 <mchua> I'll wait for your lead in the meantime. :)
15:57:14 <alolita> in the meantime, we complete our posse work this week
15:57:18 <mchua> If there's anything that comes up, let me know.
15:57:23 <mchua> Yep - I've got a lot to do on that right now. :)
15:57:27 <alolita> sure, will do
15:57:32 <mchua> (will eat lunch, then tackle my action items.)
15:57:35 <mchua> thanks, alolita!
15:57:38 <alolita> yes i know - thanks so much
15:57:50 <mchua> I'll send these notes to quaid and to the list - I'm looking forward to July.
15:57:56 <alolita> talk to you later then! i think we are making progress :-)
15:58:10 <alolita> sure - thanks again and bye for now!
15:58:26 * mchua waves
15:58:27 <mchua> mm, progress!
15:58:29 <mchua> #endmeeting