18:02:49 <mchua> #startmeeting
18:02:49 <zodbot> Meeting started Thu May  6 18:02:49 2010 UTC.  The chair is mchua. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:02:49 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:02:51 <mchua> #chair ctyler
18:02:51 <zodbot> Current chairs: ctyler mchua
18:02:56 <mchua> #meetingname POSSE RIT curriculum
18:02:56 <zodbot> The meeting name has been set to 'posse_rit_curriculum'
18:03:07 <mchua> #link http://meetbot.fedoraproject.org/teachingopensource/2010-05-04/posse_rit_curriculum.2010-05-04-14.05.html
18:03:17 <mchua> #info when last we left our heroes, they were finishing Wednesday's curriculum
18:03:31 <mchua> ctyler: and we said we'd start by checking over Wednesday's curriculum again first
18:03:40 <mchua> ctyler: Thus! http://teachingopensource.org/index.php/POSSE_RIT_Wednesday#Overview
18:06:08 * ctyler nods, is reading
18:07:12 <mchua> ctyler: I'm not sure how much of last summer's daily materials can actually be merged - for instance, http://teachingopensource.org/index.php/POSSE_RIT_Tuesday#Code has way more detail than I think we need this time, perhaps.
18:07:18 <mchua> (but you're teaching that section, so I left all the notes up)
18:08:11 * mchua feels like a wiki-managing bulldozer; at some point this system of pages and tables will get unwieldy, but 'till then... *soldiers on!*
18:11:08 <ctyler> agreed
18:12:01 <mchua> ctyler: I realize that each day is still mostly in outline form, and that each section/exercise will need to be fleshed out more and tested and the day divvied up in more detail, but right now outline-for-each-day is all I'm headed for
18:12:17 <ctyler> last year we (humph & i) met daily to discuss status + fine-tune next day
18:12:28 <mchua> ctyler: so for my part, I'm happy with where we stand re: Wednesday, and want to sketch in Thursday (and go over Friday briefly) before passing through them all again
18:12:34 <mchua> (oh, and FOSSCon)
18:12:37 <ctyler> good
18:12:47 <mchua> ctyler: Yeah, I think that's a good idea - you and I will be at the same hotel, so that should be very easy
18:12:51 <mchua> ctyler: (you and I and lmacken, in fact)
18:13:14 <mchua> #info ctyler, mchua, and (probably) lmacken will meet daily to discuss status + fine-tune the next day
18:14:23 <ctyler> unlike last time, I suspect that this time people won't be f2f in the evening for the most part
18:14:27 * mchua nods
18:14:32 <mchua> we have basically all locals
18:14:37 <ctyler> that will change the dynamic
18:14:45 <mchua> I want to set the expectation for group dinners
18:15:06 <mchua> and also that online office hours (and in-person office hours in the hotel lobby) will be held
18:15:08 <ctyler> the odd thing is that "locals" will have less f2f, and therefore do their overnights with remote-collab tools :-)
18:15:14 <mchua> ctyler: Heh!
18:15:41 <mchua> ctyler: Any ideas on how we can set that expectation? I want to draw a strong line, but also respect that people do have busy lives and families and such.
18:16:42 <ctyler> It's a *bootcamp*. Drop and give me 5 patches, private!
18:16:52 * mchua chuckles
18:17:04 <mchua> ctyler: so we *can* say "you WILL be online in the evenings!"
18:17:09 <mchua> ctyler: I mean, they do have homework.
18:17:20 * mchua will be online allll the time for office hours as she can.
18:17:23 <ctyler> Seriously, I think that people are expecting it to be intense, but we aren't planning on killing them
18:17:28 * mchua nods
18:17:43 <ctyler> I think that telling people they'll have 1-2+ hours overnight is reasonable
18:17:50 <mchua> For me, constant contact and feedback helps me calibrate - I mostly worry that without the in-person evenings we may not get that data
18:18:01 <mchua> since part of the learning curve is "how to keep that touch, online"
18:18:15 <mchua> but that's something we can review with them in the mornings, I suppose.
18:18:20 <ctyler> exactly
18:18:23 * mchua should stop worrying about that, it'll work out.
18:18:30 <mchua> ctyler: Wednesday OK, move on to Thurs?
18:18:53 <ctyler> It's not really different from teaching in class, students are not f2f in evenings but we expect them to be working with each other and the community outside of class
18:18:58 * mchua nods
18:19:02 <ctyler> Thu
18:19:07 <mchua> #topic Thursday
18:19:35 <mchua> #info Wednesday night's homework will be to start working on their Sugar Activity mods, so Thursday will begin by reviewing that and beginning the submission process.
18:19:51 <mchua> ctyler: I believe that's what we have so far.
18:19:55 <mchua> Other things that usually happen Thursday:
18:19:58 <mchua> * debugging and testing
18:20:08 <mchua> * collaborative development
18:20:33 <mchua> * Student project case studies (Luke, Remy, Steve, etc. at RIT should pull out what they've done here, we should give them time in this session)
18:20:39 <mchua> * Dinner of Awesome!
18:20:46 <ctyler> So let's do the get-it-into-review thing for Morning A
18:20:47 <mchua> ctyler: I am not sure what we want to do for the first two.
18:20:52 * mchua nods
18:21:03 <mchua> I can handle that session no problem, since I'm part of that upstream.
18:21:13 <mchua> Debugging and testing, less sure what that would mean.
18:21:34 <mchua> ctyler: http://teachingopensource.org/index.php?title=POSSE_2009_Thursday is last year's Thursday
18:21:40 <ctyler> yeah
18:21:57 <ctyler> the Morning B session went well, and the previous Morning A was pretty useful
18:22:02 <ctyler> but I think we can compress here
18:22:26 * mchua would like to be able to do stuff like gdb as a "possibly useful for you later on" thing, but it's not so useful to the project they are doing during that week
18:22:34 <mchua> so maybe it becomes a "here are tools available and how you would learn more"
18:22:45 * mchua thinks it would be good to schedule Fedora Classroom sessions on these sorts of tools throughout the summer anyhow
18:23:11 <ctyler> enh, skipping over gdb yes, doing collaborative debugging no
18:23:26 <ctyler> how about I do a compressed version of what A+B was last year
18:23:43 <ctyler> with a pythonesque slant, perhaps?
18:24:25 <ctyler> Afternoon as a guided discussion as before is good, I think
18:24:42 <mchua> ctyler: sure, and I'm guessing lmacken can help with the Python-specificity
18:24:54 <ctyler> indeed
18:25:05 <mchua> ctyler: I'm happy to just slice Thursday into two, where I go "yay let us upstream things!" in the morning and you and Luke go "aaaand debugging and collaborative whee!" in the evening
18:25:15 <mchua> and we all go pig out somewhere for dinner afterwards :D
18:25:24 * mchua totally looks forward to an entire summer full of POSSE Thursday dinners
18:25:31 <ctyler> perfect :-)
18:25:34 <mchua> (thank you for the budget o' nom, spevack)
18:25:43 <ctyler> mchua: just don't put on a "POSSE 15" :-)
18:26:17 <mchua> ctyler: heh, this summer is the first time I'll be trying out a dedicated running/travel-workout plan for precisely that reason ;)
18:26:28 <ctyler> :-)
18:26:31 <ctyler> on to Fri?
18:26:31 <mchua> #info Morning: Mel leads the "let us push your patches upstream, here is the process" session
18:26:45 <mchua> #info Afternoon: Chris (and Luke) lead a debug/collaborative-development session
18:26:49 <mchua> #info Evening: NOM NOM NOM
18:26:50 <mchua> #topic Friday
18:26:52 <mchua> ctyler: indeed :)
18:26:55 <ctyler> s/let us/you/
18:27:00 <mchua> #link http://teachingopensource.org/index.php/POSSE_RIT_Friday
18:27:06 <mchua> ctyler: I think that really, it can probably stand as-is
18:27:16 <mchua> ctyler: we may need to hunt for non-tech involvement examples in particular
18:27:21 <mchua> but it seems mostly like discussion
18:27:30 <mchua> and I think it makes sense for you to own that day in large part, since you actually... teach :)
18:27:45 <mchua> things I would like to add in; from the RHT side, we're trying to figure out how non-academic institutions can support TOS profs
18:28:10 <mchua> so I'd like to have a discussion on that - bring up the stuff we already have (mini-grants available, etc) and what we've done, ask what they'd like to see over the next ~3 years
18:28:19 <ctyler> sounds good, guided discussion
18:28:48 <mchua> ctyler: which one do you want to have first?
18:30:15 <ctyler> I think progression should be: what's been done and works -> what next and plans you (attendees) have to apply this -> how non-academic institutions can support profs
18:31:00 <ctyler> mchua: clarify, please: non-academic institution as you've used here means? Foss.com's? Communities?
18:31:06 <mchua> ctyler: Yes and yes.
18:31:25 <ctyler> ok
18:31:56 <ctyler> Sounds good
18:32:32 <mchua> ctyler: Ok, so just those three discussions for Friday, however long they take - and then feedback round, then done?
18:32:47 <mchua> Friday, imo, is the easiest day to plan for, since it's pretty much all "play it by ear!"
18:32:58 <ctyler> I think so
18:33:24 <ctyler> I'll talk a bit about the model we're using at the start, to get the ball rolling
18:34:06 <mchua> ctyler: oh wait, the student project case samples were Thursday... is this different?
18:34:49 <ctyler> Yes
18:35:03 <ctyler> Thursday is examples of student work, projects; Friday is about courses.
18:35:15 <ctyler> related not !=
18:35:23 <ctyler> related but != rather
18:35:52 <mchua> Oh, okay
18:36:08 <mchua> #info Discussion 1 of 3: Chris gets the ball rolling by talking about course models, what's been done at Seneca/elsewhere and works
18:36:34 <mchua> #info Discussion 2 of 3: What plans do you have to apply what you've learned in upcoming school years/classes?
18:37:00 <mchua> #info Discussion 3 of 3: Mel leads discussion on available resources and what further support resources they'd like to see (provided by foss.coms, communities, etc)
18:37:09 <mchua> #info Wrap-up and feedback time
18:37:34 <mchua> ctyler: I think that wraps Friday - we can have a debrief over dinner that night if we're not all too tired (you and I and Luke and whoever else is interested)
18:37:52 <mchua> ctyler: I wanted to touch briefly on the POSSE panel at FOSSCon for Saturday before we went through the whole week
18:38:35 <ctyler> tell me more about that panel
18:39:11 <mchua> #topic Saturday and FOSSCon panel
18:39:33 <mchua> #info we have 2:10pm-4pm (double-slot)
18:39:49 <mchua> ctyler: It's in the "FOSS in Education" track, and we can do *anything* we want with that time.
18:39:52 <mchua> My thoughts:
18:39:58 <mchua> * "what's POSSE?" 5-10m overview
18:40:13 <mchua> * professors introduce themselves, and go over the plans/ideas for the future that they had on Friday
18:40:28 <mchua> * and the support/resources/scaffolding they are now looking for and that we are trying to build
18:40:39 <mchua> and then we ask for help, and go into participatory-improvised-workshop mode
18:40:42 <mchua> EOF
18:42:31 <ctyler> ok
18:42:38 <ctyler> so you're going to intro this on Monday?
18:42:56 <ctyler> on Monday we will talk about planning a course through the week --> Friday, so that fits
18:43:01 <mchua> ctyler: the "we haz panel" thing?
18:43:04 * mchua can do that
18:43:09 <ctyler> right
18:43:11 <ctyler> perfect
18:43:15 * mchua is also going to be bringing it up on the mailign list so we have a list of folks who want to participate ahead of time
18:43:26 <mchua> FOSSCon *really* wants to have the POSSE profs come and hang out.
18:43:55 <ctyler> come and hang out is easier, "be on a panel talking about something you *just* learned about" might be less easy
18:44:19 <ctyler> also, there's the Baked factor, though being local will help mitigate that
18:44:55 * mchua nods.
18:45:16 <mchua> Well, I think of the panel as "come and hang out," but...
18:45:48 <ctyler> right
18:46:08 <ctyler> ok, so I think we're in generally good shape
18:47:45 <mchua> ctyler: I agree.
18:48:02 <mchua> ctyler: We have division-of-work for Thur-Sat, not yet Mon-Wed
18:48:40 <mchua> ctyler: shall we do that real quick, then we're basically set to run on our sections and then check in in another week or two to finalize the "here are you pre-arrival assignments/readings" email?
18:48:44 * mchua can do a first draft of that
18:50:08 <ctyler> actually I'm not sweating the division at all
18:51:42 <ctyler> Monday: propose I do an intro, you do timeline, I do distinctives, you do sugar, I do Fedora, I do teaching model (based on OLS 2008 paper)
18:51:56 <mchua> ctyler: #info that, it sounds good
18:52:07 <ctyler> #info Monday: propose I do an intro, you do timeline, I do distinctives, you do sugar, I do Fedora, I do teaching model (based on OLS 2008 paper)
18:52:26 * ctyler tries again
18:52:39 <mchua> #action mchua draft pre-arrival assignments/readings email
18:53:00 <ctyler> #info Monday: ctyler intro, mchua  timeline, ctyler  distinctives, mchua  sugar, ctyler  Fedora & teaching model (based on OLS 2008 paper)
18:53:06 <mchua> ctyler: Ok. Then I think we have a good idea of what needs to happen scaffolding-building wise to make each of our schedule-days possible.
18:53:23 <mchua> and since a lot of that scaffolding is identical to what needs to be made for the Worcester POSSE the week before, i am *not* worried about having it up ahead of time
18:53:31 <ctyler> perfect
18:54:41 <ctyler> do we need to divvy Tue/Wed? I'm happy to divvy when we tune the night before, I think basically you're on for foss.com and sugar, I'll take foss.edu and fedora
18:54:52 <mchua> ctyler: yeah, I think we can divvy when we tune on Monday night
18:55:01 <mchua> that seems all logical.
18:55:02 <mchua> yay!
18:55:19 <ctyler> we'll pass back and forth during the sessions, too, I'm sure.
18:57:14 <mchua> +1
18:57:23 <mchua> ctyler: Feel good about improvising through the rest of POSSE, basically?
18:57:36 <mchua> ctyler: do we need to check in any more between now and, say, 1-2 weeks before, aside from the pre-readings email?
18:57:44 <ctyler> Certainly.
18:57:51 * mchua has an insanely high tolerance for improvisation, can be dumped into any classroom anywhere on any topic and Make Stuff Up
18:58:13 <mchua> ctyler: Ok. Steve will, I think, at some point send us notes on the non-tech faculty so we have more data to adjust with, but we'll roll with it.
18:58:31 <mchua> #action mchua follow up with Steve re: any notes on adjusting to non-tech faculty
18:58:44 <mchua> ctyler: Would you like a copy of all the applications so you know the backgrounds of folks coming in?
18:58:52 <ctyler> I think we'll stay in touch as the event approaches, work on this in the background and tune as event unfold, start meeting up in early June.
18:58:54 * mchua nods.
18:58:58 <ctyler> A copy of the apps would be perfect
18:59:08 <mchua> #action mchua send ctyler copies of the participant apps
18:59:18 <mchua> ctyler: I will do that as soon as we freeze the final class so you have all of them in one fell swoop
18:59:23 <mchua> there are 14, but I believe we got one last-minute app
18:59:25 <mchua> or two
18:59:30 * mchua hasn't checked for a few days
18:59:40 <mchua> but then we'll lock it and we'll be set.
18:59:46 * mchua EOF
18:59:50 <mchua> ctyler: anything else?
18:59:51 <ctyler> Sounds good. Peter Liu is out, I understand, due to health.
18:59:56 * mchua nods.
19:00:03 * ctyler ponders Posse Seneca 2011.
19:00:03 * mchua was sad to hear that - hopefully next summer.
19:00:10 <mchua> ctyler: Yeah, I was going to say - I'd like to do that.
19:00:22 <mchua> I can't believe we didn't think of it this year, really.
19:00:36 <mchua> you and farlog and humph are all there, and... seriously.
19:00:39 <ctyler> Though we did do a precursor based on Moz about 3 years back.
19:01:05 <ctyler> mchua: have you seen any of the audio data in browser or Processing.js stuff recently?
19:01:30 <mchua> ctyler: Only via humph's blog
19:01:50 <ctyler> some quite incredible stuff, I'll demo at RIT sometime.
19:02:04 <ctyler> and bring some diminutive ARM boxen.
19:03:22 <ctyler> And it's a wrap.
19:03:25 <ctyler> #endmeeting