#fedora-meeting: Fedora QA Meeting

Meeting started by jlaska at 16:01:14 UTC (full logs).

Meeting summary

  1. gathering (jlaska, 16:01:34)
  2. Previous meeting follow-up (jlaska, 16:04:28)
    1. jlaska to post recommendations on F-12 QA retrospective (jlaska, 16:05:20)
    2. adamw to escalate security policy issue to fesco (jlaska, 16:06:26)
    3. https://fedorahosted.org/fesco/ticket/297 (adamw, 16:07:47)
    4. jlaska to set up a meeting to co-ordinate test plan changes for F13 (jlaska, 16:08:57)
    5. https://fedorahosted.org/fedora-qa/query?status=new&status=assigned&status=reopened&component=Test+Review&milestone=Fedora+13&order=priority (jlaska, 16:11:22)
    6. adamw and jlaska to look at setting up f13 test day process (jlaska, 16:11:58)

  3. F-13 QA Recommendations (jlaska, 16:14:29)
    1. ACTION: Viking-Ice investigating adding an LXDE test day to the F-13 test day schedule (jlaska, 16:18:56)
    2. ACTION: maxamillion investigating scheduling a XFCE test day to F-13 test day schedule (jlaska, 16:19:29)
    3. https://fedoraproject.org/wiki/Fedora_12_QA_Retrospective#Recommendations (jlaska, 16:20:49)
    4. https://fedoraproject.org/wiki/Fedora_12_QA_Retrospective#Recommendations (jlaska, 16:22:05)
    5. ACTION: adamw and rhe to discuss ways to add install testing as a QA activity (jlaska, 16:25:47)
    6. https://fedoraproject.org/wiki/Releases/13/FeatureList (jlaska, 16:30:22)

  4. F-13 QA Recommendations - test planning (jlaska, 16:30:53)
    1. Maintenance of the Fedora Install Test Plan - Liam and Hurry are doing a lot of heavy lifting here (jlaska, 16:31:32)
    2. Draft a more formal, but basic and lightweight, security checklist/test plan - discussed earlier, adamw has a fesco ticket filed ... stay tuned (jlaska, 16:31:55)
    3. Draft a test plan to cover the desktop verification from Fedora_Release_Criteria (jlaska, 16:32:14)
    4. https://fedoraproject.org/wiki/Fedora_Release_Criteria (jlaska, 16:32:19)
    5. We have no formal Xorg-x11-drv test plan ... either create one, or develop proposal for gathering the same feedback through other means (smolt, bugzilla) (jlaska, 16:33:31)
    6. ACTION: jlaska will reach out to mclasen for thoughts on F-13 fit'n'finish test days (jlaska, 16:47:03)

  5. F-13 QA Recommendations - test automation (jlaska, 16:48:32)
    1. https://fedoraproject.org/wiki/Fedora_12_QA_Retrospective#Test_Automation (jlaska, 16:48:43)
    2. Deploy AutoQA 'is rawhide broken?' front-end into fedora infrastructure (jlaska, 16:49:01)
    3. ACTION: jlaska to reach out ot fedora-{test,devel}-list for trading reviews (jlaska, 16:49:25)
    4. Deploy build-time sanity checking mechanism for package maintainers (rpmguard, rpmlint etc...) (jlaska, 16:49:36)
    5. Develop proof-of-concept for automating install test matrix (jlaska, 16:50:44)

  6. F-13 QA Recommendations - process (jlaska, 16:55:11)
    1. https://fedoraproject.org/wiki/Fedora_12_QA_Retrospective#Process_4 (jlaska, 16:55:16)
    2. Move User:Liam/Draft_Install_Test_SOP out of draft status - to me this is part of making install testing easier (jlaska, 16:57:28)
    3. Move User:Poelstra/blocker_bug_meeting_sop out of draft status - adamw had some improvements during FUDCon, I think we just need to dust it off before the blocker reviews kick in again (jlaska, 16:57:54)
    4. Draft a SOP (or extract from existing BugsAndFeatureRequests page) that describes how to document bugs (e.g. common_bugs or release notes or install guide etc...) (jlaska, 16:58:07)
    5. Draft/promote a recommended test checklist for rawhide testers (for example see User:Jlaska/Draft2) - this is something spot discussed a while ago and adamw drafted an idea. I think it would be worthwhile to reference from the QA/Joining page ... ideas? (jlaska, 16:59:17)
    6. # 'How to debug <component> problems?' -- Determine whether guides can be offered by Fedora QA as a result of a test day/feature process. - Viking-Ice already discussed this previously (jlaska, 17:00:36)
    7. ACTION: jlaska to reach out to beland for guidance/ideas on how to document the process (or point to existing documentation) for how bugs are noted (common_bugs, release notes, install guide etc...) How to determine which bugs land in which place (jlaska, 17:04:23)

  7. F-13 QA Recommendations - communication (jlaska, 17:05:10)
    1. https://fedoraproject.org/wiki/Fedora_12_QA_Retrospective#Communication_4 (jlaska, 17:05:13)

  8. Open discussion - <your topic here> (jlaska, 17:06:49)


Meeting ended at 17:10:04 UTC (full logs).

Action items

  1. Viking-Ice investigating adding an LXDE test day to the F-13 test day schedule
  2. maxamillion investigating scheduling a XFCE test day to F-13 test day schedule
  3. adamw and rhe to discuss ways to add install testing as a QA activity
  4. jlaska will reach out to mclasen for thoughts on F-13 fit'n'finish test days
  5. jlaska to reach out ot fedora-{test,devel}-list for trading reviews
  6. jlaska to reach out to beland for guidance/ideas on how to document the process (or point to existing documentation) for how bugs are noted (common_bugs, release notes, install guide etc...) How to determine which bugs land in which place


Action items, by person

  1. adamw
    1. adamw and rhe to discuss ways to add install testing as a QA activity
  2. jlaska
    1. jlaska will reach out to mclasen for thoughts on F-13 fit'n'finish test days
    2. jlaska to reach out ot fedora-{test,devel}-list for trading reviews
    3. jlaska to reach out to beland for guidance/ideas on how to document the process (or point to existing documentation) for how bugs are noted (common_bugs, release notes, install guide etc...) How to determine which bugs land in which place
  3. maxamillion
    1. maxamillion investigating scheduling a XFCE test day to F-13 test day schedule
  4. Viking-Ice
    1. Viking-Ice investigating adding an LXDE test day to the F-13 test day schedule


People present (lines said)

  1. jlaska (154)
  2. adamw (57)
  3. Viking-Ice (19)
  4. maxamillion (17)
  5. wwoods (12)
  6. kparal (8)
  7. nirik (4)
  8. zodbot (3)
  9. buggbot (1)


Generated by MeetBot 0.1.4.