#rdo: RDO packaging meeting (2015-09-02)

Meeting started by chandankumar at 15:01:01 UTC (full logs).

Meeting summary

  1. Discover module removal from upstream openstack-* packages (chandankumar, 15:02:42)
    1. patch regarding removing discover module from test-requirements sent and is merged in sahara, cinder, nova, designate, ceilometer, manila, magnum, zaqar, barbican, ironic (chandankumar, 15:03:01)
    2. https://review.openstack.org/218285 (chandankumar, 15:04:00)

  2. RDO packages specs update to python3 (chandankumar, 15:04:54)
    1. https://etherpad.openstack.org/p/RDO-python3-porting-packages (chandankumar, 15:05:38)
    2. take care of obsoleting the python-xxx modules while updating the spec to python3 (chandankumar, 15:09:12)
    3. (chandankumar, 15:10:35)
    4. https://chandankumar.fedorapeople.org/python-eventlet.spec (chandankumar, 15:10:38)
    5. ACTION: chandankumar to send a mail to python-eventlet maintainer with updated spec (chandankumar, 15:11:46)
    6. https://trello.com/c/eT0jvRGN/67-rdo-rpm-macros (number80, 15:18:22)
    7. ACTION: pixelb commit the eventlet py3 update to rawhide/f23 (apevec, 15:19:58)
    8. ACTION: chandankumar to update the specs of python-* packages to py3 (chandankumar, 15:20:09)

  3. new package scm requests (chandankumar, 15:21:34)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1257329 (chandankumar, 15:22:07)
    2. openstack-ironic-python-agent is imported in openstack-packages. (chandankumar, 15:23:55)
    3. ACTION: apevec to review Add ironic-python-agent in rdoinfo (apevec, 15:24:01)

  4. new package under review (chandankumar, 15:24:51)
    1. python-jsonpath-rw-ext - https://bugzilla.redhat.com/show_bug.cgi?id=1259075 (chandankumar, 15:25:17)
    2. python-yaql https://bugzilla.redhat.com/show_bug.cgi?id=1257178 (number80, 15:26:28)
    3. https://bugzilla.redhat.com/show_bug.cgi?id=RDO-LIBERTY-REVIEWS (apevec, 15:28:08)
    4. ACTION: chandankumar to review python-jsonpath-rw-ext (chandankumar, 15:29:10)

  5. liberty-3 Rawhide updates (chandankumar, 15:30:46)
    1. https://trello.com/c/GPqDlVLs/63-liberty-3-rpms (chandankumar, 15:33:14)
    2. ACTION: apevec to update pyton-oslo-* to the latest releases (apevec, 15:33:46)
    3. https://trello.com/c/wzdl1IlZ/52-openstack-in-fedora (chandankumar, 15:34:22)
    4. ACTION: apevec to post on rdo-list summary from https://trello.com/c/wzdl1IlZ/52-openstack-in-fedora (apevec, 15:38:19)

  6. open floor (chandankumar, 15:43:56)


Meeting ended at 15:51:43 UTC (full logs).

Action items

  1. chandankumar to send a mail to python-eventlet maintainer with updated spec
  2. pixelb commit the eventlet py3 update to rawhide/f23
  3. chandankumar to update the specs of python-* packages to py3
  4. apevec to review Add ironic-python-agent in rdoinfo
  5. chandankumar to review python-jsonpath-rw-ext
  6. apevec to update pyton-oslo-* to the latest releases
  7. apevec to post on rdo-list summary from https://trello.com/c/wzdl1IlZ/52-openstack-in-fedora


Action items, by person

  1. apevec
    1. apevec to review Add ironic-python-agent in rdoinfo
    2. apevec to update pyton-oslo-* to the latest releases
    3. apevec to post on rdo-list summary from https://trello.com/c/wzdl1IlZ/52-openstack-in-fedora
  2. chandankumar
    1. chandankumar to send a mail to python-eventlet maintainer with updated spec
    2. chandankumar to update the specs of python-* packages to py3
    3. chandankumar to review python-jsonpath-rw-ext
  3. pixelb
    1. pixelb commit the eventlet py3 update to rawhide/f23


People present (lines said)

  1. chandankumar (72)
  2. apevec (64)
  3. number80 (23)
  4. zodbot (9)
  5. social (5)
  6. trown (4)
  7. jpena (4)
  8. pixelb (2)
  9. rbowen (1)
  10. paragan (1)


Generated by MeetBot 0.1.4.