15:03:03 <number80> #startmeeting RDO meeting - 2018-03-14
15:03:03 <zodbot> Meeting started Wed Mar 14 15:03:03 2018 UTC.  The chair is number80. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:03:03 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:03:03 <zodbot> The meeting name has been set to 'rdo_meeting_-_2018-03-14'
15:03:05 <mjturek> \o/
15:03:05 <openstack> Meeting started Wed Mar 14 15:03:03 2018 UTC and is due to finish in 60 minutes.  The chair is number80. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:03:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:03:09 <openstack> The meeting name has been set to 'rdo_meeting___2018_03_14'
15:03:11 <myoung|rover> o/
15:03:15 <rbowen> Oh, you're chairing? Awesome. :)
15:03:17 <rbowen> o/
15:03:24 <amoralej> o/
15:03:34 <number80> #chair rbowen myoung|rover amoralej mjturek
15:03:34 <zodbot> Current chairs: amoralej mjturek myoung|rover number80 rbowen
15:03:36 <openstack> Current chairs: amoralej mjturek myoung|rover number80 rbowen
15:03:38 <ykarel> o/
15:03:42 <baha> o/
15:03:49 <chandankumar> \o/
15:03:50 <number80> rbowen: yeah, I was mesmerized by my phone :)
15:03:54 <number80> #chair ykarel baha chandankumar
15:03:54 <zodbot> Current chairs: amoralej baha chandankumar mjturek myoung|rover number80 rbowen ykarel
15:03:55 <openstack> Current chairs: amoralej baha chandankumar mjturek myoung|rover number80 rbowen ykarel
15:04:08 <rdogerrit> Sagi Shnaidman created rdo-infra/ci-config master: TE-broker role  https://review.rdoproject.org/r/12915
15:04:49 <number80> ok, let's start
15:05:05 <number80> #topic PTG video are half up
15:05:13 <zodbot> number80: Error: Can't start another meeting, one is in progress.
15:05:13 <openstack> number80: Error: Can't start another meeting, one is in progress.  Use #endmeeting first.
15:05:15 <jpena> o/
15:05:20 <number80> http://youtube.com/RDOCommunity
15:05:25 <number80> #chair jpena
15:05:25 <zodbot> Current chairs: amoralej baha chandankumar jpena mjturek myoung|rover number80 rbowen ykarel
15:05:25 <openstack> Current chairs: amoralej baha chandankumar jpena mjturek myoung|rover number80 rbowen ykarel
15:05:29 <number80> ^ rbowen
15:05:39 <rbowen> Nothing more to say there. Just wanted people to know. They're going up at about the rate of 2 a day.
15:05:46 <rbowen> Watch them! THey're awesome!
15:05:55 <rbowen> If you missed your chance to do an interview, and still want to, ping me!
15:06:39 <number80> #info half of PTG videos are uploaded!
15:06:55 <number80> #info if you missed your chance to get interviewed, ping rbowen
15:07:40 <number80> I think we can move on then
15:07:43 <rbowen> Yep
15:07:58 <number80> #topic Building Power containers in centos
15:08:02 <number80> mjturek: ^
15:08:14 <mjturek> hey! so at PTG a bunch of us discussed the prospect of building RDO containers in the community. We're really excited to do this and I'm wondering how we get started.
15:08:32 <mjturek> number80: I think you mentioned that it should just be some config changes?
15:09:09 <mjturek> sorry, for Power specifically
15:10:09 <number80> We need to see with infra team, the details to reserve a power node through cico and set jobs
15:10:18 <rdogerrit> Eric Harney created openstack/cinder-distgit rpm-master: Require qemu-img >= 2.10.0  https://review.rdoproject.org/r/12916
15:10:25 <number80> anyone available to explain in details?
15:10:43 <mjturek> anyone we should ping specifically on the infra team?
15:12:01 <rbowen> Hmm. Anyone here from the infra team?
15:12:06 <rdogerrit> ktibi proposed rdoinfo master: Add designate-ui project to RDO  https://review.rdoproject.org/r/12914
15:12:07 <mjturek> I don't want to derail the meeting so we don't need to go into detail, but I'd like to get some initial steps set so we can get the ball rolling
15:12:33 <jpena> dmsimard: do you know ^^? (how to reserve a power node in ci.centos using cico)
15:12:49 <dmsimard> yeah
15:12:55 <krtaylor> probably also worth mentioning that we have worked out and built centos containers on power with kolla
15:12:56 <rbowen> I wonder if bringing it up at tomorrow's CentOS Cloud SIG meeting might be good.
15:12:56 <dmsimard> cicoclient has an --arch parameter or something along those lines
15:13:23 <dmsimard> rbowen, jpena: the doc is available here https://wiki.centos.org/QaWiki/CI/Multiarch
15:13:33 <number80> #chair dmsimard
15:13:33 <zodbot> Current chairs: amoralej baha chandankumar dmsimard jpena mjturek myoung|rover number80 rbowen ykarel
15:13:34 <openstack> Current chairs: amoralej baha chandankumar dmsimard jpena mjturek myoung|rover number80 rbowen ykarel
15:14:24 <number80> mjturek and dmsimard can you exchange about that either by chat or through the list (it can be interesting to happen there for future references)
15:14:44 <mjturek> dmsimard number80 that sounds good to me!
15:14:54 <number80> cool
15:14:56 <mjturek> but basically we need to start by figuring out what hardware we're using
15:17:05 <number80> ack
15:18:38 <number80> next topic?
15:18:46 <dmsimard> oh yeah I remember mjturek sent a patch to weirdo
15:18:48 <dmsimard> I meant to review that
15:19:19 <number80> *nods*
15:19:23 <mjturek> dmsimard yep - not sure it's complete but I figure it's a start
15:19:33 <mjturek> https://review.rdoproject.org/r/#/c/12858/
15:23:01 <number80> ok, next topic then
15:23:14 <number80> #action * follow-up on the mailing list about multiarch jobs
15:23:19 <number80> #topic How to process tickets opened in CentOS mantis instance
15:23:48 <number80> Fabian pointed me out that some people opened tickets on mantis for OpenStack bugs => https://bugs.centos.org/view.php?id=14566
15:24:30 <number80> I thought about adding a default assignee that should be a list so people can monitor it
15:27:00 <number80> nobody?
15:27:37 <amoralej> i can
15:27:39 <rbowen> Quiet today.
15:27:59 <jpena> number80: you can add me, if it's going to be mostly packstack stuff :)
15:28:17 <amoralej> number80, but there is no a RDO or cloudsig category?
15:28:27 <amoralej> it's per package?
15:28:30 <number80> Yeah, that's also something we need to figure out
15:28:50 <number80> amoralej: I'd rather encourage people to use launchpad or bugzilla since it's more actively monitored
15:28:53 <dmsimard> what did I miss ?
15:28:55 <dmsimard> I mean
15:28:59 <dmsimard> Why are we talking about mantis ?
15:29:05 <dmsimard> We already have bugzilla ?
15:29:22 <number80> dmsimard: we have tickets opened in mantis and we have to figure out how to handle them
15:29:41 <dmsimard> number80: I have enough trouble following up with one bug tracker as it is :(
15:30:17 <number80> Yeah, I know so that's why we're trying to figure out how to handle these
15:30:21 <amoralej> yeah, we probably should just ask requestors to fill a bz
15:31:08 <rbowen> That seems reasonable.
15:31:38 <dmsimard> It's hard enough for people to know where to file a bug in the first place
15:31:44 <number80> I don't mind that, it was my first answer :)
15:31:49 <dmsimard> Is it bugzilla ? launchpad ? storyboard ?
15:32:03 <number80> storyboard => /dev/null
15:32:07 <dmsimard> It's hard for people to tell who's fault an issue might be to begin with
15:32:21 <dmsimard> like is it a packaging issue, a project bug, etc
15:32:29 <number80> what we care is that tickets opened are visible by the people who can fix it
15:33:11 <number80> so we can monitor mantis so that they are not left unattended even if it means requesting people to use a different tracker
15:34:27 <dmsimard> yeah I don't have any great ideas right now, I'm not very familiar with mantis
15:34:51 <number80> #agreed encourage people using bugzilla instead and we'll figure out the rest later
15:35:07 <number80> since we have other topics to cover, let's move on
15:35:15 <amoralej> number80, yeah, it sounds reasonable to monitor and ask peopole to report in BZ
15:35:28 <number80> *nods*
15:35:45 <number80> #topic pip10 changes
15:36:03 <dmsimard> they were discussing $topic in #openstack-infra just now
15:36:21 <dmsimard> #link https://github.com/pypa/pip/issues/4805
15:36:26 <dmsimard> #link https://github.com/pypa/pip/pull/5066
15:36:54 <dmsimard> I'll copy-paste a summary in the best interest of time
15:36:58 <dmsimard> 11:25:23 	<clarkb>	dmsimard: the tl;dr is that distro packaging for python packages must stop using distutils (eg setup.py install) to make python packages to continue to be compatibile with future pip
15:37:09 <dmsimard> 11:27:17 	<fungi>	dmsimard: basically, `sudo pip install --upgrade foo` will start breaking with pip 10 if you have a distro-installed python-foo built with distutils mechanisms
15:37:47 <number80> ok, this is something that we can't change for EL7, but I need to ask status in Fedora
15:37:53 <dmsimard> This feels slightly important but I'm struggling to understand the impact on our packaging
15:38:28 <dmsimard> jschlueter, mburned_out ^ FYI
15:39:16 <dmsimard> apevec: ^ also
15:39:34 <dmsimard> I don't really have anything to add, this just seems like something pretty important that the knowledgeable people should be aware of
15:39:39 * dmsimard is a noob at packaging
15:40:01 <jschlueter> dmsimard: first time seeing this so not sure on imact currently .. tvignaud you have any insights?
15:40:06 <jschlueter> dmsimard: thanks for bringing it up
15:40:06 <number80> well, if it's about using pip to install packages, we're not yet there
15:40:13 <rbowen> I am also. I'm hoping to learn how to package this year, but I'm off to a slow start.
15:40:15 <dmsimard> number80: it's not /really/ about using pip
15:40:20 <number80> about metadata, it needs more time to think about it
15:40:33 <dmsimard> number80: it's about distro-installed python packages further conflicting with pip installed packages
15:40:38 <dmsimard> (at least as I understand it)
15:41:11 <jpena> if pip wants us to stop using setup.py install, well... it's there on 100% of our python RPM packages (via the %py2_install macro)
15:41:11 <number80> yeah, the thing is that there were multiple causes, and some were fixed, but I'm not sure they're the one we're speaking about
15:41:12 <jschlueter> need to figure it out for RDO first
15:41:36 <dmsimard> jpena: that's kind of my point, we need to figure that out (and what about EL7 and Fedora base packages??)
15:41:50 <tvignaud> jschlueter: regarding pip?
15:41:56 <dmsimard> Anyway, the issue and the pull request I linked above have more information
15:42:12 <jschlueter> tvignaud: more for reading material at this point
15:45:39 <jschlueter> just a quick reading of that makes it seem very very harsh for uptake of newer pip version
15:51:58 <dmsimard> number80: should we move on ?
15:52:13 <number80> yep
15:52:28 <number80> #topic next week chair
15:52:32 <number80> who wants it?
15:54:11 <amoralej> i can take it
15:54:36 <sfbender> Fabien Boucher created DLRN master: Remove workaround as include_fns arg of RdoInfoRepo is now merged  https://softwarefactory-project.io/r/11565
15:54:43 <rbowen> Thanks!
15:56:52 <number80> #info amoralej chairing next week
15:56:56 <number80> Thanks :)
15:57:00 <number80> #topic open floor
15:57:07 <number80> last call to bring a topic
15:59:36 <rdobot> [sensu] NEW: master.monitoring.rdoproject.org - check-delorean-queens-current @ http://tinyurl.com/ydch3xzo |#| Build failure on centos7-queens/current: networking-ovn: http://trunk.rdoproject.org/centos7-queens/report.html
16:00:32 <number80> #endmeeting