15:01:27 <jcapitao> #startmeeting RDO meeting - 2019-10-02
15:01:27 <zodbot> Meeting started Wed Oct  2 15:01:27 2019 UTC.
15:01:27 <zodbot> This meeting is logged and archived in a public location.
15:01:27 <zodbot> The chair is jcapitao. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:27 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:01:27 <zodbot> The meeting name has been set to 'rdo_meeting_-_2019-10-02'
15:01:28 <openstack> Meeting started Wed Oct  2 15:01:27 2019 UTC and is due to finish in 60 minutes.  The chair is jcapitao. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:30 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:32 <openstack> The meeting name has been set to 'rdo_meeting___2019_10_02'
15:01:44 <jcapitao> #topic roll call
15:01:57 <jcapitao> #chair PagliaccisCloud
15:01:57 <zodbot> Current chairs: PagliaccisCloud jcapitao
15:01:58 <openstack> Current chairs: PagliaccisCloud jcapitao
15:03:19 <jcapitao> Please add last-minute topic to meeting agenda, https://etherpad.openstack.org/p/RDO-Meeting
15:03:32 <ykarel> o/
15:03:49 <jcapitao> #chair ykarel
15:03:49 <zodbot> Current chairs: PagliaccisCloud jcapitao ykarel
15:03:49 <openstack> Current chairs: PagliaccisCloud jcapitao ykarel
15:04:07 <jpena> o/
15:04:32 <jcapitao> #chair jpena
15:04:32 <zodbot> Current chairs: PagliaccisCloud jcapitao jpena ykarel
15:04:33 <openstack> Current chairs: PagliaccisCloud jcapitao jpena ykarel
15:06:02 <jcapitao> amoralej: ^
15:08:26 <amoralej> o/
15:08:44 <jcapitao> #chair amoralej
15:08:44 <zodbot> Current chairs: PagliaccisCloud amoralej jcapitao jpena ykarel
15:08:45 <openstack> Current chairs: PagliaccisCloud amoralej jcapitao jpena ykarel
15:08:54 <jcapitao> ok let's start
15:09:06 <jcapitao> #topic swift deps py2->py3 Status
15:09:27 <jcapitao> it's me, so we have merged in master all py2/py3 swift deps today
15:09:49 <ykarel> nice
15:10:07 <amoralej> https://media.tenor.com/images/d45d1130a748a7d8b152c40b782c72c4/tenor.gif
15:10:29 <jcapitao> \o/
15:10:35 <amoralej> we need to merge https://review.rdoproject.org/r/#/c/22779/
15:10:43 <amoralej> to fix openstacksdk after the change
15:11:18 <ykarel> ohh i commented there in review i think
15:11:29 <ykarel> but seeing the binary was there in fedora, i let it go
15:11:36 <ykarel> unversioned binary
15:11:58 <ykarel> amoralej, what issue it caused
15:12:03 <amoralej> it's not in eeel8
15:12:27 <ykarel> ohhk got it, i should have checked there too
15:12:34 <amoralej> https://trunk.rdoproject.org/rhel8-master/report.html
15:12:42 <amoralej> we have several ftbfs there
15:12:44 <amoralej> need to check
15:13:00 <ykarel> ack
15:13:42 <jcapitao> those ftbfs are not connected to gerrit ?
15:13:55 <amoralej> jcapitao, nop rhel8 builder is not reporting to gerrit
15:14:24 <amoralej> #info all py2 removal commits have been merged in rpm-master
15:14:33 <jcapitao> ok
15:14:44 <jcapitao> so now I'm currently cherry-pick'ing those changes to train-rdo
15:14:51 <amoralej> #action amoralej check FTBFS in https://trunk.rdoproject.org/rhel8-master/report.html
15:14:57 <jcapitao> in order to recreate builds in cbs with the new specs
15:15:07 <jcapitao> #info cherry-pick'ing py2/py3 changes to train-rdo
15:15:15 <amoralej> and use in RDO Trunk Train
15:15:29 <amoralej> need to also cherry-pick fixes
15:15:34 <amoralej> as the one for openstacksdk
15:16:38 <jcapitao> ok I'll check this with you off-meeting
15:16:48 <amoralej> sure
15:17:21 <jcapitao> so let's move
15:17:33 <jcapitao> #topic Train Release Preparation
15:18:08 <jcapitao> ykarel: your time
15:18:20 <ykarel> ack
15:18:39 <ykarel> so have couple of updates,
15:18:44 <ykarel> #info Branching status: RC builds for service projects done, puppet modules are branched, CBS builds will be Done this week
15:19:00 <ykarel> a few are pending which are under review
15:19:33 <ykarel> #info Once builds are done we will start testing RC builds with adding train-testing tags for them
15:19:47 <ykarel> Some patches open for reviews:- https://review.rdoproject.org/r/#/q/topic:train-branching
15:19:59 <ykarel> please have a look at open reviews
15:20:19 <rdogerrit> Gabriele Cerami proposed rdo-infra/ci-config master: Promoter test: refactor integration tests  https://review.rdoproject.org/r/22664
15:20:29 <ykarel> #info Promotion pipeline Jobs for train are added/tested with:- https://review.rdoproject.org/r/#/q/topic:train-jobs
15:20:44 <ykarel> Still jobs are not activated, seems waiting for https://review.opendev.org/#/q/topic:train_release
15:20:56 <ykarel> but chandankumar rlandy can confirm more about it ^^
15:21:06 <ykarel> also with testing couple of issues are noticed
15:21:25 <ykarel> one is previous-current-tripleo symlink is not exist for train, causing updates job to fail
15:21:46 <amoralej> i can create one
15:21:53 <amoralej> pointing to the same hash
15:21:53 <ykarel> second, standalone upgrade job is failing, same as master, so may be oooq guys are already looking at those
15:21:57 <amoralej> as current-tripleo
15:22:09 <ykarel> ack
15:23:53 <amoralej> wrt to synchronization of -testing to buildlogs
15:23:54 <ykarel> any queries on above?
15:24:03 <amoralej> https://git.centos.org/centos/cbs-content-control/pull-request/11 is merged
15:24:07 <ykarel> hmm i checked it's not started
15:24:10 <amoralej> but still not syncing
15:24:13 <amoralej> i'll ask
15:24:22 <ykarel> ack
15:24:23 <jcapitao> what does oooq mean ?
15:24:28 <ykarel> tripleo quickstart
15:24:43 <jcapitao> ooh okk
15:25:50 <amoralej> jcapitao, oooq == tripleo-quickstart, oooqe == tripleo-quickstart-extras
15:26:04 <amoralej> repos used in CI to deploy usint tripleo
15:26:31 <jcapitao> got it
15:27:13 <amoralej> #info non-OpenStack puppet modules have been pinned for train
15:27:36 <jcapitao> if there is no more questions on above, we can move to next topic
15:27:37 <amoralej> there is not rc1 for openstack puppet modules yet ykarel
15:27:44 <amoralej> so we may need to wait a bit for it
15:27:49 <amoralej> before being able to test rc
15:28:02 <amoralej> or use m3 builds
15:29:01 <ykarel> EmilienM, mwhahaha, you aware of any timeline for RC bits for puppet modules ^^
15:29:11 <rdogerrit> User marios proposed rdo-infra/ci-config master: WIP! add promote-images molecule & delegated-promote-images job  https://review.rdoproject.org/r/22772
15:29:30 <mwhahaha> i'm not, we can probably propose one. or check if one is already up
15:29:40 <mwhahaha> i think we we already merged the  metadata bumps
15:30:15 <amoralej> mwhahaha, last release in puppet was M3 https://review.opendev.org/#/c/682269/
15:30:55 <mwhahaha> yea not sure the diff between m3 and current
15:30:59 <mwhahaha> probably only a few changes
15:31:59 <amoralej> mm there are reviews for rc1 in metadata.json https://review.opendev.org/#/c/684483/1
15:32:15 <amoralej> https://review.opendev.org/#/q/topic:prep-release-train-rc1+(status:open+OR+status:merged)
15:33:26 <rdogerrit> Merged openstack/glance-distgit rpm-master: Requirement Sync for Train  https://review.rdoproject.org/r/22541
15:33:54 <ykarel> ohhk the relase patch was up from 16th and merged around 27th
15:34:24 <ykarel> so since RC1 patches for puppet modules already merged, good to release RC tags for them
15:34:53 <amoralej> yes
15:34:57 <amoralej> and branch stable/train
15:35:05 <ykarel> hmm
15:35:24 <ykarel> mwhahaha, EmilienM wdyt wrt ^^?
15:35:40 <mwhahaha> m3 isn't rc1
15:36:47 <amoralej> yes, but apparently modules are ready to create rc1 releases
15:36:52 <mwhahaha> likely
15:37:07 <amoralej> https://review.opendev.org/#/q/topic:prep-release-train-rc1+(status:open+OR+status:merged
15:37:16 <mwhahaha> oh
15:37:17 <mwhahaha> handy
15:38:22 <mwhahaha> yea i don't think there's anything we need to land in the puppet land so we can likely branch those
15:39:03 <amoralej> ok, once new releases are created, builds should be automatically proposed in RDO
15:39:20 <ykarel> okk, so let's build non-openstack puppet modules
15:39:26 <amoralej> yes
15:39:26 <ykarel> as openstack one rely on those
15:39:31 <amoralej> we'll need them first also
15:39:41 <amoralej> it's next step in the list
15:41:33 <amoralej> also we could create rc tag in packstack
15:41:35 <amoralej> jpena, ^
15:41:43 <amoralej> and branch
15:41:44 <jpena> amoralej: ack, I will
15:42:03 <jpena> when do we need it?
15:43:20 <amoralej> jpena we can wait until we have builds for puppet
15:43:21 <ykarel> atleast around puppet modules builds are ready
15:44:25 <amoralej> i think that's it about train preparation
15:45:03 <ykarel> yes, let's move
15:45:22 <jcapitao> ok let's move on to the next topic
15:45:38 <jcapitao> #topic Chair for next week
15:45:59 <jcapitao> any volunteer?
15:46:09 <jpena> I can take it
15:46:10 <ykarel> i can take it
15:46:12 <ykarel> :)
15:46:42 <jcapitao> jpena: you're the winner :)
15:47:05 <jcapitao> #action jpena to chair next week meeting
15:47:41 <jcapitao> thank you
15:47:49 <jcapitao> #topic open floor
15:47:57 <rdogerrit> Alfredo Moralejo created openstack/ceilometermiddleware-distgit rpm-master: Fix command in %build  https://review.rdoproject.org/r/22786
15:48:07 <amoralej> fix for ftbfs ^
15:50:49 <rdogerrit> Alfredo Moralejo created openstack/cliff-distgit rpm-master: Fix command in %build  https://review.rdoproject.org/r/22787
15:52:26 <jcapitao> any other thoughts you would like to share ?
15:52:43 <rdogerrit> Merged rdo-infra/ci-config master: Fix container prep regex  https://review.rdoproject.org/r/22774
15:53:27 <amoralej> no from my side
15:53:34 <ykarel> nothing from me too
15:53:54 <jcapitao> ok let's close then
15:54:06 <jcapitao> thank you all for your time
15:54:26 <jcapitao> #endmeeting