14:01:07 <amoralej> #startmeeting RDO meeting - 2021-02-10
14:01:07 <zodbot> Meeting started Wed Feb 10 14:01:07 2021 UTC.
14:01:07 <zodbot> This meeting is logged and archived in a public location.
14:01:07 <zodbot> The chair is amoralej. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:07 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:01:07 <zodbot> The meeting name has been set to 'rdo_meeting_-_2021-02-10'
14:01:09 <openstack> Meeting started Wed Feb 10 14:01:08 2021 UTC and is due to finish in 60 minutes.  The chair is amoralej. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:12 <openstack> The meeting name has been set to 'rdo_meeting___2021_02_10'
14:01:27 <amoralej> #topic roll call
14:01:31 <mjturek> o/
14:01:49 <spotz> o/
14:02:04 <jcapitao> o/
14:02:11 <amoralej> #chair mjturek spotz jcapitao
14:02:11 <zodbot> Current chairs: amoralej jcapitao mjturek spotz
14:02:12 <openstack> Current chairs: amoralej jcapitao mjturek spotz
14:02:15 <ykarel> o/
14:02:37 <amoralej> #chair ykarel
14:02:37 <zodbot> Current chairs: amoralej jcapitao mjturek spotz ykarel
14:02:38 <openstack> Current chairs: amoralej jcapitao mjturek spotz ykarel
14:02:55 <amoralej> let's give a couple more minutes
14:03:38 <jpena> o/
14:03:45 <amoralej> #chair jpena
14:03:45 <zodbot> Current chairs: amoralej jcapitao jpena mjturek spotz ykarel
14:03:46 <openstack> Current chairs: amoralej jcapitao jpena mjturek spotz ykarel
14:04:39 <amoralej> #topic Publishing disk images for ppc64le
14:04:44 <amoralej> mjturek, ^
14:04:55 <mjturek> hello! we've briefly discussed this in the past but jeremyfreudberg and I would like to get this going. Can someone detail where we could upload to and where we can get credentials for the server?
14:05:55 <amoralej> this is about overcloud images, right?
14:05:56 <mjturek> currently we just build and discard the images
14:05:59 <mjturek> yep!
14:06:34 <amoralej> where is tripleo pushing their images now?
14:06:49 <mjturek> jeremyfreudberg do you happen to know?
14:06:59 <amoralej> a http://images.rdoproject.org/centos8/
14:07:02 <jeremyfreudberg> https://images.rdoproject.org/centos8/master/rdo_trunk/
14:07:03 <jeremyfreudberg> yeah
14:07:12 <amoralej> who is maintaining that?
14:07:19 <amoralej> jpena, is it under infra control?
14:08:16 <jpena> amoralej: yes. I see there is a RSYNC_PASSWORD env variable in the jenkins nodes, and https://github.com/rdo-infra/ci-config/blob/master/jenkins/jobs/scripts/tripleo-quickstart-publish-testing-images.sh uses it
14:08:31 <jpena> not sure if that script is still up to date, but we could test it
14:08:44 <amoralej> but i think images are now created in zuul jobs
14:08:50 <amoralej> in periodic pipeline?
14:09:03 <amoralej> ykarel, ^ you know where images are created and published?
14:09:30 <ykarel> amoralej, in periodic pipeline there are image build jobs, which build and pushes those images to images.rdoproject.org
14:09:35 <mjturek> ah interesting jpena
14:10:04 <ykarel> periodic-tripleo-centos-8-buildimage-overcloud-full-master and periodic-tripleo-centos-8-buildimage-ironic-python-agent-master for master
14:10:34 <amoralej> mjturek, you are creating it in a job in ci.centos.org?
14:10:53 <ykarel> i don't think publish-testing-images.sh is still being used in ci.centos
14:10:54 <mjturek> https://ci.centos.org/job/tripleo-upstream-images-build-master-ppc64le
14:11:22 <mjturek> amoralej this job runs tripleo-ci's build-images role
14:11:23 <amoralej> ok, so you are more interested in the jenkins jobs
14:11:32 <amoralej> that jpena pointed
14:11:54 <amoralej> just make sure you don't collide with the locations used by tripleo for the other images
14:12:02 <mjturek> absolutely
14:12:18 <mjturek> is there a folder we should upload to?
14:12:28 <mjturek> not sure if we're the ones to decide that
14:12:52 <amoralej> maybe other folder http://images.rdoproject.org/centos8-ppc64le/ ?
14:12:56 <amoralej> jpena, ^ wdyt?
14:13:56 <jpena> we have a top-level aarch64 directory with ocata and pike images, we could do the same and create images.rdoproject.org/ppc64le/master
14:13:58 <amoralej> iirc, the initial folder must be created in advance
14:14:19 <mjturek> oh nice!
14:15:04 <mjturek> can someone create a folder for us?
14:15:50 <jpena> I've created the folder already. Please contact me when you start uploading, we have some scripts to remove old images we will need to adapt
14:16:02 <mjturek> will do jpena
14:16:27 <jeremyfreudberg> thanks
14:16:28 <amoralej> mjturek, you plan to create images periodically?
14:16:38 <mjturek> amoralej we're building it for times a day
14:17:03 <mjturek> not sure if we'll need to adjust cadence but need to discuss that with oooci
14:17:05 <amoralej> just make sure you remove old ones
14:17:23 <amoralej> i'm not sure who/what takes care of prunning old ones
14:17:37 <mjturek> amoralej: jpena says there's a script that does it
14:17:45 <amoralej> ah, ok
14:17:55 <mjturek> but he'll need to adjust it
14:17:56 <amoralej> sorry, i didn't read it
14:18:00 <mjturek> \no worries!
14:18:04 <amoralej> yeah, i just re-read it
14:18:08 <amoralej> good
14:18:11 <jeremyfreudberg> yeah, seems we are building for ppc64le a lot more than for x86 is doing here... i mean, this is ~1 year and there are 40 images, and we would build as many in just 10 days
14:18:12 <ykarel> mjturek, isn't that job using url-trigger?
14:18:21 <jeremyfreudberg> i'm happy to do as much pruning as needed
14:18:32 <mjturek> jeremyfreudberg oh wow
14:18:49 <mjturek> ykarel we're doing a timed job currently. Is there a url-trigger we should use?
14:19:15 <ykarel> mjturek, yes it would be better to do with url-trigger to run unnecessary with same set of repos
14:19:37 <mjturek> ykarel might reach out to you to advise there
14:19:44 <ykarel> in our promotion jobs in ci.centos we run only when ex. trunk.rdoproject.org/centos8-master/current-tripleo/delorean.repo changes
14:19:58 <mjturek> oh cool!
14:20:12 <mjturek> +1 for running less frequently
14:21:10 <mjturek> so for now jeremyfreudberg and I will get the job uploading to that folder and will reach out as we hit blockers
14:21:26 <amoralej> ok, good
14:21:35 <amoralej> anything else wrt this topic?
14:21:36 <mjturek> jeremyfreudberg you have anything else?
14:21:42 <jeremyfreudberg> nope
14:21:48 <mjturek> cool thanks rdo folks!
14:22:09 <amoralej> #topic ansible-macros status
14:22:15 <amoralej> jcapitao, all yours
14:22:26 <jcapitao> so, currently mock config doesn't allow us to install weak deps in CBS
14:22:37 <jcapitao> I pinged Arrfab on #centos-devel channel to discuss about this
14:23:05 <jcapitao> he doesn't seem okay with the idea of providing those macros as they are still in Fedora rawhide (not yet branched anywhere)
14:23:38 <jcapitao> plus, it seems that ansible will make some changes in the near future, maybe we should wait a bit ?
14:24:58 <amoralej> iirc, it's sshnaidm who was willing to add some collections
14:25:27 <amoralej> so, as soon as he moves on we will hit this issue
14:25:43 <jcapitao> yeap
14:26:11 <jcapitao> so, do we ask to install weak deps anyway ?
14:26:15 <ykarel> so after fedora branches 34, he is ok? i see f34 will be released Apr 20
14:26:41 <amoralej> i'm not sure why branching is relevant in this case tbh
14:27:02 <amoralej> i think installing weak deps is good anyway
14:27:07 <amoralej> in cbs builds
14:27:22 <ykarel> atleast optionally allow to SIG who wants
14:27:41 <amoralej> yes, right
14:27:56 <amoralej> jcapitao, did arrfab tell you if that is possible?
14:28:01 <amoralej> i mean, request to enable weak deps
14:28:04 <jcapitao> plus it's BR
14:28:48 <jcapitao> amoralej: nope, he did not explictly say it was not possible
14:29:00 <jcapitao> I will create a pagure ticket
14:29:06 <amoralej> so, i'd try to move on with the weak deps
14:29:07 <jcapitao> to track it
14:29:14 <amoralej> we can discuss wrt ansible-macros
14:29:19 <amoralej> as a separated issue
14:29:25 <amoralej> but it's something we can do in the SIG
14:29:58 <jcapitao> right
14:30:36 <spotz> hehee I like the he didn't explicitly say it was not possible:)
14:31:12 <amoralej> we like explicitness :)
14:31:31 <amoralej> #action jcapitao to request to enable weak dependencies in CBS build root
14:32:25 <amoralej> so i think we have next steps wrt this?
14:32:32 <amoralej> jcapitao, wrt the python3-pip issue
14:32:39 <rdogerrit> Merged rdoinfo master: Fix pin for puppet-certmonger  https://review.rdoproject.org/r/31932
14:32:40 <amoralej> did you find something?, it's a weird issue
14:33:08 <jcapitao> I haven't find anything relevant
14:33:31 <jcapitao> I'll check with centos guys
14:33:40 <jcapitao> as you mentioned
14:34:06 <amoralej> but i think it should affect to anyone building something with BR on python3 in centos7
14:34:18 <amoralej> although probably not may people will be using it
14:34:37 <amoralej> there may be something preventing python3-pip installation in cbs buildroot
14:34:50 <jcapitao> to bring context: https://review.rdoproject.org/r/#/c/31885/
14:35:23 <amoralej> check mock config
14:35:24 <jcapitao> ah ?
14:35:45 <rdogerrit> rdo-trunk created puppet/puppet-certmonger-distgit train-rdo: puppet-certmonger-2.6.0-1.a198870git  https://review.rdoproject.org/r/31933
14:35:52 <rdogerrit> rdo-trunk created puppet/puppet-certmonger-distgit ussuri-rdo: puppet-certmonger-2.6.0-1  https://review.rdoproject.org/r/31934
14:35:59 <rdogerrit> rdo-trunk created puppet/puppet-certmonger-distgit victoria-rdo: puppet-certmonger-2.6.0-1  https://review.rdoproject.org/r/31935
14:36:05 <jcapitao> but if there is not python3-pip then python3 would not be able to be installed ?
14:36:19 <amoralej> yes, that's the problem as i understand it
14:36:27 <amoralej> python3-pip is Requires for python3
14:36:46 <jcapitao> I will give another shot this afternoon
14:37:20 <amoralej> DEBUG util.py:439:  Error: Package: python3-3.6.8-18.el7.x86_64 (build)
14:37:20 <amoralej> DEBUG util.py:439:             Requires: python3-pip
14:37:22 <amoralej> in fact
14:37:25 <amoralej> other question is
14:37:32 <amoralej> what is pulling python3 as dependency
14:37:46 <amoralej> there may be some issue in some of the deps
14:38:07 <amoralej> ah, ansible-freeipa you mentioned
14:38:08 <jcapitao> it's ansible-freeipa
14:38:11 <jcapitao> yeah
14:38:37 <amoralej> ok, let's check it after the mtg
14:38:49 <amoralej> we can move to next topic, right?
14:38:59 <jcapitao> yes
14:39:41 <amoralej> #topic Issues in Fedora with OpenStack packages and python 3.10
14:40:16 <amoralej> so, some of you may have got mails related to BZs with build failures with openstack packages in fedora for python3.10
14:40:24 <amoralej> mostly related to collections
14:40:51 <amoralej> as example https://bugzilla.redhat.com/show_bug.cgi?id=1926360
14:40:54 <openstack> bugzilla.redhat.com bug 1926360 in python-oslo-context "python-oslo-context fails to build with Python 3.10: AttributeError: module 'collections' has no attribute 'MutableMapping'" [Unspecified,New] - Assigned to chkumar
14:41:25 <amoralej> #info tracker BZ https://bugzilla.redhat.com/show_bug.cgi?id=1890881
14:41:27 <openstack> bugzilla.redhat.com bug 1890881 in Changes Tracking "Python 3.10 tracker" [Unspecified,Assigned] - Assigned to thrnciar
14:42:07 <amoralej> those failures are related to builds in a test copr
14:42:19 <amoralej> but the plan is to include 3.10 in F35
14:42:50 <amoralej> so, i think we have some time to fix, i don't like to start pushing cherry-picks in the distgit
14:42:57 <ykarel> so fixes are already in place
14:43:13 <amoralej> when we are going to have final releases for libraries and clients in wallaby in three weaks
14:43:20 <amoralej> ykarel, some of them are fixed, some others not
14:43:27 <amoralej> let me check
14:43:48 <jpena> at least we should identify if there's a fix upstream, and send it if there's not
14:43:54 <jpena> sushy was lacking one fix
14:43:57 <amoralej> #info https://review.opendev.org/q/topic:%22collections.abc%22+(status:open%20OR%20status:merged)
14:44:19 <amoralej> jpena, yep, that's a good point
14:44:24 <ykarel> ohkk so then we have to send fix for pending ones or reach out to maintainers
14:44:34 <amoralej> tbh, i think those are being treated systematically
14:44:48 <amoralej> i'd expect that there are reviews for all or most of them
14:44:52 <amoralej> but yes, good to check
14:45:27 <amoralej> and i'd propose to update packages in Fedora as soon as possible even before of Wallaby GA
14:45:39 <amoralej> maybe at RC1 or so
14:46:02 <jcapitao> ok, and update later with final releases ?
14:46:07 <amoralej> no
14:46:22 <amoralej> in fedora we have only libraries and clients
14:46:30 <amoralej> so, they are finally releases
14:46:32 <ykarel> at rc1 client/libs are final ones
14:46:36 <ykarel> yeap right
14:46:37 <amoralej> yep
14:47:02 <jcapitao> okk
14:47:08 <ykarel> there may be more after that for FFE but those are rare
14:47:35 <amoralej> yeap
14:47:40 <amoralej> we can treat those later
14:48:15 <amoralej> so, to start, could we get a list of all the bz for python3.10 that affect to packages in openstack-sig?
14:48:25 <amoralej> or the ones we maintain
14:49:40 <ykarel> yes sounds good
14:49:45 <amoralej> we can try to create a query
14:49:54 <amoralej> that includes any of us as assigned
14:50:05 <amoralej> i'm not sure what's the best way, tbh
14:50:43 <ykarel> iirc we you have created similar query in past when we were retiring some packages, can use that
14:50:48 <ykarel> s/we/you
14:50:50 <amoralej> mmm, right
14:50:55 <amoralej> i'll find out
14:51:03 <amoralej> i need to remember
14:51:05 <amoralej> :)
14:51:18 <amoralej> so, i'll create some etherpad with the list
14:51:24 <amoralej> so that we can start working on it
14:51:52 <amoralej> #action amoralej to create the list of BZ for python3.10 issues related to openstack packages
14:52:23 <amoralej> #action openstack-sig to check if there are missing patches upstream for issues with python 3.10
14:52:50 <amoralej> #info we will update openstack libraries and clients in Fedora as soon as final ones are releases by RC1
14:52:56 <amoralej> i think that's it
14:53:16 <amoralej> #topic chair for next week
14:53:19 <amoralej> volunteers?
14:53:38 <ykarel> i can take it
14:53:55 <amoralej> #action ykarel to chair next week
14:53:59 <amoralej> #topic open floor
14:54:25 <amoralej> time for anyone that wants to bring some other topic
14:55:02 <spotz> A reminder if you received an email about Cloud SiG and wish to be a member going forward please answer me:)
14:55:19 <amoralej> any progress with replies=
14:55:21 <amoralej> ?
14:55:38 <spotz> A few and talked to Rich yesterday, they're ok with us removing the non-responses
14:55:45 <amoralej> ok
14:56:01 <amoralej> spotz, you plan to update the cloudsig wiki?
14:56:24 <spotz> Oddly none from the unapproved queue
14:56:35 <amoralej> ok
14:56:36 <spotz> amoralej: I've updated once a little already
14:56:41 <amoralej> well, let's give some time
14:56:42 <amoralej> ah, ok
14:56:55 <amoralej> someone showed interest also on it
14:57:02 <amoralej> on improving the wiki
14:57:13 <amoralej> ykarel or jcapitao, iirc
14:57:23 <spotz> I put the meeting frequency change and the interim contacts on it already
14:57:27 <ykarel> yeap i pointed out
14:57:38 <amoralej> ok
14:57:47 <spotz> Oh and removed the word Linux linke on the calendar page
14:58:04 <amoralej> ok :)
14:58:13 <amoralej> so, we are almost out of time
14:58:21 <amoralej> anything else?
14:58:29 <spotz> ykarel: Feel free to make any little changes to it, if you want to do something bigger just share for another set of eyes first. Kinda like we do for large mailings
14:58:50 <ykarel> spotz, sure will sync with you on it
14:58:59 <spotz> I for one am bad for missing my own typoes in larger things:)
14:59:55 <amoralej> i'm closing the mtg
15:00:08 <amoralej> sorry, i have one more right now :)
15:00:21 <amoralej> #endmeeting