20:11:52 <dgilmore> #startmeeting
20:11:52 <zodbot> Meeting started Fri Feb 11 20:11:52 2011 UTC.  The chair is dgilmore. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:11:52 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
20:12:01 <dgilmore> #meetingname releng
20:12:01 <zodbot> The meeting name has been set to 'releng'
20:12:07 <dgilmore> #topic init
20:12:41 <dgilmore> notting: Oxf13: skvidal: abadger1999: nirik: ping
20:12:45 <notting> yo
20:12:58 * abadger1999 around
20:13:02 <Oxf13> idle.
20:13:05 * nirik is here.
20:13:16 <notting> should we invite the new guys?
20:13:22 <dgilmore> notting: yep
20:13:42 <dgilmore> nb: ping
20:14:10 * jsmith lurks
20:15:09 <dgilmore> #info present jsmith notting nirik abadger1999 dgilmore Oxf13
20:15:18 <dgilmore> #topic mass rebuild
20:15:40 <dgilmore> so other than being crammed it went reasonably smoothly
20:15:59 <dgilmore> there is still some packages needing building
20:16:02 <nirik> sounds like there might be some corner case tagging issues?
20:16:11 <dgilmore> possibly that also
20:16:33 <dgilmore> im waiting on just under 5k rpms to be signed
20:16:45 <dgilmore> then i can do a branched compose and see how we are looking
20:16:55 <nirik> rawhide finished today?
20:17:18 <notting> good question
20:17:19 <nirik> looks like it did.
20:17:20 <notting> it started :)
20:17:24 <nirik> but hasn't synced yet?
20:17:49 <dgilmore> seems to be not finished
20:17:59 <notting> oof
20:18:01 <notting> it's still going
20:18:59 <notting> presumably, all the rebuild-induced deltas
20:19:13 <dgilmore> probably yeah
20:19:23 <dgilmore> its still running mash
20:19:51 <nirik> well, hopefully it will be along...
20:20:18 <dgilmore> once the packages are signed ill manually run a branched compose
20:20:32 <nirik> ok.
20:20:48 <dgilmore> try and get the tc2 images created
20:20:51 <nirik> how do we want to handle updates? I didn't push any this morning...
20:21:14 <dgilmore> anything else on the rebuild anyone wants to add?
20:21:39 <dgilmore> #topic updates
20:21:43 <dgilmore> ok updates
20:22:16 <dgilmore> id like to wait till i get the f15 packages all signed
20:22:23 <dgilmore> then do updates pushes
20:23:10 <nirik> ok. You want me to push them all, or should we split up the pushing?
20:23:26 <dgilmore> i need to grant access to the fedora-15 key to at least nirik
20:23:40 <nirik> with branched we just push testing right?
20:23:50 <nirik> regular is nightly ?
20:23:54 <notting> no,it's more complicated than that
20:24:04 * nirik tries to recall.
20:24:06 <dgilmore> nirik: well we push all except for when frozen
20:24:23 <notting> there's also stable pushes, for things that pass testing. it just tags them into dist-f15
20:24:31 <dgilmore> when we are in the feature freeze we manually include the builds that fix the blockers
20:24:36 <dgilmore> and push testing
20:24:56 <dgilmore> notting: right thats a per build thing
20:25:18 <dgilmore> once pushed to stable it goes to dist-f15
20:25:32 <dgilmore> we need to make sure that the packages are signed
20:25:40 <dgilmore> and have signed copies written to disk
20:25:48 <dgilmore> then the branched compose will pull them in
20:26:08 <dgilmore> there is 2 phases of pushes
20:26:20 <notting> the one issue is that because stable-bound things are moved from updates-testing to dist-f15, once you push stable updates, you need to wait for the next branched compose before you push testing again
20:26:21 <dgilmore> when we are not frozen we can push to stable and testing
20:26:26 <notting> otherwise packages disapper
20:26:31 <notting> disappear, even
20:26:36 <dgilmore> when frozen we can push to testing and selected builds to stable
20:26:47 <nirik> yeah, thats the wrinkle I was trying to remember.
20:27:26 <dgilmore> notting: right
20:27:33 <dgilmore> so push to testing
20:27:39 <dgilmore> then do the stable push
20:27:51 <dgilmore> then after branched can be done again
20:28:25 <nirik> or perhaps do testing in the morning, then wait in case we want more testing pushes during the day, and do a stable later in the day when things are quieted down?
20:28:36 <dgilmore> or that
20:28:42 <notting> that can work too, if you're willing to keep up with it
20:29:03 <nirik> if we don't do a stable push, the branched compose will pick those up, right?
20:29:10 <nirik> so, perhaps no stable pushes unless requested?
20:29:22 <nirik> or it only picks up things that have been pushed already to stable?
20:29:33 <dgilmore> nirik: we have to do the stable push for things to hit the branched compose
20:29:42 <nirik> ok.
20:30:20 <nirik> we should update http://fedoraproject.org/wiki/Pushing_fedora_updates
20:30:46 <dgilmore> yeah
20:30:50 <dgilmore> ill do that
20:30:51 <notting> we just be careful with what we push during freezes
20:30:59 <notting> according to the wiki, we're not frozen now
20:31:13 <nirik> yeah.
20:31:44 <dgilmore> #action dgilmore to update wiki with info on pushing for branched
20:31:47 <nirik> so, I am happy just adding F15-testing to the morning pushes I have been doing... perhaps then someone else could do the stable ones later in the day?
20:32:02 <dgilmore> notting: right next tuesday we hit freeze
20:33:51 <dgilmore> http://poelstra.fedorapeople.org/schedules/f-15/f-15-releng-tasks.html lists Feb 15
20:34:09 <dgilmore> #link http://poelstra.fedorapeople.org/schedules/f-15/f-15-releng-tasks.html releng tasks
20:34:38 <nirik> or if folks want I can do stable too, but then we couldn't do a later one...
20:35:25 <dgilmore> nirik: maybe we should make the cutoff 5pm est
20:35:33 <nirik> sounds reasonable.
20:35:34 <dgilmore> do a stable push then
20:35:43 <notting> nirik: are you doing pushes via web or cli?
20:35:49 <nirik> cli
20:36:14 <dgilmore> and we can do testing pushes during the day
20:36:16 <notting> ok. may need to fix the cli to be able to only do a testing/stable push
20:36:24 <dgilmore> notting: ive never used the web to do a push
20:36:25 <nirik> I think it can do that...
20:36:34 <dgilmore> notting: it can do it
20:37:07 <dgilmore> bodhi -P --push-release=F15 --push-type=testing
20:37:11 <nirik> yeah.
20:37:19 <notting> that works. i think it was --push-type=stable that didn't
20:37:27 <notting> (unless it got fixed)
20:37:32 <lmacken> it was push-type=testing that didn't work, and I fixed it
20:37:45 <nirik> thanks lmacken. ;)
20:37:53 <dgilmore> notting: yeah stable builds during frozen we cant use --push-type=stable
20:37:59 <lmacken> fixed in 0.7.10
20:38:11 <dgilmore> we need to push only approved blocker builds
20:39:22 * nirik nods.
20:39:24 <dgilmore> ok i think we have a plan for updates
20:39:40 <dgilmore> #topic alpha tasks
20:39:56 <dgilmore> i think were on track
20:40:06 <dgilmore> the mass rebuild put us a little behind
20:40:22 <dgilmore> but not to the extent that its going to cause delays
20:40:56 <dgilmore> we have a bunch of stuff that we need to do over the next few weeks
20:41:14 <nirik> I guess we still need to block / retire orphans?
20:41:21 <notting> nirik: working on that
20:41:28 <nirik> cool.
20:41:39 * nirik wonders if he can add one of his...
20:41:47 <dgilmore> nirik: you can
20:42:01 <dgilmore> the first RC for alpha is due next thursday
20:42:46 <dgilmore> please let me know if i missed something
20:42:56 <dgilmore> notting: they going to be blocked today?
20:43:15 <notting> dgilmore: wanted to give a little more warning
20:43:24 <dgilmore> notting: ok no problems
20:44:17 <dgilmore> once i have a branched compose im going to do tc2 compose. would have been good to have them blocked
20:44:55 <dgilmore> oh well
20:45:23 <notting> let's re-run the script and see how bad it would be
20:45:30 <dgilmore> notting: ok
20:45:55 <dgilmore> #topic koji admins
20:46:22 <dgilmore> so i noticed yesterday that caillion tagged stuff into dist-f15-override
20:46:26 <dgilmore> which suprissed me
20:46:53 <dgilmore> i revoked his admin privlidges and gave hime fedora-override
20:47:11 <notting> those are separate?
20:47:16 <dgilmore> but it made me think we should check who has admin privlidges and if they really need it
20:47:24 <dgilmore> notting: they are as of last week
20:47:46 <dgilmore> rather than grant admin to tomspur and nb i did the same as was done for epel
20:48:05 <dgilmore> there is a epel-override and fedora-override groups
20:48:28 <dgilmore> to tag into overrides you only need to be a member of the appropriate groups
20:49:20 <dgilmore> my main concern was that things were tagged into overrides and not being documented
20:49:26 <dgilmore> maybe that doesnt matter
20:49:29 <notting> who are the current set of admins?
20:50:05 <dgilmore> notting: let me look in the db
20:50:08 <notting> probably needs to be 'anyone who pushes updates' (on top of existing koji guys like mbonnet/mikem/etc)
20:50:19 <nirik> yeah, the command line doesn't seem to have a way to list them out.
20:52:14 <nirik> anyhow, we could do that out of band? or do we want to do it now?
20:53:24 <dgilmore> lets do it out of band
20:53:45 <dgilmore> what are peoples thoughts
20:53:55 <notting> wfm
20:53:59 <nirik> sure.
20:54:06 * skvidal is sorry he wasn't hear earlier
20:54:48 <abadger1999> sounds good.
20:56:56 * nirik has a topic if we still have time/for open floor.
20:57:34 * notting has one too
20:58:12 <dgilmore> nirik: its yours
20:58:20 <dgilmore> #admin nirik notting
20:58:29 <dgilmore> #admins nirik notting
20:58:45 <nirik> you want #chair
20:58:48 <nirik> ?
20:58:55 <dgilmore> #chair nirik notting
20:58:55 <zodbot> Current chairs: dgilmore nirik notting
20:58:59 <dgilmore> nirik: yep
20:59:03 <dgilmore> the floor is yours
20:59:17 <nirik> #topic Feedback on multidvd
20:59:21 <nirik> https://fedorahosted.org/rel-eng/ticket/4342
20:59:28 <nirik> we were asked for feedback on this issue a while back.
20:59:33 <nirik> we should really respond. ;)
20:59:46 <dgilmore> nirik: i spoke with spot on this yesterday.  he was going to come up with some saner tooling
21:00:06 <dgilmore> we can put it on alt
21:00:16 <nirik> excellent. So, it might end up being something we produce? or at least host?
21:00:30 <dgilmore> but my biggest concern is all the fighting over the tooling
21:00:35 <nirik> yeah.
21:00:48 <nirik> I can see this being a lot more useful for ambassadors than most users.
21:01:00 <dgilmore> nirik: well the board wants releng to be the producers.  but i feel it has no place as part of the regular release
21:01:11 <dgilmore> so alt seems like a good place for it
21:01:40 <nirik> sure, but that still leaves who produces it and with what tools...
21:01:45 <nirik> but it sounds like thats being worked on.
21:01:53 <dgilmore> nirik: well releng produces
21:02:00 <nirik> ok.
21:02:06 <dgilmore> its the tools that are in question
21:02:21 <nirik> cool. So, if you or spot could update the ticket with some info that would be great.
21:02:30 <dgilmore> sure  will do
21:02:32 <nirik> thats all I had. Just wanted to bring that up
21:02:38 <dgilmore> nirik: thanks
21:02:43 <dgilmore> notting: floor is yours
21:02:46 <jsmith> dgilmore: From my perspective, I don't think it needs to be tied to the release schedule
21:03:05 <jsmith> dgilmore: But I would like it produced by rel-eng, with tools that are in Fedora (for obvious reasons)
21:03:07 <notting> ok, just wanted to comment on rawhide this week
21:03:23 <dgilmore> jsmith: considering we dont make livecds with updates it makes sense to do it with the rest of the release
21:03:33 <notting> it failed twice due to a very bizarre error copying the files. no obvious reason it would have happened other than 'something else running in parallel', which didn't seem to be the case
21:03:35 <dgilmore> #topic rawhide this week
21:03:41 <notting> we couldn't reproduce it
21:03:46 <notting> and it passed that part today
21:04:16 <notting> #info rawhide failed twice this week, in nonreproducible fashion
21:04:29 <notting> #info it passed this area today
21:04:36 <notting> #info watch in case it happens agian
21:04:39 <notting> #undo
21:04:39 <zodbot> Removing item from minutes: <MeetBot.items.Info object at 0x2b0260a44f50>
21:04:43 <notting> #info watch in case it happens again
21:04:57 <notting> just stating that for the record. not sure what else to do at this point
21:05:12 <dgilmore> notting: i guess all we can do is keep an eye on it
21:05:14 <nirik> yeah, it was a weird one.
21:06:20 <dgilmore> alright anything else?
21:06:57 * nirik has nada
21:07:00 <notting> not i
21:07:03 <dgilmore> if not ill close up in 30
21:07:50 <dgilmore> #endmeeting