#fedora-meeting-1: RELENG (2014-09-29)

Meeting started by dgilmore at 15:31:54 UTC (full logs).

Meeting summary

  1. init process (dgilmore, 15:32:02)
  2. #5931 [Proposal] Move new branch and unretire requests to pkgdb2 (dgilmore, 15:35:17)
    1. https://fedorahosted.org/rel-eng/ticket/5931 (dgilmore, 15:35:22)
    2. nothing new from pingou (tyll, 15:35:35)

  3. #5967 Enable source repo generation (dgilmore, 15:35:55)
    1. ACTION: dgilmore still needs to ask for more info (tyll, 15:36:24)

  4. #4071 Block pushes to origin/ in gitolite ACLs (dgilmore, 15:37:04)
    1. https://fedorahosted.org/rel-eng/ticket/4071 (dgilmore, 15:37:09)
    2. patches in the ticket need review (tyll, 15:38:05)
    3. ACTION: dgilmore to apply patch (dgilmore, 15:38:53)
    4. move to production after f21 with lots of changes (tyll, 15:44:27)

  5. #5878 noarch packages corrupted on import on ppc.koji.fp.o (dgilmore, 15:46:15)
    1. https://fedorahosted.org/rel-eng/ticket/5878 (dgilmore, 15:46:21)
    2. bug in koji (tyll, 15:47:29)

  6. #5959 Enable keep-alive connections for koji (primary and secondaries) (dgilmore, 15:50:20)
    1. https://fedorahosted.org/rel-eng/ticket/5959 (dgilmore, 15:50:27)
    2. updating ticket was forgotten, it should be enabled everywhere (tyll, 15:51:22)

  7. #5963 Orphaned vulnerable packages in EPEL (dgilmore, 15:51:32)
    1. https://fedorahosted.org/rel-eng/ticket/5963 (dgilmore, 15:51:35)
    2. ACTION: volunteer needed for tooling (dgilmore, 15:52:34)

  8. #6000 automate creation of excludelist for koji-shadow (dgilmore, 15:52:52)
    1. https://fedorahosted.org/rel-eng/ticket/6000 (dgilmore, 15:52:58)
    2. http://kojipkgs.fedoraproject.org/mash/branched-20140929/logs/excludearch-arm.log (dgilmore, 15:54:19)
    3. scripts were adjusted, but need debugging (tyll, 15:54:21)
    4. ACTION: dgilmore to fix up the calls (dgilmore, 15:58:34)

  9. #5886 need method for distributing urgent fixes... urgently (dgilmore, 16:01:11)
    1. https://fedorahosted.org/rel-eng/ticket/5886 (dgilmore, 16:01:17)
    2. do not rely on fedmsg (tyll, 16:06:45)
    3. multilib needs to be taken care of (tyll, 16:12:42)
    4. ACTION: nirik create a wiki page (tyll, 16:12:53)
    5. mirrormanager needs changes (tyll, 16:13:54)

  10. https://fedorahosted.org/rel-eng/ticket/5775 (dgilmore, 16:16:24)
    1. https://fedorahosted.org/rel-eng/ticket/5775 (dgilmore, 16:16:27)
    2. https://fedoraproject.org/wiki/Urgent_updates_policy is the draft I put up. Please edit/add. (nirik, 16:16:38)
    3. this is what oddshocks's upload service does (tyll, 16:19:07)

  11. #5819 Need tags deleted in python-heatclient repo (dgilmore, 16:20:19)
    1. https://fedorahosted.org/rel-eng/ticket/5819 (dgilmore, 16:20:22)
    2. koji should be changed to create non-scratch builds only from full commit hashes (tyll, 16:28:56)
    3. https://fedorahosted.org/rel-eng/ticket/5843 (tyll, 16:30:30)
    4. https://fedorahosted.org/koji/ticket/281 (tyll, 16:30:41)
    5. tags cannot be removed, because they might have been used to build something (tyll, 16:31:32)
    6. ACTION: dgilmore to close the ticket as wontfix with and explanation as to why (dgilmore, 16:32:27)

  12. #5914 Move fedmsg based blocking service to Fedora Infrastructure (dgilmore, 16:32:35)
    1. https://fedorahosted.org/rel-eng/ticket/5914 (dgilmore, 16:32:41)
    2. ACTION: till to get teh script in to the releng git repo and wire up buildbranched and buildrawhide to run it (dgilmore, 16:41:25)
    3. ACTION: dgilmore to make sure the masher user can block the packages and that till wires thinsg up correctly (dgilmore, 16:41:54)

  13. Secondary Architectures updates (dgilmore, 16:46:43)
  14. Secondary Architectures update - ppc (dgilmore, 16:54:02)
    1. ppc Alpha TC2 out and being tested, hopefully RC soon (dgilmore, 16:55:48)

  15. Secondary Architectures update - s390 (dgilmore, 16:56:00)
  16. Secondary Architectures update - arm (dgilmore, 17:00:28)
  17. Open Floor (dgilmore, 17:11:36)
    1. https://lists.fedoraproject.org/pipermail/releng-cron/2014-September/002672.html and https://lists.fedoraproject.org/pipermail/releng-cron/2014-September/002673.html (nirik, 17:12:02)
    2. cron jobs fail because of dwa's expired koji certificate (tyll, 17:13:24)
    3. ACTION: pbrobinson takes care to fix them (tyll, 17:13:55)
    4. http://fedoraproject.org/wiki/Packaging:Guidelines#Desktop_files (dgilmore, 17:29:52)
    5. https://fedoraproject.org/wiki/Packaging:Guidelines#Desktop_files (nirik, 17:36:23)


Meeting ended at 17:48:20 UTC (full logs).

Action items

  1. dgilmore still needs to ask for more info
  2. dgilmore to apply patch
  3. volunteer needed for tooling
  4. dgilmore to fix up the calls
  5. nirik create a wiki page
  6. dgilmore to close the ticket as wontfix with and explanation as to why
  7. till to get teh script in to the releng git repo and wire up buildbranched and buildrawhide to run it
  8. dgilmore to make sure the masher user can block the packages and that till wires thinsg up correctly
  9. pbrobinson takes care to fix them


Action items, by person

  1. dgilmore
    1. dgilmore still needs to ask for more info
    2. dgilmore to apply patch
    3. dgilmore to fix up the calls
    4. dgilmore to close the ticket as wontfix with and explanation as to why
    5. dgilmore to make sure the masher user can block the packages and that till wires thinsg up correctly
  2. nirik
    1. nirik create a wiki page
  3. pbrobinson
    1. pbrobinson takes care to fix them
  4. UNASSIGNED
    1. volunteer needed for tooling
    2. till to get teh script in to the releng git repo and wire up buildbranched and buildrawhide to run it


People present (lines said)

  1. dgilmore (251)
  2. nirik (67)
  3. tyll (61)
  4. kalev (39)
  5. bochecha (34)
  6. sharkcz (34)
  7. pbrobinson (30)
  8. zodbot (6)
  9. mbooth (2)
  10. masta (0)


Generated by MeetBot 0.1.4.