2023-10-17 16:00:21
         <@humaton:fedora.im>  
        !startmeeting RELENG (2023-10-17)

        
2023-10-17 16:00:23 <@meetbot:fedora.im> Meeting started at 2023-10-17 16:00:21 UTC
2023-10-17 16:00:23 <@meetbot:fedora.im> The Meeting name is 'RELENG (2023-10-17)'
2023-10-17 16:00:28 <@humaton:fedora.im> !meetingname releng
2023-10-17 16:00:33 <@humaton:fedora.im> !chair nirik sharkcz pbrobinson phsmoura dustymabe jednorozec
2023-10-17 16:00:58 <@humaton:fedora.im> !topic init process
2023-10-17 16:01:29 <@jnsamyak:matrix.org> !hello jnsamyak
2023-10-17 16:01:31 <@zodbot:fedora.im> Samyak Jain (jnsamyak) - he / him / his
2023-10-17 16:01:58 <@nirik:matrix.scrye.com> oh, on matrix? ok... morning
2023-10-17 16:02:23 <@humaton:fedora.im> well that where I got the ping :D
2023-10-17 16:03:01 <@humaton:fedora.im> It seems there is most of the meetbot features implemented
2023-10-17 16:03:25 <@nirik:matrix.scrye.com> mostly yeah... we still need to sort out the meetingminutes email...
2023-10-17 16:03:36 <@humaton:fedora.im> oh
2023-10-17 16:03:46 <@humaton:fedora.im> so should I close it and rerun on IRC
2023-10-17 16:03:47 <@humaton:fedora.im> ?
2023-10-17 16:03:51 <@humaton:fedora.im> its not a problem...
2023-10-17 16:04:04 <@nirik:matrix.scrye.com> no biggie, lets try here...
2023-10-17 16:06:16 <@humaton:fedora.im> I dont have much updates for today. Some more updates to the docs are needed as we discussed with jnsamyak
2023-10-17 16:06:23 <@humaton:fedora.im> some more small ones
2023-10-17 16:06:32 <@nirik:matrix.scrye.com> !info nirik out on pto starting 2023-10-18 and back 2023-10-24
2023-10-17 16:06:33 <@patrikp:matrix.org> !hello patrikp
2023-10-17 16:06:36 <@zodbot:fedora.im> Patrik Polakovič (patrikp)
2023-10-17 16:06:51 <@jnsamyak:matrix.org> `nirik hope you have lots of fun on the time off :D
2023-10-17 16:07:14 <@humaton:fedora.im> yup, so we are running the RCs jnsamyak patrikp
2023-10-17 16:07:16 <@nirik:matrix.scrye.com> me too. ;) I'll likely poke in from time to time if I am bored. ;)
2023-10-17 16:07:38 <@nirik:matrix.scrye.com> dunno if we will get a rc in time this week, but we will see
2023-10-17 16:08:51 <@nirik:matrix.scrye.com> I think the fedora-final.conf is ready to go... but do check it over first
2023-10-17 16:10:19 <@pcreech:matrix.org> !hello pcreech17
2023-10-17 16:10:23 <@zodbot:fedora.im> Patrick Creech (pcreech17)
2023-10-17 16:10:29 <@humaton:fedora.im> will rcheck
2023-10-17 16:11:23 <@jnsamyak:matrix.org> this one: https://pagure.io/pungi-fedora/blob/f39/f/fedora-final.conf
2023-10-17 16:11:47 <@humaton:fedora.im> yup
2023-10-17 16:12:00 <@humaton:fedora.im> !releng 11385
2023-10-17 16:12:04 <@zodbot:fedora.im> releng #11385 (https://pagure.io/releng/issue/11385): Silverblue aarch64 installer image compose always fails on F38 and Rawhide
2023-10-17 16:12:51 <@nirik:matrix.scrye.com> oh yeah... this old one
2023-10-17 16:12:57 <@humaton:fedora.im> so
2023-10-17 16:13:06 <@humaton:fedora.im> I have a question about the runroot
2023-10-17 16:13:08 <@nirik:matrix.scrye.com> we were going to make a new image, but it wasn't working?
2023-10-17 16:13:19 <@humaton:fedora.im> I dont understand why this jjob never finishes https://koji.fedoraproject.org/koji/taskinfo?taskID=104586676
2023-10-17 16:13:41 <@humaton:fedora.im> I tried different composes and paths it just hangs there, what am I missing
2023-10-17 16:13:59 <@nirik:matrix.scrye.com> its in the wrong channel
2023-10-17 16:14:09 <@nirik:matrix.scrye.com> it has to be in the 'compose' channel
2023-10-17 16:14:30 <@humaton:fedora.im> w8 I think I did that as well
2023-10-17 16:14:47 <@nirik:matrix.scrye.com> try passing --channel-override=compose ?
2023-10-17 16:15:17 <@humaton:fedora.im> but it will be probably faster just to rerun it
2023-10-17 16:15:40 <@nirik:matrix.scrye.com> yeah. just try again with that and we can see
2023-10-17 16:17:08 <@humaton:fedora.im> opened PR for
2023-10-17 16:17:11 <@humaton:fedora.im> .releng 11680
2023-10-17 16:17:15 <@humaton:fedora.im> ah
2023-10-17 16:17:21 <@humaton:fedora.im> !releng 11680
2023-10-17 16:17:22 <@zodbot:fedora.im> releng #11680 (https://pagure.io/releng/issue/11680): EPEL9 not listed in MDAPI branches
2023-10-17 16:17:40 <@nirik:matrix.scrye.com> oh nice, I wasn't sure where that was...
2023-10-17 16:18:01 <@humaton:fedora.im> it took me a while but grep -R is my friend
2023-10-17 16:18:04 <@humaton:fedora.im> its in mdapi
2023-10-17 16:18:08 <@nirik:matrix.scrye.com> did we also want to add epel9-next?
2023-10-17 16:18:29 <@humaton:fedora.im> oh
2023-10-17 16:18:32 <@humaton:fedora.im> we should
2023-10-17 16:18:50 <@humaton:fedora.im> lets try this
2023-10-17 16:19:14 <@humaton:fedora.im> !action jednorozec to update mdapi PR with epel9-next
2023-10-17 16:19:40 <@humaton:fedora.im> boring name of the emoji
2023-10-17 16:21:54 <@humaton:fedora.im> .releng 11527
2023-10-17 16:22:05 <@humaton:fedora.im> I think this was fixed by me
2023-10-17 16:22:16 <@humaton:fedora.im> !releng 11527
2023-10-17 16:22:17 <@zodbot:fedora.im> releng #11527 (https://pagure.io/releng/issue/11527): Fix tokens for ftbfs_weekly_reminder. script
2023-10-17 16:22:32 <@humaton:fedora.im> its nice that the bot reacts on edits :)
2023-10-17 16:23:08 <@jnsamyak:matrix.org> :D
2023-10-17 16:24:15 <@nirik:matrix.scrye.com> yeah. propose closing.
2023-10-17 16:24:32 <@nirik:matrix.scrye.com> I do see the cron could use a adjustment tho.
2023-10-17 16:24:51 <@humaton:fedora.im> you mean the script? or?
2023-10-17 16:25:38 <@humaton:fedora.im> this is the script https://pagure.io/releng/blob/main/f/scripts/ftbfs_weekly_reminder.py
2023-10-17 16:25:44 <@nirik:matrix.scrye.com> it outputs on success: "Last login: Sun Oct 8 04:22:02 UTC 2023"
2023-10-17 16:26:13 <@nirik:matrix.scrye.com> which generates a useless cron email. ;)
2023-10-17 16:26:22 <@nirik:matrix.scrye.com> but its all working
2023-10-17 16:26:25 <@humaton:fedora.im> huh
2023-10-17 16:26:49 <@humaton:fedora.im> can you post the output in the ticket? I can take it and update the script
2023-10-17 16:26:54 <@nirik:matrix.scrye.com> sure.
2023-10-17 16:27:42 <@humaton:fedora.im> ok I see it now, there is actually no return code nothing it just runs and does the stuff
2023-10-17 16:27:42 <@nirik:matrix.scrye.com> done
2023-10-17 16:27:55 <@humaton:fedora.im> and prints strings :)
2023-10-17 16:28:09 <@nirik:matrix.scrye.com> that might be to stderr? not sure...
2023-10-17 16:29:26 <@humaton:fedora.im> the script that is.
2023-10-17 16:29:51 <@humaton:fedora.im> no more updates on my side
2023-10-17 16:29:54 <@nirik:matrix.scrye.com> ha
2023-10-17 16:30:09 <@nirik:matrix.scrye.com> I only had one thing to note:
2023-10-17 16:31:02 <@nirik:matrix.scrye.com> I've been working on new sigul verson in staging... slowly. Everything is almost working (a problem with head signing still remains).
2023-10-17 16:31:28 <@nirik:matrix.scrye.com> Soon we are getting new vault hardware and I will deploy this to the new hardware and we can look at moving over after f39 is all out the door
2023-10-17 16:32:19 <@nirik:matrix.scrye.com> There will be small adjustments for sop's... we will need to generate a signed cert for ima keys, but I can update that when the time comes.
2023-10-17 16:32:40 <@nirik:matrix.scrye.com> It should be... vastly faster than current sigul at signing large rpms.
2023-10-17 16:32:56 <@humaton:fedora.im> nice
2023-10-17 16:33:15 <@nirik:matrix.scrye.com> anyhow, just wanted to note all that.
2023-10-17 16:34:19 <@nirik:matrix.scrye.com> I don't know that I had anything else off hand today.
2023-10-17 16:34:39 <@humaton:fedora.im> Any updates/ questions/ discussion points from anybody?
2023-10-17 16:36:22 <@jnsamyak:matrix.org> ok sorry
2023-10-17 16:36:26 <@jnsamyak:matrix.org> just one quick thing
2023-10-17 16:36:47 <@jnsamyak:matrix.org> !releng 11607
2023-10-17 16:37:09 <@zodbot:fedora.im> releng #11607 (https://pagure.io/releng/issue/11607): [mass_branching] Create a "logical" checklist for mass branching
2023-10-17 16:37:40 <@jnsamyak:matrix.org> intial pr is up for this and might be a good if we can check for some stuff that i might have missed, it is an initial draft so there are some things to be added and beautified
2023-10-17 16:38:37 <@jnsamyak:matrix.org> but that's added in the pr like new signing key stuff, or how to handle new artifacts in the release cycle etc
2023-10-17 16:40:25 <@jnsamyak:matrix.org> thanks that's all from my end
2023-10-17 16:40:31 <@jnsamyak:matrix.org> :D
2023-10-17 16:45:36 <@humaton:fedora.im> So if there is nothing more to discuss I will leave you with one httpgoat
2023-10-17 16:45:36 <@humaton:fedora.im> https://httpgoats.com/444
2023-10-17 16:45:42 <@humaton:fedora.im> !endmeeting